Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 734477 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Fuguet

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #700 en: 27-03-2015, 14:57 (Viernes) »
Otra cosa reciente que me ha pasado, que no se si es por "exclusiva" de gargoyle o que... la frecuencia en que se cambiaba la IP pública... a cada 30 minutos, o 15 miutos, .... haciendo una corta pero dolorosa desconexión de todo.
Me pasaba al usar torrent en un synology, con una subida de unos 500KB configurado como máximo en upload (tengo 10Mb de subida) no paraba de ir perdiendo aceite por el camino, algunos pings perdidos (imagino que normal hasta cierto porcentage en la FTTH.. o no?  :-\ )
Miré como andaba la CPU del router, estaba OK.. la memoria a un 30%, descartado... hasta llegué a pensar que la ONT no toleraba tanto flujo de conexión, pero es el Alcatel Lucent... No obstante, cuando bajaba el upload a 100KB ya no pasaba...eso me indujo a poner el router de Movistar el Comtrend blanco.. Con la misma situación se perdían algunos pings pero no cambiaba IP..... eso me mosqueaba, como dice tmax, los muy ca.... lo exprimen bien...

Bueno al final vi un parámetro en mi configuración de la wan llamado keepalive, y via web sale por defecto
"Failed pings before reconnect" --> 3
"Ping Interval" --> 5
Como puede verse en esta imagen:
http://images.geekzone.co.nz/imagessubs/blog876d377b35f9f0caac48fccc66580949.jpg

Si me di cuenta, era por su descripción, y ver que daba resultado, lo puse en 50 y 10. Y ya esta... IP mantenida hasta "que la muerte la separe..."
Lo que mi duda ahora es... como va esto del keep alive? es decir hay un contador que si llega al numero de pings fallidos ya hace el proceso de reconexión? O bien tiene que ser numero de fallidos seguidos, o sino el contador vuelve a 0? No se si me explico... :S

Bueno, ahora mi pequeña preocupación, es si es normal estas perdidas " de vez en cuando" de pings al tener un upload de la mitad de tu conexión de upload... sobretodo al hacer un www.pingtest.net el resultado sale mediano con ese upload, sin embargo, a partir de unos 100 o 110 KB sale de rango "A"  >:D !



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2203
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #701 en: 27-03-2015, 17:06 (Viernes) »
Otra cosa reciente que me ha pasado, que no se si es por "exclusiva" de gargoyle o que... la frecuencia en que se cambiaba la IP pública... a cada 30 minutos, o 15 miutos, .... haciendo una corta pero dolorosa desconexión de todo.
Me pasaba al usar torrent en un synology, con una subida de unos 500KB configurado como máximo en upload (tengo 10Mb de subida) no paraba de ir perdiendo aceite por el camino, algunos pings perdidos (imagino que normal hasta cierto porcentage en la FTTH.. o no?  :-\ )
Miré como andaba la CPU del router, estaba OK.. la memoria a un 30%, descartado... hasta llegué a pensar que la ONT no toleraba tanto flujo de conexión, pero es el Alcatel Lucent... No obstante, cuando bajaba el upload a 100KB ya no pasaba...eso me indujo a poner el router de Movistar el Comtrend blanco.. Con la misma situación se perdían algunos pings pero no cambiaba IP..... eso me mosqueaba, como dice tmax, los muy ca.... lo exprimen bien...

Bueno al final vi un parámetro en mi configuración de la wan llamado keepalive, y via web sale por defecto
"Failed pings before reconnect" --> 3
"Ping Interval" --> 5
Como puede verse en esta imagen:
http://images.geekzone.co.nz/imagessubs/blog876d377b35f9f0caac48fccc66580949.jpg

Si me di cuenta, era por su descripción, y ver que daba resultado, lo puse en 50 y 10. Y ya esta... IP mantenida hasta "que la muerte la separe..."
Lo que mi duda ahora es... como va esto del keep alive? es decir hay un contador que si llega al numero de pings fallidos ya hace el proceso de reconexión? O bien tiene que ser numero de fallidos seguidos, o sino el contador vuelve a 0? No se si me explico... :S

Bueno, ahora mi pequeña preocupación, es si es normal estas perdidas " de vez en cuando" de pings al tener un upload de la mitad de tu conexión de upload... sobretodo al hacer un www.pingtest.net el resultado sale mediano con ese upload, sin embargo, a partir de unos 100 o 110 KB sale de rango "A"  >:D !

No sólo tienes que tener en cuenta la subida que le pongas, sino el sobreesfuerzo que hace en mantener todas las conexiones establecidas. Eso seguro que te consume más ancho de banda en subida, y sumado todo junto te lo colapsa.
Contrariamente a lo que se cree, la subida es el factor clave en las conexiones. Si la subida está al máximo, navegarás lentísimo, porque el ordenador no podrá mandar los datos necesarios para mantener la navegación, y en consecuencia, recibirá pocos datos en respuesta.
Yo probaría a bajar el número de conexiones y a subir la velocidad de subida, hasta hallar un equilibrio que permitiera una velocidad alta de subida, con un número razonable de conexiones establecidas.

Larteas

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #702 en: 28-03-2015, 12:23 (Sábado) »
 Muy buenas, lo primero enhorabuena por el tutorial, comentarte que soy informático aunque para nada experto en redes (pero amos, me muevo algo).

Pero chico, incapaz de que funcione el imagenio. Me lo han instalado hoy, ya tenia un router con openwrt (un WRT1043n v1) funcionando pero ni intentando con el script manual ni con el automático r18 lo consigo.

Os paso el fichero /etc/config/network a ver si ves algo raro, pero en mi caso no lo distingo:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd53:90f0:c28f::/48'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'switch0'
        option ports '0t 5t'
        option vlan '6'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ip6assign '60'
        option igmp_snooping '1'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'iptv'
        option ifname 'eth0.2'
        option proto 'static'
        option netmask '255.X.X.X'
        option gateway '10.X.X.X'
        option defaultroute '0'
        option peerdns '0'
        option ipaddr '10.X.X.X'

config interface 'wan'
        option ifname 'eth0.6'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'
        option ipv6 '1'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

config route                 
        option interface 'iptv'
        option target '172.26.0.0'
        option netmask '255.255.0.0'
        option gateway '10.X.X.X'

¿alguna idea de que puedo probar?

Gracias de antemano!

tmax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #703 en: 28-03-2015, 20:01 (Sábado) »
Creo que no has configurado las direcciones del IPTV, esta parte:

config interface 'iptv'
        option ifname 'eth0.2'
        option proto 'static'
->    option netmask '255.X.X.X'
->    option gateway '10.X.X.X'
        option defaultroute '0'
        option peerdns '0'
->    option ipaddr '10.X.X.X'
config route                 
        option interface 'iptv'
        option target '172.26.0.0'
        option netmask '255.255.0.0'
->    option gateway '10.X.X.X'

Parece que no has introducido esas direcciones al ejecutar el script

Larteas

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #704 en: 28-03-2015, 20:21 (Sábado) »
Gracias por el mensaje, puse las X para no poner las direcciones que saqué del backup del router original de movistar, pero al final lo he conseguido, justo ya volviéndome loco la cosa fue volver a ejecutar el script eligiendo el voip y magia borras ya funciona! :D

En fin, parecía más fácil de lo que fue, pero gracias al pedazo de curro del autor aqui estamos! :D

Por cierto, no tuve que parchear nada, me baje la build r42625 y como dije la tenía desde hace tiempo funcionando, con samba y todo listo.

Lo único que no he probado es lo del tema de ver imagenio por vlc, pero bueno, lo básico funciona y por PLC, sin cables por medio del salón :D

Fuguet

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #705 en: 28-03-2015, 22:06 (Sábado) »

No sólo tienes que tener en cuenta la subida que le pongas, sino el sobreesfuerzo que hace en mantener todas las conexiones establecidas. Eso seguro que te consume más ancho de banda en subida, y sumado todo junto te lo colapsa.
Contrariamente a lo que se cree, la subida es el factor clave en las conexiones. Si la subida está al máximo, navegarás lentísimo, porque el ordenador no podrá mandar los datos necesarios para mantener la navegación, y en consecuencia, recibirá pocos datos en respuesta.
Yo probaría a bajar el número de conexiones y a subir la velocidad de subida, hasta hallar un equilibrio que permitiera una velocidad alta de subida, con un número razonable de conexiones establecidas.

Gracias Tki2000;

Uso Download Station en el synlogy, si no me equivoco usa el mismo motor de transmission. Antes de configurar nada, acostumbro a usar la guia de parámetros del propio utorrent, lo que hago es ir al asistente y marcar 100Mb en el desplegable, donde sugiere:

Límite de subida: 10.9MB/s
Conexiones por torrent: 125
Torrents máximos activos: 25
Agujeros de subida: 50
Conexiones globales: 1000
Máximo de bajadas activas: 25

lo único que veo elevado como dices es la subida, que está al límite... (rectifico: esto es mucho mas que mi límite, el mio seria en 1MB/s, puesto que tengo 10Mb de subida.. creo que el asistente da por hecho que tanto bajada como subida es simétrica...)
(Segunda rectificación..: el asistente es solo para la subida, al cambiarlo de idioma el utorrent, la palabra subida no me aparecía.. de ahí mi confusión, vaya cosa mas ton.. y claro toda la configuración cambia por completo..   :-[
No obstante la cola de utorrent se queda en 15, y ese parámetro no lo puedo configurar de manera "amigable" en mi Download Station)
En Download Station, en la sección BitTorrent via interfaz gráfica web, tengo menos parámetros...

Y lo tengo así:
(ahora cambiado,edito valores)
Bajadas máximas activas: 25 15
Conexiones por torrent: 25 100
limite subida: 120 KB/s
Limite bajada: ilimitado
Red DHT habilitado

Y se acabó.. no me deja configurar nada más... por lo que estoy viendo , los ficheros que están activos són 41 30, de los cuales 18 15 están bajando y subiendo, y el resto (que están completados) subiendo, no se si es demasiado, según el asistente de utorrent, el límite de subidas está en 50 25, no se si el asistente de utorrent es un poco "agresivo" para los 100Mb...
Como ves la "escasa" configuración de Download Station, crees que debería de bajar las conexiones activas y elevar la subida?
Alguien con experiencia con su synology?

Gracias de nuevo!
« Última modificación: 28-03-2015, 23:31 (Sábado) por Fuguet »

500L

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #706 en: 29-03-2015, 16:17 (Domingo) »
Hola a todos! Es mi primer mensaje en el foro, aunque llevo mucho tiempo leyendo.
Me he registrado para dar las gracias a Noltari por su gran aporte sobre esto. Debido a que movistar nos va a subir la velocidad de 100/10  300/30, ayer decidí enterrar el Mikrotik, ya que su wifi es n y no aprovecharíamos en casa toda la velocidad. Ayer compré un Archer C5 (ya se que no es el mejor router que hay, pero por precio y prestaciones está muy bien).

Intentaré aclarar una cosa para que nadie se lie, ya que en el archer c5 con el OpenWRT Barrier Breaker 14.07 hay algunas cosas que me hicieron resetear el router a fábrica dos veces, debido a la configuración de las VLANs por la cual perdí conexión a la pata de gestión. Como podeis ver, en el archer c5, aparece un puerto 6, y la cpu, si no se configura bien, se pierde la conectividad. Esta es la configuración VLAN para el c5 con imagenio:



Respecto a la velocidad wired, no me da los 100-103 de bajada que me daba el Mikrotik y el Comtrend de movistar, y solo me da 83mbps. Esto es lo de menos, ya que estoy investigando en ello.
Tengo todo funcionando, incluso imagenio, pero hay un problema con la wifi. A ver si me podéis echar una mano, ya que por mucho que he modificado la config, la ac solo me da 6mbps máximo.
He instalado el reghack, y además he probado esto:

Código: [Seleccionar]
uci set wireless.radio0.htmode=VHT80
uci commit
wifi
Si activo esto, la 5ghz baja el rendimiento a 5mbps, dándome en los tests 4,8mbps de bajada máximo, y lo que es raro, es que me da 10mbps de subida (el tope de movistar que tengo ahora). Muy raro.
Se que luci no reporta bien la ac vía gestión web (además la reporta como N), pero es que es real lo que me está dando en los tests, no sale de ahí:



Si quito el htmode, la velocidad que me da en 5ghz es las misma que por n (30mbps). Cuando lo activo, el test me da como mucho 4,8mbps de bajada y 10 y pico de subida  ???
Esta es la config:



Alguna sugerencia?

Muchas gracias a todos y un saludo desde Barcelona!

500L

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #707 en: 29-03-2015, 21:52 (Domingo) »
Después de un rato trasteando, he visto que en el LG G3 me reporta una velocidad de 433mbps, cosa aceptable para mi, pero en el test de velocidad me sigue dando 4mbps de bajada y los 10mbps correctos de subida con movistar. Descargando otros archivos para hacer la prueba también va muy lento.  No entiendo nada... No tengo más dispositivos que este para hacer la prueba. Pero me extraña que la subida vaya perfecta y la bajada no. El ping bien...
Os pongo capturas.





Un saludo!
« Última modificación: 29-03-2015, 21:54 (Domingo) por 500L »

Fuguet

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #708 en: 30-03-2015, 01:14 (Lunes) »
Parece que la cosa ha mejorado activando el QoS en Upload al Gargoyle.
Le he puesto un par de clases, una al 1% con mínimo y máximo de ancho de banda establecidos, y otra al 99% sin límites establecidos.
una regla con la IP de Synology, que todo lo que no coincida en dicha regla, se vaya a la clase del 99% por defecto.

El curro ahora se lo lleva el router, y ya me despreocupo de fijar el máximo de subida en el cliente de Download Station (puede quedarse en 0)
Por ahora la estabilidad es buena..

A ver como lo va asimilando...

tmax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #709 en: 30-03-2015, 08:40 (Lunes) »
Después de un rato trasteando, he visto que en el LG G3 me reporta una velocidad de 433mbps, cosa aceptable para mi, pero en el test de velocidad me sigue dando 4mbps de bajada y los 10mbps correctos de subida con movistar. Descargando otros archivos para hacer la prueba también va muy lento.  No entiendo nada... No tengo más dispositivos que este para hacer la prueba. Pero me extraña que la subida vaya perfecta y la bajada no. El ping bien...
Os pongo capturas.





Un saludo!

Yo tengo ese mismo router (asegurate que la version de hardaware sea la v1.2). Le instale el firmware compilado por Noltari, el de esta url: http://files.noltari.es/openwrt/firmwares/ar71xx/TL-Archer-C5/ ejecute el script y funciono todo como la seda, y el wifi me da buenos ratios.

500L

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #710 en: 30-03-2015, 08:46 (Lunes) »
Gracias por tu respuesta!
Si, es el hardware 1.20. Me lo baje de la web oficial de openwrt, la que corresponde al archer c5 factory.
Un saludo.

Edito: He comparado los dos bin (el de noltari y el oficial de openwrt) y son distintos. Parece que la versión de Noltari es mas nueva). Probaré de bajarme el sysupgrade sin tocar la config que tengo a ver si chuta bien y sino le haré un reset y empezaré de 0 con la factory.
« Última modificación: 30-03-2015, 11:37 (Lunes) por 500L »

tmax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #711 en: 30-03-2015, 15:04 (Lunes) »
La de Noltari lleva ya todos los paquetes instalados

500L

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #712 en: 30-03-2015, 15:08 (Lunes) »
Hola, gracias a todos.
El problema de la 5ghz estaba en que yo siempre desactivo el WMM y he probado con el activado y ya me ha dado 96mbps de bajada.
El chaos calmer es mas nuevo que el barrier breaker, no?

tmax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #713 en: 30-03-2015, 19:16 (Lunes) »
Asi es, enhorabuena

tmax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #714 en: 30-03-2015, 20:43 (Lunes) »
El unico "pero" que le pongo al openwrt es que el igmp snooping no tiene efecto sobre el chip que hace de switch, solo en el propio wifi del router. Una lastima. Este es el post en el que se habla de ello:

https://foro.seguridadwireless.net/openwrt/igmp-snooping-no-funciona/

500L

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #715 en: 31-03-2015, 12:38 (Martes) »
Igual con el ddwrt si que funciona. Esta tarde lo probaré, no es difícil de configurar a mano movistar.
Un saludo!

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #716 en: 31-03-2015, 15:24 (Martes) »
Muy buenas!

En primer lugar, quisiera agradecer a Noltari el estupendo trabajo realizado. Compré un TP-Link TD4300 hace unos meses, después de leer este hilo, y me costó cinco minutos tener la conexión lista. Enhorabuena.

Y en segundo lugar, quisiera aportar mis modestas experiencias al hilo:

* IPv6
 - A pesar de que el script está preparado para usar IPv6, Movistar aún no ha configurado toda su red; depurando la conexión he visto que el servidor de PPPoE explícitamente rechaza usar IPv6.
- Si a alguien le interesa el tema, Hurricane Electric (https://www.tunnelbroker.net/) ofrece túneles IPv6 gratuitos, que con OpenWrt se configuran en minutos.

* VOIP:
 - Conseguí instalar y hacer funcionar Asterisk en el router; ahora lo uso como servidor de VOIP, puedo conectar varios terminales, hacer y recibir llamadas (suenan todos los terminales, puesto que para el servidor de VOIP de Movistar sólo hay un dispositivo conectado), y obviamente también hablar entre terminales.
 - Además, con esta configuración no es necesario permitir tráfico entre la LAN y la red VOIP de Movistar.
 - Para poder usar la VOIP desde fuera tengo un servidor de VPN en el propio router; así puedo conectarme desde el móvil y hacer / recibir llamadas con la línea del fijo, aunque esté fuera de casa.

Si a alguien le interesa algo de lo que comento más arriba y necesita ayuda, que lo comente.

thunderman

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #717 en: 31-03-2015, 16:42 (Martes) »
Madremia Noltari, menudo curro te has pegado!!! Es increible >:(

Yo hoy he comprado un C5 para ver si puedo mandar al carajo al Comtrend-5813n que menuda castaña xD

Ya os contare que tal se queda todo!

PD: Si hubiera que tramitar garantía del router se puede volver al firm original no?
« Última modificación: 31-03-2015, 16:44 (Martes) por thunderman »

ianjohnmadrid

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #718 en: 31-03-2015, 20:26 (Martes) »
Hola Noltari / todos,

Yo tengo un problema con el ultimo firmware aquí (r44597 5/3/2015 - http://files.noltari.es/openwrt/firmwares/brcm63xx/CT-WAP-5813n/  ), no arranca el router (Comtrend 5813). He conseguido tener internet, TV (pero sin VOD) con un firmware "openwrt-WAP-5813n-squashfs-cfe-smp-39167-20131227 (11n)" - como ves, este firmware es muy viejo y no soporte VOD, pero el internet y la TV funcionan  ???

No quiero repetitr el mensaje que he puesto en otro hilo pero creo que es el mejor aquí porque el problema es VOD / Grabaciones (falta el package kmod-ipt-nathelper-rtsp)

https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-5813n/msg328479/#msg328479

¿Alguien tiene el firmware anterior de r44597 por ejemplo?

¿Alguien tiene un link para bajar otro firmware de Noltari?

Gracias y un saludo

« Última modificación: 31-03-2015, 20:27 (Martes) por ianjohnmadrid »

victormurgar

  • Visitante
Re:
« Respuesta #719 en: 31-03-2015, 20:33 (Martes) »
Hay una forma de que te funcione el VOD con ese firmware: En LUCI vete a firewall y vete a la pestaña de reglas propias (la última pestaña de la derecha)  y añade esto :
iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 1
IPDETUIPTV -j DNAT --to-destination IPDETUDECODIFICADOR
Y reinicias el router y ya verás como funciona.