Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 702754 veces)

0 Usuarios y 3 Visitantes están viendo este tema.

ianjohnmadrid

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #720 en: 31-03-2015, 20:51 (Martes) »
Gracias Victor,

Gracias por la repuesta.

Acabo de entrar en el router y en Firewall - Custom Rules (La ultima pestaña), he añadido los cambios y reinicio el router (apagar y encender).

Pero no me funciona, bueno no he probado exactamente VOD, he probado MOVISTAR SERIES (que tengo una suscripción) y también las grabaciones) y no me funcionan.

El router estaba configurado por el script Movistar R18 y veo 172.26.0.0 y tus cambios.

¿Eso es correcto?

Por ejemplo mi red está configurado asi.

Lan
192.168.1.1/24

Pongo un copy paste de los contenidos que ya tengo en Custom Rules.

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 1
IPDETUIPTV -j DNAT --to-destination IPDETUDECODIFICADOR



Fuguet

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #721 en: 31-03-2015, 21:17 (Martes) »
Hay otro problema que no sé si afecta a todos, o va llegando como si de una actualización de smartphone se tratase... Yo lo he tenido y por la comunidad de Movistar se comenta bastante.

parece que la ruta de VOIP ahora no se importa por bird4, (antes me funcionaba y no toqué nada de esto...) He tenido que ponerla de manera estática.
El proxy/registrar para configurarlo en el software PhonerLite (por nombar uno) es el 10.31.255.134, y Bird4 no la importa, no se si han quitado la opción RIP movistar...

inserté la ruta en /etc/config/network para que llegue a la red del outbound proxy:

Código: [Seleccionar]
config route
        option interface 'voip'
        option target '10.31.255.128'
        option netmask '255.255.255.224'
        option gateway 'tu_gateway_de_voip'

lo único que hace falta averiguar es el gateway de cada uno, que no es el mismo para todos... (o se saca por la config de backup del comtrend, o calculandolo por su máscara, siempre siendo la primera del rango)

Ha tenido que hacer alguien este cambio?
Si esto es así, entonces podemos quitar el bird4, puesto a que ya no es necesario, no?

Gracias a todos

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #722 en: 31-03-2015, 23:46 (Martes) »
Hay otro problema que no sé si afecta a todos, o va llegando como si de una actualización de smartphone se tratase... Yo lo he tenido y por la comunidad de Movistar se comenta bastante.

parece que la ruta de VOIP ahora no se importa por bird4, (antes me funcionaba y no toqué nada de esto...) He tenido que ponerla de manera estática.
El proxy/registrar para configurarlo en el software PhonerLite (por nombar uno) es el 10.31.255.134, y Bird4 no la importa, no se si han quitado la opción RIP movistar...

inserté la ruta en /etc/config/network para que llegue a la red del outbound proxy:

Código: [Seleccionar]
config route
        option interface 'voip'
        option target '10.31.255.128'
        option netmask '255.255.255.224'
        option gateway 'tu_gateway_de_voip'

lo único que hace falta averiguar es el gateway de cada uno, que no es el mismo para todos... (o se saca por la config de backup del comtrend, o calculandolo por su máscara, siempre siendo la primera del rango)

Ha tenido que hacer alguien este cambio?
Si esto es así, entonces podemos quitar el bird4, puesto a que ya no es necesario, no?

Gracias a todos

De momento, con la configuración original (usando bird4) me sigue funcionando (automáticamente aparece la red que comentas); pero gracias por el aviso.

Fuguet

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #723 en: 01-04-2015, 00:15 (Miércoles) »
De momento, con la configuración original (usando bird4) me sigue funcionando (automáticamente aparece la red que comentas); pero gracias por el aviso.
Gracias a ti eduperez, ahora ya se que no es a todos por igual y a la vez..

Estas son mis rutas en Gargoyle:


Y esta es mi configuración de la network (incluyo banner para que veáis versión/compilación exacta):
Código: [Seleccionar]

------------------------------------------------------------------
|            _____                             _                 |
|           |  __ \                           | |                |
|           | |  \/ __ _ _ __ __ _  ___  _   _| | ___            |
|           | | __ / _` | '__/ _` |/ _ \| | | | |/ _ \           |
|           | |_\ \ (_| | | | (_| | (_) | |_| | |  __/           |
|            \____/\__,_|_|  \__, |\___/ \__, |_|\___|           |
|                             __/ |       __/ |                  |
|                            |___/       |___/                   |
|                                                                |
|----------------------------------------------------------------|
| Gargoyle version 1.6.2    | OpenWrt Attitude Adjustment branch |
| Gargoyle revision b70bfc1 | OpenWrt revision r42171            |
| Built August 26, 2014     | Target  ar71xx/usb_large           |
------------------------------------------------------------------

root@Gargoyle:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option dns '192.168.1.1'

config interface 'wan'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'
        option mtu '1492'
        option ifname 'eth0.6'
        option keepalive '50 10'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0t 1 4 5'

config switch_vlan
        option device 'eth0'
        option vlan '2'
        option ports '0t 2t'
        option vid '6'

config switch_vlan
        option device 'eth0'
        option vlan '3'
        option ports '0t 2t'
        option vid '2'

config switch_vlan
        option device 'eth0'
        option vlan '4'
        option ports '0t 2t'
        option vid '3'

config switch_vlan
        option device 'eth0'
        option vlan '5'
        option ports '0t 3'
        option vid '4'

config interface 'iptv'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '10.X.Y.Z'
        option netmask '255.128.0.0'
        option gateway '10.X.Y.Z'
        option defaultroute '0'
        option peerdns '0'

config interface 'voip'
        option ifname 'eth0.3'
        option proto 'dhcp'
        option defaultroute '0'
        option peerdns '0'

config interface 'tvlan'
        option ifname 'eth0.4'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

config route
        option interface 'iptv'
        option target '172.26.0.0'
        option netmask '255.255.0.0'
        option gateway '10.X.Y.Z'

config route
        option interface 'voip'
        option target '10.31.255.128'
        option netmask '255.255.255.224'
        option gateway 'W.X.Y.Z'

y aquí mi bird4:

Código: [Seleccionar]
root@Gargoyle:~# cat /etc/bird4.conf

# THIS CONFIG FILE IS NOT A COMPLETE DOCUMENTATION
# PLEASE LOOK IN THE BIRD DOCUMENTATION FOR MORE INFO

# However, most of options used here are just for example
# and will be removed in real-life configs.

log syslog all;
router id 192.168.1.1;

protocol kernel {

        persist;                # Don't remove routes on bird shutdown
        scan time 20;           # Scan kernel routing table every 20 seconds
        import all;             # Default is import all
        export all;             # Default is export none
}

# This pseudo-protocol watches all interface up/down events.
protocol device {
        scan time 10;           # Scan interfaces every 10 seconds
}

protocol static {
        export none;            # Default is export none

}

filter voip_filter {
if net ~ 10.0.0.0/8 then accept;
else reject;
}
protocol rip voip {
import all;
export filter voip_filter;
interface "eth0.3";
}

filter iptv_filter {
if net ~ 172.26.0.0/16 then accept;
else reject;
}
protocol rip iptv {
import all;
export filter iptv_filter;
interface "eth0.2";
}

Alguien ve algo raro?

Muchas gracias señores!

Edito y Añado: y Para mas inri, pongo mi fichero de firewall:

Código: [Seleccionar]
root@Gargoyle:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option network 'lan'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'
        option reload '1'

config include
        option type 'script'
        option path '/usr/lib/gargoyle_firewall_util/gargoyle_additions.firewall'
        option family 'IPv4'
        option reload '1'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'IPv4'
        option reload '1'

config include 'openvpn_include_file'
        option path '/etc/openvpn.firewall'
        option reload '1'

config include 'tor_include_file'
        option path '/etc/tor.firewall'
        option reload '1'

config zone
        option name 'iptv'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option network 'iptv'
        option masq '1'

config zone
        option name 'voip'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option network 'voip'
        option masq '1'

config forwarding
        option src 'lan'
        option dest 'voip'

config zone
        option name 'tvlan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option network 'tvlan'

config forwarding
        option src 'tvlan'
        option dest 'iptv'

config forwarding
        option src 'iptv'
        option dest 'tvlan'

« Última modificación: 01-04-2015, 00:46 (Miércoles) por Fuguet »

victormurgar

  • Visitante
Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #724 en: 01-04-2015, 01:16 (Miércoles) »
Gracias Victor,

Gracias por la repuesta.

Acabo de entrar en el router y en Firewall - Custom Rules (La ultima pestaña), he añadido los cambios y reinicio el router (apagar y encender).

Pero no me funciona, bueno no he probado exactamente VOD, he probado MOVISTAR SERIES (que tengo una suscripción) y también las grabaciones) y no me funcionan.

El router estaba configurado por el script Movistar R18 y veo 172.26.0.0 y tus cambios.

¿Eso es correcto?

Por ejemplo mi red está configurado asi.

Lan
192.168.1.1/24

Pongo un copy paste de los contenidos que ya tengo en Custom Rules.

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 1
IPDETUIPTV -j DNAT --to-destination IPDETUDECODIFICADOR
Pero tienes que añadir los datos que pone en la regla.

ianjohnmadrid

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #725 en: 01-04-2015, 07:56 (Miércoles) »
ah, tenia que leer mejor :-)  >:(

entonces,me puedes confirmar

iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 1
IPDETUIPTV -j DNAT --to-destination IPDETUDECODIFICADOR

¿Hay 4 parameters tengo que cambiar? IPDETUIPTV, IPDETUDECODIFICADOR, PREROUTING, DNAT ??

IPDETUIPTV = esto es la ip empieza asi 10.184.x.x se llama IPTV en el router
IPDETUDECODIFICADOR = de momento creo que la ip de los decodificadores son de DHCP pero puedo cambiar a estáticos, Tengo 2 descodificadores (MULTI ROOM)
PREROUTING = ???? o A PREROUTING ???   -A es un parameter ??
DNAT = ???

Perdona, soy novato en configurar este tipo de información.

Gracias

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #726 en: 01-04-2015, 11:05 (Miércoles) »
Alguien ve algo raro?

Yo lo veo todo prácticamente igual que la configuración que yo tengo... si además te ha dejado de funcionar, será que realmente están cambiando algo.

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #727 en: 01-04-2015, 11:07 (Miércoles) »
ah, tenia que leer mejor :-)  >:(

entonces,me puedes confirmar

iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 1
IPDETUIPTV -j DNAT --to-destination IPDETUDECODIFICADOR

¿Hay 4 parameters tengo que cambiar? IPDETUIPTV, IPDETUDECODIFICADOR, PREROUTING, DNAT ??

IPDETUIPTV = esto es la ip empieza asi 10.184.x.x se llama IPTV en el router
IPDETUDECODIFICADOR = de momento creo que la ip de los decodificadores son de DHCP pero puedo cambiar a estáticos, Tengo 2 descodificadores (MULTI ROOM)
PREROUTING = ???? o A PREROUTING ???   -A es un parameter ??
DNAT = ???

Perdona, soy novato en configurar este tipo de información.

Gracias


Sólo tienes 2 parámetros a modificar: IPDETUIPTV y IPDECODIFICADOR, lo demás son palabras clave que debes escribir tal cual.

victormurgar

  • Visitante
Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #728 en: 01-04-2015, 11:10 (Miércoles) »
ah, tenia que leer mejor :-)  >:(

entonces,me puedes confirmar

iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 1
IPDETUIPTV -j DNAT --to-destination IPDETUDECODIFICADOR

¿Hay 4 parameters tengo que cambiar? IPDETUIPTV, IPDETUDECODIFICADOR, PREROUTING, DNAT ??

IPDETUIPTV = esto es la ip empieza asi 10.184.x.x se llama IPTV en el router
IPDETUDECODIFICADOR = de momento creo que la ip de los decodificadores son de DHCP pero puedo cambiar a estáticos, Tengo 2 descodificadores (MULTI ROOM)
PREROUTING = ???? o A PREROUTING ???   -A es un parameter ??
DNAT = ???

Perdona, soy novato en configurar este tipo de información.

Gracias


Sólo tienes 2 parámetros a modificar: IPDETUIPTV y IPDECODIFICADOR, lo demás son palabras clave que debes escribir tal cual.
Exacto. Si tienes 2 decodificadores tendrás que ponerla 2 veces. Si están los dos en DHCP simplemente pon la IP de cada uno. Yo lo tengo en DHCP y me funciona.

500L

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #729 en: 01-04-2015, 13:40 (Miércoles) »
Hola,

Ayer estuve trasteando con el ddwrt y la verdad es que llegué a un punto en que me quedé clavado. A diferencia del Openwrt, en el Archer C5, solo detecta los puertos:
ath0(2,4ghz), ath1(5ghz), eth0(wan) y eth1(lan).
Me dije: !!!¿¿¿Donde demonios están los eth 2,3 y4????!!!
Todo funcionaba bien, tenía internet, asignada VLAN 6 prioridad 1 a eth0, y a su vez asignado eth0.6 como WAN, pero cuando configuré la VLAN 2, taggeando eth0 y eth1 para imagenio todo se torció. Me fijé que cuando conectaba algún dispositivo que no fuera mi PC, a cualquier puerto LAN, no se encencía el LED.
Borré la VLAN 2 y dejé todo para tener internet y que nada, ni reiniciando el router. Si conecto una impresora a los puertos 1,2,3,4, no se enciende el LED, pero si conecto mi PC si.
Es normal que solo detecte eth1 (puerto LAN)?
Ya se que el post es para el Openwrt, pero alguien me puede aclarar esto, por favor?
De todas formas ya volví a openwrt, pero me interesaría saber porqué pasa esto. Además estoy interesado en asignar solo la IPTV al puerto 4 del archer c5. Con deshacer el tagging VID 2 en los puertos 1,2 y 3 es suficiente?

Un saludo!

500L

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #730 en: 01-04-2015, 15:29 (Miércoles) »
Se me había olvidado comentar, que hay un usuario en el foro de openwrt que está compilando nuevas versiones del CC para varios routers, entre ellos el mío (Archer C5) y al actualizar deja de funcionar la wan. Supongo que el motivo es que el nuevo firm no incluye el paquete de movistar. Si cojo todos los archivos del paquete de movistar de la build de Noltari y los copio a la nueva build funcionaría?
El motivo de querer actualizar es porque no me deja instalar el openvpn-openssl por causa del kernel. El paquete luci-app-openvpn tampoco funciona.
Un saludo y perdonar por la vara que os doy :(

Fuguet

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #731 en: 01-04-2015, 18:57 (Miércoles) »
Se me había olvidado comentar, que hay un usuario en el foro de openwrt que está compilando nuevas versiones del CC para varios routers, entre ellos el mío (Archer C5) y al actualizar deja de funcionar la wan. Supongo que el motivo es que el nuevo firm no incluye el paquete de movistar. Si cojo todos los archivos del paquete de movistar de la build de Noltari y los copio a la nueva build funcionaría?
El motivo de querer actualizar es porque no me deja instalar el openvpn-openssl por causa del kernel. El paquete luci-app-openvpn tampoco funciona.
Un saludo y perdonar por la vara que os doy :(
No te preocupes 500L, aquí todos somos uno, estamos para echarnos los cables y las ondas que hagan falta ;)

Yo, en mi caso, no lo tuve nada fácil ni tampoco fue trivial, pero si te lo propones lo sacarás.

Nunca he creado builds, solo me centré en la imagen original de Gargoyle, y hasta lo actualicé a la versión última stable, que por cierto... veo que ahora en la experimental se incluye tu archer C5! Lo digo porque ya te vendrá con el openvpn y tal, que me dices compi, porque no le das un vistazo ? :) Seguro que te gustará, es muy apreciado por su fantástico QoS y por su visor de monitorización de ancho de banda, y como no..., la gestión de quotas,...
Te tendrás que pelear un poquitín para tener todo lo necesario para movistar FTTH (usa los propios repositorios que te vienen con la build, si no esta mcproxy pues se usa igmpproxy, udpxy puede que sea una versión distinta, pero de funcionar funciona...), pero es algo que ganarás, no pierdes nada

Un saludo!

atomizasser

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #732 en: 01-04-2015, 20:27 (Miércoles) »
Hola.

Gracias a este script pude poner mosvitar fibra en mi archer c5 con openwrt.
Con el router de telefonica /un amper) podia configurar mi android para recibir llamadas VOIP por wifi, pero ahora siguiendo los mismo pasos no conecta nunca. alguien puede poner un pequeño tutorial de como hacerlo?

Gracias,

500L

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #733 en: 01-04-2015, 21:22 (Miércoles) »
Se me había olvidado comentar, que hay un usuario en el foro de openwrt que está compilando nuevas versiones del CC para varios routers, entre ellos el mío (Archer C5) y al actualizar deja de funcionar la wan. Supongo que el motivo es que el nuevo firm no incluye el paquete de movistar. Si cojo todos los archivos del paquete de movistar de la build de Noltari y los copio a la nueva build funcionaría?
El motivo de querer actualizar es porque no me deja instalar el openvpn-openssl por causa del kernel. El paquete luci-app-openvpn tampoco funciona.
Un saludo y perdonar por la vara que os doy :(
No te preocupes 500L, aquí todos somos uno, estamos para echarnos los cables y las ondas que hagan falta ;)

Yo, en mi caso, no lo tuve nada fácil ni tampoco fue trivial, pero si te lo propones lo sacarás.

Nunca he creado builds, solo me centré en la imagen original de Gargoyle, y hasta lo actualicé a la versión última stable, que por cierto... veo que ahora en la experimental se incluye tu archer C5! Lo digo porque ya te vendrá con el openvpn y tal, que me dices compi, porque no le das un vistazo ? :) Seguro que te gustará, es muy apreciado por su fantástico QoS y por su visor de monitorización de ancho de banda, y como no..., la gestión de quotas,...
Te tendrás que pelear un poquitín para tener todo lo necesario para movistar FTTH (usa los propios repositorios que te vienen con la build, si no esta mcproxy pues se usa igmpproxy, udpxy puede que sea una versión distinta, pero de funcionar funciona...), pero es algo que ganarás, no pierdes nada

Un saludo!


Gracias por tus comentarios :)
El Gargoyle lo estuve mirando, la verdad es que sin profundizar. Esperaré un poco a que el src no esté en alpha para el archer y a ver que hago jejeje.
Sobre compilar, pues no soy manco en linux pero antes tengo que entender bien el sistema openwrt.
De momento usaré ya compilado y añadiré mis retoques.
Ya tengo el openwrt cc 45179 funcionando sin problemas (menos el kmod-bridge y el nathelper), que gracias a un tal mk ya incluye el openvpn con ssl y configurable vía luci, servidor de impresión, upnp, ddns, etc. Lo del openvpn por luci es importante, ya que vía ssh no tengo problemas, pero si la parienta que no sabe de estas cosas jejeje. Así que cuanto más le pueda habilitar por ui mejor...
En casa me van a capar con tanto reset XD

Un saludo!
« Última modificación: 01-04-2015, 21:24 (Miércoles) por 500L »

ianjohnmadrid

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #734 en: 02-04-2015, 10:39 (Jueves) »
Ok, buenas noticias, ya tengo VOD/Movistar Series/Grabaciones funcionando pero solo en 1 TV - Tengo multi room, y solo funciona con la primera TV.

Gracias a todos para la ayuda. ¿ Alguien sabe como conseguir multi room (2 tv con VOD/grabaciones/movistar series) ? Pongo más información en otro mensaje pero aquí pongo la solución que tengo para funcionar una TV ( no multiroom)

Debaja de firewall, la ultima pestaña (CUSTOM RULES) en LUCI pon esta linea

iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d TUIPDETUIPTV -j DNAT --to-destination IPDETUDESCODIFICADOR

solo hay que cambiar TUIPDETUIPTV para la ip de la TV, mio empieza con 10.184..... y IPDETUDESCODIFICADOR a la ip de tu equipo (hay que cambiar de DHCP a estático). Yo he puesto una ip estática de 192.168.1.10

Antes yo tenia un poco mal la linea, cuando he puesto bien tampoco funciona.

Después de meter la linea en el router hay que reiniciar el router - pero espera si quieres porque hay que hacer más cositas  >:(

hay que hacer telnet o SSH a tu ip de router y ejecutar el siguiente

opkg update
opkg install kmod-ipt-nathelper-rtsp

pero tampoco va a funcionar con mi firmware porque hay una dependencia en otra version de kernel, dice que hay un error con dependencias. Entonces ahora hay que añadir --force-depends

opkg update
opkg install kmod-ipt-nathelper-rtsp --force-depends

AHORA reiniciar el router, y prueba VOD, Movistar Series y grabaciones - todo funciona.

Recuerda, esto solo es para 1 TV.

multi room, no tengo ni idea que está pasando ...

Ahora voy a explicar más en otro mensaje.

Espero que te ayude alguien.

ianjohnmadrid

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #735 en: 02-04-2015, 10:49 (Jueves) »
Problema con multiroom y VOD/Grabaciones/Movistar Series.

Tengo 2 x TV, he puesto la ip 192.168.1.10 en una TV Y 192.168.1.11 en la otra.

Ahora tengo esta linea,metido en CUSTOM RULES en FIREWALL
(donde 10.184.x.x es mi ip de mi tv)

iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 10.184.x.x -j DNAT --to-destination 192.168.1.10

y funciona VOD en la TV con la ip 192.168.1.10

si cambio la linea a la ip 192.168.1.11

iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 10.184.x.x -j DNAT --to-destination 192.168.1.11

y dejar funcionar 192.168.1.10 y funciona 192.168.1.11.

Perfecto, los 2 funcionan pero no a la vez.

Entonces he intentado poner muchas cosas y no puedo conseguir que las 2 TV funcionan con VOD a la vez.

He intentado

iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 10.184.x.x -j DNAT --to-destination 192.168.1.10
iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 10.184.x.x -j DNAT --to-destination 192.168.1.11

No funciona, solo funciona la primera TV

He intentado

iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 10.184.x.x -j DNAT --to-destination 192.168.1.10  --to-destination 192.168.1.11

No funciona

iptables -t nat -A PREROUTING -s 172.26.0.0/16 -p udp -d 10.184.x.x -j DNAT --to-destination 192.168.1.10 192.168.1.11

No funciona

Alguien puedo ayudar, estoy perdido.

Un cosa interesante es en R16 de movstar script de Notari puedes encontrar la linea iptables pero en los scripts >16 como 17,18 no vas a encontrar.


Nissan003

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #736 en: 02-04-2015, 12:05 (Jueves) »
Hola a todos, perdonar mi ignorancia pero he estado leyendo un monton de post y no me queda bien claro el tema; el caso es que quiero comprar el wr1043nd v2.1 e instalat openwrt para fibra mvositar e imagenio, leyendo el primer post veo que es necesario instalar una serie de paquetes para que todo funcione correctamente, aqui van las pregusntas (gracias por anticipado)

- con la factory.bin (openwrt-ar71xx-generic-tl-wr1043nd-v2-squashfs-factory_r44597.bin) vienen todos los paquetes necesarios? es mejor esta o la anterior (openwrt-ar71xx-generic-tl-wr1043nd-v2-squashfs-factory_r43179.bin)? Imagino, que vendra con la interface de configuración Luci?

- una vez instalado el firmware(paso anterior) hay que ejecutar el movistar.sh del primer post, contestando a las preguntas sobre la red de imagenio, es así?

- he visto que a algunos haciendo esto no les funciona, hay que configurar algo más? es problema del firmware? es que he visto que algunos han tenido que compilar otra vez el firmware.

-Yo tengo 100/10 Mb, el wr1043nd soportará  la ampliación de velocidad que se rumorea que hará Telefónica?

Un saludo y gracias de antemano.
« Última modificación: 02-04-2015, 12:10 (Jueves) por Nissan003 »

thunderman

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #737 en: 02-04-2015, 19:22 (Jueves) »
Buenas gente!

Al final he conseguido instalarlo todo y se ha quedado bastante bien a mi parecer.

Lo unico que me comentan que la TV, ya que yo no la veo, que va bastante mas lenta a la hora de hacer cambio de canal o realizar busquedas en el deco.

Os escribo el log de la configuracion introducida por si os ocurre algo que pueda hacer para mejorar esto ya que si no tendre que retirar el router y volver al odioso 5813.

Código: [Seleccionar]
system type : Qualcomm Atheros QCA9558 ver 1 rev 0
machine : TP-LINK Archer C5
processor : 0
cpu model : MIPS 74Kc V5.0
BogoMIPS : 358.80
wait instruction : yes
microsecond timers : yes
tlb_entries : 32
extra interrupt vector : yes
hardware watchpoint : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa : mips1 mips2 mips32r1 mips32r2
ASEs implemented : mips16 dsp dsp2
shadow register sets : 1
kscratch registers : 0
package : 0
core : 0
VCED exceptions : not available
VCEI exceptions : not available

Movistar FTTH Configuration Script r18
OpenWrt Chaos Calmer r44597 (ar71xx/generic)
Alvaro Fernandez Rojas (noltari@gmail.com)
---
Router identified: TP-Link Archer C5 (archer-c5)
---
Customize LAN Network? (def 192.168.1.1/24) (y/n)
y
LAN IP Address (e.g 192.168.1.1)
192.168.1.1
LAN Netmask (e.g 255.255.255.0)
255.255.255.0
---
Enable VOIP? (y/n)
y
Enable IPTV? (y/n)
y
WAN + VOIP + IPTV
---
IPTV IP Address (e.g 172.26.0.2/10.128.0.2)
10.107.171.80
IPTV Netmask (e.g. 255.255.240.0/255.128.0.0)
255.192.0.0
IPTV Gateway (e.g. 172.26.208.1/10.128.0.1)
10.64.0.1
nf_conntrack_rtsp module detected
Enable DHCP for IPTV decoders? (y/n)
y
Configure udpxy? (y/n)
y
Enter udpxy port (def 4022)
4022
Allow access to udpxy from WAN? (y/n)
n
---
Network config erased
cfg043777
cfg051ec7
cfg061ec7
cfg071ec7
cfg081ec7
cfg0ec8b4
Network config loaded
Network config applied
uci: Entry not found
uci: Entry not found
cfg16dc81
cfg17dc81
cfg18ad58
cfg19dc81
cfg1aad58
cfg1bad58
cfg1cdc81
cfg1dad58

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'

config forwarding
option src 'lan'
option dest 'wan'

config zone
option name 'iptv'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option network 'iptv'
option masq '1'

config forwarding
option src 'lan'
option dest 'iptv'

config forwarding
option src 'iptv'
option dest 'lan'

config zone
option name 'voip'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option network 'voip'
option masq '1'

config forwarding
option src 'lan'
option dest 'voip'

Firewall config saved
bird4 config applied
bird4 enabled
mcproxy config applied
mcproxy enabled
DNS rebind protection disabled
udpxy config applied
udpxy enabled
uci: Entry not found
uci: Entry not found
IPTV DHCP server config applied
---
Configuration done!
Make log persistent? (y/n)
y

Tambien me he dado cuenta que cuando hago algun cambio en la configuracion Wifi la señal de la TV se resiente aunque esto lo considero medio normal.

Muchas gracias de antemano!

500L

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #738 en: 02-04-2015, 19:53 (Jueves) »
A mi el cambio de canal me va mucho más rápido que usando el comtrend de movistar. Es lo primero que noté. Vamos, es una delicia y sin cortes!

thunderman

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #739 en: 02-04-2015, 20:58 (Jueves) »
Entonces he tenido que hacer algo mal :(