Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 716133 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado eduperez

  • **
  • Mensajes: 42
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1320 en: 17-10-2020, 18:22 (Sábado) »
Hola a todos. Saludos desde Argentina.. Tengo un router con Oprnwrt 19.07.4 X86. Aca las configuraciones son parecidas pero las Vlans son 10 pppoe, 11 IPTV y 12 VOIP. el problema que tengo es que el IP en la Vlan 11 IPTV es asignada por DHCP y no consigo obtener una direccion (el servidor no me asigna) Tengo configurado todo a mano porque el script no lo puedo correr (no tengo switch por ser una version x86. Lo que creo que me esta dando problemas es la configuracion de BIRD. Les agradeceria si me pueden dar una mano. Gracias!

Copia aquí el fichero de configuración "/etc/config/network" para que podamos echarle un vistazo.



Desconectado BillieJoe

  • **
  • Mensajes: 5
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1321 en: 18-10-2020, 23:22 (Domingo) »
Hola a todos. Saludos desde Argentina.. Tengo un router con Oprnwrt 19.07.4 X86. Aca las configuraciones son parecidas pero las Vlans son 10 pppoe, 11 IPTV y 12 VOIP. el problema que tengo es que el IP en la Vlan 11 IPTV es asignada por DHCP y no consigo obtener una direccion (el servidor no me asigna) Tengo configurado todo a mano porque el script no lo puedo correr (no tengo switch por ser una version x86. Lo que creo que me esta dando problemas es la configuracion de BIRD. Les agradeceria si me pueden dar una mano. Gracias!

Copia aquí el fichero de configuración "/etc/config/network" para que podamos echarle un vistazo.

Perdon por la tardanza. estuve sin conexion

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd3:6bf1:4733::/48'

config interface 'LAN'
        option ifname 'eth0'
        option netmask '255.255.255.0'
        option proto 'static'
        option delegate '0'
        option ipaddr '192.168.2.1'

config interface 'wg0'
        option proto 'wireguard'
        option private_key
        option listen_port '51820'
        option delegate '0'
        list addresses '10.0.0.1'

config wireguard_wg0
        list allowed_ips '10.0.0.2/32'
        option route_allowed_ips '1'
        option persistent_keepalive '25'
        option public_key

config wireguard_wg0
        option public_key
        option description 'Musenko'
        list allowed_ips '10.0.0.3/32'
        option route_allowed_ips '1'
        option persistent_keepalive '25'

config interface 'WAN11'
        option ifname 'eth1.11'
        option delegate '0'
        option proto 'dhcp'
        option peerdns '0'
        option defaultroute '0'

config interface 'WAN10'
        option proto 'pppoe'
        option password '---'
        option ipv6 'auto'
        option keepalive '5 10'
        option username '---'
        option ifname 'eth1.10'
        option service 'MOVISTAR'

config interface 'WAN12'
        option ifname 'eth1.12'
        option proto 'dhcp'
        option delegate '0'
        option macaddr 'xx:xx:xx:xx:xx:xx'
        option peerdns '0'
        option defaultroute '0'


Editado por Tki2000 para quitar información sensible.
« Última modificación: 19-10-2020, 17:20 (Lunes) por Tki2000 »

Desconectado BillieJoe

  • **
  • Mensajes: 5
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1322 en: 20-10-2020, 21:32 (Martes) »
Hola, ya solucione parte del problema. Cambie el HGU por una ont propia (el askey rtf8115vw no estaba haciendo bridge) Ya tengo internet en la Vlan 10 y IPTV en la Vlan 11, me falta ver como hago que mi telefono movil se registre para tener VOIP.
En IPTV tengo un problema de microcorte aleatorio, estuve viendo la configuracion de igmpproxy pero no lo puedo solucionar. Les dejo la conf.

config igmpproxy
        option quickleave 0
#       option verbose [0-3](none, minimal[default], more, maximum)
        option verbose 3

config phyint
        option network WAN11
#       option zone wan
        option direction upstream
        list altnet 0.0.0.0/0
        list altnet 192.168.2.1/24

config phyint
        option network LAN
        option zone lan
        option direction downstream


Muchas gracias

Desconectado BillieJoe

  • **
  • Mensajes: 5
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1323 en: 21-10-2020, 23:18 (Miércoles) »
Probe con mcproxy y hace lo mismo. El vivo se corta cada 4 minutos exactos (con igmpproxy y con mcproxy) Me funciona todo, el VOD rebobinar ver contenido en diferido. Ya no se que mas probar. Les aclaro que yo no instalo BIRD, las rutas las consigo por dhcp con la opcion 120.
El hgu de Movistar tiene configurada una opcion  en IGMP "query_interval"  en 15 segundos, tendra algo que ver?

Desconectado jgora

  • **
  • Mensajes: 5
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1324 en: 27-10-2020, 09:36 (Martes) »
En el github está el parche, comprobado, pero en el directorio de las 2 compilaciones que he hecho (19.07.2 y 19.07.4) ./feeds/packages/net/xtables-addons/patches/100-add-rtsp-conntrack.patch , el único en el que esta el parche, este no esta "reparcheado". Si se reparchea la imagen controla totalmente el imagenio, si no, he probado, no funciona la pausa, ver desde el principio, rebobinar y avance rapido.

Las 2 compilaciones, las he realizado con las versiones estables 19.07.2 y 19.07.4, la primera de 29 de Febrero y la segunda de 8 de Septiembre, ambas posteriores al reparche de 14 de Enero https://github.com/openwrt/packages/commits/master/net/xtables-addons/patches/100-add-rtsp-conntrack.patch despues hay 2 "reparches" mas, que los he mirado y en principio nada tiene que ver.

Hasta aqui llego. Puede ser que alguien tenga que aprobar esos reparches y aunque estén en ese github, eso es como una antesala en espera de aprobaciónpara pasar al github de verdad, no se. Lo cierto es que en la distribución para compilar 19.07.2 y 19.07.4 no estan y por tanto hay que reparchear.

Salu2

Hola

El parche está en el master.
He abierto esta PR a ver si alguien lo traslada a la rama openwrt-19.07
https://github.com/openwrt/packages/pull/13828

Saludos
« Última modificación: 02-11-2020, 14:26 (Lunes) por jgora »

Desconectado BillieJoe

  • **
  • Mensajes: 5
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1325 en: 27-10-2020, 21:45 (Martes) »
En el github está el parche, comprobado, pero en el directorio de las 2 compilaciones que he hecho (19.07.2 y 19.07.4) ./feeds/packages/net/xtables-addons/patches/100-add-rtsp-conntrack.patch , el único en el que esta el parche, este no esta "reparcheado". Si se reparchea la imagen controla totalmente el imagenio, si no, he probado, no funciona la pausa, ver desde el principio, rebobinar y avance rapido.

Las 2 compilaciones, las he realizado con las versiones estables 19.07.2 y 19.07.4, la primera de 29 de Febrero y la segunda de 8 de Septiembre, ambas posteriores al reparche de 14 de Enero https://github.com/openwrt/packages/commits/master/net/xtables-addons/patches/100-add-rtsp-conntrack.patch despues hay 2 "reparches" mas, que los he mirado y en principio nada tiene que ver.


Hola

Hasta aqui llego. Puede ser que alguien tenga que aprobar esos reparches y aunque estén en ese github, eso es como una antesala en espera de aprobaciónpara pasar al github de verdad, no se. Lo cierto es que en la distribución para compilar 19.07.2 y 19.07.4 no estan y por tanto hay que reparchear.

Salu2

Hola

El parche está en el master y en la rama openwrt-18.06
He abierto este issue a ver si alguien lo traslada a la rama openwrt-19.07
https://github.com/openwrt/packages/issues/13769

Saludos

Hola jgora. Gracias por responder. Por suerte no tengo ese problema, Ami rebobinar, pausar, y ver desde el comienzo me funciona, en mi caso con Movistar Argentina lo solucione agregando las peticiones de rutas por DHCP en la WAN de IPTV, agregando en /etc/config/network
WANIPTV
option reqopts '6 15 42 50 100 121 1 3'
la opcion 121 le pide al servidor todas las rutas estaticas.

no tuve que usar BIRD porque mi VLan para IPTV obtiene IP por DHCP. Mi problema es el stream Multicast en vivo( dura 4 minutos y se corta y vuelve a conectar por otros 4 minutos y asi sucesivamente.

M

Desconectado jgora

  • **
  • Mensajes: 5
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1326 en: 28-10-2020, 09:54 (Miércoles) »
Hola BillieJoe
Lo que comentas que se corta la transmisión multicast sólo me ocurrió cuando olvide permitir en el firewall el tráfico multicast de la wan de iptv a la lan. La transmisión creo recordar que comienza con unicast y por eso ves los primeros minutos, y cuando pasa a multicast se acabó...
Por otro lado utilizo mcproxy con igmp v2 en lugar de igmpproxy

Desconectado filiptc

  • **
  • Mensajes: 2
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1327 en: 07-11-2020, 15:01 (Sábado) »
Buenos días.

En mi caso me encuentro en la versión OpenWRT 19.07.02 (Turris Omnia 5.0) y no tengro problemas, para que funcione la tele en Turris Omnia, salvo la reproduccion del control directo, pero de resto funciona, supongo que se debe a que se debe modificar el parche como anteriores versiones, ya que yo vengo de openwrt 15.05.1 (Chaos Calmer) y no tenia problemas.
Copio mi config, aclarar que mi deco funciona solo en el puerto lan 0 del router porque esta aislado "tvlan", para usar mcproxy y udpxy pero sin inundar toda la red:
[...]

Mil gracias por esto, @deejayexe. Replicando esto he podido reconectar el deco tras actualizar mi turris. Sólo falta que funcione el control de directo, que imagino que habrá que esperar a que el parche del que se está hablando esté disponible...
« Última modificación: 07-11-2020, 15:01 (Sábado) por filiptc »

Desconectado jgora

  • **
  • Mensajes: 5
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1328 en: 11-12-2020, 11:05 (Viernes) »
Entiendo que la reciente 19.07.5 ya contendrá el parche del rtsp

Desconectado ealfaroc

  • **
  • Mensajes: 1
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1329 en: 28-12-2020, 18:29 (Lunes) »
Entiendo que la reciente 19.07.5 ya contendrá el parche del rtsp

Acabo de instalar OpenWrt 19.07.5 r11257-5090152ae3 y todo funciona a la perfección

Desconectado jgora

  • **
  • Mensajes: 5
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1330 en: 16-01-2021, 17:45 (Sábado) »
Entiendo que la reciente 19.07.5 ya contendrá el parche del rtsp

Acabo de instalar OpenWrt 19.07.5 r11257-5090152ae3 y todo funciona a la perfección
Lo he instalado también y confirmo que todo funciona.

Recordar añadir net.netfilter.nf_conntrack_helper=1 a /etc/sysctl.conf y por precaución desactivar la activación automática de los helper en la wan.

Desconectado filiptc

  • **
  • Mensajes: 2
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1331 en: 16-01-2021, 21:58 (Sábado) »
Confirmado! También con la versión 5.1.5 de Turris! Gracias!!

Desconectado ppfdez

  • **
  • Mensajes: 14
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1332 en: 24-01-2021, 20:46 (Domingo) »
Confirmado. Acabo de instalar sobre una Xunlong Orange Pi Zero Plus + switch D-Link DGS-1100-08 la versión estable
OpenWrt 19.07.6 r11278-8055e38794 / LuCI openwrt-19.07 branch git-21.018.57536-6ba9740 (Released: Tue, 19 Jan 2021),
y todas las funcionalidades de mi instalación, además del control del directo en TV, funcionan perfectamente.

Estoy contento porque por fin tengo mi particularización de OpenWRT, sobre una versión estable, pudiendo evolucionar sin necesidad de compilar, un alivio.

Esperemos que el parche de marras, no choque con las políticas linux o se vuelva a quedar en el olvido y pasemos otra vez el quinario consecuente.

Salud y responsabilidad para todos.

Desconectado Franco Castillo

  • **
  • Mensajes: 1
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1333 en: 13-02-2021, 16:41 (Sábado) »
Hola, hay algún resumen que esté acutalizado?

Desconectado yonoesio

  • **
  • Mensajes: 1
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1334 en: 24-02-2021, 07:08 (Miércoles) »
Bueno,
después de un año he vuelto a movistar. Ya no tengo ont y tengo un HGU.
Ha sido un dolor de cabeza configurar OpenWrt porque el script ya no vale si no tiene ont.
Básicamente es:
Poner el hgu en monopuesto.
En el OpenWrt. Configurar la WAN por PPPoE
Crear otra interfaz usando la misma ínter física que la WAN y configurarla con DHCP.
Configurar el reenvío entre la WAN, LAN y la nueva interfaz desde el firewal.
Añadir alguna ruta y DNS
Configurar igmpproxy
Configurar udpxy

Y ya funciona Internet en el router OpenWrt, se ven los canales que no tienen DRM...
El deco no se si va pero me da igual porque esta enchufado al HGU.

Puedo descargar la guía xml, generar la lista de canales m3u y pasarla a xteve y de ahí a Plex.

Saludos.

Desconectado Gripao

  • **
  • Mensajes: 1
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1335 en: 28-02-2021, 11:42 (Domingo) »
Buenas a todos!!

He seguido la guía 1.2 pero no entiendo de donde sacar estos datos:


config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '172.26.X.Y'
option netmask '255.255.240.0'
option gateway '172.26.X.Z'

config 'alias'
option 'interface''lan'
option 'proto''static'
option ipaddr '10.X.Y.Z'
option nestmask '255.255.255.248'

En la negrita pone lo siguiente: hay que cambiar las direcciones IP de IPTV y del alias del Bridge LAN por las únicas de cada cliente (las marcadas en negro).

Es decir, ¿de dónde saco esos datos en negrita?

No sé si habría alguna guía más actualizada. Decir que tengo el HGU pero lo he quitado para utilizar una ONT + OpenWRT (Xiaomi AC2100). La VLAN 6 sin problemas.

Un saludo y gracias a todos!!

Desconectado jgora

  • **
  • Mensajes: 5
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1336 en: 07-03-2021, 00:23 (Domingo) »
Buenas a todos!!

He seguido la guía 1.2 pero no entiendo de donde sacar estos datos:


config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '172.26.X.Y'
option netmask '255.255.240.0'
option gateway '172.26.X.Z'

config 'alias'
option 'interface''lan'
option 'proto''static'
option ipaddr '10.X.Y.Z'
option nestmask '255.255.255.248'

En la negrita pone lo siguiente: hay que cambiar las direcciones IP de IPTV y del alias del Bridge LAN por las únicas de cada cliente (las marcadas en negro).

Es decir, ¿de dónde saco esos datos en negrita?

No sé si habría alguna guía más actualizada. Decir que tengo el HGU pero lo he quitado para utilizar una ONT + OpenWRT (Xiaomi AC2100). La VLAN 6 sin problemas.

Un saludo y gracias a todos!!
Tienes que sacarla del router que te ha dado movistar, de tu hgu. Es tu ip fija para iptv. Lo del alias no me suena de nada.