Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 743522 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Myckelon

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #800 en: 23-04-2015, 07:09 (Jueves) »
Hola a todos.

Tengo un wdr3600 instalado con el firm y el scrip de noltari funcionando correctamente desde hace tiempo. Pero al ver los post de eduperez. Tambien estaria interesado en crear la VPN para poder recibir las llamadas fuera de casa. He intentado seguir tus explicaciones eduperez pero al instalar lo que indicas no me deja instalarlo, ni el strongswan-full ni xl2tpd.

No se si sera por la version del firmware que es el que tiene noltari al principio del post: OpenWrt Chaos Calmer r43179.

Si me pudierais echar una mano a configurar una VPN en este router. Sobre todo para el voip y para poder entrar a mi red desde fuera para gestionar un pequeño NAS con transmission.

Muchas gracias a todos por este gran POST.

Si pusieras aquí el error que te aparece al intentar instalar los paquetes...



Con opkg update me pone que ha habido un error y no puede actualizar.

He probado a instalar la version nueva del firmware que tiene Noltari colgada. Y entonces si actualiza. Pero al instalar me da varios errores en el kernel. En cuanto pueda subo unas fotos del error.

Gracias.

Leed, por favor, leed. Está todo en las FAQ:
https://foro.seguridadwireless.net/openwrt/%28faq%29-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Kernel_Deps
https://foro.seguridadwireless.net/openwrt/%28faq%29-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Packages

Gracias luego pruebo y posteo



bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #801 en: 23-04-2015, 22:28 (Jueves) »
eduperez, nada, no funciona. ¿Cómo tienes tú puesta la VPN, fuera de la br-lan?

Con "no funciona" no me dices nada... ¿qué es exactamente lo que no funciona? ¿cómo lo has probado? ¿qué mensajes te aparecen en el log? ¿...?

Yo tengo la VPN como una red independiente, y si has usado mis ficheros de configuración debería quedarte así. Si la has configurado de otra manera, estaría bien que subieras aquí tus ficheros para poder revisarlos.

Bueno, pues he reinstalado el firmware desde cero (Attitude Adjustment 12.09, que no da problemas de dependencias con strongswan y xl2tpd), y he puesto los ficheros de configuración como me dijiste. Quedan exactamente igual que los tuyos, excepto éstos dos:

Código: [Seleccionar]
/etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 2 3 4 5'

config switch_vlan
option device 'switch0'
option vlan '3'
option ports '0t 1t'

config switch_vlan
option device 'switch0'
option vlan '6'
option ports '0t 1t'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ip6assign '60'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'voip'
option ifname 'eth0.3'
option proto 'dhcp'
option defaultroute '0'
option peerdns '0'

config interface 'wan'
option ifname 'eth0.6'
option proto 'pppoe'
option username 'adslppp@telefonicanetpa'
option password 'adslppp'

config interface 'vpn'
option ifname 'ppp+'
option proto 'none'
option delegate '0'
option auto '1'
Código: [Seleccionar]
/etc/config/firewall
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config zone
option name 'voip'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option network 'voip'
option masq '1'

config forwarding
option src 'lan'
option dest 'voip'

config rule
option target 'ACCEPT'
option src 'wan'
option proto '50'
option name 'IPSEC_ESP'

config rule
option target 'ACCEPT'
option src 'wan'
option proto '51'
option name 'IPSEC_AH'

config rule
option name 'IPSEC_IKE'
option target 'ACCEPT'
option src 'wan'
option proto 'udp'
option dest_port '500'

config rule
option name 'IPSEC_NAT'
option target 'ACCEPT'
option src 'wan'
option proto 'udp'
option dest_port '4500'

Así queda ahora la VPN desde Luci:



Si hago ping a la ip del servidor VPN, no responde. Si intento conectar desde el móvil a la VPN, tanto con wifi como con 3g, el mensaje de error es siempre el mismo "El servidor VPN no responde".
No sé por dónde seguir.
« Última modificación: 23-04-2015, 22:39 (Jueves) por bellido »

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #802 en: 23-04-2015, 22:35 (Jueves) »
Si hago ping a la ip del servidor VPN, no responde.

Hasta que no tengas eso solucionado, no hace falta que pruebes nada más... Desde dentro de tu red, haces PING a la dirección interna del router, ¿y no te funciona? Y a la página de configuración del router, ¿puedes acceder?

bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #803 en: 23-04-2015, 22:42 (Jueves) »
A la página de configuración del router sí accedo, pero a la ip del servidor VPN (192.168.2.254, según los ficheros de configuración), ahí no.

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #804 en: 23-04-2015, 22:44 (Jueves) »
A la página de configuración del router sí accedo, pero a la ip del servidor VPN (192.168.2.254, según los ficheros de configuración), ahí no.

Esa es la dirección IP del router en la red VPN, y la red VPN no se existe hasta que no estableces la conexión VPN; tienes que probar con la misma dirección que usas para acceder a la página de configuración.

bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #805 en: 23-04-2015, 22:46 (Jueves) »
Lo acabo de cambiar en los ajustes del móvil, pero tampoco.

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #806 en: 23-04-2015, 22:47 (Jueves) »
Lo acabo de cambiar en los ajustes del móvil, pero tampoco.

¿Y qué dicen los logs del router?

bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #807 en: 23-04-2015, 22:54 (Jueves) »
Código: [Seleccionar]
Apr 23 22:45:56 OpenWrt daemon.info syslog: 01[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:45:56 OpenWrt daemon.info syslog: 01[ENC] generating INFORMATIONAL_V1 request 3844802278 [ N(NO_PROP) ]
Apr 23 22:45:56 OpenWrt daemon.info syslog: 01[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:45:59 OpenWrt daemon.info syslog: 15[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (596 bytes)
Apr 23 22:45:59 OpenWrt daemon.info syslog: 15[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V V V ]
Apr 23 22:45:59 OpenWrt daemon.info syslog: 15[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:45:59 OpenWrt daemon.info syslog: 15[ENC] generating INFORMATIONAL_V1 request 2642888234 [ N(NO_PROP) ]
Apr 23 22:45:59 OpenWrt daemon.info syslog: 15[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:46:03 OpenWrt daemon.info syslog: 16[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (596 bytes)
Apr 23 22:46:03 OpenWrt daemon.info syslog: 16[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V V V ]
Apr 23 22:46:03 OpenWrt daemon.info syslog: 16[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:46:03 OpenWrt daemon.info syslog: 16[ENC] generating INFORMATIONAL_V1 request 3901667121 [ N(NO_PROP) ]
Apr 23 22:46:03 OpenWrt daemon.info syslog: 16[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:46:06 OpenWrt daemon.info syslog: 12[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (596 bytes)
Apr 23 22:46:06 OpenWrt daemon.info syslog: 12[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V V V ]
Apr 23 22:46:06 OpenWrt daemon.info syslog: 12[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:46:06 OpenWrt daemon.info syslog: 12[ENC] generating INFORMATIONAL_V1 request 2968129389 [ N(NO_PROP) ]
Apr 23 22:46:06 OpenWrt daemon.info syslog: 12[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:50:04 OpenWrt daemon.info syslog: 03[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (596 bytes)
Apr 23 22:50:04 OpenWrt daemon.info syslog: 03[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V V V ]
Apr 23 22:50:04 OpenWrt daemon.info syslog: 03[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:50:04 OpenWrt daemon.info syslog: 03[ENC] generating INFORMATIONAL_V1 request 736202689 [ N(NO_PROP) ]
Apr 23 22:50:04 OpenWrt daemon.info syslog: 03[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:50:07 OpenWrt daemon.info syslog: 01[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (596 bytes)
Apr 23 22:50:07 OpenWrt daemon.info syslog: 01[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V V V ]
Apr 23 22:50:07 OpenWrt daemon.info syslog: 01[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:50:07 OpenWrt daemon.info syslog: 01[ENC] generating INFORMATIONAL_V1 request 1304345100 [ N(NO_PROP) ]
Apr 23 22:50:07 OpenWrt daemon.info syslog: 01[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:50:14 OpenWrt daemon.info syslog: 15[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (596 bytes)
Apr 23 22:50:14 OpenWrt daemon.info syslog: 15[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V V V ]
Apr 23 22:50:14 OpenWrt daemon.info syslog: 15[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:50:14 OpenWrt daemon.info syslog: 15[ENC] generating INFORMATIONAL_V1 request 981023486 [ N(NO_PROP) ]
Apr 23 22:50:14 OpenWrt daemon.info syslog: 15[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:52:42 OpenWrt daemon.info syslog: 12[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (500 bytes)
Apr 23 22:52:42 OpenWrt daemon.info syslog: 12[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
Apr 23 22:52:42 OpenWrt daemon.info syslog: 12[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:52:42 OpenWrt daemon.info syslog: 12[ENC] generating INFORMATIONAL_V1 request 419716134 [ N(NO_PROP) ]
Apr 23 22:52:42 OpenWrt daemon.info syslog: 12[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:52:45 OpenWrt daemon.info syslog: 08[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (500 bytes)
Apr 23 22:52:45 OpenWrt daemon.info syslog: 08[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
Apr 23 22:52:45 OpenWrt daemon.info syslog: 08[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:52:45 OpenWrt daemon.info syslog: 08[ENC] generating INFORMATIONAL_V1 request 3483821992 [ N(NO_PROP) ]
Apr 23 22:52:45 OpenWrt daemon.info syslog: 08[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:52:49 OpenWrt daemon.info syslog: 09[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (500 bytes)
Apr 23 22:52:49 OpenWrt daemon.info syslog: 09[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
Apr 23 22:52:49 OpenWrt daemon.info syslog: 09[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:52:49 OpenWrt daemon.info syslog: 09[ENC] generating INFORMATIONAL_V1 request 3132654193 [ N(NO_PROP) ]
Apr 23 22:52:49 OpenWrt daemon.info syslog: 09[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)
Apr 23 22:52:52 OpenWrt daemon.info syslog: 06[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (500 bytes)
Apr 23 22:52:52 OpenWrt daemon.info syslog: 06[ENC] parsed ID_PROT request 0 [ SA V V V V V V V V V V V V ]
Apr 23 22:52:52 OpenWrt daemon.info syslog: 06[IKE] no IKE config found for 192.168.1.1...192.168.1.193, sending NO_PROPOSAL_CHOSEN
Apr 23 22:52:52 OpenWrt daemon.info syslog: 06[ENC] generating INFORMATIONAL_V1 request 3880630162 [ N(NO_PROP) ]
Apr 23 22:52:52 OpenWrt daemon.info syslog: 06[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (40 bytes)

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #808 en: 23-04-2015, 23:11 (Jueves) »
Quizás sea un problema del cliente, ¿cómo configuras la conexión?

bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #809 en: 23-04-2015, 23:18 (Jueves) »
En iOS: ajustes--VPN--añadir configuracion VPN--
He probado tanto en L2TP como en IPsec:

Descripción: MiVPN
Servidor: la IP del router.
Cuenta: usuario-vpn
Contraseña: contraseña-usuario-vpn
Secreto: contraseña-global-vpn
Enviar todo el tráfico: activado.
Guardar la configuración.

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #810 en: 23-04-2015, 23:21 (Jueves) »
En iOS: ajustes--VPN--añadir configuracion VPN--
He probado tanto en L2TP como en IPsec:

Descripción: MiVPN
Servidor: la IP del router.
Cuenta: usuario-vpn
Contraseña: contraseña-usuario-vpn
Secreto: contraseña-global-vpn
Enviar todo el tráfico: activado.
Guardar la configuración.


Debes usar L2TP, y tener desactivada la opción "RSA SecurID"; si es así, y el resto de ficheros de configuración es correcto, no sé qué más puede ser...

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #811 en: 23-04-2015, 23:23 (Jueves) »
En iOS: ajustes--VPN--añadir configuracion VPN--
He probado tanto en L2TP como en IPsec:

Descripción: MiVPN
Servidor: la IP del router.
Cuenta: usuario-vpn
Contraseña: contraseña-usuario-vpn
Secreto: contraseña-global-vpn
Enviar todo el tráfico: activado.
Guardar la configuración.


Debes usar L2TP, y tener desactivada la opción "RSA SecurID"; si es así, y el resto de ficheros de configuración es correcto, no sé qué más puede ser...

Rectifico: acabo de probarlo con iOS, y la configuración que antes me funcionaba ahora ya no (y en el router me aparecen los mismos mensajes de error); supongo que alguna actualización de iOS ha cambiado algo, y ya no funciona.

bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #812 en: 23-04-2015, 23:28 (Jueves) »
Código: [Seleccionar]
Debes usar L2TP, y tener desactivada la opción "RSA SecurID"
Está desactivada.
Los ficheros los he revisado, y están exactamente igual que los tuyos excepto network y firewall, pero esas son las opciones con las que quedan después de ejecutar el script de Noltari.

No sé si influirá, la versión de hardware del router es la 1.7

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #813 en: 24-04-2015, 12:19 (Viernes) »
Rectifico: acabo de probarlo con iOS, y la configuración que antes me funcionaba ahora ya no (y en el router me aparecen los mismos mensajes de error); supongo que alguna actualización de iOS ha cambiado algo, y ya no funciona.

En algún momento se ha debido perder el fichero de configuración de strongswan y no me he dado cuenta porque con Android seguía funcionando (la mayoría de las veces); a raíz de este hilo he visto que algo no estaba mal, y he recuperado el fichero de configuración de una copia de seguridad.

Prueba con este fichero, a mí me conecta inmediatamente tanto en Android como en iOS:

Código: [Seleccionar]
### /etc/ipsec.conf


config setup
# strictcrlpolicy=yes
uniqueids = no

conn vpnserver
type=transport
authby=secret
keyingtries=3
left=%any
leftprotoport=udp/l2tp
right=%any
rightprotoport=udp/%any
auto=add

bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #814 en: 24-04-2015, 19:41 (Viernes) »
Lo he cambiado, y sigue sin conectar (ni en adroid ni en iOS). El log da un error:

Código: [Seleccionar]
4 19:27:31 OpenWrt daemon.info xl2tpd[1632]: Enabling IPsec SAref processing for L2TP transport mode SAs
Apr 24 19:27:31 OpenWrt daemon.warn xl2tpd[1632]: IPsec SAref does not work with L2TP kernel mode yet, enabling forceuserspace=yes
Apr 24 19:27:31 OpenWrt daemon.crit xl2tpd[1632]: setsockopt recvref[30]: Protocol not available
Apr 24 19:27:31 OpenWrt daemon.info xl2tpd[1632]: Using l2tp kernel support.
Apr 24 19:27:31 OpenWrt daemon.info xl2tpd[1633]: xl2tpd version xl2tpd-1.3.1 started on OpenWrt PID:1633
Apr 24 19:27:31 OpenWrt daemon.info xl2tpd[1633]: Written by Mark Spencer, Copyright (C) 1998, Adtran, Inc.
Apr 24 19:27:31 OpenWrt daemon.info xl2tpd[1633]: Forked by Scott Balmos and David Stipp, (C) 2001
Apr 24 19:27:31 OpenWrt daemon.info xl2tpd[1633]: Inherited by Jeff McAdams, (C) 2002
Apr 24 19:27:31 OpenWrt daemon.info xl2tpd[1633]: Forked again by Xelerance (www.xelerance.com) (C) 2006
Apr 24 19:27:31 OpenWrt daemon.info xl2tpd[1633]: Listening on IP address 0.0.0.0, port 1701
Apr 24 19:27:31 OpenWrt user.info sysinit: no files found matching '/etc/strongswan.d/charon/*.conf', ignored
Apr 24 19:27:31 OpenWrt user.info sysinit: Starting strongSwan 5.1.3 IPsec [starter]...
Apr 24 19:27:31 OpenWrt authpriv.info ipsec_starter[1635]: Starting strongSwan 5.1.3 IPsec [starter]...
Apr 24 19:27:31 OpenWrt user.info sysinit: !! Your strongswan.conf contains manual plugin load options for charon.
Apr 24 19:27:31 OpenWrt authpriv.info ipsec_starter[1635]: !! Your strongswan.conf contains manual plugin load options for charon.
Apr 24 19:27:31 OpenWrt user.info sysinit: !! This is recommended for experts only, see
Apr 24 19:27:31 OpenWrt authpriv.info ipsec_starter[1635]: !! This is recommended for experts only, see
Apr 24 19:27:31 OpenWrt user.info sysinit: !! http://wiki.strongswan.org/projects/strongswan/wiki/PluginLoad
Apr 24 19:27:31 OpenWrt authpriv.info ipsec_starter[1635]: !! http://wiki.strongswan.org/projects/strongswan/wiki/PluginLoad
Apr 24 19:27:31 OpenWrt user.info sysinit: (null):0: syntax error, unexpected $end, expecting EOL []
Apr 24 19:27:31 OpenWrt authpriv.info ipsec_starter[1635]: (null):0: syntax error, unexpected $end, expecting EOL []
Apr 24 19:27:31 OpenWrt user.info sysinit: unable to start strongSwan -- fatal errors in config
Apr 24 19:27:31 OpenWrt authpriv.info ipsec_starter[1635]: unable to start strongSwan -- fatal errors in config

Mirando otra vez en la configuración, en el fichero xl2tpd.conf, se incluye auth file = /etc/xl2tpd/xl2tp-secrets. ¿Cómo es tu fichero xl2tp-secrets?
« Última modificación: 24-04-2015, 19:47 (Viernes) por bellido »

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #815 en: 24-04-2015, 22:09 (Viernes) »
En /etc/xl2tpd/xl2tp-secrets no tengo nada, está todo comentado; la autentificación se hace en otro sitio, y no es necesario. Lo que veo es que te está dando errores al arrancar strongSwan: "unable to start strongSwan -- fatal errors in config"; ¿seguro que has copiado bien todos los ficheros?

Te paso la lista de módulos del kernel que tengo instalados (los que tienen pinta de estar relacionados), porque veo algún error sospechoso en tu log:
Código: [Seleccionar]
kmod-crypto-aes - 3.10.49-1
kmod-crypto-arc4 - 3.10.49-1
kmod-crypto-authenc - 3.10.49-1
kmod-crypto-cbc - 3.10.49-1
kmod-crypto-core - 3.10.49-1
kmod-crypto-crc32c - 3.10.49-1
kmod-crypto-deflate - 3.10.49-1
kmod-crypto-des - 3.10.49-1
kmod-crypto-ecb - 3.10.49-1
kmod-crypto-fcrypt - 3.10.49-1
kmod-crypto-hash - 3.10.49-1
kmod-crypto-hmac - 3.10.49-1
kmod-crypto-iv - 3.10.49-1
kmod-crypto-manager - 3.10.49-1
kmod-crypto-md4 - 3.10.49-1
kmod-crypto-md5 - 3.10.49-1
kmod-crypto-misc - 3.10.49-1
kmod-crypto-null - 3.10.49-1
kmod-crypto-pcbc - 3.10.49-1
kmod-crypto-pcompress - 3.10.49-1
kmod-crypto-rng - 3.10.49-1
kmod-crypto-sha1 - 3.10.49-1
kmod-crypto-sha256 - 3.10.49-1
kmod-crypto-user - 3.10.49-1
kmod-crypto-wq - 3.10.49-1
kmod-cryptodev - 3.10.49+1.6-ar71xx-1
kmod-ipsec - 3.10.49-1
kmod-ipsec4 - 3.10.49-1
kmod-ipsec6 - 3.10.49-1
kmod-ipt-conntrack - 3.10.49-1
kmod-ipt-conntrack-extra - 3.10.49-1
kmod-ipt-core - 3.10.49-1
kmod-ipt-filter - 3.10.49-1
kmod-ipt-ipopt - 3.10.49-1
kmod-ipt-ipsec - 3.10.49-1
kmod-ipt-nat - 3.10.49-1
kmod-ipt-nathelper - 3.10.49-1
kmod-iptunnel - 3.10.49-1
kmod-iptunnel4 - 3.10.49-1
kmod-iptunnel6 - 3.10.49-1
kmod-ipv6 - 3.10.49-1
kmod-l2tp - 3.10.49-1
kmod-ppp - 3.10.49-1
kmod-pppoe - 3.10.49-1
kmod-pppol2tp - 3.10.49-1
kmod-pppox - 3.10.49-1
kmod-tun - 3.10.49-1

Prueba a ejecutar "ipsec start --debug", a ver si sacamos más información...

emiralles

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #816 en: 25-04-2015, 07:57 (Sábado) »
Jolines!!! he cambiado, por probar, la versión de openwrt, pasando del BarrierBreaker 14.07 al Chaos Calmer r45566 ya que tenia unos problemas en la red inalambrica de conexiones y desconexiones y estuve leyendo que se solucionaban en versiones siguientes y si, se me han solucionado los problemas de wifi, pero sin embargo la televisión la veo unos 10 segundos y luego se para, cambio de canal y se ve 10 segundos (quizás menos) y se para.

Se puede solucionar? Puedo solucionar mis problemas de WIFI en Barrier Breaker?

Gracias

bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #817 en: 25-04-2015, 14:54 (Sábado) »
...Te paso la lista de módulos del kernel que tengo instalados (los que tienen pinta de estar relacionados), porque veo algún error sospechoso en tu log:

Bueno... pues te cuento: de esa lista me faltaban varios paquetes, que al instalalrlos me daban errores de dependencias. Al forzar la instalación, el router se quedó pillado, la única forma de arreglarlo fue abrirlo y conectarlo vía serie para resetear y empezar de nuevo, uff. Decidí compilar e incluir todo. He reinstalado de nuevo, he vuelto a poner los archivos tal y como los has puesto, y ahora puedo conectar el móvil a la VPN desde dentro de la Lan, pero conectado no navega.
Ahora, si hago ping al 192.168.2.254 desde el pc, se abre la página de configuración del router.

No sé si será así como debe aparecer en Luci:



El log del router:
Código: [Seleccionar]
Sat Apr 25 12:27:54 2015 daemon.info syslog: 11[IKE] received FRAGMENTATION vendor ID
Sat Apr 25 12:27:54 2015 daemon.info syslog: 11[IKE] received DPD vendor ID
Sat Apr 25 12:27:54 2015 daemon.info syslog: 11[IKE] 192.168.1.193 is initiating a Main Mode IKE_SA
Sat Apr 25 12:27:54 2015 authpriv.info syslog: 11[IKE] 192.168.1.193 is initiating a Main Mode IKE_SA
Sat Apr 25 12:27:54 2015 daemon.info syslog: 11[ENC] generating ID_PROT response 0 [ SA V V V ]
Sat Apr 25 12:27:54 2015 daemon.info syslog: 11[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (136 bytes)
Sat Apr 25 12:27:54 2015 daemon.info syslog: 03[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (228 bytes)
Sat Apr 25 12:27:54 2015 daemon.info syslog: 03[ENC] parsed ID_PROT request 0 [ KE No NAT-D NAT-D ]
Sat Apr 25 12:27:54 2015 daemon.info syslog: 03[ENC] generating ID_PROT response 0 [ KE No NAT-D NAT-D ]
Sat Apr 25 12:27:54 2015 daemon.info syslog: 03[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (244 bytes)
Sat Apr 25 12:27:54 2015 daemon.info syslog: 04[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (108 bytes)
Sat Apr 25 12:27:54 2015 daemon.info syslog: 04[ENC] parsed ID_PROT request 0 [ ID HASH N(INITIAL_CONTACT) ]
Sat Apr 25 12:27:54 2015 daemon.info syslog: 04[CFG] looking for pre-shared key peer configs matching 192.168.1.1...192.168.1.193[192.168.1.193]
Sat Apr 25 12:27:54 2015 daemon.info syslog: 04[CFG] selected peer config "vpnserver"
Sat Apr 25 12:27:54 2015 daemon.info syslog: 04[IKE] IKE_SA vpnserver[4] established between 192.168.1.1[192.168.1.1]...192.168.1.193[192.168.1.193]
Sat Apr 25 12:27:54 2015 authpriv.info syslog: 04[IKE] IKE_SA vpnserver[4] established between 192.168.1.1[192.168.1.1]...192.168.1.193[192.168.1.193]
Sat Apr 25 12:27:54 2015 daemon.info syslog: 04[IKE] scheduling reauthentication in 10214s
Sat Apr 25 12:27:54 2015 daemon.info syslog: 04[IKE] maximum IKE_SA lifetime 10754s
Sat Apr 25 12:27:54 2015 daemon.info syslog: 04[ENC] generating ID_PROT response 0 [ ID HASH ]
Sat Apr 25 12:27:54 2015 daemon.info syslog: 04[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (76 bytes)
Sat Apr 25 12:27:55 2015 daemon.info syslog: 01[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (284 bytes)

Sat Apr 25 12:27:55 2015 daemon.info syslog: 01[NET] sending packet: from 192.168.1.1[500] to 192.168.1.193[500] (172 bytes)
Sat Apr 25 12:27:55 2015 daemon.info syslog: 05[NET] received packet: from 192.168.1.193[500] to 192.168.1.1[500] (60 bytes)
Sat Apr 25 12:27:55 2015 daemon.info syslog: 05[ENC] parsed QUICK_MODE request  [ HASH ]
Sat Apr 25 12:27:55 2015 daemon.info syslog: 05[IKE] CHILD_SA vpnserver{2} established with SPIs _o and TS 192.168.1.1/32[udp/l2f] === 192.168.1.193/32[udp/64541]
Sat Apr 25 12:27:55 2015 authpriv.info syslog: 05[IKE] CHILD_SA vpnserver{2} established with SPIs and TS 192.168.1.1/32[udp/l2f] === 192.168.1.193/32[udp/64541]
Sat Apr 25 12:27:55 2015 daemon.notice xl2tpd[1279]: Connection established to 192.168.1.193, 64541.  Local: 17715, Remote: 39 (ref=0/0).  LNS session is 'default'
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: start_pppd: I'm running:
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: "/usr/sbin/pppd"
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: "passive"
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: "nodetach"
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: "192.168.2.254:192.168.2.64"
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: "auth"
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: "require-pap"
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: "require-chap"
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: ""
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: ""
Sat Apr 25 12:27:55 2015 daemon.debug xl2tpd[1279]: "debug"
Sat Apr 25 12:27:55 2015 daemon.notice pppd[6948]: pppd 2.4.7 started by root, uid 0
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: using channel 3
Sat Apr 25 12:27:55 2015 daemon.info pppd[6948]: Using interface ppp1
Sat Apr 25 12:27:55 2015 daemon.notice pppd[6948]: Connect: ppp1 <--> /dev/pts/0
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MD5> <>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <> <pcomp> <accomp>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [LCP ConfRej id=0x1 <pcomp> <accomp>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <auth chap MD5> <>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: rcvd [LCP ConfReq id=0x2 <asyncmap 0x0> <magic >]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [LCP ConfAck id=0x2 <asyncmap 0x0> <magic >]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [LCP EchoReq id=0x0 magic=]

Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: rcvd [CHAP Response id=>, name = ""]
Sat Apr 25 12:27:55 2015 daemon.warn pppd[6948]: Warning - secret file /etc/ppp/chap-secrets has world and/or group access
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [CHAP Success id=0x47 "Access granted"]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [IPCP ConfReq id=0x1 <compress > <addr 192.168.2.254>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: rcvd [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [IPCP ConfNak id=0x1 <addr 192.168.2.64> <ms-dns1 192.168.2.254> <ms-dns2 192.168.2.254>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: rcvd [IPV6CP ConfReq id=0x1 <addr ]
Sat Apr 25 12:27:55 2015 daemon.warn pppd[6948]: Unsupported protocol 'IPv6 Control Protocol' (0x8057) received
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [LCP ProtRej id=]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: rcvd [IPCP ConfRej id=0x1 <compress VJ 0f 01>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [IPCP ConfReq id=0x2 <addr 192.168.2.254>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: rcvd [IPCP ConfReq id=0x2 <addr 192.168.2.64> <ms-dns1 192.168.2.254> <ms-dns2 192.168.2.254>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: sent [IPCP ConfAck id=0x2 <addr 192.168.2.64> <ms-dns1 192.168.2.254> <ms-dns2 192.168.2.254>]
Sat Apr 25 12:27:55 2015 daemon.debug pppd[6948]: rcvd [IPCP ConfAck id=0x2 <addr 192.168.2.254>]
Sat Apr 25 12:27:55 2015 daemon.info syslog: 10[KNL] 192.168.2.254 appeared on ppp1
Sat Apr 25 12:27:55 2015 daemon.info syslog: 15[KNL] 192.168.2.254 disappeared from ppp1
Sat Apr 25 12:27:55 2015 daemon.info syslog: 06[KNL] 192.168.2.254 appeared on ppp1
Sat Apr 25 12:27:55 2015 daemon.info syslog: 03[KNL] interface ppp1 activated
Sat Apr 25 12:27:55 2015 daemon.notice pppd[6948]: local  IP address 192.168.2.254
Sat Apr 25 12:27:55 2015 daemon.notice pppd[6948]: remote IP address 192.168.2.64
El ipsec start --debug, me devuelve esto:
Código: [Seleccionar]
root@OpenWrt:~# ipsec start --debug
no files found matching '/etc/strongswan.d/*.conf'
Starting strongSwan 5.2.2 IPsec [starter]...
!! Your strongswan.conf contains manual plugin load options for charon.
!! This is recommended for experts only, see
!! http://wiki.strongswan.org/projects/strongswan/wiki/PluginLoad
charon is already running (/var/run/charon.pid exists) -- skipping daemon start
Loading config setup
Loading conn 'vpnserver'
kmod: ah4 is already loaded
kmod: esp4 is already loaded
kmod: ipcomp is already loaded
kmod: xfrm4_tunnel is already loaded
kmod: xfrm_user is already loaded
found netkey IPsec stack
starter is already running (/var/run/starter.charon.pid exists) -- no fork done
root@OpenWrt:~#
No sé si me se me escapa algo.
« Última modificación: 25-04-2015, 19:59 (Sábado) por bellido »

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #818 en: 25-04-2015, 22:50 (Sábado) »
Uf, yo no tuve problemas para instalar los paquetes, ni de dependencias ni de ningún tipo. En cualquier caso, si desde el móvil ya puedes abrir la VPN (y eso es lo que se vé en los logs), entonces ya tienes la parte más complicada resuelta.

El hecho de que veas la página de configuración desde el PC en 192.168.2.254 es normal, ya que ahora esa es la dirección del router en la red VPN; es más interesante saber si puedes verla también desde el móvil.

Ahora lo que te interesa es poder navegar desde el móvil, y poder acceder también a la red VoIP (a menos que uses Asterisk); y eso es tan sencillo como permitir el tráfico. Puedes ir a la página de configuración del firewall, y copiar lo que tienes en la red LAN a la red VPN. Te paso lo que yo tengo en ese fichero (te copio sólo las partes relevantes):

Código: [Seleccionar]
config zone
option name 'vpn'
option network 'vpn'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option conntrack '1'

config forwarding
option dest 'wan'
option src 'vpn'

Por cierto, hay un aviso en tus logs (Warning - secret file /etc/ppp/chap-secrets has world and/or group access) que deberías tener en cuenta; para solucionarlo, simplemente entra en el router y ejecuta "chmod 600 /etc/ppp/chap-secrets".

grenouille

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #819 en: 26-04-2015, 21:56 (Domingo) »
hola

Os pasa a alguien que si desde el portal Luci hacéis un Reboot/Perform Reboot el router no vuelve a la vida y hay que hacer un OFF/ON del botón o trafo??? parece que haga un halt

En cambio si entro por SSH y ejecuto "reboot" no hay problema y el router se reinicia con normalidad

Esto me pasa con el WDR3600 con ftth Movistar. En otros Openwrt no me sucede

Me cito para insistir en esta consulta. He estado investigándolo y me pasa tanto haciendo un reboot via ssh como haciendo un "perform Reboot" desde Luci. Googleando un poco he localizado un post donde dicen que sucede con el WDR3600 v1.5 y también en algunos WDR4300.

https://forum.openwrt.org/viewtopic.php?id=52031 <-- aquí explican lo poco que parece que se sabe. Me pasa tal y como lo describen ahí, pasa aleatoriamente 3-4 veces de cada 10. Da igual el firmware, BB, CC, por más que he buscado parece algo relacionado con el hardware y la suerte.

Si alguien puede aportar algo y solucionarlo se agradece