Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 743525 veces)

0 Usuarios y 1 Visitante están viendo este tema.

bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #820 en: 26-04-2015, 22:35 (Domingo) »
El hecho de que veas la página de configuración desde el PC en 192.168.2.254 es normal, ya que ahora esa es la dirección del router en la red VPN; es más interesante saber si puedes verla también desde el móvil.

Ahora lo que te interesa es poder navegar desde el móvil, y poder acceder también a la red VoIP (a menos que uses Asterisk); y eso es tan sencillo como permitir el tráfico. Puedes ir a la página de configuración del firewall, y copiar lo que tienes en la red LAN a la red VPN. Te paso lo que yo tengo en ese fichero (te copio sólo las partes relevantes):

Por cierto, hay un aviso en tus logs (Warning - secret file /etc/ppp/chap-secrets has world and/or group access) que deberías tener en cuenta; para solucionarlo, simplemente entra en el router y ejecuta "chmod 600 /etc/ppp/chap-secrets".

Bueno, vamos avanzando. Ahora ya puedo navegar desde el móvil vía Wifi+VPN. Pero no he podido hacer llamadas vía VoIP+VPN (tengo instalado en el móvil el Media5-fone, y fuera de la VPN sí me funciona para llamadas VoIP vía Wifi).
Lo que sí he observado es que el interfaz VPN no muestra actividad visto en Luci, ni siquiera navegando por el móvil con la VPN activada.

P.D: Ya he corregido el aviso del log.


« Última modificación: 26-04-2015, 23:00 (Domingo) por bellido »

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #821 en: 26-04-2015, 23:01 (Domingo) »
El hecho de que veas la página de configuración desde el PC en 192.168.2.254 es normal, ya que ahora esa es la dirección del router en la red VPN; es más interesante saber si puedes verla también desde el móvil.

Ahora lo que te interesa es poder navegar desde el móvil, y poder acceder también a la red VoIP (a menos que uses Asterisk); y eso es tan sencillo como permitir el tráfico. Puedes ir a la página de configuración del firewall, y copiar lo que tienes en la red LAN a la red VPN. Te paso lo que yo tengo en ese fichero (te copio sólo las partes relevantes):

Por cierto, hay un aviso en tus logs (Warning - secret file /etc/ppp/chap-secrets has world and/or group access) que deberías tener en cuenta; para solucionarlo, simplemente entra en el router y ejecuta "chmod 600 /etc/ppp/chap-secrets".
Bueno, vamos avanzando. Ahora ya puedo navegar desde el móvil vía Wifi+VPN. Pero no he podido hacer llamadas vía VoIP+VPN (tengo instalado en el móvil el Media5-fone, y fuera de la VPN sí me funciona para llamadas VoIP vía Wifi).

Eso es porque aún no has permitido el tráfico entre la red VPN y la red VoIP; en "/etc/config/firewall" tienes que añadir lo mismo que pusiste para permitir el tráfico entre VPN y la WAN, pero cambiando WAN por el nombre de tu red VoIP.

Para llamar desde 3G+VPN+VoIP, seguramente me hará falta un servicio  para la DNS dinámico (tipo "changeip.com"), ¿no?.

Sí, es conveniente; yo uso DuckDNS.

Lo que sí he observado es que el interfaz VPN no muestra actividad visto en Luci, ni siquiera navegando por el móvil con la VPN activada.

Me pasa lo mismo, no tienes de qué preocuparte.

bellido

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #822 en: 27-04-2015, 17:48 (Lunes) »
¡Ya tengo el servicio DNS dinámico configurado, y ya me puedo conectar con la VPN tanto por Wifi como por 3g y hacer llamadas con el móvil vía VoIP!.  >:( >:( >:( >:( >:(

Mil gracias, eduperez, sin tu ayuda no lo hubiera conseguido.

Saludos

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #823 en: 27-04-2015, 22:41 (Lunes) »
¡Ya tengo el servicio DNS dinámico configurado, y ya me puedo conectar con la VPN tanto por Wifi como por 3g y hacer llamadas con el móvil vía VoIP!.  >:( >:( >:( >:( >:(

Mil gracias, eduperez, sin tu ayuda no lo hubiera conseguido.

Saludos

Ha sido un placer, y ahora, a disfrutarlo!!!

psikonetik

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #824 en: 29-04-2015, 11:47 (Miércoles) »
Hola amigos,

Una cuestión de novato.
Recientemente me he pasado de ono a movistar fibra. Me trajeron un router Amper que por supuesto me falto tiempo para cambiarlo por mi wdr4300. Al wdr4300 le puse el firmware del primer post y el internet funcionaba de maravilla, pero el telefono no.

Me comentan los del servicio tecnico que la ONT le da telefono e internet al router y que el router le da telefono a la casa por la clavija de salida de telefono que tiene. De ser esto cierto no hay manera de quitar el router de movistar de la ecuacion, correcto?


Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #825 en: 29-04-2015, 12:01 (Miércoles) »
Hola amigos,

Una cuestión de novato.
Recientemente me he pasado de ono a movistar fibra. Me trajeron un router Amper que por supuesto me falto tiempo para cambiarlo por mi wdr4300. Al wdr4300 le puse el firmware del primer post y el internet funcionaba de maravilla, pero el telefono no.

Me comentan los del servicio tecnico que la ONT le da telefono e internet al router y que el router le da telefono a la casa por la clavija de salida de telefono que tiene. De ser esto cierto no hay manera de quitar el router de movistar de la ecuacion, correcto?
Depende de la ONT que tengas.

En mi caso tengo la HG8420, por lo que el teléfono sale directamente de la ONT.
Sin embargo, he de decir que a mi me instalaron el Comtrend WAP-5813n, que no lleva puertos para la VOIP, por lo que puede que en tu caso la ONT no esté configurada para dicho fin.

Igual puedes activar los puertos de teléfono en la ONT y olvidarte del router de Movistar. ¿Qué ONT tienes?

Un saludo.

psikonetik

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #826 en: 29-04-2015, 12:32 (Miércoles) »
Exacto Noltari, el problema es justamente ese, mi ONT solo saca un eth que va al router y del router sale el telefono, es la gg-11000 edge-core.

Se me ocurren dos cosas,

Podría pedir una ONT diferente?

Podría configurar los moviles para que usasen la voip que sacase el wdr4300?

Muchas gracias!

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #827 en: 29-04-2015, 12:37 (Miércoles) »
Hola amigos,

Una cuestión de novato.
Recientemente me he pasado de ono a movistar fibra. Me trajeron un router Amper que por supuesto me falto tiempo para cambiarlo por mi wdr4300. Al wdr4300 le puse el firmware del primer post y el internet funcionaba de maravilla, pero el telefono no.

Me comentan los del servicio tecnico que la ONT le da telefono e internet al router y que el router le da telefono a la casa por la clavija de salida de telefono que tiene. De ser esto cierto no hay manera de quitar el router de movistar de la ecuacion, correcto?

¿Dónde estaba conectado antes el teléfono? Si va conectado a la ONT y sigue conectado a ella, no hay motivo para que deje de funcionar. Si estaba conectado al router, el WDR4300 no tiene puertos para teléfono, ¿dónde lo tienes conectado ahora?

Depende de la ONT que tengas.

En mi caso tengo la HG8420, por lo que el teléfono sale directamente de la ONT.
Sin embargo, he de decir que a mi me instalaron el Comtrend WAP-5813n, que no lleva puertos para la VOIP, por lo que puede que en tu caso la ONT no esté configurada para dicho fin.

Igual puedes activar los puertos de teléfono en la ONT y olvidarte del router de Movistar. ¿Qué ONT tienes?

Un saludo.

Yo también tengo esa ONT, y el teléfono también va conectado a la ONT. Pero también es cierto que el router que puso Movistar tiene puerto para teléfono, aunque no nunca se han usado, ni tengo claro que el router esté configurado para usarlo. Quizás estén migrando y ahora conecten el teléfono al router.

psikonetik

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #828 en: 29-04-2015, 12:41 (Miércoles) »
Antes yo tenia ono cable, la ONT no tiene salida de telefono, ese es el problema.
Pondran pegas al pedir cambio de ont? Que argumentos podría dar?

victormurgar

  • Visitante
Re:
« Respuesta #829 en: 29-04-2015, 13:22 (Miércoles) »
Puedes intentar pedir el cambio. Y sino te tocará comprar un adaptador que se conecta por ethernet al router y poniendo los datos VOIP de movistar te saca el teléfono por RJ11. O también puedes probar a ver si se puede configurar el router de movistar para que al conectarlo al que tienes suministre teléfono por el puerto RJ11, como se hace con Jazztel.

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #830 en: 30-04-2015, 16:06 (Jueves) »
Exacto Noltari, el problema es justamente ese, mi ONT solo saca un eth que va al router y del router sale el telefono, es la gg-11000 edge-core.

Se me ocurren dos cosas,

Podría pedir una ONT diferente?

Podría configurar los moviles para que usasen la voip que sacase el wdr4300?

Muchas gracias!

El router no tiene salida para teléfonos analógicos; aunque físicamente puedas pinchar un RJ11 en un RJ45, el hardware no está preparado.

Puedes pedir a Movistar una ONT diferente... ya nos dirás cómo te va. Supongo que también podrías comprar una de segunda mano, y tratar de replicar la configuración.

Desde cualquier móvil o tableta, sean Android o iOS, deberías poder usar la VoIP sin problemas; pero si vas a usar varios dispositivos, te interesa instalar Asterisk en el router y que haga de centralita. También hay adaptadores para poder conectar teléfonos analógicos a un servidor VoIP.

victormurgar

  • Visitante
Re:
« Respuesta #831 en: 01-05-2015, 00:03 (Viernes) »
No se si seré al único que me pasa pero desde que ayer, cuando añadieron LA 1 HD se ve correctamente pero a los 10 segundos se queda congelada la imagen, he probado con otros canales en HD y SD y funcionan correctamente sin congelaciones. Será que aún lo están probando? A alguien más le pasa?

Myckelon

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #832 en: 03-05-2015, 10:54 (Domingo) »
Hola a todos.

Despues de mucho leer y buscar por el foro y gracias a vuestra ayuda he conseguido configurar un poco el router.

He compilado el firmware y he instalado el script 18 de Noltari. Funciona perfecto.
Con respecto a la VPN que es donde tengo problemas. He instalado OpenVPN siguiendo el tutorial de ppfdez en el post 445 a 447.

Pero tengo varios problemas con la red. Me puedo conectar desde el wifi poniendo la red interna 192.168.1.1 y también puedo conectarme desde 3g con el movil cambiando la ip de acceso al servidor noip.com. Me autentifica y me da IP, puedo entrar a los equipos que tengo conectados en mi red en los dos supuestos. Pero no tengo acceso a internet y tampoco al VOIP. Ni en casa ni fuera. He buscado bastante pero no doy con la tecla.

Lo que busco es poder conectarme a mi Red desde fuera de casa, poder entrar al NAS (con OPENMEDIAVAULT), recibir llamadas de VOIP, y tambien conectarme al udpxy para ver movistar TV. (quiza sea demasiado  ;) )

Os dejo los ficheros de configuracion que tengo.

Citar

>>>etc/config/openvpn

config openvpn 'VPN'
   option enabled '1'
   option port '1194'
   option proto 'udp'
   option dev 'tun'
   option 'ca' '/etc/easy-rsa/keys/ca.crt'
        option 'cert' '/etc/easy-rsa/keys/VPN.crt'
        option 'key' '/etc/easy-rsa/keys/VPN.key'
        option 'dh' '/etc/easy-rsa/keys/dh2048.pem'
   option server '10.8.0.0 255.255.255.0'
   option ifconfig_pool_persist '/tmp/ipp.txt'
   list push 'route 192.168.1.0 255.255.255.0'
   list push 'dhcp-option DNS 192.168.1.1'
   option client_to_client '1'
   option keepalive '10 120'
   option comp_lzo 'yes'
   option max_clients '4'
   option persist_key '1'
   option persist_tun '1'
   option status '/tmp/openvpn-status.log'
   option log '/tmp/openvpn.log'
   option verb '3'
   option mute '20'
   option script_security '3'
   option auth_user_pass_verify '/etc/openvpn/pass.sh via-env'

>>>etc/config/firewall

config defaults
   option syn_flood '1'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'

config rule
   option name 'Allow-DHCP-Renew'
   option src 'wan'
   option proto 'udp'
   option dest_port '68'
   option target 'ACCEPT'
   option family 'ipv4'

config rule
   option name 'Allow-Ping'
   option src 'wan'
   option proto 'icmp'
   option icmp_type 'echo-request'
   option family 'ipv4'
   option target 'ACCEPT'

config rule
   option name 'Allow-DHCPv6'
   option src 'wan'
   option proto 'udp'
   option src_ip 'fe80::/10'
   option src_port '547'
   option dest_ip 'fe80::/10'
   option dest_port '546'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-ICMPv6-Input'
   option src 'wan'
   option proto 'icmp'
   list icmp_type 'echo-request'
   list icmp_type 'echo-reply'
   list icmp_type 'destination-unreachable'
   list icmp_type 'packet-too-big'
   list icmp_type 'time-exceeded'
   list icmp_type 'bad-header'
   list icmp_type 'unknown-header-type'
   list icmp_type 'router-solicitation'
   list icmp_type 'neighbour-solicitation'
   list icmp_type 'router-advertisement'
   list icmp_type 'neighbour-advertisement'
   option limit '1000/sec'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-ICMPv6-Forward'
   option src 'wan'
   option dest '*'
   option proto 'icmp'
   list icmp_type 'echo-request'
   list icmp_type 'echo-reply'
   list icmp_type 'destination-unreachable'
   list icmp_type 'packet-too-big'
   list icmp_type 'time-exceeded'
   list icmp_type 'bad-header'
   list icmp_type 'unknown-header-type'
   option limit '1000/sec'
   option family 'ipv6'
   option target 'ACCEPT'

config include
   option path '/etc/firewall.user'

config include 'miniupnpd'
   option type 'script'
   option path '/usr/share/miniupnpd/firewall.include'
   option family 'any'
   option reload '1'

config zone
   option name 'lan'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'ACCEPT'
   option network 'lan'

config zone
   option name 'wan'
   option input 'REJECT'
   option output 'ACCEPT'
   option forward 'REJECT'
   option masq '1'
   option mtu_fix '1'
   option network 'wan wan6'

config forwarding
   option src 'lan'
   option dest 'wan'

config zone
   option name 'iptv'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'
   option network 'iptv'
   option masq '1'

config forwarding
   option src 'lan'
   option dest 'iptv'

config forwarding
   option src 'iptv'
   option dest 'lan'

config zone
   option name 'voip'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'
   option network 'voip'
   option masq '1'

config forwarding
   option src 'lan'
   option dest 'voip'

config rule 'udpxy'
   option target 'ACCEPT'
   option src 'wan'
   option proto 'tcp udp'
   option dest_port '4022'
   option name 'udpxy'

config forwarding
        option src 'VPN'
        option dest 'wan'

config rule
   option target 'ACCEPT'
   option src 'lan'
   option dest 'vpn'
   option name 'LANtoVPN'
   option proto 'all'

config rule
   option target 'ACCEPT'
   option name 'VPNtoLAN'
   option src 'vpn'
   option dest 'lan'
   option proto 'all'

config rule
   option target 'ACCEPT'
   option src 'wan'
   option proto 'udp'
   option dest_port '1194'
   option name 'OpenVPN'

config zone
   option name 'vpn'
   option input 'ACCEPT'
   option forward 'REJECT'
   option output 'ACCEPT'
   option network 'VPN'

>>>etc/firewall.user

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.


iptables -t nat -A prerouting_wan -p udp --dport 1194 -j ACCEPT
iptables -A input_wan -p udp --dport 1194 -j ACCEPT

iptables -I INPUT -i tun+ -j ACCEPT
iptables -I FORWARD -i tun+ -j ACCEPT
iptables -I OUTPUT -o tun+ -j ACCEPT
iptables -I FORWARD -o tun+ -j ACCEPT




kevloral

  • Visitante
Re:
« Respuesta #833 en: 04-05-2015, 03:29 (Lunes) »
No se si seré al único que me pasa pero desde que ayer, cuando añadieron LA 1 HD se ve correctamente pero a los 10 segundos se queda congelada la imagen, he probado con otros canales en HD y SD y funcionan correctamente sin congelaciones. Será que aún lo están probando? A alguien más le pasa?

No, no eres el único y no, no lo están probando. Lo que ocurre es que ese canal llega desde una IP situada en una subred distinta a las demás. En mi caso, los canales llegan desde la 172.26.0.0/16, excepto la 1 HD, que llega desde la 172.23.0.0/16. Imagino que habrán enviado a los routers que pone Movistar un nuevo fichero de configuración con esa otra red (yo la he descubierto mediante un mero tcpdump en la vlan2).

No hay más que añadir la nueva red a la configuración para que deje de congelarse (yo lo he hecho hace un rato a la mía y ya funciona bien).

Saludos.
« Última modificación: 04-05-2015, 03:32 (Lunes) por kevloral »

Myckelon

  • Visitante
Re: Re:
« Respuesta #834 en: 04-05-2015, 07:02 (Lunes) »
No se si seré al único que me pasa pero desde que ayer, cuando añadieron LA 1 HD se ve correctamente pero a los 10 segundos se queda congelada la imagen, he probado con otros canales en HD y SD y funcionan correctamente sin congelaciones. Será que aún lo están probando? A alguien más le pasa?

No, no eres el único y no, no lo están probando. Lo que ocurre es que ese canal llega desde una IP situada en una subred distinta a las demás. En mi caso, los canales llegan desde la 172.26.0.0/16, excepto la 1 HD, que llega desde la 172.23.0.0/16. Imagino que habrán enviado a los routers que pone Movistar un nuevo fichero de configuración con esa otra red (yo la he descubierto mediante un mero tcpdump en la vlan2).

No hay más que añadir la nueva red a la configuración para que deje de congelarse (yo lo he hecho hace un rato a la mía y ya funciona bien).

Saludos.
Pues a mi me pasaba el otro dia pero al enredar con la VPN. Le pase el ultimo scrip de Noltari el 18 y ya se ve perfecto. Antes tenia el 16 me parece recordar.

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #835 en: 04-05-2015, 07:39 (Lunes) »
Hola a todos.

Despues de mucho leer y buscar por el foro y gracias a vuestra ayuda he conseguido configurar un poco el router.

He compilado el firmware y he instalado el script 18 de Noltari. Funciona perfecto.
Con respecto a la VPN que es donde tengo problemas. He instalado OpenVPN siguiendo el tutorial de ppfdez en el post 445 a 447.

Pero tengo varios problemas con la red. Me puedo conectar desde el wifi poniendo la red interna 192.168.1.1 y también puedo conectarme desde 3g con el movil cambiando la ip de acceso al servidor noip.com. Me autentifica y me da IP, puedo entrar a los equipos que tengo conectados en mi red en los dos supuestos. Pero no tengo acceso a internet y tampoco al VOIP. Ni en casa ni fuera. He buscado bastante pero no doy con la tecla.

Lo que busco es poder conectarme a mi Red desde fuera de casa, poder entrar al NAS (con OPENMEDIAVAULT), recibir llamadas de VOIP, y tambien conectarme al udpxy para ver movistar TV. (quiza sea demasiado  ;) )

Os dejo los ficheros de configuracion que tengo.

Citar
[...]

Me falta el /etc/config/network para estar seguro, pero creo que te faltan las reglas para permitir el tráfico desde la red VPN hacia la red VoIP. Tienes las reglas que permiten el tráfico desde la VPN a la WAN y a la LAN, o desde la LAN a la VoIP; fíjate cómo son, y trata de replicarlas.

Myckelon

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #836 en: 04-05-2015, 17:37 (Lunes) »
Hola a todos.

Despues de mucho leer y buscar por el foro y gracias a vuestra ayuda he conseguido configurar un poco el router.

He compilado el firmware y he instalado el script 18 de Noltari. Funciona perfecto.
Con respecto a la VPN que es donde tengo problemas. He instalado OpenVPN siguiendo el tutorial de ppfdez en el post 445 a 447.

Pero tengo varios problemas con la red. Me puedo conectar desde el wifi poniendo la red interna 192.168.1.1 y también puedo conectarme desde 3g con el movil cambiando la ip de acceso al servidor noip.com. Me autentifica y me da IP, puedo entrar a los equipos que tengo conectados en mi red en los dos supuestos. Pero no tengo acceso a internet y tampoco al VOIP. Ni en casa ni fuera. He buscado bastante pero no doy con la tecla.

Lo que busco es poder conectarme a mi Red desde fuera de casa, poder entrar al NAS (con OPENMEDIAVAULT), recibir llamadas de VOIP, y tambien conectarme al udpxy para ver movistar TV. (quiza sea demasiado  ;) )

Os dejo los ficheros de configuracion que tengo.

Citar
[...]

Me falta el /etc/config/network para estar seguro, pero creo que te faltan las reglas para permitir el tráfico desde la red VPN hacia la red VoIP. Tienes las reglas que permiten el tráfico desde la VPN a la WAN y a la LAN, o desde la LAN a la VoIP; fíjate cómo son, y trata de replicarlas.

Te dejo el etc/config/network no veo que puedo replicar aqui. Gracias Eduperez.

Código: [Seleccionar]


config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd89:1329:0f1e::/48'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 2 3 4 5'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 1t'

config switch_vlan
option device 'switch0'
option vlan '3'
option ports '0t 1t'

config switch_vlan
option device 'switch0'
option vlan '6'
option ports '0t 1t'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ip6assign '60'
option igmp_snooping '1'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'iptv'
option ifname 'eth0.2'
option proto 'static'
option ipaddr '10.255.231.6'
option netmask '255.128.0.0'
option gateway '10.128.0.1'
option defaultroute '0'
option peerdns '0'

config interface 'voip'
option ifname 'eth0.3'
option proto 'dhcp'
option defaultroute '0'
option peerdns '0'

config interface 'wan'
option ifname 'eth0.6'
option proto 'pppoe'
option username 'adslppp@telefonicanetpa'
option password 'adslppp'
option ipv6 '1'

config interface 'wan6'
option ifname 'wan'
option proto 'dhcpv6'

config route
option interface 'iptv'
option target '172.26.0.0'
option netmask '255.255.0.0'
option gateway '10.128.0.1'

config interface 'VPN'
option proto 'none'
option _orig_ifname 'tun0'
option _orig_bridge 'true'
option ifname 'tun0'



eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #837 en: 04-05-2015, 20:49 (Lunes) »
Te dejo el etc/config/network no veo que puedo replicar aqui. Gracias Eduperez.

No aquí no tienes nada que replicar; te lo he pedido para echarle un vistazo. Te comentaba que deberías replicar en /etc/config/firewall las reglas que tienes para acceder de VPN a LAN, pero cambiándolas para acceder de VPN a VoIP.

Por ejemplo, si ahora tienes:
Código: [Seleccionar]
config forwarding
        option src 'VPN'
        option dest 'wan'

config rule
   option target 'ACCEPT'
   option name 'VPNtoLAN'
   option src 'vpn'
   option dest 'lan'
   option proto 'all'

Entiendo que te falta:
Código: [Seleccionar]
config forwarding
        option src 'VPN'
        option dest 'voip'

config rule
   option target 'ACCEPT'
   option name 'VPNtoVoIP'
   option src 'vpn'
   option dest 'voip'
   option proto 'all'

De todas formas, yo no tengo ese segundo bloque "config rule", sólo el primer "config forwarding"; pero si así te funciona, bienvenido sea.

Fuguet

  • Visitante
Re: Re:
« Respuesta #838 en: 05-05-2015, 01:35 (Martes) »
No se si seré al único que me pasa pero desde que ayer, cuando añadieron LA 1 HD se ve correctamente pero a los 10 segundos se queda congelada la imagen, he probado con otros canales en HD y SD y funcionan correctamente sin congelaciones. Será que aún lo están probando? A alguien más le pasa?

No, no eres el único y no, no lo están probando. Lo que ocurre es que ese canal llega desde una IP situada en una subred distinta a las demás. En mi caso, los canales llegan desde la 172.26.0.0/16, excepto la 1 HD, que llega desde la 172.23.0.0/16. Imagino que habrán enviado a los routers que pone Movistar un nuevo fichero de configuración con esa otra red (yo la he descubierto mediante un mero tcpdump en la vlan2).

No hay más que añadir la nueva red a la configuración para que deje de congelarse (yo lo he hecho hace un rato a la mía y ya funciona bien).

Saludos.
Pues a mi me pasaba el otro dia pero al enredar con la VPN. Le pase el ultimo scrip de Noltari el 18 y ya se ve perfecto. Antes tenia el 16 me parece recordar.

Muy buenas;

Otro más que se une a la causa de la nueva enredada de la 1HD..., también afecta a Teledeporte HD. No he usado el script, lo he realizado "toqueteandole" un poco la moral...

En mi gargoyle puedo ver esto:



Lo más importante es añadir esta nueva red al proxy de IGMP, en mi caso al usar IGMPProxy, tenía puesto:

Código: [Seleccionar]
config phyint
        option network iptv
        option direction upstream
        list altnet 172.26.0.0/16
        list altnet 192.168.2.1/24

Y le añadí:

Código: [Seleccionar]
vi /etc/config/igmpproxy

config phyint
        option network iptv
        option direction upstream
        list altnet 172.26.0.0/16
        list altnet 172.23.0.0/16
        list altnet 192.168.2.1/24

Luego le puse la ruta estática en network:

Código: [Seleccionar]
vi /etc/config/network

config route
        option interface 'iptv'
        option target '172.23.0.0'
        option netmask '255.255.0.0'
        option gateway 'W.X.Y.Z'

Te "rebotas" con el router y si ves el canal bien con más o menos un minutillo de tiempo, señal de que ya se le ha quitado el enfado :P

A ver que sorpresita nos dan de más... a parte de cobrarnos 5 fistros de más por la pata floja...
« Última modificación: 05-05-2015, 01:37 (Martes) por Fuguet »

Myckelon

  • Visitante
Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #839 en: 05-05-2015, 07:11 (Martes) »
Te dejo el etc/config/network no veo que puedo replicar aqui. Gracias Eduperez.

No aquí no tienes nada que replicar; te lo he pedido para echarle un vistazo. Te comentaba que deberías replicar en /etc/config/firewall las reglas que tienes para acceder de VPN a LAN, pero cambiándolas para acceder de VPN a VoIP.

Por ejemplo, si ahora tienes:
Código: [Seleccionar]
config forwarding
        option src 'VPN'
        option dest 'wan'

config rule
   option target 'ACCEPT'
   option name 'VPNtoLAN'
   option src 'vpn'
   option dest 'lan'
   option proto 'all'

Entiendo que te falta:
Código: [Seleccionar]
config forwarding
        option src 'VPN'
        option dest 'voip'

config rule
   option target 'ACCEPT'
   option name 'VPNtoVoIP'
   option src 'vpn'
   option dest 'voip'
   option proto 'all'

De todas formas, yo no tengo ese segundo bloque "config rule", sólo el primer "config forwarding"; pero si así te funciona, bienvenido sea.
Gracias eduperez. Luego probare a ver si por lo menos conecta el voip y el vlc. Aunque con esto no creo que se solucione la salida a internet.

Tambien he probado a añadir en la configuracion del openvpn la linea.

List-push redirect-gateway def1

Y tampoco he conseguido salir a internet.