Autor Tema: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt  (Leído 320640 veces)

0 Usuarios y 1 Visitante están viendo este tema.

b82cargi

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #200 en: 31-12-2013, 17:54 (Martes) »
en la parte 1 punto 2, a mi no me sale la opción de "Accept router advertisements". Y también al final de la primera parte cuando te vas a status para ver el estado, el apartado de network está "not connected" y en el apartado de DHCP Leases pone "there are no active leases".

Espero que me podais ayudar, gracias de antemano



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4585
Re:
« Respuesta #201 en: 31-12-2013, 19:24 (Martes) »
Y qué quieres hacer, conectar como cliente o qué .... ?



Enviado desde mi CUBOT GT99 usando Tapatalk
Valoraciones positivas en compra/venta:
130 en Htcmania
174 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

victor_ffm

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #202 en: 31-12-2013, 20:43 (Martes) »
se podria instalar el firmware del alfa R36 al alfa ap121u ? como se podria hacer ?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4585
Re: Re: Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #203 en: 31-12-2013, 22:56 (Martes) »
se podria instalar el firmware del alfa R36 al alfa ap121u ? como se podria hacer ?

Y eso que tiene que ver con el tema del hilo ?

Enviado desde mi CUBOT GT99 usando Tapatalk
Valoraciones positivas en compra/venta:
130 en Htcmania
174 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

b82cargi

  • Visitante
Re:
« Respuesta #204 en: 31-12-2013, 23:02 (Martes) »
Y qué quieres hacer, conectar como cliente o qué .... ?



Enviado desde mi CUBOT GT99 usando Tapatalk
lo que quiero es utilizarlo como repetidor

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4585
Re: Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #205 en: 01-01-2014, 00:57 (Miércoles) »
Y tu hg556a tiene WiFi atheros ?

Enviado desde mi CUBOT GT99 usando Tapatalk
Valoraciones positivas en compra/venta:
130 en Htcmania
174 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

b82cargi

  • Visitante
Re: Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #206 en: 02-01-2014, 00:35 (Jueves) »
Y tu hg556a tiene WiFi atheros ?

Enviado desde mi CUBOT GT99 usando Tapatalk
si

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4585
Re: Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #207 en: 02-01-2014, 14:13 (Jueves) »
Y tu hg556a tiene WiFi atheros ?

Enviado desde mi CUBOT GT99 usando Tapatalk
si

Pues si sigues el tutorial, paso a paso, debería funcionarte sin ningún tipo de problema  ^-^
Valoraciones positivas en compra/venta:
130 en Htcmania
174 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

b82cargi

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #208 en: 02-01-2014, 20:14 (Jueves) »
en la parte 1 punto 2, a mi no me sale la opción de "Accept router advertisements". Y también al final de la primera parte cuando te vas a status para ver el estado, el apartado de network está "not connected" y en el apartado de DHCP Leases pone "there are no active leases".

Espero que me podais ayudar, gracias de antemano
esto es lo que me pasa por eso no me sale

krinda3

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #209 en: 10-02-2014, 23:05 (Lunes) »
Hola Noltari, muy bueno este tutorial,
tengo un problema, hasta el paso 2 va todo perfecto, pero en el paso tres no me salen las dis wifi concectadas. Me sale que la wifi esta descectada o no asociada.
Tengo un route nuevo 1043ND version 2.1 con el openwrt instalado y actualizado.
Sabes que puede pasar?
Muchas gracias de antemano

danymarc

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #210 en: 18-02-2014, 14:13 (Martes) »
Cita de: krinda3
hasta el paso 2 va todo perfecto, pero en el paso tres no me salen las dis wifi concectadas.
En El Paso 2 termina. modo repetidor sobre cliente enrutado,  el paso 3 es otra configuración completamente diferente es WDS, lo que podría estarte pasando es que al terminar paso 1 prueba cliente enrutado, regresa la Lap a Ip dinámica y debes tener internet vía cable Lan, ahora si lo que deseas es wireless al empezar paso 2 ignora
Si existe una segunda configuración para la interfaz radio0, eliminarla. si lo haces pierdes todo el paso #1
« Última modificación: 18-02-2014, 14:15 (Martes) por danymarc »

krinda3

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #211 en: 18-02-2014, 23:31 (Martes) »
Muchas gracias Dynamarc. A ver si me puedes ayudar. Ya tengo acceso pero conectando el ordenador por cable al router que a su vez de conecta por wireless al routr principal. Como debo seguir para acceder al router por wireless en lugar de hacerlo por cable?
Gracias de antemano

danymarc

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #212 en: 19-02-2014, 03:41 (Miércoles) »
Cita de: krinda3
Ya tengo acceso pero conectando el ordenador por cable al router que a su vez de conecta por wireless al routr principal. Como debo seguir para acceder al router por wireless en lugar de hacerlo por cable?
Lo q entiendo es q ya terminaste la parte #1, modo cliente enrutado. ahora tienes q crear el VAP, (virtual Acces point) la Parte 2 :: Modo repetidor sobre cliente enrutado, escoge 1A o 1B depende cuantas tarjetas tiene tu router, quiero suponer una, si es así continúa con 1B, recuerda mi post anterior no vayas a hacer este paso Si existe alguna configuración para la interfaz radio1, eliminarla o pierdes la parte 1, al terminar la parte 2 busca con la tarjeta wifi de tu Lap la nueva red ( el nombre q le hayas dado) o el default OpenWrt.

krinda3

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #213 en: 23-02-2014, 22:12 (Domingo) »
Hola Danymarc, muchas gracias por las sugerencias. Voy a ver si soy un poco mas explicito para que me podáis ayudar.

Yo creo que ya tengo el modo cliente enrutado. O sea la parte 1.
 
La red del router con acceso a internet es 192.168.1.1. El 1043ND tiene direccion 192.168.1.41 con el router primario a traves de una wifi llamada WLAN
La red que quiero conectar al 1043ND es 192.168.2.1
El PC con el que trabajo esta conectado al 1043ND por cable y tiene direcion 192.168.2.31

Puedo conectar el 1043ND tanto por la direccion 192.168.1.41 como por la 192.168.2.1
Si hago la Parte 2 :: Modo repetidor sobre cliente enrutado conectado a 192.168.1.41 al aplicar los cambios pierdo la conexion

Si hago la Parte 2 :: Modo repetidor sobre cliente enrutado conectado a 192.168.2.1 los cambios se aplican bien pero no aparece señal ni el la wifi WLAN ni en la wifi OPENWRT.


Espero que con esta informacion puedas hacerte una idea mejor de lo que quiero y me descubrr lo que estoy haciendo mal

Muchas gracias

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1953
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #214 en: 24-02-2014, 08:51 (Lunes) »
No sé si me estoy equivocando, pero lo que quieres hacer ¿no es pasar los datos que le llegan por la inalámbrica al router al cable y viceversa teniendo las dos redes subredes distintas? ¿Eso no se consigue haciendo un puente con relayd?

Relayd sin traumas (configuración gráfica desde LuCi)
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

GLaDOS

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #215 en: 24-02-2014, 09:50 (Lunes) »
No se si puedo aportar algo, pero bueno, ha sido mi experiencia:

Agarré de la red un sinfín de tutoriales, que si WDS que si relayd... A día de hoy todavía no tengo muy claro lo que viene siendo.

Configuré la interfaz LAN en el rango 192.168.2.x, me peleé MUCHÍSIMO para que LuCI reconociera el Adaptador Wireless USB y una vez conseguido (danitool, Noltari, espeltron y alguno más puede dar fe de lo que les dí la vara) tras un Escaneo pude asociar asociar el AR9271 (Alfa Negra) a la red objetivo (Abierta, no os asustéis con lo de objetivo), creando la interfaz WAN.

Asombrosamente, desde la LAN se podía acceder sin problemas a Internet.

El único problema que tengo es la inestabilidad. Al principio, sufría caídas cada 20-30 min lo cual era una jodienda porque no podía acabar de ver ni un capítulo entero dese pelisalacarta en la RPi. Tras pruebas con la localización de la antena la cosa mejoró, con conexiones estables de hasta 50 min de duración.

Tras cada caída hay que acceder al Router y Re-Conectar la interfaz WAN.

Las caídas entiendo que se deben a la naturaleza intrínseca del Wireless. Como yo digo, cuando estás lanzando Bits al aire, alguno se te pierde por el camino.

Me planteé que fuese cuestión de las cesiones DHCP, así que intenté configurar la WAN con IP Fija pero esto me imposibilitaba el reenvio de DNS a la interfaz WAN, así abandoné esa opción y por otro lado también me di cuenta de que no podía ser cuestión de cesiones DHCP TAN sumamente cortas.

Dado que supongo que la cosa es del Wireless, una mejora de Antena debería mejorar esto, teniendo en cuenta que ahora estamos tirando con la Alfa Negra pegadita con su ventosa a la ventana y una Antena Omni de 8-9 dbi's.

Con una antena direccional (no sé si sectorial, planar o parabólica, creo que lo más adecuado para este caso sería planar, por favor, si alguien puede darme una pequeña directriz a pesar de que entiendo que no sea el tema adecuado lo agradecería mucho) debería mejorar bastante la cosa.

A pesar de eso, no creo que eso resolviera el tema al 100%, un camión pasando por la calle (estamos hablando de pueblo de casa baja) podría provocar una caída. Por otro lado, a pesar de las caídas, la navegación es PERFECTA, os confirmo que los streamings en la RPi han ido de lujo - hasta que se cae y te jodes, claro :-\ - .

Es por eso que razono que no debería ser muy complicado hacer un pequeño script que cada... 5-10 segundos compruebe que la interfaz WAN esté conectada y en el momento que la detecte caída, la vuelva a levantar.

Ya os digo que no me tiene pinta de ser algo muy complicado, pero es que no tengo ni idea de como programar eso, ni de donde se 'mete' ese script en OpenWRT y os JURO, que buscando en toda la red, en el foro, en otros foros (soy un poco promiscua  >:D ) e incluso tanto en cristiano como en inglés, no  he encontrado a NADIE hablando sobre re-conexión de la interfaz WAN en OpenWRT.

Tampoco sé si una configuración óptima solucionaría esto, quizás vosotros que tenéis más experiencia podáis alumbrarme.

Así que si alguien tiene alguna pista... Vendría como agua de mayo. ;) ;)

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1953
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #216 en: 24-02-2014, 10:57 (Lunes) »
Es por eso que razono que no debería ser muy complicado hacer un pequeño script que cada... 5-10 segundos compruebe que la interfaz WAN esté conectada y en el momento que la detecte caída, la vuelva a levantar.

Ya os digo que no me tiene pinta de ser algo muy complicado, pero es que no tengo ni idea de como programar eso, ni de donde se 'mete' ese script en OpenWRT y os JURO, que buscando en toda la red, en el foro, en otros foros (soy un poco promiscua  >:D ) e incluso tanto en cristiano como en inglés, no  he encontrado a NADIE hablando sobre re-conexión de la interfaz WAN en OpenWRT.

Tampoco sé si una configuración óptima solucionaría esto, quizás vosotros que tenéis más experiencia podáis alumbrarme.

Así que si alguien tiene alguna pista... Vendría como agua de mayo. ;) ;)

He encontrado esto en la sección 3G de openwrt y tiene un script para reconectar la WAN cuando detecta que no hace ping. No es exactamente lo que buscas pero con un poco de edición se puede hacer perfectamente: http://wiki.openwrt.org/doc/recipes/3gdongle. Está casi al final. El script relevanta el interfaz caído si no detecta un ping a un host y el cron lo ejecuta cada pocos segundos, que es lo que tú querías, ¿no?  ;)
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

GLaDOS

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #217 en: 24-02-2014, 12:03 (Lunes) »
Sííííííííí Tki2000... Te voy a dedicar un TK2000 juasss...


En serio, 1 mes entero buscando. Gracias a dios, ahora a 'adaptarlo'.

 >:( >:( >:( >:(

GLaDOS

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #218 en: 01-03-2014, 14:19 (Sábado) »

El sript en bash que tengo funcionando es este.

Código: [Seleccionar]
#!/bin/sh
if ! ping -q -c 1 -W 10 -I wwan 192.168.x.x > /dev/null; then
(ifup wwan; sleep 5;) &
fi

Aún tengo que estudiar un post más extenso en ucraniano del que creo que podré hacer un tuto para reconectar diferentes interfaces. (Modems y Aparatos WirelesS)

aroca46

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #219 en: 02-03-2014, 15:59 (Domingo) »
Pero tengo un problema, todo bien hasta el paso Parte 2 -> 1b, tengo el comtrend configurador por wifi al router principal, el caso es que cuando voy al paso 1b y sigo los pasos para crear un punto de acceso y lo creo, se me vuelve todo mal, es decir tendria que quedar dos conexiones el "Client y el Master" como muestra el punto 3b, pero yo tengo el "Client" y cuando voy a crear el "Master" pam se vuelven los dos "client"...¿Que puede ser? nose si me habre explicado bien...