Autor Tema: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt  (Leído 321593 veces)

0 Usuarios y 3 Visitantes están viendo este tema.

edudi

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #140 en: 16-06-2013, 19:06 (Domingo) »
Muchísimas gracias jar229, ha sido cuestión de ponerle el firmware que compartiste y con la misma funcionó todo OK, siguiendo el tutorial paso por paso del comienzo de este hilo. Por cierto ese firmware ocupa un fisco más que el de la página oficial del Open WRT, que tiene alguna modificación o mejora?

Quiero destacar por si a alguien le pasa, que en este router ni se les ocurra poner el firmware de la versión 12.03 beta 2, no es que vaya lenta la interfaz WEB, sino 5 veces lo siguiente..., vía telnet y shh por suerte va bien (faltaría más).

IMP: Otra cosa que me costó horrores fue poder cargarle el firmware Backfire 10.03.1, vía web con la 12.03 beta 2 siempre daba error de que no respondía el router, la forma como lo conseguí fue la básica (IP 192.168.1.50, MASK 255.255.255.0, apagar router, dejar apretado el reset y sin soltar encender router, dejarlo apretado 15sg y entrar en la puerta de enlace 192.168.1.1)

Lo comento porque la primera vez que le cargué el firmware fue super sencillo desde la interfaz WEB original del router, pero luego no había forma de volver a cargarle otro, así que intentaba vía telnet y SSH (ya que vía WEB no había forma) introducirle el firmware y me volvía loco. Como algo positivo, aprendí a moverme en el router vía comandos de linux y algunos concretos (SCP, MTD) y con el WINSCP (para pasar el archivo .bin), pero ni aún así conseguí cargarle el firmware.

Gracias a todos por compartir y llegar a estos avances.


PD: La interfaz WEB con el Backfire va perfecta y rápida, tal como uno está acostumbrado a moverse por las páginas de la configuración de un router.



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #141 en: 16-06-2013, 19:33 (Domingo) »
Muchísimas gracias jar229, ha sido cuestión de ponerle el firmware que compartiste y con la misma funcionó todo OK, siguiendo el tutorial paso por paso del comienzo de este hilo. Por cierto ese firmware ocupa un fisco más que el de la página oficial del Open WRT, que tiene alguna modificación o mejora?


En routers con poca RAM y CPU's poco potentes, como en este caso, lo ideal es no usar versiones de OpenWrt posteriores a Backfire.

Me alegro que hayas notado tanta mejora  ;)

En cuanto a la diferencia de tamaño ... puede ser desde un paquete no incluído en la versión oficial, hasta ...  ^-^
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

pikomule

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #142 en: 04-10-2013, 13:36 (Viernes) »
Modo cliente en router AR-5387un. No lo consigo

Version instalada: OpenWrt Barrier Breaker r37180

Lo hago tal cual el tutorial, pero no hay manera.

Lo unico que no he encontrado en esta version de openwrt es:
Accept router advertisements: sí

Wlan0 me da como conectado y coge IP correctamente en el mismo rango que el router principal. Mi pc conectado por red coge IP en el rango 192.168.2.xxx tal como indica el tuto.

No se en que fallo

Edit:
Acabo de comprobar que desde el movil (conectado al router principal), puedo acceder al router con OPENWRT, poniendo en el navegador 192.168.1.104 (que es la ip asignada en DHCP por el router principal).

No entiendo por que con cable de red no consigo internet, si realmente esta bien conectado

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #143 en: 04-10-2013, 13:49 (Viernes) »
Cómo tienes configurada la parte LAN del ar5387un ?

No te habrás olvidado de poner el servidor DNS ?

En el PC que conectas por cable, qué datos recibes (puedes verlo con ipconfig /all si usas windows) del servidor DHCP del ar5387un ?
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

pikomule

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #144 en: 04-10-2013, 14:21 (Viernes) »
En interfaces, WWAN me sale en rojo, aunque está conectado al wifi.

El LAN en openwrt lo tengo asi:
IPv4 address 192.168.2.99
IPv4 netmask 255.255.255.0
Use custom DNS servers 8.8.8.8
IPv6 assignment length disabled
Dynamic DHCP Activado


Adaptador Ethernet Conexión de área local 2          :

        Sufijo de conexión específica DNS : lan
        Descripción. . . . . . . . . . .  : Realtek PCIe FE Family Controller
        Dirección física. . . . . . . . . : B8-70-F4-xx-xx-xx
        DHCP habilitado. . . . . . . . .  : No
        Autoconfiguración habilitada. . . : Sí
        Dirección IP. . . . . . . . . . . : 192.168.2.170
        Máscara de subred . . . . . . . . : 255.255.255.0
        Puerta de enlace predeterminada   : 192.168.2.99
        Servidor DHCP . . . . . . . . . . : 192.168.2.99
        Servidores DNS . . . . . . . . . .: 192.168.2.99


Tambien he cambiado los datos a manual en el pc a:
192.168.2.170
255.255.255.0
192.168.1.1 (puerta de enlace)
8.8.8.8 (DNS)

De ninguna manera consigo ping desde 192.168.1.1 y mucho menos internet

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #145 en: 04-10-2013, 14:32 (Viernes) »
Presupongo que no estás usando relayd, verdad ? Así que tienes claro que los equipos de ambas subredes no van a poder 'verse' totalmente ...

Partiendo de ahí, debes modificar en el apartado LAN lo siguiente en el ar5387un:

IPv4 address 192.168.2.1
IPv4 netmask 255.255.255.0
Use custom DNS servers 8.8.8.8
Gateway IP 192.168.1.1 (esto es lo que te faltaba añadir)

A partir de ahí, y una vez que hayas aplicado los cambios, para acceder al ar5387un deberás hacerlo por la IP 192.168.2.1

Todos los equipos que le conectes por cable, tendrán una IP del rango 192.168.2.x

Y te insisto, sin usar relayd, sólo los equipos que estén detras del ar587un podrán ver a los que estén conectados al router principal. Al revés, no funcionará.
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

pikomule

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #146 en: 04-10-2013, 14:47 (Viernes) »
Lo del Relayd no se que es ni donde se activa.

Lo he hecho tal cual y sigo igual. No accedo a ninguna pagina

El firewall lo desintale por si era el problema y nada.

He probado a acceder al router openwrt (sincables de red de por medio) desde el portatil (con la IP asignada por el router principal) y accedo sin problemas y puedo actualizar la lista de programas en la seccion Software, por lo que el router tiene internet, pero no me comparte por LAN

« Última modificación: 04-10-2013, 14:48 (Viernes) por pikomule »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #147 en: 04-10-2013, 15:00 (Viernes) »
Pues si desde la red principal, puedes acceder a el y actualizar paquetes ... es que hay algún tipo de lío en las interfaces.

Yo lo reiniciaría a los valores iniciales (desde LuCi) y empezaría desde 0.
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

pikomule

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #148 en: 04-10-2013, 15:08 (Viernes) »
dentro de cada interface, en los apartados Physical Settings y Firewall Settings como debe estar?


Lo tengo asi en LAN:
Physical Settings
=============
Bridge interfaces Activado
Y seleccionada solamente la casilla "VLAN Interface: "eth0.1" (lan)"

Firewall Settings
=============
Seleccionado "lan"

Asi en WWAN:
Physical Settings
=============
Solo seleccionado "Wireless Network: Client "MIWIFI" (wwan) "

Firewall Settings
=============
Seleccionado "wwan"

Es correcto?

pikomule

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #149 en: 04-10-2013, 15:37 (Viernes) »
Router reseteado, hecho desde el principio todo y ya funciona. No se cual seria el problema.  

Gracias jar229

La velocidad como cliente es normal que sea tan lenta?

EDIT: he reiniciado y ya va bien rapido internet.

« Última modificación: 04-10-2013, 15:44 (Viernes) por pikomule »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: Re: Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #150 en: 04-10-2013, 16:41 (Viernes) »
Router reseteado, hecho desde el principio todo y ya funciona. No se cual seria el problema.  

Gracias jar229

La velocidad como cliente es normal que sea tan lenta?

EDIT: he reiniciado y ya va bien rapido internet.

Algún lío con las interfaces ... :D

Enviado desde mi CUBOT GT99 usando Tapatalk
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

brunorro

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #151 en: 09-10-2013, 15:28 (Miércoles) »
Buenas !!

Ante todo, perdonad por mi laaaarga ausencia: no he tenido tiempo de trastear con mi ARV4518PW y he estado entretenido en otras cosas, más mundanas y menos divertidas (bueno, alguna más divertida) que OpenWRT.

Resulta que un buen amigo se me ha mudado de piso y ha cambiado de proveedor de internet. Para desgracia de mi colega han puesto telefónica fusión, pero es porque en el pueblo de la muchacha sólo hay cobertura con vomistar. Bueno, el internet lo paga ella así que mi colega tampoco sale perdiendo tanto :rolleye:

El piso hace unas 3 veces el anterior y las paredes no son pladur precisamente (piso de mediados del siglo XX) y tienen el router en una punta del piso (recordemos: internet lo paga ella y quiere un cable en su ordenador, mujer inteligente), así que la wireless no llega para los móviles en la otra punta del piso.

Antaño esta gente estaba utilizando Jazztel, así que les estoy reconfigurando su antiguo router (Comtrend ar-5387un) para que lo utilicen para este menester. Consume (el transformador indica) aproximadamente unos 12 Watts, así que mantenerlo encendido un año no debería pasar de los 20 euros de electricidad. El trastillo tiene un chipset broadcom soportado por OpenWRT, así que les he sacado el openwrt ya compilado en seguridadwireless (MIL GRACIAS), aunque no descarto que algún día tenga que  compilarles un firm nuevo. Funciona a la perfección. OTRAS MIL GRACIAS.

Ahora estoy pensando en montar un pseudo-bridge o una segunda red enrutada  (con RIP, me niego a hacer nada más complicado para una entrada) hacia la otra red.

Y ahora me surgen algunas dudas:

- En mi falta de conocimiento, poniendo el mismo SSID/password en los dos Access points los clientes se asociarán automáticamente al AP que les de mejor señal, aunque supongo que hay un delay para ello... O cambiaría de AP de manera "transparente" ? Caso práctico: imaginad que estáis descargando un vídeo que os envían vía Whatsapp mientras camináis (cambiando la cobertura de un AP al otro)

- El router de Telefónica es el homestation, pero no creo que el WDS de broadcom funcione directamente con él, amén que por lo que he leído sólo el módulo propietario brcm-2.4 lo acepta.

- Veo que montando una segunda red habría problemas porque habría un cambio de IP si hay cambio de AP ... El ejemplo del vídeo del whatsapp cascaría previamente ?

- El pseudobridge (con relayd) me llama la atención en sobremanera y parece un buen negocio. Pero para acceder al repetidor podría ponerle una IP estática en el rango del otro AP ? Lo digo para aprovechar el cliente transmission del router en toda la red. En esta imagen me refiero a que si asigno la 192.168.1.30 como estática me dejaría entrar directamente al repetidor desde ambos lados:



Ya sé que transmission via wireless no es lo mejor, pero es un "regalo" añadido a mi colega.

Bueno, tenga respuesta o no os contaré qué tal me va la cosa y lo que consigo.

Gracias de nuevo

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #152 en: 09-10-2013, 18:24 (Miércoles) »
Lo que no entiendo, es cómo piensas unir el Homestation y el ar5387un con OpenWrt.

Este router, a no ser que le metas un pincho wifi USB sólo puedes usarlo en modo cliente, no como repetidor (cliente + AP).

Casi seguro que por WDS tampoco podrás enlazarlos.

Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

brunorro

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #153 en: 09-10-2013, 19:36 (Miércoles) »
Lo que no entiendo, es cómo piensas unir el Homestation y el ar5387un con OpenWrt.

Este router, a no ser que le metas un pincho wifi USB sólo puedes usarlo en modo cliente, no como repetidor (cliente + AP).

Casi seguro que por WDS tampoco podrás enlazarlos.



Mi gozo en un pozo... Creí que el driver tenía soporte como cliente+AP. Bueno, con pincho la cosa cambiará.

Por WDS... Ambos llevan chipset Broadcom,  tenía la esperanza de que las especificaciones WDS fuesen las mismas para ambos.

En fin, tengo un pincho wifi usb, siempre se puede probar...

Maria32

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #154 en: 10-10-2013, 02:32 (Jueves) »
Buenas noches,
Tengo la siguiente consulta, aúnque no sé si escribo en  el tema correcto:
Estoy intentando usar WDS, para conectar un modem Astoria 4518 con un router Netgear Wnr834  (driver de dd-wrt) como repetidor; he conseguido que funcionara mediante WDS a nivel local, pero, no con acceso a internet por parte del repetidor; creo que el problema radica en que la ip de acceso al  Astoria es 192.168.2.1 y por parte de Netgear 192.168.1.1; hay alguna posibilidad de que funcione, puesto que cuando pongo una IP en el Netgear tipo 192.1.2.xxx se desconfigura y tengo que resetearlo; no sé si me he explicado.

Gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #155 en: 10-10-2013, 08:18 (Jueves) »
Si ninguno de los routers tiene OpenWrt ... pues no es el sitio correcto.

Plantea el problema en este foro: https://foro.seguridadwireless.net/puntos-de-acceso-routers-switchs-y-bridges/
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

gnordigan

  • Visitante
Re: Como poner mi Comtrend CT-5361 en modo repetidor?
« Respuesta #156 en: 16-10-2013, 09:49 (Miércoles) »
Lo primero,escribo porque siguiendo uno de los enlaces de jar229 en una respuesta he conseguido lo que daba por imposible; conectar por wi-fi mi dos routers Comtrend de fibra de Movistar. He conseguido llevar una señal de wi-fi al salón con la máxima potencia pero de repente me he dado cuenta de que alfgo no funciona y me gustaría hacer la consulta porque no soy capaz de encontrar solución alguna.

Después de conseguir que llegue la wi.fi al salón (lo quiero para que la TV pueda acceder a los contenidos de INternet) he comprobado que, aunque la TV puede ver mi mac conectado (a la misma wifi) no puede navegar por Internet. Me pasa lo mismo cuando bajo al salón con el iphone. Detecto la wifi del router del salón, me conecto, pero no navego.... qué he podido hacer mal?

Revisaré si están bien configuradas las DNS, supongo, el el router que hace de repetidor, no?

Mil gracias!!!!!

gnordigan

  • Visitante
Re: Como poner mi Comtrend CT-5361 en modo repetidor?
« Respuesta #157 en: 16-10-2013, 10:06 (Miércoles) »
Nada... no son las DNS. El tema es que los menús de configuración de mis routers no son iguales que los que aparecen en el ejemplo, y es posible que algo no esté bien puesto. El router secundario crea una wi-fi pero el pilotito de INTERNET está en rojo... no accede y, por lo tanto (supongo) los aparatos que se conectan a ese router tampoco pueden navegar.... Si a alguien se le ocurre algo o sabe cómo tengo que tener la configuración en estos routers nuevos de fibra de movistar, por favor, soy todo ojos.

Gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: Como poner mi Comtrend CT-5361 en modo repetidor?
« Respuesta #158 en: 16-10-2013, 10:10 (Miércoles) »
Tienes un Comtrend CT-5361 ?

Me imagino que has seguido el siguiente tutorial no ? https://foro.seguridadwireless.net/openwrt/(tutorial)-modo-clienterepetidor-openwrt/

No sería más oportuno que hubieras posteado allí ?

Estaría bien que pusieras unos 'pantallazos' de la configuración desde LuCi, o, que postearas el contenido de los ficheros 'network', 'wireless' y 'firewall' (están en /etc/config )

Muevo los mensajes al hilo correspondiente  ;)
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

gnordigan

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #159 en: 16-10-2013, 10:45 (Miércoles) »
Hola jar229. Pues mira, como te dije soy un ignorante total en todo esto y no he seguido el hilo que me pones. Seguí otro más arriba que me pareció que era el que tenía que seguir y todo parecía correcto hasta el fallo que te comento.

Todo lo que me dices que te mande me suena un poco "a chino" por mi desconocimiento. Lo que he podido hacer son pantallazos de prácticamente toda la configuración del router. Ni siquiera sé subir fotos por aquí. Te parecería bien si te mando los pantallazos por mail?

Mil gracias

//FINAL Y MÁS DOS RESPUESTAS