Autor Tema: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt  (Leído 321455 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #280 en: 14-08-2014, 12:50 (Jueves) »
Voy a red/wifi. Dejo la interfaz Máster (OpenWrt) tranquila y pulso editar en la Cliente (asociada al router principal). Pulso sobre Dissable, se desconecta y el led del router se apaga. Pulso Enable y se conecta de nuevo, pero el led wifi parpadea a ratos sin llegar a prender. No emite wifi.

Gracias por la paciencia

Lo único que se me ocurre ya, es que pruebes con otra compilación.

Podrías probar con la RC_3 de Barrier Braker: http://downloads.openwrt.org/barrier_breaker/14.07-rc3/brcm63xx/generic/openwrt-HW556-squashfs-cfe.bin


Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

sianeu

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #281 en: 19-08-2014, 18:39 (Martes) »
Al instalar el nuevo firmware he dejado marcada la casilla de guardar los datos. En este caso lo que ocurre es que al crear, en network/wifi la interfaz Master (que debe quedar asociada a la Lan) se desactiva la 1ª (cliente, la conectada al router principal) y quedo sin conexión a internet.
Si entonces la edito y le doy a enabled, se hace un lio y da mensaje de error.

He ido a Sistem/firmware y he aplicado un Reset a valores por defecto sin guardar datos. Ahora el problema es que no aparece el menú network/wifi (pasa de interfaces a switch).

Hay alguna forma de activar el wifi? no la he encontrado

Lo he dejado reposar un par de dias y he repetido todo con los dos firmwares, con idénticos resultados.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #282 en: 19-08-2014, 19:22 (Martes) »
Al instalar el nuevo firmware he dejado marcada la casilla de guardar los datos. En este caso lo que ocurre es que al crear, en network/wifi la interfaz Master (que debe quedar asociada a la Lan) se desactiva la 1ª (cliente, la conectada al router principal) y quedo sin conexión a internet.
Si entonces la edito y le doy a enabled, se hace un lio y da mensaje de error.

He ido a Sistem/firmware y he aplicado un Reset a valores por defecto sin guardar datos. Ahora el problema es que no aparece el menú network/wifi (pasa de interfaces a switch).

Hay alguna forma de activar el wifi? no la he encontrado

Lo he dejado reposar un par de dias y he repetido todo con los dos firmwares, con idénticos resultados.

Cuando se cambia de versión, no es muy recomendable conservar las configuraciones.

Algo, en el proceso, se te 'escapa'. Eso, o tu router es especial. En su momento (ya no tengo este equipo para hacer pruebas), el modo repetidor funcionaba perfectamente ...  ^-^

Cierto es que a veces costaba que desde LuCi hiciera correctamente el escaneo de redes, pero a partir de ahí ... todo iba como la seda  >:D
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1955
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #283 en: 19-08-2014, 20:36 (Martes) »
Puede que la wifi tenga algo en la configuración que haga que sea incompatible con la actualización.
Prueba a hacer un wifi detect y si te devuelve datos, mete los datos que te ha devuelto en el fichero de configuración con:
Código: [Seleccionar]
wifi detect > /etc/config/wireless Mira ahora si te ha creado el apartado wifi en LuCi y ya te deja activar la interfaz.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

sianeu

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #284 en: 20-08-2014, 13:51 (Miércoles) »
Wifi detect no devuelve datos.

Probado con otro firmware <r38342>. Ningún problema con el modo cliente y conseguir internet. La interfaz cliente queda como red asociada. Al crear la interfaz Master, no sólo no queda como red asociada ni da conexión wifi, sino que además elimina la interfaz Cliente de redes asociadas y cae la conexión al router principal.

Ahora si edito la interfaz cliente y la desactivo, la interfaz master sí queda como red asociada. Pero si conecto de nuevo la 1ª, vuelven a quedar las dos sin asociación.

Si elimino la interfaz Master, la 1ª vuelve a quedar asociada y conecta de neuvo a internet.

Probado con el firm <r37937>. Igual que el anterior, excepto que al desconectar la interfoaz Cliente se asocie la Master.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #285 en: 20-08-2014, 14:36 (Miércoles) »
Wifi detect no devuelve datos.

Probado con otro firmware <r38342>. Ningún problema con el modo cliente y conseguir internet. La interfaz cliente queda como red asociada. Al crear la interfaz Master, no sólo no queda como red asociada ni da conexión wifi, sino que además elimina la interfaz Cliente de redes asociadas y cae la conexión al router principal.

Ahora si edito la interfaz cliente y la desactivo, la interfaz master sí queda como red asociada. Pero si conecto de nuevo la 1ª, vuelven a quedar las dos sin asociación.

Si elimino la interfaz Master, la 1ª vuelve a quedar asociada y conecta de neuvo a internet.

Probado con el firm <r37937>. Igual que el anterior, excepto que al desconectar la interfoaz Cliente se asocie la Master.

Para poder poner en modo repetidor el Huawei hg556a con wifi ralink (el tuyo), has de usar una compilación igual o superior a la r39304.

Esta puesto en el primer post del hilo: https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/
« Última modificación: 20-08-2014, 14:43 (Miércoles) por jar229 »
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

sianeu

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #286 en: 20-08-2014, 16:49 (Miércoles) »
La versión C no lleva Atheros?
MI router:  HG556a versión HG55VDFA VER.C

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1955
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #287 en: 20-08-2014, 17:02 (Miércoles) »
La versión C no lleva Atheros?
MI router:  HG556a versión HG55VDFA VER.C

Ahora se han renombrado las versiones según el código VDF.

Ahora la versión HG55VDFA VER.C (Atheros) tiene dos versiones VDF, la A y la B.
Y la versión HG56BZRB VER.A (Ralink) tiene una versión VDF, la C.

http://wiki.openwrt.org/toh/huawei/hg556a
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

sianeu

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #288 en: 20-08-2014, 18:38 (Miércoles) »
El nºº de serie empieza por 30562, así que es Atheros.

La configuración que le aplico es la mínima, ya lo modificaría después si funcionara:
En interfaces sólo añado DNS 8.8.8.8. Lo demás ya está bien por defecto (mi red principal es 192.168.0.1).
En wifi, pulso scan y pongo la clave de mi red, submit y save&aply.
Con eso tengo internet.
Pulso add y marco asociar a Lan. Lo demás está bien por defecto. Save&aply.
Creo que no me dejo nada.

Podríais recomendarme un par de firmware más antes de descartar definitivamente el router?
« Última modificación: 20-08-2014, 18:40 (Miércoles) por sianeu »

CRC-_-

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #289 en: 03-10-2014, 18:30 (Viernes) »
Hola a tod@s soy nuevo en este foro y estoy siguiendo este manual, quiero conectar mi router TP-Link TD-W8960N a otro router AR5387un instalado openwrt. La forma que quiero hacerlo es en Modo cliente enrutado (Routed Client Mode). Sigo todos los pasos al pie de la letra ya llevo varios intentos pero el router no tiene conexión a internet y ninguno de los ordenadores que conecto por cable ethernet tampoco tiene. ¿Podeis echarme una mano antes de que me vuelva loco? :-[ Si necesitas cualquier dato decirmelo. Gracias por leerme y saludos

E.D: Estado investigando y puedo aportar más información sobre la configuración que tiene el router.

Código: [Seleccionar]
cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf8:d916:a211::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 8t'

config interface 'wwan'
        option proto 'dhcp'

Código: [Seleccionar]
cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:0'
        option htmode 'HT20'
        option disabled '0'
        option txpower '19'
        option country '00'
        option channel '4'

config wifi-iface
        option network 'wwan'
        option ssid 'HOUSE'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'oculto'
        option key 'oculto'
« Última modificación: 04-10-2014, 11:27 (Sábado) por CRC-_- »

CRC-_-

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #290 en: 05-10-2014, 13:47 (Domingo) »
Tengo una duda ¿Es necesario conectar un cable ethernet entre router1 y router2? Si lo hago de esta forma si que funciona, pero pensaba que no era necesario ningún tipo de cable entre los routers. Lo he hecho bien o hago algo mal? Otra cosa me da una dirección de red 192.168.1.x no tendría que dar una dirección de red del tipo 192.168.2.x? Siento hacer tantas preguntas pero tenga paciencia con un novato. Saludos y gracias por leerme.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #291 en: 05-10-2014, 21:38 (Domingo) »
No es necesario cablear los routers.
Si eres novato, repasa los diferentes pasos, que seguro que te has olvidado algo.

Enviado desde uno de mis 'cacharros' usando Tapatalk

Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

CRC-_-

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #292 en: 06-10-2014, 18:39 (Lunes) »
Gracias por responder jar229, como me comentas e repasado todos los pasos uno por uno, pero como no daba con el problema e borrado la configuración y la e vuelto a crear.
Ahora parece que funciona porque me da una ip dinámica de la dirección de red 192.168.2.x pero no consigo que los equipos que conecto al router por cable tengan acceso a internet. ¿Qué narices hago mal?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #293 en: 06-10-2014, 18:45 (Lunes) »
Gracias por responder jar229, como me comentas e repasado todos los pasos uno por uno, pero como no daba con el problema e borrado la configuración y la e vuelto a crear.
Ahora parece que funciona porque me da una ip dinámica de la dirección de red 192.168.2.x pero no consigo que los equipos que conecto al router por cable tengan acceso a internet. ¿Qué narices hago mal?

Has configurando correctamente el servidor DNS ?

Es un error bastante habitual olvidarse de ello ...  ^-^
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

CRC-_-

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #294 en: 06-10-2014, 18:58 (Lunes) »
La dirección del servidor DNS pongo la 8.8.8.8 los de google, también e probado con la dirección ip del router principal 192.168.1.1 pero tampoco funciona. ¿Qué DNS tengo que poner?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #295 en: 06-10-2014, 19:03 (Lunes) »
La dirección del servidor DNS pongo la 8.8.8.8 los de google, también e probado con la dirección ip del router principal 192.168.1.1 pero tampoco funciona. ¿Qué DNS tengo que poner?

Esas direcciones son correctas.

A ver si te falta algún dato más ...  ^-^

Qué compilación estás usando en el router con OpenWrt ?
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

CRC-_-

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #296 en: 06-10-2014, 19:20 (Lunes) »
El número de compilación es OpenWrt Barrier Breaker 14.07-rc3. Pongo los pasos que realizo para configurar el router.

Código: [Seleccionar]

1-) Abro una terminal con acceso ssh al router y escribo los comandos que aparecen en el tutorial

//Se cambia la dirección de red del router secundario
uci set network.lan.ipaddr=192.168.2.1
uci set network.lan.netmask=255.255.255.0
uci set network.lan.gateway=192.168.1.1
uci set network.lan.dns=8.8.8.8
uci set network.lan.nat=1
uci set network.lan.accept_ra=1

//Se activa el servidor dhcp
uci set dhcp.lan.dynamicdhcp=1

//Crear la interfaz wlan
uci set network.wan=interface
uci set network.wan.proto=dhcp

//Mostrar las redes wifi
uci show wireless

//Activar la interfaz de red wifi
uci set wireless.radio0.disabled=0
uci commit wireless
wifi --> Si introduzco este comando se queda colgado el router y no hace nada

//Se configura la interfaz wifi
uci set wireless.radio0.channel=1
uci set wireless.@wifi-iface[0].ssid=CRC-_-
uci set wireless.@wifi-iface[0].mode=sta
uci set wireless.@wifi-iface[0].network=wan
uci set wireless.@wifi-iface[0].encryption=psk2
uci set wireless.@wifi-iface[0].key=contraseña

//Configurar el firewall
uci set firewall.@zone[1].input=ACCEPT
uci set firewall.@zone[1].masq=1

//Aplicar los cambios y reiniciar
uci commit
reboot



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #297 en: 06-10-2014, 20:29 (Lunes) »
Si en lugar de hacer el proceso por comandos, lo intentas desde LuCi (escanear las redes), 'ves' tu red ?
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

CRC-_-

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #298 en: 06-10-2014, 21:03 (Lunes) »
Si que veo la red si la escaneo desde LuCi, e probado hacerlo desde una terminal y desde la interfaz web pero de las dos formas no funciona. Me da la ip pero a la hora de salir a internet no funciona. No se que narices hago mal pero realizo todos los pasos al pie de la letra.

CRC-_-

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #299 en: 07-10-2014, 20:17 (Martes) »
Bueno sigo peleándome con el router aun no tengo acceso a internet desde las bocas del router. Estado jugando un rato con él y e visto algunos archivos que lo mismo son los que pueden producirme el error.

La configuración del archivo /etc/resolv.conf, esto es lo que aparece:

Código: [Seleccionar]

 cat /etc/resolv.conf
search lan
nameserver 127.0.0.1


¿No tendría que aparecer la dirección del servidor dns 192.168.1.1 o 8.8.8.8?

La tabla de routas contiene lo siguiente:

Código: [Seleccionar]

route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 br-lan

Lo que he intentado es añadirla a mano pero me da un error y no me deja.

Código: [Seleccionar]

route add -net 192.168.2.0 netmask 255.255.255.0 gw 192.168.1.1 dev br-lan

Y lo último que e visto dentro de la interfaz wifi dentro del campo IPV4-Address no aparece ninguna dirección ip. ¿Esto es normal?

Código: [Seleccionar]

SSID MAC-Address IPv4-Address Signal Noise RX Rate TX Rate
[Signal: -73 dBm / Noise: 0 dBm] HOUSE xx:xx:xx:xx:xx:xx ? -73 dBm 0 dBm 1.0 Mbit/s, MCS 0, 20MHz 11.0 Mbit/s, MCS 0, 20MHz


¿Quien me echa una mano para hacerlo funcionar? No pienso darme por vencido tengo que conseguirlo! Saludos y gracias por leerme  
« Última modificación: 07-10-2014, 20:19 (Martes) por CRC-_- »

//FINAL Y MÁS DOS RESPUESTAS