Autor Tema: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt  (Leído 321487 veces)

0 Usuarios y 1 Visitante están viendo este tema.

cespar

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #320 en: 03-12-2014, 23:34 (Miércoles) »
Pues sigo con la mosca detrás de la oreja con el tema del mismo SSID, os cuelgo la configuración que tengo en el router que hace de cliente wds del fichero /etc/config/wierless para que me digais si está correcto.
Veréis dos interfaces distintas, la que hace de cliente y la que uso para ampliar la señal.

Mis preguntas son:
 - La que uso par ampliar la señal es estrictamente necesaria?(se trata al principio del hilo pero no se resuelve)
 - Puedo ponerle a la ampliación de la wifi el mismo nombre que la red principal? que ventajas e inconvenientes tendría?
 - Si se pudiese poner la misma SSID a las dos, como sabría desde un dispositivo a cual estoy conectado en cada momento?

Ahí va el código:

Código: [Seleccionar]
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option macaddr '64:.....'
option hwmode '11ng'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option channel '1'
option htmode 'HT40+'
option country 'ES'
option txpower '20'

config wifi-iface
option ssid 'NET_841'
option device 'radio0'
option mode 'sta'
option bssid 'E8:.......'
option key 'pass'
option wds '1'
option network 'lan'
option encryption 'psk'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'OpenWrt'
option wds '1'
option network 'lan'
option encryption 'psk'
option key 'pass'



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #321 en: 04-12-2014, 13:48 (Jueves) »
Usar dos redes distintas con el mismo nombre es posible, pero no se cómo afectará al hecho de la conexión/desconexión de dispositivos.
En enlace está correctamente configurado y las velocidades que has indicado a mi me parecen normales.

Y sí, puedes quitar el modo AP del segundo router, si no necesitas repetir la señal (te seguirá funcionando como cliente WDS).
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

cespar

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #322 en: 04-12-2014, 22:40 (Jueves) »
Ok, gracias.
No se, el caso es que siempre había oído que el WDS tenia algo para propagar el wifi con el mismo nombre, como que venía por defecto vaya. Lo dejaré así que por lo menos se a quien estoy conectado.

Gracias!

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1955
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #323 en: 05-12-2014, 08:45 (Viernes) »
WDS en sí no propaga nada (no repite), sólo crea el enlace entre los dos routers por wifi como si fuera por cable...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Torvel

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #324 en: 14-12-2014, 11:56 (Domingo) »
Me e registrado para daros las gracias a Noltari y a todos los que aportáis vuestro conocimiento en el tema, e seguido el tutorial y me a funcionado todo a la primera (menos en algunos cuelgues del router que por lo que e leído creo que son normales).
Sin mas gracias  >:(
« Última modificación: 14-12-2014, 11:56 (Domingo) por Torvel »

cap2666

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #325 en: 19-12-2014, 23:37 (Viernes) »
hola,me puede ayudar alquien?esta es mi problema:vivo en un casa de 3 plantas,en la planta baja tengo un router de jazztel de este zte sin antena externa,en la 3 planta tengo un portatil pero la senal no llega muy fuerte,asi que aqui me conecto con una antena wifi usb al router de jazztel,hace un mes he cojido un router de telefonica xavi y lo he configurado en modo brige por ip ,cambiandole la gateway por 192.168.0.1,y el lan a 192.168.0.250 como he visto en un tutorial pe youtube y la senal de el adaptador wifi me lo repetia en la 3 planta,ahorra el router de telefonica dejo de funcionar y me he comprado un tp link tlwr740n y le he metido el openwrt,pero no se como configurarlo como el de telefonica.Muchas gracias

beticocc

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #326 en: 04-01-2015, 16:22 (Domingo) »
Buenas tardes a todos y feliz año!!
Lo primero agradecer el enorme curro en este tutorial, ya que me he vuelto loco intentando configurar openwrt hasta que encontré este post.
Os cuento mi caso. Actualmente estoy viviendo en una residencia en la que no hay wifi, solo tenemos conexión por cable mediante un cable RJ45. Como tenia en casa un router Comtrend CT-5361 lo he querido aprovechar para crear una red wifi y así poder conectar el móvil, la tablet, el portátil,.... (antes conectaba todo esto creando una red wifi desde el ordenador, con el inconveniente de tener todo el dia el ordenador encendido...).
El caso es que siguiendo el tutorial he conseguido crear la red wifi, pero no se porque solo puedo conectarme desde el móvil y la tablet, si intento conectarme desde el ordenador no me deja, ya sea mediante wifi o mediante cable, siempre me sale que la conexión es limitada.
Alguien sabria por que puede ser esto y cual es la solucion???

Muchisimas gracias a todos por la ayuda

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1955
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #327 en: 04-01-2015, 16:31 (Domingo) »
Buenas tardes a todos y feliz año!!
Lo primero agradecer el enorme curro en este tutorial, ya que me he vuelto loco intentando configurar openwrt hasta que encontré este post.
Os cuento mi caso. Actualmente estoy viviendo en una residencia en la que no hay wifi, solo tenemos conexión por cable mediante un cable RJ45. Como tenia en casa un router Comtrend CT-5361 lo he querido aprovechar para crear una red wifi y así poder conectar el móvil, la tablet, el portátil,.... (antes conectaba todo esto creando una red wifi desde el ordenador, con el inconveniente de tener todo el dia el ordenador encendido...).
El caso es que siguiendo el tutorial he conseguido crear la red wifi, pero no se porque solo puedo conectarme desde el móvil y la tablet, si intento conectarme desde el ordenador no me deja, ya sea mediante wifi o mediante cable, siempre me sale que la conexión es limitada.
Alguien sabria por que puede ser esto y cual es la solucion???

Muchisimas gracias a todos por la ayuda

¿Tienes DHCP activo en el ordenador? ¿Tienes antivirus o firewall activos?
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

beticocc

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #328 en: 04-01-2015, 16:47 (Domingo) »
Buenas tardes a todos y feliz año!!
Lo primero agradecer el enorme curro en este tutorial, ya que me he vuelto loco intentando configurar openwrt hasta que encontré este post.
Os cuento mi caso. Actualmente estoy viviendo en una residencia en la que no hay wifi, solo tenemos conexión por cable mediante un cable RJ45. Como tenia en casa un router Comtrend CT-5361 lo he querido aprovechar para crear una red wifi y así poder conectar el móvil, la tablet, el portátil,.... (antes conectaba todo esto creando una red wifi desde el ordenador, con el inconveniente de tener todo el dia el ordenador encendido...).
El caso es que siguiendo el tutorial he conseguido crear la red wifi, pero no se porque solo puedo conectarme desde el móvil y la tablet, si intento conectarme desde el ordenador no me deja, ya sea mediante wifi o mediante cable, siempre me sale que la conexión es limitada.
Alguien sabria por que puede ser esto y cual es la solucion???

Muchisimas gracias a todos por la ayuda

¿Tienes DHCP activo en el ordenador? ¿Tienes antivirus o firewall activos?


El antivirus y el firewall los he desactivado ambos, y el DHCP según el símbolo del sistema esta deshabilitado, pero en las propiedades del adaptador wifi esta habilitado.

Muchísimas gracias

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1955
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #329 en: 04-01-2015, 16:51 (Domingo) »
Buenas tardes a todos y feliz año!!
Lo primero agradecer el enorme curro en este tutorial, ya que me he vuelto loco intentando configurar openwrt hasta que encontré este post.
Os cuento mi caso. Actualmente estoy viviendo en una residencia en la que no hay wifi, solo tenemos conexión por cable mediante un cable RJ45. Como tenia en casa un router Comtrend CT-5361 lo he querido aprovechar para crear una red wifi y así poder conectar el móvil, la tablet, el portátil,.... (antes conectaba todo esto creando una red wifi desde el ordenador, con el inconveniente de tener todo el dia el ordenador encendido...).
El caso es que siguiendo el tutorial he conseguido crear la red wifi, pero no se porque solo puedo conectarme desde el móvil y la tablet, si intento conectarme desde el ordenador no me deja, ya sea mediante wifi o mediante cable, siempre me sale que la conexión es limitada.
Alguien sabria por que puede ser esto y cual es la solucion???

Muchisimas gracias a todos por la ayuda

¿Tienes DHCP activo en el ordenador? ¿Tienes antivirus o firewall activos?


El antivirus y el firewall los he desactivado ambos, y el DHCP según el símbolo del sistema esta deshabilitado, pero en las propiedades del adaptador wifi esta habilitado.

Muchísimas gracias

Si lo tienes deshabilitado entonces el router no te dará la IP (y el PC cogerá la IP 192.254.x.x con conexión limitada). Tendrás que configurar la IP en el PC manualmente para poder navegar, o activar el DHCP en el PC.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

beticocc

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #330 en: 04-01-2015, 17:08 (Domingo) »
Buenas tardes a todos y feliz año!!
Lo primero agradecer el enorme curro en este tutorial, ya que me he vuelto loco intentando configurar openwrt hasta que encontré este post.
Os cuento mi caso. Actualmente estoy viviendo en una residencia en la que no hay wifi, solo tenemos conexión por cable mediante un cable RJ45. Como tenia en casa un router Comtrend CT-5361 lo he querido aprovechar para crear una red wifi y así poder conectar el móvil, la tablet, el portátil,.... (antes conectaba todo esto creando una red wifi desde el ordenador, con el inconveniente de tener todo el dia el ordenador encendido...).
El caso es que siguiendo el tutorial he conseguido crear la red wifi, pero no se porque solo puedo conectarme desde el móvil y la tablet, si intento conectarme desde el ordenador no me deja, ya sea mediante wifi o mediante cable, siempre me sale que la conexión es limitada.
Alguien sabria por que puede ser esto y cual es la solucion???

Muchisimas gracias a todos por la ayuda

¿Tienes DHCP activo en el ordenador? ¿Tienes antivirus o firewall activos?


El antivirus y el firewall los he desactivado ambos, y el DHCP según el símbolo del sistema esta deshabilitado, pero en las propiedades del adaptador wifi esta habilitado.

Muchísimas gracias

Si lo tienes deshabilitado entonces el router no te dará la IP (y el PC cogerá la IP 192.254.x.x con conexión limitada). Tendrás que configurar la IP en el PC manualmente para poder navegar, o activar el DHCP en el PC.

Acabo de probar a asignarle una ip manualmente y nada, sigue saliendo que no tiene acceso a internet, y configurando para que obtenga ip automáticamente me sigue saliendo lo mismo.

No se si tendrá algo que ver, pero antes de configurar la red wifi del router el ordenador se conectaba perfectamente por cable, pero ha sido configurar esto y no dejarme conectar. Sin embargo si me conecto directamente con cable desde el portátil a la clavija que tengo en la habitación me funciona sin problema.

Edito: Ahora ha vuelto a conectarse el ordenador a traves del router (tanto con cable como por wifi), pero el movil ya no puede conectarse via wifi.
No se si estare diciendo una absurdez, ¿Es posible que solo pueda conectarse un dispostivo al router?
« Última modificación: 04-01-2015, 18:14 (Domingo) por beticocc »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #331 en: 04-01-2015, 19:59 (Domingo) »
Versión e OpenWrt ?

Me da a mi, que ese Comtrend no puede con varios clientes a la vez (que no debiera, pero ...  ^-^)
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

beticocc

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #332 en: 04-01-2015, 20:36 (Domingo) »
Versión e OpenWrt ?

Me da a mi, que ese Comtrend no puede con varios clientes a la vez (que no debiera, pero ...  ^-^)

La versión es OpenWrt Attitude Adjustment 12.09-beta2.

Otra cosa que me pasa es que después de configurarlo cuando ya le conectó el cable de red que le da acceso a internet (en el puerto 4) no soy capaz de acceder a la interfaz de configuración del router, u tengo que volver a flashearlo

Edito: He probado con otra version de openwrt y me sigue pasando lo mismo, no se si es que no hago algo bien o es que al final el router no puede con varios router a la vez (aunque con le firmware original cuando lo usaba como modem si podia). Yo estoy siguiendo los pasos de la parte 2 del tutorial, ya que no quiero ampliar ninguna red wifi, ¿lo estoy haciendo bien no?
« Última modificación: 04-01-2015, 22:00 (Domingo) por beticocc »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #333 en: 05-01-2015, 08:40 (Lunes) »
Ese router tiene tan sólo 16 megas de RAM, creo que AA se le queda 'grande'.

Has probado a instalarle Backfire ?
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

beticocc

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #334 en: 05-01-2015, 11:49 (Lunes) »
Ese router tiene tan sólo 16 megas de RAM, creo que AA se le queda 'grande'.

Has probado a instalarle Backfire ?


Acabo de probar a instalarle Backfire y nada, sigue igual, solo da conexión al primer equipo que se conecte.

Edito: jar229 leyendo por ahí he encontrado un post del 2010 donde otro forero conseguía hacer funcionar bien este router con un firm modificado, y he visto que ese firm te lo mando por privado. Seria posible que me mandases ese firm??? Aunque después de tanto tiempo quizás ya ni lo tienes.
El post en cuestión es este https://foro.seguridadwireless.net/openwrt/instalando-openwrt-en-comtrend/100/
« Última modificación: 05-01-2015, 11:58 (Lunes) por beticocc »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #335 en: 05-01-2015, 12:40 (Lunes) »
Voy a mirar ...  >:(
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

beticocc

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #336 en: 05-01-2015, 13:50 (Lunes) »
Una pregunta que seguro que es muy tonta. Como tengo que configurar el router para conectarme a internet, como DHCP,PPPoe o Stactic IP??
Entiendo que con DHCP no??? Ya que no tengo IP fija, y PPPoe es si lo usara como modem no?

beticocc

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #337 en: 05-01-2015, 16:59 (Lunes) »
Hoy he ido a comprar y me he encontrado con un router neutro wifi por unos 10€ (Tenda N150) asi que he ido a por el y por el momento para lo que yo lo quiero va perfecto, así que abandono el CT-5361, ya que me da que no iba a ser capaz de hacerlo funcionar.

Muchisimas gracias a todos por la ayuda y perdón por las molestias!

Un saludo

Mena

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #338 en: 21-02-2015, 13:37 (Sábado) »
Hola chicos. Hoy me he decidido a meterle el openwrt a mi wr841N con v9.2. Por suerte no tuve que utilizar la consola para instalarle la gui Luci (me tenia acojonado). De momento he podido configurar el router para que me repita la señal de un wifi pero solo tengo conexion por cable. He intentado seguir unos pasos de este tutorial (muchas gracias a su creador) para intentar hacer lo que deseo, que es repetir la señal wifi pero con otra essid y contraseña diferentes. Por lo que he entendido debo cambiar el modo a acces point y seleccionar Lan en vez de wwan. Modifico el nombre de essid y contraseña. El problema es que ahora si tengo una nueva red con distinto essid y contraseña pero no tengo acceso a internet. Que hago mal?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
« Respuesta #339 en: 21-02-2015, 16:06 (Sábado) »
Hola chicos. Hoy me he decidido a meterle el openwrt a mi wr841N con v9.2. Por suerte no tuve que utilizar la consola para instalarle la gui Luci (me tenia acojonado). De momento he podido configurar el router para que me repita la señal de un wifi pero solo tengo conexion por cable. He intentado seguir unos pasos de este tutorial (muchas gracias a su creador) para intentar hacer lo que deseo, que es repetir la señal wifi pero con otra essid y contraseña diferentes. Por lo que he entendido debo cambiar el modo a acces point y seleccionar Lan en vez de wwan. Modifico el nombre de essid y contraseña. El problema es que ahora si tengo una nueva red con distinto essid y contraseña pero no tengo acceso a internet. Que hago mal?

Tienes que tener una interface en modo cliente (asociada a la parte wwan) y otra en modo AP (asociada a la lan).
Valoraciones positivas en compra/venta:
132 en Htcmania
179 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

//FINAL Y MÁS DOS RESPUESTAS