?>/script>'; } ?> [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio) Widgets Magazine

Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 851416 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #940 en: 23-07-2015, 17:00 (Jueves) »
P.D: por si a alguien le interesa, aquí os dejo el repo que contiene los scripts que he utilizado para compilar los firmwares:
https://github.com/openwrt-es/openwrt-imagebuilder
Automáticamente descarga el ImageBuilder de la web de OpenWrt para cada target/subtarget y compila los firmwares con los paquetes básicos para la fibra óptica de Movistar, así como también añade el script de configuración.
Para utilizarlo bastaría con hacer lo siguiente:
Código: [Seleccionar]
git clone https://github.com/openwrt-es/openwrt-imagebuilder.git
cd openwrt-imagebuilder
./movistar.sh

Saludos!


Fantástico, mas fácil imposible, si no te importa me he copiado el repro para compilarme el wdr4300 con mis necesidades
Para eso está ;D


elcorsario82

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #941 en: 26-07-2015, 13:49 (Domingo) »
Muy buenas,

Ayer estuve trasteando con mi TPLink WDR4300 y gracias a este hilo ya lo tengo funcionando directamente con el ONT de Movistar. He instalado OpenWrt Chaos Calmer 15.05-rc3 (kernel 3.18.14), he ejecutado el script de Noltari (aunque no tengo Imagenio) y he activado las dos bandas para conexión por WiFi.

Con mi configuración anterior, usando el router de Movistar entre el TPLink y la ONT, por cable conseguía los famosos 300Mbps. Con la actual, no consigo más de 200Mbps. ¿Os pasa? ¿Algo que deba revisar de la configuración?

Por WiFi, en la banda de 5GHz, logro unos 135Mbps con el iMac ... ¿Qué velocidades conseguís vosotros?

Muchas gracias.


charly79

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #942 en: 26-07-2015, 17:30 (Domingo) »
Hola.

Dispongo de un Wdr 4300, he actualizado el firmware sin problema, intento copiar el archivo movistar.sh via csp con el programa WINSCP, pero nunca logro conectar.

La unica forma que consigo conectar es por el explorador en el entorno y mediante telnet en el puti.

Como puedo hacerlo?.

Gracias


elcorsario82

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #943 en: 26-07-2015, 18:52 (Domingo) »
Hola charly79,

Puedes seguir estos pasos:

1. En la pestaña System-Administration, activa el acceso SSH, puerto 22.
2. Accede mediante terminal de comandos (o con el putty) de la siguiente forma:

ssh root@192.168.1.1

3. Una vez dentro, accede a la carpeta tmp:

cd /tmp

4. Usa el comando wget para descargar el script:
   
wget http://files.noltari.es/openwrt/scripts/movistar/r19/movistar.sh

5. Concede permisos de escritura:

chmod +x movistar.sh

6. Ejecuta el script:

./movistar.sh

Saludos.


elcorsario82

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #944 en: 26-07-2015, 18:53 (Domingo) »
Hola charly79,

Puedes seguir estos pasos:

1. En la pestaña System-Administration, activa el acceso SSH, puerto 22.
2. Accede mediante terminal de comandos (o con el putty) de la siguiente forma:

ssh root@192.168.1.1

3. Una vez dentro, accede a la carpeta tmp:

cd /tmp

4. Usa el comando wget para descargar el script:
   
wget http://files.noltari.es/openwrt/scripts/movistar/r19/movistar.sh

5. Concede permisos de ejecución:

chmod +x movistar.sh

6. Ejecuta el script:

./movistar.sh

Saludos.


atomizasser

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #945 en: 26-07-2015, 21:52 (Domingo) »
Buenas tardes,
Me pueden ayudar a configurar el VOIP en iOS?
Muchas gracias,


charly79

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #946 en: 26-07-2015, 23:29 (Domingo) »
Hola charly79,

Puedes seguir estos pasos:

1. En la pestaña System-Administration, activa el acceso SSH, puerto 22.
2. Accede mediante terminal de comandos (o con el putty) de la siguiente forma:

ssh root@192.168.1.1

3. Una vez dentro, accede a la carpeta tmp:

cd /tmp

4. Usa el comando wget para descargar el script:
   
wget http://files.noltari.es/openwrt/scripts/movistar/r19/movistar.sh

5. Concede permisos de escritura:

chmod +x movistar.sh

6. Ejecuta el script:

./movistar.sh

Saludos.

Gracias por tu ayuda, ya habia probado hacer eso, pero algo de me debe escapar, probare mañana porque misteriosamente he cargado el firmware de un tutorial que decia que valia, y me ha dejado el router frito, tengo que recuperarlo mediante jtag, y el ttl no lo tengo aqui hoy.

Mañana cuando lo recupere a la vida, pruebo eso y comento.


eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #947 en: 27-07-2015, 07:29 (Lunes) »
Buenas tardes,
Me pueden ayudar a configurar el VOIP en iOS?
Muchas gracias,

Si nos dices exactamente qué ayuda necesitas...


Janriman

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #948 en: 28-07-2015, 12:12 (Martes) »
Hola,
Tengo contratado la Fibra 300 y uso el router Tpl-link WDR 4300 pero los test de velocidad no me superan los 150Mb , sabéis si con el último firmware y el movistar R19 que ha creado Noltari el problema se podría solucionar?
Muchas gracias a todos y en especial a Noltari!


charly79

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #949 en: 28-07-2015, 19:56 (Martes) »
No he podido hacer nada nuevo, como os comente el router se me quedo frito al cargar un firmware supuestamente valido...

He intentado programar el bin oficial drectamente en la Flash winbond que lleva y ahora ya ha muerto del todo. Como tengo un amigo que tie uno igual, voy a desoldar su flash leerla y volcarla al mio del tiron. Con eso espero que vuelva a la vida.


Genosystem

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #950 en: 05-08-2015, 20:39 (Miércoles) »
El otro día use el script de Noltari y la verdad es que todo perfecto menos que tuve que quitar "Use builtin IPv6-management" del interfaz WAN porque no me cogía conexión.


eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #951 en: 07-08-2015, 08:14 (Viernes) »
El otro día use el script de Noltari y la verdad es que todo perfecto menos que tuve que quitar "Use builtin IPv6-management" del interfaz WAN porque no me cogía conexión.

Es curioso... yo lo tengo activado desde siempre, a la espera de que Movistar se decida algún día a activar el IPv6, y no he tenido ningún problema de conexión.


franki

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #952 en: 13-08-2015, 15:08 (Jueves) »
Tengo un router TP-Link TL-WR2543N/ND v1 con OpenWRT. El switch tiene 10 puertos, 5 con enchufe, uno para la cpu y el resto no hacen nada. ¿Funcionará el script correctamente si añado la cadena necesaria en el "case $router"?


sergzgz

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #953 en: 14-08-2015, 09:06 (Viernes) »
Quería dar las gracias a Noltari por el trabajo realizado y lo fácil que nos ha puesto las cosas (el script funciona correctamente también en un Netgear WNDR3700v4 con CC RC3 :) )


atomizasser

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #954 en: 20-08-2015, 21:34 (Jueves) »
Hola.

Me sucede algo curioso. Tengo un archer C5 configurado con el firmware 15.05-RC3 de Noltari para fibra de Movistar. Tengo 300Mb/30Mb. Si conecto por cable, solo consigo a 220-200Mb. Si uso el modem de movistar, obtengo los 300Mb. A si mismo, si configuro el archer C5 con el mismo firmware de Noltari pero en lugar de usarlo como modem, es solo router conectado al router de movistar, entonces vuelvo a conseguir los 300Mb.
Sabeis a que puede ser debido? QUizas el router no es suficientemente potente para hacer de modem/router?

Saludos.


Genosystem

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #955 en: 21-08-2015, 02:08 (Viernes) »
atomizasser, efectivamente es un problema de CPU, ya que el Openwrt hace el nateo tirando de CPU mientras que el de Movistar lo hace por hardware.
De todas formas había una lista de modems y me suena que con el tuyo se tenia que llegar a 270 creo recordar.
Yo he optado por ponerlo como lo tienes tu ahora.
Saludos


atomizasser

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #956 en: 21-08-2015, 08:56 (Viernes) »
atomizasser, efectivamente es un problema de CPU, ya que el Openwrt hace el nateo tirando de CPU mientras que el de Movistar lo hace por hardware.
De todas formas había una lista de modems y me suena que con el tuyo se tenia que llegar a 270 creo recordar.
Yo he optado por ponerlo como lo tienes tu ahora.
Saludos


Hola.

Gracias, ya entendi el problema. El openwrt no es 100% compatible con el Archer C5. El enrutarmiento y la gestión de puertos (lo que se llama NAT), el archer c5 con el firmware original lo hace por hardware y con el openwrt lo hace por software. Asi la gestion de datos que le llegan por WAN (internet) y su paso a LAN es lento, entre 200-300Mb (varia segun la version de openwrt que le instales), mientras que con el firmware original es superior a 300Mb.
Así si la velocidad que llega de internet es inferior a 200Mb, no hay cuello de botella y lo puede gestionar bien, pero superior, la CPU no es tan potente para gestionarlo y no llega a 300Mb.
Las opciones son:
-Usar el router de Movistar como modem-router y que él gestione el internet y luego el archer C5 con Openwrt que gestione el Wifi y la red local. (así es como lo tengo ahora). Como variante, dado que el Archer C5 actua de acces point, poner el firmware original
-Hacer de bridge el modem router de movistar y que el archer C5 con firmware original gestione internet, wifi y red local (mi router de movistar no puede hacer bridge es un Amper).
-Usar el archer C5 con openwrt como modem-router, pero la velocidad estaria limitada a 200Mb, que por otro lado, con los wifi N que tengo no llegan a esa velocidad, solo habira cuello de botella por cable.

Es una lastima, porque el Archer C5 va bien. Según he leído es muy poco probable que incluyan soporte de NAT por hardware al openwrt para este router.

Saludos.


pwarlike

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #957 en: 23-08-2015, 18:56 (Domingo) »
Hola,
Tengo contratado la Fibra 300 y uso el router Tpl-link WDR 4300 pero los test de velocidad no me superan los 150Mb , sabéis si con el último firmware y el movistar R19 que ha creado Noltari el problema se podría solucionar?
Muchas gracias a todos y en especial a Noltari!


Hola

Respecto a tu consulta, tengo el mismo router y el mismo problema. No supero los 150Mb por cable y además no supero nunca los 100Mb por wifi. Cuando hago las pruebas de velocidad, la cpu del router se pone al 100% y no da más.

He probado con el ultimo firmware compilado por Noltari "OpenWrt Chaos Calmer 15.05-rc3 / LuCI (git-15.167.71950-8005ecb)" y con la versión 19 del script y el problema no se corrige con ellos.

Supongo que será el mismo problema de NAT por software que tiene el Archer C5 y que no se podrá hacer gran cosa.

Un saludo.


dedosoa

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #958 en: 24-08-2015, 16:25 (Lunes) »
Hola, a ver si alguien me puede arrojar algo de luz.
Me compre un archer c7, logré instalar openwrt y configurarlo gracias al script del hilo. Aprovecho para agradeceros que al final pudiera conseguirlo así sin tener ni idea.

Ahora bien estaba intentando montar unos discos duros, en formato ntfs y fstab no funciona para la versión que tengo instalada.
El firmware es el de la pagina de wikiopenwrt y solo viene esa, tengo entendido que ntfs y fstab esta soportado a partir de cierta revsion, y la mia no lo está.
Alguien podría decirme cuales son mis alternativas a la hora de actualizar el firmware, tampoco sé como se podria compilar para este modelo sin tener ni idea. Mi versión es esta:

OpenWrt Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530) y se supone que :As of Backfire r25816 and trunk r25815 this option is already enabled by default.

Bueno espero que podais ayudarme y asi seguir aprendiendo cosillas. Gradias.


backglass

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #959 en: 24-08-2015, 17:10 (Lunes) »

A ver, el problema es que yo eso lo considero una configuración avanzada que la mayoría de usuarios no necesita, y ya bastante tengo con conseguir que os funcione todo. Desde mi punto de vista es mejor daros un punto de partida funcional y común y de ahí que cada uno lo adapte a sus necesidades.

Para llevar a cabo la configuración que dices habría que sacar un puerto de la VLAN 1 y añadimos otra VLAN con dicho puerto (la 4 por ejemplo) /etc/config/network:
Código: [Seleccionar]
config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 2 3 4 5'
Quitamos el 5 por ejemplo:
Código: [Seleccionar]
config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 2 3 4'
config switch_vlan
option device 'switch0'
option vlan '4'
option vid '5'
option ports '0t 5'
A partir de ahí, creamos una nueva interfaz (tvlan):
Código: [Seleccionar]
uci set network.tvlan="interface"
uci set network.tvlan.ifname="eth0.4"
uci set network.tvlan.proto="static"
uci set network.tvlan.ipaddr="192.168.2.1"
uci set network.tvlan.netmask="255.255.255.0"
Y la añadimos al firewall en la sección LAN /etc/config/firewall:
Código: [Seleccionar]
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'
->
Código: [Seleccionar]
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan tvlan'

Si quieres que los decos se configuren por DHCP abría que añadir esto a /etc/config/dhcp:
Código: [Seleccionar]
config dhcp 'tvlan'
option leasetime '12h'
option interface 'tvlan'
option start '100'
option limit '100'
list dhcp_option '6,172.26.23.3'
list dhcp_option '240,:::::239.0.2.10:22222:v6.0:239.0.2.30:22222'

Por último, sólo habría que modificar /etc/mcproxy.conf:
Código: [Seleccionar]
# Proxy Instance: upstream ==> downstream
pinstance iptv: "eth0.2" ==> "br-lan";
->
Código: [Seleccionar]
# Proxy Instance: upstream ==> downstream
pinstance iptv: "eth0.2" ==> "eth0.4";

Reiniciamos y todo listo.

Saludos!
Buenas,
Estoy liado intentando configurar el router( Archer c7 V2) para crear una vlan y evitar saturar la red donde están los equipos conectados del deco de imagenio y no rula, no sé qué hago mal.

La modificación que he hecho en los archivos está aquí (Izquierda archivo original sin modificar):

Archivo /etc/config/network
https://www.diffchecker.com/yvcemnqc

Archivo /etc/config/firewall
https://www.diffchecker.com/pvwm8rjp

Archivo /etc/config/dhcp
https://www.diffchecker.com/akr4v66z

Archivo /etc/mcproxy.conf
https://www.diffchecker.com/gnpos8df

Reinicio y el televisor está en negro.
Haber si me podeis ayudar
Alejandro

« Última modificación: 24-08-2015, 17:26 (Lunes) por backglass »