?>/script>'; } ?> [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio) Widgets Magazine

Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 853413 veces)

0 Usuarios y 1 Visitante están viendo este tema.

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1000 en: 21-09-2015, 11:55 (Lunes) »
Mi idea es usar el TP-LINK como neutro, conectado al Mitrastar que me proporcionó Movistar, ya que de otra forma no podría utilizar VoIP (Mi ONT no tiene salida VoIP, sale directamente del router Mitrastar)

Sólo un comentario impertinente, llámame pedante si quieres, pero quizás te ahorre alguna confusión en el futuro:

Aunque con fibra de Movistar la telefonía funcione sobre VoIP, eso es sólo desde la ONT hasta la central de Movistar; de la ONT para dentro, lo que tienes en casa es telefonía analógica convencional (o POTS, si quieres las sigas en inglés).



fagmartinez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1001 en: 21-09-2015, 16:13 (Lunes) »
Pregunta de concurso, es posible que como mi switch de 8 puertos no tiene IGMP Snooping, este haciendo trabajar de sobremanera a los routers? ya he quemado un HG556a y ahora tengo puesto un Amper ASL26555, y esta siempre muy muy caliente, a parte de que me encuentra entrar por Luci o por SSH y las luces del switch estan como locas. Todo viene a raiz de un segundo deco que puse a traves del switch este. porque el primer deco sale desde el router principal


canario_04

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1002 en: 23-09-2015, 10:18 (Miércoles) »
Hola, se puede usar toda esta configuracion para un tp-link tl-wr841nd?? Lo unico que tendria que hacer es buscarel firmware openWRT para ese router y luego aplicar el script de noltari, correcto?? Muchas gracias!


Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1003 en: 23-09-2015, 11:09 (Miércoles) »
Pregunta de concurso, es posible que como mi switch de 8 puertos no tiene IGMP Snooping, este haciendo trabajar de sobremanera a los routers? ya he quemado un HG556a y ahora tengo puesto un Amper ASL26555, y esta siempre muy muy caliente, a parte de que me encuentra entrar por Luci o por SSH y las luces del switch estan como locas. Todo viene a raiz de un segundo deco que puse a traves del switch este. porque el primer deco sale desde el router principal
Si lo estás usando para ver Imagenio sí es imprescindible que el switch tenga IGMP Snooping si quieres evitar saturar la red.
En caso contrario no hace falta.

Hola, se puede usar toda esta configuracion para un tp-link tl-wr841nd?? Lo unico que tendria que hacer es buscarel firmware openWRT para ese router y luego aplicar el script de noltari, correcto?? Muchas gracias!
El TL-WR841ND está soportado en el script, pero se te va a quedar un poco corto en cuanto a rendimiento.

Saludos.


canario_04

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1004 en: 23-09-2015, 13:02 (Miércoles) »
Gracias noltari por la respuesta, crews que se me quedara mas corto que el que tengo ahora de movistar? El zyxel p870? O notare mejoria de rendimiento?? Muchas gracias


Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1005 en: 23-09-2015, 13:34 (Miércoles) »
Gracias noltari por la respuesta, crews que se me quedara mas corto que el que tengo ahora de movistar? El zyxel p870? O notare mejoria de rendimiento?? Muchas gracias
Puedes probar el P870 a ver si te va mejor, pero el problema de la red saturada no te lo vas a quitar porque viene de que el switch no tenga IGMP Snooping.

Saludos.


chunkete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1006 en: 26-09-2015, 12:38 (Sábado) »
Buenos días a todos,

Os cuento, llevo un par de semanas intentando configurar un 1043ND v1.9 sin éxito, pasando por un brick y todo.

El caso es que lo tenía funcionando de hace años siguiendo el pdf que aparece en el post Nº2, ahora he contratado imagenio y al querer configurarlo no hay manera.

He instalado el Openwrt 15 que se linka en primer post con todo el software necesario, he borrado toda la configuración, ya os digo que hasta un brick, y luego le he ejecutado el script, tanto el v19, como el v20.

El caso es que después de ejecutar el script, configura todo, pero no se conecta la WAN y por lo tanto no funciona nada.

Os dejo el log del script, a priori no veo nada raro, salvo el ipv6 que no está desactivado y no creo que sea el problema, y un mensaje al final que dice uci: Entry not found dos veces.

La verdad no se por donde seguir, seguro que es una tontería, pero no lo encuentro.

Muchas gracias por vuestra ayuda
Código: [Seleccionar]
system type             : Atheros AR9132 rev 2                                  

machine                 : TP-LINK TL-WR1043ND                                  

processor               : 0                                                    

cpu model               : MIPS 24Kc V7.4                  

BogoMIPS                : 265.42                                                

wait instruction        : yes                                                  

microsecond timers      : yes                              

tlb_entries             : 16                    

extra interrupt vector  : yes                                                  

hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0f

isa                     : mips1 mips2 mips32r1 mips32r2

ASEs implemented        : mips16                

shadow register sets    : 1                                

kscratch registers      : 0                      

package                 : 0                      

core                    : 0                                

VCED exceptions         : not available                    

VCEI exceptions         : not available          

                                                

Movistar FTTH Configuration Script r20                    

OpenWrt Chaos Calmer 15.05 (ar71xx/generic)      

Alvaro Fernandez Rojas (noltari@gmail.com)                

---                                              

Router identified: TP-Link WR1043ND (tl-wr1043nd)

---                                              

Customize LAN Network? (def 192.168.1.1/24) (y/n)          

n                                            

---                                                        

Enable VOIP? (y/n)                                        

y                                              

Enable IPTV? (y/n)                                        

y                                              

WAN + VOIP + IPTV                                          

---                                            

IPTV IP Address (e.g 172.26.0.2/10.128.0.2)                

10.79.34.39                                    

IPTV Netmask (e.g. 255.255.240.0/255.128.0.0)              

255.192.0.0                                                

IPTV Gateway (e.g. 172.26.208.1/10.128.0.1)                

10.64.0.1                                                  

nf_conntrack_rtsp module detected                          

Enable DHCP for IPTV decoders? (y/n)                      

y                                                          

Configure udpxy? (y/n)                                    

y                                                          

Enter udpxy port (def 4022)                                

4022                                                      

Allow access to udpxy from WAN? (y/n)                      

y                                              

---                                                        

Network config erased                          

cfg043777                                                  

cfg051ec7                                      

cfg061ec7                                    

cfg071ec7                                                  

cfg081ec7                                      

cfg0bc8b4                                                  

Network config loaded                          

Network config applied                                    

uci: Entry not found                                      

uci: Entry not found                                      

cfg1fdc81                                      

cfg20dc81                                                  

cfg21ad58            

cfg24ad58                                                                      
cfg25dc81                                                                      
cfg26ad58                                                                      
                                                      
config defaults                                  
        option syn_flood '1'                              
        option input 'ACCEPT'                    
        option output 'ACCEPT'                  
        option forward 'REJECT'                            
                                                          
config rule                                      
        option name 'Allow-DHCP-Renew'          
        option src 'wan'                                  
        option proto 'udp'                      
        option dest_port '68'                              
        option target 'ACCEPT'                  
        option family 'ipv4'                    
                                                
config rule                                                
        option name 'Allow-Ping'            
        option src 'wan'                                  
        option proto 'icmp'                                
        option icmp_type 'echo-request'        
        option family 'ipv4'                              
        option target 'ACCEPT'                  
                                                          
config rule                                    
        option name 'Allow-IGMP'                          
        option src 'wan'                        
        option proto 'igmp'                                
        option family 'ipv4'                              
        option target 'ACCEPT'                            
                                                          
config rule                                                
        option name 'Allow-DHCPv6'                        
        option src 'wan'                                  
        option proto 'udp'                                
        option src_ip 'fe80::/10'                          
        option src_port '547'                              
        option dest_ip 'fe80::/10'                        
        option dest_port '546'                            
        option family 'ipv6'                    
        option target 'ACCEPT'                            
                                                
config rule                                                
        option name 'Allow-MLD'                
        option src 'wan'                    
        option proto 'icmp'                                
        option src_ip 'fe80::/10'              
        list icmp_type '130/0'                            
        list icmp_type '131/0'                  
        list icmp_type '132/0'                            
        list icmp_type '143/0'                            
        option family 'ipv6'                              
        option target ‘ACCEPT'
config rule                                                                    
        option name 'Allow-ICMPv6-Input'                                        
        option src 'wan'                                                        
        option proto 'icmp'                                                    
        list icmp_type 'echo-request'                                          
        list icmp_type 'echo-reply'                                            
        list icmp_type 'destination-unreachable'                                
        list icmp_type 'packet-too-big'                                        
        list icmp_type 'time-exceeded'                
        list icmp_type 'bad-header'              
        list icmp_type 'unknown-header-type'              
        list icmp_type 'router-solicitation'    
        list icmp_type 'neighbour-solicitation'  
        list icmp_type 'router-advertisement'              
        list icmp_type 'neighbour-advertisement'          
        option limit '1000/sec'                  
        option family 'ipv6'                    
        option target 'ACCEPT'                            
                                                
config rule                                                
        option name 'Allow-ICMPv6-Forward'      
        option src 'wan'                        
        option dest '*'                          
        option proto 'icmp'                                
        list icmp_type 'echo-request'          
        list icmp_type 'echo-reply'                        
        list icmp_type 'destination-unreachable'          
        list icmp_type 'packet-too-big'        
        list icmp_type 'time-exceeded'                    
        list icmp_type 'bad-header'            
        list icmp_type 'unknown-header-type'              
        option limit '1000/sec'                
        option family 'ipv6'                              
        option target 'ACCEPT'                  
                                                          
config include                                            
        option path '/etc/firewall.user'                  
                                                          
config rule                                                
        option src 'wan'                                  
        option dest 'lan'                                  
        option proto 'esp'                                
        option target 'ACCEPT'                            
                                                          
config rule                                                
        option src 'wan'                                  
        option dest 'lan'                      
        option dest_port '500'                            
        option proto 'udp'                      
        option target 'ACCEPT'                            
                                                
config include 'miniupnpd'                      
        option type 'script'                              
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'                                
        option reload '1'                                  
                                                          
config zone                                                
        option name 'lan'                                  
        option input 'ACCEPT'                              
        option output 'ACCEPT'                            
        option forward ‘ACCEPT'
        option network 'lan'                                                    
                                                                                
config zone                                                                    
        option name 'wan'                                                      
        option input 'REJECT'                                                  
        option output 'ACCEPT'                                                  
        option forward 'REJECT'                                                
        option masq '1'                                                        
        option mtu_fix '1'                                                      
        list network 'wan'                            
        list network 'wan6'                                
                                                          
config forwarding                                          
        option src 'lan'                        
        option dest 'wan'                                  
                                                          
config zone                                                
        option name 'iptv'                                
        option input 'ACCEPT'                              
        option output 'ACCEPT'                            
        option forward 'REJECT'                            
        option network 'iptv'                              
        option mtu_fix '1'                                
        option masq '1'                                    
                                                          
config forwarding                                          
        option src 'lan'                                  
        option dest 'iptv'                                
                                                
config forwarding                                          
        option src 'iptv'                      
        option dest 'lan'                                  
                                                
config zone                                                
        option name 'voip'                      
        option input 'ACCEPT'                              
        option output 'ACCEPT'                            
        option forward 'REJECT'                            
        option network 'voip'                              
        option masq '1'                                    
        option mtu_fix '1'                                
                                                          
config forwarding                                          
        option src 'lan'                                  
        option dest 'voip'                                
                                                          
config rule 'udpxy'                                        
        option target 'ACCEPT'                            
        option src 'wan'                                  
        option proto 'tcp udp'                            
        option dest_port '4022'                            
        option name 'udpxy'                                
                                                          
Firewall config saved                                      
bird4 config applied                                      
bird4 enabled                                              
mcproxy config applied                                    
mcproxy enabled                                            
DNS rebind protection disabled                            
udpxy config applied                                      
udpxy enabled                                              
uci: Entry not found                                      
uci: Entry not found
IPTV DHCP server config applied                            
---                                                        
Configuration done!                                        
Make log persistent? (y/n)                                
y    

En el log de openwrt aparece esto continuamente:

Código: [Seleccionar]
Wed Sep  9 06:04:00 2015 daemon.notice netifd: Interface 'wan' is now down
Wed Sep  9 06:04:00 2015 daemon.notice netifd: Interface 'wan' is disabled
Wed Sep  9 06:04:00 2015 daemon.notice netifd: Interface 'wan' is enabled
Wed Sep  9 06:04:00 2015 daemon.notice netifd: Interface 'wan' is setting up now
Wed Sep  9 06:04:00 2015 daemon.info pppd[1734]: Plugin rp-pppoe.so loaded.
Wed Sep  9 06:04:00 2015 daemon.info pppd[1734]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Wed Sep  9 06:04:00 2015 daemon.notice pppd[1734]: pppd 2.4.7 started by root, uid 0
Wed Sep  9 06:04:15 2015 daemon.warn pppd[1734]: Timeout waiting for PADO packets
Wed Sep  9 06:04:15 2015 daemon.err pppd[1734]: Unable to complete PPPoE Discovery
Wed Sep  9 06:04:15 2015 daemon.info pppd[1734]: Exit.

« Última modificación: 26-09-2015, 14:25 (Sábado) por Noltari »

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1007 en: 26-09-2015, 14:23 (Sábado) »
Buenos días a todos,

Os cuento, llevo un par de semanas intentando configurar un 1043ND v1.9 sin éxito, pasando por un brick y todo.

El caso es que lo tenía funcionando de hace años siguiendo el pdf que aparece en el post Nº2, ahora he contratado imagenio y al querer configurarlo no hay manera.

He instalado el Openwrt 15 que se linka en primer post con todo el software necesario, he borrado toda la configuración, ya os digo que hasta un brick, y luego le he ejecutado el script, tanto el v19, como el v20.

El caso es que después de ejecutar el script, configura todo, pero no se conecta la WAN y por lo tanto no funciona nada.

Os dejo el log del script, a priori no veo nada raro, salvo el ipv6 que no está desactivado y no creo que sea el problema, y un mensaje al final que dice uci: Entry not found dos veces.

La verdad no se por donde seguir, seguro que es una tontería, pero no lo encuentro.

Muchas gracias por vuestra ayuda
Voy a tirar por la vía fácil y a asumir que no has reiniciado después de ejecutar el script tal y como aparece descrito en el primer post.

Cita de: Noltari
Procedimiento
Paso 1
Opción A: Transferir el fichero movistar.sh al router de la forma que más os guste (usb, scp...).
Opción B: Crear el fichero utilizando vi (copiando el contenido de movistar.txt):
Código: [Seleccionar]
cd /tmp
vi movistar.sh
Copiar el contenido a vi y salir.
Código: [Seleccionar]
chmod +x movistar.sh
./movistar.sh
Paso 2
Introducir la información que nos pida el script.
Paso 3
Lo más conveniente es apagar el router y volver a encenderlo después de realizar la configuración.
Código: [Seleccionar]
poweroff && exitY ya está, fácil, sencillo y para toda la familia.
Sí habéis tenido algún problema, postead el contenido del fichero /tmp/movistar.log (dicho fichero es temporal y se borra si apagais el router, por lo que es conveniente copiarlo a otro lugar al finalizar la ejecución del script)
En el caso de haber seleccionado la opción de hacer el log persistente lo tendréis en la ruta /etc/movistar.log y no se borrará ni aunque hayáis reiniciado el router.

« Última modificación: 26-09-2015, 14:24 (Sábado) por Noltari »

chunkete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1008 en: 26-09-2015, 14:37 (Sábado) »
Si he reiníciado, varias veces, de hecho la única que ha medio funcionado, ha sido al aplicar el script sobre la configuración anterior sin reiniciar se veía imagenio pero no tenía internet.
En cuanto se reinicia volvemos a esta situación...



Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1009 en: 26-09-2015, 15:20 (Sábado) »
Si he reiníciado, varias veces, de hecho la única que ha medio funcionado, ha sido al aplicar el script sobre la configuración anterior sin reiniciar se veía imagenio pero no tenía internet.
En cuanto se reinicia volvemos a esta situación...


Qué versión estás usando?
Puedes poner el contenido de /etc/config/network?


grenouille

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1010 en: 26-09-2015, 15:27 (Sábado) »
Noltari o expertos, tengo una consultilla creo que sencilla a ver si me podéis ayudar:

Recibí el deco IPTV después de aumentar a los 300 Mb y seguí el tutorial y la utilidad de tu página para sacar la configuración de Imagenio.

Mi router actual es un WDR3600 con BB, funcionando a la perfección. Para las pruebas de IPTV y comprobar configuraciones, antes de migrar a CC final el WDR3600, he usado un AR5387un al que le he puesto tu firmware compilado CC final, instalando todos los paquetes necesarios y sin problemas con el script. Navegación correcta tal y como esperaba.

Mi esquema de conexión es un switch sin IGMP snooping conectado a una boca del AR5387un y a la otra boca he puesto el deco IPTV. Pensaba que tras aplicar el script, el igmp snooping ya estaría configurado pero he visto que al conectar el deco todos los leds del switch sufren la típica saturación al tener un suscriber IPTV en la red, como si no estuviera funcionando el IGMP snooping. La TV en el deco se ve... eso sí.

He probado a aplicar de nuevo el script sin configurar udproxy pero creo que no tiene que ver, sigue igual.... ¿Hay que hacer algo después de aplicar tu script para que efectivamente el IGMP snooping se haga bien?

Con el switch con IGMP se solucionaría para lo que cuelga del switch, pero tengo planeado pinchar cosas a las otras bocas del router y me gustaría poder tener la configuración correcta para el tráfico multicast

Revisando posts y googleando he visto en este link: https://foro.seguridadwireless.net/openwrt/igmp-snooping-no-funciona/ en el que se dice esto:
Citar
"The linux igmp/mld snooping only works between linux interfaces, but does not have any effect on the switch chip behind a certain interface.

You should not see any multicast traffic on wifi as long as there are no subscribers, but it will still be broadcast to all ethernet ports if there is any subscriber on one of the ports.

This is more or less a hardware limitation, Broadcom switches do not implement full MLD/IGMP snooping in hardware but are only able to redirect these packets to linux with additional information, which would then require a special driver to update the switch internal forwarding tables to match the joins/leaves/membership reports."

pero no sé si sigue siendo aplicable a día de hoy en CC, sería una ****da.

Muchas gracias!



Y ya que estoy me corrijo a mí mismo una cosa que dije el otro día pero he visto que no es así:
Citar

No sé con qué bitrate emitiría Imagenio cuando la fibra era de 100 Mb, pero el otro día probando el deco sobre cable de 100 Mb (Prueba hecha a propósito) los HD se pixelaban... osea que deben haber subido el bitrate.
Si nuestros routers no pasan de 150 va a ir un poco justito para usar imagenio + navegación en PC
Con el Comtrend VG-8050 + deco IPTV en un canal HD, el test de velocidad en un PC a otra boca del VG-8050 mantiene los 300 Mb. Imagino que al ir por otra VLAN, la ONT mantiene siempre el canuto de la Vlan6 para navegación.

« Última modificación: 26-09-2015, 19:59 (Sábado) por grenouille »

chunkete

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1011 en: 26-09-2015, 18:45 (Sábado) »
Si he reiníciado, varias veces, de hecho la única que ha medio funcionado, ha sido al aplicar el script sobre la configuración anterior sin reiniciar se veía imagenio pero no tenía internet.
En cuanto se reinicia volvemos a esta situación...


Qué versión estás usando?
Puedes poner el contenido de /etc/config/network?

Ahí va

Citar
config interface 'loopback'                                                    

        option ifname 'lo'                                                      

        option proto 'static'                                                  

        option ipaddr '127.0.0.1'                                              

        option netmask '255.0.0.0'                                              

                                                                                

config globals 'globals'                                                        

        option ula_prefix 'fd14:fc51:63e2::/48'                                

                                                                                

config switch                                                                  

        option name 'switch0'                                                  

        option reset '1'                                                        

        option enable_vlan '1'                                                  

                                                                                

config switch_vlan                                                              

        option device 'switch0'                                                

        option vlan '1'                                                        

        option ports '1 2 3 4 5t'                                              

                                                                                

config switch_vlan                                                              

        option device 'switch0'                                                

        option vlan '2'                                                        

        option ports '0t 5t'                                                    

                                                                                

config switch_vlan                                                              

        option device 'switch0'                                                

        option vlan '3'                                                        

        option ports '0t 5t'                                                    

                                                                                

config switch_vlan                                                              

        option device 'switch0'                                                

        option vlan '6'                                                        

        option ports '0t 5t'                                                    

                                                                                

config interface 'lan'                                                          

        option ifname 'eth0.1'                                                  

        option type 'bridge'                                                    

        option proto 'static'                                                  

        option ip6assign '60'                                                  

        option igmp_snooping '1'                                                

        option ipaddr '192.168.1.1'                                            

        option netmask '255.255.255.0'                                          

                                                                                

config interface 'iptv'                                                        

        option ifname 'eth0.2'                                                  

        option proto 'static'                                                  

        option ipaddr '10.79.34.39'                                            

        option netmask '255.192.0.0'                                            

        option gateway '10.64.0.1'                                              

        option defaultroute '0'                                                

        option peerdns '0'                                                      

                                                                                

config route                                                                    

        option interface 'iptv'                                                

        option target '172.16.0.0'                                              

        option netmask '255.240.0.0’                                            

        option gateway ’10.64.0.1'


config interface 'voip'                                                        
        option ifname 'eth0.3'                                                  
        option proto 'dhcp'                                                    
        option defaultroute '0'                                                
        option peerdns '0'                                                      
                                                                                
config interface 'wan'                                                          
        option ifname 'eth0.6'                                                  
        option proto 'pppoe'                                                    
        option username 'adslppp@telefonicanetpa'                              
        option password 'adslppp'                                              
        option ipv6 '1'                                                        
        option mtu '1492'                                                      
                                                                                
config interface 'wan6'                                                        
        option ifname 'wan'                                                    
        option proto 'dhcpv6'

Con el MTU en 1500 tampoco funciona

Respecto a la versión es la 15.05, la he instalado de tus compilaciones del link del primer post

« Última modificación: 26-09-2015, 23:03 (Sábado) por chunkete »

Flait31

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1012 en: 26-09-2015, 22:39 (Sábado) »
Hola noltari,he instalado en mi router tp-link archer c5 v.1.20 la version adecuada y utima de openwrt que es OpenWrt Chaos Calmer 15.05 y tengo ya todo hecho y tengo internet pero con la pega de que tengo contratadas 300mb de bajada y 30 de subida pero con este router con openwrt me llegan como entre 150 y 200 de bajada y de subida los 30.No se a que es debido,pruebo con el router de movistar y me da 307 de bajada y las 30 de subida y no encuentro la solucion a este problema.Para instalar el OpenWrt he seguido el siguiente tutorial http://raspberryparatorpes.net/proyectos/configurar-paso-a-paso-tp-link-tl-wr841n-para-movistar-ftth/ y he usado tu movistar.sh.No tengo imagenio y el tutorial mencionado anteriormente es de otro router pero lo he tomado como referencia simplemente he hecho los mismos pasos pero para mi router y no creo que el problema esté ahí.No se si puede ser por el tema de firewall y puertos o alguna configuracion mas.Otra cosa mas sabrias de donde puedo sacar informacion para configurarlo por primera vez es decir para el firewall y esas cosas basicas? He buscado por todos lados y nada, ni un tutorial.He seguido ese tutorial para instalar open wrt y con ello haciendo lo siguiente mencionado en tu post:
Paso 1
Opción A: Transferir el fichero movistar.sh al router de la forma que más os guste (usb, POR SCP LO HE HECHO...).
Paso 2
Introducir la información que nos pida el script.
Paso 3
Lo más conveniente es apagar el router y volver a encenderlo después de realizar la configuración.
Código:

poweroff && exit

Y con eso he terminado,tambien he instalado el bird4 como se indica en el tutorial que he seguido.El archivo de OpenWrt lo he sacado de su pagina oficial por si no tenia que hacerlo asi,te lo indico.Y lo unico que he tocado despues es el wifi no se si debo realizar alguna configuracion mas de puertos o de otra cosa para que funcione correctamente dando la velocidad correcta.Me esta volviendo loco este tema,espero que me arrojes un poco de luz sobre este tema.Gracias por leer todo este tocho y saludos! Info que se me olvidaba: tengo el router conectado directamente a la ont de movistar

Otra cosa que se me olvidaba como veo el archivo  /etc/config/network o cualquier otro de otra routa ya sea para verlo configurarlo o lo que sea?

« Última modificación: 26-09-2015, 22:50 (Sábado) por Flait31 »

atomizasser

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1013 en: 02-10-2015, 09:43 (Viernes) »
Hola Flait31.

Lo has hecho todo bien, el problema radica en el firmware openwrt y el archer c5. Esta combinacion, el trabajo del DHT es por software y no por hardware con lo que todo el trabajo de enrutar, puertos...etc lo lleva a cabo la CPU del archer. Esta a pesar de ser potente, no es suficiente para gestionar esos 300Mb.
A mi me pasaba lo mismo y tras mucho buscar en foros el motivo, al final me di cuenta de que era problema del firmware openwrt que no esta 100% adaptado al archer. Esto mismo pasa con muchos router que tienen la parte DHT como codigo privado y no puede ser adaptada.

La unica solucion es que el router de movistar gestione todo y el archer funciono como AP Wifi. Asi es como lo tengo yo, y tengo los 300Mb cable y unos 200Mb Wifi N. O bien limitarte a esos 200Mb.


Flait31

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1014 en: 02-10-2015, 21:13 (Viernes) »
Muchas gracias por la respuesta.Ahora tengo una pregunta ¿ para devolver el tp link al firmware de fabrica podria meter la imagen de este y ya o tendria que hacer algo mas? ¿y para dejarlo como ap wifi simplemente quito el wifi al de movistar y pongo conectado el tp link desactivando el dhcp o algo mas?


Carlidov

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1015 en: 04-10-2015, 10:52 (Domingo) »
Si he reiníciado, varias veces, de hecho la única que ha medio funcionado, ha sido al aplicar el script sobre la configuración anterior sin reiniciar se veía imagenio pero no tenía internet.
En cuanto se reinicia volvemos a esta situación...



Hola, yo tenía el mismo problema que tu y el problema era que la señal no estaba entrando por el puerto wan, si no que estaba entrando por el puerto 1 creo que era. Lo solucione cambiando desde luci la wan.
Espero que esta sea tu solución, un saludo. ;)


Notakas

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1016 en: 04-10-2015, 15:16 (Domingo) »
Más dolores de cabeza.

Para librarme del router de movistar que me andaba dando muchos problemas me he pillado un TP-Link WDR3600 y un voip (con router) Cisco SPA 112. El teléfono lo conecto al voip y el router le da red al VOIP por el ethernet. Entonces, el VOIP me marca que tiene conexión de red, y cuando intento llamar parpadea el led de teléfono en el voip, pero el teléfono no da señal.

Presiento que es cosa de OpenWRT, le falta algo por configurar o no sé. Yo simplemente ejecuté el script y se me creó la interfaz voip. ¿Alguna ayuda?

Gracias.


victormurgar

  • Visitante
Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1017 en: 04-10-2015, 15:37 (Domingo) »
Más dolores de cabeza.

Para librarme del router de movistar que me andaba dando muchos problemas me he pillado un TP-Link WDR3600 y un voip (con router) Cisco SPA 112. El teléfono lo conecto al voip y el router le da red al VOIP por el ethernet. Entonces, el VOIP me marca que tiene conexión de red, y cuando intento llamar parpadea el led de teléfono en el voip, pero el teléfono no da señal.

Presiento que es cosa de OpenWRT, le falta algo por configurar o no sé. Yo simplemente ejecuté el script y se me creó la interfaz voip. ¿Alguna ayuda?

Gracias.
Tienes que añadir una ruta estática desde Luci o SSH para eso tienes que buscar en el backup del router de movistar la IP de tu voip

Enviado desde mi Xperia S mediante Tapatalk



standby82

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1018 en: 04-10-2015, 17:50 (Domingo) »
Hola muy buenas a Tod@s.

Llevo mucho tempo buscado información para sustituir el router de FTTH de movistar por otro, porque el mio no hacia mas que bloquearse cada dos por tres.
Hasta que no encontré este foro no comencé a ver luz al final del túnel. Desde aquí quiero dar las gracias a todo el mundo que a aportado su granito de arena para que todo el mundo, desde el usuario mas avanzado hasta el mas principiante haya podido solucionar este problema, en especial muchas gracias a noltari.

Bien, ahora viene mi problema:
Lo primero, deciros que soy muy pero que muy novato en esto del Openwrt!!!
Tengo un router tp-link  TL-WR1043ND con la verion Chaos Calmer 15.05
Ejecute el script de  noltari y todo fue genial, funcionaba internet, la voip, pero no consigo que funcione el imagenio.

Como pista, deciros que cuando ejecute el script de noltari al final me puso algo así como que debía instalar nf_conntrack_rtsp, pero este paquete no lo he encontrado para instalarlo en Open y tampoco se si hay que configurarlo después.

Tambien deciros que la configuracion del deco es la misma que cuando tenia el router original de Movistar, no se si habrá que cambiar alguna ip en el, de todas formas al ejecutar el script le di la opción de dhcp a iptv.

Por supuesto deciros que la configuración de ip´s del deco lo saque del archivo de backup del router de Movistar gracias a la web de noltari

Muchas gracias majos!!!



« Última modificación: 04-10-2015, 17:57 (Domingo) por standby82 »

Notakas

  • Visitante
Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1019 en: 04-10-2015, 23:11 (Domingo) »
Más dolores de cabeza.

Para librarme del router de movistar que me andaba dando muchos problemas me he pillado un TP-Link WDR3600 y un voip (con router) Cisco SPA 112. El teléfono lo conecto al voip y el router le da red al VOIP por el ethernet. Entonces, el VOIP me marca que tiene conexión de red, y cuando intento llamar parpadea el led de teléfono en el voip, pero el teléfono no da señal.

Presiento que es cosa de OpenWRT, le falta algo por configurar o no sé. Yo simplemente ejecuté el script y se me creó la interfaz voip. ¿Alguna ayuda?

Gracias.
Tienes que añadir una ruta estática desde Luci o SSH para eso tienes que buscar en el backup del router de movistar la IP de tu voip

Enviado desde mi Xperia S mediante Tapatalk


He encontrado la IP, creo... Pero no encuentro ni la submask ni el IPv4-gateway que me faltan...