Autor Tema: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)  (Leído 590978 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ghostgoblins

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #780 en: 20-01-2014, 21:33 (Lunes) »
Buenas a todos, Queria saber si con el cable de serie Del siemens m55 http://subefotos.com/ver/?50c1c8aec66234cb28811d39c3207780o.jpg se puede flaxear el ar7518 y como se hace el cable he visto muchos ejemplos pero diferentes, unos cortando y poniendolo directo otros con el chip  max 232, no hay algo que sea mas en concreto, el jtag usb tambien valdria imaguino y como es para hacer pruebas tampoco quiero gastar nada si se puede hacer casero, con un usb de nokia tambien se podria, haber si alguien me puede orientar un poco en este tema, muchas gracias y un saludo a todos.


« Última modificación: 20-01-2014, 21:42 (Lunes) por ghostgoblins »

gasalb

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #781 en: 20-01-2014, 23:41 (Lunes) »
Señores,ya tengo el router con openwrt,pero ahora tengo el siguente problema:la version flasheada no tiene luci(es la de Cienti del tutorial) y el maldito router ;D tiene una clavija diferente a la rj45(donde se le enchufa el adsl) y no puedo instalar Luci.Alguno me puede decir como se cambia a otra imagen de openwrt desde putty,termite,hyperterminal...etc.
¿por comandos se puede conectar a wireless?

qwertyu

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #782 en: 21-01-2014, 10:01 (Martes) »
Señores,ya tengo el router con openwrt,pero ahora tengo el siguente problema:la version flasheada no tiene luci(es la de Cienti del tutorial) y el maldito router ;D tiene una clavija diferente a la rj45(donde se le enchufa el adsl) y no puedo instalar Luci.Alguno me puede decir como se cambia a otra imagen de openwrt desde putty,termite,hyperterminal...etc.
¿por comandos se puede conectar a wireless?

La clavija rj45 no es donde se echufa el adsl, es la de red, donde se enchufa el ordenador. Por la conexion de red es por donde puedes flashear la imagen nueva.

gasalb

  • Visitante
Re:
« Respuesta #783 en: 21-01-2014, 10:14 (Martes) »
Yo lo que quiero decir es que no lo puedo conectar a internet para descargar Luci,lo otro ya lo tengo,como lo dije mas arriba ya tiene openwrt

Enviado desde mi MT15i mediante Tapatalk

qwertyu

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #784 en: 21-01-2014, 16:54 (Martes) »
Tendras que instalar luci a traves de un servidor tftp o por usb.
Lo mas facil es que instales un openwrt que ya tenga integrado luci

gasalb

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #785 en: 21-01-2014, 18:17 (Martes) »
Tendras que instalar luci a traves de un servidor tftp o por usb.
Lo mas facil es que instales un openwrt que ya tenga integrado luci
Ya lo se,por eso pido ayuda para que alguien me ayude con los comandos ya que de linux entiendo muy poco.

ghostgoblins

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #786 en: 22-01-2014, 10:51 (Miércoles) »
 :D :D ;D

qwertyu

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #787 en: 22-01-2014, 13:04 (Miércoles) »
Tendras que instalar luci a traves de un servidor tftp o por usb.
Lo mas facil es que instales un openwrt que ya tenga integrado luci
Ya lo se,por eso pido ayuda para que alguien me ayude con los comandos ya que de linux entiendo muy poco.

Tienes que instalarlo mediante el comando opkg install "ubicacion del paquete de luci"

Aqui lo explica

http://wiki.openwrt.org/doc/techref/opkg#examples

De todas formas es mas facil que flashees una imagen que ya lleve luci...

gasalb

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #788 en: 22-01-2014, 18:25 (Miércoles) »
Si descargo el paquete luci lo pongo en un usb(pendrive) y lo enchufo al ruter,la ruta puede ser "opkg install sda1/paquete luci" ?? La duda es,reconocera el ruter la llave usb sin tener que instalar paquetes??

qwertyu

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #789 en: 24-01-2014, 12:00 (Viernes) »
En principo si esta formateado con un sistema de archivos ext4 y lo enchufas antes de encender el router lo va a montar automaticamente, pero depende de la firmware que hayas instalado

jpsminix

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #790 en: 07-02-2014, 00:26 (Viernes) »
Hola a todos.     Sigo con el tema de los 3 dBm de potencia de Tx.

Me gustaria que alguien (Pteridium) si pudiera,  me aclarase algunas cosillas, respecto al tema de los 3 dBm de Tx del ARV7518.

1º-  En el primer post del hilo dice lo siguiente:
Desde la revisión trunk 35357 de OpenWRT está funcionando todo en los routers Arcadyan/Astoria de ya.com: el gris (ARV4518pw) y el blanco (ARV7518pw). Este último modelo sólo se puede poner a 3dB de potencia de transmisión, pero hay un precioso parche para solucionar este inconveniente.

¿Cual es ese precioso parche ? , ¿Se refiere a esto ?

En el trunk que tiene Noltari de Barrier Breaker, Tki2000 ha sacado un parche que hace que la wifi funcione (aparte de pasar del limite de los 3dBm) en el ARV7518 seguro y supuestamente en el ARV4518 (falta por confirmar):

https://foro.seguridadwireless.net/openwrt/(repositorio)-barrier-breaker-13-12/msg302660/#msg302660

Os pongo el output de mi wifi:

Citar
root@OpenWrt:/# iw list
Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        Coverage class: 0 (up to 0m)
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
        Band 1:
                Capabilities: 0x11ce
                        HT20/HT40
                        SM Power Save disabled
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                Frequencies:
                        * 2412 MHz [1] (27.0 dBm)
                        * 2417 MHz [2] (27.0 dBm)
                        * 2422 MHz [3] (27.0 dBm)
                        * 2427 MHz [4] (27.0 dBm)
                        * 2432 MHz [5] (27.0 dBm)
                        * 2437 MHz [6] (27.0 dBm)
                        * 2442 MHz [7] (27.0 dBm)
                        * 2447 MHz [8] (27.0 dBm)
                        * 2452 MHz [9] (27.0 dBm)
                        * 2457 MHz [10] (27.0 dBm)
                        * 2462 MHz [11] (27.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed, WDS, P2P-client } <= 2048, #{ AP, mesh point, P2P-GO } <= 8, #{ IBSS } <= 1,
                   total <= 2048, #channels <= 1, STA/AP BI must match
                 * #{ IBSS, AP } <= 1,
                   total <= 1, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz}

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing

EDITO!!: Los GPIO libres que he encontrado en el ARV7518 en la version attitude (12.09, parece ser que en la version barrier cambian)



La finalidad de todo esto, era añadir una tarjeta MMC para tener un overlay dado que al conectar un USB la bobina que esta al lado (o eso creo) generaba ruido electronico infernal (un zumbido muy molesto y agudo). He conseguido que funcione completamente en la 12.09, pero creo que en la BARRIER cambian la numeración de los GPIO (estoy buscando cuales son, no tardare mucho). La tasa de transferencia es triste... 20Kbytes/s.. pero oye.. arrancar el router son 5 min, pero una vez que lo tienes completamente instalado y configurado, todo cargado en ram, va como un tiro. Cada uno puede usar esos GPIO libres para lo que quiera :)


Siento el desastre de la tarjeta en las fotos pero he cambiado 3 veces de ubicacion la MMC, y cada vez el sitio donde iba a dejarla era distinto, asi que para hacer pruebas.. lo he dejado asi hasta que consigua lo que quiero (gtalk por asterisk :D, que ya lo he conseguido pero el hardware no funciona del telefono :S).


NOTA: Es posible que mis notas no se entiendan muy bien.. eran apuntes que iba cogiendo en el momento, sino se entienden nada, lo organizo todo y lo subo, pero al menos hay algo para los que quieran :)

La configuracion de GPIOs que he usado para mi MMC (mmc over gpio) son:
- ATTITUDE ADJUSTMENT
Citar
config 'mmc_over_gpio'
        option 'name' 'MMCmod'
        option 'enabled' '1'
        option 'DI_pin' '22'
        option 'DO_pin' '17'
        option 'CLK_pin' '0'
        option 'CS_pin' '16'

        option 'mode' '0'
- BARRIER BREAKER
Citar
config 'mmc_over_gpio'
        option 'name' 'MMCmod'
        option 'enabled' '1'
       option 'DI_pin' '246'
        option 'DO_pin' '241'
        option 'CLK_pin' '224'
        option 'CS_pin' '240'

        option 'mode' '0'

Se me olvidaba algo muy importante para poder hacer overlay con la MMC. En la 12.09, faltan 2 detalles:
 1- En el directorio de compilacion, crear "~/files/config". El mmc_over_gpio, se apoya en el directorio /config para cargar la configuracion de los pines, sino existe desde el arranque (y con un squashfs, solo lo puedes meter a la hora de compilarlo), no cargara la configuración y por tanto no vera la MMC.
 2.- Cargar los modulos desde la fase preinit, esto se hace creando el fichero /lib/preinit/56_mmc con:
Citar
echo CARGANDO MODULOS MMC
insmod crc-ccitt
insmod crc-itu-t
insmod crc16
insmod crc7
insmod spi-bitbang
insmod spi-gpio
insmod spi_gpio_old
insmod mmc_core
insmod mmc_block
insmod mmc_spi
insmod gpiommc
sleep 2;
echo ARRANCANDO MMC
/etc/init.d/mmc_over_gpio start
sleep 5;
echo MMC ARRANCADA

Si hay algun tipo de problema, se vera algo asi el dmesg:
Citar
[   65.112000] gpio-mmc: Failed to request mmc_spi module.
[   65.120000] mmc_spi spi32766.0: ASSUMING 3.2-3.4 V slot power
[   65.124000] mmc_spi spi32766.0: SD/MMC host mmc0, no DMA, no WP, no poweroff
[   65.132000] gpio-mmc: MMC-Card "default" attached to GPIO pins di=106, do=101, clk=102, cs=105
[   68.168000] mmc_spi spi32766.0: setup: unsupported mode bits 4
[   68.172000] mmc_spi spi32766.0: can't change chip-select polarity
[   68.200000] mmc0: host doesn't support card's voltages
[   68.204000] mmc0: error -22 whilst initialising SDIO card
[   68.216000] mmc0: host doesn't support card's voltages
[   68.220000] mmc0: error -22 whilst initialising SD card
[   68.228000] mmc0: host doesn't support card's voltages
[   68.232000] mmc0: error -22 whilst initialising MMC card

Si carga bien la MMC:
Citar
[   65.012000] gpio-mmc: Failed to request mmc_spi module.
[   65.020000] mmc_spi spi32766.0: ASSUMING 3.2-3.4 V slot power
[   65.024000] mmc_spi spi32766.0: SD/MMC host mmc0, no DMA, no WP, no poweroff
[   65.032000] gpio-mmc: MMC-Card "default" attached to GPIO pins di=2, do=6, c5
[   65.064000] mmc_spi spi32766.0: setup: unsupported mode bits 4
[   65.068000] mmc_spi spi32766.0: can't change chip-select polarity
[   65.140000] mmc0: new high speed MMC card on SPI
[   65.168000] mmcblk0: mmc0:0001 MMC+   487 MiB
[   65.240000]  mmcblk0: p1

NOTA2: El error " gpio-mmc: Failed to request mmc_spi module." siempre me aparece, pero funciona de todas maneras, incluso estando cargado el modulo.
NOTA3: Los GPIO's de los dmesg, es debido a probar varias ramas del OpenWRT, que cambia de una a otra los GPIO's.

EDITADO: He quitado una foto de un apunte que no se entendia nada, he actualizado la de los gpios con la version de attitude y barrier, y he completado un poco mas el script del preinit.

Gracias a Noltari y a Tki2000 por vuestros esfuerzos en esta rama.
Un saludo
« Última modificación: 10-02-2014, 02:12 (Lunes) por jpsminix »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2205
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #791 en: 07-02-2014, 19:45 (Viernes) »
Gracias.

Muy, pero que muy interesante.  ;)

jpsminix

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #792 en: 07-02-2014, 19:54 (Viernes) »
Subi la info al anterior, sry por duplicar post. Admin, borrarlo si quereis que yo no puedo (o no se como al menos  :-X)
« Última modificación: 07-02-2014, 20:08 (Viernes) por jpsminix »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2205
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #793 en: 07-02-2014, 20:19 (Viernes) »
La finalidad de todo esto, era añadir una tarjeta MMC para tener un overlay dado que al conectar un USB la bobina que esta al lado (o eso creo) generaba ruido electronico infernal (un zumbido muy molesto y agudo).

En algún sitio leí, ahora no recuerdo dónde, que para evitar el ruido de la bobina la gente ponía silicona para sellar la bobina. No sé si daría resultado.

jpsminix

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #794 en: 07-02-2014, 20:43 (Viernes) »
La finalidad de todo esto, era añadir una tarjeta MMC para tener un overlay dado que al conectar un USB la bobina que esta al lado (o eso creo) generaba ruido electronico infernal (un zumbido muy molesto y agudo).

En algún sitio leí, ahora no recuerdo dónde, que para evitar el ruido de la bobina la gente ponía silicona para sellar la bobina. No sé si daría resultado.

Le meti silicona caliente con una pistola (grabe error... parece ser que existen esprays de laca o algo al estilo justo para estas cosas ). Como le meti silicona caliente (que no hizo nada) cree una pelicula que tapaba todas las entradas... y al desoldarlo me fije que se habia roto un hilo de los 3 que lleva.. pero bueno, he comprado uno nuevo, espero que no tenga ese fallo.. por que creo que por desoldar la bobina.. he perdido el switch (tengo la interfaz eth0 y mensajes en dmesg, pero no funciona, no responde a ping) y creo que ha tocado algo el telefono voip (me aparecen fallos que antes no tenia)

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2205
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #795 en: 07-02-2014, 20:57 (Viernes) »
Oooops... Ya sé dónde lo leí... era un mensaje tuyo unas páginas atrás...  ^-^

Si ves que te funciona el USB normalmente con el nuevo pondría el extroot en un pincho. O ya puestos, suelda un mini hub USB a los pines del USB por dentro y deja el mini hub dentro del router con un pincho puesto,... o un lector de tarjetas y aprovechas la que tienes.

De todas formas si no hubieras tenido el problema del USB no tendríamos esos gpios localizados, así que gracias.


quiquesk

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #796 en: 08-02-2014, 13:38 (Sábado) »
Hola a todos
Tenía el Router un poco olvidado, con el openwrt instalado (aunque sin Luci) y me propuse dejarlo bien arreglado, para ser accesible via explorador . Vi que había un firmware con el Luci instalado, pero no me fijé en si mi router era la versión pensada para ese firmware, y lo que ha ocurrido es que sí, me lo ha instalado pero al final me pone kernel panic. Os envío el mensaje que da:

Código: [Seleccionar]

U-Boot 2010.03 (May 16 2012 - 05:51:08)

Board: ARV4518PW
SoC: Danube/Twinpass/Vinax-VE V1.3, DDR Speed 166 MHz, CPU Speed 333 MHz
DRAM:  64 MB
Flash:  4 MB
Net:
searching for rtl8306 switch ... found
lq_cpe_eth
Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at b0030000 ...
   Image Name:   MIPS OpenWrt Linux-3.7.1
   Created:      2013-01-09  11:26:46 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1093866 Bytes =  1 MB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.7.1 (pepe@debian) (gcc version 4.6.4 20121210 (prerelease) (Linaro GCC 4.6-2012.12) ) #4 Wed Jan 9 12:26:36 CET 2013
[    0.000000] SoC: Danube rev 1.3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019641 (MIPS 24KEc)
[    0.000000] Board: ARV4518PW - SMC7908A-ISP, Airties WAV-221
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Kernel command line: console=ttyLTQ0,115200 init=/etc/preinit
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] __ex_table already sorted, skipping sort
[    0.000000] Writing ErrCtl register=00048cc8
[    0.000000] Readback ErrCtl register=00048cc8
[    0.000000] Memory: 61392k/65536k available (2521k kernel code, 4144k reserved, 565k data, 232k init, 0k highmem)
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 333MHz
[    0.000000] Calibrating delay loop... 221.18 BogoMIPS (lpj=442368)
[    0.040000] pid_max: default: 32768 minimum: 301
[    0.044000] Mount-cache hash table entries: 512
[    0.048000] pinctrl core: initialized pinctrl subsystem
[    0.052000] NET: Registered protocol family 16
[    0.072000] pinctrl-xway 1e100b10.pinmux: Init done
[    0.076000] dma-xway 1e104100.dma: Init done - hw rev: 3, ports: 5, channels: 20
[    0.084000] PCI host bridge /fpi@10000000/pci@E105400 ranges:
[    0.088000]  MEM 0x0000000018000000..0x0000000019ffffff
[    0.092000]   IO 0x000000001ae00000..0x000000001affffff
[    0.112000] bio: create slab <bio-0> at 0
[    0.120000] usbcore: registered new interface driver usbfs
[    0.124000] usbcore: registered new interface driver hub
[    0.128000] usbcore: registered new device driver usb
[    0.132000] PCI host bridge to bus 0000:00
[    0.136000] pci_bus 0000:00: root bus resource [mem 0x18000000-0x19ffffff]
[    0.140000] pci_bus 0000:00: root bus resource [io  0x1ae00000-0x1affffff]
[    0.144000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.148000] pci 0000:00:0e.0: BAR 0: assigned [mem 0x18000000-0x1800ffff]
[    0.152000] pci 0000:00:0e.0: SLOT:14 PIN:1 IRQ:30
[    0.156000] Switching to clocksource MIPS
[    0.164000] NET: Registered protocol family 2
[    0.172000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[    0.176000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.184000] TCP: Hash tables configured (established 2048 bind 2048)
[    0.192000] TCP: reno registered
[    0.192000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.200000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.208000] NET: Registered protocol family 1
[    0.212000] gptu: totally 6 16-bit timers/counters
[    0.216000] gptu: misc_register on minor 63
[    0.220000] gptu: succeeded to request irq 126
[    0.224000] gptu: succeeded to request irq 127
[    0.232000] gptu: succeeded to request irq 128
[    0.236000] gptu: succeeded to request irq 129
[    0.240000] gptu: succeeded to request irq 130
[    0.244000] gptu: succeeded to request irq 131
[    0.248000] ath5k,eeprom 103f0400.ath5k_eep: loaded ath5k eeprom
[    0.264000] lantiq,vmmc 1f103000.vmmc: requested GPIO 255
[    0.272000] lantiq,vmmc 1f103000.vmmc: reserved 1MB at 0x03900000
[    0.280000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.288000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.296000] msgmni has been set to 119
[    0.300000] io scheduler noop registered
[    0.304000] io scheduler deadline registered (default)
[    0.312000] 1e100c00.serial: ttyLTQ0 at MMIO 0x1e100c00 (irq = 112) is a lantiq,asc
[    0.320000] console [ttyLTQ0] enabled, bootconsole disabled
[    0.320000] console [ttyLTQ0] enabled, bootconsole disabled
[    0.336000] ltq_nor: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x0000c2 Chip ID 0x0022a8
[    0.344000] Amd/Fujitsu Extended Query Table at 0x0040
[    0.348000]   Amd/Fujitsu Extended Query version 1.1.
[    0.352000] number of CFI chips: 1
[    0.356000] 4 ofpart partitions found on MTD device ltq_nor
[    0.360000] Creating 4 MTD partitions on "ltq_nor":
[    0.364000] 0x000000000000-0x000000010000 : "uboot"
[    0.372000] 0x000000010000-0x000000020000 : "uboot_env"
[    0.380000] 0x000000020000-0x0000003f0000 : "linux"
[    0.432000] no uImage or brnImage or eva found in linux partition
[    0.436000] Can't split linux partition
[    0.440000] 0x0000003f0000-0x000000400000 : "boardconfig"
[    0.468000] libphy: ltq_mii: probed
[    0.500000] Registering RTL8306SD switch with Chip ID: 0x5988, version: 0x0000
[    0.504000] eth0: attached PHY [Realtek RTL8306S] (phy_addr=1e180000.etop-ff:00, irq=-1)
[    0.516000] wdt 1f8803f0.watchdog: Init done
[    0.520000] leds-gpio gpio-leds.5: pins are not configured from the driver
[    0.536000] TCP: cubic registered
[    0.536000] NET: Registered protocol family 17
[    0.540000] 8021q: 802.1Q VLAN Support v1.8
[    0.548000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


He intentado parar el autoarranque, montar la "paraeta" con el cable serie y el tftp32 y dar la orden run update_openwrt, pero la conexión cable de red (IP Fija 192.168.144.100) del router al PC no la reconoce, y por eso no funciona el TFTP32 y no puedo cargar otro firmware.

¿Qué puedo hacerle?
Muchas gracias.

jpsminix

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #797 en: 08-02-2014, 15:32 (Sábado) »
Has probado con el comando loady y subir la imagen por cable serie?

Este link es para el 7518 (el tuyo es el 4518, de color gris) pero me imagino que los comandos seran muy parecidos (PUNTO 3):
http://blogs.guifi.net/tonic/2012/11/01/openwrt-en-un-arv7518pw/

Yo te diria de reflasear como te digo y subirle una buena imagen.. parece como si se hubiese flaseado mal. No consigue montar la particion root y casca


Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2205
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #798 en: 08-02-2014, 17:11 (Sábado) »
Si el u-boot no te deja flashear y el openwrt no arranca me parece que vas a tener que usar el modo UART.
Si el u-boot que le pusiste es el de CieNti me parece que funcionaban tanto el TFTP como el loady.
En vez de hacer el run update_openwrt, intenta ponerle los comandos manualmente a ver si consigue conectar con el TFTP:

tftp 0x80500000 openwrt.image (o como hayamos llamado a la imagen de openwrt)
era 0xb0020000 +${filesize}
cp.b 0x80500000 0xB0020000 ${filesize}

El TFTPD32 debe estar configurado para escuchar en la dirección IP 192.168.144.100
Mi configuración del TFTPD32 es la siguiente : "PXE Compatibility","Show Progress Bar","Translate Unix Filenames","Bind TFTP to this address : 192.168.144.100","Allow '\' As virtual root". Todas las demas opciones están a OFF.
Mi tarjeta de red sólo tiene IP y netmask. No tiene ni puerta de enlace ni DNS.


gasalb

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #799 en: 09-02-2014, 00:12 (Domingo) »
Hola! Me podeis echar una mano con mi arv 4518 version R01A para instalarle otra imagen que tenga incorporada LUCI.Como lo compre de segundamano,no tengo el cable que se conecta a internet,ya que no es la tipica clavija rj45,por lo tanto no puedo instalar LUCI desde internet.El ruter me responde a la ip 192.168.1.1,putty lo reconoce y aparece lo siguente:  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (Bleeding Edge, r31732)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:/#
Cual seria la manera mas facil de instalarle otra imagen de openwrt o LUCI?