Autor Tema: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)  (Leído 591719 veces)

0 Usuarios y 1 Visitante están viendo este tema.

www-www

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #840 en: 09-04-2014, 00:44 (Miércoles) »
Hola amigos, tengo un SMC7908A-ISP de ya.com que resulta ser el ARV4518. Tengo un puerto USB de Silicon Labs CP210x USB to UART Bridge. Lo he conectado a la placa del router y al pc. Con el tera Term Pro he conseguido entrar en mode administrador. Lo cierro y abro el brndumper para sacar copia de seguridad por lo que pueda ocurrir y me ocurre lo siguiente:

Se abreel programa le coloco el principio y el finl de lo que voy a guardar y le pongo un nombre (ejem. volcado) y al picar en guardar me arroja una ventana que es la que sigue:



Me dice ¡¡¡archivo inválido!!! (o entiendo que es el nombre inválido, mi inglés es muy pobre.

Tengo el XP, también lo he probado en el 7, me ha dado problemas porque no encuentra drivers y he tenido que buscarlo, me lo coloca en dispositivos como un nueco COM pero me aparece una interrogación en puerto serie pci.

¿Conocéis algún otro software para sacar el backup que no sea el brndumper?

¿Sabéis como solucionarlo?

Saludos y gracias



barriteleves

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #841 en: 09-04-2014, 16:18 (Miércoles) »
hola compañero www.www por lo que de este modelo deberias poder sacar la copia que estas intentado realizar, por lo menos yo en un 4528 la tengo y en el 7518pw tambien por loque creo te pueda ocurrir y darte algun consejo procura dar algunos datos con detalle de lo que realizas y como estas conecado a el por puerto serie supongo ???


nota amplio los datos en mi caso he seguido este manujal al pie de la letra en los dos casos:

http://blogs.guifi.net/tonic/2012/11/01/openwrt-en-un-arv7518pw/

suerte un detalle no se te olvide cuando este en modo administrador cierra el programa terminal que ulices que supongo lo has realizado. pero por insistir que no quede un saludo
« Última modificación: 09-04-2014, 16:22 (Miércoles) por barriteleves »

www-www

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #842 en: 09-04-2014, 18:24 (Miércoles) »
...procura dar algunos datos con detalle de lo que realizas y como estas conecado a el por puerto serie supongo ???

http://blogs.guifi.net/tonic/2012/11/01/openwrt-en-un-arv7518pw/

suerte un detalle no se te olvide cuando este en modo administrador cierra el programa terminal que ulices que supongo lo has realizado. pero por insistir que no quede un saludo

hola Barriteleves, te explico:

Uso un USB que en herramientas de dispositivos pone

USB de Silicon Labs CP210x USB to UART Bridge.


He conectado tres cables del USB a la placa base, el GRND y los RTD y RDX (cruzados), abro el hyperterminal o el tera trem pro (ambos funcionan), elijo el puerto (COM4) coloco la velocidad (115200), enciendo el router y sale el menú maravilloso (al principio me salían marcianitos y nunca paraban de salir y al encender el router entonces ya salían al mil por hora, era un error en la colocación de los cables), doy los tres golpes de espacio, entra en un mini menú de opciones y pulso ! y me sale el del administrador. Cierro el terminal y arranco el tera term pro, para ello he creado un acceso directo y le he añadido

"K:\Documents and Settings\XXXX\Escritorio\SMC-7908-ISP\brndumper-win-0.1\brndumper.exe" --port=\\.\com4

me abre el programa y le fijo el principio y el final y le doy a dump, le pongo un nombre, como total (sin extensión ninguna, y al darle a guardar, me sale la ventana



Lo he realizado desde XP y desde win7, en ambos casos me dió bastantes problemas porque no tenían ni encontraban los drivers, tuve que buscarlos e instalarlos, pero en el 7 me ha quedado una exclamación en herramienta de dispositivos que pone puerto serie PCI

¿Alguna idea de lo que ocurre? ¿Otro software que sirva para hacer el proceso sin que sea el tera term pro? ¿Puede estar dañado el tera term pro? ¿Falta alguna configuración en el tera term?

El manual que me indicas, es precisamente, el que estoy siguiendo y aqui estoy parado y buscando otro software que me permita realizar la copia de seguridad.

Muchas gracias por tu ayuda.

Saludos


Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2205
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #843 en: 10-04-2014, 09:17 (Jueves) »
Con tu misma configuración no me da ningún problema.
¿Dónde estás intentando grabar el fichero? (Pon la ruta completa)

barriteleves

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #844 en: 10-04-2014, 13:10 (Jueves) »
hola compañero dice:

...procura dar algunos datos con detalle de lo que realizas y como estas conecado a el por puerto serie supongo ???

http://blogs.guifi.net/tonic/2012/11/01/openwrt-en-un-arv7518pw/

suerte un detalle no se te olvide cuando este en modo administrador cierra el programa terminal que ulices que supongo lo has realizado. pero por insistir que no quede un saludo

hola Barriteleves, te explico:

Uso un USB que en herramientas de dispositivos pone

USB de Silicon Labs CP210x USB to UART Bridge.


He conectado tres cables del USB a la placa base, el GRND y los RTD y RDX (cruzados), abro el hyperterminal o el tera trem pro (ambos funcionan), elijo el puerto (COM4) coloco la velocidad (115200), enciendo el router y sale el menú maravilloso (al principio me salían marcianitos y nunca paraban de salir y al encender el router entonces ya salían al mil por hora, era un error en la colocación de los cables), doy los tres golpes de espacio, entra en un mini menú de opciones y pulso ! y me sale el del administrador. Cierro el terminal y arranco el tera term pro, para ello he creado un acceso directo y le he añadido

[b]"K:\Documents and Settings\XXXX\Escritorio\SMC-7908-ISP\brndumper-win-0.1\brndumper.exe" --port=\\.\com4[/b]

me abre el programa y le fijo el principio y el final y le doy a dump, le pongo un nombre, como total (sin extensión ninguna, y al darle a guardar, me sale la ventana



Lo he realizado desde XP y desde win7, en ambos casos me dió bastantes problemas porque no tenían ni encontraban los drivers, tuve que buscarlos e instalarlos, pero en el 7 me ha quedado una exclamación en herramienta de dispositivos que pone puerto serie PCI

¿Alguna idea de lo que ocurre? ¿Otro software que sirva para hacer el proceso sin que sea el tera term pro? ¿Puede estar dañado el tera term pro? ¿Falta alguna configuración en el tera term?

El manual que me indicas, es precisamente, el que estoy siguiendo y aqui estoy parado y buscando otro software que me permita realizar la copia de seguridad.

Muchas gracias por tu ayuda.

Saludos



aunque supongo que en el primer caso señalado en color diferente es un error de escritura, ya que una vez apagado el terminal, para que quieres el tera term, entiendo que es el brn no ???


luego en eel otro apartado no esplicas que datos pones de principio y fin ya que se puede realizar de dos formas 1º opcion: 0xbxxxxxxx o 2º opcion: $bxxxxxxx esto es fundamental solo funciona de una forma  creo recordar que la segunda opcion

y te animo a insistir ya que si se puede seguro, solo es cuestion de algunos decatalles como el que has comenado de que no te salia y has cambiado la posicion de rx y tx, tambien puede ser una soldadura fria  o mal contacto de la  masa o gnd. suerte

www-www

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #845 en: 10-04-2014, 17:36 (Jueves) »
Con tu misma configuración no me da ningún problema.
¿Dónde estás intentando grabar el fichero? (Pon la ruta completa)


La carpeta donde está el brndumper es esta:


"K:\Documents and Settings\XXXX\Escritorio\SMC-7908-ISP\brndumper-win-0.1\"

Al darle al Dump se abre la carpeta donde está en brndumper y es ahí donde intento grabar.

¿Influye el tipo de nombre que se le ponga o extensión? Creo que no.

Cita de: barriteleves
aunque supongo que en el primer caso señalado en color diferente es un error de escritura, ya que una vez apagado el terminal, para que quieres el tera term, entiendo que es el brn no Huh

luego en el otro apartado no esplicas que datos pones de principio y fin ya que se puede realizar de dos formas 1º opcion: 0xbxxxxxxx o 2º opcion: $bxxxxxxx esto es fundamental solo funciona de una forma  creo recordar que la segunda opcion y te animo a insistir ya que si se puede seguro, solo es cuestion de algunos decatalles como el que has comenado de que no te salia y has cambiado la posicion de rx y tx, tambien puede ser una soldadura fria  o mal contacto de la  masa o gnd. suerte

Tienes razón donde digo que abro el tera term, es el brndumper. Es un error aunque debajo hablo de como configuré el brndumper.

Los datos los pongo con $b0000000 y $b0400000 para el general y luego intento $b03f0000 y  $b0400000 solo los datos y en ambos me arroja el error.

(Datos de esta web https://forum.openwrt.org/viewtopic.php?pid=167584#p167584)

Con respecto a las soldaduras, yo no he hecho ninguna, he comprado el USB que me trae cinco cables,he abierto el router que trae incluido en la placa base los pines y simplemente los he conectado

El error que cometí con los cables es que no vi bien la marca que señalaba el pin 1 y los coloqué mal.

Después lo he intentado por activa y por pasiva y siempre sale el error que os puse en la captura de pantalla del post anterior.

Por mi pobre inglés y por loque pone en la ventana dice INVALID FILENAME que yo interpreto con NOMBRE DE ARCHIVO INCORRECTO.

Gracias por vuestras respuestas y ¿alguna idea que se os ocurra para solucionar el tema? ¿Existe otro software para conseguir esto que no sea el brndumper?

Muchas gracias.

www-www

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #846 en: 10-04-2014, 18:00 (Jueves) »
¡ ¡ ¡ S O L U C I O N A D O ! ! !

Parece mentira pero he conseguido la solución. He copiado la carpeta del BRNDUMPER al RAIZ de una de mis unidades le he colocado el principio y el final y HA SALIDO FUNCIONANDO Y GUARDANDO DATOS

Quién iba a pensar que tiene que estar en el raíz o en una carpeta que no tenga muchos caracteres, quizás use el sistema DOS, ocho letras y tres para las extensión, y sin espacios en blanco ni signos extraños.

Gracias a todos. Os mantendré informado con lo que consiga.

Saludos

NOTA: Ahora tengo otro problema, desde estas dos webs:

http://blogs.guifi.net/tonic/2012/11/01/openwrt-en-un-arv7518pw/
https://forum.openwrt.org/viewtopic.php?pid=167584#p167584

Para usar el brndumper, los principios y fin para sacar las copias de seguridad ¡¡¡SON DISTINTAS!!! ¿Cuales son las correctas?
« Última modificación: 10-04-2014, 18:37 (Jueves) por www-www »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2205
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #847 en: 10-04-2014, 18:36 (Jueves) »
Los espacios no son amigos de las rutas de programa, de ahí que mucha gente utilice _ y - para suplir los espacios.
También puede ser que no tengas permisos en la carpeta donde quieres escribir. No ejecutes un programa en la misma carpeta en la que te lo has bajado. (Por eso te decía lo de copiarlo en otro sitio).

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #848 en: 10-04-2014, 19:17 (Jueves) »
Para usar el brndumper, los principios y fin para sacar las copias de seguridad ¡¡¡SON DISTINTAS!!! ¿Cuales son las correctas?
- ARV4518: $b0000000 $b0400000 (4MB)
- ARV7518: $b0000000 $b0800000 (8MB)
Parece simple pero el hexadecimal hace cosas así.

www-www

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #849 en: 10-04-2014, 23:48 (Jueves) »
Bueno os cuento como me ha ido. Siguiendo el tutorial de

http://blogs.guifi.net/tonic/2012/11/01/openwrt-en-un-arv7518pw/

He subido el u-boot, todo perfecto, he reiniciado y sale todo sin errores, con un promt nuevo que es

ARV4518>

He subido una imagen del OpenWRT y he seguido con las instrucciones de la web citada:

ARV4518 ⇒ loady 0x80500000
Sube la imagen (5 minutos)
ARV4518 => era ${kernel_addr} +${filesize}
ARV4518 => cp.b ${ram_addr} ${kernel_addr} ${filesize}

Y reinicio (apagando y encendiendo) y... ¡¡¡OOOOHHHH!!! Esto no va, las luces se quedan todas encendidas, no puedo conectar con el router, si entro con el TeraTerm entra y se me queda el promt ARV4518>

Y ahora no se que hacer, por lo menos, ¿como puedo restaurar la copia de seguridad que saqué?

Desde el promt tecleo help y me salen una serie de comandos pero no veo ninguno para subir la copia de seguridad y dejarlo como estaba.

¿Me echáis una mano?

Gracias

NOTA: Puedo entrar vía telnet, pero ese camino no lo conozco. Me aparece el logo de openwrt y una especie de menú, la versión es del 2013.

Siguiendo las recomendaciones de la wiki de openwrt, le he puesto una clave al telnet y... ¡¡¡ahora no puedo entrar por telnet!!! Ahora lo hago por vía SSH desde WINSCP

Estoy hecho un verdadero lio. Las luces apagadas son las LAN, las demás, power, adsl, tfno, etc están encendidas y no puedo entrar tampoco via web. Un ping no llega.
« Última modificación: 11-04-2014, 00:40 (Viernes) por www-www »

espeltron

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #850 en: 11-04-2014, 05:25 (Viernes) »
Hola www-www

Para poder contestarte adecuadamente es necesario que indiques algunos datos:
1.- El modelo de router, no se si estas utilizando un ARV4518 o un ARV7518.
2.- Tampoco se si has hecho un puente permanente en las resistencias que habilitan el modo UART o si has utilizado interruptores y resistencias de 1K.
Lo digo porque en caso de puentes permanentes los 4MB de la parte alta de las memorias de 8MB se deshabilitan.
3.- La direccion del u-boot ASCII que has utilizado.
Por ejemplo algo asi:
http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/lantiq/danube/uboot-lantiq-arv7518PW_ramboot/u-boot.asc
4.- La imagen OpenWrt que le has volcado y grabado.
Por ejemplo algo asi:
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/openwrt-lantiq-danube-ARV7518PW-squashfs.image

Aparte de esto, he de decirte que algunas imagenes mas recientes, por problemas de tamaño omiten incluir el servidor de paginas web uhttp y Luci, y por tanto no tendras pagina web. Tendrias que instalar Luci con paquetes adicionales que hayas descargado previamente o directamente por internet.

Algunos servicos puede que no se inicien por defecto, aunque el servidor de paginas web siempre suele iniciarse tras la instalacion.

Saludos
espeltron

www-www

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #851 en: 11-04-2014, 18:30 (Viernes) »
Hola www-www

Para poder contestarte adecuadamente es necesario que indiques algunos datos:
1.- El modelo de router, no se si estas utilizando un ARV4518 o un ARV7518.
2.- Tampoco se si has hecho un puente permanente en las resistencias que habilitan el modo UART o si has utilizado interruptores y resistencias de 1K.
Lo digo porque en caso de puentes permanentes los 4MB de la parte alta de las memorias de 8MB se deshabilitan.
3.- La direccion del u-boot ASCII que has utilizado.
Por ejemplo algo asi:
http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/lantiq/danube/uboot-lantiq-arv7518PW_ramboot/u-boot.asc
4.- La imagen OpenWrt que le has volcado y grabado.
Por ejemplo algo asi:
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/openwrt-lantiq-danube-ARV7518PW-squashfs.image

Saludos
espeltron

Gracias espeltronpor tu respuesta. Te voy contestando a lo que me preguntas:
1º. Es un SMC-7908A-ISP que se coresponde con el ARV4518
2º. No, no he hecho puentes algunos, he conectado el USB coh los cales GRND, RDX y TDX a la placa base y arrancando el hyperterminal o el Tera Term Pro al encender el router sale el menú para subir el u-boot y luego el openwrt
3º. El u´boot que he usado es este
http://www.cienti.com/arv4518pw/openwrt/files/u-boot-bootstrap.bin que está en la página que he seguido durante todo el proceso http://blogs.guifi.net/tonic/2012/11/01/openwrt-en-un-arv7518pw/
4º. La imagen del openwrt es la de este enlace http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/openwrt-lantiq-danube-ARV4518PW-squashfs.image

Citar
Aparte de esto, he de decirte que algunas imagenes mas recientes, por problemas de tamaño omiten incluir el servidor de paginas web uhttp y Luci, y por tanto no tendras pagina web. Tendrias que instalar Luci con paquetes adicionales que hayas descargado previamente o directamente por internet.

Algunos servicos puede que no se inicien por defecto, aunque el servidor de paginas web siempre suele iniciarse tras la instalacion.

Esta última cita no se como saber si está instalado o como instalar el Luci. ¿Dónde se busca el Luci y como se instala?
Según la wiki de openwrt dice que el servicio wifi viene por defecto desactivado.

Lo que más me mosquea es todas las luces que tiene encendidas cuando conecto por RJ45, que son DSL, internet, voip, phone1, phone2 y usb, las que están apagadas y se encienden es cuando conecto un cable RJ45.

También me mosquea que después de haber terminado el proceso puse telnet 192.168.1.1 y entré saliendo el logo de openwrt y siguiendo la wiki de openwrt le puse una clave al router y ya no puedo volver a entrar por telnet, me dice que no se puede acceder al puerto 23. Puedo conectar via SSH con el WinSCP, pero con eso no se que hacer.

Saludos y gracias

pelocho

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #852 en: 12-04-2014, 00:27 (Sábado) »
Hola a todos.

Conseguí compilar e instalar OpenWRT Attitude Adjustment en mi router 4518pw. He metido Asterisk, MiniDLNA, Samba y Amule. Funciona todo de maravilla, a excepción del Amule, con el que tengo algunos problemas que creo irresolubles.

Desde aquí animo a que os instaléis OpenWrt en vuestros routers de Orange.


doblecero

  • Visitante
Re: Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #853 en: 12-04-2014, 10:48 (Sábado) »
Hola www-www,
Una vez le pones password a root se deshabilita el acesso por telnet. Ahora solo puedes acceeder a la consola vía ssh. Puedes usar putty si es desde windows.

Lo de las luces... No recuerdo como venían por defecto en las imágenes de este router, pero casi seguro puedes cambiar su comportamiento.

Lucí... Una vez entres por ssh pones:
opkg update

Te actualizara la lista de paquetes. Cuando termine, pones:

opkg install luci luci-theme-openwrt

una vez termine de instalar y configurar

/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable


Saludos


Enviado desde mi GT-I9300 mediante Tapatalk

www-www

  • Visitante
Re: Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #854 en: 12-04-2014, 15:00 (Sábado) »
Hola www-www,
Una vez le pones password a root se deshabilita el acesso por telnet. Ahora solo puedes acceeder a la consola vía ssh. Puedes usar putty si es desde windows.

Lo de las luces... No recuerdo como venían por defecto en las imágenes de este router, pero casi seguro puedes cambiar su comportamiento.

Lucí... Una vez entres por ssh pones:
opkg update

Te actualizara la lista de paquetes. Cuando termine, pones:

opkg install luci luci-theme-openwrt

una vez termine de instalar y configurar

/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable


Saludos


Enviado desde mi GT-I9300 mediante Tapatalk

Muchas gracias doble cero. Os cuento mi experiencia.

Después de instalar en u-boot y el openwrt, entré por telnet cambié la contraseña y ya no pude volver a entrar por él, tenía que hacerlo a través de SSH. Esto fue funcionando asi durante algunas horas mientras investigaba el por qué desde la web no podía acceder. El router no tiene conexión a internet por lo que no puedo hacer lo que, muy amablemente me has explicado, llegué a la conclusión de tanto leer información, que la versión del wrt que instalé era mínima, no tenía luci ni nada, vamos lo básico. Encontré otra versión del wrt que ocupaba 2.5 Mg, igual a la que tenía instalada, y la subí y exactamente lo mismo. Ante esta tesitura, doy por perdido el router he intentado restablecer la copia de seguridad que obtuve con el brdumper pero, ¿qué tipo de archivo es la copia? ¿dump, bin, image? No lo sé intenté buscar información sobre ello y no lo encontré, pero mientras buscaba encontré otra versión del wrt que ocupaba 3.5 Mg y decía que llevaba incluido luci, wifi activado, etc,. de perdido al rio, para dejarlo de pisapapeles decido meterle ese firmware y al terminar intento entrar por telnet y ¡¡¡entra!!! PERO me pide una contraseña, probé todo lo que se me ocurrió y nada, lo intenté desde el WinSCP y exactamente igual, la maldita contraseña, y por último, antes de desconectar para guardarlo arranco el navegado y tecleo 192.168.1.1 y ¡¡¡oooohhh!!! me aparece la interfaz de luci y las luces solo cuatro encendidas.

Después de esta película, ahora toca luchar con el openwrt para poder configurarlo como un repetidor, que es lo que me interesa. Conozco el dd-wrt, pero este, es la primera vez que lo veo.

Agradezco toda la ayuda que me habéis brindado. Gracias a todos. Saludos.

barriteleves

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #855 en: 12-04-2014, 16:17 (Sábado) »
hola www.www, no desesperes, el tema esta mas o menos como yo si no sabes compilar y o no puedes como es mi caso hay bien la cuestion estas a espensas de pillar una imagen que te guste y tenga luci, yo al final tengo dos una de Pteridiun que esta e su pack y otra de espeltron que acaba de colgar ayer creo recordar, pero no valen para el tuyo son para el 7518,  este modelo casi no hay imagenes, lo raro es que no tengas para el tuyo hay mas cantidad de ellas prueba otras de la misma forma que has metido estas seguro que lo consigues al final pillar una que tenga luci, y lo primero que debes realizar es cambiar la  password y la direccion ip que trae, si la vas a utilikzar como cliente, por ejemplo todo ello por luci no se te olvide salvar bien y aplicar lo dejas aunque tarde mucho que termine y ya podras entrar y salir como quieras de la imagen con wscp, luci etc. sigue para el adsl los post de espeltron o para wifi van muy bien, el adsl si me ha costado solo lo he consegido con la imagen de espeltron colgada en el hilo de vozip. suerte y paciencia. tambien comentar que el wifi en el 7518 va como un cañon

www-www

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #856 en: 13-04-2014, 12:34 (Domingo) »
hola www.www, no desesperes, el tema esta mas o menos como yo si no sabes compilar y o no puedes como es mi caso hay bien la cuestion estas a espensas de pillar una imagen que te guste y tenga luci, yo al final tengo dos una de Pteridiun que esta e su pack y otra de espeltron que acaba de colgar ayer creo recordar, pero no valen para el tuyo son para el 7518,  este modelo casi no hay imagenes, lo raro es que no tengas para el tuyo hay mas cantidad de ellas prueba otras de la misma forma que has metido estas seguro que lo consigues al final pillar una que tenga luci, y lo primero que debes realizar es cambiar la  password y la direccion ip que trae, si la vas a utilikzar como cliente, por ejemplo todo ello por luci no se te olvide salvar bien y aplicar lo dejas aunque tarde mucho que termine y ya podras entrar y salir como quieras de la imagen con wscp, luci etc. sigue para el adsl los post de espeltron o para wifi van muy bien, el adsl si me ha costado solo lo he consegido con la imagen de espeltron colgada en el hilo de vozip. suerte y paciencia. tambien comentar que el wifi en el 7518 va como un cañon

Gracias barriteleves por tus ánimos y ayuda. Comentarte que, bicheando con el WinSCP, encontré una carpeta con un archivo al abrirlo me decía la versión instalada, etc.

Es la BARRIER BREAKER R35052

Por lo que he leido en la wiki del OpenWRT esta versión no es la estable es la que llaman a Bleeding Edge (o lo que es lo mismo una versión desesperada para que funcione, la traducción, según google es sangrado borde de openwrt).

Nadie sabe donde puedo conseguir una versión estable, que funcione con luci y no me arroje errores al intentar actualizar los paquetes?

Esto lo he publicado en este parte del foro

https://foro.seguridadwireless.net/openwrt/luci-configurar-puerto-lan-como-wan/msg307612/#msg307612

Agradecido y saludos

barriteleves

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #857 en: 13-04-2014, 14:42 (Domingo) »
pues verdaderamente como el modelo que tengo es el 7518pw no te valen pero no desesperes ya que hay soluciones has mirado en el hilo de 4518 7518 vozip ?? miro haber que hay de ese he puesto la imagen que ha colgado espeltron para mi modelo y funciona genial muy estable de momento probando el adsl y el wifi, este ultimo la señal parece que ha bajado con respecto a la otra que tenia con wifi cliente solo que esa si tenia siempre 100 por 100 de señal en los mismo lugares que ahora ha bajado a 60. bueno ahora me toca leer bien el hilo de vozip. haber que conclusiones saco.

barriteleves

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #858 en: 13-04-2014, 14:46 (Domingo) »

www-www

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #859 en: 13-04-2014, 16:17 (Domingo) »
mira esta de Pteridium haber si te va estable
este es el hilo:


https://foro.seguridadwireless.net/openwrt/voip-en-routers-de-yacom-arv4518-y-arv7518/

aqui tienes la imagen:

http://www.mediafire.com/?2w34c64cuhnhw3c

Gracias Barriteleves. Me he bajado esa versión y antes de instalarla he hecho una comparación con la image que tengo instalada y me dice que los archivos son idénticos.

¿Habrá diferencias si lo instalo al ser los archivos iguales? No lo creo. ¿Puede que alguna versión de los paquetes sean distintas? Creo que saltarían las diferencias al comparar ambos archivos.

Recuerdo que el problema que tengo es que no me presenta la actualización de paquetes, da error. No me sale la pestaña red/swicth para convertir una boca lan en wan.

Muchas gracias por tus molestias. Saludos