Autor Tema: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)  (Leído 587078 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #680 en: 06-11-2013, 19:14 (Miércoles) »
Estamos en las mismas, a mi cuando lo pongo para que tire del adsl se reinicia cada 2 por 3 y es fijo por calor, le he puesto un disipador que he recuperado de por ahí, con pasta térmica entre el disipador y lo que lleva, pero se acaba de reiniciar, he deshabilitado varios servicios, hasta el uhttpd, cuando necesite luci ya lo activare, alguna otra solución?
Operativo con PPoE y PPoA. Con mi conexión en 2 días que lo tuve en pruebas no hubo cortes ni nada raro. La autodetección del tipo de ADSL a veces falla, con lo que si los valores de sincronización no te cuadran habría que ver cómo hacer para que se pueda seleccionar manualmente.
¿Exactamente qué quieres decir con reinicios, que el router se reinicia o que pierde el sincronismo con la central? Si es el primer caso habría que ver los logs para poder encontrar el fallo, pero en el segundo tocaría verificar que la línea es estable, que esté bien configurado openwrt, si sólo ocurre cuando se generan conexiones a saco, que es lo que hace ares, emule u otros, o cualquier otra cosa.
No recuerdo si se puede comprobar el margen de ruido y la atenuación a las que sincroniza, ya que también ayudaría a ver si la conexión va muy "justa".


« Última modificación: 06-11-2013, 19:15 (Miércoles) por Pteridium »

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #681 en: 07-11-2013, 16:52 (Jueves) »
No consigo que conecte a internet con una PPOE de telefonica, con los VPI/VCI y demas bien, con ninguna compilacion, con la misma configuracion el 4518 si es operativo...

Algún paquete que falte o algún detalle?

Gracias de antemano.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #682 en: 08-11-2013, 16:07 (Viernes) »
No consigo que conecte a internet con una PPOE de telefonica, con los VPI/VCI y demas bien, con ninguna compilacion, con la misma configuracion el 4518 si es operativo...

Algún paquete que falte o algún detalle?
Seguramente es algún detalle. ¿podrías poner el contenido del archivo network?
Código: [Seleccionar]
cat /etc/config/networkTambién sería de ayuda saber si el router que tienes para adsl sincroniza en ADSL2+, G.dmt o T1.413 (los dos últimos son adsl a secas).

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #683 en: 09-11-2013, 02:33 (Sábado) »
 config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
 
config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ifname 'eth0.1'
        option ipaddr '192.168.1.180'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'
 
config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'
 
config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0t 2 3 4 5'
 
config adsl-device 'adsl'
        option fwannex 'a'
 
config atm-bridge 'atm'
        option unit '0'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option vpi '8'
        option atmdev '0'
 
config interface 'wan'
        option ifname 'nas0'
        option _orig_ifname 'nas0'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'
 
root@OpenWrt:/#
 
 


Método de conexión: ADSL_2plus

Gracias, ahora mismo /etc/init.d/dsl_control me llega a marcar la atenuación de la línea, asi como la capacidad de transferencia de esta 10/1mb de movistar, gracias
« Última modificación: 09-11-2013, 02:35 (Sábado) por eq7mavala »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #684 en: 09-11-2013, 10:19 (Sábado) »
config adsl-device 'adsl'
        option fwannex 'a'
 
config atm-bridge 'atm'
        option unit '0'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option vpi '8'
        option atmdev '0'

Método de conexión: ADSL_2plus

Gracias, ahora mismo /etc/init.d/dsl_control me llega a marcar la atenuación de la línea, asi como la capacidad de transferencia de esta 10/1mb de movistar, gracias

Si tienes ADSL2+ tienes que cambiar "option fwannex" de "a " a "a2p" o borrar esa línea para que autodetecte.

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #685 en: 09-11-2013, 10:52 (Sábado) »
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 88:25:2C:43:73:22
          inet addr:192.168.1.180  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:516 errors:0 dropped:83 overruns:0 frame:0
          TX packets:389 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:68313 (66.7 KiB)  TX bytes:110737 (108.1 KiB)

eth0      Link encap:Ethernet  HWaddr 88:25:2C:43:73:22
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0.1    Link encap:Ethernet  HWaddr 88:25:2C:43:73:22
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:715 errors:0 dropped:0 overruns:0 frame:0
          TX packets:392 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:109392 (106.8 KiB)  TX bytes:110849 (108.2 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:17 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1692 (1.6 KiB)  TX bytes:1692 (1.6 KiB)

wlan0     Link encap:Ethernet  HWaddr 88:25:2C:43:73:23
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:170 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:135 (135.0 B)  TX bytes:38939 (38.0 KiB)

root@OpenWrt:/# /etc/init.d/dsl_control status
Chipset:                Ifx-Danube 1.5
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              10.042 Mb/s / 831 Kb/s
Line Attenuation:       27.4dB / 19.1dB
Noise Margin:           10.0dB / 19.1dB
Line Uptime:            2m 19s

No funciona, es como si no adquiriera dirección IP...  :(

Noltari

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #686 en: 09-11-2013, 11:15 (Sábado) »
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 88:25:2C:43:73:22
          inet addr:192.168.1.180  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:516 errors:0 dropped:83 overruns:0 frame:0
          TX packets:389 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:68313 (66.7 KiB)  TX bytes:110737 (108.1 KiB)

eth0      Link encap:Ethernet  HWaddr 88:25:2C:43:73:22
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0.1    Link encap:Ethernet  HWaddr 88:25:2C:43:73:22
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:715 errors:0 dropped:0 overruns:0 frame:0
          TX packets:392 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:109392 (106.8 KiB)  TX bytes:110849 (108.2 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:17 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1692 (1.6 KiB)  TX bytes:1692 (1.6 KiB)

wlan0     Link encap:Ethernet  HWaddr 88:25:2C:43:73:23
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:170 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:135 (135.0 B)  TX bytes:38939 (38.0 KiB)

root@OpenWrt:/# /etc/init.d/dsl_control status
Chipset:                Ifx-Danube 1.5
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              10.042 Mb/s / 831 Kb/s
Line Attenuation:       27.4dB / 19.1dB
Noise Margin:           10.0dB / 19.1dB
Line Uptime:            2m 19s

No funciona, es como si no adquiriera dirección IP...  :(
El ADSL desde luego va bien.

Lo que parece no estar bien configurado es la zona WAN, porque ni siquiera aparece en el ifconfig.

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #687 en: 09-11-2013, 21:50 (Sábado) »
He probado otro firmware, el que hay colgado 3 pag atrás y el adsl funciona, pero no hay diferencias entre un /etc/config/netwrok y otro, para mi que es algo de que el puerto adsl no esta bien definido o así, no se muy bien que hacer...

Gracias

espeltron

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #688 en: 10-11-2013, 02:34 (Domingo) »
Buenas noches eq7mavala

Revisando los datos de la conexion DSL veo algo extraño:

Line Attenuation:       27.4dB / 19.1dB
Noise Margin:           10.0dB / 19.1dB

La bajada puede estar bien, pero la subida es "rara":
- Los 19.1dB de "Line Attenuation" me parecen excesivos para tener una bajada tan buena.
- El "Noise Margin" de 19.1dB una barbaridad, ya que habitualmente no supera los 10-11dB.

Si no me equivoco estas utilizando el siguiente firmware para el ARV7518PW:
https://www.dropbox.com/s/o9jvsm5scy9mds4/openwrt-lantiq-xway-ARV7518PW-squashfs.image
Al resto de firmwares publicados hasta la fecha le ocurre algo parecido, ya que solo incluyen el archivo del firmware "b".
Solo en compilaciones trunk mas recientes se ha solucionado esto, incluyendo el firmware "a" por defecto, aunque aun no se han subido imagenes compiladas.
Habia un error en la configuracion por defecto del "make menuconfig" que seleccionaba el firmware "b" en vez del "a".

El firmware DSL parece que funciona correctamente, ya que sincroniza, pero no lo hace adecuadamente.

Viendo la libreria que tiene en el interior el archivo "openwrt-lantiq-xway-ARV7518PW-squashfs.image", se ve que solo dispone de un archivo de firmware, el anexo "b":
/lib/firmware/ltq-dsl-fw-b-danube.bin

Desde un telnet o un ssh haz en el router:
ls -la /lib/firmware/
Y mira si existe algun archivo "fw-a"

El firmware "a" es para lineas de telefonia convencionales PSTN = POT.
El firmware "b" es para lineas digitales ISDN = RDSI.

Da igual que configures la conexion con el anexo "a", ya que el archivo de firmware "ltq-dsl-fw-a-danube.bin" no existe en ninguna parte, habria que añadirlo.

En una respuesta de otro tema indico varias formas de arreglarlo:
https://foro.seguridadwireless.net/openwrt/voip-en-routers-de-yacom-arv4518-y-arv7518/msg286157/#msg286157

Asi que puedes arreglarlo facilmente:
- instalando el fw-a directamente con opkg install kmod-ltq-adsl-danube-fw-a
- o reemplaza el archivo /lib/firmware/dsl-fw-b.bin con el /lib/firmware/dsl-fw-a.bin obtenido del paquete kmod-ltq-adsl-danube-fw-a_0.1-1_lantiq.ipk
- o compila de nuevo un "trunk" actual

El siguiente paso es verificar que los parametros ATM sean los adecuados: VPI=8 y VCI=32 estan bien.

A continuacion la configuracion PPPoE tambien es la adecuada.

Saludos

espeltron

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #689 en: 10-11-2013, 18:05 (Domingo) »
He instalado el que hay colgado en el repositorio original de openwrt el xway, con instalar los firmware del Adsl A funciona, pero no soy capaz de instalar el luci-app-qos, por lo que me sirve de poco, no tengo muy claro que va a pasar...  :(

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #690 en: 10-11-2013, 20:30 (Domingo) »
Es como si la interfaz adsl no la reconociese...

Ni aparece en el ifconfig, ni con ifup wan, no tengo ni idea donde esta la interfaz nas0 que veo en otras compilaciones, ni idea

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #691 en: 10-11-2013, 22:14 (Domingo) »
Es como si la interfaz adsl no la reconociese...

Ni aparece en el ifconfig, ni con ifup wan, no tengo ni idea donde esta la interfaz nas0 que veo en otras compilaciones, ni idea
nas0 aparece cuando se ha autenticado con éxito con el ISP.
Pon las últimas líneas que te saca el router al ejecutar el comando logread; seguramente te pondrá algo como "unable to receive PADO packets" y algunos mensajes más de que no consigue negociar la conexión.
¿Qué versión y revisión de openwrt estás usando?
Si quieres probar a hacer otra compilación usa este .config

espeltron

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #692 en: 11-11-2013, 00:41 (Lunes) »
Buenas noches eq7mavala
He instalado el que hay colgado en el repositorio original de openwrt el xway, con instalar los firmware del Adsl A funciona, pero no soy capaz de instalar el luci-app-qos, por lo que me sirve de poco, no tengo muy claro que va a pasar...  :(
Supongo que te refieres a esta imagen:
http://downloads.openwrt.org/snapshots/trunk/lantiq/openwrt-lantiq-xway-ARV4525PW-squashfs.image
Es como si la interfaz adsl no la reconociese...

Ni aparece en el ifconfig, ni con ifup wan, no tengo ni idea donde esta la interfaz nas0 que veo en otras compilaciones, ni idea
Si has elegido esa imagen es posible que tengas problemas con las tarjetas de red integradas, tanto el switch ethernet como la del wifi, ya que los chips son totalmente distintos.
Te pongo ambas paginas con las caracteristicas de los routers:
http://wiki.openwrt.org/toh/t-com/spw502v
http://wiki.openwrt.org/toh/astoria/arv7518pw
No se si la imagen seleccionada tiene los drivers de las tarjetas de red de tu dispositivo, normalmente son validos solamente si el fabricante del chip de red wifi es el mismo.
¿Puedes indicar sobre que router estas haciendo las pruebas?
¿Puedes indicar si te funciona la red ethernet y la red wifi de ese router con la imagen elegida?
Saludos
espeltron


eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #693 en: 11-11-2013, 00:52 (Lunes) »
Buenas noches, estoy trabajando con un 7518pw con su imagen correcta, funciona todo menos el adsl, ahora mismo ya no puedo hacer más pruebas tendrá que ser mañana, muchas gracias

Uso esta:
http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/lantiq/danube/openwrt-lantiq-danube-ARV7518PW-squashfs.image
« Última modificación: 11-11-2013, 00:54 (Lunes) por eq7mavala »

espeltron

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #694 en: 11-11-2013, 02:07 (Lunes) »
Buenas noches, estoy trabajando con un 7518pw con su imagen correcta, funciona todo menos el adsl, ahora mismo ya no puedo hacer más pruebas tendrá que ser mañana, muchas gracias

Uso esta:
http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/lantiq/danube/openwrt-lantiq-danube-ARV7518PW-squashfs.image
Si mal no recuerdo algunas versiones estaban incompletas en cuanto al soporte ADSL.
Compila un "trunk", ya que la 12.09 carece de algunos paquetes como el siguiente:
http://downloads.openwrt.org/snapshots/trunk/lantiq/packages/kmod-ltq-atm-danube_3.10.18-1_lantiq.ipk
O tambien puedes usar la imagen XWAY subida anteriormente en este foro y añadirle el firmware del anexo a.
Yo te puedo asegurar que funciona correctamente el ADSL con la XWAY, haciendo esta modificacion del firmware y revisando que los servicios del arranque necesarios esten cargados y ejecutandose.
Saludos
espeltron

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #695 en: 11-11-2013, 09:45 (Lunes) »
De compilar no tengo ni idea, una vez lo intente y despues de ello no aceptaba la imagen...

Un resumen-recapitulacion de la situacion:

Resultado del logread:

Nov 11 08:31:54 OpenWrt kern.err kernel: [  609.676000] [DSL_BSP_Showtime 916]: Datarate US intl = 831357, fast = 0
Nov 11 08:31:55 OpenWrt user.notice root: Found no matching interface for DSL notification (UP)

OPKG list-installed:
root@OpenWrt:~# opkg list-installed
atm-diagnostics - 2.5.2-4
atm-tools - 2.5.2-4
base-files - 117-r36088
br2684ctl - 2.5.2-4
busybox - 1.19.4-6
dnsmasq - 2.62-2
dropbear - 2011.54-2
firewall - 2-55.1
hotplug2 - 1.0-beta-4
iptables - 1.4.10-4
iw - 3.6-1
jshn - 2013-01-29-0bc317aa4d9af44806c28ca286d79a8b5a92b2b8
kernel - 3.3.8-1-d5f2bfb6ed8babd6e465f20ac2872a76
kmod-ath - 3.3.8+2012-09-07-3
kmod-ath9k - 3.3.8+2012-09-07-3
kmod-ath9k-common - 3.3.8+2012-09-07-3
kmod-atm - 3.3.8-1
kmod-atmtcp - 3.3.8-1
kmod-button-hotplug - 3.3.8-3
kmod-cfg80211 - 3.3.8+2012-09-07-3
kmod-crypto-aes - 3.3.8-1
kmod-crypto-arc4 - 3.3.8-1
kmod-crypto-core - 3.3.8-1
kmod-input-core - 3.3.8-1
kmod-input-gpio-keys-polled - 3.3.8-1
kmod-input-polldev - 3.3.8-1
kmod-ipt-conntrack - 3.3.8-1
kmod-ipt-core - 3.3.8-1
kmod-ipt-nat - 3.3.8-1
kmod-ipt-nathelper - 3.3.8-1
kmod-leds-gpio - 3.3.8-1
kmod-ledtrig-netdev - 3.3.8-1
kmod-ledtrig-usbdev - 3.3.8-1
kmod-lib-crc-ccitt - 3.3.8-1
kmod-ltq-dsl-danube - 3.3.8+3.24.4.4-3
kmod-ltq-dsl-firmware-a-danube - 3.24.4.4-3
kmod-mac80211 - 3.3.8+2012-09-07-3
kmod-nls-base - 3.3.8-1
kmod-ppp - 3.3.8-1
kmod-pppoa - 3.3.8-1
kmod-pppoe - 3.3.8-1
kmod-pppox - 3.3.8-1
kmod-usb-core - 3.3.8-1
kmod-usb-dwc-otg - 3.3.8-1
libblobmsg-json - 2013-01-29-0bc317aa4d9af44806c28ca286d79a8b5a92b2b8
libc - 0.9.33.2-1
libgcc - 4.6-linaro-1
libip4tc - 1.4.10-4
libiwinfo - 36
libiwinfo-lua - 36
libjson - 0.9-2
liblua - 5.1.4-8
libnl-tiny - 0.1-3
libpthread - 0.9.33.2-1
libubox - 2013-01-29-0bc317aa4d9af44806c28ca286d79a8b5a92b2b8
libubus - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
libubus-lua - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
libuci - 2013-01-04.1-1
libuci-lua - 2013-01-04.1-1
libxtables - 1.4.10-4
linux-atm - 2.5.2-4
ltq-dsl-app - 3.24.4.4-1
lua - 5.1.4-8
luci - 0.11.1-1
luci-app-firewall - 0.11.1-1
luci-i18n-english - 0.11.1-1
luci-lib-core - 0.11.1-1
luci-lib-ipkg - 0.11.1-1
luci-lib-nixio - 0.11.1-1
luci-lib-sys - 0.11.1-1
luci-lib-web - 0.11.1-1
luci-mod-admin-core - 0.11.1-1
luci-mod-admin-full - 0.11.1-1
luci-proto-core - 0.11.1-1
luci-proto-ppp - 0.11.1-1
luci-sgi-cgi - 0.11.1-1
luci-theme-base - 0.11.1-1
luci-theme-openwrt - 0.11.1-1
mtd - 18.1
netifd - 2013-01-29.2-4bb99d4eb462776336928392010b372236ac3c93
opkg - 618-3
ppp - 2.4.5-8
ppp-mod-pppoa - 2.4.5-8
ppp-mod-pppoe - 2.4.5-8
swconfig - 10
ubus - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
ubusd - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
uci - 2013-01-04.1-1
uhttpd - 2012-10-30-e57bf6d8bfa465a50eea2c30269acdfe751a46fd
wpad-mini - 20120910-1

/etc/config/network

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.12'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'
        option netmask '255.255.255.0'
        option ifname 'eth0.1'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config adsl-device 'adsl'
#       option fwannex 'a'
#       option annex 'a2p'

config atm-bridge 'atm'
        option unit '0'
        option vpi '8'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config interface 'wan'
        option ifname 'nas0'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'

He mirado y creo que tengo instalado el paquete kmod-ltq-atm-danube_3.10.18-1_lantiq.ipk y manualmente me dice que las dependencias y tal...

De todas formas, acabo de instalar todos los kmod-ltq*  que he visto..

opkg install kmod-ltq-dsl-danube kmod-ltq-dsl-firmware-a-danube
kmod-ltq-ifxos kmod-ltq-kpi2udp kmod-ltq-tapi kmod-ltq-vmmc


Y nada de nada...
Gracias

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #696 en: 11-11-2013, 16:45 (Lunes) »
Prueba esta imagen de Attitude Adjustment a ver si te da problemas o si "rula" bien. Si todo va ok luego te mando el config.
No metí muchos paquetes relativamente útiles porque pensé que podría hacerse muy grande, pero con QoS y alguna cosilla más sólo ocupa 4MB.

espeltron

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #697 en: 11-11-2013, 20:04 (Lunes) »
Buenas tardes eq7mavala

Te voy a indicar una prueba rapida, sin tener que hacer compilaciones y usando lo que tienes actualmente.

He comparado el listado de paquetes que has indicado con alguna compilacion que tenia hecha en la 12.09 e indicare algunos paquetes que pueden ser la solucion al problema de la Attitude Adjustment 12.09, ya que no puedes usar la XWAY debido a que te surgen otros problemas.

La imagen de la 12.09-rc2 coincide con la 12.09 definitiva.
Puedes comparar ambos archivos:
http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/lantiq/danube/openwrt-lantiq-danube-ARV7518PW-squashfs.image
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/openwrt-lantiq-danube-ARV7518PW-squashfs.image
Por esto voy a indicar unicamente paquetes de la 12.09 definitiva y no de la realease candidate 2.

Manten el listado de paquetes que has indicado y los paquetes que indicas posteriormente:
opkg install kmod-ltq-dsl-danube kmod-ltq-dsl-firmware-a-danube kmod-ltq-ifxos kmod-ltq-kpi2udp kmod-ltq-tapi kmod-ltq-vmmc

Si tu router no tiene conexion directa a internet:
Descarga los siguientes archivos y copialos a la carpeta temporal que utilices para las instalaciones offline:

http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-lib-crc16_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-bridge_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-stp_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-llc_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-swconfig_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-libphy_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/libip4tc_1.4.10-4_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/libip6tc_1.4.10-4_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/luci-app-qos_0.11.1-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/qos-scripts_1.2.1-6_all.ipk

He comprobado que los 10 archivos de la 12.09-rc2 son identicos a los indicados de la 12.09.
En total son unos 44KB, y no se si sera necesario alguno mas por temas de dependencias.

El paquete kmod-atmtcp no lo he tenido que usar nunca, y para evitar problemas de configuraciones inadecuadas lo podrias eleminar.

opkg remove kmod-atmtcp

En cambio tienes que dejar el paquete kmod-atm, ya que este si se utiliza.

Intenta instalar los siguientes paquetes con los paquetes que te pidan sus dependencias:

opkg install kmod-lib-crc16
opkg install kmod-bridge kmod-stp kmod-llc
opkg install kmod-swconfig kmod-libphy
opkg install libip4tc libip6tc
opkg install luci-app-qos qos-scripts

Puede que alguno sea innecesario, pero de momento instalalos todos y mas adelante prueba a eliminar el que consideres innecesario.

Mira a ver si hay algun avance y lo comentas.

Nota:
El paquete kmod-ltq-atm-danube de la rama "trunk" no aparece en la 12.09.
Esto es debido a una reestructuracion de los paquetes.
El modulo interno "ltq_atm_danube.ko" de la "trunk" creo que sustituye al "lantiq_atm.ko" de la 12.09.
Por esto en la rama "trunk" ya no aparece "kmod-ltq-dsl-danube" y si se encuentra "kmod-ltq-atm-danube".

Dicho modulo "lantiq_atm.ko" se encuentra en el siguiente paquete de la 12.09:
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-ltq-dsl-danube_3.3.8%2b3.24.4.4-3_lantiq.ipk
Paquete que ya tienes instalado.

Saludos
espeltron
« Última modificación: 11-11-2013, 20:37 (Lunes) por espeltron »

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #698 en: 12-11-2013, 15:42 (Martes) »
Prueba esta imagen de Attitude Adjustment a ver si te da problemas o si "rula" bien. Si todo va ok luego te mando el config.
No metí muchos paquetes relativamente útiles porque pensé que podría hacerse muy grande, pero con QoS y alguna cosilla más sólo ocupa 4MB.

La imagen no me sale disponible, algo del link incorrecto???

Gracias

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #699 en: 12-11-2013, 15:49 (Martes) »
Buenas tardes eq7mavala

Te voy a indicar una prueba rapida, sin tener que hacer compilaciones y usando lo que tienes actualmente.

He comparado el listado de paquetes que has indicado con alguna compilacion que tenia hecha en la 12.09 e indicare algunos paquetes que pueden ser la solucion al problema de la Attitude Adjustment 12.09, ya que no puedes usar la XWAY debido a que te surgen otros problemas.

La imagen de la 12.09-rc2 coincide con la 12.09 definitiva.
Puedes comparar ambos archivos:
http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/lantiq/danube/openwrt-lantiq-danube-ARV7518PW-squashfs.image
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/openwrt-lantiq-danube-ARV7518PW-squashfs.image
Por esto voy a indicar unicamente paquetes de la 12.09 definitiva y no de la realease candidate 2.

Manten el listado de paquetes que has indicado y los paquetes que indicas posteriormente:
opkg install kmod-ltq-dsl-danube kmod-ltq-dsl-firmware-a-danube kmod-ltq-ifxos kmod-ltq-kpi2udp kmod-ltq-tapi kmod-ltq-vmmc

Si tu router no tiene conexion directa a internet:
Descarga los siguientes archivos y copialos a la carpeta temporal que utilices para las instalaciones offline:

http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-lib-crc16_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-bridge_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-stp_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-llc_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-swconfig_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-libphy_3.3.8-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/libip4tc_1.4.10-4_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/libip6tc_1.4.10-4_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/luci-app-qos_0.11.1-1_lantiq.ipk
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/qos-scripts_1.2.1-6_all.ipk

He comprobado que los 10 archivos de la 12.09-rc2 son identicos a los indicados de la 12.09.
En total son unos 44KB, y no se si sera necesario alguno mas por temas de dependencias.

El paquete kmod-atmtcp no lo he tenido que usar nunca, y para evitar problemas de configuraciones inadecuadas lo podrias eleminar.

opkg remove kmod-atmtcp

En cambio tienes que dejar el paquete kmod-atm, ya que este si se utiliza.

Intenta instalar los siguientes paquetes con los paquetes que te pidan sus dependencias:

opkg install kmod-lib-crc16
opkg install kmod-bridge kmod-stp kmod-llc
opkg install kmod-swconfig kmod-libphy
opkg install libip4tc libip6tc
opkg install luci-app-qos qos-scripts

Puede que alguno sea innecesario, pero de momento instalalos todos y mas adelante prueba a eliminar el que consideres innecesario.

Mira a ver si hay algun avance y lo comentas.

Nota:
El paquete kmod-ltq-atm-danube de la rama "trunk" no aparece en la 12.09.
Esto es debido a una reestructuracion de los paquetes.
El modulo interno "ltq_atm_danube.ko" de la "trunk" creo que sustituye al "lantiq_atm.ko" de la 12.09.
Por esto en la rama "trunk" ya no aparece "kmod-ltq-dsl-danube" y si se encuentra "kmod-ltq-atm-danube".

Dicho modulo "lantiq_atm.ko" se encuentra en el siguiente paquete de la 12.09:
http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/danube/packages/kmod-ltq-dsl-danube_3.3.8%2b3.24.4.4-3_lantiq.ipk
Paquete que ya tienes instalado.

Saludos
espeltron

Nada he instalado todo y nada de nada...

Voy a probar si con la imagen que ha puesto Pteridium..
Thanks