Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 665197 veces)

0 Usuarios y 1 Visitante están viendo este tema.

plicostan

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #420 en: 07-07-2014, 13:12 (Lunes) »
Hola a todos,

ayer me vino el técnico de telefónica a instalarme el movistar fusion, y ya que tengo un wdr4300, pues quiero mandar a tomar viento el comtrend que me han dejado. Pero tengo un problema con mi ubuntu, parece ser que es de memoria por lo que leido en los foros, y no consigo compilar openwrt Barrier-Breaker desde el repo del foro(git clone git://github.com/openwrt-es/barrier-breaker-openwrt.git -b barrier-breaker_14.04) para el WDR4300.

¿Alguien me puede pasar una compilación para este router?

Ah! He intentado bajar un par de enlaces de Noltari que había puesto en su dropbox (pág 1 y 17) y ambos están ya desactivados.


GRACIASSSS


Hola,

ésta es la web de openwrt para tu modelo, con los enlaces a las versiones compiladas, pero necesitas saber primero que versión tienes.

http://wiki.openwrt.org/toh/tp-link/tl-wdr4300

Un saludo



deejayexe

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #421 en: 13-07-2014, 04:53 (Domingo) »
Buenas!

Me presento por este foro, y aprovecho para dar las Gracias a Noltari por su trabajo en este post y en otros que he ido leyendo en este foro, acerca de Openwrt, y que me a servido para prejubilar antes de tiempo al Comtrend vg-8050 y poner en marcha un TP-Link TL-WDR4900 v1.

He puesto en este TP-Link TL-WDR4900 v1, el script de Noltari y funciona correctamente, ademas de la voip, salvo imagenio ya que todavía no lo tengo.
Incluso he compilado para este router (Gracias también a jar229 por su post sobre compilar) ,añadiéndole toda esta configuración por defecto mas los paquetes necesarios como luci, idioma,etc. por si a alguien le hiciera falta ya compilado.

Aprovechando este post, comentando,  lo único que me queda es poder hacer que me funcione una Vpn, con Openvpn, para acceder desde el exterior y entre otras cosas realizar llamadas a través del Voip del mismo router, que si me funciona tanto en android como en Pc pero usando como server un Nas Qnap, pero lo que realmente necesito es poder hacerlo desde el mismo router pero no logro hacer que funcione un server en el, ya que siempre me tira el error desde la app "openvpn para android" "read UDP [EHOSTUNREACH]: No route to host (code=113)" y tampoco funciona con openvpn connec . Y eso que he usado distintas configuraciones por ejemplo la recomendada en la wiki http://wiki.openwrt.org/inbox/vpn.howto. He visto que en la lan si puedo acceder a 10.0.0.1 como si fuera mi puerta de enlace 192.168.1.1, pero desde el exterior no.

Revisando el foro no he visto ningun post acerca de montar una Vpn para dar poder usar la voip, y me gustaría poder ponerla marcha y no me importaría hacer un tutorial para usar la voip de movistar con zoiper 3cx, phoner lite en pc, etc.

Saludos deejayexe! ;)
« Última modificación: 13-07-2014, 04:55 (Domingo) por deejayexe »

SaSAX

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #422 en: 19-07-2014, 00:20 (Sábado) »
Enhorabuena por el foro, encantado de estar por aquí.

Gracias a los maestros por esos grandes tutos y dedicación.

He realizado el proceso de Noltari con el script, y todo bien excepto imagenio, se entrecorta una barbaridad. Yo tengo el nuevo desde hace una semana contratado con 100/10Mb. En cuanto conecto el deco de movistarTV, la actividad de la red es frenética (los switchs y router parecen una discoteca). De verás, que he leído y releído el hilo, y otros de FAQS. Creo que puede deberse a la compilación que le he metido a mi WRT4900v1.

Por esto, me preguntaba si podrías pasarme la compilación para el mismo router de alguna manera? Me gustaría probar con tu compilación. Has probado ya con IPTV si va bien?

Estoy deseando quitarme de en medio el VG-8050 de movistar. Tengo muchos problemas con el NAT y UPNP.

Gracias de antemano.

Un saludo.

Buenas!

Me presento por este foro, y aprovecho para dar las Gracias a Noltari por su trabajo en este post y en otros que he ido leyendo en este foro, acerca de Openwrt, y que me a servido para prejubilar antes de tiempo al Comtrend vg-8050 y poner en marcha un TP-Link TL-WDR4900 v1.

He puesto en este TP-Link TL-WDR4900 v1, el script de Noltari y funciona correctamente, ademas de la voip, salvo imagenio ya que todavía no lo tengo.
Incluso he compilado para este router (Gracias también a jar229 por su post sobre compilar) ,añadiéndole toda esta configuración por defecto mas los paquetes necesarios como luci, idioma,etc. por si a alguien le hiciera falta ya compilado.

Aprovechando este post, comentando,  lo único que me queda es poder hacer que me funcione una Vpn, con Openvpn, para acceder desde el exterior y entre otras cosas realizar llamadas a través del Voip del mismo router, que si me funciona tanto en android como en Pc pero usando como server un Nas Qnap, pero lo que realmente necesito es poder hacerlo desde el mismo router pero no logro hacer que funcione un server en el, ya que siempre me tira el error desde la app "openvpn para android" "read UDP [EHOSTUNREACH]: No route to host (code=113)" y tampoco funciona con openvpn connec . Y eso que he usado distintas configuraciones por ejemplo la recomendada en la wiki http://wiki.openwrt.org/inbox/vpn.howto. He visto que en la lan si puedo acceder a 10.0.0.1 como si fuera mi puerta de enlace 192.168.1.1, pero desde el exterior no.

Revisando el foro no he visto ningun post acerca de montar una Vpn para dar poder usar la voip, y me gustaría poder ponerla marcha y no me importaría hacer un tutorial para usar la voip de movistar con zoiper 3cx, phoner lite en pc, etc.

Saludos deejayexe! ;)
« Última modificación: 19-07-2014, 12:59 (Sábado) por SaSAX »

deejayexe

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #423 en: 19-07-2014, 17:13 (Sábado) »
Enhorabuena por el foro, encantado de estar por aquí.

Gracias a los maestros por esos grandes tutos y dedicación.

He realizado el proceso de Noltari con el script, y todo bien excepto imagenio, se entrecorta una barbaridad. Yo tengo el nuevo desde hace una semana contratado con 100/10Mb. En cuanto conecto el deco de movistarTV, la actividad de la red es frenética (los switchs y router parecen una discoteca). De verás, que he leído y releído el hilo, y otros de FAQS. Creo que puede deberse a la compilación que le he metido a mi WRT4900v1.

Por esto, me preguntaba si podrías pasarme la compilación para el mismo router de alguna manera? Me gustaría probar con tu compilación. Has probado ya con IPTV si va bien?

Estoy deseando quitarme de en medio el VG-8050 de movistar. Tengo muchos problemas con el NAT y UPNP.

Gracias de antemano.

Un saludo.

Buenas.

Por ahora no tengo imagenio, y no he podido probarlo asi que por ese lado no podria decirte si va bien o que en este modelo, ya que no dispongo de la configuracion para la iptv.
Te recomiendo que saques la informacion de imagenio de tu router vg-8050 desde la pagina que ha ha puesto noltari: http://noltari.es/movistar/ , cuando la tengas te puedo pasar una compilación con solo luci, y los paquetes necesarios: swconfig, bird4, mcproxy o igmpproxy, kmod-bridge y udpxy. Una vez, lo tengas solo es cuestion de que guardes tu propia carpeta de config y generar otra compilacion ya con tu propia config.
Pero como te digo, voy a ciegas con la iptv, por lo que por ese lado poco puedo ayudar....y en cuanto a la nat y upnp que problema tienes, porque lo mejor es abrir puertos de forma manual y olvidarte del upnp.

Saludos deejayexe!

SaSAX

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #424 en: 20-07-2014, 17:28 (Domingo) »
Muy buenas de nuevo, gracias por contestarme por privado deejayexe... Me has aclarado algunas dudas y estoy trasteando con el último trunk r41707. Lo he configurado a tope: LUCI, LENGUAJE, USB, VSFTP, SAMBA, DDNS, ESTADISTICAS, PUERTOS, etc...
Internet va bien, y el wifi en la banda de 5Ghz al principio parece como que no iba fino. Después de algún ajuste, parece que bien. MovistarTV sigue yendo mal. Va a trompicones, y satura la red con paquetes multicast. Tengo que desenchufar incluso la ONT y reiniciar el router con el deco apagado, y de nuevo todo a la normalidad. En el ajuste del script que pregunta si quiero activar VOD, le digo que "no"...  Por lo demás, le meto todo los parámetros que me pide correctamente, y hasta aquí puedo contar.

De momento no creo que necesite la compilación. Gracias por la ayuda amigo.

Sigo probando.

Un saludo.

kalanda

  • Visitante
Modificación script para que funcione con Buffalo WZR-HP-AG300H
« Respuesta #425 en: 23-07-2014, 01:28 (Miércoles) »
Hola,

Este es mi primer post por aquí aunque llevo meses leyendo este hilo de cara a que me instalasen Movistar TV.  Lo primero quiero dar las gracias a Noltari por este magnifico script que nos hace la vida mas fácil y por todo su trabajo de campo en el tema  :D

Ya tenia fibra (solo internet) funcionando con mi router Buffalo WZR-HP-AG300H con Openwrt Barrier Breaker, pero la semana pasada pedi fusion para tener TV pero no tenia muchas esperanzas en hacerlo funcionar con mi router. Deciros que ha funcionado, todavía lo tengo que tenerlo en observación algún día pero funciona muy bien.

El caso es que este router tiene el caso especial que se contempla en el script para los "rtl8366"con el tema de los eth0 y eth1 (ver esquema)



En mi router el comando swconfig me devuelve:

Código: [Seleccionar]
root@OpenWrt:~# swconfig list
Found: switch0 - ag71xx-mdio.0

Para que funcione he modificado la linea 140 del script para que aplicase la regla especial en mi caso cambiando el "rtl8366" por "ag71xx-mdio"

https://github.com/openwrt-es/ftth-movistar/blob/master/movistar.sh#L140

Así que lo pongo por aquí por si a alguien le ayuda o incluso si Noltari quiere añadir otra condición al script para que contemple este modelo de router.

Gracias de nuevo,
« Última modificación: 23-07-2014, 01:31 (Miércoles) por kalanda »

jfm

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #426 en: 25-07-2014, 11:12 (Viernes) »
Hola a todos.

Quería actualizar el tema del RTSP. Lo doy por perdido  :'(

Para los que no quieran leer mucho hacia atrás: cuando quieres ver una película, un tráiler o una serie del videoclub, la transmisión es distinta que con los canales de televisión normales. El deco establece una sesión RTSP y el contenido se reproduce sólo para ti (unicast). Para cruzar el cortafuegos, existen unos módulos de ayuda que se deben instalar con el kernel. Con estos módulos, el video debería atravesar el cortafuegos y llegar correctamente al deco. Cuando uno sólo tiene un deco se puede forzar que el vídeo vaya al deco con una regla DNAT pero ¿qué hacer si tienes dos o tres decos? Dependes de que el "RTSP NAT helper" funcione. Y no funciona.

Escribí al autor del módulo y me ha contestado que ya no lo desarrolla y que algo ha cambiado en los kernels más recientes y por eso los módulos están "rotos":
http://mike.it-loops.com/item/31

Si algún genio del C se atreve con este reto  ^-^

Entretanto la única opción para manejar varios decos es quedarse con el router de Telefónica o regresar a una versión antigua de OpenWRT que lleve un kernel soportado (<3.7). Esto último no lo he probado aunque debiera funcionar.


« Última modificación: 25-07-2014, 16:05 (Viernes) por jfm »

Goommer

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #427 en: 04-08-2014, 00:33 (Lunes) »
Perdón por colarme en el hilo sin tener conocimiento.

En debian el paquete nf_nat_rtsp compila correctamente con núcleo 3.14, https://packages.debian.org/hu/sid/nat-rtsp-dkms.

Aún no lo he probado, no tengo mucho tiempo, pero quería comentároslo por si queréis ir probando, o viendo las diferencias con el original.

fagmartinez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #428 en: 14-08-2014, 11:13 (Jueves) »
Buenos Días a todos:

una pregunta técnica a cerca de los routers, iba a adquirir un router tp-link AC1750, la cosa es que mirando la compatibilidad del AC1750 con openwrt, me dice que no soporta la banda de los 5Ghz, con lo que creo que este router deja de merecer la pena. Cual me recomendais que sea Dual Band o ac? sobretodo lo usare a parte de imagenio, para hacer streaming de juegos a fullhd con steam. Deciros que mi red es gigabit.

Un saludo

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2083
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #429 en: 14-08-2014, 13:03 (Jueves) »
Buenos Días a todos:

una pregunta técnica a cerca de los routers, iba a adquirir un router tp-link AC1750, la cosa es que mirando la compatibilidad del AC1750 con openwrt, me dice que no soporta la banda de los 5Ghz, con lo que creo que este router deja de merecer la pena. Cual me recomendais que sea Dual Band o ac? sobretodo lo usare a parte de imagenio, para hacer streaming de juegos a fullhd con steam. Deciros que mi red es gigabit.

Un saludo

El TP-Link Archer C7 que no soporta la banda de los 5GHz es la versión 1.0, porque la tarjeta mPCIe que lleva tiene un bug de hardware y el driver no la soporta. La versión 2.0 tiene una tarjeta con hardware 2.0 que arregla las deficiencias de la anterior versión y es soportada en openwrt. Los 2.4GHz están soportados por la tarjeta que lleva integrada en placa.

Si compras un Archer C7 es una lotería que te toque una versión 1.0 o 2.0, porque por fuera son indistinguibles.
Yo tengo una versión 1.0 y le he cambiado la tarjeta que tenía por una con versión hardware 2.0, pero todavía no he compilado ningún openwrt para él, así que lo que te puedo decir es por lo que sé y he leído, no por las pruebas que haya hecho con él. En las próximas dos semanas espero hacer una compilación para él y haber probado la tarjeta nueva.

De todas formas, ya que la tarjeta es una mPCIe y si le metes openwrt, la puedes cambiar por otra que soporte los 5GHz, como una AR9380, que era mi primera opción, aunque si no te encuentras el router por 20€ como me pasó a mí, por el precio que tiene no merece la pena. Al final con las "actualizaciones" me ha salido casi a precio de calle. Una tarjeta mPCIe con 11ac soportada por openwrt puede salir alrededor de los 60-70€.

En resumidas cuentas, si te encuentras una versión 2.0, está todo soportado según la página de openwrt a partir de la revisión r41757. Si te encuentras una versión 1.0, "huye".
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

fagmartinez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #430 en: 14-08-2014, 13:20 (Jueves) »
TKI2000, muchas gracias por tu pronta respuesta, creo que voy a pasar de este modelo.

he visto estos dos tambien ac:

Dlink AC1200
Dlink AC750

Cual me recomendarias?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2083
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #431 en: 14-08-2014, 14:00 (Jueves) »
TKI2000, muchas gracias por tu pronta respuesta, creo que voy a pasar de este modelo.

he visto estos dos tambien ac:

Dlink AC1200
Dlink AC750

Cual me recomendarias?

Hay varios modelos para las velocidades que indicas. Pero en D-Link, lo que he visto con ac, o bien tienen chipset no compatible, o bien las wifi son broadcom y no están soportadas.

Si lo quieres para poner openwrt, aparte del Archer C7 v2.0 no conozco ninguno al que le funcione todo. Si no, la elección es personal.
Lo único que te puedo decir es que si la wifi es Atheros que lleve una versión 2.0 del hardware para no encontrarse con problemas de microcortes en la conexión y que creo que las wifi ac Broadcom no se llevan bien con el resto de marcas.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

alfgut

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #432 en: 18-08-2014, 15:05 (Lunes) »
Primero gracias por el tuto y el script y por las horas de trabajo que le echáis. Os comento mi situación. Hasta hace poco tenía contratada la FTTH de Movistar sin Imagenio, sólo Internet. Como el Comtrend WAP-5813n que me pusieron iba de pena seguí las instrucciones en:

https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-5813n/

Y puse un firmware compilado por Noltari que ya venía además configurado para Movistar (Creo recordar que la r36529).

Ahora he aprovechado la nueva oferta para incluir Imagenio pagando lo mismo que pagaba antes y Movistar ya me ha dado el servicio de alta y me ha mandado un deco a casa por mensajería. Mi pregunta es cómo poner a funcionar Imagenio en el Comtrend. Por lo que entiendo el tutorial sirve para tomar la configuración del router de Movistar con firmware de Movistar y luego aplicarla en el mismo router ya con el firmware Openwrt (o en otro router diferente), pero yo ya parto de Openwrt por lo que no sé cómo debería recuperar esa configuración para usarla en el script.

¿Algún alma caritativa podría echarme una mano indicándome los pasos a seguir? Resumo:

- Router Comtrend WAP-5813n
- Openwrt r36529 preconfigurado con los parámetros Movistar funcionando ok (sin Imagenio)
- Me han enviado el deco de Imagenio y lo quiero poner a funcionar con Openwrt
- ¿Qué tengo que hacer?

Muchísimas gracias por vuestra ayuda, paciencia y comprensión.

Edito para comentar que he restaurado el firmware oficial y he puesto a funcionar Imagenio (ha costado lo suyo en reinicios). Ahora ya tengo los datos de mi "Imagenio versión nueva". Corregidme si me equivoco, tengo que:

1. Incorporar estos datos al fichero movistar.sh
2. Cargar en el Comtrend el firmware Openwrt
3. Ejecutar el script en el Comtrend
4. Meter el puerto 4 como puerto WAN

¿Y ya está?

Gracias por la ayuda

Edito de nuevo: He hecho lo dicho y todo ok salvo que el UPnP no parece funcionar y tampoco el servidor DHCP en el interfaz IPTV. En el script elegí habilitar VOD y en consecuencia hay problemas con el funcionamiento del UPnP y con el NAT. No consigo abrir un puerto para el servidor Plex...

¿Una ayudita por favor?
« Última modificación: 18-08-2014, 22:18 (Lunes) por alfgut »

alfgut

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #433 en: 20-08-2014, 13:26 (Miércoles) »
Hola de nuevo,

Comentar que me he dado por vencido con el tema del uPnP, no consigo hacerlo funcionar. He intentado reinstalar el paquete miniupnpd pero no ha servido de nada. He visto que hacía algunas redirecciones en la tabla de UPnP del Luci pero al comprobar si funcionaban he visto que los puertos seguían cerrados (con el servidor del Plex y también comprobado con el puerto del Transmission).

He devuelto el Comtrend a la R9 de Movistar y he encargado un WDR4300 (N750) que se supone que me llega el viernes. Con el firmware de Movistar funciona todo pero de vez en cuando pierdo la conexión a Internet, por lo que si estoy de viaje y durante el mismo pierdo la conexión pues apañados estamos.

Por otro lado observé que el punto de acceso wifi se saturaba de vez en cuando con el Openwrt. Aclaro que tengo la wifi del router Comtrend desactivada y uso un punto de acceso TP-Link en otra parte de la casa, conectado por cable al router. Creo que se saturaba porque recibía el tráfico de Imagenio también a través de la wi-fi.

¿Podéis decirme si con el WDR4300 tendré problemas con el UPnP o podrán solucionarse?

Gracias de nuevo. Sé que es Agosto y no hay mucha actividad pero precisamente estas fechas son las únicas en las que puedo cacharrear a gusto :)

virusbcn

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #434 en: 21-08-2014, 14:05 (Jueves) »
Gracias, mil gracias por los tutos y los scripts !!!   >:( >:( >:(

Noltari for president  ;D


Por fin he conseguido en mi WDR4900 ver los canales de Movistar TV que vienen con mi FTTH, lo he conseguido en el PC con el VLC y tan contento voy a la tele enchufo el deco, veo que arranca, sincroniza la hora  >:( y........   se queda la pantalla en blanco total, ni menú, ni atrás, ni nada de nada se me queda en blanco, se os ocurre por qué puede ser ???

Los temas que me quedan por realizar son tener acceso por FTP y SMB a un disco y un pen pinchados al router y sobretodo montar una VPN contra el despacho, ya sea por OpenVPN o por IPSEC, a ver si alguien me puede echar una manilla  >:(

alfgut

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #435 en: 21-08-2014, 18:02 (Jueves) »
Pues al final parece que lo tengo funcionando todo OK en el WDR4300 que me ha llegado de Amazon hace un par de horas.

Os cuento cómo lo he hecho yo por si alguien está en la misma situación que lo pueda hacer sin muchos dolores de cabeza.

1. Mi WDR4300 (N750) es v1.7, por lo que he seguido los pasos descritos en https://forum.openwrt.org/viewtopic.php?pid=242539 para instalar la última versión estable del BB: http://downloads.openwrt.org/barrier_breaker/14.07-rc3/ar71xx/generic/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-factory.bin
Resumiendo,
1a. primero hay que instalar la última versión disponible del firmware oficial TP-Link,
1b. luego el firmware OpenWrt indicado desde la propia interfaz web.
1c. Después hacemos un telnet a 192.168.1.1 y ponemos el password de root que queramos ejecutando el comando "passwd"
1d. en el firm que he cargado yo viene Luci, por lo que ya podremos acceder via interfaz web

2. Instalar los módulos necesarios para poder ver imagenio, a mí me faltaban:
bird4 (necesario para importar las rutas RIPv2 de IPTV)
mcproxy o igmpproxy (preferiblemente mcproxy - necesario para acceder a las transmisiones IGMP para IPTV)
kmod-bridge (necesario para habilitar IGMP Snooping y evitar saturar el WiFi)
udpxy (Opcional, sólo si quieres acceder a IPTV vía WiFi)
Yo también he instalado miniupnpd, ya que hago uso del UPnP
He hecho la instalación desde Luci, aprovechando que tenía el otro router conectado a internet, conectando el puerto WAN del WDR4300 a uno de los puertos LAN del Comtrend (o del router que tengáis operativo).

3. Seguir el tutorial del primer post del thread para configurar la conexión (ya habremos sacado los parámetros del Imagenio gracias a la web de Noltari). En mi caso el puerto para WAN es el "1", supongo que será lo mismo para todos los WDR4300 v1.7. Yo he habilitado el VOD y le he puesto la IP 192.168.1.200 (luego le he dado un lease DHCP estático para que el deco siempre tenga esa IP).

Antes tenía un punto de acceso aparte (TP-Link TL-WA801ND), pero ahora estoy utilizando la wifi del propio WDR4300, ya que el punto de acceso se saturaba, ya que parecía que todo el tráfico de Imagenio también pasaba por él.

¿Alguien me podría indicar cómo restringir el tráfico de Imagenio en la wifi de ese dispositivo?
También agradecería que me indicaseis la configuración óptima de la wi-fi del WDR4300, ya que he visto que tiene dos adaptadores. Yo estoy usando el genérico (bgn) y parece que llega a toda la casa, pero tengo curiosidad acerca del otro (an).

Muchas gracias de nuevo y espero que mi granito de arena sea de utilidad para los que se encuentren en mi caso.

virusbcn

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #436 en: 21-08-2014, 18:13 (Jueves) »
Gracias, mil gracias por los tutos y los scripts !!!   >:( >:( >:(

Noltari for president  ;D


Por fin he conseguido en mi WDR4900 ver los canales de Movistar TV que vienen con mi FTTH, lo he conseguido en el PC con el VLC y tan contento voy a la tele enchufo el deco, veo que arranca, sincroniza la hora  >:( y........   se queda la pantalla en blanco total, ni menú, ni atrás, ni nada de nada se me queda en blanco, se os ocurre por qué puede ser ???

Los temas que me quedan por realizar son tener acceso por FTP y SMB a un disco y un pen pinchados al router y sobretodo montar una VPN contra el despacho, ya sea por OpenVPN o por IPSEC, a ver si alguien me puede echar una manilla  >:(

Pues probando, probando, parece que al final funciona, pero tarda más de uno o dos minutos en arrancar tras la pantalla en blanco, los canales se ven bien sin pixelación ni pausas, pero los menús no funcionan, ni la guía, ni la configuración.... quizás pueda ser por qué no he activado el VOD en el script de Noltari ¿????  como ponia errores con el NAT no lo he instalado, probaré otra vez a ver.....

virusbcn

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #437 en: 21-08-2014, 18:33 (Jueves) »
Gracias, mil gracias por los tutos y los scripts !!!   >:( >:( >:(

Noltari for president  ;D


Por fin he conseguido en mi WDR4900 ver los canales de Movistar TV que vienen con mi FTTH, lo he conseguido en el PC con el VLC y tan contento voy a la tele enchufo el deco, veo que arranca, sincroniza la hora  >:( y........   se queda la pantalla en blanco total, ni menú, ni atrás, ni nada de nada se me queda en blanco, se os ocurre por qué puede ser ???

Los temas que me quedan por realizar son tener acceso por FTP y SMB a un disco y un pen pinchados al router y sobretodo montar una VPN contra el despacho, ya sea por OpenVPN o por IPSEC, a ver si alguien me puede echar una manilla  >:(

Pues probando, probando, parece que al final funciona, pero tarda más de uno o dos minutos en arrancar tras la pantalla en blanco, los canales se ven bien sin pixelación ni pausas, pero los menús no funcionan, ni la guía, ni la configuración.... quizás pueda ser por qué no he activado el VOD en el script de Noltari ¿????  como ponia errores con el NAT no lo he instalado, probaré otra vez a ver.....


Pues sí, ha sido activar el VOD y todos los menús y la guía funcionan correctamente y bien rápido, si alguien me puede ampliar esos posibles errores NAT-PMP se lo agradecería.

Muchas gracias Noltari por descubrirme este mundo y dejarme aprender tanto  >:(

Ahora sólo me falta pulir el acceso a SMB/FTP, un poco de DLNA, quizás transmission y sobretodo una VPN contra el despacho, me temo que esto lo tendré que hacer a pelo, sin el GUI de Luci, ¿un poquito de ayuda ????


dtroyanop

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #438 en: 23-08-2014, 10:15 (Sábado) »
buenos días, soy nuevo en el foro he llegado buscando una solución a la basura de router que ponen telefónica movistar con la fibra fusion internet+voip+tv.

el dichoso es un comtrend vg8050 en el que al poner el torrent el router se cuelga y el pc te indica red limitada. por lo que he visto en foros no soy el único que sufre esta chapuza, en el que las soluciones son bajar el numero de descargas por torrent, las conexiones a clientes y limitar la velocidad.
esto pasa con wifi  y con cable lan

el caso es que mirando el tutorial  del post no se si se si metiéndole openwrt mejorará el asunto citado anteriormente y la cobertura... pero la cobertura es lo de menos porque al final acabaré pasando cable ethernet.


tengo unas dudas sobre el tutorial, ya que es mi primera vez en meter openwrt a un router

Paso 1
Opción A: Transferir el fichero movistar.sh al router de la forma que más os guste (usb, scp...).
Opción B: Crear el fichero utilizando vi (copiando el contenido de movistar.txt):


"A"no entiendo como se puede transferir el movistar.sh al router. usb? scp? me podéis decir que es o como se hace?
"B" entiendo que la opción B es crear un firmware con el script de Noltari siguiendo los pasos que indican. una vez con lo que se cree al final del script se puede meter al router cómo una actualización o cómo?

y si sale algo mal se puede devolver al estado de fábrica de movistar en algún momento??

muchas gracias

y gracias a Noltari por el pedazo tutorial

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #439 en: 23-08-2014, 14:08 (Sábado) »
buenos días, soy nuevo en el foro he llegado buscando una solución a la basura de router que ponen telefónica movistar con la fibra fusion internet+voip+tv.

el dichoso es un comtrend vg8050 en el que al poner el torrent el router se cuelga y el pc te indica red limitada. por lo que he visto en foros no soy el único que sufre esta chapuza, en el que las soluciones son bajar el numero de descargas por torrent, las conexiones a clientes y limitar la velocidad.
esto pasa con wifi  y con cable lan

el caso es que mirando el tutorial  del post no se si se si metiéndole openwrt mejorará el asunto citado anteriormente y la cobertura... pero la cobertura es lo de menos porque al final acabaré pasando cable ethernet.


tengo unas dudas sobre el tutorial, ya que es mi primera vez en meter openwrt a un router

Paso 1
Opción A: Transferir el fichero movistar.sh al router de la forma que más os guste (usb, scp...).
Opción B: Crear el fichero utilizando vi (copiando el contenido de movistar.txt):


"A"no entiendo como se puede transferir el movistar.sh al router. usb? scp? me podéis decir que es o como se hace?
"B" entiendo que la opción B es crear un firmware con el script de Noltari siguiendo los pasos que indican. una vez con lo que se cree al final del script se puede meter al router cómo una actualización o cómo?

y si sale algo mal se puede devolver al estado de fábrica de movistar en algún momento??

muchas gracias

y gracias a Noltari por el pedazo tutorial

Buenas,

La opción A no está descrita, pero la opción B sí...
De todas formas, si no sabes cómo copiar el fichero al router es casi mejor que no sigas, porque probablemente no tengas los conocimientos básicos que necesitas para realizar el proceso hasta el final.

A todo esto, el Comtrend VG-8050 no tiene soporte OpenWrt, así que necesitarías utilizar otro router.

Saludos.

//FINAL Y MÁS DOS RESPUESTAS