Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 673839 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Myckelon

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #520 en: 08-11-2014, 16:39 (Sábado) »
Hola a todos.

Llevo tiempo siguiendo el foro y gracias a el he conseguido configurar mi tp-link wdr3600 con openwrt.

Ahora que tengo contratada la fibra de movistar quiero ejecutar el scrip de Noltari para desacerme del comtrend de movistar de una vez por todas.
El problema es que necesito compilar el openwrt con el parche para el VOD ya que tengo en casa dos decos de tv. Y estoy un poco perdido ya que nunca he compilado openwrt.

Os estaria muy agradecido si pudierais pasarme el firm ya compilado para mi router con el parche VOD y lo necesario para ejecutar el script de Noltari.

Muchas gracias a todos



Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #521 en: 08-11-2014, 16:49 (Sábado) »
Hola a todos.

Llevo tiempo siguiendo el foro y gracias a el he conseguido configurar mi tp-link wdr3600 con openwrt.

Ahora que tengo contratada la fibra de movistar quiero ejecutar el scrip de Noltari para desacerme del comtrend de movistar de una vez por todas.
El problema es que necesito compilar el openwrt con el parche para el VOD ya que tengo en casa dos decos de tv. Y estoy un poco perdido ya que nunca he compilado openwrt.

Os estaria muy agradecido si pudierais pasarme el firm ya compilado para mi router con el parche VOD y lo necesario para ejecutar el script de Noltari.

Muchas gracias a todos
Buenas,

Tienes suerte de que guardara los firmwares de los routers similares a mi WDR4300 la última vez que compilé:
http://files.noltari.es/openwrt/firmwares/ar71xx/TL-WDR3600/openwrt-ar71xx-generic-tl-wdr3600-v1-squashfs-sysupgrade_r43179.bin

Y si alguien quiere algún otro:
http://files.noltari.es/openwrt/firmwares/ar71xx/

Saludos!

Myckelon

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #522 en: 08-11-2014, 17:01 (Sábado) »
Hola a todos.

Llevo tiempo siguiendo el foro y gracias a el he conseguido configurar mi tp-link wdr3600 con openwrt.

Ahora que tengo contratada la fibra de movistar quiero ejecutar el scrip de Noltari para desacerme del comtrend de movistar de una vez por todas.
El problema es que necesito compilar el openwrt con el parche para el VOD ya que tengo en casa dos decos de tv. Y estoy un poco perdido ya que nunca he compilado openwrt.

Os estaria muy agradecido si pudierais pasarme el firm ya compilado para mi router con el parche VOD y lo necesario para ejecutar el script de Noltari.

Muchas gracias a todos
Buenas,

Tienes suerte de que guardara los firmwares de los routers similares a mi WDR4300 la última vez que compilé:
http://files.noltari.es/openwrt/firmwares/ar71xx/TL-WDR3600/openwrt-ar71xx-generic-tl-wdr3600-v1-squashfs-sysupgrade_r43179.bin

Y si alguien quiere algún otro:
http://files.noltari.es/openwrt/firmwares/ar71xx/

Saludos!

Muchisimas gracias Noltari voy a intentarlo ahora.

Edito: acabo de instalarlo y todo funciona correctamente los dos decos y el updxy. Gracias por todo Noltari
« Última modificación: 08-11-2014, 18:04 (Sábado) por Myckelon »

Katre04

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #523 en: 08-11-2014, 20:09 (Sábado) »
Hola a todos, Noltari, en la captura del SYSTEM LOG (página 26) he visto esta parte por si puede servir de pista por lo que no consigue conexión wan con la ont:

Wed Nov  5 16:24:57 2014 user.notice upnp daemon: external interface not found, not starting
Wed Nov  5 16:24:57 2014 user.notice firewall: Reloading firewall due to ifup of iptv (eth0.2)
Wed Nov  5 16:24:58 2014 daemon.notice netifd: voip (948): Sending discover...
Wed Nov  5 16:25:07 2014 daemon.warn pppd[961]: Timeout waiting for PADO packets
Wed Nov  5 16:25:07 2014 daemon.err pppd[961]: Unable to complete PPPoE Discovery

he repetido varias veces el borrado del firmware y la ejecución del script y nada.Saludos

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #524 en: 08-11-2014, 20:40 (Sábado) »
Hola a todos, Noltari, en la captura del SYSTEM LOG (página 26) he visto esta parte por si puede servir de pista por lo que no consigue conexión wan con la ont:

Wed Nov  5 16:24:57 2014 user.notice upnp daemon: external interface not found, not starting
Wed Nov  5 16:24:57 2014 user.notice firewall: Reloading firewall due to ifup of iptv (eth0.2)
Wed Nov  5 16:24:58 2014 daemon.notice netifd: voip (948): Sending discover...
Wed Nov  5 16:25:07 2014 daemon.warn pppd[961]: Timeout waiting for PADO packets
Wed Nov  5 16:25:07 2014 daemon.err pppd[961]: Unable to complete PPPoE Discovery

he repetido varias veces el borrado del firmware y la ejecución del script y nada.Saludos
¿Has probado a reiniciar la ONT?
Apaga el router y la ont, enciende la ont, espera a que conecte y enciende el router.

A mi alguna vez me ha pasado que se le iba la olla a la ont...

Saludos.

Katre04

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #525 en: 08-11-2014, 21:44 (Sábado) »
Si lo he hecho, porque me ha pasado en alguna ocasión. He visto en tareas, que hay una deshabilitada miniupnpd. Saludos,

deejayexe

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #526 en: 10-11-2014, 02:04 (Lunes) »
Buenas!

He estado testeando Imagenio y los ultimos scripts tuyos Noltari versiones 13 y 14 y todo correcto en cuanto a Imagenio para un wdr4900 v1 y un wdr3600, que hace unas semanas que tenemos imagenio por casa.

El problema es que Mcproxy, genera mucho trafico multicast por la red  (las luces parpadean al mismo tiempo) y me esta dando problemas en un Nas Qnap y en las consolas también.
Por lo que he intentado como poner el deco en un puerto en concreto del router para que Mcproxy o Igmproxy solo se genere en ese puerto y seguir usando Udpxy de forma remota y local ya que me parece mas efectivo y no saturar tanto la red.
He buscado la información del foro al respecto sobre todo en la pagina 3 de este post y no saco en claro lo que hay que hacer, ya que he probado a dejar marcado-tagged el puerto 2 del switch (boca 1 del router para el deco) para eth0.2 IPTV y dejarlo parado en br-lan y cambiar la config de Mcproxy, tambien lo he intentado creando una lan solo para el deco...probando poniendo eth0.2 en modo brigde...y al final me he hecho un lio porque tambien esta el dchp para el deco en br-lan :-\ y algo se me escapa para que funcione imagenio con VOD en un puerto en concreto para el deco.

No se si es interesante Noltari, pero quizas se podria implementar en una futura actualizacion del script, y asi evitar el trafico multicast en los puertos no necesarios o demas routers que haya en la red y asi generar ese trafico multicast solo para el deco y usar udpxy para la reproduccion en unicast. Si me equivoco corregidme que no se si estoy en lo cierto.

Saludos deejayexe!
« Última modificación: 10-11-2014, 02:18 (Lunes) por deejayexe »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #527 en: 10-11-2014, 07:17 (Lunes) »
Hola deejayexe, no tengo imagenio ni nunca lo he visto de cerca, pero viendo estos post sobre imagenio en openwrt me ha despertado la curiosidad y me puesto a investigar de que va el tema y como funciona esto de la IPTV.

Buscando información he llegado hasta este articulo que me ha parecido muy interesante: http://www.cbelena.es/2013/11/jugando-con-imagenio

El que ha escrito el artículo tenía el mismo problema que tu y en el explica como lo ha solucionado.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Katre04

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #528 en: 10-11-2014, 09:11 (Lunes) »
Hola a todos, ruego que alguien del foro confirme que le funciona todo (Internet, VOIP e IPTV) con el último firmware de Noltari (gracias por tu esfuerzo en este trabajo) y el script R14, en un TP-Link 1043 V1. Lo he intentando repetidas veces y no consigo ni tener Internet. Con otro firmware de Alfredo Matas, si he tenido Internet, pero no IPTV. Gracias por adelantado.

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #529 en: 10-11-2014, 13:06 (Lunes) »
Buenas!

He estado testeando Imagenio y los ultimos scripts tuyos Noltari versiones 13 y 14 y todo correcto en cuanto a Imagenio para un wdr4900 v1 y un wdr3600, que hace unas semanas que tenemos imagenio por casa.

El problema es que Mcproxy, genera mucho trafico multicast por la red  (las luces parpadean al mismo tiempo) y me esta dando problemas en un Nas Qnap y en las consolas también.
Por lo que he intentado como poner el deco en un puerto en concreto del router para que Mcproxy o Igmproxy solo se genere en ese puerto y seguir usando Udpxy de forma remota y local ya que me parece mas efectivo y no saturar tanto la red.
He buscado la información del foro al respecto sobre todo en la pagina 3 de este post y no saco en claro lo que hay que hacer, ya que he probado a dejar marcado-tagged el puerto 2 del switch (boca 1 del router para el deco) para eth0.2 IPTV y dejarlo parado en br-lan y cambiar la config de Mcproxy, tambien lo he intentado creando una lan solo para el deco...probando poniendo eth0.2 en modo brigde...y al final me he hecho un lio porque tambien esta el dchp para el deco en br-lan :-\ y algo se me escapa para que funcione imagenio con VOD en un puerto en concreto para el deco.

No se si es interesante Noltari, pero quizas se podria implementar en una futura actualizacion del script, y asi evitar el trafico multicast en los puertos no necesarios o demas routers que haya en la red y asi generar ese trafico multicast solo para el deco y usar udpxy para la reproduccion en unicast. Si me equivoco corregidme que no se si estoy en lo cierto.

Saludos deejayexe!

A ver, el problema es que yo eso lo considero una configuración avanzada que la mayoría de usuarios no necesita, y ya bastante tengo con conseguir que os funcione todo. Desde mi punto de vista es mejor daros un punto de partida funcional y común y de ahí que cada uno lo adapte a sus necesidades.

Para llevar a cabo la configuración que dices habría que sacar un puerto de la VLAN 1 y añadimos otra VLAN con dicho puerto (la 4 por ejemplo) /etc/config/network:
Código: [Seleccionar]
config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 2 3 4 5'
Quitamos el 5 por ejemplo:
Código: [Seleccionar]
config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 2 3 4'
config switch_vlan
option device 'switch0'
option vlan '4'
option vid '5'
option ports '0t 5'
A partir de ahí, creamos una nueva interfaz (tvlan):
Código: [Seleccionar]
uci set network.tvlan="interface"
uci set network.tvlan.ifname="eth0.4"
uci set network.tvlan.proto="static"
uci set network.tvlan.ipaddr="192.168.2.1"
uci set network.tvlan.netmask="255.255.255.0"
Y la añadimos al firewall en la sección LAN /etc/config/firewall:
Código: [Seleccionar]
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'
->
Código: [Seleccionar]
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan tvlan'

Si quieres que los decos se configuren por DHCP habría que añadir esto a /etc/config/dhcp:
Código: [Seleccionar]
config dhcp 'tvlan'
option leasetime '12h'
option interface 'tvlan'
option start '100'
option limit '100'
list dhcp_option '6,172.26.23.3'
list dhcp_option '240,:::::239.0.2.10:22222:v6.0:239.0.2.30:22222'

Por último, sólo habría que modificar /etc/mcproxy.conf:
Código: [Seleccionar]
# Proxy Instance: upstream ==> downstream
pinstance iptv: "eth0.2" ==> "br-lan";
->
Código: [Seleccionar]
# Proxy Instance: upstream ==> downstream
pinstance iptv: "eth0.2" ==> "eth0.4";

Reiniciamos y todo listo.

Saludos!
« Última modificación: 11-09-2015, 11:12 (Viernes) por Noltari »

Katre04

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #530 en: 10-11-2014, 13:36 (Lunes) »
Hola Noltari, veo que estas conectado y por eso te pregunto si has podido ver si hay alguna pista sobre mi problema de desconexión en wan. Saludos

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #531 en: 10-11-2014, 15:14 (Lunes) »
Hola Noltari, veo que estas conectado y por eso te pregunto si has podido ver si hay alguna pista sobre mi problema de desconexión en wan. Saludos
Lo único que se me ocurre es que en el último trunk haya habido alguna regresión que haya reintroducido los bugs descritos aquí:
http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd#warnings.gotchas
En esa parte de la wiki dice que hay ciertos modelos que tienen problemas con el puerto WAN, aunque supuestamente fueron solucionados en el trunk.
Sin embargo, se comenta una forma de solucionarlo haciendo un downgrade del bootloader que no considero muy segura para usuarios inexpertos.
El tema es que si antes te funcionaba es bastante raro que ahora haya dejado de funcionar...
¿Qué versión de OpenWrt tenías instalada antes?

Saludos!
« Última modificación: 10-11-2014, 16:39 (Lunes) por Noltari »

Katre04

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #532 en: 10-11-2014, 15:45 (Lunes) »
Hola Noltari, la Attitude Adjustment (12.09, r38093) modificada por Alfredo Matas, para en teoría tener todos los servicios (Internet+VOIP+IPTV) La tengo ahora puesta, y me funciona el internet (VOIP no lo he probado). La IPTV no funciona.Saludos,

Katre04

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #533 en: 10-11-2014, 15:48 (Lunes) »
Otra cosa, el modelo es 1043 V1.6 y creo que lo que comentan en ese enlace es para modelo más modernos.Saludos

warren.deleon

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #534 en: 10-11-2014, 19:55 (Lunes) »
Perdona mi ignorancia, pero que quieres que haga exactamente? Quieres que desinstale el IGMProxy e instale mcproxy? Es que de donde descargue el firmware fue en este enlace: http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-tl-wr1043nd-v2-squashfs-factory.bin

Y yo lo que hice fue poner el router blanco de Telefónica en modo bridge, conectar el router TP-LINK en un puerto ethernet, instalar el firmware, desde Luci OpenWRT poner la WAN en modo PPoE. Comprobar que tenía conexión. Conectarme por ssh a OpenWRT hacer "opkg update && opkg install nano && opkg install bird4 && opkg install igmpproxy && opkg install udpxy"

Una vez tenia todo instalado, volví a poner el WAN tal y como estaba antes, desconecté el router de Movistar, conecté el TP-LINK a la ONT y ejecuté tu script. Después de hacer eso, tuve internet directo desde la ONT.

Necesitaria los pasos a seguir para desinstalar el IGMPproxy e instalación de MCproxy. El script me configurará el MCproxy? es que todo esto que instalé lo hice porque ponías que eran requisitos indispensables.

He eliminado VLAN 4 y mi internet sigue funcionando. Ahora mismo no la tengo. Si necesitas conectarte vía Teamviewer a mi Mac OS. Puedo darte los datos por privado y así compruebas por ti mismo. Luego puedo postear los resultados.

Por cierto, no se si es relevante, pero a parte de usar el descodificador de Movistar TV, uso VLC para verlo. Seguirá funcionando? Y otro dato, yo solo uso lo que tengo contratado, nunca compro ni alquilo ninguna peli.
Buenas otra vez,

He compilado un firmware con todo lo necesario (y con mcproxy en vez de igmpproxy):
http://files.noltari.es/openwrt/firmwares/ar71xx/TL-WR1043ND/

Pruébalo con esta nueva versión del script y me comentas:
movistar_r14_test2.sh
movistar_r14_test2.txt

P.D: imagino que ya lo sabes, pero al tener instalado ya OpenWrt debes utilizar la versión sysupgrade del firmware.

Saludos!

OK, utilizaré la imagen del sysupgrade y luego volveré a ejecutar el script hoy a eso de las 22h te escribo una respuesta. Estoy fuera y mi única opción es conectarme vía Teamviewer. Si hago un upgrade del firmware supongo que perderé la conexión a internet y no podría ejecutar el script.

Hola Noltari,

Después de haber realizado la instalación del firmware que me diste ahora tengo el problema que no me deja instalar OpenVPN ni PPPTP. Podrías darme alguna solución? ¿Hay alguna actulización de tu firmware que permita instalar una VPN? Por favor, necesito una solución.

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #535 en: 10-11-2014, 21:23 (Lunes) »
Hola Noltari,

Después de haber realizado la instalación del firmware que me diste ahora tengo el problema que no me deja instalar OpenVPN ni PPPTP. Podrías darme alguna solución? ¿Hay alguna actulización de tu firmware que permita instalar una VPN? Por favor, necesito una solución.
La solución pasa por compilar tú mismo un firmware con todo lo que necesites.

Saludos.

deejayexe

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #536 en: 13-11-2014, 01:40 (Jueves) »


A ver, el problema es que yo eso lo considero una configuración avanzada que la mayoría de usuarios no necesita, y ya bastante tengo con conseguir que os funcione todo. Desde mi punto de vista es mejor daros un punto de partida funcional y común y de ahí que cada uno lo adapte a sus necesidades.

Buenas!

Muchas gracias NOLTARI por tu tiempo y tu ayuda, no he respondido antes porque he estado compilando y probando que todo funciona bien, perfecto diria yo y tambien por tu nuevo config para udpxy!!.
Mi fallo era que no generaba para la nueva lan (tvlan) una ip estatica distinta de la lan común 192.168.1.1 y por eso no funcionaba, vamos que me lie.
Tambien gracias a goommer por su parche para el deco para NAT/PAT y tambien a jfm por su instrucciones para compilar el parche.
Ahora a disfrutar del imagenio y de udpxy!!...Si alguien necesita una compilacion final con todo lo necesario para imagenio, voip para wdr4900 v1 y wdr3600 v1 que me avise. Saludos deejayexe!

pd. Solo me queda openvpn server que lo tengo atravesado y no lo termino de configurar para el router y dejarlo fino!!! ;D

virusbcn

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #537 en: 13-11-2014, 12:05 (Jueves) »
Noltari tengo un WDR4900 que hasta la fecha funcionaba perfectamente con tu script, pero despues de desconectarlo de la corriente y volver a encenderlo no hay manera de conectar con su IP, ni por wifi ni por lan, ¿cómo puedo hacer un reset ????  ahora mismo está "out"   :-[ :-[ :-[

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #538 en: 13-11-2014, 12:40 (Jueves) »
Noltari tengo un WDR4900 que hasta la fecha funcionaba perfectamente con tu script, pero despues de desconectarlo de la corriente y volver a encenderlo no hay manera de conectar con su IP, ni por wifi ni por lan, ¿cómo puedo hacer un reset ????  ahora mismo está "out"   :-[ :-[ :-[
¿Ha dejado de funcionar así porque sí de un día para otro? ¿Sin haber hecho cambios en la configuración? Es un poco raro xD...
Puedes intentar entrar en modo failsafe (Primer punto del FAQ: https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/). Una vez que hayas entrado en el modo failsafe y se reinicie el router con la configuración por defecto vuelve a configurarlo con el script.

De todas formas es raro, porque si no has alterado la configuración sería interesante obtener el log a través del serial para ver qué está pasando. Ojo, que no hace falta, puedes hacer lo del failsafe y si no te funciona ni con esas entonces sí sería necesario...

Saludos.

virusbcn

  • Visitante
Re:
« Respuesta #539 en: 13-11-2014, 15:12 (Jueves) »
Gracias Noltari !!!!
Ya está arreglado,  me daba miedo hacer el reset por lo del openwrt y haber movido el root al pendrive, he hecho el reset al encender el router y curiosamente vuelve a funcionar todo sin problemas
Qué susto !!!!

Enviado desde mi MSX