Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 673837 veces)

0 Usuarios y 1 Visitante están viendo este tema.

dodger

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #460 en: 10-09-2014, 11:23 (Miércoles) »
Buenas,
Ante todo gracias por el magnífico trabajo!
Estoy poniendo mi Openwrt a funcionar, pero la voip no consigo que vaya.
Yo creo que el routing está ok, pero necesito que alguno me confirméis (no sea problema del firewall), actualmente las rutas que tengo son:
root@gigarouter01:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         80.58.67.115    0.0.0.0         UG    0      0        0 pppoe-wan6_inet
10.22.128.0     0.0.0.0         255.255.224.0   U     0      0        0 eth0.3
10.31.255.128   10.22.128.1     255.255.255.224 UG    0      0        0 eth0.3
80.58.67.115    0.0.0.0         255.255.255.255 UH    0      0        0 pppoe-wan6_inet
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

He configurado el router a mano por que es un poco "especial" (tp-link 1043nd v2 con el switch de 6+1 puertos)
Muchas gracias de antemano



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2141
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #461 en: 10-09-2014, 11:46 (Miércoles) »
Si... Gracias... pero seguimos con la burra a brincos... Si, se lo del power line, se lo del wifi... pero no se esto que pregunto...

Yo lo que quiero es conectarlo con el router wifi con openwrt, y en modo cliente (funcionando para un pc ya probado) no funciona para el deco.
Y me gustaria que funcionara...

¿podemos darle solucion por ese camino?

S2

Creo que la opción es redirigir todo el tráfico desde el router ADSL al router openwrt, bien poniendo el modem ADSL como bridge y dejando que sea el router openwrt el que se encargue de conectar por PPPOE, o bien poniendo en el router ADSL una DMZ dirigida al router openwrt en cuyo caso la interfaz WAN del router openwrt debe tener una IP fija (o si hay alguna opción en el router ADSL, redirigir todos los puertos y protocolos a la IP de la WAN del router con openwrt). Si en vez de redirigir todo el tráfico, sólo quieres redirigir unos cuantos puertos y protocolos, tendrás que buscar qué puertos y protocolos son los que se usan, ya que yo los desconozco.

El resto del tutorial debe de ser igual.

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

ppfdez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #462 en: 10-09-2014, 17:20 (Miércoles) »
Buenas,
Ante todo gracias por el magnífico trabajo!
Estoy poniendo mi Openwrt a funcionar, pero la voip no consigo que vaya.
Yo creo que el routing está ok, pero necesito que alguno me confirméis (no sea problema del firewall), actualmente las rutas que tengo son:
root@gigarouter01:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         80.58.67.115    0.0.0.0         UG    0      0        0 pppoe-wan6_inet
10.22.128.0     0.0.0.0         255.255.224.0   U     0      0        0 eth0.3
10.31.255.128   10.22.128.1     255.255.255.224 UG    0      0        0 eth0.3
80.58.67.115    0.0.0.0         255.255.255.255 UH    0      0        0 pppoe-wan6_inet
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

He configurado el router a mano por que es un poco "especial" (tp-link 1043nd v2 con el switch de 6+1 puertos)
Muchas gracias de antemano


Tengo el mismo router que tu y route -n me da una salida muy similar solo cambian direcciones ip pero conceptualmete es la misma.

No he hecho ninguna prueba voip y no te puedo ayudar mas. No se ni por donde se empieza.

Salu2

dodger

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #463 en: 10-09-2014, 20:11 (Miércoles) »
Gracias ppfdez,
Entonces es cosa del fw  ¬¬'
Responderé si consigo algo más.



UPDATE
Pues ya está...
He copiado las opciones adicionales del interface/vlan eth0.3 de Noltari y ya funciona...
queda así:
Código: [Seleccionar]
config interface 'voip'
        option proto 'dhcp'
        option ifname 'eth0.3'
        option accept_ra '0'
        option defaultroute '0'
        option peerdns '0'

Por si alguien tiene problemas con este router (TP-LINK 1043ND v2), hay que dejar las 2 vlans que trae openwrt (1 y 2) SIN tocar y añadir la 3 y la 6 tageando los puertos 5 y 6 del switch.
Por lo demás es todo igual  >:(
Eso sí, el script no lo uséis o no podréis acceder ya que hace cambios en esas 2 vlans y solo se puede entrar por failsafe...
« Última modificación: 10-09-2014, 20:36 (Miércoles) por dodger »

ppfdez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #464 en: 10-09-2014, 23:44 (Miércoles) »
Gracias .......He copiado las opciones adicionales del interface/vlan eth0.3 de Noltari y ya funciona...
Código: [Seleccionar]
config interface 'voip'
        option proto 'dhcp'
        option ifname 'eth0.3'
        option accept_ra '0'
        option defaultroute '0'
        option peerdns '0'
Por si alguien tiene problemas con este router (TP-LINK 1043ND v2), hay que dejar las 2 vlans que trae openwrt (1 y 2) SIN tocar y añadir la 3 y la 6 tageando los puertos 5 y 6 del switch. Por lo demás es todo igual  >:(
Eso sí, el script no lo uséis o no podréis acceder ya que hace cambios en esas 2 vlans y solo se puede entrar por failsafe...

Yo lo tengo igual salvo el accept_ra '0' que no lo tengo.

¿Que cosas haces con voip? Estoy interesado en hacer algo, pero como ya te decía antes estoy pegado sobre el tema y no se como empezar siquiera.

Sobre el tp-link tl-wr1043ND V2 mira:
https://foro.seguridadwireless.net/openwrt/(tutorial)-movistar-ftth-con-openwrt/msg311139/#msg311139
https://foro.seguridadwireless.net/openwrt/(tutorial)-movistar-ftth-con-openwrt/msg311331/#msg311331
https://foro.seguridadwireless.net/openwrt/(tutorial)-movistar-ftth-con-openwrt/msg311344/#msg311344
https://foro.seguridadwireless.net/openwrt/(tutorial)-movistar-ftth-con-openwrt/msg311455/#msg311455
Yo use el script "responsablemente", creo que en su revisión 10 segun explico y todo OK. Lástima que el OpenWRT no sea capaz de aprovechar las posibilidades de nateo por hardware del switch del router.

Salu2.

dodger

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #465 en: 11-09-2014, 11:40 (Jueves) »
PUes díria que el accept_ra es lo único que yo no tenía y que lo ha hecho funcionar...
Yo tuve que hacer un factory después de usar el script (I'm feelink lucky mode), asi que he ido poco a poco, lo último era lo de la voip ya que no tengo IPTV, aunque me gustaría trastear un poco con la config de iptv, a ver que pasa :-P
Lo del nateo por hard no sé a que te refieres como no sea tagear los puertos del router en una vlan.


Sobre la VOIP? pues un asterisk para dominarlo todo ;-)
Es otro tema, por que no me chuta el CallerID :-( miraré si hay información por aquí
« Última modificación: 11-09-2014, 11:44 (Jueves) por dodger »

jfm

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #466 en: 13-09-2014, 21:50 (Sábado) »
¡Hola a todos!
Hace tiempo que no me pasaba por aquí, entre las vacaciones y una vuelta al trabajo de lo más intensa...  :(

Me he estado poniendo al día y he llegado al mensaje de Goommer.

GRACIAS, GOOMMER
 >:( >:( >:( >:( >:( >:( >:(

Tu parche soluciona el problema de los que tenemos varios decos y la configuración nueva (NAT/PAT).

Basta con incluirlo y sin añadir ninguna regla de iptables todo funciona a la perfección.

Para los que lo quieran probar compilando OpenWRT, he generado un parche que incluye todos los cambios necesarios para llevar el código rtsp del trunk a la última versión con todos los últimos parches (espero no haberme equivocado ;) ): aquí lo tenéis

Cómo usarlo: suponiendo que tengáis el código del openwrt en el directorio ~/openwrt/trunk, en el directorio package/network/utils/xtables-addons/patches deberíais tener ya un par de parches para rtsp (101 y 102). Sólo tenéis que copiar el parche que he preparado (el 103) y compilar (sugerencia, haced make clean antes).

Yo lo he compilado para mi Comtrend 5813n y he hecho unas cuantas pruebas y han funcionado perfectamente.

Noltari, quizás podrías hacer que incluyeran el código actualizado en OpenWRT. El parche de Goommer seguramente valga para usuarios de IPTV de otros países y no disminuye la funcionalidad del rtsp nat helper.

Para los que les cuesta esto de las compilaciones, voy a dejar un firmware compilado en el hilo del Comtrend 5813n. Y ya sabéis, si algo falla, es bajo vuestra responsabilidad.

De nuevo, muchas gracias Goommer.  >:( >:( >:(

Nota 23-09-14: He quitado el firmware del Comtrend 5813n, he comprobado que no funciona el igmp snooping y se llena la red de paquetes multicast. Mis disculpas. No tiene que ver con el parche de Goommer, podéis hacer vuestras compilaciones.
« Última modificación: 23-09-2014, 12:15 (Martes) por jfm »

Goommer

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #467 en: 17-09-2014, 15:21 (Miércoles) »
Tu parche soluciona el problema de los que tenemos varios decos y la configuración nueva (NAT/PAT)

Hola jfm, realmente soluciona de manera parcial la funcionalidad nat-rtsp para movistar-tv, ya tengas uno o n decos.

Digo parcialmente porque hay cosas que no funcionan, por la implementación de nat-rtsp, si la pausa de la reproducción es prolongada, quizás más de 30 segundos, la restauración de la sesión no funciona. Esto implica que merece la pena cancelar la reproducción y luego reiniciarla desde el último punto. Quiero mirarlo, espero tener tiempo.


... gracias Goommer...

Gracias a vosotros que me llevasteis hasta nat-rtsp.

jfm

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #468 en: 17-09-2014, 22:49 (Miércoles) »
hay cosas que no funcionan, por la implementación de nat-rtsp, si la pausa de la reproducción es prolongada, quizás más de 30 segundos, la restauración de la sesión no funciona.

Cuanto lo siento, lo cierto es que la pausa no la he probado, aunque ya fue suficiente alegría ver cómo funcionaban los dos decos a la vez  >:( >:(

De lo poco que sé, lo que consigues con el nat-helper es que la ip desde donde se transmite el video aparezca ante netfilter como RELATED, es decir, relacionada con la conexión RTSP que se acaba de iniciar y cuyo estado es ESTABLISHED. Creo que las tablas de netfilter tienen para cada nueva entrada un contador de caducidad. Si no hay tráfico y el contador llega a su límite, la entrada se borra de la tabla (para evitar que la tabla crezca sin control). Debería haber alguna manera (que yo desconozco) de crear la entrada de la ip especificando el valor de caducidad. Con un tiempo largo, digamos de 30 minutos, el problema podría considerarse resuelto.

Saludos.

jfm

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #469 en: 21-09-2014, 12:25 (Domingo) »
@Goommer: Si no me equivoco, las variables que fijan cuando se descarta una entrada IP en las tablas de netfilter están en /proc/sys/net/netfilter.

Buscando un poco por Google encontré esta página.

Ahí dice además que los valores de los módulos conntrack están en los archivos  linux/include/netfilter-ipv4/ip_conntrack*.h

Entiendo que la ubicación de los ficheros cambia de una versión a otra, pero supongo que en alguno de los archivos *.h del rtsp-conntrack habrá alguna variable/constante que te permita alargar el tiempo que aguanta la pausa sin que se borre la IP de las tablas de netfilter.



« Última modificación: 21-09-2014, 12:26 (Domingo) por jfm »

jirm

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #470 en: 23-09-2014, 10:55 (Martes) »
Wooooooou vaya !!!. Parece que el tema del multiroom (varios decos) ya esta resuelto. Que alegria.
 >:( >:( >:( >:( >:(

Antes de nada 1000 gracias a Goomer y jfm por sus aportaciones !!!!

El unico problema es que parece que la solucion no esta disponible de forma general sino es mediante recompilacion del firmware, por lo que no es posible aplicarlo de forma general.

Mi pregunta ahora es...hay algun modo de que podamos descargar e instalar el modulo nat-helper modificado para todos los routers openwrt sin que sea necesario recompilar un firmware ???

Es posible hacerlo disponible en los repositorios de modulos habituales de openwrt ???

Los que no sabemos ni podemos recompilar firmware como podriamos instalarlo :'(  

Espero impaciente vuestras noticias.

Un saludo
« Última modificación: 23-09-2014, 10:59 (Martes) por jirm »

jfm

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #471 en: 23-09-2014, 12:08 (Martes) »
Es posible hacerlo disponible en los repositorios de modulos habituales de openwrt ???

Creo que no te queda otra opción que compilar. Hasta donde yo entiendo, el cortafuegos (netfilter) es casi una parte del kernel y los módulos que modifican su comportamiento se compilan junto con el kernel.

Es decir, que hasta que el parche no se acepte oficialmente y forme parte de openwrt, o te lo compilas tú o alguien lo hace por tí.

arrobar

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #472 en: 23-09-2014, 16:27 (Martes) »
¡Hola a todos!
Hace tiempo que no me pasaba por aquí, entre las vacaciones y una vuelta al trabajo de lo más intensa...  :(

Me he estado poniendo al día y he llegado al mensaje de Goommer.

GRACIAS, GOOMMER
 >:( >:( >:( >:( >:( >:( >:(

Tu parche soluciona el problema de los que tenemos varios decos y la configuración nueva (NAT/PAT).

Basta con incluirlo y sin añadir ninguna regla de iptables todo funciona a la perfección.

Para los que lo quieran probar compilando OpenWRT, he generado un parche que incluye todos los cambios necesarios para llevar el código rtsp del trunk a la última versión con todos los últimos parches (espero no haberme equivocado ;) ): aquí lo tenéis

Cómo usarlo: suponiendo que tengáis el código del openwrt en el directorio ~/openwrt/trunk, en el directorio package/network/utils/xtables-addons/patches deberíais tener ya un par de parches para rtsp (101 y 102). Sólo tenéis que copiar el parche que he preparado (el 103) y compilar (sugerencia, haced make clean antes).

Yo lo he compilado para mi Comtrend 5813n y he hecho unas cuantas pruebas y han funcionado perfectamente.

Noltari, quizás podrías hacer que incluyeran el código actualizado en OpenWRT. El parche de Goommer seguramente valga para usuarios de IPTV de otros países y no disminuye la funcionalidad del rtsp nat helper.

Para los que les cuesta esto de las compilaciones, voy a dejar un firmware compilado en el hilo del Comtrend 5813n. Y ya sabéis, si algo falla, es bajo vuestra responsabilidad.

De nuevo, muchas gracias Goommer.  >:( >:( >:(

Nota 23-09-14: He quitado el firmware del Comtrend 5813n, he comprobado que no funciona el igmp snooping y se llena la red de paquetes multicast. Mis disculpas. No tiene que ver con el parche de Goommer, podéis hacer vuestras compilaciones.

He compilado una versión para el tplink 4300 con Barrier Breaker 14.07-rc3 (parece que funciona y no me lo creo, jajaja). Entiendo que copiando el parche en la carpeta y compilando de nuevo ya estaría o hay que añadir algún paquete a mayores?

Un Saludo y gracias

jfm

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #473 en: 23-09-2014, 19:05 (Martes) »
He compilado una versión para el tplink 4300 con Barrier Breaker 14.07-rc3 (parece que funciona y no me lo creo, jajaja). Entiendo que copiando el parche en la carpeta y compilando de nuevo ya estaría o hay que añadir algún paquete a mayores?

Lo que yo haría:

Código: [Seleccionar]
make clean
Borras la carpeta tmp que se ha creado al compilar donde tienes las fuentes (sólo por precaución).

Copias el parche donde dije antes (package/network/utils/xtables-addons/patches).

Haces
Código: [Seleccionar]
make menuconfig
En Network->Firewall->iptables marcas con asterisco (si no lo tienes ya)
Código: [Seleccionar]
iptables-mod-conntrack-extra
iptables-mod-nat-extra

En Kernel modules->Netfilter Extensions deberían estar marcados con asterisco:
Código: [Seleccionar]
kmod-ipt-nathelper-rtsp
kmod-ipt-conntrack
kmod-ipt-conntrack-extra
kmod-ipt-nat
kmod-ipt-nat-extra
kmod-nf-conntrack
kmod-nf-nat
kmod-nf-nathelper
kmod-nf-nathelper-extra

Guardas tu configuración y a compilar.


arfonzo

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #474 en: 25-09-2014, 09:06 (Jueves) »
Buenas señores, posteo a ver si alguien me puede echar una mano.
Tengo un Linksys WRT160NL con Attitude adjustment bajado para el router desde la pagina de OpenWrt. Le instalo los paquetes que me faltan y que el primer post dice que son imprescindibles (pocos, pero alguno, por ejemplo el igmpproxy, porque el mcproxy no me aparece, imagino que será para otra verison) y ejecuto el script ver. r12 (el ultimo). En cuanto me pide el puerto WAN, le pongo el 4, porque el 5 me lo marca como CPU, le voy dando todos los datos y cuando acabo, el router casca y toca recuperar en failmode (o como se llame) y volver a empezar, lo cual me deja en manos del Comtrend Vg-8050 de nuevo. Creo que el problema es que según la wiki del openwrt "Port 4 is the internal/cpu port. Port 5 (tagged 'CPU' in LUCI) is probably unconnected." ¿me casca por eso? ¿Que puñetero puerto wan le pongo entonces?.

jgice

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #475 en: 26-09-2014, 01:55 (Viernes) »
Hola,

¿sabéis si es posible aislar el tráfico entre el router y el deco en un único puerto y que siga funcionando el VOD? He conseguido aislarlo en un único puerto pero el VOD no me funciona. Lo que he hecho es en la configuración del switch dejar el puerto conectado al deco sólo "untagged" para la VLAN 2 (IPTV). Con esto creo que resolvería mis problemas de tráfico multicast por toda la red.

Gracias, un saludo.

arfonzo

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #476 en: 29-09-2014, 10:09 (Lunes) »
En vista del poco exito que tengo con el WRT160Nl para jubilar el comtrend de telefónica, me he agenciado un Huawei 556a.
Sé que hay un hilo sobre el router, pero aún no voy ni por la pagina 20 (y son 104!!!!). Solo queria preguntar una cosita.
Una vez le meta el firm de la primera pagina de dicho hilo, ¿solo tengo que seguir el script v.12 o tengo primero que asignar un puerto LAN a WAN?, es decir, ¿el firm de huawei 556a de Jar229 ya te crea un puerto WAN o lo tengo que hacer primero como lo dicen en: configurar puerto lan como wan?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2141
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #477 en: 29-09-2014, 18:31 (Lunes) »
En vista del poco exito que tengo con el WRT160Nl para jubilar el comtrend de telefónica, me he agenciado un Huawei 556a.
Sé que hay un hilo sobre el router, pero aún no voy ni por la pagina 20 (y son 104!!!!). Solo queria preguntar una cosita.
Una vez le meta el firm de la primera pagina de dicho hilo, ¿solo tengo que seguir el script v.12 o tengo primero que asignar un puerto LAN a WAN?, es decir, ¿el firm de huawei 556a de Jar229 ya te crea un puerto WAN o lo tengo que hacer primero como lo dicen en: configurar puerto lan como wan?

El firmware compilado no crea automáticamente ninguna WAN en los routers que no son neutros o con ADSL funcionando, así que, salvo que jar229 haya hecho algo que no haya dicho, te toca hacer el puerto WAN manualmente. El tutorial al que apuntas va bien.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

arfonzo

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #478 en: 29-09-2014, 21:33 (Lunes) »
Ok, al ataque pues, gracias
  ^-^

arfonzo

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #479 en: 30-09-2014, 08:13 (Martes) »
Ok, al ataque pues, gracias
  ^-^
Bueno, pues esta noche lo he conseguido, no sin problemas, ya que mi deco tenía una ip 192.168.1.84 que era la que metía en script, y después de rearrancar la ONT y el router, me la había cambiado a 192.168.1.211, dejándome ciego el VOD  :(
He tenido que volver a ejecutar el script con la nueva ip del deco y ya va todo como la seda, con el firmware que saqué del foro de coches que recomendaba un usuario del hilo del 556a.
Ya tengo hasta liberado el pincho-modem USB 3G que me venía con el router comprado de segundamano por 10 € y guardado en el trastero el comtrend de Movistar.
Gracias por la ayuda.