Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 613030 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Morax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #240 en: 03-01-2014, 19:26 (Viernes) »
El problema del VLC tampoco es que me preocupe mucho ya que no lo suelo usar. Lo que me preocupa es que no funcione la guía ni la información desde el desco.

Con el firmware de movistar el VLC va sin problemas también. Cuando vuelva a tener un poco de tiempo probaré de nuevo.



psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #241 en: 03-01-2014, 20:37 (Viernes) »
Morax yo tengo la configuracion antigua con IP fija y mi deco es un ZyXEL modelo STB-2112T Nano V2, y a mí me va genial. Es posible que tu deco tenga algo especial, supongo que Noltari te pedira por prividado el LOG donde aparezca el fallo, para ver que es.

Saludos!!

PD: Como curiosidad, VLC en MAC va genial con Imagenio, en cambio en PC, he de cachear de 2 a 2,5 seg para que no me haga lo que tú comentas. En cambio, en PC con Windows Media Player siempre se ve bien.

Morax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #242 en: 03-01-2014, 21:11 (Viernes) »
Muchas gracias por contestar psdos!. He vuelto a flashear el firmware desde la R07 de movistar, ejecutar el script y ahora va de maravilla. Yo tengo también el STB-2112T Nano v2, el negro sin reloj.  Ahora va todo: guía, videoteca, incluso he visto que ponen capítulos de series gratis por si te los has perdido :O (La verdad es que no uso muy a fondo imagenio, es el mini que dan gratis por tener fusión).

Lo mejor de todo es poder usar decentemente el Upnp para juegos online, que no veas que dolor es con el firmware de movistar. Y todo gracias a esta estupenda comunidad.

Un saludo y
Feliz año y felices reyes!.

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #243 en: 03-01-2014, 21:27 (Viernes) »
Una cosa que se me olvido, es que a veces es necesario reiniciar, ONT y Router para que todo vaya bien.
« Última modificación: 03-01-2014, 21:34 (Viernes) por psdos »

mrspuny

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #244 en: 04-01-2014, 19:02 (Sábado) »
Gracias Noltari por este estupendo script de configuración, actualmente lo tengo todo funcionando en un 4300, ha sido meter el firmware del primer post y el script y a la primera.

Lo que no termino de entender es como funciona el iptables para la biblioteca porque con el comando
iptables -t nat -A PREROUTING -p udp -d 10.X.Y.Z -j DNAT --to-destination 192.168.1.200 en teroria solo deberia ver la biblioteca en el deco con la ip 200, pues tengo dos decos, uno con la 200 y otro con la 201 y funciona con los dos.

otra cosa que no termino de ver. En el router de movistar las cesiones de ip a los decos van por vendor id con dhcp distinto, ¿aqui como van? porque solo veo un servidor dhcp.

Añado también, aunque a lo mejor se sale del tema.
He probado el paquete xupnpd que viene en el firmware openwrt y no consigo ver por dlna los canales movistar. He realizado un playlist m3u similar a este.

#EXTM3U name="Movistar TV"
#EXTINF:0 logo=http://192.168.1.50/tv/images/movistar.jpg type=mpeg dlna_extras=mpeg_ts ,Movistar TV
rtp://@239.0.0.77:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/la1.jpg type=mpeg dlna_extras=mpeg_ts ,La 1
rtp://@239.0.0.76:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/la2.jpg type=mpeg dlna_extras=mpeg_ps_pal ,La 2
rtp://@239.0.0.2:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/antena3.jpg type=mpeg dlna_extras=mpeg_ps_pal ,Antena 3
rtp://@239.0.0.3:8208

y me dice que el video es incompatible, sin embargo realizandolo con canales youtube si que funciona en las smarttv que tengo en casa.

He probado con dos tipos de formato de video como se puede ver en la info que adjunto

Alguien me puede arrojar un poco de luz?

Gracias y Un saludo
« Última modificación: 05-01-2014, 13:16 (Domingo) por mrspuny »

manux

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #245 en: 05-01-2014, 13:21 (Domingo) »
Buenos dias.

Algo debo estar haciendo mal ya que no puedo ejecutar el scrip desde putty, transfiero el archivo movistar.sh creado por noltari a la carpeta tmp a traves de scp y a la hora de ejecutarlo obtengolo siguiente:

-ash: ./movistar.sh: not found

Tambien aclarar que tengo movistar Tv mini, y como hepodido leer por mensajes anteriores tengo la configuracion nueva, la que no lleva direccion ip fija. ¿puede utilizarse elimagenio de todas formas con esta configuracio?

unsaludo y gracias de antemano.

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #246 en: 05-01-2014, 13:40 (Domingo) »
En vez de transferir el fichero movistar.sh crealo con vi movistar.sh y pega el contenido del movistar.txt. Y luego lo ejecutas, en el tuto de Noltari te lo pone. De todas formas si tienes dudas me lo comentas y te pego todo el proceso.

Saludos!!

manux

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #247 en: 05-01-2014, 15:22 (Domingo) »
He hecho lo que me has dicho y no he tenido ningun problema, muchas gracias.

Agradecer a todo el equipo de esta web y en especial a Noltari el estupendo trabajo realizado, sencillamente fenomenal.

tresvecesseis

  • Visitante
Re: Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #248 en: 06-01-2014, 00:11 (Lunes) »
Gracias Noltari por este estupendo script de configuración, actualmente lo tengo todo funcionando en un 4300, ha sido meter el firmware del primer post y el script y a la primera.

Lo que no termino de entender es como funciona el iptables para la biblioteca porque con el comando
iptables -t nat -A PREROUTING -p udp -d 10.X.Y.Z -j DNAT --to-destination 192.168.1.200 en teroria solo deberia ver la biblioteca en el deco con la ip 200, pues tengo dos decos, uno con la 200 y otro con la 201 y funciona con los dos.

otra cosa que no termino de ver. En el router de movistar las cesiones de ip a los decos van por vendor id con dhcp distinto, ¿aqui como van? porque solo veo un servidor dhcp.

Añado también, aunque a lo mejor se sale del tema.
He probado el paquete xupnpd que viene en el firmware openwrt y no consigo ver por dlna los canales movistar. He realizado un playlist m3u similar a este.

#EXTM3U name="Movistar TV"
#EXTINF:0 logo=http://192.168.1.50/tv/images/movistar.jpg type=mpeg dlna_extras=mpeg_ts ,Movistar TV
rtp://@239.0.0.77:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/la1.jpg type=mpeg dlna_extras=mpeg_ts ,La 1
rtp://@239.0.0.76:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/la2.jpg type=mpeg dlna_extras=mpeg_ps_pal ,La 2
rtp://@239.0.0.2:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/antena3.jpg type=mpeg dlna_extras=mpeg_ps_pal ,Antena 3
rtp://@239.0.0.3:8208

y me dice que el video es incompatible, sin embargo realizandolo con canales youtube si que funciona en las smarttv que tengo en casa.

He probado con dos tipos de formato de video como se puede ver en la info que adjunto

Alguien me puede arrojar un poco de luz?

Gracias y Un saludo

El formato es un mpeg_ts, y en el playlist pongo la entrada del canal apuntando al udpxy

#EXTINF:0,1- La 1:http://<ip udpxy>:<puerto udpxy>/rtp/239.0.0.76:8208



Enviado desde mi Nexus 5 mediante Tapatalk

mrspuny

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #249 en: 06-01-2014, 00:31 (Lunes) »
Muchas gracias, ha funcionado solo con fox, no se por que, todas las entradas del playlist estan igual, aunque al rato se corta en el resto de entradas me pone archivo incompatible.

me tiene loco

#EXTINF:0,0 Movistar TV
http://192.168.1.1:4022/rtp/239.0.0.77:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/la1.jpg ,1 La 1
http://192.168.1.1:4022/rtp/239.0.0.76:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/la2.jpg ,2 La 2
http://192.168.1.1:4022/rtp/239.0.0.2:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/antena3.jpg ,3 Antena 3
http://192.168.1.1:4022/rtp/239.0.0.3:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/cuatro.jpg ,4 Cuatro
http://192.168.1.1:4022/rtp/239.0.0.4:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/telecinco.jpg ,5 Tele 5
http://192.168.1.1:4022/rtp/239.0.0.5:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/lasexta.jpg ,6 La Sexta
http://192.168.1.1:4022/rtp/239.0.0.58:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/telemadrid.jpg ,7 Telemadrid
http://192.168.1.1:4022/rtp/239.0.0.25:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/laotra.jpg ,8 La Otra
http://192.168.1.1:4022/rtp/239.0.0.26:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/mes.jpg  ,9 Canal del Mes
http://192.168.1.1:4022/rtp/239.0.0.99:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/fox.jpg ,10 FOX HD
http://192.168.1.1:4022/rtp/239.0.9.134:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/axn.jpg ,11 AXN HD
http://192.168.1.1:4022/rtp/239.0.9.131:8208
#EXTINF:0 logo=http://192.168.1.50/tv/images/calle13.jpg ,12 Calle 13 HD
http://192.168.1.1:4022/rtp/239.0.5.74:8208
« Última modificación: 06-01-2014, 13:11 (Lunes) por mrspuny »

Noltari

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #250 en: 06-01-2014, 13:10 (Lunes) »
Muchas gracias, ha funcionado solo con fox, no se porque porque todas las entradas del playlist estan igual, aunque al rato se corta en el resto de entradas me pone archivo incompatible.

me tiene loco

Intentaré pulirlo un poco mas y cuando lo tenga publicare el playlist aqui por si alguien lo quiere usar.
Aquí tienes:
https://www.dropbox.com/s/hvly7kjfbl9q2s3/imagenio_tcp.m3u

Por lo visto la opción "-M 60" en el udpxy puede dar ese tipo de problemas.
Prueba a eliminarla:
Código: [Seleccionar]
OPTIONS="-T -S -p 4000 -m eth0.2"Después reinicia el udpxy:
Código: [Seleccionar]
/etc/init.d/udpxy stop
/etc/init.d/udpxy start

Saludos!

mrspuny

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #251 en: 06-01-2014, 13:16 (Lunes) »
Muchas Gracias NOLTARI, ahora si que va.

Eres un monstruo.  >:(
« Última modificación: 06-01-2014, 13:26 (Lunes) por mrspuny »

papaloukas

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #252 en: 06-01-2014, 18:38 (Lunes) »
Yo lo he probado en un TP-Link WDR4300, Comtrend WAP-5813n y Huawei HG556a.
Hola Noltari,

he probado la ultima versión de tu script con un Huawei HG556a con el primer firmware que aparecen en el hilo de OpenWRT en este router. pero me dan dos errores:
Código: [Seleccionar]
cd /tmp
./movistar.sh
movistar.sh not found

Y si llamo al script desde la shell:
Código: [Seleccionar]
root@OpenWrt:/tmp# sh movistar.sh
: not found: line 2:
'ovistar.sh: .: line 4: can't open '/etc/openwrt_release
root@OpenWrt:/tmp# Write failed: Broken pipe
¿Con que versión de OpenWRT en el Huawei HG556a deberia funcionar tu script?

mrspuny

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #253 en: 06-01-2014, 21:24 (Lunes) »
Yo lo he probado en un TP-Link WDR4300, Comtrend WAP-5813n y Huawei HG556a.
Hola Noltari,

he probado la ultima versión de tu script con un Huawei HG556a con el primer firmware que aparecen en el hilo de OpenWRT en este router. pero me dan dos errores:
Código: [Seleccionar]
cd /tmp
./movistar.sh
movistar.sh not found

Y si llamo al script desde la shell:
Código: [Seleccionar]
root@OpenWrt:/tmp# sh movistar.sh
: not found: line 2:
'ovistar.sh: .: line 4: can't open '/etc/openwrt_release
root@OpenWrt:/tmp# Write failed: Broken pipe
¿Con que versión de OpenWRT en el Huawei HG556a deberia funcionar tu script?

Copia el archivo txt y editalo con vi, despues ejecutal el comando chmod como dice en el primer post y por ultimo ejecuta el .sh
« Última modificación: 06-01-2014, 21:25 (Lunes) por mrspuny »

papaloukas

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #254 en: 07-01-2014, 10:53 (Martes) »
Yo lo he probado en un TP-Link WDR4300, Comtrend WAP-5813n y Huawei HG556a.
Hola Noltari,

he probado la ultima versión de tu script con un Huawei HG556a con el primer firmware que aparecen en el hilo de OpenWRT en este router. pero me dan dos errores:
Código: [Seleccionar]
cd /tmp
./movistar.sh
movistar.sh not found

Y si llamo al script desde la shell:
Código: [Seleccionar]
root@OpenWrt:/tmp# sh movistar.sh
: not found: line 2:
'ovistar.sh: .: line 4: can't open '/etc/openwrt_release
root@OpenWrt:/tmp# Write failed: Broken pipe
¿Con que versión de OpenWRT en el Huawei HG556a deberia funcionar tu script?

Copia el archivo txt y editalo con vi, despues ejecutal el comando chmod como dice en el primer post y por ultimo ejecuta el .sh
Gracias por la ayuda pero el comando chmod ya lo habia ejecutado. Creo que debe ser un problema con la version de busybox de esa compilación.

pacoloco

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #255 en: 09-01-2014, 20:57 (Jueves) »
Hola, probé el script y funciona de coña!
En realidad solo uso imagenio, ya que no tengo voip.

El tema es que por un tema de mi configuración local tengo un rango de IP diferente del estandard, precisamente el 192.168.10.x
Si lo dejo todo en estandard con el 192.168.1.x todo funciona bien, pero con la cambiando a 192.168.10.x ya no va el imagenio.. :/

Cuando hablo de cambiar la config me refiero a remplazar todo los strings '192.168.1.' con '192.168.10.' en todos los archvos de la carpeta /etc

Puedo hacer algo para hacer que funcione con mi red? Muchas gracias!

psdos

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #256 en: 11-01-2014, 14:31 (Sábado) »
Y por que no usas la web que ha puesto Noltari que te extrae los datos de las IPs desde un archivo de copia de seguridad del router original de Movistar? Así sabrias si las IPs que tú crees que están bien son correctas. Una vez hecho eso, te aconsejo volver a restaurar el router y ejecutar de nuevo el script de Noltari, a ver que pasa...

La web de Noltari para procesar el fichero de copia de seguridad de tú router original --> http://noltari.es/movistar/

Saludos!!

« Última modificación: 11-01-2014, 14:31 (Sábado) por psdos »

Morax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #257 en: 16-01-2014, 12:28 (Jueves) »
Tras varios intentos, desgraciadamente tengo que confirmar que no me va bien imagenio con el router comtrend de movistar y la configuración vieja.

Todos los canales se ven, el mando funciona, la videoteca también. El problema es que en el tiempo de una hora y algo viendo un canal, más o menos, imagenio se congela. La única manera de solucionarlo es volver a cambiar de canal pero a partir de ahí ya las congelaciones son cada menos tiempo.

El resto de internet, tanto wifi como por cable va perfecto, pero es un problema porque no se puede ver una película seguida  :-\.

MaxSGWL

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #258 en: 17-01-2014, 09:02 (Viernes) »
Tras varios intentos, desgraciadamente tengo que confirmar que no me va bien imagenio con el router comtrend de movistar y la configuración vieja.

Todos los canales se ven, el mando funciona, la videoteca también. El problema es que en el tiempo de una hora y algo viendo un canal, más o menos, imagenio se congela. La única manera de solucionarlo es volver a cambiar de canal pero a partir de ahí ya las congelaciones son cada menos tiempo.

El resto de internet, tanto wifi como por cable va perfecto, pero es un problema porque no se puede ver una película seguida  :-\.

Morax no se si será éste tu caso: ¿Tienes ADSL por fibra o por cobre? Si es por cobre, que te cambien el PTR. Esto me pasaba a mi y el técnico que me instaló imagenio, en cuanto le dije estos sintomas, me cambió el PTR y como la seda.

Si éste no es tu casa, sorry  :-[

Morax

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #259 en: 17-01-2014, 11:49 (Viernes) »
Gracias por contestar MAxSGWL. Tengo fibra. Todo va por FTTH menos el teléfono.  ???