Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 1994699 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1220 en: 20-02-2013, 00:08 (Miércoles) »

He probado tu compilación y no me funciona para hacerlo repetidor (con una sola radio esta vez).  ???

Todo va correcto hasta que creo el AP en la misma radio que tengo el Cliente. Ahí se le va la pinza y renombra las 2 redes de igual manera y ya no funciona internet. Con la compilación r35318 que aparece al principio del hilo todo correcto, aunque no puedo instalarme los paquetes de soporte para NTFS y ETX3/4 (y otras muchas, por dependencias del kernel, claro).

Si hubieras leído un poco ...  ;D

Aquí teneis el backport a Backfire (10.02)

https://files.myopera.com/danitool/linux/hg556a/hg556a_ath_backport_10.02.zip

Ale a testear (solo wifis Atheros).

Probado y funcionando perfectamente  >:( >:( >:(

Sólo me he encontrado con un 'problemilla' que no es tal, y no se siquiera si es achacable al backport o a la propia versión backfire. Me explico:
Para testearlo, yo lo configuro en modo repetidor. Escaneo (desde LuCi), me uno a la red después de poner la clave y ... ya está funcionando en modo cliente. Luego añado un nuevo interfaz virtual (en radio0) en modo AP. Pues bien, en el momento en que termina la configuración (cuando dice que se han aplicado todos los cambios), pierdo el enlace en modo cliente. Sigo viendo el punto de acceso, pero si me intento conectar, no me da IP.

Se soluciona, desactivando y volviendo a activar el interfaz virtual desde LuCi o desde putty con 'wifi down' y 'wifi'  :D

He instalado modulos del kernel sin ninguna 'queja' (kmod-usb-storage, kmod-fs-vfat, etc.)

Ahí va el dmesg: http://pastebin.com/PpTatYuj


Creo la partición swap por ejemplo en /dev/sda3, pero ¿qué tengo que tener ahí (sda3)? Cualquier dispositivo de almacenamiento?

Porque me da el error de
Citar
swapoff: can't stat '/dev/sda3': No such file or directory

Usando el ejemplo de jar en su hilo, no me queda claro.

Gracias!

Pero has creado la partición de intercambio realmente (igual que hiciste con las otras) ?

De ser así, el comando, para montarla es

swapon /dev/sda1 (en lugar de sda1 deberás poner el que correspona)



cohone

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1221 en: 20-02-2013, 09:30 (Miércoles) »

Por mi experiencia, transmission consume mucha ram y como dices, un archivo de intercambio puede solucionarlo, pero debes crear una nueva partición de tipo swap y esa es la que debes poner


Creo la partición swap por ejemplo en /dev/sda3, pero ¿qué tengo que tener ahí (sda3)? Cualquier dispositivo de almacenamiento?

Porque me da el error de
Citar
swapoff: can't stat '/dev/sda3': No such file or directory

Usando el ejemplo de jar en su hilo, no me queda claro.

Gracias!

Jeje, se te ve un poco verde con el tema de las particiones. Debes crear una partición nueva (no se si easeus partition es compatible) y elegir de tipo swap, casi como cuando hiciste la ext3, y eso te creará un /dev/sdax donde x es la nueva partición.

Y después configuras para que se use con swapon

curtis

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1222 en: 20-02-2013, 14:12 (Miércoles) »
[

Si hubieras leído un poco ...  ;D

Pero has creado la partición de intercambio realmente (igual que hiciste con las otras) ?

De ser así, el comando, para montarla es

swapon /dev/sda1 (en lugar de sda1 deberás poner el que correspona)

Gracias jar: sí que lo había leído, pero la verdad que no lo relacionaba con lo que me pasaba a mí... ya lo siento.

Cohone y jar: ok, entiendo. Creo una partición swap en el disco duro que va a utilizar como memoria y la monto en rc.local con el comando swapon.

Gracias por vuestra paciencia!

ximox

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1223 en: 21-02-2013, 00:50 (Jueves) »
vaya sigo hundido en la miseria .Esta compilación no tiene acceso por http probe a conectar por ssh o telnet y tampoco asi que luci no va o no existe y telnet - ssh tampoco van .supongo que el rango de ips sea el que viene por defecto del rango 192.168.1.xx aunque probe con otras con el mismo resultado .esta compilado para el 556a? y la testeaste? Perdona pero de momento sigo dejando el cacharro como diría amador aaaparcao.
me fije en la mac y es de las que no van 64:16:F0 vaya suerte la mia joe
El firm que que he posteado lo compiló Noltari en julio del año pasado. Incluye el paquete kmod-usb-audio y lo tengo funcionando en un hg556a con mac F4:C7:14.
https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/msg247469/#msg247469
Como ya te dije, nunca conseguí que funcionara en otro hg556a de mac 64:16:F0.
La buena noticia es que ahora el firm del trunk funciona perfectamente y se le puede añadir el resto de paquetes necesarios (LuCI, kmod-usb2, kmod-usb-core, kmod-usb-ohci, kmod-usb-audio, mpd-full y mpc) sin que el kernel rechine.
Léete bien el primer mensaje del post "instalacion (fácil) de openwrt en huawei-553". La instalación en el hg556 es similar. Sigue los pasos hasta instalar LuCI. A partir de ahí el camino es más sencillo. Aquí tienes el post del 553: https://foro.seguridadwireless.net/openwrt/instalacion-(facil)-de-openwrt-en-huawei-553/
ok gracias y perdonad por las molestias si resulto un poco pesado estoy intentando aprender ,estoy leyendo hace tiempo todo lo referente a usar un router como radio wifi  pero no me sale una bien leere ese post ,aunque me suena de haberlo visto y probare espero que no se base en el mismo firmware que ya baje el ultimo que hay subido en openwrt por que este no me conectaba por http ni por telnet o ssh ,volveré a probar mañana y si no meteré el Ubuntu 11 en un pc que tengo por ahí y haber si siguiendo minuciosamente la guía de jar al final consigo mi cometido y si no ya no os dare mas la vara .De todas muchas gracias a todos los que me habéis echado un cable

raphik

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1224 en: 21-02-2013, 01:25 (Jueves) »
ok gracias y perdonad por las molestias si resulto un poco pesado estoy intentando aprender ,estoy leyendo hace tiempo todo lo referente a usar un router como radio wifi  pero no me sale una bien leere ese post ,aunque me suena de haberlo visto y probare espero que no se base en el mismo firmware que ya baje el ultimo que hay subido en openwrt por que este no me conectaba por http ni por telnet o ssh ,volveré a probar mañana y si no meteré el Ubuntu 11 en un pc que tengo por ahí y haber si siguiendo minuciosamente la guía de jar al final consigo mi cometido y si no ya no os dare mas la vara .De todas muchas gracias a todos los que me habéis echado un cable
El firmware de la rama trunk (el que viene pelao, sin LuCI) cambia casi a diario. La rama trunk está en desarrollo. Eso, a efectos prácticos, significa que lo que hace dos días funcionaba igual no funciona hoy, pero vuelve a funcionar mañana. Depende de los desarrolladores. El firm actual funciona, pero hay que ser muy meticuloso al instalarlo. Sigue los pasos de post del hg553 y verás cómo lo consigues. 1, descarga el firmware. 2, instálalo. 3, inicia sesión con telnet. 4, cambia el password (lo que posibilita conectar por ssh) 5, conecta por ssh. 6, instala Luci. 7, conecta por http. 8, instala el resto de paquetes. Ésta es la secuencia. No te saltes ningún paso.
Hay un par de herramientas que para mí son fundamentales: PuTTY y WinSCP. Son gratuitas y te resuelven la conexión telnet, SSH y la transferencia y edición de ficheros. Suerte.

Saludos.
« Última modificación: 21-02-2013, 01:32 (Jueves) por raphik »

ximox

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1225 en: 21-02-2013, 13:02 (Jueves) »
Gracias por los consejos de putty y winscp ya se bastante los uso mucho para el asus rtn16 que tengo como web server cliente torrent y hot spot comunitario para compartir contenidos con los vecinos .hasta puse una sala de poker para jugar entre nosotros pero solo a nivel de intranet sin salida hacia afuera.
esta tarde probare no sabia que se modificaba tan amenudo la rama trunk fijo que el dia que me puse pille la versión chunga .
Otra cosilla me pille hace poco un adaptador usb ttl para conectar al router que me recomendó un user en este hilo el problema es que no se que software usar me baje el secure crt no se si me valdra.¿Donde hay un manualillo de uso?Gracias de nuevo ya comentare
« Última modificación: 21-02-2013, 13:07 (Jueves) por ximox »

raphik

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1226 en: 21-02-2013, 17:22 (Jueves) »
Otra cosilla me pille hace poco un adaptador usb ttl para conectar al router que me recomendó un user en este hilo el problema es que no se que software usar me baje el secure crt no se si me valdra.¿Donde hay un manualillo de uso?Gracias de nuevo ya comentare
Para las comunicaciones por puerto serie también puedes usar el PuTTY. Fíjate en los radio button que hay donde pone "Connection type" y verás que hay Raw, Telnet, Rlogin, SSH y Serial. Una vez que eliges "Serial" te permite poner el puerto COM y la velocidad.


Saludos.
« Última modificación: 21-02-2013, 17:26 (Jueves) por raphik »

ximox

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1227 en: 21-02-2013, 17:45 (Jueves) »
estupendo eso nunca lo había probado en putty asi que luego tendre entretenimiento.Y una cosilla mas por serial ¿se puede enviar firmwares para por ej revivir routers muertos? además de ver lo que sucede en el router

peterpunk

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1228 en: 21-02-2013, 20:50 (Jueves) »
No lo entiendo.
Tengo configurado el servicio de no-ip como indica en una parte del foro, aun asi lo pongo aqui.

https://www.dropbox.com/s/7x3dx1c4596jpr3/ServicioDDNS.gif
Supongo que tendre que poner el enlace entre las etiquetas de img,
,  pero no se ve nada

En el router esta en modo cliente conectado a la red por wifi. Para lo que se utiliza es para compartir el disco duro y que lo pueda ver la wii.

Quiero acceder al disco desde fuera de casa, por lo que ip fija con NO-IP.

Pues en no-ip se me almacena la IP 192.168.2.X  esto es siempre la ip local del router.

Alguien sabe el porque? que estoy haciendo mal?

Saludos y gracias
« Última modificación: 22-02-2013, 16:22 (Viernes) por peterpunk »

roli06

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1229 en: 22-02-2013, 01:19 (Viernes) »
asi es como lo tengo yo
https://www.dropbox.com/s/a6evcwd6o4aeg7v/Captura3.GIF

y desde putty ago [sh /usr/lib/ddns/dynamic_dns_updater.sh myddns &]

cohone

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1230 en: 22-02-2013, 09:05 (Viernes) »
No lo entiendo.
Tengo configurado el servicio de no-ip como indica en una parte del foro, aun asi lo pongo aqui.

https://www.dropbox.com/s/7x3dx1c4596jpr3/ServicioDDNS.gif
Supongo que tendre que poner el enlace entre , pero no se ve nada

En el router esta en modo cliente conectado a la red por wifi. Para lo que se utiliza es para compartir el disco duro y que lo pueda ver la wii.

Quiero acceder al disco desde fuera de casa, por lo que ip fija con NO-IP.

Pues en no-ip se me almacena la IP 192.168.2.X  esto es siempre la ip local del router.

Alguien sabe el porque? que estoy haciendo mal?

Saludos y gracias
Que estás seleccionando como origen de IP  la red wwlan, que esa red, por lo que has explicado es la red wifi, por lo que tiene una ip interna del tipo 192.168.1.x

Tienes que hacer como dice roli06, que es como el cliente de ddns averigua cual es la ip externa (el no la sabe, solo el router principal), preguntandole a una web.

peterpunk

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1231 en: 22-02-2013, 16:23 (Viernes) »
Gracias Ya me funciona NO-IP.
« Última modificación: 22-02-2013, 16:23 (Viernes) por peterpunk »

SERASER

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1232 en: 23-02-2013, 19:29 (Sábado) »
Hola.

Me han regalado uno de estos con su módem USB y todo.

¿Como se desmonta? :-*

Salud. ;)

raphik

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1233 en: 23-02-2013, 21:42 (Sábado) »
Hola.

Me han regalado uno de estos con su módem USB y todo.

¿Como se desmonta? :-*

Salud. ;)
Quita el tornillo que hay debajo de la pegatina (mira mi avatar). Luego separa la parte delantera de la trasera empezando por abajo. Es cuestión de maña y un poco de suerte.

Saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1234 en: 23-02-2013, 21:50 (Sábado) »
Si yo he sido capaz de desmontarlo ... :D

Como te ha dicho raphik, el tornillo está escondido tras la pegatina. Una vez que lo quites, el resto es fácil ;)

Un placer leerte de nuevo :P

Enviado desde mi U30GT-H usando Tapatalk 2

SERASER

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1235 en: 24-02-2013, 00:13 (Domingo) »
Eiiii :D

Que estaba de coña amigos ;D

Era por escribir algo que hace mucho que no lo hago ^-^

Se me perdone el offtopic please 8)

Muchos recuerdos a todos, como no a mi amigo Jar229, peazoooooo de moderata >:(

Salud.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1236 en: 24-02-2013, 10:55 (Domingo) »
;D ;D ;D

Enviado desde mi U30GT-H usando Tapatalk 2
« Última modificación: 24-02-2013, 13:16 (Domingo) por jar229 »

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1237 en: 25-02-2013, 13:48 (Lunes) »
Buenas, me acabo de registrar en este foro en busca de ayuda.
Me han dado un huawei 556a y le he instalado el openwrt, concretamente la versión que teneis en el primer post para los 556a con wifi atheros, la compilación personalizada del backport a backfire.

Bien, antes de nada decir que yo de openwrt ni idea, estoy descubriendo este mundillo.
Despúes de de instalarlo, he logrado configurar la red (despues de mucho leer y probar) y funciona de lujo, el problema lo tengo con el disco duro usb que tengo conectado.
No tengo ni idea de como se configura el samba para poder acceder al disco duro desde cualquier pc de la red, pero he seguido el tutorial de jar229 para el hg553 y ahora cuando entro 'Services' 'Network Shares' me aparece este error:

Código: [Seleccionar]
/usr/lib/lua/luci/dispatcher.lua:449: Failed to execute cbi dispatcher target for entry '/admin/services/samba'.
The called action terminated with an exception:
/usr/lib/lua/luci/cbi.lua:264: Unable to read UCI data: samba
stack traceback:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:449: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

A mí, que mi linux es muy escaso, esto me suena casi a chino, por lo que vengo pidiendo ayuda.
¿No hay una forma de configurarlo desde luci?

Y una última pregunta, una vez configurado ¿aparece el disco duro en la red o se accede por ftp?.

Ahh se me olvidada, el disco duro está en NTFS (1 sola partición).

Gracias y saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1238 en: 25-02-2013, 14:13 (Lunes) »
Sí, se puede configurar samba desde el propio LuCi. Pero claro ... ahora parece que te has 'cargado' algo ...

Citar
Y una última pregunta, una vez configurado ¿aparece el disco duro en la red o se accede por ftp?.

Ahh se me olvidada, el disco duro está en NTFS (1 sola partición).

Samba es lo mismo que 'compartir archivos y carpetas' en widows.

Si quieres acceder por ftp, tendrás que instalar y/o configurar el servidor ftp.

Ambos son independendientes. Puedes tener ambos funcionando a la vez, o sólo uno de ellos ...

Con respecto a lo del disco en NTFS: https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1239 en: 25-02-2013, 14:23 (Lunes) »
Gracias, volveré a instalar el firmware a ver si lo soluciono.
Una vez solucionado, ¿como se configuraría samba desde luci? porque estuve mirando así por encima y no me aclaraba mucho.

Ya sé que no se recomienda NTFS, pero es que tengo un disco usb de 1.5TB casi lleno y quería compartirlo si tener que estar un pc encendido las 24 horas, a ver que consigo...

Saludos.