Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 2008701 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ximox

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1100 en: 31-01-2013, 14:40 (Jueves) »
una cosilla mas  quería aprender a compilar .¿donde puedo encontrar una guía para newbies? y que necesito .voy a bajar el ubuntu por que e leído que va bien para estos menesterezs sobre todo la versión 11



Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1101 en: 31-01-2013, 14:42 (Jueves) »
una cosilla mas  quería aprender a compilar .¿donde puedo encontrar una guía para newbies? y que necesito .voy a bajar el ubuntu por que e leído que va bien para estos menesterezs sobre todo la versión 11
Hay un hilo en este mismo foro (con sticky)...

https://foro.seguridadwireless.net/openwrt/compilar-openwrt-a-nuestro-gusto/
Hay que aprender a buscar en el foro, que para algo están el botón buscar y mi hilo que recopila los tutoriales más importantes del subforo de OpenWrt:
https://foro.seguridadwireless.net/openwrt/(indice)-hilos-relevantes-de-openwrt/

Saludos.

CieNTi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1102 en: 31-01-2013, 15:06 (Jueves) »
Perfecto, deshabilitando robo y dejando solamente swconfig ;) Voy siguiendo el hilo y tengo ambos routers A y C. Para pruebas aqui me tienes

CieNTi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1103 en: 31-01-2013, 15:15 (Jueves) »
Perdona por ser pesado. Tengo la opcion, independiente una de otra, de habilitar swconfig y kmod-swconfig ... tu cual/es has habilitado?

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1104 en: 31-01-2013, 15:31 (Jueves) »
Perdona por ser pesado. Tengo la opcion, independiente una de otra, de habilitar swconfig y kmod-swconfig ... tu cual/es has habilitado?
swconfig a secas, pero en la última versión del trunk debería estar habilitado por defecto.

CieNTi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1105 en: 31-01-2013, 15:46 (Jueves) »
Ok, gracias ... compilando!

Una pregunta, aparte de usar el bus SPI mediante GPIOs, este broadcom tiene bus master SPI y el switch tiene comunicacion por SPI, sabeis si se puede usar o directamente no está conectado?

Porque mas que gastar unos cuantos GPIOs en un SPI, si se puede reusar el existente ... solo habría que gastar un GPIO para el CS* y creo que ademas en velocidad de transferencia se ganaria bastante

Sabes algo de esto?

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1106 en: 31-01-2013, 18:06 (Jueves) »
Una pregunta, aparte de usar el bus SPI mediante GPIOs, este broadcom tiene bus master SPI y el switch tiene comunicacion por SPI, sabeis si se puede usar o directamente no está conectado?

Porque mas que gastar unos cuantos GPIOs en un SPI, si se puede reusar el existente ... solo habría que gastar un GPIO para el CS* y creo que ademas en velocidad de transferencia se ganaria bastante

Sabes algo de esto?
Algo se intentó, pero sin éxito.  :-\
https://foro.seguridadwireless.net/openwrt/tutorial-music-player-daemon-en-hg556a/msg263107/#msg263107
« Última modificación: 31-01-2013, 18:07 (Jueves) por Pteridium »

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1107 en: 31-01-2013, 21:32 (Jueves) »
La interfaz SPI es una de esas con las que en teoría se pueden hacer muchas cosas, pero que en la práctica nadie hace nada por lo que no existe mucho material en el que apoyarse.

Lo único que conozco que se ha llegado usar por SPI en bcm63xx es recientemente soporte para el switch bcm53xx y para de contar. Si le preguntas a los desarrolladores si el SPI funciona te dirán que sí aunque no sé con que dispositivos lo habrán probado/testeado  >:D.


CieNTi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1108 en: 31-01-2013, 21:42 (Jueves) »
Si supieramos (de haberlos) los puntos del SPI original del chip, me pongo a probar como un loco xD El tema de hacerlo por GPIO lo estoy dejando para el final.

Lo suyo es poder usar un bus SPI (como dije, a ser posible el que trae de fabrica) de cara no solo a una SD/MMC, sino tambien a una LCD por SPI.

Si no encuentro el bus del chip me tendré que conformar con hacerlo mediante GPIO. A ver como leches encuentro si los pads del SPI estan conectados xDDD Me va a llevar un ratejo

----------------------

Escribiendo yo has respondido tu, danitool, asique te pregunto ... sabes tu los puntos del bus SPI?

Lo que dices de "mucha posibilidad pero nadie hace nada" es cierto y es, pienso yo, porque hay una gran mayoria que quiere el openwrt en su router y una vez dentro, ale ... poca gente creo que se para a analizar el bicho o a compilarse su firm ... pero weno, ni falta que me importa xDDD

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1109 en: 31-01-2013, 21:49 (Jueves) »
La interfaz SPI es una de esas con las que en teoría se pueden hacer muchas cosas, pero que en la práctica nadie hace nada por lo que no existe mucho material en el que apoyarse.

Lo único que conozco que se ha llegado usar por SPI en bcm63xx es recientemente soporte para el switch bcm53xx y para de contar. Si le preguntas a los desarrolladores si el SPI funciona te dirán que sí aunque no sé con que dispositivos lo habrán probado/testeado  >:D.
Que yo sepa se han probado switches en su mayoría, ya sean Broadcom o de otras marcas (conectados por SPI), básicamente porque es lo más fácil de probar, ya que todo está conectado y no hay que tocar nada.

Si supieramos (de haberlos) los puntos del SPI original del chip, me pongo a probar como un loco xD El tema de hacerlo por GPIO lo estoy dejando para el final.

Lo suyo es poder usar un bus SPI (como dije, a ser posible el que trae de fabrica) de cara no solo a una SD/MMC, sino tambien a una LCD por SPI.

Si no encuentro el bus del chip me tendré que conformar con hacerlo mediante GPIO. A ver como leches encuentro si los pads del SPI estan conectados xDDD Me va a llevar un ratejo

----------------------

Escribiendo yo has respondido tu, danitool, asique te pregunto ... sabes tu los puntos del bus SPI?

Lo que dices de "mucha posibilidad pero nadie hace nada" es cierto y es, pienso yo, porque hay una gran mayoria que quiere el openwrt en su router y una vez dentro, ale ... poca gente creo que se para a analizar el bicho o a compilarse su firm ... pero weno, ni falta que me importa xDDD
Yo apenas encuentro tiempo entre la universidad, vida personal y dar soporte a los routers para andar trasteando, que es realmente lo que me gusta. Además, como siempre digo no destaco por mis conocimientos de hardware xD.

Saludos!

CieNTi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1110 en: 31-01-2013, 21:53 (Jueves) »
Creo que de quien menos puedo hablar es de vosotros que estais tol dia probando cosas xDDD Aunque hace mucho que no escribia, si que sigo algunos hilos, y le pegais de tacon ... que a hardware no le pegas mucho? Lo suples con tooooodo lo demas jajajajajaja

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1111 en: 01-02-2013, 13:56 (Viernes) »
Si el switch BCM5325 tiene cableados los pines SPI (cosa que no sé), este en teoría es el pinout del switch

http://wiki.openwrt.org/_media/toh/bcm5325_pinout.png

Por lo que es muy fácil localizar MISO MOSI CLK, solo te falta un gpio para usar de Slave Select. Luego faltaría el "pegamento" en el kernel, se hace en la estructura de la placa, hay ejemplos por ahí, fácil aunque no sabría decir como se une a la fiesta el gpio para usarlo de Slave Select  >:D.

ximox

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1112 en: 01-02-2013, 14:18 (Viernes) »
Parece ser que ya tienen casi acabada la revisión del firmware http://buildbot.openwrt.org:8010/builders/brcm63xx/builds/174
cuando este al 100% ¿donde pondrán las imágenes ?,supongo que las subirán a los repositorios de openwrt .
yo esperare a que Noltari cuando tenga un poco de tiempo me compile lo que le pedi y yo nada mas me baje el Ubuntu empezare a hacer mis pinitos en compilar o por lo menos lo intentare .Danitool me comentaste que seria interesante que me hiciera con un rs232 a ttl para poder testear mejor resultados en mi router e visto el siguiente  http://www.ebay.es/itm/USB-SERIAL-TO-RS232-UART-TTL-CP2102-CABLE-SERIE-DEBRICK-COMPATIBLE-Arduino-/320976827990?pt=LH_DefaultDomain_186&hash=item4abbb5b656no se si este me vale decirme cual seria el mejor.
E visto otro vendedor en ebay con mas cosas muy interesantes y a buen precio ,tienen también displays http://stores.ebay.es/Electronicca?_trksid=p4340.l2563
y unos modulos de ultrasonidos para arduino aunque no se que utilidad podían tener.
« Última modificación: 01-02-2013, 14:34 (Viernes) por ximox »

CieNTi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1113 en: 01-02-2013, 15:08 (Viernes) »
Si el switch BCM5325 tiene cableados los pines SPI (cosa que no sé), este en teoría es el pinout del switch

http://wiki.openwrt.org/_media/toh/bcm5325_pinout.png

Por lo que es muy fácil localizar MISO MOSI CLK, solo te falta un gpio para usar de Slave Select. Luego faltaría el "pegamento" en el kernel, se hace en la estructura de la placa, hay ejemplos por ahí, fácil aunque no sabría decir como se une a la fiesta el gpio para usarlo de Slave Select  >:D.

Disculpa, he mirado tal cantidad de cosas que algunas cosas las tengo mezcladas, tendrías un ejemplo (de copia pega o de URL) sobre el "pegamento" ? Sobre el tema del pinout ya lo tenía descargado, de ahi mis preguntas acerca del bus SPI master.
El problema es que aunque puedo tocar una patita del switch, el resto son pistas o vias, ya que de estar enganchado, va directo al micro ... y aun así no me aseguro que esté conectado.
Tengo que ponerme a seguir las pistas la verdad, pero es jodido ya que en la capa de arriba, solo asoman las patas, sin pistas, y de pasar por una via, ya es en la otra cara o en alguna intermedia, por lo que solo me queda ir probando vias ... y tener una punta del tester en una patita concreta del switch, mientras con la otra punta del tester estoy en la otra cara ... hijo de la precision!! xDDDD

Parece ser que ya tienen casi acabada la revisión del firmware http://buildbot.openwrt.org:8010/builders/brcm63xx/builds/174
cuando este al 100% ¿donde pondrán las imágenes ?,supongo que las subirán a los repositorios de openwrt .
yo esperare a que Noltari cuando tenga un poco de tiempo me compile lo que le pedi y yo nada mas me baje el Ubuntu empezare a hacer mis pinitos en compilar o por lo menos lo intentare .Danitool me comentaste que seria interesante que me hiciera con un rs232 a ttl para poder testear mejor resultados en mi router e visto el siguiente  http://www.ebay.es/itm/USB-SERIAL-TO-RS232-UART-TTL-CP2102-CABLE-SERIE-DEBRICK-COMPATIBLE-Arduino-/320976827990?pt=LH_DefaultDomain_186&hash=item4abbb5b656no se si este me vale decirme cual seria el mejor.
E visto otro vendedor en ebay con mas cosas muy interesantes y a buen precio ,tienen también displays http://stores.ebay.es/Electronicca?_trksid=p4340.l2563
y unos modulos de ultrasonidos para arduino aunque no se que utilidad podían tener.

Antes de que hagas una locura (7 eurazos!!!) pillate este, que si te fijas es el mismo ("baite" pone en la placa). Comprado, probado y funcionando, es el que uso yo. USB-TTL (5v y 3.3v) sale a mas o menos 1.60€ con gastos de envio incluidos (de verdad xD)
Para mas juguetitos, o buscas mejor en ebay (por lo que veo buscaste mas que nada en castellano, debes ampliar la busqueda, desde china mandan sin gastos de envio y super barato) o entras en Dealextreme, un ejemplo con el tema de Arduino DX > Arduino [Edit: Desde dealextreme, los precios que ves es lo que pagas, el envio siempre es gratuito]
« Última modificación: 01-02-2013, 15:17 (Viernes) por CieNTi »

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1114 en: 01-02-2013, 15:59 (Viernes) »
build_dir/linux-brcm63xx/linux-3.3.8/arch/mips/bcm63xx/boards/board_bcm963xx.c

Primero habría que definir esto, por comodidad antes de la estructura de nuestra placa en concreto. Metemos el driver que va a usar nuestra placa con SPI, en este caso mmc_spi, y la velocidad máxima que admitiría el SPI, el bus tal vez sea en este caso 1 en lugar de 0 por usar el slave select 1... (no lo aseguro)
Código: [Seleccionar]
static struct spi_board_info miplaca_spi_devices[] = {
       {
       .modalias = "mmc_spi",
       .max_speed_hz = 20000000,
       .bus_num = 0,
       }
};
Se pueden meter más opciones, estas son las básicas y en principo no necesita más que eso.

Luego dentro de la estructura de la placa se mete el SPI, viene a ser un apartado más como los leds, botones, ethernet, etc...

Código: [Seleccionar]
        .spis = miplaca_spi_devices,
        .num_spis = ARRAY_SIZE(miplaca_spi_devices),
¿Que falta hacer?, pues meter el GPIO (slave select) para que entre en juego, cosa que podría necesitar de cambios en algún otro archivo...

CieNTi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1115 en: 01-02-2013, 16:47 (Viernes) »
Perfecto, muchas gracias, voy a trastear ;)

santiacho

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1116 en: 03-02-2013, 11:20 (Domingo) »
Hola, llevo mas de 4 semanas intentando configurar mi hg556a con chipset ralink y no hay manera. La finalidad, creía que era bastante sencilla, pero se me está complicado.
Tengo el hg556a conectado mediante wifi a mi router de Orange. Al ser chipset ralink no puedo tenerlo a modo repetidor sin comprar otra tarjeta wifi, pero resulta que este no es el caso puesto que tengo el Apple TV conectado via Ethernet. Parece una tontería, pero carga bastante mas rápido los videos.
Hasta aqui todo parece estar correcto. El AppleTV tiene internet servido por mi hg 556a. El problema viene cuando tengo que ver el AppleTV desde un portátil conectado al router de Orange. Instalé el paquete relayd y lo tengo configurado en otra red distinta para dar acceso a mi red. Aquí pongo la configuración que he instalado con decenas de firmwares distintos. A ver si alguien ve el problema, que puede que sea tontísimo, pero yo no consigo averiguarlo. Gracias
Config:
cat /etc/config/wireless
Código: [Seleccionar]
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option path 'pci0000:00/0000:00:01.0'
option htmode 'HT20'
list ht_capab 'GF'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC12'
option disabled '0'
option channel '6'
option txpower '20'
option country '00'

config wifi-iface
option network 'wwan'
option ssid 'WLANVYS'
option encryption 'psk2'
option device 'radio0'
option mode 'sta'
option bssid 'C0:AC:54:03:0B:20'
option key '****************'

cat /etc/config/network
Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.0.11'
option gateway '192.168.1.1'
option dns '192.168.1.1'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 1 2t 3t 4 5t'

config interface 'wwan'
option proto 'dhcp'

config interface 'stabridge'
option proto 'relay'
option ipaddr '192.168.1.11'
list network 'lan'
list network 'wwan'

El Firewall esta parado y desabilitado.
El Relayd esta habiliado para el arranque e iniciado.
El DHCP lo tengo desabilitado y es el router de Orange quien se encarga de dar ips a mis dispositivos.

Router de Orange: 192.168.1.1 (proveedor de internet y dhcp activado)
Router hg 556a: 192.168.0.11

Cualquier ayuda recibida es de agradecer porque llevo mucho tiempo con esto y muchos post leídos y no doy con la tecla. Pero creo que va a salir volando por la ventana en breve...  :P

GRACIAS!
« Última modificación: 03-02-2013, 12:41 (Domingo) por santiacho »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1117 en: 03-02-2013, 12:58 (Domingo) »
Citar
El problema viene cuando tengo que ver el AppleTV desde un portátil conectado al router de Orange.

Explica con detalle qué quieres decir con esto ?
Qué IP tiene asignada el AppleTV ?
En el router del Orange, tienes la posibilidad de reservar una IP mediante MAC ?

Ten en cuenta que relayd no es compatible con todos los routers (yo tengo un Huawei HG532c que no 'traga' con el).

santiacho

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1118 en: 03-02-2013, 15:46 (Domingo) »
Antes de nada, agradecer tu respuesta. Gracias!

Me refiero a que no puedo ver a los equipos que se conectan al router hg556a . Es muy raro porque la ip se la da el router de orange, donde se conectan el resto de dispositivos y supuestamente están en la misma red, no tengo firewall...
El AppleTV tiene la 192.168.1.31. Esta conectado al hg556a directamente por ethernet. La ip se la ha servido el router de Orange.

Si que se puede reservar ip desde el router de Orange.

No hay solución?

Muchas gracias de nuevo!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1119 en: 03-02-2013, 16:26 (Domingo) »
Pues entonces reserva la IP para el hg556a en el router principal. Asegúrate que es la que tienes configurada:192.168.1.11

Después de esto, reinicia el hg556a. Si no se 'ven' los equipos, prueba activando/desactivando el firewall de OpenWrt

/etc/config/firewall

Código: [Seleccionar]
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wan wwan'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'