Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 1995494 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1340 en: 21-03-2013, 12:50 (Jueves) »
Necesitas kmod-ath9k-htc  ^-^

O bien el módulo kmod-carl9170 que es para USBs  con Atheros AR9170.

Nueva compilación de lo último en trunk, donde también incluyo ese módulo:
https://files.myopera.com/danitool/linux/hg556a/hg556a_r36099-USB_ralink_realtek_atheros.zip

convolucionado pruébalo, di si funciona, no estoy seguro de si este driver necesita hostapd-mini.




Pues casi seguro que va a ser ese  ;D

Nunca me había fijado en ese driver  ^-^



Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1341 en: 21-03-2013, 13:10 (Jueves) »
Necesitas kmod-ath9k-htc  ^-^

O bien el módulo kmod-carl9170 que es para USBs  con Atheros AR9170.

¡Leñe, es verdad!  :-[
Bueno, no se puede tener todo en la cabeza, pero siempre está jar229 que se fija hasta en los detalles más pequeños.  >:(

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1342 en: 21-03-2013, 13:22 (Jueves) »
¡Leñe, es verdad!  :-[
Bueno, no se puede tener todo en la cabeza, pero siempre está jar229 que se fija hasta en los detalles más pequeños.  >:(

El que la ha cazado 'al vuelo', esta vez, ha sido de danitool  ;D ;D

convolucionado

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1343 en: 22-03-2013, 00:03 (Viernes) »
Gracias danitool y los demás. Ahora reconoce el dispositivo pero no acaba de funcionar bien. Con el firmware r35318 no se reconoce, debe faltar algo. En r35889 he tenido que forzar la instalación del modulo, porque daba problemas de dependencias y luego es reconocido el adaptador, pero configurándolo como AP no encuentro la nueva wifi, en Networt -> Wifi aparecen las barritas de señal al 0%. Configurándolo como cliente el router se congela, debo sacar el USB y reiniciar para volver a LuCI. Esta es la configuración en /etc/config/wireless:

Código: [Seleccionar]
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'pci0000:00/0000:00:01.0'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
        option channel '2'
        option htmode 'HT40+'
        option noscan '1'
        option country 'ES'
        option txpower '20'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/bcm63xx_ehci.0/usb1/1-2/1-2:1.0'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'DSSS_CCK-40'
        option channel '2'
        option txpower '20'
        option country 'ES'
        option hwmode '11ng'
        option htmode 'HT20'

config wifi-iface
        option ssid 'router principal'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid '2C:B0:xxxxx'
        option key 'key'
        option network 'wwan'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option network 'lan'


El firmware último que pusiste r36099 parece que es en realidad el r35899, esa es la versión que sale al instalarlo. Por cierto yo estoy cargando los firmwares desde LuCI y no del modo de rescate al que no consigo entrar.
La cosa es que al principio me pareció que iba bien, pero fue a raíz de intentar cambiar el interface USB como cliente cuando empezaron los problemas y por más que he cambiado no lo consigo.
Se me pasó mirar que en Ubuntu es el modulo carl9170 el que se carga pinchando el USB.

No sé si ponerme a compilar, pero no sé exactamente que voy a necesitar.

Saludos.
« Última modificación: 22-03-2013, 02:17 (Viernes) por convolucionado »

lotar

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1344 en: 22-03-2013, 19:16 (Viernes) »
hola chicos, no me deis mucha caña; soy un novato en esto; tengo un huawei de estos y con ayuda de algunos amigos le he puesto el firm que tenemos en el primer post del hilo; mi objetivo es aprender y hacer correr la aplicacion oscam en él; en algun post de este hilo un usuario confirmaba que con un firm de los que habia en el hilo funcionaba, pero ese firm ya no esta en dropbox, es este post
https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/msg259712/#msg259712

bueno, yo he instalado libpsclite,pcscd, ccid y el propio oscam adecuado a este router
oscam_1.20-svn-7940_brcm63xx

todo correcto, pero al iniciarlo me lanza el error

/usr/bin/oscam: can't load library 'libssl.so.1.0.0'


¿como podria resolver esto y seguir adelante?

muchas gracias

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1345 en: 22-03-2013, 19:22 (Viernes) »
Seguro que ya lo habrás hecho, pero... ¿estás seguro que esa librería está instalada?

lotar

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1346 en: 22-03-2013, 20:51 (Viernes) »
gracias, pero la verdad es que no se como instalarla; yo no la veo por ningun lado

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1347 en: 24-03-2013, 11:39 (Domingo) »
Tienes que instalar libopenssl:

Código: [Seleccionar]
opkg update
opkg install libopenssl

Si después de esto te sigue fallando, probablemente haya que crear algún enlace simbólico a mano para evitar el error.

lotar

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1348 en: 24-03-2013, 15:29 (Domingo) »
muchisimas gracias; la solución era esa; ya esta funcionando y puedo seguir adelante con el cacharreo;
 >:(

albeixon

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1349 en: 24-03-2013, 17:04 (Domingo) »
hola gente me han comentado que mi router Huawey 556a se podría conectar a mi tarjeta alfa por usb y repartir wifi con el router por toda la casa.

yo aún no le he metido el operWRT, pero me han dicho que para repartir wifi no es necesario.

de todos modos me empaparé del hilo para aprender

saludos¡¡

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1350 en: 24-03-2013, 18:35 (Domingo) »
He añadido al primer post una nueva compilación con la última versión de OpenWrt.

Nada nuevo, simplemente una actualización a la última versión, que hacía bastante que no renovaba el firmware de este router. También he añadido soporte para todos los WiFis USB que he visto.

Saludos.

convolucionado

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1351 en: 24-03-2013, 20:51 (Domingo) »
Gracias Noltari  >:(, en un primer vistazo ahora me va bien con el USB WN111v2.
Una pregunta sobre compilar, y perdon si se contestó, ¿es necesario algún parche para compilar el firmware par el HG556? ¿Es específico para cada revisión?. En el hilo sobre como compilar, y que viene de ejemplo el HG553, hablan de el pero los enlaces no van.

Saludos.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1352 en: 24-03-2013, 21:03 (Domingo) »
Gracias Noltari  >:(, en un primer vistazo ahora me va bien con el USB WN111v2.
Una pregunta sobre compilar, y perdon si se contestó, ¿es necesario algún parche para compilar el firmware par el HG556? ¿Es específico para cada revisión?. En el hilo sobre como compilar, y que viene de ejemplo el HG553, hablan de el pero los enlaces no van.

Saludos.
Gracias por el feedback.

Los parches para compilar suelen ser necesarios en routers para los que acabamos de portar OpenWrt, pero últimamente estoy utilizando branches en Github para que no haya que aplicar ningún parche.
https://github.com/Noltari/openwrt/commits/bcm63xx-r36114

El HG556a está completamente integrado en OpenWrt. Sólo haría falta compilarlo desde mi branch en Github en el caso de que se quieran meter dos HG556a con WiFi Ralink en la misma red, ya que ambos tendrían la misma dirección MAC en el WiFi sin el parche que pongo a continuación:
https://github.com/Noltari/openwrt/blob/bcm63xx-r36114/package/mac80211/patches/612-rt2800_platform_data_mac_addr.patch

Saludos.

Elnef

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1353 en: 25-03-2013, 14:26 (Lunes) »
He añadido al primer post una nueva compilación con la última versión de OpenWrt.

Nada nuevo, simplemente una actualización a la última versión, que hacía bastante que no renovaba el firmware de este router. También he añadido soporte para todos los WiFis USB que he visto.

Saludos.

Gracias por la subida.

Lo he probado en un Ralink y va perfecto, pero en un Atheros no funciona.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1354 en: 25-03-2013, 14:53 (Lunes) »
Gracias por la subida.

Lo he probado en un Ralink y va perfecto, pero en un Atheros no funciona.
Gracias por el feedback del ralink.

En mi atheros funciona perfectamente :$. ¿Puedes dar más detalles sobre qué falla exactamente?

Elnef

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1355 en: 26-03-2013, 12:31 (Martes) »
Gracias por la subida.

Lo he probado en un Ralink y va perfecto, pero en un Atheros no funciona.
Gracias por el feedback del ralink.

En mi atheros funciona perfectamente :$. ¿Puedes dar más detalles sobre qué falla exactamente?

Tras flashearlo desde el menú del recovery, no puedo acceder al router. Debería tener la dirección 192.168.1.1 pero no responde ni a un pin. Voy a probar otra vez a ver si ha sido alguan paranoia en ese momento.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1356 en: 26-03-2013, 12:47 (Martes) »
Tras flashearlo desde el menú del recovery, no puedo acceder al router. Debería tener la dirección 192.168.1.1 pero no responde ni a un pin. Voy a probar otra vez a ver si ha sido alguan paranoia en ese momento.
Si te sigue pasando realiza el procedimiento que aparece en este post, a ver si te sucede lo mismo.
https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/msg270129/#msg270129

Saludos

Elnef

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1357 en: 26-03-2013, 13:14 (Martes) »
Tras flashearlo desde el menú del recovery, no puedo acceder al router. Debería tener la dirección 192.168.1.1 pero no responde ni a un pin. Voy a probar otra vez a ver si ha sido alguan paranoia en ese momento.
Si te sigue pasando realiza el procedimiento que aparece en este post, a ver si te sucede lo mismo.
https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/msg270129/#msg270129

Saludos

He proabado con otro router Atheros y ha hecho lo mismo. De la posible solución que comentas, no tengo ni idea de como hacer lo del Failsafe. Y la verdad es que ahora mismo tanmpoco tengo mucho tiempo para meterme en berenjenales.

portacosmin

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1358 en: 27-03-2013, 17:36 (Miércoles) »
hola a todos,tengo instalado a un router hg556a ver.c el ultimo trunk hg556a_r36099-USB_ralink_realtek_atheros y lo tengo conectado en modo cliente al mi router principal(TP Link TD-W8950ND).
El TP Link tiene conectado un portatil via lan donde tengo un disco duro compartido.
El segundo portatil lo tengo en comedor y esta conectado al hg556a por lan., internet tiene pero que tengo compartido no se ve!me puedes ensenar por favor que tengo que hacer?si conecto el segundo portatil por wifi se ve todo que es compartido pero el portatil tiene wifi g y no va bien las pelis en formato mkv

muchas gracias,un saludo!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1359 en: 27-03-2013, 19:07 (Miércoles) »
Si quieres que estén en la misma subred, tienes que usar relayd. Puedes ver este hilo, para usarlo como ejemplo en la configuración del apartado del wifi: https://foro.seguridadwireless.net/openwrt/instalacion-%28facil%29-de-openwrt-en-huawei-553/
« Última modificación: 27-03-2013, 19:10 (Miércoles) por jar229 »