Autor Tema: incluir "linux-headers" para futuras versiones de Wifislax64  (Leído 709 veces)

0 Usuarios y 1 Visitante están viendo este tema.

cjrs

  • Visitante
Hola USUARIONUEVO, sino te importa, y como una idea para futuras versiones de Wifislax64, que puedas incluir las "linux-headers" para Wifislax64 entre otras dependencias y necesaria para poder compilar el modulo RTL8812AU. Algo al estilo de lo que dice en el github de Aircrack-ng pero para ser usado en Wifislax64. Para mas detalles vease:

https://github.com/aircrack-ng/rtl8812au

Similar a: sudo apt-get install linux-headers-`uname -r` pero que funcione bajo Wifislax64 y asi se pueda hacer uso del modulo rtl8812au (pues hasta ahora sin dichas linux-headers no he podido compilar el driver rtl8812au ni en Wifislax64 v1.1 ni tampoco en la iso de desarrollo del 20 de Febrero 2018).  ^-^

Gracias



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14069
Re: incluir "linux-headers" para futuras versiones de Wifislax64
« Respuesta #1 en: 08-03-2018, 20:04 (Jueves) »
las linux-headers ,estan ..desde siempre.  :P

¿ tan dificil es descomprimir el zip , ... make ..make install ?

tan dificil es ??

por no hablar de ..

actualizadores --> drivers --> rtl8812au

que baja y compila el driver por ti , aunque de otro repositorio ..   como cansa ya esto macho.
« Última modificación: 08-03-2018, 22:22 (Jueves) por USUARIONUEVO »

cjrs

  • Visitante
Re: incluir "linux-headers" para futuras versiones de Wifislax64
« Respuesta #2 en: 09-03-2018, 12:14 (Viernes) »
Totalmente cierto USUARIONUEVO, se debio a un error de descarga, ahora ya lo tengo compilado todo bien, sin embargo apesar de que mi RTL8811AU ya esta en modo monitor y escanea en la banda de 5GHz, mira lo que pone cuando uso reaver v1.6.4:

  • Switching wlan2 to channel 36
[X] ERROR: pcap_activate status -1
[X] PCAP: generic error code
couldn't get pcap handle, exiting

Imagino que la libreria de captura de paquetes "libpcap-dev" esta instalada y no se si se tiene que activar de alguna forma o como resolver este error relacionado con pcap. Tan solo comentar que uso la iso de desarrollo del 20022018 debido a que tiene todas las dependencias para poder ejecutar el script: hostbase  ^-^

guest178389

  • Visitante
Re: incluir "linux-headers" para futuras versiones de Wifislax64
« Respuesta #3 en: 09-03-2018, 13:22 (Viernes) »
jajajajaja te has enamorado de hostbase o de koala... @cjrs

para saber si esta instalada tendrias que mirar todo lo que hay instalado en lib
y sales de dudas

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14069
Re: incluir "linux-headers" para futuras versiones de Wifislax64
« Respuesta #4 en: 09-03-2018, 23:32 (Viernes) »
sistema --> qtgzmanager

y buscas pcap ... te mostrara si hay paquetes , y en que versiones.

o

Código: [Seleccionar]
ls /var/log/packages|grep libpcap
Teneis en la cabeza una idea muy equivocada de como funciona esto ...  si teneis un "error" de funcionamiento con una tool ..debeis informar al desarrollador de esa tool ,  ... esta bien comentar aqui , pero no espereis milagros.