Autor Tema: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)  (Leído 586653 veces)

0 Usuarios y 1 Visitante están viendo este tema.

mazingerz80

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #580 en: 19-04-2013, 11:26 (Viernes) »
Seguimos en las mismas Pteridium, he compilado AA con el parche, he confirmado que lo había aplicado bien, pero el wifi del carajo sigue sin funcionar...  :-\

Sale un error en la línea 165 del siguiente pastebin que dice:
[   12.624000] ath5k: probe of 0000:00:0e.0 failed with error -5
http://pastebin.com/Qak9vb4e

Aún así lo demás bien, pero el wifi sigue dando guerra.
Con el pastebin que has colgado se detecta el fallo super fácil, pero ahí están las malas noticias: las líneas 124 y 164 indican que la dirección de la última partición está mal definida o no tiene un contenido válido (todos los bytes a 00 o a FF).
Una manera rápida de comprobarlo es meterle una imagen de Attitude Adjustment y si se repite el mensaje de la línea 124 ya estamos seguros casi al 100% que se borró la última partición.

He compilado de nuevo con la imagen http://downloads.openwrt.org/attitude_adjustment/12.09-rc2/lantiq/danube/openwrt-lantiq-danube-ARV4518PW-squashfs.image, paso el pastebin y hago alusión a las líneas 127 y 168, con lo cual estamos en las mismas  :-\
http://pastebin.com/VHJWR4uP

Mi modelo de router es Astoria ARV4518PW-R01A

Hago 2 explicaciones:

A) Pasos que sigo para compilar el firm:
1º svn co svn://svn.openwrt.org/openwrt/branches/attitude_adjustment .
2º ./scripts/feeds update -a
   me dice que está en la revisión: 36354
3º ./scripts/feeds install -a
4º copio el parche en el directorio de openwrt: mach-arv.diff
5º patch -p0 -i mach-arv.diff
   patching file target/linux/lantiq/files/arch/mips/lantiq/xway/mach-arv.c
6º compruebo que mach-arv.c está creado
7º make menuconfig (configuro los módulos que quiero)
8º make

B) pasos que sigo para cargar el firm openwrt:
-hyperterminal:
  setenv kernel_addr 0xb0030000 <-- yo ponía esta dirección hasta que leí que fallaba en AA.
  setenv kernel_addr 0xb0020000 <-- esta dirección si es válida como comentó Pteridium.
  saveenv.
(arranco Tftpd32 con ip 192.168.144.100)
  run update openwrt.

¿Qué solución se puede dar?



eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #581 en: 04-05-2013, 00:13 (Sábado) »
Alguien tiene una compilación 100% operativa? El 4518PW me reinicia la conexión ADSL 2 veces al dia y es un incordio!!!

Gracias

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #582 en: 04-05-2013, 00:49 (Sábado) »
Alguien tiene una compilación 100% operativa? El 4518PW me reinicia la conexión ADSL 2 veces al dia y es un incordio!!!

Gracias
Mañana, si puedo, te preparo algo para ver si el problema es la compilación o el calentamiento excesivo. De paso te meto una compilación de AA (la hice para mi, pero añado cuatro cosas y listo).

Por si te vale de algo yo puse un Zyxel en modo bridge porque es el único que me pasa de tres megas de bajada en mi línea y el 4518 como router. La compilación que le metí es Attitude Adjustment para olvidarme de los problemas de trunk.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #583 en: 06-05-2013, 00:57 (Lunes) »
Imagen para probar a ver si se resuelven los problemas de las desconexiones. La verdad es que tiene delito la basura de disipador que le han metido a los 4518 y 7518.
Como es para pruebas va con lo básico. La imagen es para el 4518R01A, pero es fácil parchear AA para adaptar el R01.

Lesgar

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #584 en: 06-05-2013, 01:00 (Lunes) »
Podrías explicarme como parchearla para la revisión R01?. Gracias

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #585 en: 06-05-2013, 11:37 (Lunes) »
Es bastante fácil: esta sería la manera chapucera, pero fijo que funciona. Voy a preparar un parche para que se pueda elegir entre las dos versiones de router en AA.
Básicamente lo que habría que hacer es añadir "ltq_pci_data.clock = PCI_CLOCK_INT;" entre la línea 531 y 532 del fichero mach-arv.c
https://dev.openwrt.org/browser/branches/attitude_adjustment/target/linux/lantiq/files/arch/mips/lantiq/xway/mach-arv.c#L531

Como la versión Attitude Adjustment está en fase release candidate no van a añadir soporte para el R01A, así que habrá que hacer bien el parche.

Otra cosa que se puede hacer es cambiar el regdomain de la wifi y ponerlo en 0xff, que no tiene restricciones y sólo se usa para desarrollo y debug. Se cambia 0x67 por 0xff en las líneas 452 y 470, se compila y ya está.
Esto sólo vale en AA, ya que en trunk coge el regdomain del cal_data y ahí sí que hay que usar la aplicación de Noltari: Parchear datos de calibración de dispositivos ath9k

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #586 en: 06-05-2013, 18:24 (Lunes) »
Aquí están un par de parches preliminares para el soporte del ARV4518PWR01 en Attitude Adjustment. Es importante que posteéis o mandéis un mensaje con los resultados porque si lo hacemos bien hay posibilidades de que metan el parche (uno de verdad  ;D) en AA.

Lesgar

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #587 en: 08-05-2013, 22:24 (Miércoles) »
Si funciona con el parche que me has mandado. No se que necesitas que te mande para que lo incluian en A/A. Así que te mando el log completo, por si te sirve de algo, cualquier cosa que necesites, no dudes en pedírmela.
--------------
=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.05.08 15:35:26 =~=~=~=~=~=~=~=~=~=~=~=

ROM VER: 1.0.3
CFG 01
Read¸
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2010.03 (Sep 19 2012 - 22:34:24)

Board: ARV4518PW
SoC: Danube/Twinpass/Vinax-VE V1.3, DDR Speed 166 MHz, CPU Speed 333 MHz
DRAM:  64 MB
Flash:  4 MB
Net:   
searching for rtl8306 switch ... found
lq_cpe_eth
Hit any key to stop autoboot:  2  0
ARV4518 => hrrpd    ttpd
starting httpd server from server 192.168.1.1
http start
..........request for file /
request for file /favicon.ico
couldn't open file
.request for file /favicon.ico
couldn't open file
...............expecting 3408117 bytes
received data will be stored at 80500000
...
Abort
ARV4518 => httpd
starting httpd server from server 192.168.1.1
http start
.....................request for file /
request for file /favicon.ico
couldn't open file
.........expecting 3408123 bytes
received data will be stored at 80500000
799 / 3407876
...
3407925 / 3407876
Bytes transferred = 3407876 (340004 hex)
http upload ready

## Checking Image at 80500000 ...
   Legacy image found
   Image Name:   MIPS OpenWrt Linux-3.3.8
   Created:      2013-05-08   1:57:55 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1051428 Bytes =  1 MB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
http ugrade ...

..................................................... done
Erased 53 sectors
Copy to Flash... 9....8....7....6....5....4....3....2....1....done
http ugrade ready

ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2010.03 (Sep 19 2012 - 22:34:24)

Board: ARV4518PW
SoC: Danube/Twinpass/Vinax-VE V1.3, DDR Speed 166 MHz, CPU Speed 333 MHz
DRAM:  64 MB
Flash:  4 MB
Net:   
searching for rtl8306 switch ... found
lq_cpe_eth
Hit any key to stop autoboot:  2  1  0
## Booting kernel from Legacy Image at b0020000 ...
   Image Name:   MIPS OpenWrt Linux-3.3.8
   Created:      2013-05-08   1:57:55 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1051428 Bytes =  1 MB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.3.8 (parallels@parallels-Parallels-Virtual-Platform) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Wed May 8 03:57:35 CEST 2013

[    0.000000] SoC: Danube rev 1.3

[    0.000000] bootconsole [early0] enabled

[    0.000000] CPU revision is: 00019641 (MIPS 24KEc)

[    0.000000] Determined physical RAM map:

[    0.000000]  memory: 04000000 @ 00000000 (usable)

[    0.000000] Initrd not found or empty - disabling initrd

[    0.000000] Zone PFN ranges:

[    0.000000]   Normal   0x00000000 -> 0x00004000

[    0.000000] Movable zone start PFN for each node

[    0.000000] Early memory PFN ranges

[    0.000000]     0: 0x00000000 -> 0x00004000

[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256

[    0.000000] Kernel command line: console=ttyLTQ1,115200 rootfstype=squashfs,jffs2 machtype=ARV4518PWR01

[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)

[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)

[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)

[    0.000000] Primary instruction cache 16kB, VIPT, 4-way, linesize 32 bytes.

[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes

[    0.000000] Writing ErrCtl register=00068a70

[    0.000000] Readback ErrCtl register=00068a70

[    0.000000] Memory: 61676k/65536k available (2307k kernel code, 3860k reserved, 546k data, 172k init, 0k highmem)

[    0.000000] NR_IRQS:256

[    0.000000] CPU Clock: 333MHz

[    0.000000] Calibrating delay loop... 221.18 BogoMIPS (lpj=442368)

[    0.036000] pid_max: default: 32768 minimum: 301

[    0.040000] Mount-cache hash table entries: 512

[    0.048000] NET: Registered protocol family 16

[    0.056000] gpiochip_add: registered GPIOs 0 to 15 on device: ltq_gpio

[    0.060000] gpiochip_add: registered GPIOs 16 to 31 on device: ltq_gpio

[    0.064000] MIPS: machine is ARV4518PWR01 - SMC7908A-ISP

[    0.068000] gpiochip_add: registered GPIOs 100 to 115 on device: ltq_ebu

[    0.108000] bio: create slab <bio-0> at 0

[    0.116000] PCI host bridge to bus 0000:00

[    0.120000] pci_bus 0000:00: root bus resource [mem 0x18000000-0x19ffffff]

[    0.124000] pci_bus 0000:00: root bus resource [io  0x1ae00000-0x1affffff]

[    0.128000] pci 0000:00:0e.0: unsupported PM cap regs version (5)

[    0.132000] pci 0000:00:0e.0: BAR 0: assigned [mem 0x18000000-0x1800ffff]

[    0.136000] pci 0000:00:0e.0: SLOT:14 PIN:1 IRQ:30

[    0.140000] Switching to clocksource MIPS

[    0.148000] NET: Registered protocol family 2

[    0.156000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)

[    0.160000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)

[    0.168000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)

[    0.176000] TCP: Hash tables configured (established 2048 bind 2048)

[    0.180000] TCP reno registered

[    0.184000] UDP hash table entries: 256 (order: 0, 4096 bytes)

[    0.192000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)

[    0.196000] NET: Registered protocol family 1

[    0.204000] gptu: totally 6 16-bit timers/counters

[    0.208000] gptu: misc_register on minor 63

[    0.212000] gptu: succeeded to request irq 126

[    0.216000] gptu: succeeded to request irq 127

[    0.220000] gptu: succeeded to request irq 128

[    0.224000] gptu: succeeded to request irq 129

[    0.232000] gptu: succeeded to request irq 130

[    0.236000] gptu: succeeded to request irq 131

[    0.244000] squashfs: version 4.0 (2009/01/31) Phillip Lougher

[    0.248000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.

[    0.260000] msgmni has been set to 120

[    0.264000] io scheduler noop registered

[    0.268000] io scheduler deadline registered (default)

[    0.272000] ltq_asc.1: ttyLTQ1 at MMIO 0x1e100c00 (irq = 112) is a ltq_asc

[    0.280000] console [ttyLTQ1] enabled, bootconsole disabled
[    0.280000] console [ttyLTQ1] enabled, bootconsole disabled

[    0.296000] ltq_nor: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x00007f Chip ID 0x0022f9
[    0.304000] Amd/Fujitsu Extended Query Table at 0x0040
[    0.308000]   Amd/Fujitsu Extended Query version 1.1.
[    0.312000] number of CFI chips: 1
[    0.316000] Creating 4 MTD partitions on "ltq_nor":
[    0.320000] 0x000000000000-0x000000010000 : "uboot"
[    0.328000] 0x000000010000-0x000000020000 : "uboot_env"
[    0.336000] 0x000000020000-0x0000003f0000 : "linux"
[    0.344000] found squashfs behind kernel
[    0.344000] Creating 2 MTD partitions on "ltq_nor":
[    0.348000] 0x000000020000-0x000000120b64 : "kernel"
[    0.356000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.368000] 0x000000120b64-0x0000003f0000 : "rootfs"
[    0.372000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.388000] mtd: partition "rootfs" set to be root filesystem
[    0.392000] mtd: partition "rootfs_data" created automatically, ofs=340000, len=B0000
[    0.400000] 0x000000340000-0x0000003f0000 : "rootfs_data"
[    0.408000] 0x0000003f0000-0x000000400000 : "board_config"
[    0.436000] ltq_mii: probed
[    0.464000] Registering RTL8306SD switch with Chip ID: 0x5988, version: 0x0000
[    0.472000] eth0: attached PHY [Realtek RTL8306S] (phy_addr=ltq_etop-fffffff:00, irq=-1)
[    0.492000] TCP cubic registered
[    0.496000] NET: Registered protocol family 17
[    0.500000] 8021q: 802.1Q VLAN Support[    0.512000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    0.520000] Freeing unused kernel memory: 172k freed
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
jffs2 not ready yet; using ramdisk
- init -

Please press Enter to activate this console. [    8.608000] SCSI subsystem initialized
[    8.792000] usbcore: registered new interface driver usbfs
[    8.796000] usbcore: registered new interface driver hub
[    8.804000] usbcore: registered new device driver usb
[    9.044000] NET: Registered protocol family 8
[    9.048000] NET: Registered protocol family 20
[   10.072000] gpio-keys-polled gpio-keys-polled: unable to claim gpio 30, err=-16
[   10.076000] gpio-keys-polled: probe of gpio-keys-polled failed with error -16
[   10.352000] PPP generic driver version 2.4.2
[   10.580000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   10.912000] NET: Registered protocol family 24
[   11.192000] nf_conntrack version 0.5.0 (966 buckets, 3864 max)
[   11.700000] IFX MEI Version 5.00.00
[   11.852000]
[   11.852000] Infineon CPE API Driver version: DSL CPE API V3.24.4.4
[   11.888000]     ATM (A1) firmware version 1.0.19
[   11.892000] ifxmips_atm: ATM init succeed
[   11.924000] dwc_otg: version 2.60a 22-NOV-2006
[   12.528000] DWC_otg: Using DMA mode
[   12.532000] dwc_otg dwc_otg.0: DWC OTG Controller
[   12.536000] dwc_otg dwc_otg.0: new USB bus registered, assigned bus number 1
[   12.544000] dwc_otg dwc_otg.0: irq 62, io mem 0xffffffffbe101000
[   12.552000] DWC_otg: Init: Port Power? op_state=1
[   12.556000] DWC_otg: Init: Power Port (0)
[   12.560000] hub 1-0:1.0: USB hub found
[   12.560000] hub 1-0:1.0: 1 port detected
[   12.704000] DISCONNECTED PORT
[   12.716000] Initializing USB Mass Storage driver...
[   12.720000] usbcore: registered new interface driver usb-storage
[   12.728000] USB Mass Storage support registered.
[   20.380000] device eth0 entered promiscuous mode
[   20.388000] br-lan: port 1(eth0) entered forwarding state
[   20.392000] br-lan: port 1(eth0) entered forwarding state
[   22.396000] br-lan: port 1(eth0) entered forwarding state
[   45.724000] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   45.740000] jffs2_build_filesystem(): unlocking the mtd device... done.
[   45.744000] jffs2_build_filesystem(): erasing all blocks after the end marker... done.
[   52.832000] JFFS2 notice: (1172) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.



BusyBox v1.19.4 (2013-05-08 02:16:28 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (Attitude Adjustment, r36557)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:13:F7:97:70:84 
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:440 errors:0 dropped:141 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:77358 (75.5 KiB)  TX bytes:7975 (7.7 KiB)

eth0      Link encap:Ethernet  HWaddr 00:13:F7:97:70:84 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:864 errors:0 dropped:0 overruns:0 frame:0
          TX packets:864 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:58752 (57.3 KiB)  TX bytes:58752 (57.3 KiB)

nas0      Link encap:Ethernet  HWaddr 00:00:01:00:00:00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:24 dropped:0 overruns:24 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1008 (1008.0 B)

root@OpenWrt:/# reboot
root@OpenWrt:/# [  232.428000] Restarting system.


ROM VER: 1.0.3
CFG 01
Read¸
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2010.03 (Sep 19 2012 - 22:34:24)

Board: ARV4518PW
SoC: Danube/Twinpass/Vinax-VE V1.3, DDR Speed 166 MHz, CPU Speed 333 MHz
DRAM:  64 MB
Flash:  4 MB
Net:   
searching for rtl8306 switch ... found
lq_cpe_eth
Hit any key to stop autoboot:  2  1  0
## Booting kernel from Legacy Image at b0020000 ...
   Image Name:   MIPS OpenWrt Linux-3.3.8
   Created:      2013-05-08   1:57:55 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1051428 Bytes =  1 MB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.3.8 (parallels@parallels-Parallels-Virtual-Platform) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Wed May 8 03:57:35 CEST 2013

[    0.000000] SoC: Danube rev 1.3

[    0.000000] bootconsole [early0] enabled

[    0.000000] CPU revision is: 00019641 (MIPS 24KEc)

[    0.000000] Determined physical RAM map:

[    0.000000]  memory: 04000000 @ 00000000 (usable)

[    0.000000] Initrd not found or empty - disabling initrd

[    0.000000] Zone PFN ranges:

[    0.000000]   Normal   0x00000000 -> 0x00004000

[    0.000000] Movable zone start PFN for each node

[    0.000000] Early memory PFN ranges

[    0.000000]     0: 0x00000000 -> 0x00004000

[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256

[    0.000000] Kernel command line: console=ttyLTQ1,115200 rootfstype=squashfs,jffs2 machtype=ARV4518PWR01

[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)

[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)

[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)

[    0.000000] Primary instruction cache 16kB, VIPT, 4-way, linesize 32 bytes.

[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes

[    0.000000] Writing ErrCtl register=00068a78

[    0.000000] Readback ErrCtl register=00068a78

[    0.000000] Memory: 61676k/65536k available (2307k kernel code, 3860k reserved, 546k data, 172k init, 0k highmem)

[    0.000000] NR_IRQS:256

[    0.000000] CPU Clock: 333MHz

[    0.000000] Calibrating delay loop... 221.18 BogoMIPS (lpj=442368)

[    0.036000] pid_max: default: 32768 minimum: 301

[    0.040000] Mount-cache hash table entries: 512

[    0.048000] NET: Registered protocol family 16

[    0.056000] gpiochip_add: registered GPIOs 0 to 15 on device: ltq_gpio

[    0.060000] gpiochip_add: registered GPIOs 16 to 31 on device: ltq_gpio

[    0.064000] MIPS: machine is ARV4518PWR01 - SMC7908A-ISP

[    0.068000] gpiochip_add: registered GPIOs 100 to 115 on device: ltq_ebu

[    0.108000] bio: create slab <bio-0> at 0

[    0.116000] PCI host bridge to bus 0000:00

[    0.120000] pci_bus 0000:00: root bus resource [mem 0x18000000-0x19ffffff]

[    0.124000] pci_bus 0000:00: root bus resource [io  0x1ae00000-0x1affffff]

[    0.128000] pci 0000:00:0e.0: unsupported PM cap regs version (4)

[    0.132000] pci 0000:00:0e.0: BAR 0: assigned [mem 0x18000000-0x1800ffff]

[    0.136000] pci 0000:00:0e.0: SLOT:14 PIN:1 IRQ:30

[    0.140000] Switching to clocksource MIPS

[    0.148000] NET: Registered protocol family 2

[    0.156000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)

[    0.160000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)

[    0.168000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)

[    0.176000] TCP: Hash tables configured (established 2048 bind 2048)

[    0.180000] TCP reno registered

[    0.184000] UDP hash table entries: 256 (order: 0, 4096 bytes)

[    0.192000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)

[    0.196000] NET: Registered protocol family 1

[    0.204000] gptu: totally 6 16-bit timers/counters

[    0.208000] gptu: misc_register on minor 63

[    0.212000] gptu: succeeded to request irq 126

[    0.216000] gptu: succeeded to request irq 127

[    0.220000] gptu: succeeded to request irq 128

[    0.224000] gptu: succeeded to request irq 129

[    0.232000] gptu: succeeded to request irq 130

[    0.236000] gptu: succeeded to request irq 131

[    0.244000] squashfs: version 4.0 (2009/01/31) Phillip Lougher

[    0.248000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.

[    0.260000] msgmni has been set to 120

[    0.264000] io scheduler noop registered

[    0.268000] io scheduler deadline registered (default)

[    0.272000] ltq_asc.1: ttyLTQ1 at MMIO 0x1e100c00 (irq = 112) is a ltq_asc

[    0.280000] console [ttyLTQ1] enabled, bootconsole disabled
[    0.280000] console [ttyLTQ1] enabled, bootconsole disabled

[    0.296000] ltq_nor: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x00007f Chip ID 0x0022f9
[    0.304000] Amd/Fujitsu Extended Query Table at 0x0040
[    0.308000]   Amd/Fujitsu Extended Query version 1.1.
[    0.312000] number of CFI chips: 1
[    0.316000] Creating 4 MTD partitions on "ltq_nor":
[    0.320000] 0x000000000000-0x000000010000 : "uboot"
[    0.328000] 0x000000010000-0x000000020000 : "uboot_env"
[    0.336000] 0x000000020000-0x0000003f0000 : "linux"
[    0.344000] found squashfs behind kernel
[    0.344000] Creating 2 MTD partitions on "ltq_nor":
[    0.348000] 0x000000020000-0x000000120b64 : "kernel"
[    0.356000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.368000] 0x000000120b64-0x0000003f0000 : "rootfs"
[    0.372000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.388000] mtd: partition "rootfs" set to be root filesystem
[    0.392000] mtd: partition "rootfs_data" created automatically, ofs=340000, len=B0000
[    0.400000] 0x000000340000-0x0000003f0000 : "rootfs_data"
[    0.408000] 0x0000003f0000-0x000000400000 : "board_config"
[    0.436000] ltq_mii: probed
[    0.464000] Registering RTL8306SD switch with Chip ID: 0x5988, version: 0x0000
[    0.472000] eth0: attached PHY [Realtek RTL8306S] (phy_addr=ltq_etop-fffffff:00, irq=-1)
[    0.492000] TCP cubic registered
[    0.496000] NET: Registered protocol family 17
[    0.500000] 8021q: 802.1Q VLAN Support[    0.512000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    0.520000] Freeing unused kernel memory: 172k freed
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
[    6.976000] JFFS2 notice: (346) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 6 of xref (0 dead, 2 orphan) found.
[    8.272000] SCSI subsystem initialized
[    8.440000] usbcore: registered new interface driver usbfs
[    8.444000] usbcore: registered new interface driver hub
[    8.452000] usbcore: registered new device driver usb
[    9.296000] dwc_otg: version 2.60a 22-NOV-2006
[    9.904000] DWC_otg: Using DMA mode
[    9.904000] dwc_otg dwc_otg.0: DWC OTG Controller
[    9.908000] dwc_otg dwc_otg.0: new USB bus registered, assigned bus number 1
[    9.916000] dwc_otg dwc_otg.0: irq 62, io mem 0xffffffffbe101000
[    9.924000] DWC_otg: Init: Port Power? op_state=1
[    9.928000] DWC_otg: Init: Power Port (0)
[    9.932000] hub 1-0:1.0: USB hub found
[    9.936000] hub 1-0:1.0: 1 port detected
[   10.076000] Initializing USB Mass Storage driver...
[   10.080000] usbcore: registered new interface driver usb-storage
[   10.088000] USB Mass Storage support registered.
[   10.340000] usb 1-1: new high-speed USB device number 2 using dwc_otg
[   10.548000] scsi0 : usb-storage 1-1:1.0
[   11.576000] scsi 0:0:0:0: Direct-Access     Kingston DataTraveler 2.0 PMAP PQ: 0 ANSI: 0 CCS
[   11.808000] sd 0:0:0:0: [sda] 3930112 512-byte logical blocks: (2.01 GB/1.87 GiB)
[   11.816000] sd 0:0:0:0: [sda] Write Protect is off
[   11.820000] sd 0:0:0:0: [sda] No Caching mode page present
[   11.824000] sd 0:0:0:0: [sda] Assuming drive cache: write through
[   11.836000] sd 0:0:0:0: [sda] No Caching mode page present
[   11.840000] sd 0:0:0:0: [sda] Assuming drive cache: write through
[   11.892000]  sda: sda1
[   11.896000] sd 0:0:0:0: [sda] No Caching mode page present
[   11.900000] sd 0:0:0:0: [sda] Assuming drive caswitching to jffs2
- init -

Please press Enter to activate this console. [   21.872000] NET: Registered protocol family 8
[   21.876000] NET: Registered protocol family 20
[   22.376000] gpio-keys-polled gpio-keys-polled: unable to claim gpio 30, err=-16
[   22.380000] gpio-keys-polled: probe of gpio-keys-polled failed with error -16
[   22.696000] PPP generic driver version 2.4.2
[   22.972000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   23.384000] NET: Registered protocol family 24
[   23.448000] nf_conntrack version 0.5.0 (966 buckets, 3864 max)
[   23.772000] IFX MEI Version 5.00.00
[   23.952000]
[   23.952000] Infineon CPE API Driver version: DSL CPE API V3.24.4.4
[   23.996000]     ATM (A1) firmware version 1.0.19
[   23.996000] ifxmips_atm: ATM init succeed
[   33.952000] device eth0 entered promiscuous mode
[   33.964000] br-lan: port 1(eth0) entered forwarding state
[   33.968000] br-lan: port 1(eth0) entered forwarding state
[   35.972000] br-lan: port 1(eth0) entered forwarding state
[  101.244000] [DSL_BSP_Showtime 916]: Datarate US intl = 1022451, fast = 0



BusyBox v1.19.4 (2013-05-08 02:16:28 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (Attitude Adjustment, r36557)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
[  617.440000] DISCONNECTED PORT
[  617.440000] usb 1-1: USB disconnect, device number 2
[  617.452000] DISCONNECTED PORT
[  617.488000] DISCONNECTED PORT
[  617.520000] DISCONNECTED PORT
[  617.552000] DISCONNECTED PORT
[  617.584000] DISCONNECTED PORT
[  623.196000] usb 1-1: new high-speed USB device number 3 using dwc_otg
[  623.408000] scsi1 : usb-storage 1-1:1.0
[  624.436000] scsi 1:0:0:0: Direct-Access     Kingston DataTraveler 2.0 PMAP PQ: 0 ANSI: 0 CCS
[  624.668000] sd 1:0:0:0: [sda] 3930112 512-byte logical blocks: (2.01 GB/1.87 GiB)
[  624.676000] sd 1:0:0:0: [sda] Write Protect is off
[  624.684000] sd 1:0:0:0: [sda] No Caching mode page present
[  624.688000] sd 1:0:0:0: [sda] Assuming drive cache: write through
[  624.700000] sd 1:0:0:0: [sda] No Caching mode page present
[  624.704000] sd 1:0:0:0: [sda] Assuming drive cache: write through
[  624.756000]  sda: sda1
[  624.760000] sd 1:0:0:0: [sda] No Caching mode page present
[  624.764000] sd 1:0:0:0: [sda] Assuming drive cache: write through
[  624.772000] sd 1:0:0:0: [sda] Attached SCSI removable disk
--------------
PD: no he sido capaz de configurar correctamente un firmware 100% operativo (o me faltan módulos, me falta espacio, etc). Agradecería enormemente que alguien me explicara cuales son los módulos mínimos para que sea 100% funcional.
Mi idea sería que tuviese:
-Interfaz LUCI (para que sea mas facil su configuración)
-Drivers ADSL, USB, EXT4 (o el que de un mejor rendimiento para montar un extroot en el usb y cargar el resto de paquetes).
-Flags de compilación del kernel (para poder instalar a posteriori los paquetes que se necesiten desde INTERNET una vez tenga activado el extroot, como por ejemplo el driver wifi, DDNS, VOIP, etc).
Ya he intentado usar los archivos de configuracion (.conf de las imagenes que subió pteridium, tanto la normal como la "arv4518_apretado").
Si no es mucho pedir como se configura el ADSL en jazztel, llevo un par de días intentandolo desde UCI (la única imagen que he conseguido instalar no funciona el LUCI) pero no lo consigo, no se si me faltará algún modulo, script o parte del firmware.

Os doy las gracias de antemano, ya se que pido mucho, pero como podeis observar soy bastante novato.

eq7mavala

  • Visitante
Re: Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #588 en: 08-05-2013, 23:21 (Miércoles) »
root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'   
option ifname 'lo'   
option proto 'static'   
option ipaddr '127.0.0.1'   
option netmask '255.0.0.0'

config interface 'lan'   
option ifname 'eth0'   
option type 'bridge'   
option proto 'static'   
option netmask '255.255.255.0'    option ipaddr '192.168.1.1'

config atm-bridge 'atm'   
option vci '32'   
option encaps 'llc'   
option payload 'bridged'   
option vpi '8'
config interface 'wan'   
option ifname 'nas0'   
option proto 'pppoe'   
option username 'adslppp@telefonicanetpa'   
option password 'adslppp'

Prueba a cambiar los datos de username, password, vci,vpi

 (NO SE QUE SON) encaps, payload

PD: No puedo responderte en el foro, solo puedo a través de la app de seguridadwireless desde el movil, copiarlo a un mail y luego copiarlo otra vez, jajajajaYa nos contaras!
Enviado desde un telegrafo situado en marte

Lesgar

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #589 en: 09-05-2013, 03:24 (Jueves) »
El Wifi funciona (aunque solo en modo cliente, no en modo ap).
El ADSL carga el driver pero no consigo conectar, estos son los parametros de mi conexión:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'    
option ifname 'lo'    
option proto 'static'    
option ipaddr '127.0.0.1'    
option netmask '255.0.0.0'

config interface 'lan'    
option ifname 'eth0'    
option type 'bridge'    
option proto 'static'    
option netmask '255.255.255.0'    option ipaddr '192.168.1.1'

config atm-bridge 'atm'    
option vci '35'    
option encaps 'llc'    
option payload 'bridged'    
option vpi '8'
config interface 'wan'    
option ifname 'nas0'    
option proto 'pppoe'    
option username 'usuario@adsl'    
option password 'contraseña'

¿Que es preferible compilar los drivers como módulos (M) o como parte del kernel (*)?, hay alguna diferencia en cuanto al espacio que ocuparán en la compilación ?
« Última modificación: 09-05-2013, 03:28 (Jueves) por Lesgar »

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #590 en: 09-05-2013, 08:18 (Jueves) »
config atm-bridge 'atm'   
option vci '32'   
option encaps 'llc'   
option payload 'bridged'   
option vpi '8'

config interface 'wan'   
option ifname 'nas0'   
option proto 'pppoe'   
option username 'adslppp@telefonicanetpa'   
option password 'adslppp'


Va un espacio, son 2 definiciones diferentes.

A tu pregunta no se que contestarte, no llevo nada bien lo de compilar, en realidad no tengo NPI, lo mas que he compilado han sido programitas en C++.

Jajjaja sorry...

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #591 en: 09-05-2013, 14:53 (Jueves) »
Primero una aclaración: de muchas cosas tenéis más idea que yo, sobre todo de temas de linux.

Disyuntiva de compilar drivers y otras cosas en la imagen final o en módulos:
Depende de lo que se quiera y se necesite. Obviamente si vamos cortos de flash lo preferible sería compilar una imagen con lo que necesitamos, activar extroot e instalar el resto en el pendrive.
No siempre es necesario descargar los módulos desde internet, ya que se puede "trucar" Luci para que instale en local. La idea es modificar el source de los paquetes, pero no encuentro el enlace donde indica cómo hacerlo. Sería cambiar la primera linea aquí: http://192.168.1.1/cgi-bin/luci/;stok=0c009fad92f813087597786bc4233e38/admin/system/packages/ipkg
Otra solución es montar un pequeño servidor web y que los descargue desde ahí.

Encaps depende del ISP, y los valores posibles creo que son llc y vc-mux. Payload en bridge.

En las imágenes del primer post creo que incluí el . config para que se pueda usar como guía.

@Lesgar: muchas gracias por poner el bootlog. Si puedes poner otro bootlog con los mensajes de la wifi cunado está funcionando sería genial, porque así se podría ver si hace falta hacer alguna reconfiguración en el bus PCI.

Lesgar

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #592 en: 09-05-2013, 22:56 (Jueves) »
No esta el .config en la imagen del primer post, puedes postearla. Gracias.

Noltari

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #593 en: 11-05-2013, 14:08 (Sábado) »
Hace unos días me dí cuenta de que los LEDs de la EBU no funcionan en DTS (gpiomm).

También me he dado cuenta de que en la última revisión no funciona el ethernet en el kernel 3.8 por algún motivo (¿reset?), pero lo estoy investigando. Aun así, sí que funciona en 3.7.

En cuanto haga algún progreso lo pongo por aquí y si lo soluciono mandaré los parches correspondientes.

Saludos!

Noltari

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #594 en: 11-05-2013, 21:26 (Sábado) »
Hace unos días me dí cuenta de que los LEDs de la EBU no funcionan en DTS (gpiomm).

También me he dado cuenta de que en la última revisión no funciona el ethernet en el kernel 3.8 por algún motivo (¿reset?), pero lo estoy investigando. Aun así, sí que funciona en 3.7.

En cuanto haga algún progreso lo pongo por aquí y si lo soluciono mandaré los parches correspondientes.

Saludos!
Parche mandado: http://patchwork.openwrt.org/patch/3632/

LEDs de la EBU funcionando.
Arreglado botón de WiFi (gpio 28, no 25 como estaba antes).
Habilitado botón de reset (estaba comentado y funciona perfectamente).
Cambiado el LED de power (estaba como active low y es active high).

Falta identificar el problema del switch en el kernel 3.8.

Saludos!
« Última modificación: 11-05-2013, 21:27 (Sábado) por Noltari »

eq7mavala

  • Visitante
Re: Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #595 en: 12-05-2013, 05:41 (Domingo) »
Jodo Noltari eres un maquina!

Graciassssss

Enviado desde un telegrafo situado en marte

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #596 en: 12-05-2013, 17:55 (Domingo) »
Hace unos días me dí cuenta de que los LEDs de la EBU no funcionan en DTS (gpiomm).

También me he dado cuenta de que en la última revisión no funciona el ethernet en el kernel 3.8 por algún motivo (¿reset?), pero lo estoy investigando. Aun así, sí que funciona en 3.7.

En cuanto haga algún progreso lo pongo por aquí y si lo soluciono mandaré los parches correspondientes.

Saludos!
Parche mandado: http://patchwork.openwrt.org/patch/3632/

LEDs de la EBU funcionando.
Arreglado botón de WiFi (gpio 28, no 25 como estaba antes).
Habilitado botón de reset (estaba comentado y funciona perfectamente).
Cambiado el LED de power (estaba como active low y es active high).

Falta identificar el problema del switch en el kernel 3.8.

Saludos!

¿Podrías colgar en pastebin un dmesg y un logread con debug a saco?
Hasta donde sé la comunicación entre el switch y el Danube es por un bus RMII, pero ni idea si el ar8216 se controla con gpio, mdio, spi o algún otro interfaz, aunque casi seguro que se usa un gpio para la señal de reset. También puede haber alguna interrupción perdida.
Quizá se pueda sacar algo de aquí:
http://wiki.openwrt.org/toh/astoria/arv752dpw22#bootlogs

Noltari

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #597 en: 12-05-2013, 18:35 (Domingo) »
¿Podrías colgar en pastebin un dmesg y un logread con debug a saco?
Hasta donde sé la comunicación entre el switch y el Danube es por un bus RMII, pero ni idea si el ar8216 se controla con gpio, mdio, spi o algún otro interfaz, aunque casi seguro que se usa un gpio para la señal de reset. También puede haber alguna interrupción perdida.
Quizá se pueda sacar algo de aquí:
http://wiki.openwrt.org/toh/astoria/arv752dpw22#bootlogs
Ya lo tengo funcionando.

El problema es que el kernel 3.7 llama al switch como "eth0", mientras que el kernel 3.8 lo llama "switch0" y en la configuración de las VLANs es "eth0" para ambos kernels.

A ver si blogic me hace un poquito de caso y arreglamos esto.

Saludos.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #598 en: 12-05-2013, 19:02 (Domingo) »
@Lesgar: .config a mi estilo. Respecto a VoIP no tengo mucha idea, así que si otro lo revisa por si falta o sobra algo mejor.

Ya lo tengo funcionando.

El problema es que el kernel 3.7 llama al switch como "eth0", mientras que el kernel 3.8 lo llama "switch0" y en la configuración de las VLANs es "eth0" para ambos kernels.

A ver si blogic me hace un poquito de caso y arreglamos esto.

Saludos.
Si blogic cambió a "switch0" será por alguna razón. Igual se le olvidó cambiar algunas cosillas aquí.

Noltari

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #599 en: 13-05-2013, 13:08 (Lunes) »
Buenas,

Ya he mandado el parche: http://patchwork.openwrt.org/patch/3635/

Efectivamente, es un tema del script de configuración de la red, aunque no creo que haya sido blogic el que lo haya cambiado a switch0, sino la propia actualización del kernel.

Saludos!