Autor Tema: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)  (Leído 583341 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #520 en: 03-04-2013, 10:42 (Miércoles) »
Vaya, ¿ya vuelve a las andadas la wifi del 4518? Hace 5 días con la última revisión de trunk no me funcionó ni el bus PCI ni el USB, pero pensé que era metedura de pata mía.

¿El mensaje es el mismo en trunk y AA? Por supuesto con AA la wifi no va a funcionar, eso por descontado.
Cuelga en pastebin el bootlog y pon el enlace para poder echarle un ojo más a fondo.



carlotos

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #521 en: 03-04-2013, 19:56 (Miércoles) »
Hola.

No se si ya se ha comentado por aquí.

Yo NO PODÍA HACER ANDAR EL EXTROOT, EN EL ROUTER Arcadyan ARV4518PW, y lo solucione seguiendo las intrucciones que aparecen aqui:

https://forum.openwrt.org/viewtopic.php?id=41589

Se trata de crear un enlace en la secuencia de arranque de los modulos.
Ya después funciono todo a la perfección,  >:( y con memoria interna para aplicaciones montada por USB.  ^-^

Saludos.

sblanco

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #522 en: 03-04-2013, 23:19 (Miércoles) »
Vaya, ¿ya vuelve a las andadas la wifi del 4518? Hace 5 días con la última revisión de trunk no me funcionó ni el bus PCI ni el USB, pero pensé que era metedura de pata mía.

¿El mensaje es el mismo en trunk y AA? Por supuesto con AA la wifi no va a funcionar, eso por descontado.
Cuelga en pastebin el bootlog y pon el enlace para poder echarle un ojo más a fondo.

Vaya, pensaba que eran alucinaciones mías, pensaba que había hecho algo mal compilando el trunk. Estoy igual, sin WiFi por no reconocerla el módulo ath5k ni USB.

El bootlog está en http://pastebin.com/uNHqvpiH

Saludos

ernanorrio

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #523 en: 03-04-2013, 23:55 (Miércoles) »
Hola buenas, vereis llevo tiempo siguiendo este hilo porque tengo un router 7518, pero tengo un problema, a ver si algo de lo que hago está mal:
1. Conecto los cables al usb ttl
2. conecto el usb al pc
3. Ejecuto minicom. Empieza a salir lo siguiente:
 ROM VER: 1.0.3
CFG 01
Readà
4. Enchufo el router. De buenas a primeras se para y no sale nada, como si se quedara pillado, es decir no me sale lo siguiente:
Read EEPROMX

Perdon tal vez por estar haciendo alguna novatada, pero es la primera vez que hago algo así, pero ya ire pillando experiencia (tengo otros 4 routers mas esperando a openwrt xD) 8)

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #524 en: 04-04-2013, 00:40 (Jueves) »
Vaya, ¿ya vuelve a las andadas la wifi del 4518? Hace 5 días con la última revisión de trunk no me funcionó ni el bus PCI ni el USB, pero pensé que era metedura de pata mía.

¿El mensaje es el mismo en trunk y AA? Por supuesto con AA la wifi no va a funcionar, eso por descontado.
Cuelga en pastebin el bootlog y pon el enlace para poder echarle un ojo más a fondo.

Vaya, pensaba que eran alucinaciones mías, pensaba que había hecho algo mal compilando el trunk. Estoy igual, sin WiFi por no reconocerla el módulo ath5k ni USB.

El bootlog está en http://pastebin.com/uNHqvpiH

Saludos

!Genial, ya está liada de nuevo! Debe ser alguna chorrada con el EBU que controla los buses PCI y USB, sino no se explica fácilmente que fallen los dos a la vez.
Como medida de emergencia el enlace del primer post tiene una imagen básica con un buen montoncete de paquetes para instalar a más, pero sólo vale para el 4518R01A.
A ver si mañana le echo un ojo a fondo, que estos días estoy echando un cable a depurar un driver para las wifi RTL8192SU y demás familia, y si hay suerte se podrán integrar en openwrt.

De todas maneras hoy blogic acaba de lanzar un troncho de updates, y algunos son para lantiq, así que habrá que probar a actualizar.

yorse

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #525 en: 04-04-2013, 08:26 (Jueves) »
Hola buenas, vereis llevo tiempo siguiendo este hilo porque tengo un router 7518, pero tengo un problema, a ver si algo de lo que hago está mal:
1. Conecto los cables al usb ttl
2. conecto el usb al pc
3. Ejecuto minicom. Empieza a salir lo siguiente:
 ROM VER: 1.0.3
CFG 01
Readà
4. Enchufo el router. De buenas a primeras se para y no sale nada, como si se quedara pillado, es decir no me sale lo siguiente:
Read EEPROMX

Perdon tal vez por estar haciendo alguna novatada, pero es la primera vez que hago algo así, pero ya ire pillando experiencia (tengo otros 4 routers mas esperando a openwrt xD) 8)

Yo tuve un problema. En el espacio de tiempo en el que enchufas el router y te conectas al minicom, se pasa el menu en el que tienes que pulsar 3 veces espacio. El final lo conseguí haciendo que cuando terminaba de arrancar el router pulsaba el reset y ahí aprovechaba para "cazar" dicho menu.

ernanillo

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #526 en: 04-04-2013, 16:06 (Jueves) »
Hola buenas, vereis llevo tiempo siguiendo este hilo porque tengo un router 7518, pero tengo un problema, a ver si algo de lo que hago está mal:
1. Conecto los cables al usb ttl
2. conecto el usb al pc
3. Ejecuto minicom. Empieza a salir lo siguiente:
 ROM VER: 1.0.3
CFG 01
Readà
4. Enchufo el router. De buenas a primeras se para y no sale nada, como si se quedara pillado, es decir no me sale lo siguiente:
Read EEPROMX

Perdon tal vez por estar haciendo alguna novatada, pero es la primera vez que hago algo así, pero ya ire pillando experiencia (tengo otros 4 routers mas esperando a openwrt xD) 8)

Yo tuve un problema. En el espacio de tiempo en el que enchufas el router y te conectas al minicom, se pasa el menu en el que tienes que pulsar 3 veces espacio. El final lo conseguí haciendo que cuando terminaba de arrancar el router pulsaba el reset y ahí aprovechaba para "cazar" dicho menu.

Creo que eso no es, pues conecto el cable de serie y el putty antes de enchufarlo. Creo que mi problema es que no le he activado el bootsel0 y el bootsel2. Vamos que tengo que hacer esto:


« Última modificación: 04-04-2013, 16:09 (Jueves) por ernanillo »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #527 en: 05-04-2013, 00:59 (Viernes) »
Solución de compromiso (apaño, vamos) para que tengamos wifi y usb operativos: vamos al directorio donde tenemos descargado openwrt, y dentro de éste vamos a la ruta (o como se le quiera llamar) /target/linux/lanitq y veremos un precioso fichero llamado Makefile, lo editamos (da igual gedit, mousepad, leafpad, vi, nano... el que más rabia nos dé) y cambiamos 3.8.3 por 3.7.9, compilamos y a disfrutar de la wifi y el usb.
Lo que pasa al cambiar la versión del kernel es que se usan los parches para el kernel 3.7 en vez de los del 3.8. Seguramente esto sea debido al montonazo de cambios y añadidos que metió blogic al pasar a la versión 3.8 y se le quedó alguna cosilla en el tintero. También hay que tener en cuenta que ha metido soporte VDSL y añadido un par de chips más: AR10 y otro que no me acuerdo.
Resumiendo: cambiamos una versión de kernel y ya rula todo.  ^-^

Nota: que a nadie se le pase por la cabeza poner eres el amo, controlas un montón y chorradas por el estilo; la mayoría sabéis más de linux, de redes y de programación que yo, pero la diferencia es que yo llevo siguiendo esta plataforma y openwrt desde hace más de 5 años, nada más.

Me debéis una; bueno, no me debéis nada, por que no me di cuenta de una chorrada tan simple hasta poco antes de escribir este post. Nota para mi: la solución sencilla es la mejor.
« Última modificación: 05-04-2013, 01:00 (Viernes) por Pteridium »

ernanillo

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #528 en: 05-04-2013, 08:54 (Viernes) »
Al final me funcionó!!!  >:( Lo dejo por aqui por si a alguien le pasa lo mismo. Mi problema era que no me entraba al danube boot, por lo que hice lo siguiente:

1. Activar UART
2. Iniciar u-boot desde ram haciendo lo de cat u-boot.asc > /dev/ttyUSB0
3. Ejecutar el comando protect off all
4. Apagar y desactivar UART
5. Enchufar el router y luego el puerto serie (al revés de como dice en casi todos los sitios)
6. Encendemos terminal (putty en mi caso) Si vemos que sale el lo del router estupendo.
7. Pinchamos con un clip el boton de "reset" unos 3 o 4 segundos. Cuando lo hagais vereis que sale ya por fin para iniciar el modo comando. En mi caso tuve que darle a la barra espaciadora super rapido.

Parece un poco extraño todo esto pero me ha funcionado y ya estoy haciendo backup por si las mocas xD

yorse

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #529 en: 05-04-2013, 10:10 (Viernes) »
Hola.

Después de conseguir instalar OpenWRT en mi ARV7518, me han dejado un ARV4518 y me ha pasado lo siguiente.

Le he metido el uboot y se lo tragó sin problemas, el caso es que reinicio para que arranque uboot pero en la salida del minicom me salen solo puntos (.................) y no arranca.
Tambien decir que poniendo ip estática el router me devuelve el ping.
¿Que me ha podido pasar??

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #530 en: 05-04-2013, 10:54 (Viernes) »
Hola.

Después de conseguir instalar OpenWRT en mi ARV7518, me han dejado un ARV4518 y me ha pasado lo siguiente.

Le he metido el uboot y se lo tragó sin problemas, el caso es que reinicio para que arranque uboot pero en la salida del minicom me salen solo puntos (.................) y no arranca.
Tambien decir que poniendo ip estática el router me devuelve el ping.
¿Que me ha podido pasar??

Si no recuerdo mal esos puntos son los de httpd que está esperando. Con un navegador tipo Firefox o Iceweasel, entrando en 192.168.1.1 deberías tener la posibilidad de mandar la imagen por web.

yorse

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #531 en: 05-04-2013, 16:33 (Viernes) »
Hola.

Después de conseguir instalar OpenWRT en mi ARV7518, me han dejado un ARV4518 y me ha pasado lo siguiente.

Le he metido el uboot y se lo tragó sin problemas, el caso es que reinicio para que arranque uboot pero en la salida del minicom me salen solo puntos (.................) y no arranca.
Tambien decir que poniendo ip estática el router me devuelve el ping.
¿Que me ha podido pasar??

Si no recuerdo mal esos puntos son los de httpd que está esperando. Con un navegador tipo Firefox o Iceweasel, entrando en 192.168.1.1 deberías tener la posibilidad de mandar la imagen por web.
Hola pteridium, no tengo acceso al router desde httpd con firefox tampoco. Lo que me extraña es que despues de hacer lo que pone el manual metiendo el uboot al reiniciar no me sale ninguna del uboot, solo puntos.
Entonces lo he conectado en UART y haciendo el cat  u-boot.asc > /dev/ttyUSB0 arranco el uboot desde la RAM.
Ahora tengo acceso al router por httpd y subo el archivo uboot.bin que hay en la carpeta uboot-lantiq-arv4518PW_ramboot y da el siguiente error cuando termina de subir el archivo:

Citar
##Checking Image at 80500000 ...
Unknow image format!
http upgrade failed

Tambien he activado el "protect off all" y me sigue dando el mismo error
No se si es que ese no es el archivo que tengo que subir o me estoy saltando algun paso.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #532 en: 05-04-2013, 22:24 (Viernes) »
@yorse: httpd sólo vale para grabar la imagen de openwrt vía web; para meter u-boot en la flash ejecuta "run update_uboot" y se pone el solito a buscar en un servidor tftp en la dirección 192.168.1.101 un archivo. Aquí creo que está un poco mejor explicado:
https://foro.seguridadwireless.net/openwrt/openwrt-para-roters-astoria-de-ya-com/msg270814/#msg270814

ernanillo

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #533 en: 05-04-2013, 22:44 (Viernes) »
pues ya tengo instalado openwrt!!!  >:( >:(

Ahora solo me queda parchear el wifi (cosa que no tengo ni idea de como se hace) y ver si puedo conectarme al ADSL de vodafone, que mirando no he encontrado cual es el protocolo MER, pero bueno muy contento y que bien va!!

Gracias a todos por el enorme trabajo :D, sobre todo a yorse, que fue el que me diojo de reseatear el router para acceder al danube boot
« Última modificación: 05-04-2013, 22:46 (Viernes) por ernanillo »

yorse

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #534 en: 06-04-2013, 00:46 (Sábado) »
@yorse: httpd sólo vale para grabar la imagen de openwrt vía web; para meter u-boot en la flash ejecuta "run update_uboot" y se pone el solito a buscar en un servidor tftp en la dirección 192.168.1.101 un archivo. Aquí creo que está un poco mejor explicado:
https://foro.seguridadwireless.net/openwrt/openwrt-para-roters-astoria-de-ya-com/msg270814/#msg270814

Hola Pteridium. He hecho lo que pone ese manual, y se ha tragado el u-boot por ftp, pero cuando termina de flashear y arranco de nuevo, sigue sin hacer nada el router. No obtengo ninguna salida por el minicom.

No me hacia nada con los cables del modo UART puestos y sin ellos.

Ahora ya no me hace ping el router

Que raro no? ??? ???

mazingerz80

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #535 en: 06-04-2013, 17:17 (Sábado) »
Solución de compromiso (apaño, vamos) para que tengamos wifi y usb operativos: vamos al directorio donde tenemos descargado openwrt, y dentro de éste vamos a la ruta (o como se le quiera llamar) /target/linux/lanitq y veremos un precioso fichero llamado Makefile, lo editamos (da igual gedit, mousepad, leafpad, vi, nano... el que más rabia nos dé) y cambiamos 3.8.3 por 3.7.9, compilamos y a disfrutar de la wifi y el usb.
Lo que pasa al cambiar la versión del kernel es que se usan los parches para el kernel 3.7 en vez de los del 3.8. Seguramente esto sea debido al montonazo de cambios y añadidos que metió blogic al pasar a la versión 3.8 y se le quedó alguna cosilla en el tintero. También hay que tener en cuenta que ha metido soporte VDSL y añadido un par de chips más: AR10 y otro que no me acuerdo.
Resumiendo: cambiamos una versión de kernel y ya rula todo.  ^-^

Nota: que a nadie se le pase por la cabeza poner eres el amo, controlas un montón y chorradas por el estilo; la mayoría sabéis más de linux, de redes y de programación que yo, pero la diferencia es que yo llevo siguiendo esta plataforma y openwrt desde hace más de 5 años, nada más.

Me debéis una; bueno, no me debéis nada, por que no me di cuenta de una chorrada tan simple hasta poco antes de escribir este post. Nota para mi: la solución sencilla es la mejor.

Gracias Pteridium.

Estoy compilando en trunk, pero no arranca el router, da error, estoy compilando de nuevo con nuevas revisiones a ver si alguna da en el clavo jeje, previamente claro está haciendo este paso importante que has encontrado para que funcione el wifi, en cuanto tenga algo nuevo lo comento.

Saludos  ;)

lasky

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #536 en: 06-04-2013, 18:42 (Sábado) »
hola
estoy intentando hacer una copia de un 7518 pero siemple dar error en la lectura con el brndumper, pongo el inicio en 0xb0000000 y final 0xb0800000
tengo que poner alguna configuracion especial?

Un saludo

pd: utilizo windows 7 64bts
« Última modificación: 06-04-2013, 21:33 (Sábado) por lasky »

sblanco

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #537 en: 07-04-2013, 01:02 (Domingo) »
pues ya tengo instalado openwrt!!!  >:( >:(

Ahora solo me queda parchear el wifi (cosa que no tengo ni idea de como se hace) y ver si puedo conectarme al ADSL de vodafone, que mirando no he encontrado cual es el protocolo MER, pero bueno muy contento y que bien va!!

Gracias a todos por el enorme trabajo :D, sobre todo a yorse, que fue el que me diojo de reseatear el router para acceder al danube boot


MER es siplemente utilizar el protocolo DHCP donde da a opción DHCP, PPPoE, PPPoA etc. y si no funciona, deberás suministrar el parámetro de la MAC. Yo en Orange, que debe usar plantillas híbridas para soportar Yacom, que usaba también MER, lo tengo así y disfruto de IP estática (o al menos no me la cambian nunca...).

Nota: que a nadie se le pase por la cabeza poner eres el amo, controlas un montón y chorradas por el estilo; la mayoría sabéis más de linux, de redes y de programación que yo, pero la diferencia es que yo llevo siguiendo esta plataforma y openwrt desde hace más de 5 años, nada más.

Me debéis una; bueno, no me debéis nada, por que no me di cuenta de una chorrada tan simple hasta poco antes de escribir este post. Nota para mi: la solución sencilla es la mejor.

Eres un peazo de fistro! Mañana a ver si tengo un hueco, lo pruebo y flasheo, que estoy teniendo problemas en la autentificación de la WiFi (un iPad y el Sinus TC300 que tengo no realizan bien la negociación WPA bien y conectan a veces y otras no).

Lo otro que sigo sin ver es el fallo del audio en asterisk del teléfono conectado al puerto FXS del arv4518.

Saludos!
« Última modificación: 07-04-2013, 01:04 (Domingo) por sblanco »

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #538 en: 07-04-2013, 12:06 (Domingo) »
Llevo toda la semana liado con monitorización de servicios/host con nagios, existe el paquete nagios en los repositorios, pero no consigo hacer que funcionen los .cgi, de hecho no se donde están, pero en cuanto lo consiga hacer funcionar lo publico por aquí...

Bueno al tema, alguien me puede indicar, donde o como se puede llegar a hacer funcionar un asterisk en un 7518PW? Es que necesito una compilación que tenga los paquetes instalados, puesto que siempre falla alguno, si no falla alguno peta asterisk y me mina la moral...

Muchas gracias.

PD: Habéis notado que el 4518 se cuelgue y tire la conexión ADSL abajo y la levante automáticamente? A mi me pasa, no he conseguido encontrar un patron ni nada de "interés" en el "registro de sistema"

Muchas gracias por adelantado.

mazingerz80

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #539 en: 07-04-2013, 13:41 (Domingo) »
Solución de compromiso (apaño, vamos) para que tengamos wifi y usb operativos: vamos al directorio donde tenemos descargado openwrt, y dentro de éste vamos a la ruta (o como se le quiera llamar) /target/linux/lanitq y veremos un precioso fichero llamado Makefile, lo editamos (da igual gedit, mousepad, leafpad, vi, nano... el que más rabia nos dé) y cambiamos 3.8.3 por 3.7.9, compilamos y a disfrutar de la wifi y el usb.
Lo que pasa al cambiar la versión del kernel es que se usan los parches para el kernel 3.7 en vez de los del 3.8. Seguramente esto sea debido al montonazo de cambios y añadidos que metió blogic al pasar a la versión 3.8 y se le quedó alguna cosilla en el tintero. También hay que tener en cuenta que ha metido soporte VDSL y añadido un par de chips más: AR10 y otro que no me acuerdo.
Resumiendo: cambiamos una versión de kernel y ya rula todo.  ^-^

Nota: que a nadie se le pase por la cabeza poner eres el amo, controlas un montón y chorradas por el estilo; la mayoría sabéis más de linux, de redes y de programación que yo, pero la diferencia es que yo llevo siguiendo esta plataforma y openwrt desde hace más de 5 años, nada más.

Me debéis una; bueno, no me debéis nada, por que no me di cuenta de una chorrada tan simple hasta poco antes de escribir este post. Nota para mi: la solución sencilla es la mejor.

Gracias Pteridium.

Estoy compilando en trunk, pero no arranca el router, da error, estoy compilando de nuevo con nuevas revisiones a ver si alguna da en el clavo jeje, previamente claro está haciendo este paso importante que has encontrado para que funcione el wifi, en cuanto tenga algo nuevo lo comento.

Saludos  ;)


Sigo intentando compilar openwrt con el aporte de Pteridium sobre la activación del wifi... pero me tira error (repositorio trunk)

Cuelgo el pastebin sobre la carga de openwrt y el arranque hasta el error
http://pastebin.com/eDFLyzrS

Gracias de antemano  >:D