Autor Tema: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1  (Leído 342375 veces)

0 Usuarios y 1 Visitante están viendo este tema.

mazingerz80

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #360 en: 27-02-2013, 22:47 (Miércoles) »
Bueno, ya tengo mi ADB A4001N funcionando con mi propia compilación a mi gusto.
Muchas gracias a toda la gente que hace posible esto, y también quiero aportar mi granito de arena (aunque soy novato total >:D):

1) he creado mi carpeta para esta compilación.
2) dentro de la carpeta descargo el repositorio de Noltari:
    git clone git://github.com/Noltari/openwrt.git -b bcm63xx-r35763 .
    (añado el puntito final para que no me cree una subcarpeta)
3) una vez descargado, actualizamos el repositorio:
    ./scripts/feeds update -a
    ./scripts/feeds install -a
4) creamos el menuconfig:
    make menuconfig
5) seleccionamos los módulos que queramos, según la funcionalidad que queramos
    darle al router.
6) make

Listo!!!!



eq7mavala

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #361 en: 27-02-2013, 23:26 (Miércoles) »
En tu compi ya chuta bien el wifi del todo?

Gracias

me109zito

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #362 en: 05-03-2013, 00:36 (Martes) »
Hola,

Tengo el router con los puentes soldados y un conversor usb para conectarme por UART. El caso es que el hyperterminal no detecta nada, estoy haciendolo ping al router y llego a recibir 5 paquetes del router pero luego ya no consigo que responda.

Por favor, llevo ya varios días con esto y es la primera vez que me pongo con este tipo de dispositivo, ¿alguien me puede ayudar para recuperarlo?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #363 en: 05-03-2013, 07:54 (Martes) »
Yo suelo usar putty.

Has configurado correctamente el puerto serie (115200 8N1 sin control de flujo) ?

me109zito

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #364 en: 05-03-2013, 15:11 (Martes) »
Yo suelo usar putty.

Has configurado correctamente el puerto serie (115200 8N1 sin control de flujo) ?

Lo tengo bien configurado si, he probado a la hora de comer con el putty y tampoco. El puerto también está bien puesto (en mi caso el 27).

He soldado los puentes de la primera página del hilo, también soldé los jumper para poder conectar y desconectar el adaptador usb. Le conecto los cables TX, RX y uno de los GND al adaptador usb, lo conecto al pc (tipico sonido de que lo detecta y los drivers no dan problemas), conecto el putty y enciendo el router, pero nada.
Al principio parpadea una luz y al cabo de un rato se quedan 2 luces fijas (tendría que mirar exactamente cuales son porque lo tengo desmontado). Mientras está encendiendo le hago un ping continuo cada segundo y llego a recibir 5 paquetes pero luego ya no recibo ninguno más ni aunque lo deje varios minutos.

La verdad que no se si estoy haciendo algo mal, esta tarde intentaré desoldar los jumper y volverlos a soldar por si acaso hay alguno que hace mal contacto.

¿Alguna idea?

mazingerz80

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #365 en: 13-03-2013, 18:03 (Miércoles) »
Dices que por serial no hace nada?
Prueba a intercambiar TX por RX y viceversa (puede que sea eso), y no tengas miedo que haciendo eso no haces ningún cortocircuito  >:D

Ya me cuentas

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #366 en: 14-03-2013, 12:48 (Jueves) »
Hola, ayer deje frio este router, lo he recuperado por el puerto serie, pero lo que antes me salian palabras con sentido en la consola (antes de formatear mi PC) esta vez, solo salen simbolos raros, igualmete he pulsado la letra F y me ha activafo el CFE para recuperarlo. Perome intriga el por que de los simbolos raros.

Esta es mi configuracion:

Bits por segudo: 9600
Bits de datos: 8
Paridad: Ninguno
Bits parada:1
Control de flujo: Ninguno

En codigo de Area puse 8 por que no sabia que poner

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #367 en: 14-03-2013, 13:21 (Jueves) »
Hola, ayer deje frio este router, lo he recuperado por el puerto serie, pero lo que antes me salian palabras con sentido en la consola (antes de formatear mi PC) esta vez, solo salen simbolos raros, igualmete he pulsado la letra F y me ha activafo el CFE para recuperarlo. Perome intriga el por que de los simbolos raros.

Esta es mi configuracion:

Bits por segudo: 9600
Bits de datos: 8
Paridad: Ninguno
Bits parada:1
Control de flujo: Ninguno

En codigo de Area puse 8 por que no sabia que poner
Tienes que ponerlo a 115200 baudios. El resto de la configuración está bien.

Código: [Seleccionar]
Bits por segudo: 115200
Bits de datos: 8
Paridad: Ninguno
Bits parada:1
Control de flujo: Ninguno

Saludos.

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #368 en: 14-03-2013, 13:26 (Jueves) »
perrfecto gracias. Habia probado varios baudios, excepto ese. Un saludo

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #369 en: 14-03-2013, 13:30 (Jueves) »
por cierto, he intentado soldarle unos cables al router para sacar fuera de la carcasa el puerto serie, asi evitar abrirlo para recuperarlo. Pero no he conseguido señal, los cables son cortos y comprobados. Tan poca distancia ofrece el puerto serie? uso un USB to TTL

Fedex15

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #370 en: 14-03-2013, 18:37 (Jueves) »
Hola, Estaba leyendo sobre el firmware OpenWRT y como no es mi modelo pensé que no podía ser instalado. Pero me di cuenta de que si este modelo si se puede http://wiki.openwrt.org/toh/adb/p.dg_a4001n1 y  desarme mi router y me di cuenta de que tiene estos datos.

Procesador: Broadcom - bcm63281kfbg
Memoria: Nanya nt5tu32m16dg ac-
Wifi: Broadcom bcm43225kml
Memoria Flash: mxic mx25l6406e

Por lo que he podido encontrar es el mismo procesador, el chip wifi también, de acuerdo con el fabricante dice que el flash es de 64 MB, pero creo que es de menos, aunque es la misma marca que el ADB, el gestor de arranque que tiene es el mismo que tengo, imagen adjunta para ver. Quería saber como soy nuevo , si alguien me puede dar una mano, yo ya flashe otro router pero con otro firmware a través del puerto serial y me ha ido bien (CA42). Si me pudieran dar una mano gracias. Pongo fotos después del puerto serial y router.




Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #371 en: 14-03-2013, 19:40 (Jueves) »
Hola, Estaba leyendo sobre el firmware OpenWRT y como no es mi modelo pensé que no podía ser instalado. Pero me di cuenta de que si este modelo si se puede http://wiki.openwrt.org/toh/adb/p.dg_a4001n1 y  desarme mi router y me di cuenta de que tiene estos datos.

Procesador: Broadcom - bcm63281kfbg
Memoria: Nanya nt5tu32m16dg ac-
Wifi: Broadcom bcm43225kml
Memoria Flash: mxic mx25l6406e

Por lo que he podido encontrar es el mismo procesador, el chip wifi también, de acuerdo con el fabricante dice que el flash es de 64 MB, pero creo que es de menos, aunque es la misma marca que el ADB, el gestor de arranque que tiene es el mismo que tengo, imagen adjunta para ver. Quería saber como soy nuevo , si alguien me puede dar una mano, yo ya flashe otro router pero con otro firmware a través del puerto serial y me ha ido bien (CA42). Si me pudieran dar una mano gracias. Pongo fotos después del puerto serial y router.




Buenas,

Ese router creo que ya está soportado por OpenWrt, ya que tiene el mismo identificador que una de las placas de desarrollo que hay para el BCM6328 (6328avng). Creo que la memoria que tiene es de 64 Mbits, es decir: 8MBytes.
4MB de Flash
8MB de Flash
16MB de Flash

Sin embargo, he de advertirte que si no dispones del firmware original del router no podrás volver al firmware oficial y perderás la funcionalidad de ADSL. Por tanto, a lo mejor podría ser interesante realizar un backup completo de la flash utilizando la herramienta cfetool antes de flashear OpenWrt (necesitas un conversor USB -> UART):
https://github.com/Noltari/cfetool

Saludos.
« Última modificación: 14-03-2013, 19:52 (Jueves) por Noltari »

Fedex15

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #372 en: 14-03-2013, 19:50 (Jueves) »
Buenas,

Ese router creo que ya está soportado por OpenWrt, ya que tiene el mismo identificador que una de las placas de desarrollo que hay para el BCM6328 (6328avng). Creo que la memoria que tiene es de 64 Mbits, es decir: 8MBytes.
4MB de Flash
8MB de Flash
16MB de Flash

Sin embargo, he de advertirte que si no dispones del firmware original del router no podrás volver al firmware oficial y perderás la funcionalidad de ADSL. Por tanto, a lo mejor podría ser interesante realizar un backup completo de la flash utilizando la herramienta cfetool antes de flashear OpenWrt (necesitas un conversor USB -> UART):
https://github.com/Noltari/cfetool

Saludos.

Buenas, yo cuando flashee otro router que tengo tambien lo hice por serial port, como no tenia ningun conversor lei que se podia con un cable ca-42 de nokia y me salio, queria saber como podria conectar el cable osea, cual es el gnd, rx vx de la placa esta y como deveria hacer para hacer el backup original del router. Otra cosa, vos me decis que no podre usar el adsl, osea que si le pongo este firmware quedaria solo como router y tendria que usar un modem en puente para poder conectarse no, Gracias.
« Última modificación: 14-03-2013, 19:52 (Jueves) por Noltari »

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #373 en: 14-03-2013, 19:57 (Jueves) »
Buenas,

Ese router creo que ya está soportado por OpenWrt, ya que tiene el mismo identificador que una de las placas de desarrollo que hay para el BCM6328 (6328avng). Creo que la memoria que tiene es de 64 Mbits, es decir: 8MBytes.
4MB de Flash
8MB de Flash
16MB de Flash

Sin embargo, he de advertirte que si no dispones del firmware original del router no podrás volver al firmware oficial y perderás la funcionalidad de ADSL. Por tanto, a lo mejor podría ser interesante realizar un backup completo de la flash utilizando la herramienta cfetool antes de flashear OpenWrt (necesitas un conversor USB -> UART):
https://github.com/Noltari/cfetool

Saludos.

Buenas, yo cuando flashee otro router que tengo tambien lo hice por serial port, como no tenia ningun conversor lei que se podia con un cable ca-42 de nokia y me salio, queria saber como podria conectar el cable osea, cual es el gnd, rx vx de la placa esta y como deveria hacer para hacer el backup original del router. Otra cosa, vos me decis que no podre usar el adsl, osea que si le pongo este firmware quedaria solo como router y tendria que usar un modem en puente para poder conectarse no, Gracias.
La conexión de los pines es distinta en cada placa, por lo que tendrás que averiguarlo tú mismo :$. Puedes identificar fácilmente los pines GND y VCC (el de VCC no tienes que usarlo), mientras que los pines de TX y RX es cuestión de probar xD.
Además, con la calidad de la foto que has subido es bastante difícil identificar nada :$.

Sobre el tema del ADSL, es tal y como dices, necesitas un modem u otro router actuando como modem para poder conectarte a internet por ADSL.

Por cierto, los mensajes privados no están para recibir ayuda personalizada. Te ruego que utilices el foro para estos temas, ya que así todo queda visible para todo el mundo.

Saludos.

Fedex15

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #374 en: 14-03-2013, 20:10 (Jueves) »
Buenas,

Ese router creo que ya está soportado por OpenWrt, ya que tiene el mismo identificador que una de las placas de desarrollo que hay para el BCM6328 (6328avng). Creo que la memoria que tiene es de 64 Mbits, es decir: 8MBytes.
4MB de Flash
8MB de Flash
16MB de Flash

Sin embargo, he de advertirte que si no dispones del firmware original del router no podrás volver al firmware oficial y perderás la funcionalidad de ADSL. Por tanto, a lo mejor podría ser interesante realizar un backup completo de la flash utilizando la herramienta cfetool antes de flashear OpenWrt (necesitas un conversor USB -> UART):
https://github.com/Noltari/cfetool

Saludos.

Buenas, yo cuando flashee otro router que tengo tambien lo hice por serial port, como no tenia ningun conversor lei que se podia con un cable ca-42 de nokia y me salio, queria saber como podria conectar el cable osea, cual es el gnd, rx vx de la placa esta y como deveria hacer para hacer el backup original del router. Otra cosa, vos me decis que no podre usar el adsl, osea que si le pongo este firmware quedaria solo como router y tendria que usar un modem en puente para poder conectarse no, Gracias.
La conexión de los pines es distinta en cada placa, por lo que tendrás que averiguarlo tú mismo :$. Puedes identificar fácilmente los pines GND y VCC (el de VCC no tienes que usarlo), mientras que los pines de TX y RX es cuestión de probar xD.
Además, con la calidad de la foto que has subido es bastante difícil identificar nada :$.

Sobre el tema del ADSL, es tal y como dices, necesitas un modem u otro router actuando como modem para poder conectarte a internet por ADSL.

Por cierto, los mensajes privados no están para recibir ayuda personalizada. Te ruego que utilices el foro para estos temas, ya que así todo queda visible para todo el mundo.

Saludos.

Perdon por tantas preguntas pero necesito preguntarte algunas cosas para sacarme las dudas. Como tendria que hacer para saber cual es cada pin, yo tengo tester por si hay que hacer algo, tambien queria saber ya que este modem no trae un puerto wan que seria para darle internet con el modem comun cual seria el puerto, seria el 1 y me quedarian los otros 3 para usar en pc's o no. Para extraer necesito hacerlo por serial port como tengo que hacer con ubuntu?. y para flashearlo lo puedo hacer desde la web o tambien por tftp, Gracias y no sabia lo de los mensajes privados.

PD: El modelo exacto es : mxic mx25l6406em2i-12g  me podrias decir vos que sabes si es de 8Mb? Gracias

PD2: Queria saber si me podrias ayudar a detectar cuales son los pines, tengo tester pero no se donde poner el negativo solo tiene un pin cada uno. Y si me podrias ayudar a instalar y averiguar el puerto Wan, Gracias.
« Última modificación: 15-03-2013, 01:12 (Viernes) por Fedex15 »

mazingerz80

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #375 en: 15-03-2013, 22:31 (Viernes) »
Hola,
Mi ADB A4001N va  de lujo, la única pega es que el wifi interno broadcom BCM43225 de este router no funciona en modo AP...
¿Alguna sugerencia?

He compilado en trunk, con la revisión r36008, con el parche backport también.

¿Alguna sugerencia?

Gracias  :D

mazingerz80

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #376 en: 15-03-2013, 22:35 (Viernes) »
Perdón, lo del parche backport no iba para este hilo.

También añadir que por cable lan si tengo acceso a internet.

Gracias

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #377 en: 16-03-2013, 00:08 (Sábado) »
Mi ADB A4001N va  de lujo, la única pega es que el wifi interno broadcom BCM43225 de este router no funciona en modo AP...
¿Alguna sugerencia?

Lo raro es que no fuera de lujo.  ;D

De momento el modo AP funciona mal o no funciona con las wifi N de Broadcom.
https://dev.openwrt.org/changeset/35763
https://dev.openwrt.org/ticket/13058

me109zito

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #378 en: 16-03-2013, 12:06 (Sábado) »
Dices que por serial no hace nada?
Prueba a intercambiar TX por RX y viceversa (puede que sea eso), y no tengas miedo que haciendo eso no haces ningún cortocircuito  >:D

Ya me cuentas

Joder macho...era eso, jaja. Hasta hoy no pude probarlo, pero desde luego...parezco nuevo. Muchas gracias ;)

Por cierto, ¿sabes como podría configurarlo como router neutro? Había seguido un manual que creaba un par de vlans, pero la otra vez no se si puse algo mal, pero mira en que acabé.

mazingerz80

  • Visitante
Re: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1
« Respuesta #379 en: 16-03-2013, 14:42 (Sábado) »
Mi ADB A4001N va  de lujo, la única pega es que el wifi interno broadcom BCM43225 de este router no funciona en modo AP...
¿Alguna sugerencia?

Lo raro es que no fuera de lujo.  ;D

De momento el modo AP funciona mal o no funciona con las wifi N de Broadcom.
https://dev.openwrt.org/changeset/35763
https://dev.openwrt.org/ticket/13058


Ajam, si se que es muy nuevo aún este router... y también tengo entendido que los broadcom en tema de drivers dan guerra  >:D

Estoy con otras compilaciones mientras tanto por si cae la breva y le da por funcionar jaja.

Muchas gracias