Autor Tema: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1  (Leído 317799 veces)

0 Usuarios y 1 Visitante están viendo este tema.

amarillocola

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #160 en: 28-09-2012, 10:34 (Viernes) »
Buenas, me acaban de dar un modelo de este router y quiero empezar a instalar la version openwrt-963281T_TEF-generic-squashfs-cfe_r33275, que parece estable, pero también leo que puede quedar frito...



gmtii

  • Visitante
Re: Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #161 en: 28-09-2012, 15:51 (Viernes) »
Hola

TTL 3v3. Vale un PL2303 o CP210x.

Saludos.

Enviado desde mi HUAWEI U8815 usando Tapatalk 2

amarillocola

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #162 en: 01-10-2012, 12:14 (Lunes) »
Buenas, por mas que miro y vuelvo a mirar no puedo entrar al sistema para cargar el openwrt. Probé lo de pulsar el reset y 30 seg. pero se reinicia y vuelve al estado normal. Como puedo cargar el open??

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #163 en: 01-10-2012, 12:25 (Lunes) »
Buenas, por mas que miro y vuelvo a mirar no puedo entrar al sistema para cargar el openwrt. Probé lo de pulsar el reset y 30 seg. pero se reinicia y vuelve al estado normal. Como puedo cargar el open??
Ése es exactamente el problema, que nadie sabe cómo hacer que el router entre en el bootloader. Por eso, si se queda frito, la única forma de entrar en el bootloader es utilizando un cable uart (serial).

Los demás supongo que han cargado el firmware desde el original.

Saludos.

srt8100

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #164 en: 01-10-2012, 21:59 (Lunes) »
@Noltari:

He pedido el adaptador usb con PL2303HX, en cuanto me llegue de china me pongo a resucitar el router. Tengo una duda, es necesario las 3 GND o con una ya vale?
Si necesitas que realice alguna prueba antes de volver a flashear me lo dices.. no veo muy normal tantos routers muertos, algo se nos escapa.

UN salu2

pikomule

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #165 en: 10-10-2012, 15:08 (Miércoles) »
confirmo que pulsando la tecla F en el hyperterminal al encender el router, permite la carga a traves del navegador. 192.168.1.1

he usado un serial to usb ttl:


rafa.are.ro@gmail.com

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #166 en: 11-10-2012, 18:35 (Jueves) »
Buenas tengo este router desde hace unos meses y ya es hora que le saque un poco de jugo. He leido que el wi-fi ya funciona pero que solo como router neutro si no me equivoco no? es decir tendria que tener un router X que se conectaria con el ISP y despues a este router X le conecto el ADB de movistar por unos de los puertos ethernet y lo pongo en modo bridge no?

Gracias de antemano!!

pikomule

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #167 en: 11-10-2012, 18:47 (Jueves) »
asi es, es como lo tengo yo, el router principal (192.168.1.1) con internet y conectado por ethernet al ADB con OpenWRT (192.168.1.99). Lo tengo ahora mismo como cliente Torrent con Transmission, como server SAMBA y como server web para subidas remotas, sin php ni extras. Aguanta sin problemas, mucho mejor que el Comtrend 536+ que me tenia desesperado de lo lento que iba.
« Última modificación: 11-10-2012, 18:48 (Jueves) por pikomule »

rafa.are.ro@gmail.com

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #168 en: 11-10-2012, 19:17 (Jueves) »
pues listo otro mas en openwrt! jeje por cierto de los enlaces de la primera pagina (entiendo que son los mas actuales) el 6328_svn.patch tengo que instalarlo y si es asi... como por usb montando el pendrive por telnet? y ya mi ultima pregunta y quizas la que mas frio me ha dejado ¿tiene entorno web para la configuracion? o todo a pelo? jeje si es a pelo pues  bueno asi practico xD

EDITO: jajajaja perdon mi impaciencia me hizo meterme por telnet ya que tardo un poquito en cargar por web! jaja
« Última modificación: 11-10-2012, 19:31 (Jueves) por rafa.are.ro@gmail.com »

pikomule

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #169 en: 11-10-2012, 19:35 (Jueves) »
si el pendrive va en fat32, ext2, ext3 o ext4 te lo montara automaticamente, ya que tiene los modulos necesarios para que sea automatico. Para NTFS solo lee, puedes instalar NTFS-3G para poder escribir, pero no te lo recomiendo no va uy bien.

Nada mas entrar por web te pide que le pongas una contraseña, a partir de ese momento estara activado el SSH. Tendras que hacer muchas cosas por comandos, segun la finalidad que quieras darle al router

rafa.are.ro@gmail.com

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #170 en: 11-10-2012, 19:41 (Jueves) »
vamos en linux me muevo bien en consola (uso arch y suelo configurarme casi todo) pero claro nunca he tocado un router por la terminal. Me podrias decir mas o menos como hacer para que me apareza la wl0? para poder tener wifi? y lo el 6328_svn.patch lo instalo como un script normal y corriente no? con esto ya tendria wifi?

pikomule

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #171 en: 11-10-2012, 19:44 (Jueves) »
lo del pach ni idea, y lo del wifi activalo desde el navegador, en el apartado network

rafa.are.ro@gmail.com

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #172 en: 11-10-2012, 20:03 (Jueves) »
Bueno lo dejo aqui por si alguno me puede contestar!
He pasado el patch por ssh al router, le he dado permisos y lo he intentado ejecutar.

root@OpenWrt:/# ls -l 6328_svn.patch
-rwxr-xr-x    1 root     root         35574 Sep  8 16:17 6328_svn.patch
root@OpenWrt:/# ./6328_svn.patch
./6328_svn.patch: line 1: Index:: not found
./6328_svn.patch: line 2: ===================================================================: not found
./6328_svn.patch: line 3: syntax error: unexpected "("
root@OpenWrt:/#

Intentare no ser muy pesado (pero es que me encantan los juguetes nuevos! :) )
He estado mirando las opciones de las interfaces y del wifi
en wifi le doy a enable y me pone... [Wireless is restarting...] y  [despues Wireless is disabled or not associated] el caso es que pense que no funcionaba el wifi pero si me pilla las wifis cercanas si le doy a scan.

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #173 en: 11-10-2012, 20:51 (Jueves) »
Bueno lo dejo aqui por si alguno me puede contestar!
He pasado el patch por ssh al router, le he dado permisos y lo he intentado ejecutar.

root@OpenWrt:/# ls -l 6328_svn.patch
-rwxr-xr-x    1 root     root         35574 Sep  8 16:17 6328_svn.patch
root@OpenWrt:/# ./6328_svn.patch
./6328_svn.patch: line 1: Index:: not found
./6328_svn.patch: line 2: ===================================================================: not found
./6328_svn.patch: line 3: syntax error: unexpected "("
root@OpenWrt:/#

Intentare no ser muy pesado (pero es que me encantan los juguetes nuevos! :) )
He estado mirando las opciones de las interfaces y del wifi
en wifi le doy a enable y me pone... [Wireless is restarting...] y  [despues Wireless is disabled or not associated] el caso es que pense que no funcionaba el wifi pero si me pilla las wifis cercanas si le doy a scan.
No te tomes a mal la respuesta: Lo que estás haciendo no tiene ni pies ni cabeza :$. El archivo 6328_svn.patch sirve para añadir soporte para este router en el código fuente de openwrt. Si te bajas uno de los firmwares que facilito no lo necesitas para nada ;).

Borra el archivo y a disfrutar del router y openwrt ;D.

Saludos!

rafa.are.ro@gmail.com

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #174 en: 11-10-2012, 20:54 (Jueves) »
jajajaja no no hombre a mal nunca! al reves y sabes algo de lo de la wifi? es que no se como hacerlo... me he conectado a mi otro router por wifi pero la señal se queda en 0% aunque estan a medio metro.

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #175 en: 11-10-2012, 21:06 (Jueves) »
jajajaja no no hombre a mal nunca! al reves y sabes algo de lo de la wifi? es que no se como hacerlo... me he conectado a mi otro router por wifi pero la señal se queda en 0% aunque estan a medio metro.
No sé que puede estar pasando...

¿Lo has configurado a través de LuCI como aparece en este tuto https://foro.seguridadwireless.net/openwrt/(tutorial)-modo-clienterepetidor-openwrt/?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #176 en: 11-10-2012, 22:21 (Jueves) »
Recuerda que la wifi en este router funciona sólo en modo cliente, no en AP.
Repasa los hilos fijos del foro de OpenWrt, que seguro que algunos te serán de ayuda  ;)
Valoraciones positivas en compra/venta:
167 en Htcmania
224 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

rafa.are.ro@gmail.com

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #177 en: 12-10-2012, 03:06 (Viernes) »
ahh entonces no podre dar Wifi en mi red con el ADB?

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #178 en: 12-10-2012, 03:46 (Viernes) »
ahh entonces no podre dar Wifi en mi red con el ADB?
No, no puedes por el driver incluido en el firmware. Está escrito en el primer post...

rafa.are.ro@gmail.com

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #179 en: 12-10-2012, 11:46 (Viernes) »
que pena tio si lo lei pero creia que ya habiais dado con la solucion. pero la verdad es que me ha gustado mucho jugar con openwrt, solo que necesito wifi obligatoriamente y me veo forzado a volver a la mierda de movistar. He intentado restaurar la imagen desde el menu [Backup/Flash Firmware] en el apartado de [Flash new firmware image] selecciono la imagen que hay en el primer post. (o al menos creo que es la imagen) y me  dice que el formato no es soportado. tengo que hacerlo desde otra forma?