Autor Tema: [Desarrollo] OpenWrt en Telefónica Home Station ADB P.DG A4001N1  (Leído 316909 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #120 en: 04-07-2012, 20:23 (Miércoles) »
Le he preguntado a Hauke sobre el parche al BCMA para que detecte la fallback sprom. Me ha pedido que recupere un par de valores del BCMA.

Para esto necesito que alguno pruebe este firmware, que es exactamente idéntico al anterior pero con los debugs.

https://dl.dropbox.com/u/4708147/openwrt/63281T/openwrt-963281T_TEF-generic-squashfs-cfe.bin

Saludos!



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #121 en: 05-07-2012, 00:56 (Jueves) »
Le he preguntado a Hauke sobre el parche al BCMA para que detecte la fallback sprom. Me ha pedido que recupere un par de valores del BCMA.

Para esto necesito que alguno pruebe este firmware, que es exactamente idéntico al anterior pero con los debugs.

https://dl.dropbox.com/u/4708147/openwrt/63281T/openwrt-963281T_TEF-generic-squashfs-cfe.bin

Saludos!

Mañana lo pruebo y te cuento.


Queda claro entonces que no se puede usar el driver broadcom wl, puesto que la versión que hay en Openwrt es demasiado antigua para soportar el 43225.

Así pues quedan dos alternativas: Usar brcmsmac (la última versión lo incluye). O usar b43.

El problema de brcmsmac es que habéis comentado que su rendimiento no es adecuado y produce cortes.
El problema de b43 es que no soporta Wifi N (el wifi queda limitado a b/g).

No sé si hay alguna forma de actualizar el driver wl en openwrt, si alguien sabe algo al respecto, nos vendría bien algo de luz ;).

Saludos!

Con respecto a esto, no digo que tenga mal rendimiento, digo que funciona algo peor que el atheros del hg556a.
Curiosamente, va peor en 'bajada', pero en 'subida' mejora al atheros (esto va referido a las pocas pruebas que he podido hacer, y es un simple test de velocidad en speedtest.net).

A ver si alguien más lo testea y nos comenta sus impresiones  ;)
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #122 en: 05-07-2012, 19:02 (Jueves) »
Para esto necesito que alguno pruebe este firmware, que es exactamente idéntico al anterior pero con los debugs.

https://dl.dropbox.com/u/4708147/openwrt/63281T/openwrt-963281T_TEF-generic-squashfs-cfe.bin

Saludos!

Ahí va el dmesg

[spoiler][    0.000000] Linux version 3.3.8 (noltari@skynet) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #3 Wed Jul 4 20:20:32 CEST 2012
[    0.000000] Detected Broadcom 0x6328 CPU revision 10b0
[    0.000000] CPU frequency is 320 MHz
[    0.000000] 32MB of RAM installed
[    0.000000] registering 32 GPIOs
[    0.000000] gpiochip_add: registered GPIOs 0 to 31 on device: bcm63xx-gpio
[    0.000000] board_bcm963xx: Boot address 0xb8000000
[    0.000000] board_bcm963xx: CFE version: A4001N-V0003
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0002a075 (Broadcom BMIPS4350)
[    0.000000] board_bcm963xx: board name: 963281T_TEF
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00002000
[    0.000000] Movable zone start PFN for each node
[    0.000000] Early memory PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00002000
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 802a5a60, node_mem_map 81000000
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8128 pages, LIFO batch:0
[    0.000000] Reserving 0MB of memory at 0MB for crashkernel
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc:
  • 0

[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 16 bytes.
[    0.000000] Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes
[    0.000000] Memory: 29376k/32768k available (2248k kernel code, 3392k reserved, 399k data, 200k init, 0k highmem)
[    0.000000] NR_IRQS:128
[    0.000000] Calibrating delay loop... 318.46 BogoMIPS (lpj=636928)
[    0.036000] pid_max: default: 32768 minimum: 301
[    0.040000] Mount-cache hash table entries: 512
[    0.048000] NET: Registered protocol family 16
[    0.276000] registering PCI controller with io_map_base unset
[    0.288000] bio: create slab <bio-0> at 0
[    0.296000] PCI host bridge to bus 0000:00
[    0.300000] pci_bus 0000:00: root bus resource [mem 0x10f00000-0x11efffff]
[    0.304000] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.308000] pci 0000:00:00.0: [14e4:6328] type 1 class 0x000604
[    0.308000] pci 0000:00:00.0: PME# supported from D0 D3hot
[    0.308000] pci 0000:01:00.0: [14e4:a8d8] type 0 class 0x000280
[    0.308000] pci 0000:01:00.0: reg 10: [mem 0x00000000-0x00003fff 64bit]
[    0.308000] pci 0000:01:00.0: supports D1 D2
[    0.308000] pci 0000:00:00.0: BAR 8: assigned [mem 0x10f00000-0x10ffffff]
[    0.312000] pci 0000:01:00.0: BAR 0: assigned [mem 0x10f00000-0x10f03fff 64bit]
[    0.316000] pci 0000:00:00.0: PCI bridge to [bus 01-01]
[    0.320000] pci 0000:00:00.0:   bridge window [mem 0x10f00000-0x10ffffff]
[    0.324000] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[    0.328000] Switching to clocksource MIPS
[    0.336000] PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
[    0.344000] bcma: Found chip with id 0xA8D9, rev 0x01 and package 0x0A
[    0.348000] bcma: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x22, class 0x0)
[    0.360000] bcma: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x17, class 0x0)
[    0.368000] bcma: Core 2 found: PCIe (manuf 0x4BF, id 0x820, rev 0x0F, class 0x0)
[    0.376000] bcma: Found rev 6 PMU (capabilities 0x108C2606)
[    0.376000] bcma: PMU resource config unknown or not needed for device 0xA8D9
[    0.376000] bcma: Workarounds unknown or not needed for device 0xA8D9
[    0.408000] [Hauke] bus->drv_cc.core->id.rev :: 0x22[Hauke] bus->drv_cc.capabilities :: 0x58500000[Hauke] srom_control :: 0x3
[    0.416000] bcma: SPROM offset 0x800
[    0.456000] bcma: Using SPROM revision 8 provided by platform.
[    0.460000] bcma: Bus registered
[    0.464000] NET: Registered protocol family 2
[    0.468000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.476000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[    0.484000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.488000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.496000] TCP reno registered
[    0.500000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.504000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.512000] NET: Registered protocol family 1
[    0.516000] PCI: CLS 0 bytes, default 16
[    0.520000] audit: initializing netlink socket (disabled)
[    0.524000] type=2000 audit(0.524:1): initialized
[    0.532000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.536000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.548000] msgmni has been set to 57
[    0.552000] io scheduler noop registered
[    0.556000] io scheduler deadline registered (default)
[    0.564000] bcm63xx_uart.0: ttyS0 at MMIO 0xb0000100 (irq = 36) is a bcm63xx_uart
[    0.572000] console [ttyS0] enabled, bootconsole disabled
[    0.588000] m25p80 spi0.0: found mx25l12805d, expected m25p80
[    0.596000] m25p80 spi0.0: mx25l12805d (16384 Kbytes)
[    0.600000] bcm63xxpart: CFE boot tag found with version 6 and board type 963281T_TEF
[    0.608000] bcm63xxpart: Partition 0 is CFE offset 0 and length 10000
[    0.616000] bcm63xxpart: Partition 1 is kernel offset 10100 and length eff00
[    0.624000] bcm63xxpart: Partition 2 is rootfs offset 100000 and length ef0000
[    0.628000] bcm63xxpart: Partition 3 is nvram offset ff0000 and length 10000
[    0.636000] bcm63xxpart: Partition 4 is linux offset 10000 and length fe0000
[    0.644000] bcm63xxpart: Spare partition is offset 2e0004 and length d0fffc
[    0.652000] 5 bcm63xxpart partitions found on MTD device spi0.0
[    0.656000] Creating 5 MTD partitions on "spi0.0":
[    0.664000] 0x000000000000-0x000000010000 : "CFE"
[    0.672000] 0x000000010100-0x000000100000 : "kernel"
[    0.676000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.692000] 0x000000100000-0x000000ff0000 : "rootfs"
[    0.700000] mtd: partition "rootfs" set to be root filesystem
[    0.704000] mtd: partition "rootfs_data" created automatically, ofs=2E0000, len=D10000
[    0.712000] 0x0000002e0000-0x000000ff0000 : "rootfs_data"
[    0.720000] 0x000000ff0000-0x000001000000 : "nvram"
[    0.728000] 0x000000010000-0x000000ff0000 : "linux"
[    0.772000] bcm63xx-wdt bcm63xx-wdt:  started, timer margin: 30 sec
[    0.780000] Registered led device: 963281T_TEF:green:power
[    0.780000] Registered led device: 963281T_TEF:red:stop
[    0.780000] Registered led device: 963281T_TEF:green:inet
[    0.784000] Registered led device: 963281T_TEF:red:inet-fail
[    0.784000] Registered led device: 963281T_TEF:green:ppp
[    0.784000] Registered led device: 963281T_TEF:red:ppp-fail
[    0.784000] Registered led device: 963281T_TEF:green:3g
[    0.784000] Registered led device: 963281T_TEF:red:3g-fail
[    0.784000] Registered led device: 963281T_TEF:green:wlan
[    0.784000] Registered led device: 963281T_TEF:red:wlan-fail
[    0.784000] Registered led device: 963281T_TEF:green:eth
[    0.788000] Registered led device: 963281T_TEF:red:eth-fail
[    0.788000] TCP cubic registered
[    0.792000] NET: Registered protocol family 17
[    0.796000] 8021q: 802.1Q VLAN Support v1.8
[    0.808000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    0.816000] Freeing unused kernel memory: 200k freed
[    3.336000] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 1, 100Mbps, full-duplex
[    3.392000] roboswitch: Probing device eth0:
[    3.396000] bcm63xx_enet: could not find a used port with phy_id 0, assuming phy is external
[    3.404000] No Robo switch in managed mode found, phy_id = 0xffffffff
[    3.412000] roboswitch: Probing device eth1: No such device
[    3.416000] roboswitch: Probing device eth2: No such device
[    3.424000] roboswitch: Probing device eth3: No such device
[   12.000000] Compat-wireless backport release: compat-wireless-2012-06-14
[   12.008000] Backport based on wireless-testing.git master-2012-06-14
[   12.016000] compat.git: wireless-testing.git
[   12.072000] cfg80211: Calling CRDA to update world regulatory domain
[   12.076000] cfg80211: World regulatory domain updated:
[   12.084000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   12.092000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   12.100000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   12.108000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   12.116000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   12.124000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   12.512000] NET: Registered protocol family 10
[   12.616000] There is already a switch registered on the device 'eth0'
[   12.624000] roboswitch: Probing device eth1: No such device
[   12.628000] roboswitch: Probing device eth2: No such device
[   12.636000] roboswitch: Probing device eth3: No such device
[   13.024000] Button Hotplug driver version 0.4.1
[   13.188000] PPP generic driver version 2.4.2
[   13.620000] brcmsmac bcma0:0: mfg 4bf core 812 rev 23 class 0 irq 31
[   13.984000] bcma: Switched to core: 0x812
[   13.984000] brcmsmac: use fifi: 20, 192, 192, 21, 17, 5
[   13.992000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   14.004000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   14.212000] NET: Registered protocol family 24
[   14.248000] nf_conntrack version 0.5.0 (462 buckets, 1848 max)
[   14.624000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   14.912000] input: gpio-keys-polled as /devices/platform/gpio-keys-polled.0/input/input0
[   20.896000] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 1, 100Mbps, full-duplex
[   20.904000] device eth0 entered promiscuous mode
[   20.912000] br-lan: port 1(eth0) entered forwarding state
[   20.916000] br-lan: port 1(eth0) entered forwarding state
[   22.920000] br-lan: port 1(eth0) entered forwarding state
[   31.328000] eth0: no IPv6 routers present
[   38.532000] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   38.540000] jffs2_build_filesystem(): unlocking the mtd device... done.
[   38.548000] jffs2_build_filesystem(): erasing all blocks after the end marker... done.
[  131.648000] JFFS2 notice: (1050) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[/spoiler]
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #123 en: 07-07-2012, 02:37 (Sábado) »
Gracias por el bootlog. Tengo que hablar con Hauke a ver que me cuenta del BCMA.

Mientras tanto Florian ha añadido el parche para la detección del "cfe-" en vez del "cfe-v".
https://dev.openwrt.org/changeset/32643
Lo que no sé es por qué ha borrado el parche de la placa del patchwork sin añadirlo xDDD. Mañana a ver si le pillo por banda y le pregunto.

Saludos!

srt8100

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #124 en: 11-07-2012, 22:11 (Miércoles) »
Buenas

Como va el tema del wifi? se ha solucionado algo Noltari? el usb ya funicona con los modificaciones que has echo?
Tengo el router con una firm de los primeros que colgaste y el wifi falla de vez en cuando, es para esperarme a actualizar o pongo el ultimo con los debusg

Salu2

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #125 en: 12-07-2012, 00:33 (Jueves) »
Buenas

Como va el tema del wifi? se ha solucionado algo Noltari? el usb ya funicona con los modificaciones que has echo?
Tengo el router con una firm de los primeros que colgaste y el wifi falla de vez en cuando, es para esperarme a actualizar o pongo el ultimo con los debusg

Salu2
El wifi es normal que vaya mal. El driver b43 no está muy pulido y mucho menos el brcsmac. El mejor driver sería el propietario (broadcom-wl), pero openwrt utiliza una versión antigua que no es compatible con el wifi de este router...

Así que lo siento, pero de momento nada. Además estoy dando el coñazo todos los días para que apliquen los parches...

Saludos!

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #126 en: 13-07-2012, 22:51 (Viernes) »
Después de varios días esperando el feedback de Hauke hoy he podido hablar con él y me ha confirmado lo que ya sabía, que hay que forzar la detección del fallback sprom en el driver bcma.

Parches actualizados:
https://lists.openwrt.org/pipermail/openwrt-devel/2012-July/015980.html
https://lists.openwrt.org/pipermail/openwrt-devel/2012-July/015981.html
https://lists.openwrt.org/pipermail/openwrt-devel/2012-July/015982.html

Saludos!

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #127 en: 18-07-2012, 16:46 (Miércoles) »
Una actualización del firmware, que nunca viene mal.
https://dl.dropbox.com/u/4708147/openwrt/63281T/openwrt-963281T_TEF-generic-squashfs-cfe_r32775.bin

Los drivers del wifi han sido actualizados, por lo que a lo mejor hay cierta mejora.

Saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #128 en: 18-07-2012, 19:13 (Miércoles) »
Probado.

Test de velocidad con el anterior firmware



Test de velocidad con el nuevo firmware



Las diferencias son tan pequeñas, que no creo que se puedan deber al driver (ganamos en subida y bajada, pero perdemos en ping).
Por otro lado, no estaba instalado wpa-supplicant ni hostapd, por lo que no conseguía conectar de ninguna manera (ni siquiera con la red de mi amigo y vecino con clave wep). Fue instalar ambos y 'mano de santo'  ;D

Test de velocidad con el hg556a. Como se puede ver, la velocidad de bajada es casi el doble  ;D



Te he mandado los log a tu e-mail, que últimamente está saliendo demasiada info (aunque oculta) en mis dmesg's  :D

Voy a probar el nuevo firm del ar5387un  ;)
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #129 en: 18-07-2012, 19:35 (Miércoles) »
Probado.

Test de velocidad con el anterior firmware



Test de velocidad con el nuevo firmware



Las diferencias son tan pequeñas, que no creo que se puedan deber al driver (ganamos en subida y bajada, pero perdemos en ping).
Por otro lado, no estaba instalado wpa-supplicant ni hostapd, por lo que no conseguía conectar de ninguna manera (ni siquiera con la red de mi amigo y vecino con clave wep). Fue instalar ambos y 'mano de santo'  ;D

Test de velocidad con el hg556a. Como se puede ver, la velocidad de bajada es casi el doble  ;D



Te he mandado los log a tu e-mail, que últimamente está saliendo demasiada info (aunque oculta) en mis dmesg's  :D

Voy a probar el nuevo firm del ar5387un  ;)
Pues no, no ha habido mucha mejora :P.

Actualizado el firmware corrigiendo lo del wifi. Además he actualizado los parches SVN creando un perfil para el wifi de este router.

https://dl.dropbox.com/u/4708147/openwrt/63281T/63281T_TEF_svn.patch
Saludos.

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #130 en: 19-07-2012, 19:11 (Jueves) »
Nuevos parches válidos tanto para el Comtend AR5387un como para el ADB P.DG A4001N.
https://dl.dropbox.com/u/4708147/openwrt/6328/6328_svn.patch

Firmware actualizado: https://dl.dropbox.com/u/4708147/openwrt/6328/openwrt-963281T_TEF-generic-squashfs-cfe_r32777.bin

Saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #131 en: 20-07-2012, 13:55 (Viernes) »
Hace un rato, haciendo pruebas (pretendía montar una unidad de red con cifsmount) e instalando paquetes, el router se ha quedado 'lelo'  :-[
Desgraciadamente, yo nunca conseguí que me entrara al CFE (siempre he flasheado desde LuCi o desde el interfaz web del firmware original), así que de momento está 'medio muerto' hasta que me haga con un serial ... lo iba posponiendo y al final ...  ;D
Lo curioso, es que responde al ping durante 4 o 5 segundos (tanto al 192.168.1.1 si configuro mi tarjeta de red, como al 10.0.1.99 que es la ip que tenía asignada en mi red) y luego me ignora, sin más  :-X :-X ... después, se reinicia un par de veces, y termine apagando todas las luces  ???

Pues nada, cuando me llegue el serial, ya iré contando  ;)
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka


Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #133 en: 29-07-2012, 14:06 (Domingo) »
Por fin me han aceptado un par de parches de los que tengo en espera:
https://dev.openwrt.org/changeset/32890
https://dev.openwrt.org/changeset/32892

Así que toca actualización, sobre todo por el profile del wifi utilizando brcmsmac.

Firmware actualizado:
https://dl.dropbox.com/u/4708147/openwrt/6328/openwrt-963281T_TEF-generic-squashfs-cfe_r32904.bin

Parches SVN actualizados (primer post):
https://dl.dropbox.com/u/4708147/openwrt/6328/6328_svn.patch

Saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #134 en: 29-07-2012, 15:52 (Domingo) »
Estupendas noticias ;)
A ver si esta semana me llega el serial y recupero el router.

Enviado desde mi u8500 usando Tapatalk 2
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #135 en: 31-07-2012, 23:54 (Martes) »
Nuevo firmware, con los últimos parches cambiados por enésima vez realizando los ajustes que jogo me ha pedido...
https://dl.dropbox.com/u/4708147/openwrt/6328/openwrt-963281T_TEF-generic-squashfs-cfe_r32934.bin

Actualizados también los parches SVN a la última versión:
https://dl.dropbox.com/u/4708147/openwrt/6328/6328_svn.patch

Saludos.

EDIT: Ups, copy&paste fail, había puesto el firmware del Comtrend AR5387un xD...
EDIT2: Actualizado firmware sin soporte USB, ya que bloqueaba el inicio.
« Última modificación: 01-08-2012, 21:53 (Miércoles) por Noltari »

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #136 en: 01-08-2012, 21:54 (Miércoles) »
Nuevo firmware, con los últimos parches cambiados por enésima vez realizando los ajustes que jogo me ha pedido...
https://dl.dropbox.com/u/4708147/openwrt/6328/openwrt-963281T_TEF-generic-squashfs-cfe_r32934.bin

Actualizados también los parches SVN a la última versión:
https://dl.dropbox.com/u/4708147/openwrt/6328/6328_svn.patch

Saludos.

EDIT: Ups, copy&paste fail, había puesto el firmware del Comtrend AR5387un xD...
EDIT2: Actualizado firmware sin soporte USB, ya que bloqueaba el inicio.
Actualizado firmware sin soporte USB.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #137 en: 02-08-2012, 09:54 (Jueves) »
Yo ya tengo el serial  >:(
Pero como soy un 'negao' pa las soldaduras y esas cosas, estoy a la espera de que un amiguete me haga el trabajo sucio  ^-^
Luego a recuperar el router, y seguir con las pruebas  ;)
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Noltari

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #138 en: 08-08-2012, 14:41 (Miércoles) »
Actualizado el post principal con una versión actualizada del firmware con soporte USB completo (NTFS/FAT/EXT).

Yo ya tengo el serial  >:(
Pero como soy un 'negao' pa las soldaduras y esas cosas, estoy a la espera de que un amiguete me haga el trabajo sucio  ^-^
Luego a recuperar el router, y seguir con las pruebas  ;)
Esperando noticias :P.

wiisos

  • Visitante
Re: Openwrt en routers de Telefónica Home Station ADB P.DG A4001N1
« Respuesta #139 en: 11-08-2012, 17:01 (Sábado) »
Se puede instalar OpenWRT y hacer que el router descargue torrents en un pendrive a través de USB? Perdería algo con respecto al firm original?

Un saludo y gracias