Autor Tema: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555  (Leído 472065 veces)

0 Usuarios y 1 Visitante están viendo este tema.

TheMrRafus

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #680 en: 25-10-2014, 16:09 (Sábado) »
Hola, para el puerto serie estoy utilizando arduino, para conectar el serie seria tx,rx gnd y vcc a 3,3v no??    Saludos y gracias de antemano



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #681 en: 26-10-2014, 20:29 (Domingo) »
Hola, para el puerto serie estoy utilizando arduino, para conectar el serie seria tx,rx gnd y vcc a 3,3v no??    Saludos y gracias de antemano

Si el arduino ya lo estás alimentando, NO HAY QUE CONECTAR VCC...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

TheMrRafus

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #682 en: 26-10-2014, 21:02 (Domingo) »
Muchas gracias otra cosilla en la pcb hay unos orificios iguales a los del serial,nombrados como jp2,esto es otro conjunto de comunicacion serie??         Saludos

spm

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #683 en: 04-11-2014, 13:00 (Martes) »

Amigos acá mi resultado de esta nueva compilación para la versión de 8 Megas.
- En el modo router neutro anda muy bien y es estable 100%, llevo varios días seguidos con el router configurado y no ha tenido ninguna falla ni caída y lo he puesto a trabajar a full. Lo mismo cuando lo hago trabajar como un simple ap, soportando wep, wpa, wpa2 sin problemas.
- En este mismo modo router neutro, lo he configurado para que actúe de cliente y ap al mismo instante (no es modo bridge ya que pongo mi propio nombre de red y key) con la misma interface wireless (radio0) y sin utilizar un pincho usb externo, a lo cual responde de manera fabulosa, sin caídas ni microcortes ni descuelgues inesperados.
- Aun me da el lío este de no mostrar las redes wep cada vez que le pido un scan y a veces las muestra y muchas veces no, en cambio las wpa siempre están a la vista, esto en la interface LuCI ya que por SSH si me muestra todos los ap existentes.
- Sigo sin poder hacer que reconozca algunos pinchos usb del mercado (les escribiré cuales chip son).
- Temperatura de trabajo ? lo he puesto dentro de una caja de zapatos sacando sus cables por orificios justos y exponiéndolo a una ventana donde entra el sol directo, todo para ver si se cuelga y si alcanza elevadas temperaturas y SI LO HACE ( 68° ) jajajaja se caldea como un infierno pero nunca deja de funcionar ni se pone lento, también lo he puesto a trabajar abierto y es mas relajado en temperatura alcanzando los agradables 30° y por ultimo le he instalado un disipador de temperatura http://i.imgur.com/31QpH.jpg adherido con pasta Arctic Cooling MX-4 y solo alcanza los 24° como máximo estando cerrado.

Seguiré investigando...

Saludos Cordiales a Todos.


Pues yo lo tengo como repetidor (aunque sólo para pruebas) y aunque el rendimiento no es excelente (lógicamente, si le pones un 'pincho' wifi USB va a mejorar notablemente), se comporta correctamente. Además, cuando lo reinicio vuelve a conectarse perfectamente.

No será un problema de falta de señal ?

Hola a todos

Estoy intentando configurar este equipo para que recoja por wifi la señal del router principal y la extienda en una zona alejada.
He visto estas dos opciones distintas (creo que son distintas, ¿no?)

¿Me podéis orientar un poco con las posibles soluciones?

Me he leído este tutorial, pero no consigo aclararme si necesito crear dos interfaces (una para recibir y otra para emitir) o se puede configurar una única

https://foro.seguridadwireless.net/openwrt/%28tutorial%29-modo-clienterepetidor-openwrt/

saaroc

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #684 en: 06-11-2014, 22:00 (Jueves) »
hola estoy intentando hacer:


3 - Renombramos el firmware a "openwrt.bin" sin comillas

4 - Enchufamos la memoria usb al router

5 - Entramos por telnet y ejecutamos:

Código:
cd /var/tmp/storage_dev/usb1_1
./mtd write openwrt.bin firmware

Puede tardar un par de minutos, cuando termine reiniciamos el router y... ¡Ya tenemos openwrt instalado!

Pero cuando le doy a cd /var ... me da fallo. Os pongo una imagen:

https://dl.dropboxusercontent.com/u/56883982/Captura%20de%20pantalla%20de%202014-11-06%2021%3A55%3A32.png

Lo que estoy intentando es volver al firmware original, pero estoy teniendo muuuuuuchos problemas. Otra cosa es que a menudo se queda la conexion telnet bloqueada, no me deja escribir ni nada. Por que puede ser esto, puede estar dañado el cable rj45 ??

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #685 en: 07-11-2014, 09:06 (Viernes) »
hola estoy intentando hacer:


3 - Renombramos el firmware a "openwrt.bin" sin comillas

4 - Enchufamos la memoria usb al router

5 - Entramos por telnet y ejecutamos:

Código:
cd /var/tmp/storage_dev/usb1_1
./mtd write openwrt.bin firmware

Puede tardar un par de minutos, cuando termine reiniciamos el router y... ¡Ya tenemos openwrt instalado!

Pero cuando le doy a cd /var ... me da fallo. Os pongo una imagen:

https://dl.dropboxusercontent.com/u/56883982/Captura%20de%20pantalla%20de%202014-11-06%2021%3A55%3A32.png

Lo que estoy intentando es volver al firmware original, pero estoy teniendo muuuuuuchos problemas. Otra cosa es que a menudo se queda la conexion telnet bloqueada, no me deja escribir ni nada. Por que puede ser esto, puede estar dañado el cable rj45 ??

¿Tienes una imagen del firmware original para flashearlo?
¿Por qué no lo subes por SCP al directorio /tmp/ y lo flasheas desde ahí? (El directorio /tmp es la RAM del router)
Si se te corta la conexión puede que el cable no esté muy católico. Prueba con otro.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

saaroc

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #686 en: 07-11-2014, 10:37 (Viernes) »
Me puedes explicar como es el proceso de subir el archivo por scp, es la primera vez que "cacharreo " con routers y no se ni que significan las siglas.

saaroc

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #687 en: 07-11-2014, 13:14 (Viernes) »
Me puedes explicar como es el proceso de subir el archivo por scp, es la primera vez que "cacharreo " con routers y no se ni que significan las siglas.

Bueno pues ya he descubierto como se subia el firmware, y lo he instalado. Peeero creo que me he cargado el router pa siempre  ;D tras instalar el nuevo firmware solo se enciende la luz de adsl la de poker ethernet y demas estan apagadas.

El firmware que instale lo saque de:

http://www.htcmania.com/showthread.php?t=633228

Creo que he creado un ladrillo blanco  ^-^

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #688 en: 07-11-2014, 18:26 (Viernes) »
Me puedes explicar como es el proceso de subir el archivo por scp, es la primera vez que "cacharreo " con routers y no se ni que significan las siglas.

Bueno pues ya he descubierto como se subia el firmware, y lo he instalado. Peeero creo que me he cargado el router pa siempre  ;D tras instalar el nuevo firmware solo se enciende la luz de adsl la de poker ethernet y demas estan apagadas.

El firmware que instale lo saque de:

http://www.htcmania.com/showthread.php?t=633228

Creo que he creado un ladrillo blanco  ^-^

Si se te queda bloqueado al arrancar tendrás que buscar un cable serie para conectarlo y ver qué dice el bootloader.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

Angel85j

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #689 en: 10-11-2014, 23:38 (Lunes) »
Hola, este es mi primer mensaje, aunque espero que sea el primero muchos... Hace poco rescate este router del trastero con intención de darle una segunda vida y le he instalado openwrt, hasta aquí todo correcto, el caso es que he cometido el fallo de no haberme informado lo suficiente y debia haber instalado barrier braker... Al router accedo bien por ssh pero no me reconoce el pendrive para poder meter el firmware, tampoco está conectado a internet ya que me borre de Movistar.

¿Cómo podría instalarle ahora barrier braker?

Gracias, un saludo.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #690 en: 11-11-2014, 13:33 (Martes) »
Hola, este es mi primer mensaje, aunque espero que sea el primero muchos... Hace poco rescate este router del trastero con intención de darle una segunda vida y le he instalado openwrt, hasta aquí todo correcto, el caso es que he cometido el fallo de no haberme informado lo suficiente y debia haber instalado barrier braker... Al router accedo bien por ssh pero no me reconoce el pendrive para poder meter el firmware, tampoco está conectado a internet ya que me borre de Movistar.

¿Cómo podría instalarle ahora barrier braker?

Gracias, un saludo.

Puedes actualizarlo desde LuCi (el interfaz web de OpenWrt).
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Angel85j

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #691 en: 11-11-2014, 14:14 (Martes) »
No se me ha instalado lUcI...

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #692 en: 11-11-2014, 14:39 (Martes) »
No se me ha instalado lUcI...

Desde una conexión ssh escribe:

Código: [Seleccionar]
dmesg | grep "] 0x"
Y postea el resultado.
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Angel85j

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #693 en: 11-11-2014, 14:52 (Martes) »
No se me ha instalado lUcI...

Desde una conexión ssh escribe:

Código: [Seleccionar]
dmesg | grep "] 0x"
Y postea el resultado.


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #694 en: 11-11-2014, 15:02 (Martes) »
Baja un firmware que incluya LuCi (de los muchos que hay en el hilo o la versión estable de AA del repo de OpenWrt: http://downloads.openwrt.org/barrier_breaker/14.07/ramips/rt305x/openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade.bin).

Luego lo copias al router (puedes usar WinSCP) a /tmp (lo renombras previamente a 1.bin) y nuevamente desde una conexión ssh ejecutas el comando:

Código:

Código: [Seleccionar]
mtd -r write /tmp/1.bin firmware
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Angel85j

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #695 en: 11-11-2014, 16:23 (Martes) »
Baja un firmware que incluya LuCi (de los muchos que hay en el hilo o la versión estable de AA del repo de OpenWrt: http://downloads.openwrt.org/barrier_breaker/14.07/ramips/rt305x/openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade.bin).

Luego lo copias al router (puedes usar WinSCP) a /tmp (lo renombras previamente a 1.bin) y nuevamente desde una conexión ssh ejecutas el comando:

Código:

Código: [Seleccionar]
mtd -r write /tmp/1.bin firmware

funcionó!! y ya lo he puesto en castellano tambien
muchas gracias!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #696 en: 12-11-2014, 09:44 (Miércoles) »

funcionó!! y ya lo he puesto en castellano tambien
muchas gracias!

 ;)
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

hanns

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #697 en: 15-11-2014, 17:25 (Sábado) »
Hola, tengo un alpha asl26555 por casa, y viendo las posibilidades que ofrece esto del openwrt, voy a intentar cargárselo.
La verdad es que nunca he echo nada parecido, así que agradecería mucho vuestra ayuda.

 intento descargar este archivo:

1 - Descargamos el binario mtd compilado por SENIL: http://www.mediafire.com/download/086i2q3xi3fe4zx/mtd

pero se queda la página de mediafire en blanco  :-\
también he intentado descargarlo desde el enlace que puso varondan en Onedrive y nada.

un saludo y gracias


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #698 en: 15-11-2014, 18:58 (Sábado) »
Hola, tengo un alpha asl26555 por casa, y viendo las posibilidades que ofrece esto del openwrt, voy a intentar cargárselo.
La verdad es que nunca he echo nada parecido, así que agradecería mucho vuestra ayuda.

 intento descargar este archivo:

1 - Descargamos el binario mtd compilado por SENIL: http://www.mediafire.com/download/086i2q3xi3fe4zx/mtd

pero se queda la página de mediafire en blanco  :-\
también he intentado descargarlo desde el enlace que puso varondan en Onedrive y nada.

un saludo y gracias



Pues yo puedo descargar el fichero sin ningún problema  ^-^

Prueba con otro navegador y/o otro equipo.
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

TheMrRafus

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #699 en: 15-11-2014, 20:13 (Sábado) »
Hola

Estoy tratando de conectar mediante serie y no funciona

Las soldaduras son limpias y estoy usando un pl2303hx

He conectado el tx del router al tx del ttl y rx del router al rx

Gnd conectada y 3.3V no conectada

Saludos