Autor Tema: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555  (Leído 470747 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #540 en: 27-03-2014, 17:32 (Jueves) »
Te explico una forma de flashear sin tener acceso a internet ni a la memoria usb.

Desde cualquier linux (wifislax por ejemplo):

1 - Descarga la compilación que quieras flashear, por ejemplo esta: http://www.mediafire.com/download/387padvm602wnv1/r39304.openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade.bin

2 - Ponla en tu escritorio y renómbrala a openwrt.bin

3 - Ahora creamos un pequeño servidor HTTP, para ello abre una terminal y ejecuta:

Código: [Seleccionar]
cd $HOME/Desktop
python -m SimpleHTTPServer 80

4 - Deja esa terminal abierta, y ahora entra por telnet o ssh al router y ejecuta:

Código: [Seleccionar]
cd /tmp
wget http://192.168.1.30/openwrt.bin
mtd write openwrt.bin firmware

Donde pone 192.168.1.30 tienes que poner la IP de tu máquina.

Cuando termine reinicia el router y listo  ;)



La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

nethost_cl

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #541 en: 27-03-2014, 17:40 (Jueves) »



Edito: Buscando info encuentro esto
http://wiki.openwrt.org/doc/howto/usb.storage

Código: [Seleccionar]
root@OpenWrt:/# lsusb
/bin/ash: lsusb: not found
Puede ser que me falten las librerias (pues si que viene pelado!), pero me está costando configurar la interfaz ethernet mediante UCI para que pueda pillar internet a través del portátil. Cuando pueda pongo avances.

La compilación a la que te remite tiene nethost_cl, tiene LuCi y soporte usb entre otras cosas.

Si, si el problema es que la versión que traigo está tan pelada que no soy capaz de montar el usb para flashear de nuevo con la versión que comentáis. Con la ímpetu de convertirlo a OpenWRT cogí el trunk del primer post   :-[

Es mas facil si subes la imagen al router por SCP desde linux con soporte nativo o desde windows con winscp.

Luego flasheas, no me acuerdo de los comandos pero esta todo en el foro.

Si tienes el modelo de 8Mb ( Chile ) acabo de compilar y flashear una que viene con todo, hasta para compartir impresora, eso si esta en ingles pues no me gustan las traducciones.

Si te interesa me avisas.

Saludos

nethost_cl

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #542 en: 27-03-2014, 17:55 (Jueves) »

Jar229

probé tu compilacion, tiene todo lo necesario, pero al igual que la que yo compile, no me detecta la wifi interna del router, alguna forma de habilitarla...

No me aparece en el menu de Luci, no tampoco aparece nada cuando hago un wifi detect...

Con
Código: [Seleccionar]
uci show wireless Me aparece como entrada no encontrada...

Que puede ser???

Saludos

Algo raro le pasa a tu router, porque la compilación que te puse (al menos la que es para routers con 16 megas) está testeada y funciona perfectamente en mi router.

Has leído a 'fondo' el hilo por si se ha tratado el tema anteriormente ?

Yo tambien pense lo mismo y lo flashee con una version antigua y funcionó OK, ahora viene la buena noticia. Bajé las fuentes desde

Código: [Seleccionar]
https://github.com/openwrt-es/openwrt/tree/bcm63xx-r38342


Compilé con todo lo que necesitaba y voilá... Hasta el momento todo perfecto...

Si le interesa a alguien es para la version de 8Mb, va con Luci, ddns, soporte usb etx4 | ntfs con ntfs-3g ( Lectura, escritura ) | vfat | codepages 437 | 850 | 852 | 8859-1 | 8859-13 | 8859-15 | utf8, soporte USB Wifi para las Ralink rt2500, rt2800, rt73 y la Zydas Kmod-zd1211rw, USB-Storage, Kmod-usb2, P910nd, Samba, y el kmod-usb-printer que fue por el que me metí en este lío  ;D ;D ;D ;D

Muchas gracias por la ayuda...


baumann

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #543 en: 27-03-2014, 22:34 (Jueves) »
Te explico una forma de flashear sin tener acceso a internet ni a la memoria usb.

Desde cualquier linux (wifislax por ejemplo):

1 - Descarga la compilación que quieras flashear, por ejemplo esta: http://www.mediafire.com/download/387padvm602wnv1/r39304.openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade.bin

2 - Ponla en tu escritorio y renómbrala a openwrt.bin

3 - Ahora creamos un pequeño servidor HTTP, para ello abre una terminal y ejecuta:

Código: [Seleccionar]
cd $HOME/Desktop
python -m SimpleHTTPServer 80

4 - Deja esa terminal abierta, y ahora entra por telnet o ssh al router y ejecuta:

Código: [Seleccionar]
cd /tmp
wget http://192.168.1.30/openwrt.bin
mtd write openwrt.bin firmware

Donde pone 192.168.1.30 tienes que poner la IP de tu máquina.

Cuando termine reinicia el router y listo  ;)



Muchas gracias!! La verdad es que es tan claro, y salva de tantos apuros, que eso debería estár en el hilo de "How To"  >:(

Voy a ver si consigo hacer esa imagen compatible con una antena Ralink USB externa, que en principio no me la está reconociendo y al forzar dependencias con algunas librerias ahora no funciona la wifi  ^-^

Edito: El rendimiento que da la Wifi es espectacular!! Estaba acostumbrado a lo que daba el un5387 y esto es una maravilla...


Bueno, después de instalar usbutils, encuentro que no está el paquete con el chipset de Ralink

Código: [Seleccionar]
root@openwrt:~# lsusb
Bus 001 Device 002: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Según leí a jar229 en otro hilo, si al intentar instalar un paquete da error de dependencias, incluso forzando la instalación del mismo, no quedaría otro remedio que compilar mi propio firmware con todos los paquetes que quiera, cierto?

Esto es lo que escupió el router:

Código: [Seleccionar]

root@openwrt:~# opkg install kmod-rt2800-usb --force-depends
Installing kmod-rt2800-usb (3.10.32+2014-01-23.1-2) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/packages/kmod-rt2800-usb_3.10.32+2014-01-23.1-2_ramips_24kec.ipk.
Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-lib-crc-ccitt and kmod-lib-crc-ccitt) providing same name marked HOLD or PREFER. Using latest.
Installing kmod-rt2x00-usb (3.10.32+2014-01-23.1-2) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/packages/kmod-rt2x00-usb_3.10.32+2014-01-23.1-2_ramips_24kec.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-rt2800-usb:
 *      kernel (= 3.10.32-1-b7d5fd0bcbbdd36d9a3e820f5fa11382) *         kernel (= 3.10.32-1-b7d5fd0bcbbdd36d9a3e820f5fa11382) *
 * opkg_install_pkg: Package kmod-rt2x00-usb md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
 * opkg_install_cmd: Cannot install package kmod-rt2800-usb.


root@openwrt:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/barrier_breaker.


root@openwrt:~# opkg install kmod-rt2800-usb --force-depends
Installing kmod-rt2800-usb (3.10.32+2014-01-23.1-2) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/packages/kmod-rt2800-usb_3.10.32+2014-01-23.1-2_ramips_24kec.ipk.
Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-lib-crc-ccitt and kmod-lib-crc-ccitt) providing same name marked HOLD or PREFER. Using latest.
Installing kmod-rt2x00-usb (3.10.32+2014-01-23.1-2) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/packages/kmod-rt2x00-usb_3.10.32+2014-01-23.1-2_ramips_24kec.ipk.
Configuring kmod-rt2x00-usb.
Configuring kmod-rt2800-usb.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-rt2800-usb:
 *      kernel (= 3.10.32-1-b7d5fd0bcbbdd36d9a3e820f5fa11382) *         kernel (= 3.10.32-1-b7d5fd0bcbbdd36d9a3e820f5fa11382) *
root@android:~#

« Última modificación: 27-03-2014, 23:38 (Jueves) por baumann »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #544 en: 08-04-2014, 11:28 (Martes) »
Nueva compilación  ;)

r40398
LuCi, soporte para discos usb en formato ntfs, vfat y ext2-3-4, cifsmount, transmission, p910nd (servidor de impresion), servidor samba, pure-ftpd (servidor de ftp), wol, screen, swap-utils, etc.

No he podido probarla, ya que tengo el router 'prestado'. Si alguien quiere testearla ...  ^-^

La versión para routers con 8 megas de flash: aquí

Edito: debido al problema detectado con el interface wifi borro la descarga (un par de post más adelante pongo el nuevo firmware).
« Última modificación: 09-04-2014, 08:59 (Miércoles) por jar229 »
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

casidi22

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #545 en: 08-04-2014, 18:06 (Martes) »
Nueva compilación  ;)

r40398
LuCi, soporte para discos usb en formato ntfs, vfat y ext2-3-4, cifsmount, transmission, p910nd (servidor de impresion), servidor samba, pure-ftpd (servidor de ftp), wol, screen, swap-utils, etc.

No he podido probarla, ya que tengo el router 'prestado'. Si alguien quiere testearla ...  ^-^

La versión para routers con 8 megas de flash: aquí

Buenas jar229, hacia tiempo que no posteaba por aqui, lo he probado por encima y por lo pronto el wifi no aparece por ningun lado de luci. Impresion samba y transmission y soporte para discos usb estan operativos. Lo he mirado por encima y todo el resto parece funcionar.  ;)
Por si te vale de algo.

Código: [Seleccionar]
============================================
Ralink UBoot Version: 3.3 Alpha
--------------------------------------------
ASIC 3052_MP2 (Port5<->RvMII)
DRAM component: 128 Mbits SDR
DRAM bus: 32 bit
Total memory: 32 MBytes
Flash component: SPI Flash
Date:Mar 16 2011  Time:18:01:52
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:128, ways:4, linesz:32 ,total:16384
## Powering down port 0 ~ 4.

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   9: Load Boot Loader code then write to Flash via TFTP.                     0

3: System Boot system code via Flash.
## Booting image at bf050000 ...
## Booting image from active region 1 at bf050000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.34
   Created:      2014-04-08   8:19:48 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    995326 Bytes = 972 kB
   Load Address: 80000000
   Entry Point:  80000000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.10.34 (jar@jar-virtual-machine) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.01 r40422) ) #1 Tue Apr 8 10:19:28 CEST 2014
[    0.000000] SoC Type: Ralink RT3052 id:1 rev:3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0001964c (MIPS 24KEc)
[    0.000000] MIPS: machine is Alpha ASL26555
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00025019
[    0.000000] Readback ErrCtl register=00025019
[    0.000000] Memory: 29352k/32768k available (2167k kernel code, 3416k reserved, 550k data, 160k init, 0k highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 384MHz
[    0.000000] Calibrating delay loop... 255.59 BogoMIPS (lpj=1277952)
[    0.070000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] pinctrl core: initialized pinctrl subsystem
[    0.100000] NET: Registered protocol family 16
[    0.140000] bio: create slab <bio-0> at 0
[    0.150000] rt2880_gpio 10000600.gpio: registering 24 gpios
[    0.160000] rt2880_gpio 10000600.gpio: registering 24 irq handlers
[    0.170000] Switching to clocksource MIPS
[    0.180000] NET: Registered protocol family 2
[    0.190000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    0.210000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    0.220000] TCP: Hash tables configured (established 512 bind 512)
[    0.230000] TCP: reno registered
[    0.240000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.250000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.260000] NET: Registered protocol family 1
[    0.270000] rt-timer 10000100.timer: maximum frequncy is 7812Hz
[    0.320000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.330000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.350000] msgmni has been set to 57
[    0.360000] io scheduler noop registered
[    0.370000] io scheduler deadline registered (default)
[    0.380000] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    0.400000] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20) is a 16550A
[    0.410000] console [ttyS0] enabled, bootconsole disabled
[    0.410000] console [ttyS0] enabled, bootconsole disabled
[    0.440000] m25p80 spi32766.0: s25sl12801 (16384 Kbytes)
[    0.460000] 7 ofpart partitions found on MTD device spi32766.0
[    0.470000] Creating 7 MTD partitions on "spi32766.0":
[    0.480000] 0x000000000000-0x000000030000 : "uboot"
[    0.490000] 0x000000030000-0x000000040000 : "uboot-env"
[    0.500000] 0x000000040000-0x000000050000 : "factory"
[    0.520000] 0x000000050000-0x000000fd0000 : "firmware"
[    0.530000] 0x00000014303e-0x000000fd0000 : "rootfs"
[    0.540000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.570000] mtd: device 4 (rootfs) set to be root filesystem
[    0.580000] mtd: partition "rootfs_data" created automatically, ofs=0x630000, len=0x9a0000
[    0.600000] 0x000000630000-0x000000fd0000 : "rootfs_data"
[    0.610000] 0x000000fd0000-0x000000fe0000 : "cert"
[    0.630000] 0x000000fe0000-0x000000ff0000 : "langpack"
[    0.640000] 0x000000ff0000-0x000001000000 : "devdata"
[    0.660000] eth0: done loading
[    0.670000] rt2880_wdt 10000120.watchdog: Initialized
[    0.680000] TCP: cubic registered
[    0.690000] NET: Registered protocol family 17
[    0.700000] 8021q: 802.1Q VLAN Support v1.8
[    0.720000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    0.740000] Freeing unused kernel memory: 160K (802a8000 - 802d0000)
procd: Console is alive
procd: - watchdog -
procd: - preinit -
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[    9.430000] usbcore: registered new interface driver usbfs
[    9.440000] usbcore: registered new interface driver hub
[    9.450000] usbcore: registered new device driver usb
[    9.560000] SCSI subsystem initialized
[    9.580000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    9.600000] ehci-platform: EHCI generic platform driver
[    9.610000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    9.630000] dwc_otg: version 2.72a 24-JUN-2008
[    9.640000] dwc_otg: Core Release: 2.66a
[    9.850000] dwc_otg: Periodic Transfer Interrupt Enhancement - disabled
[    9.870000] dwc_otg: Multiprocessor Interrupt Enhancement - disabled
[    9.880000] dwc_otg: Using DMA mode
[    9.890000] dwc_otg: Device using Buffer DMA mode
[    9.890000] dwc_otg 101c0000.otg: DWC OTG Controller
[    9.900000] dwc_otg 101c0000.otg: new USB bus registered, assigned bus number 1
[    9.920000] dwc_otg 101c0000.otg: irq 26, io mem 0x101c0000
[    9.930000] dwc_otg: Init: Port Power? op_state=1
[    9.940000] dwc_otg: Init: Power Port (0)
[    9.950000] hub 1-0:1.0: USB hub found
[    9.960000] hub 1-0:1.0: 1 port detected
[    9.970000] leds-gpio gpio-leds.4: pins are not configured from the driver
[   10.000000] usbcore: registered new interface driver usb-storage
jffs2 is ready
[   11.040000] jffs2: notice: (320) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 15 of xref (0 dead, 2 orphan) found.
switching to jffs2
procd: - early -
procd: - watchdog -
procd: - ubus -
procd: - init -
Please press Enter to activate this console.
[   15.880000] NET: Registered protocol family 10
[   15.950000] nf_conntrack version 0.5.0 (461 buckets, 1844 max)
[   15.980000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   16.030000] fuse init (API version 7.22)
[   16.040000] Loading modules backported from Linux version master-2014-03-31-1-0-g5c109d2
[   16.060000] Backport generated by backports.git backports-20140221-0-g8e94650
[   16.080000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   16.130000] usbcore: registered new interface driver ums-alauda
[   16.150000] usbcore: registered new interface driver ums-cypress
[   16.160000] usbcore: registered new interface driver ums-datafab
[   16.180000] usbcore: registered new interface driver ums-freecom
[   16.200000] usbcore: registered new interface driver ums-isd200
[   16.210000] usbcore: registered new interface driver ums-jumpshot
[   16.230000] usbcore: registered new interface driver ums-karma
[   16.250000] usbcore: registered new interface driver ums-sddr09
[   16.260000] usbcore: registered new interface driver ums-sddr55
[   16.280000] usbcore: registered new interface driver ums-usbat
[   16.300000] usbcore: registered new interface driver usblp
[   16.340000] xt_time: kernel timezone is -0000
[   16.450000] cfg80211: Calling CRDA to update world regulatory domain
[   16.470000] cfg80211: World regulatory domain updated:
[   16.480000] cfg80211:  DFS Master region: unset
[   16.480000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   16.500000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   16.520000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   16.540000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   16.550000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   16.570000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   16.590000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   16.640000] PPP generic driver version 2.4.2
[   16.650000] NET: Registered protocol family 24
[   16.710000] rt2800_wmac 10180000.wmac: failed to load eeprom property
[   16.720000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'soc_wmac.eeprom'.
procd: Could not find firmware /lib/firmware/soc_wmac.eeprom
[   76.960000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Error - Failed to request EEPROM.
[   76.970000] rt2800_wmac: probe of 10180000.wmac failed with error -2
[   87.240000] device eth0.1 entered promiscuous mode
[   87.250000] device eth0 entered promiscuous mode
[   87.270000] br-lan: port 1(eth0.1) entered forwarding state
[   87.280000] br-lan: port 1(eth0.1) entered forwarding state
[   88.240000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   89.280000] br-lan: port 1(eth0.1) entered forwarding state
procd: - init complete -



BusyBox v1.19.4 (2014-04-08 09:53:26 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (Bleeding Edge, r40422)
 -----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
 -----------------------------------------------------
root@OpenWrt:/#
« Última modificación: 08-04-2014, 23:42 (Martes) por Noltari »

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #546 en: 08-04-2014, 23:41 (Martes) »
Buenas jar229, hacia tiempo que no posteaba por aqui, lo he probado por encima y por lo pronto el wifi no aparece por ningun lado de luci. Impresion samba y transmission y soporte para discos usb estan operativos. Lo he mirado por encima y todo el resto parece funcionar.  ;)
Es lo que tiene trunk:
https://dev.openwrt.org/changeset/40426
https://dev.openwrt.org/ticket/15496

Os toca volver a compilar con la versión más reciente.

Saludos!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #547 en: 09-04-2014, 09:03 (Miércoles) »


Buenas jar229, hacia tiempo que no posteaba por aqui, lo he probado por encima y por lo pronto el wifi no aparece por ningun lado de luci. Impresion samba y transmission y soporte para discos usb estan operativos. Lo he mirado por encima y todo el resto parece funcionar.  ;)


Gracias por probarlo.
Como se puede ver en el log (y luego ha confirmado Noltari) es un problema al intentar cargar la eeprom del wifi.

Es lo que tiene trunk:
https://dev.openwrt.org/changeset/40426
https://dev.openwrt.org/ticket/15496

Os toca volver a compilar con la versión más reciente.

Saludos!

Gracias por avisar. Me pongo a compilar de nuevo (tras actualizar las fuentes) y en un rato cuelgo un firmware con el problema corregido  ;)
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #548 en: 09-04-2014, 09:58 (Miércoles) »
Nueva compilación  ;)

r40432
LuCi, soporte para discos usb en formato ntfs, vfat y ext2-3-4, cifsmount, transmission, p910nd (servidor de impresion), servidor samba, pure-ftpd (servidor de ftp), wol, screen, swap-utils, etc.

No he podido probarla, ya que tengo el router 'prestado'. Si alguien quiere testearla ...  ^-^

La versión para routers con 8 megas de flash: aquí
« Última modificación: 11-04-2014, 18:58 (Viernes) por jar229 »
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2075
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #549 en: 10-04-2014, 11:50 (Jueves) »
Por lo que estoy probando, parece que va bien, pero LuCi no escanea redes...  :-\

Para escanear redes tengo que meterme en un terminal y hacer:
Código: [Seleccionar]
ifconfig wlan0 up
iw wlan0 scan

Y esto me devuelve el escaneo de redes, aunque no sea tan "amigable" como LuCi..., pero se ven más datos...  ;D

EDITO: La compilación del post anterior de jar229 es la 40432 y no 40398 como pone...
« Última modificación: 10-04-2014, 12:56 (Jueves) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

GLaDOS

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #550 en: 10-04-2014, 18:26 (Jueves) »
Esta tarde-noche podría flashearla y probarlo. Pregunta chorra  :-[. Entiendo se recompila para actualizar los paquetes ¿No? ¿Esto se refiere a herrmientas instalables o también por ejemplo Kernel, Drivers, OpenWRT etc?

baumann

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #551 en: 10-04-2014, 23:06 (Jueves) »
Nueva compilación  ;)

r40398
LuCi, soporte para discos usb en formato ntfs, vfat y ext2-3-4, cifsmount, transmission, p910nd (servidor de impresion), servidor samba, pure-ftpd (servidor de ftp), wol, screen, swap-utils, etc.

No he podido probarla, ya que tengo el router 'prestado'. Si alguien quiere testearla ...  ^-^

La versión para routers con 8 megas de flash: aquí


Con mucho gusto :D Yo intenté la semana pasada compilar uno propio sobre una máquina virtual, y al hacer un make entró en una especie de bucle que se comió los 6 GB de disco en 45 minutos... ¿Tanto tarda, y tanto ocupa para hacer un ficherito de 6 mb?

La compilación parece funcionar estupendásticamente bien

Código: [Seleccionar]
BusyBox v1.19.4 (2014-04-09 09:24:36 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (Bleeding Edge, r40432)
 -----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
 -----------------------------------------------------
root@OpenWrt:~#

Respecto al fallo de la WIFI, aporto mi granito de arena, a través de Lua, al hacer scan, la página web deja de cargar al instante, no como en el resto de routers, si bien comenta Tki2000 tiene que forzar a que levante el interfaz wlan0, ¿el interfaz viene en shutdown por defecto?


Si necesitais algún tipo de log acerca del router, comentarlo.

1saludo!

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2075
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #552 en: 11-04-2014, 09:06 (Viernes) »
Respecto al fallo de la WIFI, aporto mi granito de arena, a través de Lua, al hacer scan, la página web deja de cargar al instante, no como en el resto de routers, si bien comenta Tki2000 tiene que forzar a que levante el interfaz wlan0, ¿el interfaz viene en shutdown por defecto?

Pues no lo sé porque no me fijé antes de cepillármela. Para ver si era un fallo como del que se ha hablado en el foro que se soluciona borrando la interfaz y volviéndola a crear, eso fue lo que hice directamente al ver que no escaneaba. El caso es que bajo LuCi sin hacer el "ifconfig wlan0 up", funciona bien la wifi y se puede configurar y activar, pero no escanea. Visto esto pasé a la línea de comandos e "iw" se quejaba de que la interfaz no estaba levantada, así que la levanté manualmente y ya funcionó el scan... El que no funcionara "iw" a la primera puede ser debido a que antes me había cepillado la interfaz para volver a crearla, no sé... Incluso después de levantar el interfaz LuCi no escanea.

Lo que me parece llamativo es que la página de scan de LuCi llama a la rutina con un argumento que es "radio0", y sin embargo al hacer scan manualmente utilizo "wlan0". Desconozco el método de escaneo por lua de LuCi, así que no sé cómo llama al procedimiento de scan ni con qué argumentos y tampoco conozco cómo parsea los resultados. También probé a cambiar manualmente el argumento de "radio0" a "wlan0" y el resultado fue el mismo... A mí me hace que LuCi está llamando a algún procedimiento que o bien no existe o no devuelve los datos como se espera y por eso sale la página en blanco...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

quetzalin

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #553 en: 11-04-2014, 12:50 (Viernes) »
Hola,

He compilado mi propio OpenWRT para este router, mi idea es utilizarlo como repetidor WiFi (con WDS a poder ser) de otro router que tambien tiene openwrt (WR1043ND) pero no consigo que se conecte tan siquiera como cliente (ya no digo cliente WDS), ¿algun paquete que se me olvida a la hora de compilar?.

Como AP sin mas funciona...

Por cierto, a mi el scaneo de Wifis por LuCi si que me funciona (Barrier breaker r40449)

Edit: Vale, solucionado, culpa mia, el WR1043ND no tenia OpenWrt y por eso no enganchaba el WDS, le he puesto OpenWrt y enganchan por WDS sin problema, incluso aunque los chipset wifi sean diferentes (el del 1043ND es un atheros). El ASL26555 funciona como repetidor wifi a las mil maravillas  ;D  ;D

Si alguien quiere mi compilacion que me lo diga, es una compilacion pelada solo pensada para hacer de repetidor con lo que trae el router (solo le he añadido LuCi y el editor nano, ni drivers para dispositivos USB ni nada mas).
« Última modificación: 11-04-2014, 13:55 (Viernes) por quetzalin »

GLaDOS

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #554 en: 11-04-2014, 17:39 (Viernes) »
Nueva compilación  ;)

r40398
LuCi, soporte para discos usb en formato ntfs, vfat y ext2-3-4, cifsmount, transmission, p910nd (servidor de impresion), servidor samba, pure-ftpd (servidor de ftp), wol, screen, swap-utils, etc.

No he podido probarla, ya que tengo el router 'prestado'. Si alguien quiere testearla ...  ^-^

La versión para routers con 8 megas de flash: aquí


Acabo de flashearla y corre perfecta. Peero me he hecho la picha un lío con una cuestión... Posteas la compilación r40398 aunque la enlazada en mediafire es la r40432.

Esta última es la que tengo corriendo ahora mismo en el ASL, que esta gestionando la red de mi casa detrás de un RTA-01N.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #555 en: 11-04-2014, 19:04 (Viernes) »

Acabo de flashearla y corre perfecta. Peero me he hecho la picha un lío con una cuestión... Posteas la compilación r40398 aunque la enlazada en mediafire es la r40432.

Esta última es la que tengo corriendo ahora mismo en el ASL, que esta gestionando la red de mi casa detrás de un RTA-01N.

Parece que el que se ha liado he sido yo.

Ya he corregido el número de compilación en el post dónde colgué el firmware.

Gracias por el aviso  ;)
Hola,

He compilado mi propio OpenWRT para este router, mi idea es utilizarlo como repetidor WiFi (con WDS a poder ser) de otro router que tambien tiene openwrt (WR1043ND) pero no consigo que se conecte tan siquiera como cliente (ya no digo cliente WDS), ¿algun paquete que se me olvida a la hora de compilar?.

Como AP sin mas funciona...

Por cierto, a mi el scaneo de Wifis por LuCi si que me funciona (Barrier breaker r40449)

Edit: Vale, solucionado, culpa mia, el WR1043ND no tenia OpenWrt y por eso no enganchaba el WDS, le he puesto OpenWrt y enganchan por WDS sin problema, incluso aunque los chipset wifi sean diferentes (el del 1043ND es un atheros). El ASL26555 funciona como repetidor wifi a las mil maravillas  ;D  ;D

Si alguien quiere mi compilacion que me lo diga, es una compilacion pelada solo pensada para hacer de repetidor con lo que trae el router (solo le he añadido LuCi y el editor nano, ni drivers para dispositivos USB ni nada mas).

Pensaba que siendo diferentes chipsets wifi (atheros en el tp-link y ralink en el alpha) un enlace usando WDS no funcionaría ...  ???

Qué cifrado tienes en la configuración WDS ?

Si es WPA ...  >:(
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

quetzalin

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #556 en: 11-04-2014, 22:27 (Viernes) »
Pensaba que siendo diferentes chipsets wifi (atheros en el tp-link y ralink en el alpha) un enlace usando WDS no funcionaría ...  ???

Qué cifrado tienes en la configuración WDS ?

Si es WPA ...  >:(

Pues estan con WPA2-PSK, la verdad tampoco tenia esperanzas por ser diferentes chip wifi pero parece ser que tira mas que sea el mismo firmware que lo otro.

Y tengo otro ASL-26555 que me acaban de dar.

¿Como puedo saber si son de Movistar Chile o España?, a este le meti el flash de 16MB y trago (si, gran fallo mio no haber mirado antes, lo pude haber brickeado), acabo de abrir el nuevo pero donde deberia estar la pegatina con el S/N no hay nada, ¿entiendo entonces que se trata de la version Chilena?.

Gracias!
« Última modificación: 11-04-2014, 22:46 (Viernes) por quetzalin »

GLaDOS

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #557 en: 13-04-2014, 03:31 (Domingo) »
Acabo de 'mudar' la WiFi de casa del 'Observa Telecom RTA01N v2' al ASL-26555.

Yendo a lo bruto y hablando de Ping a central y ancho de banda;

Antes



Ahora


Si estoy usando WiFi, para mí ese Mb arriba o abajo es despreciable. para poner la conexión a tope, tengo el ethernet.
« Última modificación: 13-04-2014, 14:17 (Domingo) por GLaDOS »

quetzalin

  • Visitante
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #558 en: 15-04-2014, 09:46 (Martes) »
Por si le pudiera servir de algo a alguien dejo aqui mi firmware compilado para este router, es para la release r40512 de Barrier Breaker.

Es un firmware pelado solo pensado para usar el router como repetidor / AP. Tiene LuCI (ingles), el editor nano y le he metido soporte para zram y FPU emulation (aunque no sean necesarios).

Para que funcione el escaneo WiFi en LuCi solo tenemos que habilitar y deshabilitar la red WiFi que viene creada por defecto, una vez deshabilitada nos la podemos cargar.

8M (Chile): http://www.mediafire.com/download/xn1aq235b19syq2/r40512.openwrt-ramips-rt305x-asl26555-8M-squashfs-sysupgrade.bin
16M: http://www.mediafire.com/download/e4l66wchvi2vl7k/r40512.openwrt-ramips-rt305x-asl26555-16M-squashfs-sysupgrade.bin

Y tambien dejo el .config que he usado para compilar:

http://www.mediafire.com/view/n7jvpsb0jx09x6s/openwrt-asl26555.config
« Última modificación: 15-04-2014, 09:50 (Martes) por quetzalin »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: [Desarrollo] OpenWrt en routers de Telefónica Home Station ALPHA ASL26555
« Respuesta #559 en: 30-04-2014, 09:16 (Miércoles) »
Nueva compilación  ;)

r40593
LuCi, soporte para discos usb en formato ntfs, vfat y ext2-3-4, cifsmount, transmission, p910nd (servidor de impresion), servidor samba, pure-ftpd (servidor de ftp), wol, screen, swap-utils, amule (han actualizado a la última versión disponible), soporte para varios pinchos wifi usb (chipsets atheros, ralink, realtek, etc.)

El escaneo de redes con LuCi, sigue haciendo el 'tonto'  >:D

He probado el modo repetidor y poco más ...  ^-^
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

//FINAL Y MÁS DOS RESPUESTAS