Autor Tema: [Desarrollo] OpenWrt en Comtrend WAP-5813n  (Leído 340507 veces)

0 Usuarios y 1 Visitante están viendo este tema.

el_sabio_

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #260 en: 18-11-2013, 17:04 (Lunes) »
Imposible de descargar lo hacen ellos me dicen....



Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #261 en: 18-11-2013, 17:26 (Lunes) »
Ah otra pregunta, lo máximo que cojo de señal en mi pc por wifi son hasta 65mbps. El PC lleva una  Atheros AR9285 que supuestamente admite hasta 128MBPS por lo que no oy capaz de haer emitir el wifi a más velocidad...

Alguna sugerencia?
El driver utilizado en el firmware es el propietario (brcm-wl), el problema es que no es la versión actual, sino que es la antigua más reciente de la que se disponen las fuentes.
En las versiones actuales broadcom ya no distribuye el código fuente, sólo binarios que no sirven para nada a no ser que tengas un firmware 90% igual al oficial.
Así que toca tragar con esas velocidades :/...

Saludos.
Hay dos opciones para que la wifi mejore:
1.- Cambiar la miniPCI por otra. Consigues un livebox 2, le robas la wifi, se la pones al comtrend y compilas un firm con soporte para atheros.
2.- Consigues un router con wifi N, le desactivas dhcp y cambias la configuración de la red por, por ejemplo, 192.168.10.1, lo enganchas por cable al comtrend y ya está.

Morax

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #262 en: 19-11-2013, 00:12 (Martes) »

Parece que la configuración está bien.
Seguro que has habilitado el bird4 para que se ejecute y el igmpproxy también?

Saludos.
Hola Noltari. He comprobado que al reiniciar el router aparece desactivado el igmpproxy. Lo activo manualmente desde luci pero sigue sin verse imagenio. Para activarlo lo que he hecho son los comandos del manual:
Código: [Seleccionar]
/etc/init.d/igmpproxy enable
He desisntalado bird4 y igmpproxy y he eliminado los archivos y lo he vuelto a instalar todo pero nada, sigue igual... :(. Veo que estoy casi casi pero nunca lo consigo xD.
« Última modificación: 19-11-2013, 01:46 (Martes) por Morax »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #263 en: 19-11-2013, 10:12 (Martes) »
Código: [Seleccionar]
/etc/init.d/igmpproxy enable hace que ese servicio se active en el siguiente reinicio; para arrancarlo sería
Código: [Seleccionar]
/etc/init.d/igmpproxy startRevisa si todos los archivos de configuración aparecen con el nombre correcto con
Código: [Seleccionar]
ls -R /etc desde telnet o ssh.
En este correo se ve que algunos archivos aparecen renombrados.
Código: [Seleccionar]
/etc/dropbear:
dropbear_dss_host_key  opoparar_dssosost_key
dropbear_rsa_host_key  opopbearsasaososkekey

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #264 en: 19-11-2013, 11:06 (Martes) »
Intenta realizar el proceso íntegro nuevamente pero con un firmware que contenga todos los paquetes necesarios en lugar de instalarlos posteriormente.

Puede que ese sea el problema.

Saludos.

riskel

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #265 en: 20-11-2013, 03:08 (Miércoles) »
Hola aver si me pueden ayudar , le meti satisfactoriamente este firmware ami router de telefonica ese --- >   Movistar FTTH/VOIP + SMP + brcm-wl + luci + luci-app-upnp + luci-app-ddns + swconfig + bird4
r36529_movistar (Autoconfigurado para Movistar FTTH+VOIP)

todo bien pero quise volver a ponerle el de fabrica este lo flaseo  -->

Firmwares oficiales de Movistar (sin bootloader CFE)
WAP-5813n-P401-402TLF-C04_R05 BETA

me sale ke espere ke se esta flaseando okey

y espero un rato y el router no carga se queda con la luz power en rojo por mucho ke intento ke carge no carga no identifica y aunke le asigne una ip de 192.168.1.2 y poniendo puerta de enlace tb y nada se queda colgado, intento resetear poniendo algo fino en el abujerito de atras 30 seg y nada  estoy desesperado pido ayuda porfavor no es ke sea un experto pero algo se  que solucion me dais porfavor gracias

Morax

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #266 en: 20-11-2013, 10:30 (Miércoles) »
Yo me bajé la versión CFE v1.0.37-102.1-5 en lugar de la de sin bootloader.
Aún así, después de cargar el firmware de openWrt se me queda el router como dices, con la luz roja. Solo tengo que acceder de nuevo a 192.168.1.1 y me sale la opción para cargar un firmware. Vuelvo a cargar el de movistar desde ahí y ya funciona todo OK.

Ten cuidado si utilizas Firefox porque a mí me guardaba aún la caché de luci y no podía ver esa web para cargar firmware. Usa cualquier otro navegador o limpia tu sesión.

riskel

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #267 en: 20-11-2013, 13:44 (Miércoles) »
Muchas gracias morax , hize lo que me dijistes , yo uso el chrome  y era que tenia que borrar el historial de cache y le añadi manualmente la ip 192.168.1.2 ala tarjeta de red y logre cargar este  Firmwares oficiales de Movistar (sin bootloader CFE)
WAP-5813n-P401-402TLF-C04_R05 BETA

pero ahora cuando quiero acceder a el pongo de usuario y contraseña   1234 . 1234  y me dice ke no es tb he probado con admin . 1234  ,   user.1234 y ninguna es no me entra en router , navegando por internet poerfectamente con el eso si , aver si alguien sabe ke contraseña es o tu mismo morax gracias compi muy amable

Morax

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #268 en: 20-11-2013, 15:18 (Miércoles) »
Cuando cargas el firmware se vuelve a poner por defecto el portal alejandra. Tendrás que meterte y cambiar la contraseña para poder acceder como antes.

riskel

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #269 en: 20-11-2013, 17:49 (Miércoles) »
muchas gracias denuevo morax ya me di cuenta y valio correctamente , una cosita para movistar ke version de open wrt me recomiendas pq ge visto esa ultima y no trae configuracion de movistar!  solo tengo internet no tengo imagenio  si te sirve de dato.

Morax

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #270 en: 20-11-2013, 22:09 (Miércoles) »
La que viene configurada para FTTH + VOIP funciona de perlas pero si quieres ver imagenio tendrás que configurar cosas adicionales. Aquí tienes el manual:
https://foro.seguridadwireless.net/openwrt/%28tutorial%29-movistar-ftth-con-openwrt/

Difiere un poco con el router de Movistar. Un poco más arriba he puesto unos archivos de configuración que puedes tomar como referencia. Yo no lo llegué a conseguir aún. Cuando pueda me pondré de nuevo. Creo que el problema estaba en la instalación de cierto software en OpenWRT (como bird4 y igmpproxy). Tengo que probar a hacer la configuración desde un firmware limpio.

Suerte y a ver si lo consigues!.

riskel

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #271 en: 21-11-2013, 02:27 (Jueves) »
muchas gracias morax me estas ayudando mucho llebo tiempo fuera del  mundo de la informatica pero  apasiona las redes las configuraciones y trastear y aprender cosas nuevas me gusta tratar con gente como tu muy amable y ayuda en lo ke puede te debo una y por supuesto al creador de este pedazo de firmware  ke sepa ke ha hecho un gran trabajo me encanta el firmw .

Slartibartfast

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #272 en: 24-11-2013, 09:39 (Domingo) »
Difiere un poco con el router de Movistar. Un poco más arriba he puesto unos archivos de configuración que puedes tomar como referencia. Yo no lo llegué a conseguir aún. Cuando pueda me pondré de nuevo. Creo que el problema estaba en la instalación de cierto software en OpenWRT (como bird4 y igmpproxy). Tengo que probar a hacer la configuración desde un firmware limpio.

He probado tu configuración con una compilación limpia e Imagenio funciona perfectamente. Lo que no he conseguido es que me funcione la WiFi (los clientes obtienen una dirección IP, pero no se conectan a internet) Voy a trastear un poco más, porque seguro que he metido la pata, pero tiene muy buena pinta.

Slartibartfast

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #273 en: 27-11-2013, 00:11 (Miércoles) »
Los problemas de la WiFi resultaron ser por inundación de paquetes multicast. Activando el IGMP snooping (instalando el paquete kmod-bridge y añadiendo esto a /etc/rc.local):

Código: [Seleccionar]
echo "1" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping
problema resuelto :)

¡Excelente trabajo, Noltari!

riskel

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #274 en: 27-11-2013, 03:11 (Miércoles) »
hola buenas noches me gustaria saber como puedo abrir un rango de puertos por ejemplo  el udp  desde el 5000 al 5200 , no de 1 en 1 o poder dejarlos todos abiertos para poder jugar alos juegos online ? gracias

Mikeltb

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #275 en: 27-11-2013, 12:28 (Miércoles) »
Buenas...

Con ayuda de Jav ya veo canales de imagenio con direccones 192.x.x.x /24.
Me faltaba configurar el fichero igmpproxy:

Código: [Seleccionar]
config igmpproxy
option quickleave 1

config phyint
option network iptv
option direction upstream
list altnet 172.0.0.0/8

config phyint
option network lan
option direction downstream
list altnet 192.168.1.0/24
list altnet 10.xxx.xxx.0/24

Despues por ssh:

Código: [Seleccionar]
/etc/init.d/igmpproxy enable
/etc/init.d/igmpproxy start

Gracias Jav!!!


Lo que me ocurre ahora es muy muy curioso. Cuando reproduzco un canal de imagenio, por ejemplo rtp://239.0.0.0.3:8208 por vlc o XBMC (modulo y ADD-ON IPNA) , a los 4 min 30 seg se corta teniendo que abrir de nuevo el medio.

¿Alguna idea de por qué puede ser?

Nota: He probado con el firmware de telefonica y no me ocurre.
El deco no se corta y ninguno de los casos.


« Última modificación: 27-11-2013, 12:36 (Miércoles) por Mikeltb »

Mikeltb

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #276 en: 28-11-2013, 02:00 (Jueves) »
Bueno, aquí seguimos, con casi las dos de la mañana y en 5 horas toca diana..... :-[

Esto se sigue cortando a los 4 minutos y medio...
Una cosa que me he dado cuenta... es que el igmpproxy de /etc/init.d se llama igmpoxoxy, no se si eso esta bien pero desde luego no es el nombre correcto, no obstante dentro de dicho fichero parece estar todo correcto.

Una vez que se corta en el VLC el canal de imagenio  que estoy viendo si ejecuto en el ssh el siguiente comando:

Código: [Seleccionar]
/etc/init.d/igmppxoxy restart
vuelvo a visualizar el canal

¿hay alguna forma que el poxoxy se ejecute cada 4 minutos ??   ;D


Mikeltb

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #277 en: 28-11-2013, 12:13 (Jueves) »
Siguiendo con mis investigaciones, la mayoria sin sentido por falta de conocimientos...  hay un comando para el igmpproxy desde un terminal SSH

Código: [Seleccionar]
/etc/init.d/igmpproxy -d /etc/igmpproxy.conf -v -v
me devuelve estas trazas que no se interpretar y puede que alguno de vosotros pueda identificar que mi problema este aqui, copio un trozo que se esta repitiendo continuamente:

Código: [Seleccionar]
RECV V2 member report   from 192.168.1.22    to 239.0.0.3
Should insert group 239.0.0.3 (from: 192.168.1.22) to route table. Vif Ix : 0
Updated route entry for 239.0.0.3 on VIF #0

Current routing table (Insert Route):
-----------------------------------------------------
#0: Src: 0.0.0.0, Dst: 239.0.0.3, Age:2, St: I, OutVifs: 0x00000001
#1: Src: 0.0.0.0, Dst: 239.0.0.77, Age:1, St: I, OutVifs: 0x00000001
#2: Src: 0.0.0.0, Dst: 239.0.2.2, Age:2, St: I, OutVifs: 0x00000001
#3: Src: 0.0.0.0, Dst: 239.0.2.30, Age:2, St: I, OutVifs: 0x00000001
#4: Src: 0.0.0.0, Dst: 239.0.2.129, Age:2, St: I, OutVifs: 0x00000001
#5: Src: 0.0.0.0, Dst: 239.0.2.169, Age:2, St: I, OutVifs: 0x00000001
#6: Src: 0.0.0.0, Dst: 239.255.255.250, Age:2, St: I, OutVifs: 0x00000001
-----------------------------------------------------
The source address 172.xx.xx.1 for group 239.0.0.3, is not in any valid net for upstream VIF.
The source address 192.168.1.169 for group 239.255.255.250, is not in any valid net for upstream VIF.
The source address 172.xx.xx.58 for group 239.0.0.77, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.2, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.30, is not in any valid net for upstream VIF.
The source address 192.168.1.10 for group 239.255.250.250, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.169, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.129, is not in any valid net for upstream VIF.
The source address 172.xx.xx.1 for group 239.0.0.3, is not in any valid net for upstream VIF.
The source address 172.xx.xx.58 for group 239.0.0.77, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.2, is not in any valid net for upstream VIF.
The source address 192.168.1.169 for group 239.255.255.250, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.30, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.169, is not in any valid net for upstream VIF.
The source address 192.168.1.10 for group 239.255.255.250, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.129, is not in any valid net for upstream VIF.
The source address 172.xx.xx.1 for group 239.0.0.3, is not in any valid net for upstream VIF.
The source address 172.xx.xx.58 for group 239.0.0.77, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.2, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.30, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.169, is not in any valid net for upstream VIF.
The source address 192.168.1.169 for group 239.255.255.250, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.129, is not in any valid net for upstream VIF.
The source address 172.xx.xx.1 for group 239.0.0.3, is not in any valid net for upstream VIF.
The source address 172.xx.xx.58 for group 239.0.0.77, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.2, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.30, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.169, is not in any valid net for upstream VIF.
The source address 192.168.1.169 for group 239.255.255.250, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.129, is not in any valid net for upstream VIF.
The source address 172.xx.xx.1 for group 239.0.0.3, is not in any valid net for upstream VIF.
The source address 172.xx.xx.58 for group 239.0.0.77, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.2, is not in any valid net for upstream VIF.
The source address 172.xx.xx.39 for group 239.0.2.30, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.169, is not in any valid net for upstream VIF.
The source address 192.168.1.10 for group 239.255.255.250, is not in any valid net for upstream VIF.
The source address 192.168.1.10 for group 239.255.250.250, is not in any valid net for upstream VIF.
The source address 192.168.1.169 for group 239.255.255.250, is not in any valid net for upstream VIF.
The source address 172.xx.xx.41 for group 239.0.2.129, is not in any valid net for upstream VIF.
RECV V2 member report   from 192.168.1.169   to 239.0.2.129
Should insert group 239.0.2.129 (from: 192.168.1.169) to route table. Vif Ix : 0
Updated route entry for 239.0.2.129 on VIF #0


saludos... Mikel.



Mikeltb

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #278 en: 28-11-2013, 18:21 (Jueves) »
Pues ya lo tengo funcionando  y gracias y a todos los que habeis colaborado en este foro al que he llegado tarde.  >:( >:( >:( >:( >:(
¿Qué era, como lo he solucionado?, mi profesor de matemáticas de EGB  siempre decía que si un problema no te sale, vuelve a comenzarlo de nuevo.
Y así he hecho, he cogido el firmware del comienzo de este post publicado por Noltari y seguido todos los pasos de nuevo y funcionando!!!!!

Me queda la openvpn que ya la tenia funcionando de anteriores.

Un saludo.

jfromeo

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #279 en: 28-11-2013, 23:38 (Jueves) »
Una pregunta, Noltari.

Tengo Movistar FTTH+VoIP 100MB/10MB, y veo que hay una versión OpenWRT más nueva (r37180) y otra autoconfigurada para Movistar más antigua (r36529).

¿Podría meterla la r37180 y luego configurarla para Movistar FTTH+VoIP? Si es así, ¿Dónde puedo leer información sobre qué valores tendría que modificar?

Gracias por adelantado!

EDIT: He visto este magnífico tutorial tuyo, creo que me autorespondo:

https://dl.dropboxusercontent.com/u/4708147/seguridadwireless/tutorial_movistar_ftth_openwrt_luci/Movistar_FTTH_OpenWrt.pdf

Ahora la pregunta es, ¿Recomiendas personalmente meter la última revisión OpenWRT y modificarla para FTTH+VoIP?
« Última modificación: 28-11-2013, 23:41 (Jueves) por jfromeo »