Autor Tema: [Desarrollo] OpenWrt en Comtrend WAP-5813n  (Leído 340508 veces)

0 Usuarios y 1 Visitante están viendo este tema.

MaxSGWL

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #240 en: 02-10-2013, 12:15 (Miércoles) »
Trabajo de Fin de Grado y he aprobado ;D.
[/quote]

¡¡¡Enhorabuena!!!



eltrasimaco

  • Visitante
No me tira internet
« Respuesta #241 en: 02-10-2013, 16:54 (Miércoles) »
Hola!
He metido el openwrt en mi 5813n, funciona todo al 100% incluyendo Luci, lo queria poner como bridge del ruter que saca adsl (otro comtrend de jazztel); el caso que le pongo a capón la 192.168.1.2 , lo asocio correctamente al otro router (el de adsl 192.168.1.1) , le quito el firewall y no solo no me tira la internet sino que tampoco me hace el ping a la 192.168.1.1 ¿?
lo he hecho a la mano desde la consola y tambien desde luci sin resultado
no entiendo nada!!  :-[ alguna ayudita? gracias!

trofin

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #242 en: 03-10-2013, 16:39 (Jueves) »
Hola a todos,

Lo primero agradecer a Noltari y al resto de la gente su esfuerzo.

Llevo varias semanas leyendo este foro y buscando soluciones a algunos de los problemillas que se me van presentado.
Compré un router de segunda mano por 10€ para trastear un poco, le cambié la tarjeta de red wifi por una atheros y me compilé el openwrt usando git clone git://github.com/Noltari/openwrt.git -b bcm63xx-r37180.

Todo funciona ok, excepto lo siguiente:

El tema es que cuando intento instalar cualquier paquete como por ejemplo openvpn-openssl me dice lo siguiente:
----
root@OpenWrt:~# opkg install openvpn-openssl
Installing openvpn-openssl (2.3.2-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/openvpn-openssl_2.3.2-1_brcm63xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-openssl:
 *      kernel (= 3.10.13-1-390efcbbd19beac68409c2dd1bc95a1c) *
 * opkg_install_cmd: Cannot install package openvpn-openssl.
----

He leído que es un tema de diferencias en el kernel, pero no sé cómo podría solucionarlo. ¿Alguien me podría echar un cable?

Por otra parte también quiero modificar la tabla ARP para que una entrada sea estática y poder hacer Wol On Wan y no soy capaz de ninguna de las siguientes maneras:

arp -s hostname ether_addr

ip neigh add 192.168.1.2    lladdr 00:de:ad:be:ef:00  nud permanent   dev br0
-ash: ip: not found

¿Sabéis alguna otra forma de añadir una entrada estática?

EDITO:
-----------------------------
Acabo de encontrar la solución al problema con el comando ip:
No tenía instalado el comando y por eso no funcionaba.

opkg update
opkg install ip

Asunto resuelto, ya he podido poner la entrada como estática en la tabla ARP
----------------------------------


Os agradecería cualquier ayuda porque ando perdido con esto...

Gracias a todos.





« Última modificación: 03-10-2013, 16:51 (Jueves) por trofin »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #243 en: 03-10-2013, 18:16 (Jueves) »
El tema de las dependencias con el kernel lo tienes explicado en el hilo de las FAQ.

Enviado desde mi CUBOT GT99 usando Tapatalk

PortDisaster

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #244 en: 08-10-2013, 14:17 (Martes) »
Con esto funciona de maravilla, la unica pega el wifi, con el firmware original me llegaban a mi salon 22mb y con este 18, baja un poco la velocidad wifi aunque el alcance es bueno, no obstante voy a hacer varias pruebas para encontrar la configuración óptima...a ver si se peude mejorar y ya lo bordamos  ;D
Si no recuerdo mal, en este router la wifi va en una tarjeta miniPCI. Cámbiala por una con chip Atheros o Ralink y ya volverás a tener wifi N. Con el Comtrend VR-3025un le puse la miniPCI de un livebox 2 y cero problemas, además de mayor velocidad y algo más de cobertura. Por supuesto, hay que cargar o compilar los drivers ath9k.

Precisamente tengo un Livebox 2 de Orange cogiendo polvo en un cajon por una portabilidad-estafa de Orange  que tras varios meses no se han dignado en recoger :D

Me podrías dar mas pistas de como instalar los nuevos drivers de la tarjeta Atheros?

Segun esta pagina http://wiki.openwrt.org/es/toh/sagem/livebox.2 la tarjeta miniPCI es una Atheros AR9223 802.11b/g/n

Se pueden instalar con el comando opkg? Estoy un poco pez en linux aunque gracias a una raspberry y ahora el router poco a poco voy recordando cosas...
« Última modificación: 08-10-2013, 14:21 (Martes) por PortDisaster »

eltrasimaco

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #245 en: 12-10-2013, 20:09 (Sábado) »
nadie?  :-[

Pteridium

  • Visitante
Re: No me tira internet
« Respuesta #246 en: 12-10-2013, 20:30 (Sábado) »
Hola!
He metido el openwrt en mi 5813n, funciona todo al 100% incluyendo Luci, lo queria poner como bridge del ruter que saca adsl (otro comtrend de jazztel); el caso que le pongo a capón la 192.168.1.2 , lo asocio correctamente al otro router (el de adsl 192.168.1.1) , le quito el firewall y no solo no me tira la internet sino que tampoco me hace el ping a la 192.168.1.1 ¿?
lo he hecho a la mano desde la consola y tambien desde luci sin resultado
no entiendo nada!!  :-[ alguna ayudita? gracias!
nadie?  :-[
Apenas has explicado lo que está haciendo, con lo que difícilmente alguien te podrá ayudar. De todas formas... ¿por qué desactivas el firewall? Sin él no puede enrutar y es lógico que no te funcione internet.  ???

mediocaballero

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #247 en: 07-11-2013, 00:01 (Jueves) »
Hola!

Me he registrado para dar las gracias a Noltari por el grandísimo trabajo.
Esta es mi primera incursión en el mundo de los firmares abiertos para el routet y, gracias a él, ha sido un paseo :-)

Ahora, pregunta de novato... He instalado la versión con el tagging preconfigurado para FTTH de Movistar... ¿cómo actualizo a la versión más reciente? ¿tengo que instalar el paquete base-files más nuevo directamente?

Graciasss!

mediocaballero

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #248 en: 09-11-2013, 00:53 (Sábado) »
Pues me he encontrado con el mismo problema que comentaban algunos compis en este mismo hilo... Si instalo lo que sea, al reiniciar, me ha desaparecido :-m

¿Alguno llegó a solucionarlo?

Morax

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #249 en: 17-11-2013, 18:26 (Domingo) »
Me gustaría agradecer a Noltari el curro de firmware que ha hecho. Estaba desesperado con el maldito firmware de Movistar que no me dejaba abrir puertos ni hacer absolutamente nada y no podía jugar online decentemente.

El firmware para FTTH es instalar y funcionar! ¡Una auténtica maravilla!

Sin embargo, no he conseguido hacer funcionar Movistar TV con el manual. Cuando añado la VLAN 2 pierdo internet... Por lo visto, revisando el firmware preconfigurado y el manual pdf para imagenio, me he dado cuenta de que en este router no coinciden los puertos físicos con lo que se indica en el manual. He intentado solucionarlo cambiando los puertos en el archivo network de '0t 1t' a '4t 5t', pero el resultado es el mismo: pierdo internet y el acceso al router por cable (por wifi sí puedo).

Realmente es un mal menor, Movistar Tv me lo pusieron gratis hace poco, y prefiero tener un internet decente a la TV y con internet capado, pero ya funcionando las dos cosas sería brutal.

No sé qué estaré haciendo mal. Si se os ocurre algo... y si no, ¡espero impaciente un nuevo firmware preconfigurado para imagenio! Noltari tienes todo mi apoyo y agradecimiento! Seguid así!

el_sabio_

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #250 en: 18-11-2013, 02:11 (Lunes) »
Excelente firmware. Funciona genial.

Yo no consigo abrir los puertos, quiero abrir un puerto por ejmplo 6050 en TCP y UDP, como lo hago?
Me voy a Firewall - Port Forwards

Y cuando los doy de alta me sale una cosa así:
IPv4-TCP
From any host in lan
Via any router IP at port 6050

IPv4-UDP
From any host in lan
Via any router IP at port 6050

Qué hago mal?

Gracias de antemano.

el_sabio_

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #251 en: 18-11-2013, 02:18 (Lunes) »
Ah otra pregunta, lo máximo que cojo de señal en mi pc por wifi son hasta 65mbps. El PC lleva una  Atheros AR9285 que supuestamente admite hasta 128MBPS por lo que no oy capaz de haer emitir el wifi a más velocidad...

Alguna sugerencia?

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #252 en: 18-11-2013, 10:51 (Lunes) »
Excelente firmware. Funciona genial.

Yo no consigo abrir los puertos, quiero abrir un puerto por ejmplo 6050 en TCP y UDP, como lo hago?
Me voy a Firewall - Port Forwards

Y cuando los doy de alta me sale una cosa así:
IPv4-TCP
From any host in lan
Via any router IP at port 6050

IPv4-UDP
From any host in lan
Via any router IP at port 6050

Qué hago mal?

Gracias de antemano.
Network->Firewall->Port Forwards
Código: [Seleccionar]
Name: Lo que quieras
Protocol: TCP+UDP
External zone: wan
External port: 6050
Internal zone: lan
Internal IP address: 192.168.1.x (la IP del dispositivo al que abres el puerto)
Internal port: 6050
Después pulsas Add, esperas a que cargue la página y, por último, le das a Save & Apply.
Cuando acabe de modificar los ficheros ya debería funcionar.

Ah otra pregunta, lo máximo que cojo de señal en mi pc por wifi son hasta 65mbps. El PC lleva una  Atheros AR9285 que supuestamente admite hasta 128MBPS por lo que no oy capaz de haer emitir el wifi a más velocidad...

Alguna sugerencia?
El driver utilizado en el firmware es el propietario (brcm-wl), el problema es que no es la versión actual, sino que es la antigua más reciente de la que se disponen las fuentes.
En las versiones actuales broadcom ya no distribuye el código fuente, sólo binarios que no sirven para nada a no ser que tengas un firmware 90% igual al oficial.
Así que toca tragar con esas velocidades :/...

Saludos.

Morax

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #253 en: 18-11-2013, 16:24 (Lunes) »
¡He conseguido añadir bien las VLAN! Creo que en el manual está incorrecto porque en un principio se indica que las ID deben ser 1, 2, 3 y 6 pero luego se declaran como 1, 2, 4 y 6. Y por eso es por lo que creo que perdía internet al configurarlo.

Sin embargo, sigo sin poder ver imagenio. Voy a publicar aquí mis archivos, a ver si se os ocurre qué es lo que puede fallar. (Tengo el comtrend de telefónica de FTTH y como dije antes, los puertos están cambiados con respecto a lo que se especifica en el manual)

Network:
Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd47:61ab:b9f2::/48'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option proto 'pppoe'
option ifname 'eth0.6'
option username 'adslppp@telefonicanetpa'
option password 'adslppp'

config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '172.26.208.73'
option netmask '255.255.240.0'
option gateway '172.26.208.1'

config 'alias'
option 'interface' 'lan'
option 'proto' 'static'
option ipaddr '10.250.162.57'
option netmask '255.255.255.248'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 1 2 3 5t'
option vid '1'

config switch_vlan
option device 'eth0'
option ports '4t 5t'
option vlan '2'
option vid '2'

config switch_vlan
option device 'eth0'
option ports '4t 5t'
option vlan '3'
option vid '3'

config switch_vlan
option device 'eth0'
option ports '4t 5t'
option vlan '6'
option vid '6'

config interface 'voip'
option proto 'dhcp'
option ifname 'eth0.3'
option defaultroute '0'
option peerdns '0'

Firewall:
Código: [Seleccionar]
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config zone
option name 'iptv'
option input 'ACCEPT'
option output 'ACCEPT'
option network 'iptv'
option forward 'REJECT'

config forwarding
option src 'lan'
option dest 'iptv'

config rule
option name 'IGMP IPTV'
option src 'iptv'
option proto 'igmp'
option target 'ACCEPT'

config rule
option name 'UDP IPTV'
option src 'iptv'
option proto 'udp'
option dest 'lan'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'

config rule
option name 'UDP IPTV (udpxy)'
option src 'iptv'
option proto 'udp'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'
option enabled '0'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config include
option type 'script'
option path '/usr/share/firewall/ipv6-ula-border.sh'
option family 'IPv6'
option reload '1'

config zone
option name 'voip'
option input 'ACCEPT'
option forward 'REJECT'
option output 'ACCEPT'
option network 'voip'
option masq '1'

config forwarding
option dest 'voip'
option src 'lan'

config forwarding
option dest 'wan'
option src 'lan'

config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd/firewall.include'
option family 'IPv4'
option reload '1'

bird4.conf
Código: [Seleccionar]
log syslog all;
protocol kernel {
persist;
scan time 20;
import all;
export all;
}
protocol device {
scan time 10;
}
protocol static {
export none;
}
filter voip_filter {
if net ~ 10.0.0.0/8 then accept;
else reject;
}
protocol rip voip {
import all;
export filter voip_filter;
interface "eth0.3";
}
filter iptv_filter {
if net ~ 172.26.0.0/16 then accept;
else reject;
}
protocol rip iptv {
import all;
export filter iptv_filter;
interface "eth0.2";
}

igmpproxy
Código: [Seleccionar]
config igmpproxy
option quickleave 1

config phyint
option network iptv
option direction upstream
list altnet 192.168.1.0/24
list altnet 172.0.0.0/8

config phyint
option network lan
option direction downstream

Muchas gracias por todo. Sigo intentado cosas y espero poder poner pronto cómo lo solucioné!

el_sabio_

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #254 en: 18-11-2013, 16:30 (Lunes) »
No me lo hace, intento comprobarlo en el escaneador de puertos y me dice CERRADO. Dichoso router...

Lo he hecho así, tal cual:

Código:
Name: Lo que quieras
Protocol: TCP+UDP
External zone: wan
External port: 6050
Internal zone: lan
Internal IP address: 192.168.1.x (la IP del dispositivo al que abres el puerto)
Internal port: 6050


Mi firmware es; OpenWrt Barrera Frenzy r36529 / Luci Trunk (svn-r9812)
Kernel version: 3.8.11

Es el Comtrend de fibra de "MOVISTAR" Lo mismo hice algo mal al meter el firm nose..


Morax

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #255 en: 18-11-2013, 16:35 (Lunes) »
el_sabio, a mí tampoco me los abre de esa manera. Con el firmware de movistar era imposible abrir puertos, ni DMZ ni nada, y el Upnp se desactivaba solo. En cambio ahora el Upnp funciona correctamente y al menos puedo jugar online decentemente y utilizar otras aplicaciones. No puedo abrir puertos individualmente, pero con el Upnp se apaña bastante bien (he comprobado que funcionar funciona). Quizás el router esté capado por hardware y no por software...

el_sabio_

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #256 en: 18-11-2013, 16:38 (Lunes) »
Anda, nuevo firmware de movistar....
Que raro...
P401-402TLF-C04_R07

Habrá que testearlo y modificarlo jaja.
Si encuentro un enlace os lo pongo

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #257 en: 18-11-2013, 16:40 (Lunes) »
¡He conseguido añadir bien las VLAN! Creo que en el manual está incorrecto porque en un principio se indica que las ID deben ser 1, 2, 3 y 6 pero luego se declaran como 1, 2, 4 y 6. Y por eso es por lo que creo que perdía internet al configurarlo.

Sin embargo, sigo sin poder ver imagenio. Voy a publicar aquí mis archivos, a ver si se os ocurre qué es lo que puede fallar. (Tengo el comtrend de telefónica de FTTH y como dije antes, los puertos están cambiados con respecto a lo que se especifica en el manual)

Network:
Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd47:61ab:b9f2::/48'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option proto 'pppoe'
option ifname 'eth0.6'
option username 'adslppp@telefonicanetpa'
option password 'adslppp'

config interface 'iptv'
option proto 'static'
option ifname 'eth0.2'
option ipaddr '172.26.208.73'
option netmask '255.255.240.0'
option gateway '172.26.208.1'

config 'alias'
option 'interface' 'lan'
option 'proto' 'static'
option ipaddr '10.250.162.57'
option netmask '255.255.255.248'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 1 2 3 5t'
option vid '1'

config switch_vlan
option device 'eth0'
option ports '4t 5t'
option vlan '2'
option vid '2'

config switch_vlan
option device 'eth0'
option ports '4t 5t'
option vlan '3'
option vid '3'

config switch_vlan
option device 'eth0'
option ports '4t 5t'
option vlan '6'
option vid '6'

config interface 'voip'
option proto 'dhcp'
option ifname 'eth0.3'
option defaultroute '0'
option peerdns '0'

Firewall:
Código: [Seleccionar]
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config zone
option name 'iptv'
option input 'ACCEPT'
option output 'ACCEPT'
option network 'iptv'
option forward 'REJECT'

config forwarding
option src 'lan'
option dest 'iptv'

config rule
option name 'IGMP IPTV'
option src 'iptv'
option proto 'igmp'
option target 'ACCEPT'

config rule
option name 'UDP IPTV'
option src 'iptv'
option proto 'udp'
option dest 'lan'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'

config rule
option name 'UDP IPTV (udpxy)'
option src 'iptv'
option proto 'udp'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'
option enabled '0'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config include
option type 'script'
option path '/usr/share/firewall/ipv6-ula-border.sh'
option family 'IPv6'
option reload '1'

config zone
option name 'voip'
option input 'ACCEPT'
option forward 'REJECT'
option output 'ACCEPT'
option network 'voip'
option masq '1'

config forwarding
option dest 'voip'
option src 'lan'

config forwarding
option dest 'wan'
option src 'lan'

config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd/firewall.include'
option family 'IPv4'
option reload '1'

bird4.conf
Código: [Seleccionar]
log syslog all;
protocol kernel {
persist;
scan time 20;
import all;
export all;
}
protocol device {
scan time 10;
}
protocol static {
export none;
}
filter voip_filter {
if net ~ 10.0.0.0/8 then accept;
else reject;
}
protocol rip voip {
import all;
export filter voip_filter;
interface "eth0.3";
}
filter iptv_filter {
if net ~ 172.26.0.0/16 then accept;
else reject;
}
protocol rip iptv {
import all;
export filter iptv_filter;
interface "eth0.2";
}

igmpproxy
Código: [Seleccionar]
config igmpproxy
option quickleave 1

config phyint
option network iptv
option direction upstream
list altnet 192.168.1.0/24
list altnet 172.0.0.0/8

config phyint
option network lan
option direction downstream

Muchas gracias por todo. Sigo intentado cosas y espero poder poner pronto cómo lo solucioné!
Parece que la configuración está bien.
Seguro que has habilitado el bird4 para que se ejecute y el igmpproxy también?

Saludos.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #258 en: 18-11-2013, 16:48 (Lunes) »
No me lo hace, intento comprobarlo en el escaneador de puertos y me dice CERRADO. Dichoso router...

Lo he hecho así, tal cual:

Código:
Name: Lo que quieras
Protocol: TCP+UDP
External zone: wan
External port: 6050
Internal zone: lan
Internal IP address: 192.168.1.x (la IP del dispositivo al que abres el puerto)
Internal port: 6050


Mi firmware es; OpenWrt Barrera Frenzy r36529 / Luci Trunk (svn-r9812)
Kernel version: 3.8.11

Es el Comtrend de fibra de "MOVISTAR" Lo mismo hice algo mal al meter el firm nose..


Ojo, que para que un scaner online de puertos diga que está abierto, tiene que existir alguna aplicación con un socket abierto en dicho puerto ejecutándose en dicho momento.

el_sabio, a mí tampoco me los abre de esa manera. Con el firmware de movistar era imposible abrir puertos, ni DMZ ni nada, y el Upnp se desactivaba solo. En cambio ahora el Upnp funciona correctamente y al menos puedo jugar online decentemente y utilizar otras aplicaciones. No puedo abrir puertos individualmente, pero con el Upnp se apaña bastante bien (he comprobado que funcionar funciona). Quizás el router esté capado por hardware y no por software...
No hay forma de capar eso por hardware, porque se hace por software :/...

Anda, nuevo firmware de movistar....
Que raro...
P401-402TLF-C04_R07

Habrá que testearlo y modificarlo jaja.
Si encuentro un enlace os lo pongo
¿Te lo ha instalado automáticamente o has pedido en el foro que te lo instalen?
No creo que encuentres ningún enlace al firmware, ya que los otros firmwares que están disponibles por internet de Movistar para este router son copias de los que yo mismo he extraído y facilitado en este foro :).

Saludos.

Morax

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #259 en: 18-11-2013, 16:49 (Lunes) »
Gracias por contestar Noltari. Sí, lo tengo activado. Puedo verlo desde luci en la página de Startup. Sin embargo, es posible que tenga que reiniciar el router. No me dio tiempo a hacerlo, pero la última vez que lo hice, aparecieron deshabilitados ciertos scrips, y uno de ellos era el igmpproxy... Le di a habilitar y luego a recargar, y se seguía sin ver y ya me tuve que ir...

Cuando llegue a casa lo vuelvo a probar. De todas formas, también me dio un conflicto al actualizar el igmpproxy y me creó otro archivo igmpproxy-opkg. En cualquier caso modifiqué ambos...

Habrá que probar el nuevo firmware de movistar R_07 que parece que arregla el Upnp...