Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 375196 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado alazan_jc

  • **
  • Mensajes: 6
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1180 en: 30-01-2020, 21:32 (Jueves) »
Habiendo CP2102 o CP2104 a menos de 2€ en fleaBay, yo ya estaría pidiendo uno para tenerlo en el cajón del escritorio.
De hecho hoy he usado uno para desbriquear un Edgerouter-X.
Usar un Arduino para el puerto serie me parece matar moscas a cañonazos... Pero bueno, para gustos, colores.  >:D
Asegúrate de que el puerto serie del router aguanta las señales a 5V, que el arduino tiene las señales a 5V y no a 3.3V. No sea que frías el router.
Desde el puerto serie puedes ver por qué no te está flasheando el nuevo firmware. Para mi un puerto serie es la primera herramienta que tienes que tener. Es una inversión en tiempo.

Gracias por tu consejo. En su momento utilicé el Arduino para flashear el router y no me causó problemas, pero lo tendré en cuenta.

Por otra parte, cuando dices que podré ver el motivo del error en el flasheado desde el puerto serie, ¿puedes concretarme un poco qué debo hacer para verlo?

Gracias por adelantado.



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2049
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1181 en: 01-02-2020, 21:56 (Sábado) »
Habiendo CP2102 o CP2104 a menos de 2€ en fleaBay, yo ya estaría pidiendo uno para tenerlo en el cajón del escritorio.
De hecho hoy he usado uno para desbriquear un Edgerouter-X.
Usar un Arduino para el puerto serie me parece matar moscas a cañonazos... Pero bueno, para gustos, colores.  >:D
Asegúrate de que el puerto serie del router aguanta las señales a 5V, que el arduino tiene las señales a 5V y no a 3.3V. No sea que frías el router.
Desde el puerto serie puedes ver por qué no te está flasheando el nuevo firmware. Para mi un puerto serie es la primera herramienta que tienes que tener. Es una inversión en tiempo.

Gracias por tu consejo. En su momento utilicé el Arduino para flashear el router y no me causó problemas, pero lo tendré en cuenta.

Por otra parte, cuando dices que podré ver el motivo del error en el flasheado desde el puerto serie, ¿puedes concretarme un poco qué debo hacer para verlo?

Gracias por adelantado.

Ya deberías de haber pasado por allí:

[Índice] Hilos relevantes de OpenWrt -->>  [Tutorial] Puerto Serie - Cómo Acceder
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

Desconectado m4ximus

  • **
  • Mensajes: 20
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1182 en: 03-02-2020, 10:58 (Lunes) »
Buenas,

He podido compilar openwrt con los drivers Intel del WAVE300 que se han publicado en el foro de Openwrt, los paquetes que he incluido en la imagen son:

kmod-iwlwav-driver-uci
iwlwav-driver-uci
iwlwav-tools
iwlwav-iw
iwlwav-base-files
iwlwav-hostap-uci

Al parecer el driver funciona con una version especifica de hostap y iw pero de momento no consigo hacerlo funcionar, puedo compartir la version de openwrt compilada con estos paquetes si alguien quiere probar tambien puedo crear un tutorial de como compilarla.

Saludos,

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2049
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1183 en: 03-02-2020, 16:49 (Lunes) »
Buenas,

He podido compilar openwrt con los drivers Intel del WAVE300 que se han publicado en el foro de Openwrt, los paquetes que he incluido en la imagen son:

kmod-iwlwav-driver-uci
iwlwav-driver-uci
iwlwav-tools
iwlwav-iw
iwlwav-base-files
iwlwav-hostap-uci

Al parecer el driver funciona con una version especifica de hostap y iw pero de momento no consigo hacerlo funcionar, puedo compartir la version de openwrt compilada con estos paquetes si alguien quiere probar tambien puedo crear un tutorial de como compilarla.

Saludos,

Si quieres y tienes tiempo, puedes publicar un tuto para compilar como dices tú. Mejor enseñar a cultivar que dar latas de comida una vez. A alguien le puede enseñar y dar ideas nuevas.
Crea un nuevo hilo para ello, si lo vas a hacer, y gracias por aportar.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

Desconectado m4ximus

  • **
  • Mensajes: 20
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1184 en: 04-02-2020, 15:15 (Martes) »
Hola,

Despues de preguntar en el hilo de openwrt dicen que el driver es open source pero solo para Wave500 y 600 asi que nada, creo que voy a abrir un nuevo hilo para desarrollar el driver Wave300 para el Livebox 2.1 particularmente-

Saludos,

Buenas,

He podido compilar openwrt con los drivers Intel del WAVE300 que se han publicado en el foro de Openwrt, los paquetes que he incluido en la imagen son:

kmod-iwlwav-driver-uci
iwlwav-driver-uci
iwlwav-tools
iwlwav-iw
iwlwav-base-files
iwlwav-hostap-uci

Al parecer el driver funciona con una version especifica de hostap y iw pero de momento no consigo hacerlo funcionar, puedo compartir la version de openwrt compilada con estos paquetes si alguien quiere probar tambien puedo crear un tutorial de como compilarla.

Saludos,

Si quieres y tienes tiempo, puedes publicar un tuto para compilar como dices tú. Mejor enseñar a cultivar que dar latas de comida una vez. A alguien le puede enseñar y dar ideas nuevas.
Crea un nuevo hilo para ello, si lo vas a hacer, y gracias por aportar.

Desconectado peperfus

  • *****
  • Mensajes: 216
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1185 en: 04-02-2020, 15:56 (Martes) »
Hola,

Despues de preguntar en el hilo de openwrt dicen que el driver es open source pero solo para Wave500 y 600 asi que nada, creo que voy a abrir un nuevo hilo para desarrollar el driver Wave300 para el Livebox 2.1 particularmente-

Saludos,

Buenas,

He podido compilar openwrt con los drivers Intel del WAVE300 que se han publicado en el foro de Openwrt, los paquetes que he incluido en la imagen son:

kmod-iwlwav-driver-uci
iwlwav-driver-uci
iwlwav-tools
iwlwav-iw
iwlwav-base-files
iwlwav-hostap-uci

Al parecer el driver funciona con una version especifica de hostap y iw pero de momento no consigo hacerlo funcionar, puedo compartir la version de openwrt compilada con estos paquetes si alguien quiere probar tambien puedo crear un tutorial de como compilarla.

Saludos,

Si quieres y tienes tiempo, puedes publicar un tuto para compilar como dices tú. Mejor enseñar a cultivar que dar latas de comida una vez. A alguien le puede enseñar y dar ideas nuevas.
Crea un nuevo hilo para ello, si lo vas a hacer, y gracias por aportar.

Yo te apoyo. Aunque no tengo suficiente conocimiento para ayudarte, si me das instrucciones precisas, puedo ayudarte con pruebas, etc....
Tengo por aquí algún Livebox 2.1 de sobra.

Desconectado m4ximus

  • **
  • Mensajes: 20
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1186 en: 04-02-2020, 20:11 (Martes) »
Hola peperfus,

Pues vamos a ponernos manos a la obra, de momento estoy intentando compilar el driver que sale en el hilo de openwrt. Pero despues de compilarlo se necesitan algunos archivos del router principal que se encuentran el /lib/firmware/ y los archivos son:

Citar
/lib/firmware/sta_upper.bin
/lib/firmware/ap_upper.bin
/lib/firmware/contr_lm.bin
/lib/firmware/Progmodel_*.bin

Hay alguna manera de sacar estos archivos de un livebox con el firmware de fabrica? Yo tambien tengo uno pero con openwrt.

Saludos,

Desconectado peperfus

  • *****
  • Mensajes: 216
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1187 en: 04-02-2020, 20:32 (Martes) »
Vaya. Todos los que tengo llevan Open. ¿Quizás se podría reflashear el firmware original?
Y para sacarlos, no sé si se podrá. Se me ocurre que igual que para flashear desde cero, hizo falta acceder a una consola de comandos (creo que fue el uboot?), tal vez se pueda acceder desde ahí a los archivos y copiarlos a un pendrive por usb ?

Si no.... ni idea, lo veo complicado, es lo único que se me ocurre.

Desconectado m4ximus

  • **
  • Mensajes: 20
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1188 en: 06-02-2020, 19:57 (Jueves) »
Hola,

aqui esta la git del driver

https://repo.or.cz/wave300.git

si alguien se anima a compilarlo, de momento es compatible con la version 18.06.5. Tambien se ve que solo funciona en modo abierto sin cifrado ni WEP ni WPA.

Saludos,

Desconectado danitool

  • ****
  • Mensajes: 52
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1189 en: 06-02-2020, 21:59 (Jueves) »
Hola peperfus,

Pues vamos a ponernos manos a la obra, de momento estoy intentando compilar el driver que sale en el hilo de openwrt. Pero despues de compilarlo se necesitan algunos archivos del router principal que se encuentran el /lib/firmware/ y los archivos son:

Citar
/lib/firmware/sta_upper.bin
/lib/firmware/ap_upper.bin
/lib/firmware/contr_lm.bin
/lib/firmware/Progmodel_*.bin

Hay alguna manera de sacar estos archivos de un livebox con el firmware de fabrica? Yo tambien tengo uno pero con openwrt.

Saludos,

No sé si ya has resuelto esta parte. De todas formas por si es útil he extraido el dump de un ARV7519RW22. Estos archivos estaban en el directorio fw. Aquí os dejo el link de ese directorio
https://drive.google.com/uc?export=download&id=10vmr2xRfVetiqgselQIJYspGuv_0ejK5

Quizás fuese mejor idea extraerlo desde dentro del propio router. O si bien podeis acceder a la linea de comandos hacer un md5sum para comprobar que los archivos están bien.

Saludos

Desconectado alazan_jc

  • **
  • Mensajes: 6
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1190 en: 08-02-2020, 13:26 (Sábado) »
Habiendo CP2102 o CP2104 a menos de 2€ en fleaBay, yo ya estaría pidiendo uno para tenerlo en el cajón del escritorio.
De hecho hoy he usado uno para desbriquear un Edgerouter-X.
Usar un Arduino para el puerto serie me parece matar moscas a cañonazos... Pero bueno, para gustos, colores.  >:D
Asegúrate de que el puerto serie del router aguanta las señales a 5V, que el arduino tiene las señales a 5V y no a 3.3V. No sea que frías el router.
Desde el puerto serie puedes ver por qué no te está flasheando el nuevo firmware. Para mi un puerto serie es la primera herramienta que tienes que tener. Es una inversión en tiempo.

Gracias por tu consejo. En su momento utilicé el Arduino para flashear el router y no me causó problemas, pero lo tendré en cuenta.

Por otra parte, cuando dices que podré ver el motivo del error en el flasheado desde el puerto serie, ¿puedes concretarme un poco qué debo hacer para verlo?

Gracias por adelantado.

Ya deberías de haber pasado por allí:

[Índice] Hilos relevantes de OpenWrt -->>  [Tutorial] Puerto Serie - Cómo Acceder


Ayer tuve un poco de tiempo y me dejaron un Arduino. Realicé el proceso de conectarme por el puerto serie y sustituí el firmware por la versión 19.7.1 (el retraso me ha permitido saltarme la 19.7.0 jejeje).

El asunto es que he realizado el proceso de sustituir el firmware desde el uboot y no he tenido ningún problema. Ya está actualizado.

Cuando Tki2000 me comentaba que este procedimiento me permitiría determinar el motivo de que no pudiese sustituir el firmware desde Luci, yo me refería a esto, que me temía que me quedaría como estaba, sigo sin saber porque no puede completar el proceso desde Luci.

Lo cierto es que no es grave, sé que "destripando el cacharro" y conectándome a él bien sea con un Arduino o como muy bien dice Tki2000 mediante un adaptador TTL-USB, podré realizar el proceso.

Muchas gracias a tod@s por vuestra ayuda.

Desconectado mac47

  • **
  • Mensajes: 3
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1191 en: 18-03-2020, 21:16 (Miércoles) »
Hola,

Ante todo, muchas gracias por los post anteriores, y por la predisposición y mis disculpas si me repito, pero me he perdido bastante entre las 62 páginas de hilo y o lo tengo nada claro.

Tengo el router  ARV7520CW22-A-LT y quiero usarlo para hacer una subred (en principio no he separado la ONT y ya se que no se puede poner en modo bridge). Antes de pegarme con él (porque con un Home Station Amper ASL 26555 no he conseguido hacerlo, imagino que porque es antiguo), quería cambiar el firware porque imagino que vendrá muy capado por los de  Orange. Pero como en https://openwrt.org/toh/arcadyan/arv7519 dice:

"WARNING: Starting at least from 01/2015 the Livebox 2.1 features a very different hardware despite it has the same aspect.
The only external difference is that this new model only has one USB instead two. The lateral USB is the missing one.
In the product sticker in the box and in the device it's shown as ARV7520CW22-A-LT"

Pues interpreto que el 7519 no es válido, y más después de leer varias páginas de este hilo.

¿tenéis alguna solución o firmware alternativo o sabéis si ese funciona? y de paso ¿conocéis algún link donde explique como hacer la subred?

Mil gracias.

Desconectado javihijate

  • **
  • Mensajes: 13
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1192 en: 21-04-2020, 18:59 (Martes) »
Buenas a todos,
me he puesto a flashear otro de estos y me ha pasado una cosa muy rara. El que yo tengo aparentemente es la versión 1.2 pero cuanto le meto el uboot (el que hay en la pagina de openwrt que vienen dos archivos, uno para la 1.1 y otro para la 1.2) me sale esto:
U-Boot 2013.10-openwrt5-00014-g0b78b5c-dirty (Mar 11 2014 - 23:00:03) arv7519rw

Board: Lantiq ARV7519RW VRX200 Family Board
SoC:   Lantiq VRX288 v1.1
CPU:   500 MHz
IO:    250 MHz
BUS:   250 MHz
BOOT:  NOR
DRAM:  128 MiB
Flash: 32 MiB
In:    serial
Out:   serial
Err:   serial
Net:   Phy not found
PHY reset timed out
Phy not found
PHY reset timed out
ltq-eth
Hit any key to stop autoboot:  0
arv7519rw #



Osea que en el uboot dice que tengo la 1.1 pero debajo del router pone que tengo la 1.2. La placa tambien parece que es la 1.2. Ahora le he inetentado flashear el u-boot-V12 por si me habia equivocado antes, que no creo, con tftpboot y me sigue saliendo que tengo la 1.1. Openwrt inicia pero la luz de ethernet no se enciende y tampoco me aparece la pestaña switch en luci. Por debajo del router pone que es la r02, ¿que puedo hacer?

Desconectado m4ximus

  • **
  • Mensajes: 20
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1193 en: 10-05-2020, 14:40 (Domingo) »
Hola,

Tema wifi he podido compilar el driver y levantar la tarjeta wifi en modo ap solo y sin cifrado, iperf me da valores alrededor de 7mbs. Se ve que el driver no es compatible con el hostapd normal y necesita uno modificado. No se mucho de codigo parches etc.. si alguien está interesado puedo compartir mi progreso y de alli ir viendo como hacer que el cifrado funcione y que se integre en openwrt

Saludos

Desconectado peterpunk

  • **
  • Mensajes: 2
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1194 en: 29-05-2020, 14:58 (Viernes) »
Hola.

Primero pedir disculpas porque desde el 2014 no parezco por aquí (me habían borrado hasta la cuenta) y agradecer todo vuestro trabajo.
En aquella época instale el OpenWrt en un Huawei HG556a, cosa facil.
Aunque tenía el router arcadyan_arv7519rw22 de aquella época, no hice nada con él porque no lo veía inútil sin wifi, ahora (encerrado en estado de alarma) lo necesito utilizar como switch.
Al grano:

Tengo instalada la versión disponible en:

http://downloads.openwrt.org/releases/19.07.3/targets/lantiq/xrx200/openwrt-19.07.3-lantiq-xrx200-arcadyan_arv7519rw22-squashfs-sysupgrade.bin


Esto es lo que aparece al entrar:

Código: [Seleccionar]
BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.3, r11063-85e04e9f46
 -----------------------------------------------------
root@OpenWrt:~# uname -a
Linux OpenWrt 4.14.180 #0 SMP Sat May 16 18:32:20 2020 mips GNU/Linux
root@OpenWrt:~#

En el primer post de inicio indica que no funciona el wifi. Correcto, pero ¿tampoco funciona con adaptadores wifi externos?

Si, es no. Pues no continuar leyendo, me contestáis y punto. Pero como creo que es posible poner un usb wifi externo he seguido el manual:


¿Puedo conectar una tarjeta wifi USB para hacer que mi router actúe como Repetidor?
https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Repeater

El caso es que tampoco funciona. Aquí están los pasos.

Código: [Seleccionar]
root@OpenWrt:~# lsusb
Bus 001 Device 002: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0011:7788 Unknown counterfeit flash drive
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@OpenWrt:~# pwd
/root
root@OpenWrt:~# lsusb -D /dev/bus/usb/001/002
Device: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.01
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x148f Ralink Technology, Corp.
  idProduct          0x7601 MT7601U Wireless Adapter
  bcdDevice            0.00
  iManufacturer           1 MediaTek
  iProduct                2 802.11 n WLAN
  iSerial                 3 1.0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           74
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              160mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           8
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x84  EP 4 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x85  EP 5 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x08  EP 8 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x04  EP 4 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x05  EP 5 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x06  EP 6 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x07  EP 7 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x09  EP 9 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
Binary Object Store Descriptor:
  bLength                 5
  bDescriptorType        15
  wTotalLength           12
  bNumDeviceCaps          1
  USB 2.0 Extension Device Capability:
    bLength                 7
    bDescriptorType        16
    bDevCapabilityType      2
    bmAttributes   0x00000002
      Link Power Management (LPM) Supported
Device Status:     0x0000
  (Bus Powered)
root@OpenWrt:~#
root@OpenWrt:~# opkg list-installed|grep 7601
kmod-mt7601u - 4.14.180+4.19.120-1-1
mt7601u-firmware - 20190416-1
root@OpenWrt:~#

root@OpenWrt:/etc/config# rm wireless
root@OpenWrt:/etc/config# wifi config > wireless
root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/1f400000.fpi/1e101000.usb/usb1/1-1/1-1:1.0'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

Se elimina la línea:  option disabled '1' del fichero wireless.

Por la interfaz Luci, no aparece ningún dispositivo activo.
Además, el ejecutar el comando wifi config > wireless, con o sin el usb conectado siempre genera el mismo fichero.

No entiendo.


¿Alguien ha configurado un usb wifi externo, en este dispositivo?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2049
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1195 en: 29-05-2020, 20:10 (Viernes) »
Tienes que instalar los drivers del chipset wifi del pincho. Averigua cuál tiene y pon los drivers. Por defecto no viene ninguno instalado. (Creo que para el tuyo sería kmod-mt7601u)
No sé si desde un mismo pincho wifi por usb se puede tener a la vez AP y Cliente.
Para hacer de repetidor necesitas dos wifis. Una que capte y otra que repita -> dos pinchos usb y enrutamiento entre las dos redes. Puede que con relayd se solucione.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

Desconectado Ficht

  • **
  • Mensajes: 48
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1196 en: 29-05-2020, 22:40 (Viernes) »
Hola peterpunk

yo creo que has de instalar esto:

kmod-mt76-core
kmod-mt76-usb
kmod-mt7601u

Suerte. (ah, hay pinchos que si permiten hacer de repetidor)

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2049
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1197 en: 30-05-2020, 10:55 (Sábado) »
Suerte. (ah, hay pinchos que si permiten hacer de repetidor)

¿Cuálos?  ;)
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

Desconectado peterpunk

  • **
  • Mensajes: 2
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1198 en: 30-05-2020, 18:27 (Sábado) »
Hola.

Indicar que no lo quiero como repetidor, solo como AP. Me estoy mudando al trastero, (no es posible trabajar en casa con los niños)
Ya tengo cable, pero necesito wifi para que funcione el WhatApp, ya que no hay cobertura.

Solo estaba instalada la libreria kmod-mt7601u,  he instalado las otras, pero sigue sin aparecer OK mediante Luci.

Código: [Seleccionar]
root@OpenWrt:/etc/config# opkg list-installed|grep kmod-mt76
kmod-mt76-core - 4.14.180+2020-03-10-08054d5a-1
kmod-mt76-usb - 4.14.180+2020-03-10-08054d5a-1
kmod-mt7601u - 4.14.180+4.19.120-1-1
root@OpenWrt:/etc/config#


Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2049
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1199 en: 31-05-2020, 12:36 (Domingo) »
Hola.

Indicar que no lo quiero como repetidor, solo como AP. Me estoy mudando al trastero, (no es posible trabajar en casa con los niños)
Ya tengo cable, pero necesito wifi para que funcione el WhatApp, ya que no hay cobertura.

Solo estaba instalada la libreria kmod-mt7601u,  he instalado las otras, pero sigue sin aparecer OK mediante Luci.

Código: [Seleccionar]
root@OpenWrt:/etc/config# opkg list-installed|grep kmod-mt76
kmod-mt76-core - 4.14.180+2020-03-10-08054d5a-1
kmod-mt76-usb - 4.14.180+2020-03-10-08054d5a-1
kmod-mt7601u - 4.14.180+4.19.120-1-1
root@OpenWrt:/etc/config#

Tiene otras dependencias:
https://openwrt.org/packages/pkgdata_owrt18_6/kmod-mt7601u

Esto ya no tiene nada que ver con el router de este hilo. Si sigues teniendo problemas abre otro hilo al respecto y plantea la situación ahí.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

//FINAL Y MÁS DOS RESPUESTAS