Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 1693852 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado danitool

  • **
  • Mensajes: 39
Re:[Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #3080 en: 09-01-2020, 21:44 (Jueves) »
No entiendo por qué llega a estable un firmware que no arranca. Supongo que es un proceso automático.
Me imagino que alguien avisará a los desarrolladores para que lo miren, si no se ha hecho ya.
Seguramente será alguna cosa fácil, como algo de particiones o algo así.

Por cierto, entre atheros y ralink, cuál de los dos es mejor chip wifi?
PD: según he encontrado por ahí:
Atheros > Intel > Ralink/Realtek > Broadcom.

Es un proceso automático. No debería pasar el tener una versión estable para un router y que no arranque. Para los desarrolladores es físicamente imposible probar todos los modelos porque hay decenas para cada target, por eso es bueno informar de los fallos que van apareciendo en el bugtracker.

Si se prueban de forma regular los snapshots es fácil detectar cual fue el cambio que provocó el fallo, pero es una tarea que nadie lleva a cabo. Tal vez si fuese una empresa lucrativa habría gente expresamente dedicada a testear.

En la wiki elaboré una tabla con los firmwares estables que están testeados y funcionales. Este debería ser el enfoque más práctico, que salgan las versiones estables, pero que se confirmen que funcionan bien en el router con una "V" de verificado. Convencer de algo tan sencillo tanto a desarrolladores como usuarios no es fácil.

No hace mucho alguien borró la tabla porque eran "links obsoletos de firmwares".... parece dificil de explicar que queremos cosas que funcionen aunque no sean lo último. Como dato anecdótico que no tiene nada que ver con Openwrt. Ubiquti, un peso pesado del wifi, usa en sus últimos firmwares para equipos AC un Linux 2.6.32, no digo que esto sea bueno, pero ahí lo dejo.

En cuanto al wifi sin duda alguno mejor Atheros. Además la placa con Atheros trae blindajes en todos los chips. Para la placa con wifi  Ralink recomiendo poner un disipador encima del chip... ya que a más de uno se le frió tanto en este como en otros modelos de router.

Saludos



Desconectado peperfus

  • *****
  • Mensajes: 200
Re:[Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #3081 en: 09-01-2020, 23:41 (Jueves) »
https://bugs.openwrt.org/index.php?do=details&task_id=2721

Bug informado.
Es la primera vez que informo de un bug, espero haberlo hecho bien.
Bff, debería haber puesto HG556a también en el título, se me ha ocurrido después de postearlo.  :P
« Última modificación: 09-01-2020, 23:50 (Jueves) por peperfus »

Desconectado Ficht

  • **
  • Mensajes: 38
Re:[Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #3082 en: 10-01-2020, 00:55 (Viernes) »
Joe..
hace un tiempo que me estaba pasando, y pensaba que era tema mio, con dos git pull de por medio.... ^-^
En en VH4032N funciona bien y en alguno mas, pero en los hg556 hace tiempo que me ocurre eso con esta rama....

Desconectado peperfus

  • *****
  • Mensajes: 200
Re:[Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #3083 en: 12-01-2020, 22:03 (Domingo) »
Como tengo un HG556a A en el que sí funciona OpenWrt 19.07.0, se me había ocurrido copiarle la flash al otro, que es el mismo modelo. Supongo que donde dice "Save mtdblock contents", en "System/ Backup/Flash firmware", puedo descargar las copias binarias de esas particiones....
Lo que no entiendo muy bien es cómo destaurarlas luego.
Supongo que será con mtd write archivo partición, pero...
Me salen archivos de 10, 15, 13 MB ....
¿Alguien ha hecho esto o sabe cómo va? ¿es así de fácil, como ir restaurando con el comando mtd los archivos a sus particiones correspondientes desde la RAM?
Si esto es así de fácil y funciona, puedo pasar una copia de mis archivos flash a quien le interese.

Y otra pregunta aparte....
que puede ser algo rara: ¿Se le puede pagar a alguien para que arregle el firmware y lo publique en las descargas oficiales? Y en tal caso.... ¿alguna idea de cuánto costaría? (es sobre todo curiosidad)

Desconectado peperfus

  • *****
  • Mensajes: 200
Re:[Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #3084 en: 13-01-2020, 19:26 (Lunes) »
He conectado el puerto serie y he posteado la salida del terminal en el informe del bug. A ver qué dicen.

Edito:
https://bugs.openwrt.org/index.php?do=details&task_id=2202
Parece ser que este bug ya estaba detectado desde marzo del año pasado. Habrá que tener paciencia, me imagino.
« Última modificación: 14-01-2020, 21:10 (Martes) por peperfus »

Desconectado peperfus

  • *****
  • Mensajes: 200
Re:[Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #3085 en: 21-01-2020, 22:26 (Martes) »
"He estado intentando" sacar el firmware de un HG556a A con 19.07.0 que sí funciona, pero no termino de aclararme, así que... creo que acabaré antes intentando volver a compilarlo. Además, así, si sale bien, puedo aprovechar para compilar para A, B y C. Por lo visto, según tengo entendido, el fallo está en el Kernel...; así que lo que voy a intentar es compilarlo con la misma versión de Kernel que tengo en el que sí arranca.
A ver si hay suerte y lo consigo.

Edito: Gracias a danitool, que ha sacado amablemente el firmware de mi HG556a con open19 que misteriosamente sí arranca, he flasheado otro HG556a con dicho firmware y no arranca. En cuanto pueda, le conectaré cable serial para ver la salida por consola y la pondré por aquí.
« Última modificación: 27-01-2020, 12:51 (Lunes) por peperfus »

//FINAL Y MÁS DOS RESPUESTAS