Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 364564 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado alazan_jc

  • **
  • Mensajes: 6
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1180 en: 30-01-2020, 21:32 (Jueves) »
Habiendo CP2102 o CP2104 a menos de 2€ en fleaBay, yo ya estaría pidiendo uno para tenerlo en el cajón del escritorio.
De hecho hoy he usado uno para desbriquear un Edgerouter-X.
Usar un Arduino para el puerto serie me parece matar moscas a cañonazos... Pero bueno, para gustos, colores.  >:D
Asegúrate de que el puerto serie del router aguanta las señales a 5V, que el arduino tiene las señales a 5V y no a 3.3V. No sea que frías el router.
Desde el puerto serie puedes ver por qué no te está flasheando el nuevo firmware. Para mi un puerto serie es la primera herramienta que tienes que tener. Es una inversión en tiempo.

Gracias por tu consejo. En su momento utilicé el Arduino para flashear el router y no me causó problemas, pero lo tendré en cuenta.

Por otra parte, cuando dices que podré ver el motivo del error en el flasheado desde el puerto serie, ¿puedes concretarme un poco qué debo hacer para verlo?

Gracias por adelantado.



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1997
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1181 en: 01-02-2020, 21:56 (Sábado) »
Habiendo CP2102 o CP2104 a menos de 2€ en fleaBay, yo ya estaría pidiendo uno para tenerlo en el cajón del escritorio.
De hecho hoy he usado uno para desbriquear un Edgerouter-X.
Usar un Arduino para el puerto serie me parece matar moscas a cañonazos... Pero bueno, para gustos, colores.  >:D
Asegúrate de que el puerto serie del router aguanta las señales a 5V, que el arduino tiene las señales a 5V y no a 3.3V. No sea que frías el router.
Desde el puerto serie puedes ver por qué no te está flasheando el nuevo firmware. Para mi un puerto serie es la primera herramienta que tienes que tener. Es una inversión en tiempo.

Gracias por tu consejo. En su momento utilicé el Arduino para flashear el router y no me causó problemas, pero lo tendré en cuenta.

Por otra parte, cuando dices que podré ver el motivo del error en el flasheado desde el puerto serie, ¿puedes concretarme un poco qué debo hacer para verlo?

Gracias por adelantado.

Ya deberías de haber pasado por allí:

[Índice] Hilos relevantes de OpenWrt -->>  [Tutorial] Puerto Serie - Cómo Acceder
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

Desconectado m4ximus

  • **
  • Mensajes: 15
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1182 en: 03-02-2020, 10:58 (Lunes) »
Buenas,

He podido compilar openwrt con los drivers Intel del WAVE300 que se han publicado en el foro de Openwrt, los paquetes que he incluido en la imagen son:

kmod-iwlwav-driver-uci
iwlwav-driver-uci
iwlwav-tools
iwlwav-iw
iwlwav-base-files
iwlwav-hostap-uci

Al parecer el driver funciona con una version especifica de hostap y iw pero de momento no consigo hacerlo funcionar, puedo compartir la version de openwrt compilada con estos paquetes si alguien quiere probar tambien puedo crear un tutorial de como compilarla.

Saludos,

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1997
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1183 en: 03-02-2020, 16:49 (Lunes) »
Buenas,

He podido compilar openwrt con los drivers Intel del WAVE300 que se han publicado en el foro de Openwrt, los paquetes que he incluido en la imagen son:

kmod-iwlwav-driver-uci
iwlwav-driver-uci
iwlwav-tools
iwlwav-iw
iwlwav-base-files
iwlwav-hostap-uci

Al parecer el driver funciona con una version especifica de hostap y iw pero de momento no consigo hacerlo funcionar, puedo compartir la version de openwrt compilada con estos paquetes si alguien quiere probar tambien puedo crear un tutorial de como compilarla.

Saludos,

Si quieres y tienes tiempo, puedes publicar un tuto para compilar como dices tú. Mejor enseñar a cultivar que dar latas de comida una vez. A alguien le puede enseñar y dar ideas nuevas.
Crea un nuevo hilo para ello, si lo vas a hacer, y gracias por aportar.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

Desconectado m4ximus

  • **
  • Mensajes: 15
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1184 en: 04-02-2020, 15:15 (Martes) »
Hola,

Despues de preguntar en el hilo de openwrt dicen que el driver es open source pero solo para Wave500 y 600 asi que nada, creo que voy a abrir un nuevo hilo para desarrollar el driver Wave300 para el Livebox 2.1 particularmente-

Saludos,

Buenas,

He podido compilar openwrt con los drivers Intel del WAVE300 que se han publicado en el foro de Openwrt, los paquetes que he incluido en la imagen son:

kmod-iwlwav-driver-uci
iwlwav-driver-uci
iwlwav-tools
iwlwav-iw
iwlwav-base-files
iwlwav-hostap-uci

Al parecer el driver funciona con una version especifica de hostap y iw pero de momento no consigo hacerlo funcionar, puedo compartir la version de openwrt compilada con estos paquetes si alguien quiere probar tambien puedo crear un tutorial de como compilarla.

Saludos,

Si quieres y tienes tiempo, puedes publicar un tuto para compilar como dices tú. Mejor enseñar a cultivar que dar latas de comida una vez. A alguien le puede enseñar y dar ideas nuevas.
Crea un nuevo hilo para ello, si lo vas a hacer, y gracias por aportar.

Desconectado peperfus

  • *****
  • Mensajes: 210
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1185 en: 04-02-2020, 15:56 (Martes) »
Hola,

Despues de preguntar en el hilo de openwrt dicen que el driver es open source pero solo para Wave500 y 600 asi que nada, creo que voy a abrir un nuevo hilo para desarrollar el driver Wave300 para el Livebox 2.1 particularmente-

Saludos,

Buenas,

He podido compilar openwrt con los drivers Intel del WAVE300 que se han publicado en el foro de Openwrt, los paquetes que he incluido en la imagen son:

kmod-iwlwav-driver-uci
iwlwav-driver-uci
iwlwav-tools
iwlwav-iw
iwlwav-base-files
iwlwav-hostap-uci

Al parecer el driver funciona con una version especifica de hostap y iw pero de momento no consigo hacerlo funcionar, puedo compartir la version de openwrt compilada con estos paquetes si alguien quiere probar tambien puedo crear un tutorial de como compilarla.

Saludos,

Si quieres y tienes tiempo, puedes publicar un tuto para compilar como dices tú. Mejor enseñar a cultivar que dar latas de comida una vez. A alguien le puede enseñar y dar ideas nuevas.
Crea un nuevo hilo para ello, si lo vas a hacer, y gracias por aportar.

Yo te apoyo. Aunque no tengo suficiente conocimiento para ayudarte, si me das instrucciones precisas, puedo ayudarte con pruebas, etc....
Tengo por aquí algún Livebox 2.1 de sobra.

Desconectado m4ximus

  • **
  • Mensajes: 15
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1186 en: 04-02-2020, 20:11 (Martes) »
Hola peperfus,

Pues vamos a ponernos manos a la obra, de momento estoy intentando compilar el driver que sale en el hilo de openwrt. Pero despues de compilarlo se necesitan algunos archivos del router principal que se encuentran el /lib/firmware/ y los archivos son:

Citar
/lib/firmware/sta_upper.bin
/lib/firmware/ap_upper.bin
/lib/firmware/contr_lm.bin
/lib/firmware/Progmodel_*.bin

Hay alguna manera de sacar estos archivos de un livebox con el firmware de fabrica? Yo tambien tengo uno pero con openwrt.

Saludos,

Desconectado peperfus

  • *****
  • Mensajes: 210
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1187 en: 04-02-2020, 20:32 (Martes) »
Vaya. Todos los que tengo llevan Open. ¿Quizás se podría reflashear el firmware original?
Y para sacarlos, no sé si se podrá. Se me ocurre que igual que para flashear desde cero, hizo falta acceder a una consola de comandos (creo que fue el uboot?), tal vez se pueda acceder desde ahí a los archivos y copiarlos a un pendrive por usb ?

Si no.... ni idea, lo veo complicado, es lo único que se me ocurre.

Desconectado m4ximus

  • **
  • Mensajes: 15
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1188 en: 06-02-2020, 19:57 (Jueves) »
Hola,

aqui esta la git del driver

https://repo.or.cz/wave300.git

si alguien se anima a compilarlo, de momento es compatible con la version 18.06.5. Tambien se ve que solo funciona en modo abierto sin cifrado ni WEP ni WPA.

Saludos,

Desconectado danitool

  • **
  • Mensajes: 43
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1189 en: 06-02-2020, 21:59 (Jueves) »
Hola peperfus,

Pues vamos a ponernos manos a la obra, de momento estoy intentando compilar el driver que sale en el hilo de openwrt. Pero despues de compilarlo se necesitan algunos archivos del router principal que se encuentran el /lib/firmware/ y los archivos son:

Citar
/lib/firmware/sta_upper.bin
/lib/firmware/ap_upper.bin
/lib/firmware/contr_lm.bin
/lib/firmware/Progmodel_*.bin

Hay alguna manera de sacar estos archivos de un livebox con el firmware de fabrica? Yo tambien tengo uno pero con openwrt.

Saludos,

No sé si ya has resuelto esta parte. De todas formas por si es útil he extraido el dump de un ARV7519RW22. Estos archivos estaban en el directorio fw. Aquí os dejo el link de ese directorio
https://drive.google.com/uc?export=download&id=10vmr2xRfVetiqgselQIJYspGuv_0ejK5

Quizás fuese mejor idea extraerlo desde dentro del propio router. O si bien podeis acceder a la linea de comandos hacer un md5sum para comprobar que los archivos están bien.

Saludos

Desconectado alazan_jc

  • **
  • Mensajes: 6
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1190 en: 08-02-2020, 13:26 (Sábado) »
Habiendo CP2102 o CP2104 a menos de 2€ en fleaBay, yo ya estaría pidiendo uno para tenerlo en el cajón del escritorio.
De hecho hoy he usado uno para desbriquear un Edgerouter-X.
Usar un Arduino para el puerto serie me parece matar moscas a cañonazos... Pero bueno, para gustos, colores.  >:D
Asegúrate de que el puerto serie del router aguanta las señales a 5V, que el arduino tiene las señales a 5V y no a 3.3V. No sea que frías el router.
Desde el puerto serie puedes ver por qué no te está flasheando el nuevo firmware. Para mi un puerto serie es la primera herramienta que tienes que tener. Es una inversión en tiempo.

Gracias por tu consejo. En su momento utilicé el Arduino para flashear el router y no me causó problemas, pero lo tendré en cuenta.

Por otra parte, cuando dices que podré ver el motivo del error en el flasheado desde el puerto serie, ¿puedes concretarme un poco qué debo hacer para verlo?

Gracias por adelantado.

Ya deberías de haber pasado por allí:

[Índice] Hilos relevantes de OpenWrt -->>  [Tutorial] Puerto Serie - Cómo Acceder


Ayer tuve un poco de tiempo y me dejaron un Arduino. Realicé el proceso de conectarme por el puerto serie y sustituí el firmware por la versión 19.7.1 (el retraso me ha permitido saltarme la 19.7.0 jejeje).

El asunto es que he realizado el proceso de sustituir el firmware desde el uboot y no he tenido ningún problema. Ya está actualizado.

Cuando Tki2000 me comentaba que este procedimiento me permitiría determinar el motivo de que no pudiese sustituir el firmware desde Luci, yo me refería a esto, que me temía que me quedaría como estaba, sigo sin saber porque no puede completar el proceso desde Luci.

Lo cierto es que no es grave, sé que "destripando el cacharro" y conectándome a él bien sea con un Arduino o como muy bien dice Tki2000 mediante un adaptador TTL-USB, podré realizar el proceso.

Muchas gracias a tod@s por vuestra ayuda.

Desconectado mac47

  • **
  • Mensajes: 3
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1191 en: 18-03-2020, 21:16 (Miércoles) »
Hola,

Ante todo, muchas gracias por los post anteriores, y por la predisposición y mis disculpas si me repito, pero me he perdido bastante entre las 62 páginas de hilo y o lo tengo nada claro.

Tengo el router  ARV7520CW22-A-LT y quiero usarlo para hacer una subred (en principio no he separado la ONT y ya se que no se puede poner en modo bridge). Antes de pegarme con él (porque con un Home Station Amper ASL 26555 no he conseguido hacerlo, imagino que porque es antiguo), quería cambiar el firware porque imagino que vendrá muy capado por los de  Orange. Pero como en https://openwrt.org/toh/arcadyan/arv7519 dice:

"WARNING: Starting at least from 01/2015 the Livebox 2.1 features a very different hardware despite it has the same aspect.
The only external difference is that this new model only has one USB instead two. The lateral USB is the missing one.
In the product sticker in the box and in the device it's shown as ARV7520CW22-A-LT"

Pues interpreto que el 7519 no es válido, y más después de leer varias páginas de este hilo.

¿tenéis alguna solución o firmware alternativo o sabéis si ese funciona? y de paso ¿conocéis algún link donde explique como hacer la subred?

Mil gracias.

//FINAL Y MÁS DOS RESPUESTAS