Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 334627 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Conectado Tki2000

  • Moderador
  • *
  • Mensajes: 1933
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1160 en: 06-06-2019, 23:46 (Jueves) »
Me refería a que tengo un pincho usb instalado (un tl-wn722n), de ahí que mencionara el driver ath9k-htc, correspondiente a el chip que lleva dicha tarjeta, sé de antemano que la wifi interna de este dispositivo no es compatible con openwrt. Haciendo un dmesg me ssale lo siguiente:

[  482.723107] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits
[  483.140183] ath: phy3: Mac Chip Rev 0x0f.3 is not supported by this driver
[  483.145692] ath: phy3: Unable to initialize hardware; initialization status: -122
[  483.153187] ath: phy3: Unable to initialize hardware; initialization status: -122
[  483.160685] ath9k_htc: Failed to initialize the device
[  483.169739] usb 1-1: ath9k_htc: USB layer deinitialized

Asegúrate de que la versión del pincho es la adecuada. Hay varias versiones de ese pincho y tiene chipsets distintos. Las versiones 2 y 3 tienen chipset realtek.
¿Qué versión de openwrt le has puesto?



No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Desconectado javihijate

  • **
  • Mensajes: 11
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1161 en: 07-06-2019, 00:52 (Viernes) »
El pincho lleva atheros, lo sé de haberlo usado antes en otros routers, ademas de que al hacer lsusb me dice que es un atheros. Tengo la ultima version de openwrt (la 18.06.2) y he reestablecido de fábrica por si acaso pero ni me sale la pestaña wifi siquiera.

Conectado Tki2000

  • Moderador
  • *
  • Mensajes: 1933
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1162 en: 07-06-2019, 08:40 (Viernes) »
El pincho lleva atheros, lo sé de haberlo usado antes en otros routers, ademas de que al hacer lsusb me dice que es un atheros. Tengo la ultima version de openwrt (la 18.06.2) y he reestablecido de fábrica por si acaso pero ni me sale la pestaña wifi siquiera.

Pues poco más puedo decirte. A tenor de lo que te suelta el log, parece que el driver no soporta esta versión del hardware.

https://github.com/qca/open-ath9k-htc-firmware/issues/154
https://github.com/qca/open-ath9k-htc-firmware/issues/136

Alguien en esos threads dice que lo solucionó pinchando la wifi en un hub. No sé cuánto de verdad tendrá eso..., pero si lo quieres probar.

https://whitedome.com.au/re4son/topic/tl-722n-v1-not-working-with-pi-tail-pre-made-image/

En el último thread, que habla de la Raspberry, dicen que lo solucionan cambiando algo en el fichero de configuración, pero no sé si eso mismo se puede aplicar a openwrt.

https://forum.openwrt.org/t/lantiq-xrx200-tplink-8970-openwrt-18-06-rc1-usb-adapter/16092

De este thread, deduzco que el pincho funcionaba en la versión lede 17.01.4. Prueba esa versión si ves que no puedes con lo anterior.
« Última modificación: 07-06-2019, 08:42 (Viernes) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Desconectado javihijate

  • **
  • Mensajes: 11
Re:[Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #1163 en: 09-06-2019, 01:25 (Domingo) »
Pues en vista de que no funcionaba el usb wifi, me he puesto hacer un servidor vpn en el router. Todo funciona bien, pero obtengo anchos de banda muy escasos, similares aun tl-wr841n y si se supone que este router es mejor no entiendo como no funciona mejor. Alguna sugerencia para optimizar openvpn en este router? Tambien he estado mirando otro protocolo vpn que se llama wireguard que dicen que es mucho mas rapido. Alguien lo ha probado?