Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 458324 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Lesgar

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #420 en: 23-05-2014, 17:10 (Viernes) »
Yo empecé usando kubuntu y por sugerencia de Pteridium me pase a Debian sabor KDE.

Como "por fin" murio  :-[ mi viejo equipo, me acabo de pillar un Asus G65jr y estoy probando varias distros diferentes porque el nvidia optimus no va "fino".

Seguramente me quede en sabayon linux, que aunque no es mi preferida es la que mejor funciona.

Ejem: respecto al tema en cuestión si creeis que dependiendo de la distro puede haber problemas al compilar las imágenes, pasadme el .config y la rama que estais usando para compilar la imagen y lo pruebo con las diferentes distros que voy pobando.
Solo lo podré probar en la versión de hardware v1.1, no tengo ningún v1.2 "funcional"


« Última modificación: 23-05-2014, 17:11 (Viernes) por Lesgar »

doblecero

  • Visitante
Re:
« Respuesta #421 en: 23-05-2014, 18:45 (Viernes) »
Yo estoy probando con el .config de Ptedirium de una página mas atrás. También en un 1.1 rama trunk obviamente.... O es que tu compilas desde otra?

Enviado desde mi GT-I9300 mediante Tapatalk


chema79

  • Visitante
Re:
« Respuesta #422 en: 23-05-2014, 19:48 (Viernes) »
Yo estoy probando con el .config de Ptedirium de una página mas atrás. También en un 1.1 rama trunk obviamente.... O es que tu compilas desde otra?

Enviado desde mi GT-I9300 mediante Tapatalk



Yo estoy exactamente igual, ya estoy pensando en si hay que recitar algo del necronomicon mientras compila.
Sigo los mismos pasos que tu, excepto lo de la partidica y no me saca los firms en carpeta.

Compilo desde una ubuntu 14.04 (si, soy un temerario), y nada...
Pero en cuanto instalo la imagen original, vuala! ahi estan los 4 puertos funcionando  ???

Pelikano21

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #423 en: 23-05-2014, 21:14 (Viernes) »
Doblecero, gracias, he empezado de nuevo cargando la imagen de openwrt, instalado el paquete para el usb wifi  kmod-rtl8187. La wifi seria para conectar con la wifi de casa en modo cliente. He seguido tus indicaciones y te pongo lo que ha devuelto.

wifi
wlan0: link is not ready

ifconfig
br-lan    Link encap:Ethernet  HWaddr 53:7Z:4A:03:92:ED
          inet addr:192.168.69.250  Bcast:192.168.69.255  Mask:255.255.255.0
          inet6 addr: fe80::527e:5dff:fe03:46ed/64 Scope:Link
          inet6 addr: fd02:f75d:ed29::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1314 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1513 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:135646 (132.4 KiB)  TX bytes:368962 (360.3 KiB)

eth0      Link encap:Ethernet  HWaddr FF:5E:AA:B4:BB:29
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1380 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1513 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:171268 (167.2 KiB)  TX bytes:383847 (374.8 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:522 errors:0 dropped:0 overruns:0 frame:0
          TX packets:522 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:46537 (45.4 KiB)  TX bytes:46537 (45.4 KiB)

nas0      Link encap:Ethernet  HWaddr 53:7Z:4A:03:92:ED
          inet6 addr: fe80::527e:5dff:fe03:46ee/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:187 dropped:0 overruns:0 carrier:187
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

dmesg (he cogido solo una parte es muy largo)

[   87.960000] WARNING: at /home/lesgar/Documents/Arv7519Pruebas/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/compat-wireless-2014-03-31/net/mac80211/rx.c:3378 mac80211_ieee80211_rx+0x190/0x890 [mac80211]()
[   87.980000] Modules linked in: iptable_nat rtl8187 pppoe p54usb p54common nf_ nat_ipv4 nf_conntrack_ipv4 mac80211 ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY usblp ums_usbat ums_sddr55 ums_sddr09 ums_karma ums_jumpshot ums_isd200 ums_freecom ums_datafab ums_cypress ums_alauda ts_kmp ts_fsm ts_bm pppox ppp_async nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv4 nf_conntrack_irc nf_conntrack_ftp ltq_deu_vr9 iptable_raw iptable_mangle iptable_filter ipt_REJECT ipt_ ECN ip_tables crc_ccitt compat cdc_wdm fuse act_connmark act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress sg drv_dsl_cpe_api drv_mei_cpe ip6t_REJECT ip6t_rt ip6t_hbh ip6t_mh ip6t_ipv6header ip6t_frag ip6t_eui64 ip6t_ah ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables nf_conntrack_ipv6 nf_conntrack nf_defrag_ipv6 pppoatm ppp_generic slhc nfsv3 nfs msdos ifb vfat fat lockd sunrpc hfsplus hfs br2684 atm bcma nls_utf8 nls_iso8859_1 ipv6 eeprom_93cx6 drv_ifxos arc4 crypto_blkcipher usb_storage ltq_hcd_vr9 uhci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 jbd2 mbcache ssb
[   88.096000] CPU: 0 PID: 1158 Comm: uhttpd Tainted: G        W    3.10.36 #7
[   88.104000] Stack : 00000000 00000000 00000000 00000000 804232ea 0000003f 86c 45340 86cce260
[   88.104000]    80367c7c 803d723b 00000486 80422a98 86c45340 86cce260 878acc0c 00000009
[   88.104000]    80440000 80023b14 00000003 800213cc 00000000 00000000 80369f84 86d15b84
[   88.104000]    00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[   88.104000]    00000000 00000000 00000000 00000000 00000000 00000000 00000000 86d15b10
[   88.104000]    ...
[   88.140000] Call Trace:
[   88.144000] [<800166d0>] show_stack+0x48/0x70
[   88.148000] [<80021540>] warn_slowpath_common+0x78/0xa8
[   88.152000] [<800215f8>] warn_slowpath_null+0x18/0x24
[   88.156000] [<86ca25b4>] mac80211_ieee80211_rx+0x190/0x890 [mac80211]
[   88.164000] [<86c800e0>] ieee80211_restart_hw+0xe0/0x1d4 [mac80211]
[   88.168000]
[   88.172000] ---[ end trace d3d51ab28d3e830f ]---
[   88.192000] usb 1-1: USB disconnect, device number 2
[  136.356000] usb 1-1: new high-speed USB device number 3 using ifxusb_hcd
[  137.008000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[  137.016000] ieee80211 phy1: hwaddr 00:0a:eb:00:51:2d, RTL8187vB (default) V1                                                                              + rtl8225z2, rfkill mask 2
[  137.060000] rtl8187: Customer ID is 0xFF
[  137.072000] rtl8187: wireless switch is on



/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ifxusb_hcd/usb1/1-1/1-1:1.0'
        option txpower '20'
        option country '00'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option ssid 'OpenWrt'
        option encryption 'none'
        option mode 'sta'

perdona pero en esto novato total, gracias

« Última modificación: 26-05-2014, 08:02 (Lunes) por Pelikano21 »

doblecero

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #424 en: 25-05-2014, 12:39 (Domingo) »
es raro que el comando wifi no te levante la interfaz...
Prueba:
Citar
ifconfig wlan0 up

desde luci puedes ver la interfaz wifi configurada?

Pelikano21

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #425 en: 25-05-2014, 16:52 (Domingo) »
Doblecero esto es lo que sale al ejecutar ifconfig wlan0 up
root@OpenWrt:/# ifconfig wlan0 up
[  251.192000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

en wifi de luci aparece

Generic MAC80211 802.11bg (radio0)
   [Señal: 0 dBm / Ruido: 0 dBm]
0%    SSID: OpenWrt | Modo: Client
Red inalámbrica desconectada o no asociada

en el usb wifi no deja de parpadear el led y putti muestra constantemente lineas como si fuera un bucle. ¿no has observado nada extraño en las lineas que te escribí en el mensaje anterior? ¿con las lineas del /etc/config/wireless funcionaría sin problemas?

doblecero

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #426 en: 26-05-2014, 13:40 (Lunes) »
Tu configuracion de /etc/config/wireless no parece estar mal (al menos yo no veo nada mal)
Es raro que no te levante la interfaz...
que marca y modelo es?

Que es lo que te saca por consola constantemente? pasa cuando conectas el dispositivo? o cuando intentas levantarlo?


Lesgar

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #427 en: 26-05-2014, 15:24 (Lunes) »
Como hay que hacer la compilación para poder cargar la imagen desde openwrt. Como hace jar229 en sus compilaciones para los western digital? ???

doblecero

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #428 en: 26-05-2014, 16:19 (Lunes) »
Como hay que hacer la compilación para poder cargar la imagen desde openwrt. Como hace jar229 en sus compilaciones para los western digital? ???

Te refieres con sysupgrade?

Lesgar

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #429 en: 26-05-2014, 16:38 (Lunes) »
Si

doblecero

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #430 en: 26-05-2014, 17:38 (Lunes) »
Que yo sepa cualquier imagen generada es actualizable via sysupgrade, ya sea por consola o por luci. Lo que ocurre es que te va a mantener la configuración a no ser que la inicialices.

Es mas, yo lo he probado, en este router, con alguna de las imágenes que se han puesto por aquí...

Saludos.

Pelikano21

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #431 en: 28-05-2014, 09:02 (Miércoles) »
Doblecero, estoy desesperado ya que no tengo manera de configurar el usb wifi para que coja internet. El router es ARV7519RW22 v.1.1, la imagen de openwrt es la compilada por lesgar de unos 6,6Mb (supongo que parte de la configuración de los parámetros es suya). Como ya te expliqué anteriormente lo quiero conectar a través del cable de red a un pc y que este tenga internet a través del usb wifi chipset rtl8187L conectado a este router. Ahora mismo si enciendo el router con el usb wifi puesto no deja de parpadear la luz acto seguido se enciende otra luz azul y vuelta a empezar, tengo que quitar el usb wifi para poder entrar. Si arranco con el wifi quitado arranca bien, cuando lo pincho e intento levantarlo otra vez la luz se pone a parpadear como te he dicho antes. Mis dudas son: si en /etc/config/ethernet y en /etc/config/wireless tengo que tener dada de alta la interfaz y por otro lado en base a la configuración que yo quiero lo mismo tendría que puentear el dispositivo wifi con la lan. Doblecero, por favor, me podrías decir si la interfaz del dispositivo usb wifi está establecida en /etc/config/ethernet? y en /etc/config/wireless?. Si no es así me podrías poner la que hiciera funcionar el wifi?. Te pongo la configuración de ambos y algo más por si te puede servir. El dmesg sólo un trozo es muy largo.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd02:f75d:ed29::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr 'xx:7e:xx:03:xx:ed'
        option gateway '192.168.69.1'
        option ipaddr '192.168.69.250'
        option dns '8.8.4.4 8.8.8.8'
        option _orig_ifname 'eth0'
        option _orig_bridge 'true'
        option ifname '@wan eth0'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config interface 'wan'
        option ifname 'nas0'
        option proto 'pppoe'
        option username 'foo'
        option password 'bar'
        option ipv6 '1'
        option macaddr '50:xx:5d:xx:46:xx'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config vdsl 'dsl'
        option annex 'a'
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'av'
        option xfer_mode 'ptm'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
   option macaddr '00:xx:eb:xx:51:xx'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ifxusb_hcd/usb1/1-1/1-1:1.0'
        option txpower '20'
        option country 'ES'
   option disabled '0'

config wifi-iface
        option device 'radio0'
        option network 'wan'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option mode 'sta'
   option key 'CCxxC27xx049xx9C8A19Fxx210'

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr xx:xx:xx:03:xx:ED
          inet addr:192.168.69.250  Bcast:192.168.69.255  Mask:255.255.255.0
          inet6 addr: fe80::527e:5dff:fe03:46ed/64 Scope:Link
          inet6 addr: fd02:f75d:ed29::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1156 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:130226 (127.1 KiB)  TX bytes:76753 (74.9 KiB)

eth0      Link encap:Ethernet  HWaddr B6:37:05:6A:50:D1
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1156 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:157396 (153.7 KiB)  TX bytes:95639 (93.3 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3765 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3765 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:258464 (252.4 KiB)  TX bytes:258464 (252.4 KiB)

nas0      Link encap:Ethernet  HWaddr xx:7E:xx:xx:46:EE
          inet6 addr: fe80::527e:5dff:fe03:46ee/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:558 dropped:0 overruns:0 carrier:558
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:xx:xx:00:51:2D
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


root@OpenWrt:~# iwconfig
ifb0      no wireless extensions.

nas0      no wireless extensions.

lo        no wireless extensions.

eth1      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

eth0      no wireless extensions.

ifb1      no wireless extensions.

br-lan    no wireless extensions.


root@OpenWrt:~# dmesg
[ 1342.368000] Call Trace:
[ 1342.372000] [<800166d0>] show_stack+0x48/0x70
[ 1342.376000] [<80021540>] warn_slowpath_common+0x78/0xa8
[ 1342.380000] [<800215f8>] warn_slowpath_null+0x18/0x24
[ 1342.388000] [<86ca25b4>] mac80211_ieee80211_rx+0x190/0x890 [mac80211]
[ 1342.392000] [<86c800e0>] ieee80211_restart_hw+0xe0/0x1d4 [mac80211]
[ 1342.400000]
[ 1342.400000] ---[ end trace 2ef7f7ba2588e496 ]---
[ 1390.088000] ------------[ cut here ]------------
[ 1390.092000] WARNING: at /home/lesgar/Documents/Arv7519Pruebas/openwrt/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/compat-wireless-2014-03-31/net/mac80211/rx.c:3378 mac80211_ieee80211_rx+0x190/0x890 [mac80211]()
[ 1390.112000] Modules linked in: iptable_nat rtl8187 pppoe p54usb p54common nf_nat_ipv4 nf_conntrack_ipv4 mac80211 ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_string xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY usblp ums_usbat ums_sddr55 ums_sddr09 ums_karma ums_jumpshot ums_isd200 ums_freecom ums_datafab ums_cypress ums_alauda ts_kmp ts_fsm ts_bm pppox ppp_async nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv4 nf_conntrack_irc nf_conntrack_ftp ltq_deu_vr9 iptable_raw iptable_mangle iptable_filter ipt_REJECT ipt_ECN ip_tables crc_ccitt compat cdc_wdm fuse act_connmark act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress sg drv_dsl_cpe_api drv_mei_cpe ip6t_REJECT ip6t_rt ip6t_hbh ip6t_mh ip6t_ipv6header ip6t_frag ip6t_eui64 ip6t_ah ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables nf_conntrack_ipv6 nf_conntrack nf_defrag_ipv6 pppoatm ppp_generic slhc nfsv3 nfs msdos ifb vfat fat lockd sunrpc hfsplus hfs br2684 atm bcma nls_utf8 nls_iso8859_1 ipv6 eeprom_93cx6 drv_ifxos arc4 crypto_blkcipher usb_storage ltq_hcd_vr9 uhci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 jbd2 mbcache ssb
[ 1390.232000] CPU: 0 PID: 0 Comm: swapper Tainted: G        W    3.10.36 #7
[ 1390.236000] Stack : 00000000 00000000 00000000 00000000 804232ea 0000003d 803d74b8 86cce260
[ 1390.236000]    80367c7c 803d723b 00000000 80422a98 803d74b8 86cce260 878acc0c 00000009
[ 1390.236000]    80440000 80023b14 00000003 800213cc 00000000 00000000 80369f84 803d1c04
[ 1390.236000]    00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[ 1390.236000]    00000000 00000000 00000000 00000000 00000000 00000000 00000000 803d1b90
[ 1390.236000]    ...
[ 1390.272000] Call Trace:
[ 1390.276000] [<800166d0>] show_stack+0x48/0x70
[ 1390.280000] [<80021540>] warn_slowpath_common+0x78/0xa8
[ 1390.284000] [<800215f8>] warn_slowpath_null+0x18/0x24
[ 1390.292000] [<86ca25b4>] mac80211_ieee80211_rx+0x190/0x890 [mac80211]
[ 1390.296000] [<86c800e0>] ieee80211_restart_hw+0xe0/0x1d4 [mac80211]
[ 1390.304000]
[ 1390.304000] ---[ end trace 2ef7f7ba2588e497 ]---

perdona por el tostón pero es que no tengo ni idea y no es porque no lea y relea configuraciones pero me fallan los conceptos. Gracias
« Última modificación: 28-05-2014, 09:07 (Miércoles) por Pelikano21 »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #432 en: 28-05-2014, 17:16 (Miércoles) »
Doblecero, estoy desesperado ya que no tengo manera de configurar el usb wifi para que coja internet. El router es ARV7519RW22 v.1.1, la imagen de openwrt es la compilada por lesgar de unos 6,6Mb (supongo que parte de la configuración de los parámetros es suya). Como ya te expliqué anteriormente lo quiero conectar a través del cable de red a un pc y que este tenga internet a través del usb wifi chipset rtl8187L conectado a este router. Ahora mismo si enciendo el router con el usb wifi puesto no deja de parpadear la luz acto seguido se enciende otra luz azul y vuelta a empezar, tengo que quitar el usb wifi para poder entrar. Si arranco con el wifi quitado arranca bien, cuando lo pincho e intento levantarlo otra vez la luz se pone a parpadear como te he dicho antes. Mis dudas son: si en /etc/config/ethernet y en /etc/config/wireless tengo que tener dada de alta la interfaz y por otro lado en base a la configuración que yo quiero lo mismo tendría que puentear el dispositivo wifi con la lan. Doblecero, por favor, me podrías decir si la interfaz del dispositivo usb wifi está establecida en /etc/config/ethernet? y en /etc/config/wireless?. Si no es así me podrías poner la que hiciera funcionar el wifi?. Te pongo la configuración de ambos y algo más por si te puede servir. El dmesg sólo un trozo es muy largo.

Me da que los problemas con drivers, sobre todo dispositivos USB, es debido a que la plataforma Lantiq se compila con MIPS16 activado por defecto.
Ahora mismo estoy compilando un firm para el R01 ó V11 (como cada uno prefiera) sin mips16. Si una vez probado funciona lo cuelgo para que lo comprobéis a ver si le encontráis algún defecto o si funciona correctamente.
Lo único que os pido es un pelín de paciencia.  :-\

Un saludo.

P.D.: si funciona compilo otro para el V12 ó R02, pero no tengo manera de probarlo.  ^-^

chema79

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #433 en: 28-05-2014, 21:59 (Miércoles) »
El error que te esta dando (ieee80211...) significa que algo del subsistema wifi, seguramente el driver de la tarjeta que estes usando, no esta todo lo fino que deberia y esta causando problemas... Yo te recomendaria que probases otra version del driver, y que comprobaras los mensajes del kernel (dmesg) para ver si sigue igual.

Pelikano21

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #434 en: 29-05-2014, 08:31 (Jueves) »
gracias chema79,  ¿pueden valer los de Windows? y ¿cómo lo instalo si lo copio en un pen? ¡como comprobarás ni idea de linux¡. Ah hay que desintalar el que está (que no se como se hace) para instalar el otro ¿no?.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2225
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #435 en: 29-05-2014, 09:51 (Jueves) »
gracias chema79,  ¿pueden valer los de Windows? y ¿cómo lo instalo si lo copio en un pen? ¡como comprobarás ni idea de linux¡. Ah hay que desintalar el que está (que no se como se hace) para instalar el otro ¿no?.


Por tarjeta se refiere al pincho usb wifi, y los drivers son los de openwrt, no tienen nada que ver los de windows.  ^-^
Básicamente espera a ver si Pteridium cuelga la compilación, que decía que estaba haciendo, cuando la termine, y a ver si los drivers sin MIPS16 funcionan bien o no (suponiendo que Pteridium haya integrado los drivers para el rtl8187L)

Pelikano21

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #436 en: 29-05-2014, 12:01 (Jueves) »
Gracias por tu aclaración Tki2000 y a Pteridium por su nueva compilación que seguro instalaré.

www-www

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #437 en: 29-05-2014, 18:58 (Jueves) »
P.D.: si funciona compilo otro para el V12 ó R02, pero no tengo manera de probarlo.  ^-^

Yo dispongo de un R02 y puedo probarlo.

Saludos

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #438 en: 30-05-2014, 16:30 (Viernes) »
Un día y pico para compilar dos firms funcionales ...  :( Para la siguiente que lo haga otro.
ARV7519RW-V11
ARV7519RW-V12

Las compilaciones están hechas con GCC 4.6, así que los paquetes de otras compilaciones pueden no funcionar o dar problemas, con lo que habrá que usar sólo los que están incluidos.

doblecero

  • Visitante
Re:
« Respuesta #439 en: 30-05-2014, 19:00 (Viernes) »
Gracias Pteridium!
1 día y medio??? Que Pc usas para compilar?? O es que usas un linux en una maquina virtual??

Yo me ofrecería a compilar si fuera porque todo lo que yo compilo hace que no funcionen los puertos ethernet...
Yo hasta el domingo no podré probarlo!

Aprovecho para preguntar aquí... Alguien ha conseguido echar a andar la adsl con pppoe?? Estoy teniendo algunos problemillas para conectarlo con mi conexión de Jazztel

Enviado desde mi GT-I9300 mediante Tapatalk