Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 382437 veces)

0 Usuarios y 1 Visitante están viendo este tema.

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #840 en: 10-12-2015, 07:26 (Jueves) »
A mi no me funciona ningún botón, salvo que los scripts que escriben al log sean incorrectos, no me sale nada en logread. ¿De qué forma podría proceder a leer el estado de esos gpio concretos? De momento en el wiki OpenWrt no he visto nada, sino miro en documentación general de linux.



howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #841 en: 10-12-2015, 07:52 (Jueves) »
Pues comprobado, no se si es la forma más ortodoxa pero he activado todos los gpio que me ha dejado el chip gpio-xway y parece que coincide con lo reportado. Aquí pongo solo los gpios pertinentes para que quien quiera lo pueda comprobar en su router, solo he probado en el R02 pero me imagino que eso no variará.

cd /sys/class/gpio
echo 462 > export
echo 489 > export
echo 493 > export
cat gpio462/value (reset sin pulsar 1, pulsado 0)
cat gpio489/value (wifi sin pulsar 1, pulsado 0)
cat gpio493/value (wps sin pulsar 1, pulsado 0)


Se ve que son todas activas en estado bajo y si se atiende a que el primer gpio empieza en 456, si restamos sale:

reset   6  LOW
wifi   33  LOW
wps    37  LOW


No se si eso vale como confirmación, lo de restar el número base del chip gpio me lo he sacado de la manga y no he buscado documentación sobre ello.
« Última modificación: 10-12-2015, 07:55 (Jueves) por howl »

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #842 en: 10-12-2015, 10:32 (Jueves) »
Acabo de reportarlo en OpenWrt https://dev.openwrt.org/ticket/21347#ticket

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #843 en: 10-12-2015, 11:13 (Jueves) »
danitool veo que has empezado a dejar más bonito el wiki, te he editado el label de wifi a rfkill que es el nombre que espera el nuevo sistema proc para los botones.

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #844 en: 10-12-2015, 11:32 (Jueves) »
Otra cosa, tengo un R01 con fecha de manufacturación 04/2013. Creo que podría estar mal las fechas de cuando empezó a fabricarse la versión R02, lo cambio a esperas de ver si hay alguna foto de un R02 con fechas de 01/2013 a 04/2013. Es posible incluso que el R02 saliese incluso algo más adelante porque el más viejo que he visto es de 08/2013.

Y ya de paso una cosilla que no comprendo, el R02 tiene el chip PEF7071V V1.5 para la interfaz ethernet, el R01 tengo que mirar pero intuyo que será el PEF7071V V1.3. Según este pdf http://www.codico.com/fileadmin/bilder/produkte/akt/20111912_Product_Overview_final.pdf viene a ser un XWAY™ PHY11G, pero nosotros le cargamos el firmware XWAY™ PHY22F. A fuerza tiene que haber algo mal por ahí, en el wiki figuraba antes los firmwares phy 11g pero yo lo edité a los phy22f ya que tanto en OpenWrt como en U-Boot son los que se cargan. No consigo ver porque hay esa discrepancia, ¿alguno ha probado poniendo los firmwares phy11g si funciona correctamente?

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #845 en: 10-12-2015, 11:41 (Jueves) »
A ver si tengo tiempo para probar los botones a lo largo de esta semana y mando el siguiente parche:
https://github.com/openwrt-es/openwrt/commit/cb109a11b97185c8455df11f32f77b54742c6989
El desarrollo de este router lo cogí ya empezado y fue una de las cosas que no llegué a verificar porque supuse que estaban bien.

Otra cosa, tengo un R01 con fecha de manufacturación 04/2013. Creo que podría estar mal las fechas de cuando empezó a fabricarse la versión R02, lo cambio a esperas de ver si hay alguna foto de un R02 con fechas de 01/2013 a 04/2013. Es posible incluso que el R02 saliese incluso algo más adelante porque el más viejo que he visto es de 08/2013.

Y ya de paso una cosilla que no comprendo, el R02 tiene el chip PEF7071V V1.5 para la interfaz ethernet, el R01 tengo que mirar pero intuyo que será el PEF7071V V1.3. Según este pdf http://www.codico.com/fileadmin/bilder/produkte/akt/20111912_Product_Overview_final.pdf viene a ser un XWAY™ PHY11G, pero nosotros le cargamos el firmware XWAY™ PHY22F. A fuerza tiene que haber algo mal por ahí, en el wiki figuraba antes los firmwares phy 11g pero yo lo edité a los phy22f ya que tanto en OpenWrt como en U-Boot son los que se cargan. No consigo ver porque hay esa discrepancia, ¿alguno ha probado poniendo los firmwares phy11g si funciona correctamente?
No va a funcionar porque hay dos configuraciones posibles: 4 puertos Fast Ethernet o 2 puertos Gigabit Ethernet.
Hasta donde llego a entender para Fast Ethernet se utilizan 4 cables, mientras que para Gigabit Ethernet se utilizan 8 cables, por lo que funcionaría si cambiamos el hardware del router y de 4 puertos fast ethernet hacemos 2 puertos gigabit ethernet.

Saludos.

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #846 en: 10-12-2015, 12:02 (Jueves) »
Entonces solo se me ocurre que los firmwares estén cambiados de nombre, es decir, que los binarios phy22f sean el phy11g y viceversa. Acabo de ver en la web de lantiq confirmación de que el chip que llevamos es el nombrado phy11g, https://www.lantiq.com/digital-home/gigabit-ethernet/gigabit-ethernet-phy/xwaytm-phy11g-gigabit-ethernet-phy/.

Si puedo intento revisar otros routers que usan estos firmwares y que chips llevan para verificar que pasa con esa discrepancia de nombres. No es algo realmente importante, es solo algo superfluo.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #847 en: 10-12-2015, 12:07 (Jueves) »
Entonces solo se me ocurre que los firmwares estén cambiados de nombre, es decir, que los binarios phy22f sean el phy11g y viceversa. Acabo de ver en la web de lantiq confirmación de que el chip que llevamos es el nombrado phy11g, https://www.lantiq.com/digital-home/gigabit-ethernet/gigabit-ethernet-phy/xwaytm-phy11g-gigabit-ethernet-phy/.

Si puedo intento revisar otros routers que usan estos firmwares y que chips llevan para verificar que pasa con esa discrepancia de nombres. No es algo realmente importante, es solo algo superfluo.
Y ese chip está, y funciona en modo Gigabit Ethernet, pero únicamente tiene conectado el puerto WAN. Los puertos de la LAN no está conectados a ese chip, sino que van al SoC directamente.

Saludos.

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #848 en: 10-12-2015, 12:17 (Jueves) »
Ok, ahora si entendí también tu anterior mensaje, perdona la torpeza.

Por cierto de momento todavía no han mirado para poner el desplazamiento de las particiones para U-Boot https://dev.openwrt.org/ticket/20964 no se si habría alguien en concreto a quien se le pueda dar un toque para que lo miren.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #849 en: 10-12-2015, 13:39 (Jueves) »
Ok, ahora si entendí también tu anterior mensaje, perdona la torpeza.

Por cierto de momento todavía no han mirado para poner el desplazamiento de las particiones para U-Boot https://dev.openwrt.org/ticket/20964 no se si habría alguien en concreto a quien se le pueda dar un toque para que lo miren.
Yo podría mirarlo si encuentro un hueco, pero me da que va a ser en las vacaciones de Navidad, porque ahora mismo estoy bastante liado :/.

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #850 en: 10-12-2015, 15:49 (Jueves) »
Tranquilo Noltari, prisa no hay pero intuyo que cuando empiece a haber una imagen que funcione correctamente con los usb más gente se animará a andar con este router y era solo por tener ese cambio antes de que eso pase, por no tener líos con diferentes esquemas. En el peor de los casos lo único que puede pasar sería que con un U-Boot que ocupe 3 páginas alguien borre la configuración de uboot pero no lo brikearía.

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #851 en: 10-12-2015, 16:11 (Jueves) »
Ok, ahora si entendí también tu anterior mensaje, perdona la torpeza.

Por cierto de momento todavía no han mirado para poner el desplazamiento de las particiones para U-Boot https://dev.openwrt.org/ticket/20964 no se si habría alguien en concreto a quien se le pueda dar un toque para que lo miren.

Cuando haces un ticket para un router concreto lo mejor es poner el nombre de la plataforma primero y luego el defecto. De esta forma se asignan más fácilmente los defectos a los desarrolladores, ya que algunos trabajan solo con lantiq, otros con bcm63xx, etc.

Ejemplo
Lantiq: gpio buttons mismatch

Dicho esto, el hacerlo tampoco garantiza que el ticket se mueva.

medber

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #852 en: 13-12-2015, 02:02 (Domingo) »
He actualizado mis dos mensajes [1] y [2]

peperfus

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #853 en: 13-12-2015, 13:32 (Domingo) »
Hola.  Perdonad si esto ya se ha preguntado ya, pero, se puede usar este Router como Router neutro? Es decir, de una red de un puerto ethernet a otra red del switch.... J?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2115
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #854 en: 13-12-2015, 19:26 (Domingo) »
Hola.  Perdonad si esto ya se ha preguntado ya, pero, se puede usar este Router como Router neutro? Es decir, de una red de un puerto ethernet a otra red del switch.... J?

Darse un paseo por los hilos relevantes nunca viene mal: https://foro.seguridadwireless.net/openwrt/luci-configurar-puerto-lan-como-wan/
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

peperfus

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #855 en: 13-12-2015, 20:11 (Domingo) »
Hola.  Perdonad si esto ya se ha preguntado ya, pero, se puede usar este Router como Router neutro? Es decir, de una red de un puerto ethernet a otra red del switch.... J?

Darse un paseo por los hilos relevantes nunca viene mal: https://foro.seguridadwireless.net/openwrt/luci-configurar-puerto-lan-como-wan/

Gracias por el enlace; no sabía que esto se podía hacer de forma genérica; creía que era configuración específica de cada router.
Entonces genial !
Cada vez me gusta más OpenWrt

Por cierto, he encontrado que venden unidades de este router de segunda mano aquí en mi pueblo, a 20 euros. ¿Lo veis caro? ¿Qué precio sería razonable? Tengo pensado pillarme al menos uno más para seguir trasteando y ponerlo en otro domicilio.

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #856 en: 13-12-2015, 21:15 (Domingo) »
Yo el más barato que he conseguido ha sido por 6 €. Por lo general la gente pide 10 € pero suelen bajar a 8 €. Luego ha gente que pide más como lo que indicas e incluso 30, y una vez vi uno que pedía 80 €, no se si lograrán venderlos a ese precio pero alguien que tenga mínimo de idea sabe que por esos precios te puedes coger un router nuevo con wifi ac, todos los puertos gigalan y características similares de memoria y procesador.

Por otro lado avisarte de que tienes que tener en cuenta lo siguiente a la hora de acertar con el modelo, que no tenga delante en botón redondo de wps porque ese es el livebox 2 y no el livebox 2.1. Además existe una versión reciente que no tiene nada que ver con el ARV7519 y es el ARV7520, visualmente por fuera es idéntico salvo porque cuenta con solo 1 usb en vez de dos, creo recodar que tiene el de atrás y la falta el del lateral.

pipiolo

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #857 en: 14-12-2015, 19:18 (Lunes) »

Por cierto, he encontrado que venden unidades de este router de segunda mano aquí en mi pueblo, a 20 euros. ¿Lo veis caro? ¿Qué precio sería razonable? Tengo pensado pillarme al menos uno más para seguir trasteando y ponerlo en otro domicilio.


Aunque parezca mentira se pueden comprar NUEVOS por menos de 15 €
http://www.amazon.es/Livebox-firmware-Astoria-Networks-ARV7519RW22-/dp/B017V6YYAC/ref=sr_1_1?s=computers&ie=UTF8&qid=1450116930&sr=1-1&keywords=livebox

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #858 en: 15-12-2015, 21:30 (Martes) »
Buenas,

Acabo de mandar el parche arreglando el tema de los botones.

Saludos.

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #859 en: 16-12-2015, 16:40 (Miércoles) »
Justo iba a enviarlo yo también conjunto a otros parches como me han indicado en uno de los tickets que abrí. He mandado un parche que hace el cambio de esquema de particiones para uboots nuevos y además he propuesto un cambio de nombre del dispositivo, por un lado poner Arcadyan al ser el último manufacturador y además en el menuconfig que salga al estilo de otro dispositivo que también muestra el nombre comercial y el de manufacturador del aparato. También le he especificado que es la versión 2.1 de Livebox.