Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 362493 veces)

0 Usuarios y 4 Visitantes están viendo este tema.

howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #920 en: 05-04-2016, 14:43 (Martes) »
Han metido para el kernel 4.6 las instancias de dwc2 para las placas lantiq arx100 y vrx200, con ello para esa versión en cuestión del módulo dwc2 solo haría falta el parche para activar los gpio de 5V de los usb y lo demás estaría ya soportado desde el propio kernel.

Los parámetros que hay en el kernel para lantiq son iguales que los que ya se tenían en openwrt que había sacado blogic salvo el de max_transfer_size, que en openwrt es de -1 (autodetectar) y en el kernel lo han metido de 65535. Si puedo buscaré a ver si encuentro el comentario de cuando lo modificaron pero dan ganas de probar a recompilar trunk usando ese valor por si acaso solventase los problemas que todavía quedan con los usb. De todas maneras en la 4.5 ya comenté que había más cambios en el módulo dwc2 pero resulta que en la 4.6 ya van también unos cambios enormes en dicho módulo.

En un entorno de 16 bits, 65535 y -1 representan el mismo número binario.  ;)

Tenía entendido que en los parámetros de dwc2 el -1 era autodetectar pero ciertamente lo que dices no te lo rebato xD. Lo que me extraña es que los demás valores los dejen como -1.

francisgambin yo he usado varios, zd1211rw, prism54, rt2500, rt2800... y la verdad cada uno hace cosas raras a su manera, pero he podido activar wifi con todos, incluso con el rt2800 hacer múltiples redes wifi con el mismo pincho.



howl

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #921 en: 06-04-2016, 14:42 (Miércoles) »
Acabo de probar un mt7601 y no funciona correctamente, se pueden crear redes y conectarlo a otras pero como si nada. Si que funciona sobre un "pc estándar".

Un r8712u tampoco funciona pero no estoy seguro de porque sea ya que tampoco funciona correctamente en una distribución típica de Linux sobre un hardware con buen soporte USB así que pudiera ser específicamente problema de este pincho concreto con ese módulo, ya que se usa para varios modelos de chip.

Intuyo que los problemas radican en el soporte usb de dwc2, creo que podría intentar sacar el diff del módulo dwc2 hasta el kernel 4.6 cuando salga y a ver si puedo meter un parche en openwrt. En principio salvo que tenga cambios que afecten a otras partes que no sean el propio módulo dwc2 solo sería quitar el parche de adición de los parámetros para lantiq (ya van incluidos upstream), mantener el parche de activación de gpio y listo.

jb61uk

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #922 en: 15-04-2016, 17:24 (Viernes) »
Hola.

Tengo uno de estos routers.

Lo resete a los valores de fabrica e instala openwrt. No quedo muy estable y lo volvi a reinstalar a traves de Luci.
El caso es que creo que se ha quedado "frito".
Solo se enciende la luz del power, no responde al ping, conectando con un puerto serial no hay señal desde el terminal en linux (gtktefrm).

¿Hay alguna forma de devolverlo  la vida?

Gracias.

ppfdez

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #923 en: 18-04-2016, 01:45 (Lunes) »
Hola compañeros. Os voy a plantear el problema que me acaba de surgir.

Tengo dos livebox que son:

Citar
ARV7519RW22-A-LT              HW Versión R01 FW Versión V00.95.005
ARV7519RW22-A-LT VR9 1.2 HW Versión R02 FW Versión V00.96.114

He decidido trastear con el segundo el R02.

Le he metido el u-boot que aparece en el primer post para la R02 (el 512.bin), seguidamente le he metido el open-wrt (gentileza de Pteridium) y después de la instalación y el reseteo, llego hasta el anagrama de openwrt y le cambio la clave para poder entrar por SSH. Hasta aqui todo perfecto. Los problemas son:

1º. Solo funcionan los puertos 1 y 3
2º. No arranca luci ni a tiros

1º. Puedo entrar por SSH
2º. Puedo hacer ping al 192.168.1.1

Lo que está en la cita lo he tomado de la pegatina que tiene debajo los routers. Al abrirlo observo que en ambos trae serigrafiado en la placa, P/N:141751920003J R01 y me pregunto ¿Serán ambos de la versión R01?

Por probar le he metido el u-boot (por loady) de la R01 y ocurre igual solo funcionan los puertos 1 y 3 y no puedo entrar en luci, puedo hacer pin, entrar por telnet, cambiar la clave, ver los distintos archivos que hay en /etc/config/.

Con el otro el R01, el boot que le puse era el que había en el primer post que servía para ambos y funcionan los cuatro puertos.

¿Podéis arrojar un poco de luz sobre este problema?
No hombre no...
En principio y hasta donde yo se las pegatinas están bien. Para salir de dudas fijate durante el arranque del u-boot si pone:
Código: [Seleccionar]
ROM VER: ��!D

U-Boot 2014.01-openwrt1 (May 16 2014 - 00:08:52) arv7519rw

Board: Lantiq ARV7519RW VRX200 Family Board
SoC:   Lantiq VRX288 v1.1
CPU:   500 MHz
IO:    250 MHz
BUS:   250 MHz
BOOT:  NOR
DRAM:  128 MiB
Flash: 32 MiB

Si pone :
SoC:   Lantiq VRX288 v1.1 -> Versión 1.1
SoC:   Lantiq VRX288 v1.2 -> Versión 1.2

Este el el u-boot que estoy usando yo, es válido tanto para la versión v1.1 como para la v1.2, detecta todos los puertos y Tambien los 128Mb de Ram.
https://www.dropbox.com/s/2u2fe9qxqznl0y6/u-boot.bin.tar.gz

¿Como podría obtener este u-boot que parece que es el bueno?. Al picar el enlace DROPBOX dice
"Error (429) This account's links are generating too much traffic and have been temporarily disabled!"
Agradecería mucho otro link para poder descargarmelo.
Gracias antipadamente.

Me contesto a mi mismo:
la versión de Lesgar (https://foro.seguridadwireless.net/profile/?u=134695), referenciada por howl (https://foro.seguridadwireless.net/profile/?u=170210) en su mensaje https://foro.seguridadwireless.net/openwrt/(desarrollo)-openwrt-en-astoria-arv7519rw22-livebox-2-1/msg341444/#msg341444 es la buena y se puede descargar aquí  https://drive.google.com/file/d/0B0jPz3dRtaKNN3FkUDBra3FPdms/view?usp=sharing
« Última modificación: 20-04-2016, 10:55 (Miércoles) por ppfdez »

ppfdez

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #924 en: 20-04-2016, 15:30 (Miércoles) »
Hace unos días adquirí un "Astoria arv7519rw22" objeto de desarrollo en este hilo.

El primer post del hilo, certero en cuanto al procedimiento de reconversión a "la verdadera doctrina" ;-) , está desactualizado en cuanto a:

1) Versión de u-boot a usar: En su última actualización por Noltari (https://foro.seguridadwireless.net/profile/?u=132039) a 8/10/2014 se publica una versión de u-boot http://drive.google.com/uc?id=0ByrtEG1tVo67WEl5ZlQwRF90ems unificada para las 2 versiones de este router pero que reporta 64Mb de memoria ram, cuando deberían de ser 128 MB. Mirando mucho por todo el hilo y probando, la versión de Lesgar (https://foro.seguridadwireless.net/profile/?u=134695), referenciada por howl (https://foro.seguridadwireless.net/profile/?u=170210 ) en su post https://foro.seguridadwireless.net/openwrt/(desarrollo)-openwrt-en-astoria-arv7519rw22-livebox-2-1/msg341444/#msg341444 es buena hasta donde yo he probado, reportando 128 MB y soportando el arranque y el funcionamiento de las compilaciones correctas de OpenWrt para este router. Se puede descargar en https://drive.google.com/file/d/0B0jPz3dRtaKNN3FkUDBra3FPdms/view?usp=sharing
2) las imagenes openwrt https://www.mediafire.com/?d5taxtqw66ze779 estan obsoletas.

Estabilizada al menos aparentemente la cuestión del u-boot, el desarrollo OpenWrt para este router esta de la siguiente manera:
1) Las versiones estables y oficales Barrier Breaker 14.07 en https://downloads.openwrt.org/barrier_breaker/14.07/lantiq/xrx200/ no atienden a la lan.
2) Las versiones estables y oficiales de Caos Calmer 15.05 https://downloads.openwrt.org/chaos_calmer/15.05/lantiq/xrx200/ y 15.05.1 https://downloads.openwrt.org/chaos_calmer/15.05.1/lantiq/xrx200/ producen un "kernel panic".
3) Existen tickets en la línea OpenWrt oficial de desarrollo sin resover, como éste https://dev.openwrt.org/ticket/18372 desde hace casi año y medio.
4) La línea trunk https://downloads.openwrt.org/snapshots/trunk/lantiq/ a día de hoy no está contemplando a este router.
5) Existen varias compilaciones particulares mas o menos afortunadas que funcionan. La para mí, más oficiosa, compatible con el repositorio oficial, es la disponible en la pagina http://practicalfoss.blogspot.com.es/2015/11/openwrt-1505-for-orange-livebox-21.html de nuestro forero medber (https://foro.seguridadwireless.net/profile/?u=167062) que colabora con una buena colección de imágenes para este router https://foro.seguridadwireless.net/openwrt/%28desarrollo%29-openwrt-en-astoria-arv7519rw22-livebox-2-1/msg339028/#msg339028 .

Ante esta situación, al día de hoy y sin compilar, se puede tener un router funcional a nivel Caos Calmer 15.05 al que se le pueden añadir paquetes del repositorio oficial salvo que necesiten un módulo kernel en cuyo caso es imposible su disponibilidad salvo compilando desde el repositorio recomendado en https://wiki.openwrt.org/toh/arcadyan/arv7519 apartado Nota importante. Verbigracia, sin compilar, lo que no esta al alcance de todos, no se puede usar como router fibra movistar desarrollado en el gran hilo de referencia, https://foro.seguridadwireless.net/openwrt/%28tutorial%29-movistar-ftth-con-openwrt/ conducido por Noltari.

Siguen existiendo los problemas de la no disponibilidad de driver WIFI, de la no habilitación del segundo core del SOC y de la no disponibilidad de control sobre el chip para Voip con 2 conexiones RJ11, que vendrían muy bien para su uso como 2 líneas de teléfono adicionales en las conexiones a FTTH.

Salu2
« Última modificación: 21-04-2016, 00:10 (Jueves) por ppfdez »

Bishop007

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #925 en: 21-04-2016, 12:48 (Jueves) »
Buenas a tod@s,

He estado trasteando con un LiveBox ARV7519RW22-A-LT HW Version R01, le he conectado el Serial así
Placa -- Serial
  1           No conectado
  2           3
  3           2
  4           5
He puenteado R148 y R155, configurado el Putty así:
Speed            115200
Data bits        8
Stop bits        1
Parity             None
Flow control   None
=======================
No consigo ver la información que indicáis en el post inicial, solo unos caracteres ilegibles y no se enciende ninguna luz.
Antes de puentear las R155 y R148 podía ver cómo pasaban cadenas de caractes sin sentido, y arrancaba.
Esta vista suele ocurrir cuando no configuras bien el Serial, alguien me puede confirmar que es el pinado correcto y la configuración de Serial correcta???

Muchas gracias. Gracias a tod@s por la info aquí encontrada.  ;)

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1980
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #926 en: 21-04-2016, 16:24 (Jueves) »
Buenas a tod@s,

He estado trasteando con un LiveBox ARV7519RW22-A-LT HW Version R01, le he conectado el Serial así
Placa -- Serial
  1           No conectado
  2           3
  3           2
  4           5
He puenteado R148 y R155, configurado el Putty así:
Speed            115200
Data bits        8
Stop bits        1
Parity             None
Flow control   None
=======================
No consigo ver la información que indicáis en el post inicial, solo unos caracteres ilegibles y no se enciende ninguna luz.
Antes de puentear las R155 y R148 podía ver cómo pasaban cadenas de caractes sin sentido, y arrancaba.
Esta vista suele ocurrir cuando no configuras bien el Serial, alguien me puede confirmar que es el pinado correcto y la configuración de Serial correcta???

Muchas gracias. Gracias a tod@s por la info aquí encontrada.  ;)

¿Qué tipo de "serial" estás utilizando? Porque si lo estás enganchando directamente al "serial" del PC, lo tienes crudo. El puerto serie del PC va de +12v a -12v, el puerto serie del router, de 0v a 3,3v. Si los conectas directamente, lo más seguro es que te lo cepilles.
Utiliza un adaptador de puerto serie USB/TTL.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

ppfdez

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #927 en: 21-04-2016, 23:47 (Jueves) »
Buenas a tod@s,

He estado trasteando con un LiveBox ARV7519RW22-A-LT HW Version R01, le he conectado el Serial así
Placa -- Serial
  1           No conectado
  2           3
  3           2
  4           5
He puenteado R148 y R155, configurado el Putty así:
Speed            115200
Data bits        8
Stop bits        1
Parity             None
Flow control   None
=======================
No consigo ver la información que indicáis en el post inicial, solo unos caracteres ilegibles y no se enciende ninguna luz.
Antes de puentear las R155 y R148 podía ver cómo pasaban cadenas de caractes sin sentido, y arrancaba.
Esta vista suele ocurrir cuando no configuras bien el Serial, alguien me puede confirmar que es el pinado correcto y la configuración de Serial correcta???

Muchas gracias. Gracias a tod@s por la info aquí encontrada.  ;)
Si el router viene "virgen" y funciona perfectamente en el ámbito para el que se fabricó, para "convertirlo a la verdadera fé" no tienes que hacer los puentes para nada. Solo conectar masa con masa y el TXdata con el Rxdata y viceversa; dar los tres espacios y pegar la contraseña con el boton derecho del ratón en putty y ....... sigue post 1 del hilo.

P.D.: El puenteo creo que se hace cuando tenemos el u-boot perdido que no debe de haberte ocurrido y en todo caso, como apunta Noltari, no directamente sino con resistencias de 470 Ohmios para evitar accidentes no deseados  ???.
« Última modificación: 21-04-2016, 23:52 (Jueves) por ppfdez »

Bishop007

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #928 en: 23-04-2016, 16:16 (Sábado) »
Buenas a tod@s,

He estado trasteando con un LiveBox ARV7519RW22-A-LT HW Version R01, le he conectado el Serial así
Placa -- Serial
  1           No conectado
  2           3
  3           2
  4           5
He puenteado R148 y R155, configurado el Putty así:
Speed            115200
Data bits        8
Stop bits        1
Parity             None
Flow control   None
=======================
No consigo ver la información que indicáis en el post inicial, solo unos caracteres ilegibles y no se enciende ninguna luz.
Antes de puentear las R155 y R148 podía ver cómo pasaban cadenas de caractes sin sentido, y arrancaba.
Esta vista suele ocurrir cuando no configuras bien el Serial, alguien me puede confirmar que es el pinado correcto y la configuración de Serial correcta???

Muchas gracias. Gracias a tod@s por la info aquí encontrada.  ;)
Si el router viene "virgen" y funciona perfectamente en el ámbito para el que se fabricó, para "convertirlo a la verdadera fé" no tienes que hacer los puentes para nada. Solo conectar masa con masa y el TXdata con el Rxdata y viceversa; dar los tres espacios y pegar la contraseña con el boton derecho del ratón en putty y ....... sigue post 1 del hilo.

P.D.: El puenteo creo que se hace cuando tenemos el u-boot perdido que no debe de haberte ocurrido y en todo caso, como apunta Noltari, no directamente sino con resistencias de 470 Ohmios para evitar accidentes no deseados  ???.
[/quote]

¿Qué tipo de "serial" estás utilizando? Porque si lo estás enganchando directamente al "serial" del PC, lo tienes crudo. El puerto serie del PC va de +12v a -12v, el puerto serie del router, de 0v a 3,3v. Si los conectas directamente, lo más seguro es que te lo cepilles.
Utiliza un adaptador de puerto serie USB/TTL.

[/quote]

Muchas gracias a los dos, lo estoy conectando ahora por un usb to serial con el pinado que puse antes pero sigo sin ver información entendible, solo código binario, he retirado los puentes porque funciona correctamente y lo que quiero es liberarlo.
¿Algún consejo?
Cambio de paridad o baudios, ¿son necesarias las resistencias en caso de un usb to serial?

Gracias por la ayuda.

Bishop007

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #929 en: 23-04-2016, 16:28 (Sábado) »
Muchas gracias por los comentarios, he retirado los puentes y conectado un usb to serial pero con esa configuración de serial solo veo código y no un interprete normal, no puedo operar sobre el router.
Alguna idea o consejo?? muchas gracias.

ppfdez

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #930 en: 29-04-2016, 18:53 (Viernes) »
Muchas gracias por los comentarios, he retirado los puentes y conectado un usb to serial pero con esa configuración de serial solo veo código y no un interprete normal, no puedo operar sobre el router.
Alguna idea o consejo?? muchas gracias.

Copias la contraseña "Oh!123Go" (sin las ") en el portapapeles.
Arrancas putty en modo serie comx 115200 8N1
Picas con el raton dentro de la ventana del putty
Arrancas el router e inmediatamente
  • das un espacio en el teclado
  • pegas el portapapeles que en el putty es dar al boton derecho del raton
y vualá ya estas en el boot. Ahora sigue con el post 1 del hilo. Suerte

fhocorp

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #931 en: 01-05-2016, 13:22 (Domingo) »
Hello

I have Livebox 2.1 too.
Did someone can send me à dump of the mtd5 partition on the Livebox 2.1 with Orange firmware ? Or did someone have the firmware files to be flashed via the webui ?

Sincerely

ppfdez

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #932 en: 02-05-2016, 01:18 (Lunes) »
Hello

I have Livebox 2.1 too.
Did someone can send me à dump of the mtd5 partition on the Livebox 2.1 with Orange firmware ? Or did someone have the firmware files to be flashed via the webui ?

Sincerely

I have mail you the firmware.

fhocorp

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #933 en: 02-05-2016, 01:58 (Lunes) »

I have mail you the firmware.

Nice thanks ! But the file size is ~ 32MB  This is the complete flashdump ? If yes, did you have all the parts of this flashdump ? I need only the mtd5 partition.

Best Regards

ppfdez

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #934 en: 02-05-2016, 18:53 (Lunes) »

I have mail you the firmware.

Nice thanks ! But the file size is ~ 32MB  This is the complete flashdump ? If yes, did you have all the parts of this flashdump ? I need only the mtd5 partition.

Best Regards

OK. I´ve e-mailed you mtd5.bin . Good luck.

batman2005

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #935 en: 20-05-2016, 06:15 (Viernes) »
Hola. A mi también me interesa el archivo del firmware original del livebox 2.1 si es superior a la versión 00.96.114.
Muchas gracias

fhocorp

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #936 en: 25-05-2016, 12:58 (Miércoles) »
Did someone have the firmware download URL when the livebox is updating ?  ???

Did someone have tried a dump of the flash on a Livebox with latest firmware ?

Best Regards
Gracias
« Última modificación: 25-05-2016, 12:59 (Miércoles) por fhocorp »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17388
  • Misántropo
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #937 en: 25-05-2016, 14:34 (Miércoles) »
Did someone have the firmware download URL when the livebox is updating ?  ???

Did someone have tried a dump of the flash on a Livebox with latest firmware ?

Best Regards
Gracias

Sorry, we don't get livebox support because legal problems with Orange.


saludos
« Última modificación: 25-05-2016, 14:36 (Miércoles) por drvalium »

fhocorp

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #938 en: 25-05-2016, 18:48 (Miércoles) »
Ok. Thanks

Someone can give me a VPN access to an orange ADSL o FTTH Line SVP ? Because the Orange Spain servers are not responding from Orange France IP addresses.

Best Regards

medber

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #939 en: 03-07-2016, 15:37 (Domingo) »
Hola a todos.

Comparto con vosotros la imagen LEDE r865 (3 Julio 2016).

Detalles:
* LEDE r865 + LuCI + IPv6 + QoS + USB WIFI (únicamente los que tienen modo N) + cURL + iperf3 + DnsCrypt/DNSSec + endurecida con opciones de seguridad (SSP/RELRO/..)  


También escribí una guía en Inglés que detalla todos los pasos para hacer el flash.

.
« Última modificación: 03-07-2016, 16:57 (Domingo) por medber »

//FINAL Y MÁS DOS RESPUESTAS