Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 407568 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

mega-samu

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #680 en: 16-09-2015, 19:52 (Miércoles) »
Tengo una duda, aun sigue sin funcionar el wifi en OpenWRT en este router?  ???



Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #681 en: 17-09-2015, 22:50 (Jueves) »
Tengo una duda, aun sigue sin funcionar el wifi en OpenWRT en este router?  ???
No oficialmente.
Hay algún driver por ahí que se puede encasquetar, pero ni idea de si funciona y/o si es estable.

Las únicas alternativas son pinchos wifi con chip Ralink o Atheros. Openwrt soporta algunos pinchos Realtek compatibles con el driver rtl8192cu pero la falntan funciones que los otros sí tienen.
« Última modificación: 17-09-2015, 22:53 (Jueves) por Pteridium »

Raugo

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #682 en: 18-09-2015, 17:48 (Viernes) »
Pteridium ¿donde has visto ese driver para el wifi? Porque seria interesante echarle un vistazo.

Saludos

Yo_Julio

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #683 en: 18-09-2015, 18:28 (Viernes) »
Hola Pteridium
He probado tu firm y me funciona, al menos para lo básico que yo necesitaba que es hacer de hub y compartir ficheros desde un pendrive.

Gracias por el firm
Salu2

joselete666

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #684 en: 20-09-2015, 20:27 (Domingo) »
Buenas a todos.

Después de comprarme el tls-usb y de poner los conectores en la placa descubro que no quiere tirar  ???.  Una mala conexión o averigua que puede ser.
Bueno a lo que iba he descubierto esto en una web por si interesa ha alguien.
http://tecnicaquilmes.fullblog.com.ar/analizando-el-livebox-21-de-orange.html

Saludos.
« Última modificación: 12-10-2015, 16:32 (Lunes) por joselete666 »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #685 en: 21-09-2015, 15:42 (Lunes) »
Buenas a todos.

Después de comprarme el tls-usb y de poner los conectores en la placa descubro que no quiere tirar  ???.  Una mala conexión o averigua que puede ser.
No descartes una mala soldadura. Para evitar sorpresas (que ya las tuve) yo sueldo en ambas caras de la placa.
Bueno a lo que iba he descubierto esto en una web por si interesa ha alguien.
http://tecnicaquilmes.fullblog.com.ar/analizando-el-livebox-21-de-orange.htm

Saludos.
Sí es interesante. ¡Buen hallazgo!

mega-samu

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #686 en: 22-09-2015, 18:04 (Martes) »
Pteridium ¿donde has visto ese driver para el wifi? Porque seria interesante echarle un vistazo.

Saludos

Lo comento un compañero anteriormente, por eso pregunte si ya funcionaba el wifi.

última versión del source del driver de la wifi, cortesia de lpm11.
Yo solo lo reposteo.
I uploaded it here: http://www.speedyshare.com/rgYPx/wave300-3.2.1.1.48.tar.gz (version from April 2012)
This needs more work, especially:
- Porting driver for kernel 3.10/3.18/next - there are some small changes and one have to reimplement (or drop) /proc/ debug information support
- Prepare OpenWRT WiFi driver for this driver. I did it with an older version - but this one has VAP support. One also have to patch libiwinfo (you can get statistics with one IOCTL) and lua scripts for LuCI.
OR
- rewrite driver to use cfg80211 instead of obsolete wext.
- Extract firmware and progmodels from OEM firmware (fmk tool will help you)

Aqui es donde esta la informacion de  que estan trabajando para conseguirlo (pero esta parado desde el comentario de lpm11)
https://forum.openwrt.org/viewtopic.php?id=45047
« Última modificación: 22-09-2015, 18:10 (Martes) por mega-samu »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #687 en: 23-09-2015, 15:45 (Miércoles) »
Pteridium ¿donde has visto ese driver para el wifi? Porque seria interesante echarle un vistazo.

Saludos

Lo comento un compañero anteriormente, por eso pregunte si ya funcionaba el wifi.

última versión del source del driver de la wifi, cortesia de lpm11.
Yo solo lo reposteo.
I uploaded it here: http://www.speedyshare.com/rgYPx/wave300-3.2.1.1.48.tar.gz (version from April 2012)
This needs more work, especially:
- Porting driver for kernel 3.10/3.18/next - there are some small changes and one have to reimplement (or drop) /proc/ debug information support
- Prepare OpenWRT WiFi driver for this driver. I did it with an older version - but this one has VAP support. One also have to patch libiwinfo (you can get statistics with one IOCTL) and lua scripts for LuCI.
OR
- rewrite driver to use cfg80211 instead of obsolete wext.
- Extract firmware and progmodels from OEM firmware (fmk tool will help you)

Aqui es donde esta la informacion de  que estan trabajando para conseguirlo (pero esta parado desde el comentario de lpm11)
https://forum.openwrt.org/viewtopic.php?id=45047
Personalmente no tengo esperanzas en que Lantiq (ahora parte de Intel) libere o haga un driver libre, aunque tenga funciones limitadas. Se han subido al carro de proteger su código y poner licencias restrictivas y de ahí no se apean.
Con los Danube las licencias eran mucho menos restrictivas, con lo que en OpenWRT se incluyen los firms de adsl y voip, pero para los VR9 hay que buscarse la vida para varias cosas.

En fin, cada compañía tiene sus políticas y maneras de funcionar que, aunque nos gusten o no, hay que respetarlas.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #688 en: 24-09-2015, 11:31 (Jueves) »
Buenas noches,

Estoy intentando compilar para pruebas sobre la versión 15.05 RC3 pero como siempre me da kernel panic. Según comentáis hay que quitar el parche multiple-flash.patch pero no se como va el proceso, es decir si se trata solamente de eliminar y después compilar sin mas?

Ya he compilado para otros dispositivos sin mayor problema pero este no doy pie con bola, estoy algo perdido en el asunto y os pido un poco de luz.

saludos y gracias
Lo que hay que cambiar es una línea en el dts y ya está. Cuando gmtii comenzó con este router usó como base para el dts otro router que tenía dos chips de flash y desde que introdujeron el parche mencionado apareció el problema.
Cambiando la línea 21 por
Código: [Seleccionar]
reg = <0x0 0x2000000>; se resuelve el problema.

Intentaré mandar el parche lo antes posible.
Noltari mandó un parche en condiciones que además de este problema mejora el algunas cosillas en Desiganated Driver (trunk) y también corrige un problema con unos de los puertos USB que parece que apareció cuando blogic cambió del driver usb de Lantiq a DWC2 en los routers que usan SoC VR9 como el ARV7519RW.
Todavía no se ha incluido en OpenWRT pero esperemos que pronto esté añadido.

TheMrRafus

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #689 en: 25-09-2015, 10:44 (Viernes) »
Hola

Alguien tiene el backup original de la flash para este router??

Saludos


francisgambin

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #690 en: 25-09-2015, 20:35 (Viernes) »
Hola

Alguien tiene el backup original de la flash para este router??

Saludos



Buenas tardes,

Yo tengo un backup que realice con la instalación, es eso lo que quieres?

saludos

rulasss

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #691 en: 05-10-2015, 03:21 (Lunes) »
Hola, tengo un minúsculo problema, a ver si alguien me puede ayudar con esto  :-\
Resulta que le estaba soldando unos cablecitos para dejarlo mono y hacer el corto desde la parte de arriba de la placa con unos interruptores smc, cuando sin querer, uno de los cablecitos se enganchó un poco (cables de RJ45 del bueno, osease, gorditos) y me arrancó el punto de soldadura con el de la placa  ^-^, y como no se de donde sale, no puedo soldar a ningún punto cercano, es que realmente no se de donde sale la pista, aunque pienso que sale directo del chip de arriba, pero no se   ???
A ver si alguien sabe o puede ver de donde sale y puedo soldar a otro punto o pelar la pista por donde vaya y soldar.
Os dejo unas imagenes de mi desastre. Por cierto, el punto es el de la R148 el que está pegado a la inexistente R149.

http://i.imgur.com/RZfaL0o.jpg
http://i.imgur.com/xQxiC6v.jpg
http://i.imgur.com/M9zyG10.jpg
http://i.imgur.com/VX9ycj8.jpg
http://i.imgur.com/i3UNJrv.jpg
http://i.imgur.com/LZfR3GT.jpg
http://i.imgur.com/kd2Wr9g.jpg

Las dejo así porque no se cómo las puedo poner para que no ocupen demasiado. En imgur no me las redujo, asi que no se como hacerlo  :-\


cmax091

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #692 en: 08-10-2015, 08:05 (Jueves) »
Necesitaría que alguien subiera un backup del firmware original v00.96.114 o superior.

Gracias de antemano y felicidades por la labor que estáis realizando. 

caaruizbe

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #693 en: 09-10-2015, 00:45 (Viernes) »
Hola, tengo un minúsculo problema, a ver si alguien me puede ayudar con esto  :-\
Resulta que le estaba soldando unos cablecitos para dejarlo mono y hacer el corto desde la parte de arriba de la placa con unos interruptores smc, cuando sin querer, uno de los cablecitos se enganchó un poco (cables de RJ45 del bueno, osease, gorditos) y me arrancó el punto de soldadura con el de la placa  ^-^, y como no se de donde sale, no puedo soldar a ningún punto cercano, es que realmente no se de donde sale la pista, aunque pienso que sale directo del chip de arriba, pero no se   ???
A ver si alguien sabe o puede ver de donde sale y puedo soldar a otro punto o pelar la pista por donde vaya y soldar.
Os dejo unas imagenes de mi desastre. Por cierto, el punto es el de la R148 el que está pegado a la inexistente R149.

Pues tu problema no es tan minúsculo, he tenido que tirar placas enteras  por cosas así. sin embargo parece que aún queda un punto de donde soldar, en fin, estoy curioseando mi router y me he puesto a buscar una alternativa y parece que pin que mencionas (el pin de abajo de la r148) esta conectado con el pin de abajo de la r149.
A ver si alguien más lo confirma.

Saludos

rulasss

  • Visitante
Re: Re: Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #694 en: 09-10-2015, 01:02 (Viernes) »
Hola, tengo un minúsculo problema, a ver si alguien me puede ayudar con esto  :-
Resulta que le estaba soldando unos cablecitos para dejarlo mono y hacer el corto desde la parte de arriba de la placa con unos interruptores smc, cuando sin querer, uno de los cablecitos se enganchó un poco (cables de RJ45 del bueno, osease, gorditos) y me arrancó el punto de soldadura con el de la placa  ^-^, y como no se de donde sale, no puedo soldar a ningún punto cercano, es que realmente no se de donde sale la pista, aunque pienso que sale directo del chip de arriba, pero no se   ???
A ver si alguien sabe o puede ver de donde sale y puedo soldar a otro punto o pelar la pista por donde vaya y soldar.
Os dejo unas imagenes de mi desastre. Por cierto, el punto es el de la R148 el que está pegado a la inexistente R149.

Pues tu problema no es tan minúsculo, he tenido que tirar placas enteras  por cosas así. sin embargo parece que aún queda un punto de donde soldar, en fin, estoy curioseando mi router y me he puesto a buscar una alternativa y parece que pin que mencionas (el pin de abajo de la r148) esta conectado con el pin de abajo de la r149.
A ver si alguien más lo confirma.

Saludos
Muchas gracias por contestar. Lo ideal seria tener un diagrama o esquema de la placa, pero no se si lo habrá por ahi...

Enviado desde mi SM-T110 mediante Tapatalk


manty

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #695 en: 22-10-2015, 23:17 (Jueves) »
Buenas.

He recibido una livebox nueva de Orange y pensaba utilizarla para hacer las pruebas antes de flashear a la que tengo en producción, pero me he llevado una sorpresa al ver que no es una livebox 2.1 como las de este hilo, sino algo más moderno: ARV7520CW22-A-LT reza el bicho

Lo comento por si acaso a alguien se le da por intentar meter uno de los firmwares de por aquí en dicho bicho, ha cambiado, aunque supongo que no en el fondo, pero me da que los uboot y el openwrt habrá que cocinarlos de nuevo.

Dejo por aquí (si me deja el señor foro) un enlace al drive con unas fotos.

https://drive.google.com/open?id=0BzGZ-HlECc0-aTRUb0h0dHZDZm8

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2185
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #696 en: 23-10-2015, 08:34 (Viernes) »
Buenas.

He recibido una livebox nueva de Orange y pensaba utilizarla para hacer las pruebas antes de flashear a la que tengo en producción, pero me he llevado una sorpresa al ver que no es una livebox 2.1 como las de este hilo, sino algo más moderno: ARV7520CW22-A-LT reza el bicho

Lo comento por si acaso a alguien se le da por intentar meter uno de los firmwares de por aquí en dicho bicho, ha cambiado, aunque supongo que no en el fondo, pero me da que los uboot y el openwrt habrá que cocinarlos de nuevo.

Dejo por aquí (si me deja el señor foro) un enlace al drive con unas fotos.

https://drive.google.com/open?id=0BzGZ-HlECc0-aTRUb0h0dHZDZm8


No se ve cuál es el procesador principal, que es lo más interesante en estos "bichos". Para saber si puede tener soporte, hay que averiguar el procesador que lleva y los componentes.
El procesador está debajo del disipador grande, pero puede que no se pueda quitar y que el disipador esté totalmente pegado, así que al intentarlo lo puedes estropear. Prueba a forzar un poquito a ver qué pasa. Si no, otra forma de saberlo es con el log de arranque por el puerto serie, que parece que está al lado de la flash (conector X1), por las fotos que pones, pero saber el pinout exacto ya es otra cosa. Yo auguraría que TX/RX son los pines del centro (no sé en qué orden), y que GND es el más alejado del triángulo.
[Tutorial] Puerto Serie - Cómo Acceder
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #697 en: 23-10-2015, 12:05 (Viernes) »
Buenas.

He recibido una livebox nueva de Orange y pensaba utilizarla para hacer las pruebas antes de flashear a la que tengo en producción, pero me he llevado una sorpresa al ver que no es una livebox 2.1 como las de este hilo, sino algo más moderno: ARV7520CW22-A-LT reza el bicho

Lo comento por si acaso a alguien se le da por intentar meter uno de los firmwares de por aquí en dicho bicho, ha cambiado, aunque supongo que no en el fondo, pero me da que los uboot y el openwrt habrá que cocinarlos de nuevo.

Dejo por aquí (si me deja el señor foro) un enlace al drive con unas fotos.

https://drive.google.com/open?id=0BzGZ-HlECc0-aTRUb0h0dHZDZm8


No se ve cuál es el procesador principal, que es lo más interesante en estos "bichos". Para saber si puede tener soporte, hay que averiguar el procesador que lleva y los componentes.
El procesador está debajo del disipador grande, pero puede que no se pueda quitar y que el disipador esté totalmente pegado, así que al intentarlo lo puedes estropear. Prueba a forzar un poquito a ver qué pasa. Si no, otra forma de saberlo es con el log de arranque por el puerto serie, que parece que está al lado de la flash (conector X1), por las fotos que pones, pero saber el pinout exacto ya es otra cosa. Yo auguraría que TX/RX son los pines del centro (no sé en qué orden), y que GND es el más alejado del triángulo.
[Tutorial] Puerto Serie - Cómo Acceder
Si tuviera que apostar diría que está lleva un ARX388 porque le falta el AFE que llevan los VR9.
Si acierto adiós a la wifi, pero no debiera ser complicado darle soporte para openwrt.

manty

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #698 en: 24-10-2015, 22:40 (Sábado) »
Lo siento porque aunque me quedé con las ganas de pillar los logs de arranque no tenía ganas de quemar nada, así que lo he puesto a funcionar, sobre lo del micro el pegamento no parecía demasiado duro, pero tenía miedo de j*der todo, así que no tiré mucho y no salió.

El cacharro no me tenía mucho interés porque sólo tiene 4 puertos Fast Ethernet y uno USB, o sea, parece una versión capada del 2.1 en la que pierde el giga y uno de los USB. Lo bueno podría ser que la wifi estuviera soportada, entonces sí tendría algún interés, pero asumí que sería similar a la del 7519 y por lo tanto sin soporte.

Si en el futuro veo que tengo ocasión (ahora mismo no tengo tiempo) intento hacerme con un log.

rulasss

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22
« Respuesta #699 en: 25-10-2015, 04:07 (Domingo) »
mie.....*piiiiiiii*!!!!! Me cargué el regulador de voltaje al hacer el corto. Resulta que cualquiera de los dos cortos no dejaba arrancar el router y por probar se me ocurrió hacerlo con el encendido con una "pulsación rápida", hizo un ruido y se murió  :'(
El regulador es el que está debajo de los dos condensadores grandes (mirandolo con los puertos rj45 hacia arriba).
Ahora es casi imposible conseguirlo por internet, cobran demasiado por el chip, para eso me pillo uno de segunda mano  :-\
MORALEJA: Tened cuidado con los cortos en este router  :-[