Autor Tema: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack  (Leído 453697 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15451
Re: PixieScript v2.5, ataque automatizado Pixie Dust Attack
« Respuesta #340 en: 08-05-2015, 22:37 (Viernes) »
voy a "hablar por hablar"


siendo maquina virtual ,cuando reseteamos el driver la tarjeta es como desconectada..


¿no sera que se pierde hay la tarjeta?

¿por que siempre es con maquina virtual?

¿por que no hacen lo mismo desde un usb para ver que pasa ?



5.1

  • Visitante
Re: PixieScript v2.5, ataque automatizado Pixie Dust Attack
« Respuesta #341 en: 08-05-2015, 23:02 (Viernes) »
voy a "hablar por hablar"


siendo maquina virtual ,cuando reseteamos el driver la tarjeta es como desconectada..


¿no sera que se pierde hay la tarjeta?

¿por que siempre es con maquina virtual?

¿por que no hacen lo mismo desde un usb para ver que pasa ?

En la 2.5 no reseteo la interface. A raiz de la conversación que tuvimos sobre el origen de la "manía" de resetear la interface y que te preguntabas si servía para algo, decidí no resetear en esa versión a ver si disminuian las incidencias con algunos chipsets, y me da la impresión de que así fue.

Si te fijas en la funcion puse un comentario al respecto.


Código: [Seleccionar]
ResetInterface() {
DRIVER=`ls -l /sys/class/net/$TARJETA_SELECCIONADA/device/driver | awk -F '/' '{print $NF}'`

####
DesactivarMONsX
unset DRIVER
return 0
##### Por ahora deshabilito el resto de la función por los problemas de desaparecer las interfaces de red

rmmod -f "$DRIVER" >/dev/null 2>&1
if [ "$DRIVER" = "ath9k_htc" ]
then
ifconfig $TARJETA_SELECCIONADA >/dev/null 2>&1
while [ $? -eq 0 ] #esperamos a que se desactive el módulo de la interfaz
do
ifconfig $TARJETA_SELECCIONADA >/dev/null 2>&1
done
fi
modprobe "$DRIVER" >/dev/null 2>&1
if [ "$DRIVER" = "ath9k_htc" ]
then
ifconfig $TARJETA_SELECCIONADA >/dev/null 2>&1
while [ $? -ne 0 ] #esperamos a que se active el módulo de la interfaz
do
ifconfig $TARJETA_SELECCIONADA >/dev/null 2>&1
done
fi
}
« Última modificación: 08-05-2015, 23:04 (Viernes) por 5.1 »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15451
Re: PixieScript v2.5, ataque automatizado Pixie Dust Attack
« Respuesta #342 en: 08-05-2015, 23:46 (Viernes) »
OK , entonces donde dije digo dije diego.   ;D

calorro

  • Visitante
Re: PixieScript v2.5, ataque automatizado Pixie Dust Attack
« Respuesta #343 en: 09-05-2015, 23:06 (Sábado) »
estado probando la ultima  iso veta  que lleva  i PixieScript  me e dado cuenta que tiene un error cuando buscas las redes  y seleccionas ejemplo te salen 1.2.3.4.5.6.7 redes yo selecciono a tacar la red numero  7  pues me ataca la  primera redes no seleccionada  .
saludos .

zaratustra

  • Visitante
Re: PixieScript v2.5, ataque automatizado Pixie Dust Attack
« Respuesta #344 en: 10-05-2015, 18:52 (Domingo) »
Hola, pues si que tengo el archivo, tambien me he dado cuenta que tarda un tiempo en aparecer el programa en el menu de wpa wps, que cosa mas rara, no se si tendra algo que ver que estoy en escritorio virtual...

5.1

  • Visitante
Re: PixieScript v2.5, ataque automatizado Pixie Dust Attack
« Respuesta #345 en: 10-05-2015, 19:15 (Domingo) »
estado probando la ultima  iso veta  que lleva  i PixieScript  me e dado cuenta que tiene un error cuando buscas las redes  y seleccionas ejemplo te salen 1.2.3.4.5.6.7 redes yo selecciono a tacar la red numero  7  pues me ataca la  primera redes no seleccionada  .
saludos .

El error es tuyo no del script, estás seleccionando "atacar todos" y deberias seleccionar "Atacar AP seleccionado"


10/5/2015 ACTUALIZADA LA BASE DE DATOS DE VULNERABLES, ACTUALIZAR DESDE EL PROPIO SCRIPT
« Última modificación: 10-05-2015, 20:08 (Domingo) por 5.1 »

calorro

  • Visitante
Re: PixieScript v2.5, ataque automatizado Pixie Dust Attack
« Respuesta #346 en: 10-05-2015, 21:41 (Domingo) »
5.1 pues que va yo solo selecciono atacar a una app   

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15451
Re: PixieScript v2.5, ataque automatizado Pixie Dust Attack
« Respuesta #347 en: 10-05-2015, 22:07 (Domingo) »
5.1 pues que va yo solo selecciono atacar a una app   

fijate mas, hay una lista de tres acciones...

elige atacar seleccionada y despues atacar.

calorro

  • Visitante
Re: PixieScript v2.5, ataque automatizado Pixie Dust Attack
« Respuesta #348 en: 11-05-2015, 11:51 (Lunes) »
pues nose 5.1 boy a bolver a probarlo bien no sea que se me pasara algo aun que lo dudo

5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #349 en: 13-05-2015, 14:27 (Miércoles) »
Actualizado a la versión 2.6 .... fase testing ....

rapcat

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #350 en: 13-05-2015, 17:34 (Miércoles) »
Obtenidas un 6A:CD:BE  y un 6A:3D:FF (El primero no esta en la lista de bssid vulnerables)
Hace un rato he probado la version 2.6 y a la hora de escanear me salian mensajes de error: "Ha ocurrido un error escaneando redes" o " No se han detectado redes con wps activo".

saludos

5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #351 en: 13-05-2015, 18:08 (Miércoles) »
Obtenidas un 6A:CD:BE  y un 6A:3D:FF (El primero no esta en la lista de bssid vulnerables)
Hace un rato he probado la version 2.6 y a la hora de escanear me salian mensajes de error: "Ha ocurrido un error escaneando redes" o " No se han detectado redes con wps activo".

saludos

Cuando te de el error prueba lo siguiente .....
Sin cerrar el script, abre una terminal y pon :
Código: [Seleccionar]
cat /opt/PixieScript/LOGS/AIRODUMP.LOG | wc -l | awk {' print$1 '}¿Que te devuelve ?

Ahora cierra el script, mira en la carpeta /opt/PixieScript, debería haber un archivo pixiescript.log, si puedes pásamelo o copia aquí el contenido, nos debería dar una pista pq te falla el escaneo.
« Última modificación: 13-05-2015, 18:37 (Miércoles) por 5.1 »

najador

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #352 en: 13-05-2015, 18:25 (Miércoles) »
gracias por el pedazo de trabajo
he descargado la 2.6 antes de intentar instalar la nueva elimine el modulo de la 2.5 ¿hago algo mal?
intento instalar y me sale esto ayuda plees



¿que puede pasar? perdon por mi poco conocimiento
saludos

5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #353 en: 13-05-2015, 18:35 (Miércoles) »
¿ Pero has hecho lo que te pide ?
Código: [Seleccionar]
svn cleanup

najador

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #354 en: 13-05-2015, 18:47 (Miércoles) »
tenia instalada la 2.5  quite el modulo desde windows y encendi en modo live wifislas y procedi con la instalcion de la nueva version con internet y no se....
hare todo de nuevo intalciom de wifislax y pixie ;quizas tenga algo raro en la usb porque hoy por la mañana al arranquar windows y la usb metida me ha analizado la usb y me decia que habia arreglado sectores en la usb
y con tu respuesta y pensando un poco creo que es la usb
gracias por tu rapida respuesta
saludos

mat_ov

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #355 en: 13-05-2015, 18:55 (Miércoles) »
Una duda, yo tengo un netbook con una pantalla de 1024 x 600 y la ventana tiene un tamaño fijo; ¿no se podría hacer para que entrase en pantalla?

5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #356 en: 13-05-2015, 19:02 (Miércoles) »
Una duda, yo tengo un netbook con una pantalla de 1024 x 600 y la ventana tiene un tamaño fijo; ¿no se podría hacer para que entrase en pantalla?

Esa respuesta ya está contestada y con solución , la próxima vez usa el buscador

Abre el programa, despues  pincha con boton derecho del raton en la barra superior, mas acciones, preferencias especiales de la aplicacion, tamaño y posicion,y alli marcar la casilla de tamaño y forzar.

mat_ov

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #357 en: 13-05-2015, 21:41 (Miércoles) »
Tengo XFce de gestor de ventanas, esa opción no me sale.

A pantalla completa se ve toda la ventana.

Tengo la versión 2.5 y la 2.6. La 2.5 funciona correctamente, encuentra las redes.

La 2.6 no encuentra redes con WPS.

cat /opt/PixieScript/LOGS/AIRODUMP.LOG | wc -l | awk {' print$1 '}

me devuelve 0

wash -C -f /opt/PixieScript/CAPTURA-01.cap

me da

Wash v1.4-r119 WiFi Protected Setup Scan Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

[X] ERROR: Failed to open '(null)' for capturing





halfwurst

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #358 en: 13-05-2015, 21:57 (Miércoles) »
Obtenidas un 6A:CD:BE  y un 6A:3D:FF (El primero no esta en la lista de bssid vulnerables)
Hace un rato he probado la version 2.6 y a la hora de escanear me salian mensajes de error: "Ha ocurrido un error escaneando redes" o " No se han detectado redes con wps activo".

saludos

Hola,

Tengo el mismo problema. En PixieScript 2.5 múltiples redes con WPS activas parecen a mí, sin embargo, por lo que este puede no ser adecuado. Aquí el PixieScript.log: (sorry about the spanish, used google to translate..)

Código: [Seleccionar]
***************** ListarTarjetasWifi
***************** ActivarModoMonitor
***************** CheckInterface
***************** DeshabilitarNetworkManager
 
lo        no wireless extensions.
eth0      no wireless extensions.
***************** EscanearRedes
***************** ValidarTiempos
***************** ComprobarSesiones
***************** ProcesarDatosScaneo
Wash v1.4 WiFi Protected Setup Scan Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>
***************** Limpiar
***************** DeshabilitarNetworkManager
 
Interface Chipset Driver
wlan0 Unknown brcmsmac - [phy0]
mon0 Unknown brcmsmac - [phy0] (removed)
mon1 Unknown brcmsmac - [phy0]
reaver_pixie: no process found
airodump-ng: no process found
xclip: no process found
pixiewps: no process found
cpulimit: no process found

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15451
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #359 en: 13-05-2015, 23:19 (Miércoles) »
 ;)

A mi tampoco me escanea nada ..pero ya lo he cazado.

LEETELO BIEN POR QUE NECESITARAS VARIABLES AQUI

A ver , wash , para funcionar necesita usar el fichero  reaver.db

sI compilamos al estilo basico ...con solo un   ./configure

entonces al no fijar rutas , el fichero .db deberia estar en

/usr/local/etc/reaver/reaver.db

puede que el sistema ya tenga un reaver y el fichero .db ya este en el sistema ...

las rutas clasicas son , la que te puse ...si es el usuario el que lo instalo ,..por que no se matan mucho en los argumentos.


SI ES UN PAQUETE OFICIAL SUELE VENIR COMO DIOS MANDA

FIJADO A USR Y ETC


asi que no se exactamente como deberias montar

pero deberia mirar antes si el fichero  .db esta en alguna de las rutas

si esta en local ...entonces compila tu wash   ..sin argumentos extras ...


creo que se podria hacer facil


if  -f /etc/reaver/reaver.db ; then
CONFIG_REAVER="./configure --prefix=/usr --sysconfdir=/etc"
COPIAR_DB=NO
else
CONFIG_REAVER="./configure"
COPIAR_DB=SI
fi

luego revisar si hay que copiar el db ..y si es SI , meterlo en

/usr/local/etc/reaver/reaver.db


vamos , que si el archivo esta donde debe estar compila reaver como dios manda..

y si no esta en ese sitio ...pues configure y a tomar viento ...pero necesitaras copiar el .db


DE MOMENTO PARA SALIR DEL PASO ...MODIFICAR EL ARCHIVO INSTALADOR ..LINEA 123

./configure &> COMPILANDO_REAVER || ErroresDependencias 2


./configure --prefix=/usr --sysconfdir=/etc &> COMPILANDO_REAVER || ErroresDependencias 2
« Última modificación: 13-05-2015, 23:23 (Miércoles) por USUARIONUEVO »