Autor Tema: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack  (Leído 453803 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #360 en: 13-05-2015, 23:22 (Miércoles) »
o bien ...


dejas la compilacion fijada como dios manda


./configure --prefix=/usr --sysconfdir=/etc


y despues compruebas si existe el db  en  /etc/reaver/reaver.db

y si no existe , pues lo copias alli.   fin del drama.



________________________

esto habria que probarlo , pero igual puedes prefijar en

/opt/pixiscript/HERRAMIENTAS ... despues dentro de herramientas copias

una carpeta reaver y dentro el reaver.db  , asi seria mas limpio aun ..ya que no sobreescribirias ni dependerias de un .db existente.


« Última modificación: 13-05-2015, 23:25 (Miércoles) por USUARIONUEVO »

5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #361 en: 13-05-2015, 23:33 (Miércoles) »
Ummmm, ojala tengas razon,  me lo leo con calma....

Lo raro es que a mi no me ha fallado ni en WifiSlax ni en Linux Minst, que son las dos distros que tengo instaladas , supongo que me pilla el db del sistema.

En fin, ahora mismo me pongo a ello pq me tiene muy mosca el tema.

Muchas gracias USUARIONUEVO, no se que haria yo sin ti!! jejejeje

PD: Una cosa, la mejor forma de asegurarme que funciona bien, supongo que seria eliminar del sistema el reaverdb no? Me refiero el que viene por defecto con wifislax. Y una vez hecho eso hacer lo que me expicas en los 2 posts anteriores ... ¿Correcto?

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #362 en: 13-05-2015, 23:41 (Miércoles) »
Ummmm, ojala tengas razon,  me lo leo con calma....

Lo raro es que a mi no me ha fallado ni en WifiSlax ni en Linux Minst, que son las dos distros que tengo instaladas , supongo que me pilla el db del sistema.

En fin, ahora mismo me pongo a ello pq me tiene muy mosca el tema.

Muchas gracias USUARIONUEVO, no se que haria yo sin ti!! jejejeje

PD: Una cosa, la mejor forma de asegurarme que funciona bien, supongo que seria eliminar del sistema el reaverdb no? Me refiero el que viene por defecto con wifislax. Y una vez hecho eso hacer lo que me expicas en los 2 posts anteriores ... ¿Correcto?

por que seguro , tienes un db , en  /usr/local/etc/reaver/reaver.db


es eso seguro  ;D

estoy mirando de fijar las rutas de reaver hacia tu carpeta /opt/pixie    ;)

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #363 en: 13-05-2015, 23:47 (Miércoles) »
Ya lo tengo amigo  ;D


Fijadas las rutas de trabajo de wash , a tu carpeta , ahora si que JAMAS , un fichero tuyo sera sobreescrito ni tu sobreescribiras uno del sistema.


linea 123 , hacia abajo -.-.--

el modulo xzm , como copias la carpeta opt todo se mete automaticamente  ;D



Código: [Seleccionar]
./configure --prefix=$RUTA_HERRAMIENTAS --sysconfdir=$RUTA_HERRAMIENTAS &> COMPILANDO_REAVER || ErroresDependencias 2
make &>> COMPILANDO_REAVER || ErroresDependencias 2
echo "OK"
echo "        LIMPIANDO .................... OK "
cp reaver "$RUTA_HERRAMIENTAS/reaver_pixie"
cp wash "$RUTA_HERRAMIENTAS/wash"
# La carpeta reaver ya existe creamos una temporal y despues renombramos
mkdir -p $RUTA_HERRAMIENTAS/reaver2
cp reaver.db $RUTA_HERRAMIENTAS/reaver2/reaver.db
cd "$RUTA_HERRAMIENTAS"
rm -rf reaver
mv $RUTA_HERRAMIENTAS/reaver2 $RUTA_HERRAMIENTAS/reaver
else
echo "OK"
fi

echo -n "COMPROBANDO DEPENDENCIA PIXIEWPS ..... "

5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #364 en: 13-05-2015, 23:50 (Miércoles) »

Pero si para escanear no utilizo el reaver!!!!
Me explico, yo hago el escaneo con airodump-ng, y a continuacion con el wash analizo ese .cap
O sea, a no ser que wash tambien haga uso del reaver.db no lo entiendo.

Para mas inri acabo de mover /usr/local/etc/reaver/reaver.db y /etc/reaver/reaver.db al una carpeta en el escritorio, a continuación lanzo el script y me sigue escaneando perfectamente .....  ???
« Última modificación: 13-05-2015, 23:53 (Miércoles) por 5.1 »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #365 en: 13-05-2015, 23:52 (Miércoles) »
men , hazme caso  ;D


wash , WASH , para trabajar necesita el .db

y como tu ahora compilas uno propio , necesitas su db en la ruta de trabajo donde se configuro

como no se configuro nada ..


./configure

pues las rutas son las de por defecto de usuario  LOCAL


es wash ...aunque no lo uses para escanear , lo usas para parsear los .cap e identificar objetivos.


si tienes un wifislax LIVE  a mano , pruebalo ..y veras lo que te digo.


mueves wash , a tu  /opt  , pero te dejas el .db

antes como se usaba el de sistema , no te pasaba eso , por que el de sistema esta o.k

pero ahora al usar uno compilado ,hay que currarselo un poco mas ...fijate que solo meti un par de variables al configure...
« Última modificación: 13-05-2015, 23:54 (Miércoles) por USUARIONUEVO »

5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #366 en: 13-05-2015, 23:54 (Miércoles) »
men , hazme caso  ;D


wash , WASH , para trabajar necesita el .db

y como tu ahora compilas uno propio , necesitas su db en la ruta de trabajo donde se configuro

como no se configuro nada ..


./configure

pues las rutas son las de por defecto de usuario  LOCAL


es wash ...aunque no lo uses para escanear , lo usas para parsear los .cap e identificar objetivos.

Si si, si lo que dices tiene todo el sentido del mundo, pero no comprendo como es que habiendo movido los dos reaver.db que te comento en el post anterior me sigue funcionando....

EDIT : Vale, ya lo se, por lo visto me crea un reaver.db en /usr/local/etc/reaver/reaver.db automaticamente al lanzarlo.
« Última modificación: 13-05-2015, 23:58 (Miércoles) por 5.1 »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #367 en: 14-05-2015, 00:00 (Jueves) »
usa el buscador de ficheros ...y mira donde tienes mas reaver.db

 ;)


esto que te digo del fichero .db , les paso nada menos que a los de kali-linux  , no recuerdpo en que release, con todo lo  pros , que se supone que son.


hu , pues mira ...parece que no necesita el db , si no el directorio , para escribir sus log de trabajo.

mira este hilo de 2013 ...
https://forums.kali.org/archive/index.php/t-89.html

Got it working by making a a directory in /etc/ "mkdir /etc/reaver" then run wash. Worked like a charm for me.



eliminate la carpeta

/usr/local/etc/reaver

 ;D

conste que se del problema, pero en wifislax nunca se dio ..por que siempre fijo a /usr y /etc para las configs.



bueno ,veo que ya los has visto ...en cualquier caso lo suyo es copiar el .db
« Última modificación: 14-05-2015, 00:01 (Jueves) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #368 en: 14-05-2015, 00:05 (Jueves) »
en la respuesta  #364

deje definidas las rutas a /opt/pixie  

probado desde cero y funcionando.

 ;)

lo de la carpeta temporal reaver2 , es por que asi al borrar la carpeta de sources no te cepillas el db que ya se movio a reaver2 y despues al final se le quita el 2 y a rular.   8)
« Última modificación: 14-05-2015, 00:08 (Jueves) por USUARIONUEVO »

5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #369 en: 14-05-2015, 00:10 (Jueves) »
en la respuesta  #364

deje definidas las rutas a /opt/pixie  

probado desde cero y funcionando.

 ;)

lo de la carpeta temporal reaver2 , es por que asi al borrar la carpeta de sources no te cepillas el db que ya se movio a reaver2 y despues al final se le quita el 2 y a rular.   8)

Me parece que lo que mas me mola de la informática es comerme la cabeza y resolver los problemas cuando algo no va bien jejeje...
Hago un par de pruebas mas y subo la 2.6.1

Confirmado, si me cepillo /usr/local/etc/reaver ya no me escanea.... vuelvo a probar instalandolo con las modificaciones que me has puesto en #364
« Última modificación: 14-05-2015, 00:14 (Jueves) por 5.1 »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #370 en: 14-05-2015, 00:13 (Jueves) »
en la respuesta  #364

deje definidas las rutas a /opt/pixie  

probado desde cero y funcionando.

 ;)

lo de la carpeta temporal reaver2 , es por que asi al borrar la carpeta de sources no te cepillas el db que ya se movio a reaver2 y despues al final se le quita el 2 y a rular.   8)

Me parece que lo que mas me mola de la informática es comerme la cabeza y resolver los problemas cuando algo no va bien jejeje...
Hago un par de pruebas mas y subo la 2.6.1


ok ,  >:( >:(


recuerda , que la ruta de trabajo la puedes variar como quieras argumentandola en el configure ...

digamos que con el prefix , defines la ruta del ejecutable y en sysconfdir la de configs


son los dos parametros mas basicos , a la hora de compilar algo , con un poco mas de criterio...



jajajaj , me toy descojonando , con lo de que te mola que algo no vaya ...para mirar que le pasa...tu eres de los mios.   ;D

cuando algo no va y puedo reproducir el error, ...me mola.
« Última modificación: 14-05-2015, 00:16 (Jueves) por USUARIONUEVO »

5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #371 en: 14-05-2015, 00:23 (Jueves) »
 >:( >:( >:( >:( >:( >:(

A sus pies USUARIONUEVO, todo OK

Empaqueto y subo....


5.1

  • Visitante
Re: PixieScript v2.6 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #372 en: 14-05-2015, 00:41 (Jueves) »
Ale, pues ya está la versión 2.6.1 subida.

Tambien he actualizado la base de datos de bssids vulnerables, así que cuando instaleis, actualizarla desde el script.

Aunque os funcionara la 2.6 os recomiendo actualizar a la 2.6.1
« Última modificación: 14-05-2015, 00:43 (Jueves) por 5.1 »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #373 en: 14-05-2015, 00:47 (Jueves) »
Ale , a probar mas.  8)

5.1

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #374 en: 14-05-2015, 00:50 (Jueves) »
Ale , a probar mas.  8)

Por cierto, el tema del bruteforce hay una parte que la he hecho "a ciegas" ya que no tenia ningun bssid vulnerable con que hacer las pruebas... pero vamos, con un par de routers que tenia por casa si que admitia el ataque (aunque no son vulnerables y por tanto no saca el pin) y funcionaba bien, eso si, unas 3 horas me tardaba por sesión.

A ver si alguien que le fructifique este ataque confirma algo.

« Última modificación: 14-05-2015, 00:51 (Jueves) por 5.1 »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #375 en: 14-05-2015, 01:12 (Jueves) »
Pues he tardao poco ...

Si en mitad de un ataque , cierras la gui ...

sale el mensaje de yad  UN ERROR A OCURRIDO ...y es en LOOP

no se cierra ni con

killall yad

en el gestor de procesos pone que el proceso padre es sh

si mato sh entonces ya deja de salir el mensaje yad

si no , puedes cerrarlo un millon de veces y no se va.

______________________________________________________________________________________________

Esto otro es muy muy muy EMOCIONANTE

ya sabes que los routers

8C:0C:A3:XX:XX:XX

NO USAN UN PIN ESTANDARD

Pues , resulta que el pin es recuperado ...pero no la key , por que imagino lanzar el pin con tu reaver ...

hay que modificarle para que acepte pines sin cumplir el checksum   ;D

mira la foto , abajo .... pin conseguido ...obteniendo wpa ...pero falla ...esa mac es NO CHECKSUM

SERIA UN BOMBAZO , para esas mac no hay nada de nada , salvo un bruteforce completo que dura infinitas horas de reaver , contando con que no se bloquee a la de tres intentos.

ademas me suena que habia otra mac del estilo ...  que ahora no recuerdo ...

lo dicho , pinta muy bien


5.1

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #376 en: 14-05-2015, 01:18 (Jueves) »
Bueno, lo de que al cerrarlo en medio de un ataque se quede pillado tiene una solucion sencilla, mañana me lo miro tranquilamente e intento reproducir el error, pero vamos, no es un problema solucionarlo,

Por otro lado, con las infinitas pruebas que he realizado, me pasa a menud que justo despues de conseguir el PIN, el router se medio cierra en banda y no escupe la clave WPA.

Sin embargo, si te vas al menu ver, te deberia salir la linea con ese router, la marcas y le das a "Recuperar clave WPA" y de esta manera me ha recuperado claves que de otra forma no lo hacia.

Prueba a ver si tienes suerte.

De todas maneras mañana miraré tambien el tema del checksum y el reaver, a ver si es factible tocarlo para que no compruebe el checksum.

Oye, ahora que me fijo en la foto, no veas si tienes redes al alcance!!!! yo pobre de mi no paso de 5 o 6, y encima ya te ha sacado unas cuantas eh!!!
« Última modificación: 14-05-2015, 01:23 (Jueves) por 5.1 »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #377 en: 14-05-2015, 01:22 (Jueves) »
Bueno, lo de que al cerrarlo en medio de un ataque se quede pillado tiene una solucion sencilla, mañana me lo miro tranquilamente e intento reproducir el error, pero vamos, no es un problema solucionarlo,

Por otro lado, con las infinitas pruebas que he realizado, me pasa a menud que justo despues de conseguir el PIN, el router se medio cierra en banda y no escupe la clave WPA.

Sin embargo, si te vas al menu ver, te deberia salir la linea con ese router, la marcas y le das a "Recuperar clave WPA" y de esta manera me ha recuperado claves que de otra forma no lo hacia.

Prueba a ver si tienes suerte.


NO . men lee , es IMPORTANTE  , esa mac NO USA UN PIN CKECKSUM

con lo que sin un reaver modificado a tal fin (como reavermod)  ... no se puede obtener el wpa

sabes que el pin , el ultimo digito es el checksum ..

en esos amper , se pasaron esa regla por el forro , y el ultimo numero es el que les da la gana a ellos.

O modificas reaver , o ... para esas macs dile que lance reavermod ...

lo suyo es modificar el reaver ... añadirlo al .patch

habia hilos , la modificacion era sencilla ...


seria un bombazo que cayeran esos routers en segundos ...por que hasta la fecha solo hay un bruteforce completo all pins


creo , no eres consciente , es IMPORTANTE.


seguramente nadie se dio cuenta de esa sutileza  ....

yo tengo un router de estos...aunque solo lo uso para pruebas, me lo dio un familiar que se quito movistar y tenia ese router y me lo dio para cacharreos.
« Última modificación: 14-05-2015, 01:24 (Jueves) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15457
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #378 en: 14-05-2015, 01:26 (Jueves) »
miralooooooooooooooooooo

https://foro.seguridadwireless.net/live-wifislax/reaver-wifislax-mod-para-problema-99/



http://www.downloadwireless.net/Aplicaciones-modificadas/BETA_7.0-reaver-1.4-wifislax-no-checksum-mod.zip



solucion facil ...descargar y compilar ese , y cuando detectes la mac en cuestion reaver_mod  ..o como quieras llamarlo.


aunque lo suyo es añadir las modificaciones al .patch
« Última modificación: 14-05-2015, 01:27 (Jueves) por USUARIONUEVO »

5.1

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #379 en: 14-05-2015, 01:26 (Jueves) »
Bueno, lo de que al cerrarlo en medio de un ataque se quede pillado tiene una solucion sencilla, mañana me lo miro tranquilamente e intento reproducir el error, pero vamos, no es un problema solucionarlo,

Por otro lado, con las infinitas pruebas que he realizado, me pasa a menud que justo despues de conseguir el PIN, el router se medio cierra en banda y no escupe la clave WPA.

Sin embargo, si te vas al menu ver, te deberia salir la linea con ese router, la marcas y le das a "Recuperar clave WPA" y de esta manera me ha recuperado claves que de otra forma no lo hacia.

Prueba a ver si tienes suerte.


NO . men lee , es IMPORTANTE  , esa mac NO USA UN PIN CKECKSUM

con lo que sin un reaver modificado a tal fin (como reavermod)  ... no se puede obtener el wpa

sabes que el pin , el ultimo digito es el checksum ..

en esos amper , se pasaron esa regla por el forro , y el ultimo numero es el que les da la gana a ellos.

O modificas reaver , o ... para esas macs dile que lance reavermod ...

lo suyo es modificar el reaver ... añadirlo al .patch

habia hilos , la modificacion era sencilla ...


seria un bombazo que cayeran esos routers en segundos ...por que hasta la fecha solo hay un bruteforce completo all pins


creo , no eres consciente , es IMPORTANTE.


seguramente nadie se dio cuenta de esa sutileza  ....

Pues tienes razon, no lei bien, es que estoy viendo el chiringuito, que como buen culé que soy hoy lo estoy disfrutando jajajaja.

Pues mañana mismo me pongo a ello y miro de modificar el reaver para evitar el checksum. Lo he toqueteado bastante y conozco bastante bien el codigo, así que si no es muy complejo creo que lo podre hacer.