Autor Tema: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack  (Leído 453206 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ebola_30

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #380 en: 14-05-2015, 01:33 (Jueves) »
Acabo de actualizar a la versión 2.6.1 y me sigue sin salir ninguna red al realizar el scaneo.
Al instalar el script me pide que instale la aplicación yad,sino no me lo instala.



Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15444
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #381 en: 14-05-2015, 01:34 (Jueves) »
en su dia yo lo consegui ...asi que muy complejo no sera.


ordenando por fecha , son todos de 2012 menos estos que marca fecha de 2013 y por ende , hay esta lo que buscamos ...

sera buscar las diffs con los files originales...y escudriñar lo que nos interesa....pff, es que ya no me acuerdo de na ...

bueno , mañana sera otro dia ... ;D

si se añade el mod al  .patch no necesitaras dos ejecutables distintos, y no afecta en nada , solo que si metes un pin no checksum , reaver lo pruebe y no rechiste negandose a probarlo.

argsparser.c
cracker.c
globule.c
globule.h
keys.c
pins.c
wpscrack.c

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15444
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #382 en: 14-05-2015, 01:36 (Jueves) »
Acabo de actualizar a la versión 2.6.1 y me sigue sin salir ninguna red al realizar el scaneo.
Al instalar el script me pide que instale la aplicación yad,sino no me lo instala.


y que sistema usas ..que no tiene yad ...  ^-^

5.1

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #383 en: 14-05-2015, 01:39 (Jueves) »
Pero lo que nos interesaria es simplemente que nos deje probar un pin que no cumpla el checksum no? El hecho de que en un ataque normal de reaver el ultimo pin siempre sea checksum da igual, ya que ese ataque no nos interesa, tan solo nos interesa el ataque con un pin especifico, aunque no cumpla la regla checksum.

EDIT : En fin, esoty mirando el codigo pero ya no me centro, me voy a dormir, mañana más y ya te digo algo cuando le eche un vistazo en mis plenas facultades mentales jejeje...

« Última modificación: 14-05-2015, 01:44 (Jueves) por 5.1 »

ebola_30

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #384 en: 14-05-2015, 01:40 (Jueves) »
Acabo de actualizar a la versión 2.6.1 y me sigue sin salir ninguna red al realizar el scaneo.
Al instalar el script me pide que instale la aplicación yad,sino no me lo instala.


y que sistema usas ..que no tiene yad ...  ^-^

Uso wifislax 4.10 instalado en un usb.La versión 2.5 me iba sin problemas.

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15444
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #385 en: 14-05-2015, 01:43 (Jueves) »
Pero lo que nos interesaria es simplemente que nos deje probar un pin que no cumpla el checksum no? El hecho de que en un ataque normal de reaver el ultimo pin siempre sea checksum da igual, ya que ese ataque no nos interesa, tan solo nos interesa el ataque con un pin especifico, aunque no cumpla la regla checksum.

exacto

es decir, que nos deje poner 8 digitos ... los que sean.

como el pin lo saca pixie , y es despues que reaver debe probar..es solo eso

que reaver se coma cualquier combinacion de 8

________________

igual es mejor empezar de cero y no mirar mucho el code del mod , ya que lo modifico tanta gente que al final no lo puse en el iso ... por que ya no sabia ni que se habia tocado.

en principio se hizo solo lo que buscamos ahora, y despues se le toco infinito , para que

1 - probase todos los pins normales
2 - si no salia el pin normal ,entonces automaticamente deberia de ejecutarse ,en busca de pins no check


PERO NUESTRO CASO ES MAS PARTICULAR Y SENCILLO ... solo que se coma cualquie numero de 8 digitos.

Hay que pasarle los 8 , si pones 7 , reaver automaticamente rellena el 8 hueco con el checksum ...


Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15444
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #386 en: 14-05-2015, 01:44 (Jueves) »
Acabo de actualizar a la versión 2.6.1 y me sigue sin salir ninguna red al realizar el scaneo.
Al instalar el script me pide que instale la aplicación yad,sino no me lo instala.


y que sistema usas ..que no tiene yad ...  ^-^

Uso wifislax 4.10 instalado en un usb.La versión 2.5 me iba sin problemas.


pues no se por que te pide yad ..si wifislax ya lo lleva.

ebola_30

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #387 en: 14-05-2015, 01:46 (Jueves) »
Acabo de actualizar a la versión 2.6.1 y me sigue sin salir ninguna red al realizar el scaneo.
Al instalar el script me pide que instale la aplicación yad,sino no me lo instala.


y que sistema usas ..que no tiene yad ...  ^-^

Uso wifislax 4.10 instalado en un usb.La versión 2.5 me iba sin problemas.


pues no se por que te pide yad ..si wifislax ya lo lleva.


Me descargaré la última versión de wifislax 4.10.1 a ver si me funciona.

5.1

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #388 en: 14-05-2015, 01:48 (Jueves) »
A ver, quiza me aventure a hablar sin mirarlo en profundidad, pero digo yo que traceando desde el principio el argumento -p deberiamos llegar a una funcion que verifique el si el pin cumple con el checksum, y si no cumple devolver un false o algo similar.... simplemente tocando que siempre devuelva un true deberiamos poder conseguir lo que necesitamos.
Aunque repito, estoy hablando por hablar eh, no me lo he mirado bien.

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15444
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #389 en: 14-05-2015, 01:52 (Jueves) »
A ver, quiza me aventure a hablar sin mirarlo en profundidad, pero digo yo que traceando desde el principio el argumento -p deberiamos llegar a una funcion que verifique el si el pin cumple con el checksum, y si no cumple devolver un false o algo similar.... simplemente tocando que siempre devuelva un true deberiamos poder conseguir lo que necesitamos.
Aunque repito, estoy hablando por hablar eh, no me lo he mirado bien.

si , si lo basico eran 2 lineas a tocar ...

lo que necesitamos era supefacil , pero despues  el code que te puse se modifico 10,000 veces, por eso ya no se si fiarme...aunque en pins.c tienes notas que te daran todas las pistas.


5.1

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #390 en: 14-05-2015, 01:55 (Jueves) »
Pues bueno, mañana por la maña me pongo a ello y te digo cosas, que ya no se si estoy mirando el codigo fuente del reaver o leyendo el quijote, ya estoy empanado jejeje.

Venga tio, buenoas noches y mañana seguimos, a ver si sacamos el tema adelante... y en cuanto a lo de ser el primero.. mejor di, seriamos...

Mañana más...

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15444
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #391 en: 14-05-2015, 01:58 (Jueves) »
ok , mañana mas.


EDIT: Algo no cuadra aqui

cuando ataco al router amper  ,  dice PIN CONSEGUIDO

sin embargo el campo PIN , de REAVER.LOG esta vacio

es mas , esta mal formado ya que mete como datos cosas como la ruta de trabajo ...tal vez se deba a que no consigue los datos de algu campo ...y se haga un lio despues.

voy a intentar el proceso a manopla.


___________________________

proceso a mano = PIN NOT FOUND

con lo que todo apunta a algun problema en la gui ... por que la gui dice pin encontrado ,pero el REAVER.LOG , no lleva el pin en realidad.
« Última modificación: 14-05-2015, 03:03 (Jueves) por USUARIONUEVO »

Spanky37

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #392 en: 14-05-2015, 08:46 (Jueves) »
Probada la 2.6.1 en ws 4.10.1 y me sigue dando "ha ocurrido un error al escanear redes", un saludo y a seguir probando. ;)

5.1

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #393 en: 14-05-2015, 09:23 (Jueves) »
ok , mañana mas.


EDIT: Algo no cuadra aqui

cuando ataco al router amper  ,  dice PIN CONSEGUIDO

sin embargo el campo PIN , de REAVER.LOG esta vacio

es mas , esta mal formado ya que mete como datos cosas como la ruta de trabajo ...tal vez se deba a que no consigue los datos de algu campo ...y se haga un lio despues.

voy a intentar el proceso a manopla.


___________________________

proceso a mano = PIN NOT FOUND

con lo que todo apunta a algun problema en la gui ... por que la gui dice pin encontrado ,pero el REAVER.LOG , no lleva el pin en realidad.

A ver si puedes pasarme el REAVER.LOG de ese ataque que vea que es lo que pasa....
Por otro lado aunque parece que nno vaya a servir de nada, ya había modificado el reaver cuando he visto esto ....  :-[

Probada la 2.6.1 en ws 4.10.1 y me sigue dando "ha ocurrido un error al escanear redes", un saludo y a seguir probando. ;)

A ver, la 2.6.X está dando demasiados problemas, si teneis ganas de probar, adelante, usarla, pero si no, mejor usad la 2.5

5.1

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #394 en: 14-05-2015, 09:45 (Jueves) »
USUARIONUEVO fijate, esta es parte de la funcion que saca el pinn desde el reaver.log

Código: [Seleccionar]
# Sin en el REAVER.LOG encuentra la caden "WPS pin not found"
if grep -q "WPS pin not found" "$LOG_ATAQUE"    
then
# Comprueba si esta la cadena que nos indica que es posible el ataque bruteforce
                if grep -q "Try again with --force or with another (newer) set of data." "$LOG_ATAQUE"
then
# Si estamos en modo automatico (atacar todos) no lo agrega, y si estamos en atacar un solo ap seguimos
                        if [ $AUTOMATICO = "NO" ]
then
# Nos pregunta si queremos agregar una sesión de bruteforce
                                seguir=$(yad --image "dialog-question" --title "SESION BRUTEFORCE" --button=gtk-yes  ......... $ICONO_SOFT)
ret=$?
                                # Si le decimos que si
if [ $ret = "1" ]
then
                                        # Comprueba si ya existe el archivo con los datos del bssid en la carpeta bruteforce, eso indica que ya esta agregado anteriormente
if [ -f "$RUTA_BRUTEFORCE/$BSSID.BF" ]
then
echo "$BSSID : YA HAY UNA SESION DE BRUTEFORCE PARA $BSSID, NO SE AÑADIRA" > "$LOG_STATUSBAR"
ATAQUE_ACABADO="SI"
return 1
fi
# Si no lo esta recopila los datos necesarios
                                        RecopilarDatosBruteforce
# Escribe el aviso de agregarda la sesion en la barra de statusbar
                                        echo "$BSSID : AÑADIDO A SESIONES DE BRUTEFORCE" > "$LOG_STATUSBAR"
# Le cambia el icono en la pantalla de redes escaneadas a el icono de agregado a bruteforce
                                        AgregarBssidDatabases 4
# Indico que el ataque ha acabado
                                        ATAQUE_ACABADO="SI"
                                        # Y actualizo los datos de el scaneo de cara a que se refresque el nuevo icono y muestre el icono correcto
if [ $ACTUALIZAR_SCAN = "SI" ]; then ProcesarDatosScaneo; fi
# Y salimos de la funcion
                                        return 1
fi
fi
fi
# Si llega aqui implica que no ha encontrado el pin y no admite bruteforce o bien no hemos querido agregar la sesion
                echo "$BSSID : ATAQUE FALLIDO, BSSID NO VULNERABLE A PIXIEWPS ATTACK" > "$LOG_STATUSBAR"
# Cambio el icono a no vulnerable
                AgregarBssidDatabases 2
# Le indico que ha acabado el ataque
                ATAQUE_ACABADO="SI"
                # Y refresco los datos del scaneo para que muestre el icono de no vulnerable
if [ $ACTUALIZAR_SCAN = "SI" ]; then ProcesarDatosScaneo; fi
# Salimos
                return 1
fi
        # Si estamos aqui implica que el "WPS not found" no se escuentra en el LOG, por tanto en teoria deberia haber encontrado el PIN
        # En teoria deberia ser aqui donde lo extrae  
PIN_WPS=$(grep "WPS pin" "$LOG_ATAQUE" | awk -F":" {' print $2 '})

Conclusion, en el REAVER.LOG del ataque al amper está la clave, hay que ver que narices pone para que esté fallando...
« Última modificación: 14-05-2015, 09:59 (Jueves) por 5.1 »

Desconectado pepe10000

  • *******
  • Mensajes: 623
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #395 en: 14-05-2015, 12:59 (Jueves) »
Probada la 2.6.1 en ws 4.10.1 y me sigue dando "ha ocurrido un error al escanear redes", un saludo y a seguir probando. ;)

Pues a mí me ha funcionado el la 4.10.1 final y en la de desarrollo wifislax-13052015.iso con la Wifistation Planar en el sobremesa, peeero no dispongo de ningún router vulnerable para poder hacer mas pruebas.

Un saludo.
« Última modificación: 14-05-2015, 13:00 (Jueves) por pepe10000 »

5.1

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #396 en: 14-05-2015, 13:03 (Jueves) »
Probada la 2.6.1 en ws 4.10.1 y me sigue dando "ha ocurrido un error al escanear redes", un saludo y a seguir probando. ;)

Pues a mí me ha funcionado el la 4.10.1 final y en la de desarrollo wifislax-13052015.iso con la Wifistation Planar en el sobremesa, peeero no dispongo de ningún router vulnerable para poder hacer mas pruebas.

Un saludo.

Vaya, al menos no os falla a todos  ;D

De todas maneras ya me he cansado de ir retocando el codigo desde la primera versión, así que con la experiencia adquirida voy a empezar de 0, y entre otras cosas modificaré el pixiewps para que me cree un archivo con los datos exactos que necesito, de esa manera me ahorrare bastantes lineas de codigo y comprobaciones.... asi que paciencia chicos, tardaré unos dias pero al final dejaremos el script funcionando como tiene que funcionar ...

Saludos

mat_ov

  • Visitante
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #397 en: 14-05-2015, 17:21 (Jueves) »
Otro router vulnerable:

F8:C3:46

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15444
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #398 en: 14-05-2015, 22:29 (Jueves) »
bueno , pues he probado en modo live y no escanea.

escanea si creas el modulo y sin reiniciar lo usas el programa.

sigue siendo lo de la ruta de reaver .. cuando lo tenga solventado del todo ,posteare.

¡MEA CULPA!

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15444
Re: PixieScript v2.6.1 (Testing), ataque automatizado Pixie Dust Attack
« Respuesta #399 en: 14-05-2015, 23:05 (Jueves) »
Que error mas tonto tio ..........

¿verdad que todo el tiempo estube hablando de fijar la ruta de raver a tu  /opt/pixie ...?


pues voy y en las configure le meto la ruta PWD , con lo que cuando la carpeta inicial de instalacion ya no esta..pues falla ....  :P



cambiad en el INSTALADOR , la linea 123

y poner esto


      
Código: [Seleccionar]
./configure --prefix=${RUTA_INSTALACION}/HERRAMIENTAS --sysconfdir=${RUTA_INSTALACION}/HERRAMIENTAS &> COMPILANDO_REAVER || ErroresDependencias 2

probado en live ...y ya va bien de una vez por todas.