Autor Tema: PixieScript v2.6.3 (Testing), ataque automatizado Pixie Dust Attack  (Leído 418148 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

xexudj89

  • Visitante
Re: Re: Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #220 en: 19-04-2015, 23:52 (Domingo) »
llega a asociarte el reaver?al lo mejor es porque estan lejos.
Que va, he probado con varios routers de los tengo propiedad y nada. En todos hace lo mismo. Se cierra super rápido e reaver


¿que paquete estas usando?  ..por que tengo una sospecha.

si usas la iso de desarrollo ,... deberia funcionar bien
si usas el INSTALADOR , en wifislax, deberia ir bien

¿estas usando un xzm que bajaste? ¿cual? ...
He cojido el enlace que hay en el primer hilo, y he cojido lo he descomprimido, he ejecutado el script instalador y me crea el módulo y ese módulo lo he metido en la carpeta modules. Yo he pensado que pueda ser algo de permisos.... Uso la versión final 4.10 ( la última estable) con kernel de serie en modo live.



Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: Re: Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #221 en: 19-04-2015, 23:56 (Domingo) »
llega a asociarte el reaver?al lo mejor es porque estan lejos.
Que va, he probado con varios routers de los tengo propiedad y nada. En todos hace lo mismo. Se cierra super rápido e reaver


¿que paquete estas usando?  ..por que tengo una sospecha.

si usas la iso de desarrollo ,... deberia funcionar bien
si usas el INSTALADOR , en wifislax, deberia ir bien

¿estas usando un xzm que bajaste? ¿cual? ...
He cojido el enlace que hay en el primer hilo, y he cojido lo he descomprimido, he ejecutado el script instalador y me crea el módulo y ese módulo lo he metido en la carpeta modules. Yo he pensado que pueda ser algo de permisos.... Uso la versión final 4.10 ( la última estable) con kernel de serie en modo live.


pues como no sea el mismo bug que reporto otro usuario , que tras poner en modo monitor la tarjeta desaparece ....

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: Re: Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #222 en: 20-04-2015, 00:08 (Lunes) »

pues como no sea el mismo bug que reporto otro usuario , que tras poner en modo monitor la tarjeta desaparece ....

Eso me pasa mi continuamente con la atheros desde que se actualizó el kernel... me estaba volviendo loco, me he comprado una ralink solo por eso.

Te pregunté si a ti te pasaban cosas raras con las atheros y me dijiste que no, así que pensé que era solo cosa de mi tarjeta y no le di mas vueltas.

Me pasa cuando desmonto el driver y lo vuelvo a montar, que me desaparece la interfaz aunque el driver está montado, y la única forma de que vuelva a aparecer es desconectando el usb y volviendolo a conectar.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Markillo

  • Visitante
Re:
« Respuesta #223 en: 20-04-2015, 00:10 (Lunes) »
Nexus89 yo utilizo los mismos adaptadores que tú y no tengo fallos.

Enviado desde mi Nexus 4 mediante Tapatalk


xexudj89

  • Visitante
Re: Re: Re: Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #224 en: 20-04-2015, 00:13 (Lunes) »
llega a asociarte el reaver?al lo mejor es porque estan lejos.
Que va, he probado con varios routers de los tengo propiedad y nada. En todos hace lo mismo. Se cierra super rápido e reaver


¿que paquete estas usando?  ..por que tengo una sospecha.

si usas la iso de desarrollo ,... deberia funcionar bien
si usas el INSTALADOR , en wifislax, deberia ir bien

¿estas usando un xzm que bajaste? ¿cual? ...
He cojido el enlace que hay en el primer hilo, y he cojido lo he descomprimido, he ejecutado el script instalador y me crea el módulo y ese módulo lo he metido en la carpeta modules. Yo he pensado que pueda ser algo de permisos.... Uso la versión final 4.10 ( la última estable) con kernel de serie en modo live.


pues como no sea el mismo bug que reporto otro usuario , que tras poner en modo monitor la tarjeta desaparece ....
Sí pero que también lo haga la alpha de 1w que no es Atheros....

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: Re: Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #225 en: 20-04-2015, 00:19 (Lunes) »

pues como no sea el mismo bug que reporto otro usuario , que tras poner en modo monitor la tarjeta desaparece ....

Eso me pasa mi continuamente con la atheros desde que se actualizó el kernel... me estaba volviendo loco, me he comprado una ralink solo por eso.

Te pregunté si a ti te pasaban cosas raras con las atheros y me dijiste que no, así que pensé que era solo cosa de mi tarjeta y no le di mas vueltas.

Me pasa cuando desmonto el driver y lo vuelvo a montar, que me desaparece la interfaz aunque el driver está montado, y la única forma de que vuelva a aparecer es desconectando el usb y volviendolo a conectar.


hay que diferenciar

ya comente varias veces el ath9k no da guerra (pci)

pero el que va por usb   ath9k_htc   , necesita un sleep de varios segundos ...

rmmod ath9k_htc
sleep 3
modprobe ath9k_htc



creo que el script resetea el driver..y si no hay pausa ....bye bye tarjeta.

pero esto es mas viejo que el sol , se comento mas de una vez.

si con sleep 3 , no da tiempo , se amplia el sleep  ... depende de lo rapido del equipo puede tardar mas de 3 en hacer el reload.



a veces el rmmod no ha acabado , y se lanza el modprobe ...  cuando el rmmod acaba , desmonta denuevo el driver quedando a NADA.
« Última modificación: 20-04-2015, 00:22 (Lunes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #226 en: 20-04-2015, 00:24 (Lunes) »
a lo mejor en vez de


rmmod
modprobe


o

rmmod
sleep 3
modprobe


seria mejor un


rmmod && modprobe     asi la segunda accion no comienza nunca , hasta que la primera este acabada.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #227 en: 20-04-2015, 00:32 (Lunes) »
La última versión del geminisauditor lleva un sleep 5, y ni con esas...

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #228 en: 20-04-2015, 00:33 (Lunes) »
funcion que resetea interfaces...

¿los que os desaparece la interface usais un atheros usb ?


Código: [Seleccionar]
reiniciar_interface() {
DRIVER=`ls -l /sys/class/net/$INTERFAZ/device/driver | awk -F '/' '{print $NF}'`
echo -e $AMARILLO"Reiniciando la interfaz $INTERFAZ $DRIVER..."$COL_RESET
echo ""
rmmod -f "$DRIVER" >/dev/null 2>&1 #reiniciamos la interfaz
if [ "$DRIVER" = "ath9k_htc" ]
then
ifconfig $INTERFAZ >/dev/null 2>&1
while [ $? -eq 0 ] #esperamos a que se desactive el módulo de la interfaz
do
ifconfig $INTERFAZ >/dev/null 2>&1
done
fi
modprobe "$DRIVER" >/dev/null 2>&1
if [ "$DRIVER" = "ath9k_htc" ]
then
ifconfig $INTERFAZ >/dev/null 2>&1
while [ $? -ne 0 ] #esperamos a que se active el módulo de la interfaz
do
ifconfig $INTERFAZ >/dev/null 2>&1
done
fi
}

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #229 en: 20-04-2015, 00:34 (Lunes) »
La última versión del geminisauditor lleva un sleep 5, y ni con esas...

prueba modificsando


rmmod $DRIVER && modprobe $DRIVER


sin sleepes ...creo que deberia servir.

tengo aqui un atheros usb , bueno 2 , asi que voy a mirar aver...

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #230 en: 20-04-2015, 00:43 (Lunes) »
siento ser tan pesado , pero creo es conveniente dar el maximo de informacion a desarrolladores.


si no recuerdo mal ...


en los kerneles nuevos  , las atheros , les pasa como las ralink  ... necesitan la interface real UP

si matamos networkmanager la interface queda DOWN

siempre antes de un ataque o scan  ...asegurar de levantar interface real.

creo que algunos scripts llevan reglas de ese tipo , pero solo contemplan si es un chip ralink .. y ahora los atheros se comportan igual.


___________________________________________________________________________________________________________

forma de evitar todo esto , seria usar airmon-zc  , el cual no genera interface virtual ,si no que directamente convierte la real , en modo monitor y UP

pero hay muchisimos scripts que dejan de funcionar , al no generarse la interafce virtual ...algunas apps, son guis , de las que no hay sources , y directamente irian a la basura.


la linea correcta seria adaptarse a la lionea de trabajo actual ..

con esa nueva forma, ni siquiera el kernel necesita patches ... al ser siempre interfaces reales y solo estan en uno u otro modo ...


trabajr en eso , llevaria semanas de trabajo y quitar muchas apps .... pero al final , ...renovarse o morir.

xexudj89

  • Visitante
Re: Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #231 en: 20-04-2015, 01:02 (Lunes) »
siento ser tan pesado , pero creo es conveniente dar el maximo de informacion a desarrolladores.


si no recuerdo mal ...


en los kerneles nuevos  , las atheros , les pasa como las ralink  ... necesitan la interface real UP

si matamos networkmanager la interface queda DOWN

siempre antes de un ataque o scan  ...asegurar de levantar interface real.

creo que algunos scripts llevan reglas de ese tipo , pero solo contemplan si es un chip ralink .. y ahora los atheros se comportan igual.


___________________________________________________________________________________________________________

forma de evitar todo esto , seria usar airmon-zc  , el cual no genera interface virtual ,si no que directamente convierte la real , en modo monitor y UP

pero hay muchisimos scripts que dejan de funcionar , al no generarse la interafce virtual ...algunas apps, son guis , de las que no hay sources , y directamente irian a la basura.


la linea correcta seria adaptarse a la lionea de trabajo actual ..

con esa nueva forma, ni siquiera el kernel necesita patches ... al ser siempre interfaces reales y solo estan en uno u otro modo ...


trabajr en eso , llevaria semanas de trabajo y quitar muchas apps .... pero al final , ...renovarse o morir.
Uso el kernel de serie creo que es el 3.12.xx no estoy en wifislax ahora mismo.

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #232 en: 20-04-2015, 01:03 (Lunes) »
acabo de probar y parece que el script tiene algun problema cuando es el driver ath9k_htc

a mi se me ha quedado en reseteando interface y de hay no pasa ...   >:D


no tengo una con chip rtl8187 para probar asi que de esa no puedo decir nada.
« Última modificación: 20-04-2015, 01:04 (Lunes) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #233 en: 20-04-2015, 01:10 (Lunes) »
Yo también estoy haciendo pruebas, y confirmo que el problema es externo a los scripts.

Da igual cuanto sleep le pongas, he hecho un bucle infinito y simplemente hay veces que la interface no se puede volver a montar nunca, no importa el tiempo que esperes.

La única solución es desconectar y volver a conectar el usb.
« Última modificación: 20-04-2015, 01:11 (Lunes) por geminis_demon »

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

5.1

  • Visitante
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #234 en: 20-04-2015, 01:11 (Lunes) »
Macho, para hacer un puto script !!!! Tanta tarjeta y tanta ostia !!! Es una locura, estás seguro de que funciona y luego con otro dispositivo peta... arfffff...

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #235 en: 20-04-2015, 01:17 (Lunes) »
solved



Código: [Seleccionar]
reiniciar_interface() {
DRIVER=`ls -l /sys/class/net/$INTERFAZ/device/driver | awk -F '/' '{print $NF}'`
echo -e $AMARILLO"Reiniciando la interfaz $INTERFAZ $DRIVER..."$COL_RESET
echo ""
rmmod -f "$DRIVER" &>/dev/null && modprobe "$DRIVER" &>/dev/null && ifconfig $INTERFAZ up &>/dev/null
}


confirmo que es problema del script  ;D

llevo meses con kerneles 3.16 - 3.19   y cero problemas con las tarjetas a excepcion de wash 00


ALE , sin sleeps ni ostias raras  ;D
« Última modificación: 20-04-2015, 01:21 (Lunes) por USUARIONUEVO »

5.1

  • Visitante
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #236 en: 20-04-2015, 01:24 (Lunes) »
 >:( >:( >:( >:( >:( >:( >:(

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #237 en: 20-04-2015, 01:32 (Lunes) »
mi gozo en un pozo , ... a la segunda vez, desaparece del todo la interface ...

aunque ya no se queda atscado al momento del modo monitor , la interface desaparece a veces ... juas juas.


solucion ... no resetear el driver.
« Última modificación: 20-04-2015, 01:33 (Lunes) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #238 en: 20-04-2015, 01:32 (Lunes) »
solved



Código: [Seleccionar]
reiniciar_interface() {
DRIVER=`ls -l /sys/class/net/$INTERFAZ/device/driver | awk -F '/' '{print $NF}'`
echo -e $AMARILLO"Reiniciando la interfaz $INTERFAZ $DRIVER..."$COL_RESET
echo ""
rmmod -f "$DRIVER" &>/dev/null && modprobe "$DRIVER" &>/dev/null && ifconfig $INTERFAZ up &>/dev/null
}


confirmo que es problema del script  ;D

llevo meses con kerneles 3.16 - 3.19   y cero problemas con las tarjetas a excepcion de wash 00


ALE , sin sleeps ni ostias raras  ;D

Me sigue petando igual...

El driver siempre se monta correctamente, haces un lsmod y lo ves que esta ahí, pero la interface ni existe.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15019
Re: PixieScript v2.4, ataque automatizado Pixie Dust Attack
« Respuesta #239 en: 20-04-2015, 01:34 (Lunes) »
solved



Código: [Seleccionar]
reiniciar_interface() {
DRIVER=`ls -l /sys/class/net/$INTERFAZ/device/driver | awk -F '/' '{print $NF}'`
echo -e $AMARILLO"Reiniciando la interfaz $INTERFAZ $DRIVER..."$COL_RESET
echo ""
rmmod -f "$DRIVER" &>/dev/null && modprobe "$DRIVER" &>/dev/null && ifconfig $INTERFAZ up &>/dev/null
}


confirmo que es problema del script  ;D

llevo meses con kerneles 3.16 - 3.19   y cero problemas con las tarjetas a excepcion de wash 00


ALE , sin sleeps ni ostias raras  ;D

Me sigue petando igual...

El driver siempre se monta correctamente, haces un lsmod y lo ves que esta ahí, pero la interface ni existe.

me acaba de pasar .....   y veo lo mismo que tu , lsmod y el driver esta hay , pero no la tarjeta    :(

Why...?