?>/script>'; } ?> [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio) Widgets Magazine

Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 858375 veces)

0 Usuarios y 1 Visitante están viendo este tema.

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1120 en: 26-04-2016, 10:35 (Martes) »
Gracias por los archivos, el problema que tengo es cuando intento conectar desde el movil usando  CSipSimple, creo la cuenta con los datos puestos en asterisk pero siempre me dice "Error al registrar - Request Timeout."

mirando en el la consola de asterisk sale " NOTICE[21720]: chan_sip.c:28332 handle_resquest_register: Registration from '<sip:951xxxxxx@192.168.1.100>' failed for '192.168.1.34:59350' - Wrong password" (951xxxxx es mi numero de telefono y 192.168.1.34 es la ip del movil)

El objetivo de usar Asterisk es que actúe como centralita, de manera que Asterisk se conecta al servidor de Movistar, y tus dispositivos se conectan a Asterisk. Entonces, el usuario y la contraseña que debes usar en los dispositivos son los que tú mismo definas en el fichero "sip.conf". Es decir, si allí has puesto
Código: [Seleccionar]
[_device1_](dispositivo)
secret=_password1_
el usuario que debes poner en el cliente es "_device1_" y la contraseña "_password1_". Si te dice "Registration from '<sip:951xxxxxx@192.168.1.100>' failed", entiendo que o es que has llamado al dispositivo igual que tu número de teléfono (y yo no lo haría, te vas a liar mucho) o es que estás usando las credenciales de Movistar en tu dispositivo.


tagotis

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1121 en: 26-04-2016, 11:56 (Martes) »
Gracias por los archivos, el problema que tengo es cuando intento conectar desde el movil usando  CSipSimple, creo la cuenta con los datos puestos en asterisk pero siempre me dice "Error al registrar - Request Timeout."

mirando en el la consola de asterisk sale " NOTICE[21720]: chan_sip.c:28332 handle_resquest_register: Registration from '<sip:951xxxxxx@192.168.1.100>' failed for '192.168.1.34:59350' - Wrong password" (951xxxxx es mi numero de telefono y 192.168.1.34 es la ip del movil)

El objetivo de usar Asterisk es que actúe como centralita, de manera que Asterisk se conecta al servidor de Movistar, y tus dispositivos se conectan a Asterisk. Entonces, el usuario y la contraseña que debes usar en los dispositivos son los que tú mismo definas en el fichero "sip.conf". Es decir, si allí has puesto
Código: [Seleccionar]
[_device1_](dispositivo)
secret=_password1_
el usuario que debes poner en el cliente es "_device1_" y la contraseña "_password1_". Si te dice "Registration from '<sip:951xxxxxx@192.168.1.100>' failed", entiendo que o es que has llamado al dispositivo igual que tu número de teléfono (y yo no lo haría, te vas a liar mucho) o es que estás usando las credenciales de Movistar en tu dispositivo.

en mi caso lo tengo definido con nombre movil1 en dispositivo y en CsipSimple  se lo tengo asignado a nombre de usuario y la contraseña es la misma que tengo definida en el sip.conf

bueno parece que esto resuelto ya me reconoce los terminales en asterisk , pero ahora cuando intento realizar una llamada a cualquier extension a a cualquier numero, asterisk se cierra y no se realiza la llamada

« Última modificación: 26-04-2016, 13:18 (Martes) por tagotis »

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1122 en: 26-04-2016, 23:38 (Martes) »
bueno parece que esto resuelto ya me reconoce los terminales en asterisk , pero ahora cuando intento realizar una llamada a cualquier extension a a cualquier numero, asterisk se cierra y no se realiza la llamada

Para el demonio de Asterisk "/etc/init.d/asterisk stop" y arráncalo en modo consola con todos los mensajes activados "asterisk -cvvv"; ahora te conectas con una terminal, intentas hacer una llamada, y miras qué dicen los mensajes de log.


tagotis

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1123 en: 27-04-2016, 09:39 (Miércoles) »
bueno parece que esto resuelto ya me reconoce los terminales en asterisk , pero ahora cuando intento realizar una llamada a cualquier extension a a cualquier numero, asterisk se cierra y no se realiza la llamada

Para el demonio de Asterisk "/etc/init.d/asterisk stop" y arráncalo en modo consola con todos los mensajes activados "asterisk -cvvv"; ahora te conectas con una terminal, intentas hacer una llamada, y miras qué dicen los mensajes de log.
     

este es el mensaje que me sale en log cuando realizo alguna llamada

  > Saved useragent "Zoiper r36944" for peer movil2
  > Saved useragent "Zoiper r36944" for peer movil1
Segmentation fault


eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1124 en: 27-04-2016, 15:20 (Miércoles) »
este es el mensaje que me sale en log cuando realizo alguna llamada

  > Saved useragent "Zoiper r36944" for peer movil2
  > Saved useragent "Zoiper r36944" for peer movil1
Segmentation fault


¿Quizás se está quedando sin memoria? Si no es eso, yo apuntaría a un error en el Asterisk, incompatibilidad de alguna librería, ...


tagotis

  • Visitante
Re:
« Respuesta #1125 en: 27-04-2016, 15:26 (Miércoles) »
Alguna posible solución

Enviado desde mi Lenovo K3 Note mediante Tapatalk

solucionado, tenia instalada la version 13, la he desinstalado y he instalado la version 18 y todo correcto


« Última modificación: 27-04-2016, 20:27 (Miércoles) por tagotis »

Castorcillo

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1126 en: 03-05-2016, 09:29 (Martes) »
Buenas.
Siguiendo el manual consigo ver Movistar TV con mi Linksys E3200 sin problemas de imagen ni con los menús.
El problema está en que el tráfico multicast satura mi red y no puedo usar WiFi.
He probado a configurar igmp snooping, pero sigue igual.
Cuando apago el DECO, vuelve a funcionar la LAN.
¿Alguien tiene el mismo problema?
¿Cómo lo ha solucionado?
Este mismo problema sucede con Tomato y DD-WRT.
Gracias


borekon

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1127 en: 03-05-2016, 22:14 (Martes) »
Bueno, a mucha gente no le funcionará tal y como está puesto (a mi al menos no).
Tengo un tplink TL-WR1043ND v1.1 con el firmware del primer post.
He ejecutado también el script que aquí sale pero me seguía sin conectar.
Así que, mirando el archivo de configuración del otro router veo que hay una VLAN 3 para peticiones dhcp  ??? o algo por el estilo.
Así que me toca crear una vlan 3 tal y como se ve en la imagen adjunta y funciona al pelo:

« Última modificación: 03-05-2016, 22:53 (Martes) por borekon »

eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1128 en: 04-05-2016, 08:05 (Miércoles) »
Bueno, a mucha gente no le funcionará tal y como está puesto (a mi al menos no).
Tengo un tplink TL-WR1043ND v1.1 con el firmware del primer post.
He ejecutado también el script que aquí sale pero me seguía sin conectar.
Así que, mirando el archivo de configuración del otro router veo que hay una VLAN 3 para peticiones dhcp  ??? o algo por el estilo.
Así que me toca crear una vlan 3 tal y como se ve en la imagen adjunta y funciona al pelo:

Si no estoy equivocado, la VLAN3 es para VoIP (la VLAN6 es para la conexión a internet y la VLAN2 para IPTV); si no la tienes configurada, lo único que te debería fallar es VoIP, el resto te debería funcionar. Quizás al arreglar la VLAN3 as arreglado algo más sin darte cuenta...


borekon

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1129 en: 04-05-2016, 12:30 (Miércoles) »

Si no estoy equivocado, la VLAN3 es para VoIP (la VLAN6 es para la conexión a internet y la VLAN2 para IPTV); si no la tienes configurada, lo único que te debería fallar es VoIP, el resto te debería funcionar. Quizás al arreglar la VLAN3 as arreglado algo más sin darte cuenta...

Si, pero la voip está configurada directamente en la ont (o sea, que el teléfono me funciona teniendo el router apagado).
Aquí las líneas del archivo de configuración en el que me he basado. Se ve claramente que usa la vlan 3 (aunque no tengo muy claro para qué  ^-^ ):
Código: [Seleccionar]
[wan_mix_dhcp]
#rule = static_dns|dns1|dns2|vlan|nat|d_route|igmp|vlan_pri|en_vendor_id|vendor_name|fcnat|en_option43
rule01 0|||3|1|0|0|4|0||0|1
Y aquí se aprecia la parte de la vlan 6 (internet)
Código: [Seleccionar]
[wan_mix_pppoe]
#rule = user|pass|serv_name|ac_name|echo_time|echo_fail|auth|mtu|idle|vlan|nat|d_route|igmp|vlan_pri|fcnat|ipv6_rule
rule01 adslppp@telefonicanetpa|adslppp|||3|20|0|1492|0|6|1|1|0|1|0|rule01
Imagino que la parte de [wan_mix_xxxx] viene de que en el apartado siguiente el protocolo que se usa no es el pppoe, sino mix_mode (tampoco tengo mucha idea de qué es)
Código: [Seleccionar]
[wan]
#protocol 0:dhcpc,1:pppoe,3:static_ip,20:mix_mode
protocol 20

« Última modificación: 04-05-2016, 19:12 (Miércoles) por borekon »

zorrua

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1130 en: 06-05-2016, 13:57 (Viernes) »
Una pregunta sobre IPTV.

¿Se puede ver mas de un stream a la vez?

Un saludo.


fcocor

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1131 en: 11-05-2016, 21:00 (Miércoles) »
Buenas,

En primer lugar agradecer todo el trabajo que realizáis por aquí.  >:( >:( >:(

Uso una placa/router Ubiquiti routerstation Pro con Openwrt 15.05 sin ningún problema con mi conexión de Movistar 30/3 (Internet, Voip y IPTv). Todo ha funcionado perfectamente durante meses, pero este fin de semana solicite el cambio a velocidad simétrica (30/30) y mi sorpresa es que con el Ubiquiti sigo con 30/3, pero si lo quito y conecto el Comtrend VG-5080 que tengo (de fabrica) si que funciona la velocidad simétrica.
¿Alguien sabe por que puede ocurrir?

Muchas gracias.


eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1132 en: 12-05-2016, 00:00 (Jueves) »
Buenas,

En primer lugar agradecer todo el trabajo que realizáis por aquí.  >:( >:( >:(

Uso una placa/router Ubiquiti routerstation Pro con Openwrt 15.05 sin ningún problema con mi conexión de Movistar 30/3 (Internet, Voip y IPTv). Todo ha funcionado perfectamente durante meses, pero este fin de semana solicite el cambio a velocidad simétrica (30/30) y mi sorpresa es que con el Ubiquiti sigo con 30/3, pero si lo quito y conecto el Comtrend VG-5080 que tengo (de fabrica) si que funciona la velocidad simétrica.
¿Alguien sabe por que puede ocurrir?

Muchas gracias.

He pasado recientemente de 30/3 a 30/30 y yo sí consigo toda la velocidad, con un TP-Link TL-WDR4300 corriendo Chaos Calmer 15.05,
¿No te habrás olvidado de re-configurar SQM / QOS o similar?


fcocor

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1133 en: 12-05-2016, 01:20 (Jueves) »
Buenas,

En primer lugar agradecer todo el trabajo que realizáis por aquí.  >:( >:( >:(

Uso una placa/router Ubiquiti routerstation Pro con Openwrt 15.05 sin ningún problema con mi conexión de Movistar 30/3 (Internet, Voip y IPTv). Todo ha funcionado perfectamente durante meses, pero este fin de semana solicite el cambio a velocidad simétrica (30/30) y mi sorpresa es que con el Ubiquiti sigo con 30/3, pero si lo quito y conecto el Comtrend VG-5080 que tengo (de fabrica) si que funciona la velocidad simétrica.
¿Alguien sabe por que puede ocurrir?

Muchas gracias.

He pasado recientemente de 30/3 a 30/30 y yo sí consigo toda la velocidad, con un TP-Link TL-WDR4300 corriendo Chaos Calmer 15.05,
¿No te habrás olvidado de re-configurar SQM / QOS o similar?

eduperez, te debo una cerve  ;D ;D ;D  Ni me acordaba del QOS, problema resuelto.

Muchas gracias


zorrua

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1134 en: 29-05-2016, 00:40 (Domingo) »
Hola a todos,

Para poder aplicar esta configuracion, ¿debo de configurar algo en el router/ONT de Movistar?

Llevo un monton de tiempo intentanto configurar, pero no me asigan ninguna IP el PPPoE.

He probado a ponerl el router/ONT en modo monopuesto, pero nada.

¿Debo de configurar algo mas?

Gracias por todo.

Un saludo.


eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1135 en: 29-05-2016, 16:29 (Domingo) »
Hola a todos,

Para poder aplicar esta configuracion, ¿debo de configurar algo en el router/ONT de Movistar?

Llevo un monton de tiempo intentanto configurar, pero no me asigan ninguna IP el PPPoE.

He probado a ponerl el router/ONT en modo monopuesto, pero nada.

¿Debo de configurar algo mas?

Gracias por todo.

Un saludo.

Si es un ONT, no necesitas configurarlo: tal y como lo deja Movistar ya es suficiente.
Si es un router, prácticamente nada de lo que se comenta aquí te sirve: la configuración por defecto de OpenWrt ya te sirve.

Hablas de ponerlo en modo monopuesto, luego supongo que se trata de un router.


zorrua

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1136 en: 29-05-2016, 21:26 (Domingo) »
Hola a todos,

Para poder aplicar esta configuracion, ¿debo de configurar algo en el router/ONT de Movistar?

Llevo un monton de tiempo intentanto configurar, pero no me asigan ninguna IP el PPPoE.

He probado a ponerl el router/ONT en modo monopuesto, pero nada.

¿Debo de configurar algo mas?

Gracias por todo.

Un saludo.

Si es un ONT, no necesitas configurarlo: tal y como lo deja Movistar ya es suficiente.
Si es un router, prácticamente nada de lo que se comenta aquí te sirve: la configuración por defecto de OpenWrt ya te sirve.

Hablas de ponerlo en modo monopuesto, luego supongo que se trata de un router.

Gracias por responder,

Lo que me han puesto es un router/ONT MitraStar GPT-2541GNAC. Segun he leido no se puede poner solo en modo ONT. Asi que he pedido un cambio de equipo.

Las dudas que tengo son:

1. ¿Existe algun modelo router/ONT que puedo ponerlo solo en modo ONT?
2. Si me ponen un ONT, ¿tendra puerto 1Gbps? Tengo 300Mbps asi que me hace falta lo de 1Gbps.

Agradezco vuestras respuestas.

Un saludo.


eduperez

  • Visitante
Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1137 en: 30-05-2016, 11:22 (Lunes) »
Hola a todos,

Para poder aplicar esta configuracion, ¿debo de configurar algo en el router/ONT de Movistar?

Llevo un monton de tiempo intentanto configurar, pero no me asigan ninguna IP el PPPoE.

He probado a ponerl el router/ONT en modo monopuesto, pero nada.

¿Debo de configurar algo mas?

Gracias por todo.

Un saludo.

Si es un ONT, no necesitas configurarlo: tal y como lo deja Movistar ya es suficiente.
Si es un router, prácticamente nada de lo que se comenta aquí te sirve: la configuración por defecto de OpenWrt ya te sirve.

Hablas de ponerlo en modo monopuesto, luego supongo que se trata de un router.

Gracias por responder,

Lo que me han puesto es un router/ONT MitraStar GPT-2541GNAC. Segun he leido no se puede poner solo en modo ONT. Asi que he pedido un cambio de equipo.

Las dudas que tengo son:

1. ¿Existe algun modelo router/ONT que puedo ponerlo solo en modo ONT?
2. Si me ponen un ONT, ¿tendra puerto 1Gbps? Tengo 300Mbps asi que me hace falta lo de 1Gbps.

Agradezco vuestras respuestas.

Un saludo.

Si te cambia el equipo Movistar, te pondrán el que ellos decidan (date una vuelta por los foros de Movistar y verás lo que se cuece allí); y obviamente, si tienes contratados 300Mbps, tendrán que ponerte un ONT con 1Gbps.


zorrua

  • Visitante
Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1138 en: 30-05-2016, 11:32 (Lunes) »
Hola a todos,

Para poder aplicar esta configuracion, ¿debo de configurar algo en el router/ONT de Movistar?

Llevo un monton de tiempo intentanto configurar, pero no me asigan ninguna IP el PPPoE.

He probado a ponerl el router/ONT en modo monopuesto, pero nada.

¿Debo de configurar algo mas?

Gracias por todo.

Un saludo.

Si es un ONT, no necesitas configurarlo: tal y como lo deja Movistar ya es suficiente.
Si es un router, prácticamente nada de lo que se comenta aquí te sirve: la configuración por defecto de OpenWrt ya te sirve.

Hablas de ponerlo en modo monopuesto, luego supongo que se trata de un router.

Gracias por responder,

Lo que me han puesto es un router/ONT MitraStar GPT-2541GNAC. Segun he leido no se puede poner solo en modo ONT. Asi que he pedido un cambio de equipo.

Las dudas que tengo son:

1. ¿Existe algun modelo router/ONT que puedo ponerlo solo en modo ONT?
2. Si me ponen un ONT, ¿tendra puerto 1Gbps? Tengo 300Mbps asi que me hace falta lo de 1Gbps.

Agradezco vuestras respuestas.

Un saludo.

Si te cambia el equipo Movistar, te pondrán el que ellos decidan (date una vuelta por los foros de Movistar y verás lo que se cuece allí); y obviamente, si tienes contratados 300Mbps, tendrán que ponerte un ONT con 1Gbps.
Gracias por la info.

Lo ideal para poner un router mio con las 3 VLANes sera poner un ONT, no?

Alguien me puede decir si con un router/ont puedo gestionar las VLANes?

Tengo 15 dias de garantia de la instalacion, asi que como me toquen muchos los xxxxxxx, me doy de baja.

Un saludo.


eduperez

  • Visitante
Re: Re: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1139 en: 30-05-2016, 14:03 (Lunes) »
Hola a todos,

Para poder aplicar esta configuracion, ¿debo de configurar algo en el router/ONT de Movistar?

Llevo un monton de tiempo intentanto configurar, pero no me asigan ninguna IP el PPPoE.

He probado a ponerl el router/ONT en modo monopuesto, pero nada.

¿Debo de configurar algo mas?

Gracias por todo.

Un saludo.

Si es un ONT, no necesitas configurarlo: tal y como lo deja Movistar ya es suficiente.
Si es un router, prácticamente nada de lo que se comenta aquí te sirve: la configuración por defecto de OpenWrt ya te sirve.

Hablas de ponerlo en modo monopuesto, luego supongo que se trata de un router.

Gracias por responder,

Lo que me han puesto es un router/ONT MitraStar GPT-2541GNAC. Segun he leido no se puede poner solo en modo ONT. Asi que he pedido un cambio de equipo.

Las dudas que tengo son:

1. ¿Existe algun modelo router/ONT que puedo ponerlo solo en modo ONT?
2. Si me ponen un ONT, ¿tendra puerto 1Gbps? Tengo 300Mbps asi que me hace falta lo de 1Gbps.

Agradezco vuestras respuestas.

Un saludo.

Si te cambia el equipo Movistar, te pondrán el que ellos decidan (date una vuelta por los foros de Movistar y verás lo que se cuece allí); y obviamente, si tienes contratados 300Mbps, tendrán que ponerte un ONT con 1Gbps.
Gracias por la info.

Lo ideal para poner un router mio con las 3 VLANes sera poner un ONT, no?

Alguien me puede decir si con un router/ont puedo gestionar las VLANes?

Tengo 15 dias de garantia de la instalacion, asi que como me toquen muchos los xxxxxxx, me doy de baja.

Un saludo.

Sí, en mi opinión lo ideal es un ONT tonto, como los que ponían al principio (Huawei HG8240, Alcatel-Lucent I240G-T, ...), y así tienes control absoluto de las conexiones desde tu router.