Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 595168 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado eduperez

  • **
  • Mensajes: 19
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1260 en: 03-09-2018, 09:43 (Lunes) »
Sí, con 18.06.1 me funciona todo.



Desconectado lesgar

  • **
  • Mensajes: 3
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1261 en: 04-09-2018, 00:02 (Martes) »
Hola,
Tengo instalado todo esto (gracias Noltari), con la versión que aparece en el hilo y me preguntaba si se puede actualizar a la última versión de OpenWRT (OpenWrt 18.06.1) y si hay alguna mejora y merece la pena actualizar.

Como único problema que tengo es que a veces la wifi deja de funcionar, creo que es por que el chromecast me satura la wifi y tengo que reiniciarla.
La verdad es que tengo un nivel bajo de redes por lo que no se si habría que hacer muchos cambio para actualizar de versión.


Muchas gracias.

Nat por hardware, en algunos modelos (Mir3g por ejemplo).
Respecto al VOD, hace escasos días que me di de baja de Movistar, pero hasta ese momento me funcionaba correctamente con el script de noltari (en manual pq no reconocía algunos modelos de router que tengo), los paquetes que no encuentra, es pq ya vienen implementados de serie. Hay que añadir un parámetro mas, sino el VOD no funcionará en kernels posteriores al 4.4.
Pasos:
1- Actualizar a la última versión:
opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade

2.- Instalar paquetes necesarios (los que den fallo, no pasa nada, ya vienen de serie, no hacen falta, los puse para que fuera genérico y no dependa de la versión del kernel).
opkg install swconfig bird4 kmod-bridge kmod-ipt-nathelper-rtsp udpxy mcproxy

3.- Solo hace falta en kernel +4.4
 
Con kernel-4.4, el helper pptp se cargará automáticamente cuando se vea el tráfico PPTP, pero para kernel 4.9 y posteriores, tendrá que hacer eso explícitamente:

opkg update opkg instalar kmod-nf-nathelper-extra al final a mi no me hacía falta

Agregue una línea al archivo /etc/sysctl.d/local.conf:

"net.netfilter.nf_conntrack_helper = 1"

y reiniciar el enrutador

Desconectado jaberwky

  • **
  • Mensajes: 2
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1262 en: 29-09-2018, 19:30 (Sábado) »
Hola!

querría agradecer enormemente a Noltari su tremendo esfuerzo, por el cual he conseguido configurar mi Tp-Link AC1750 Archer C7 (v4).  ;D >:( >:( >:( >:( >:(

EDITO: Falta que funcione el VOD (U7D, grabaciones, ver desde inicio) en cuanto lo resuelva lo añado.

Como el script no es correcto para este router (además en /tmp/sysinfo/board_name lo declara como "archer-c7-v4") incluyo el /etc/config/network con FFTH+VoIP+IPTV funcionando, por si le sirve a alguien.

¡Un abrazo a todos y salud al foro!

Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd2a:e709:16d0::/48'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1t'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 1t'
        option vid '3'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '0t 1t'
        option vid '6'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ip6assign '60'
        option igmp_snooping '1'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'iptv'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '10.105.X.Y'
        option netmask '255.192.0.0'
        option gateway '10.64.X.Y'
        option defaultroute '0'
        option peerdns '0'

config route
        option interface 'iptv'
        option target '172.16.0.0'
        option netmask '255.240.0.0'
        option gateway '10.64.X.Y'

config interface 'wan'
        option ifname 'eth0.6'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'
        option ipv6 '1'
        option mtu '1492'

config interface 'wan6'
        option ifname 'eth0.6'
        option proto 'dhcpv6'

« Última modificación: 30-09-2018, 14:22 (Domingo) por jaberwky »

Desconectado elpedrui

  • **
  • Mensajes: 3
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1263 en: 06-10-2018, 10:07 (Sábado) »
Buenos días,
estoy utilizando la 18.06.1 y me funciona todo menos pausar/retroceder en los canales de TV (control del directo creo que lo llama Movistar). Al respecto del RTSP tengo instalado el  kmod-ipt-nathelper-rtsp y añadida la línea ya comentada en el archivo /etc/sysctl.d/local.conf:
net.netfilter.nf_conntrack_helper = 1

¿Me falta algo más para que me funcione el pausar/retroceder en los canales en directo?

Gracias a todos por el trabajo y compartir las soluciones que habéis ido encontrando.





Desconectado jordip

  • **
  • Mensajes: 4
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1264 en: 06-10-2018, 23:19 (Sábado) »
Yo tengo el mismo problema ...., lo tenia perfectamente funcionando y al actualizar a 18.06.1, no me funciona en absoluto IPTV.

Ya no es tema de que no tengo VOD, es que el deco no quiere arrancar, como si no tuviera red.

Tengo MT7621 y no existe el módulo kmod-bridge, no se si tendrá que ver con eso. Tampoco existe el omcproxy, pero entiendo que esto solo me afecta si intento usar dispositivos en la WiFi, el deco de Movistar está con cable.

Alguna idea de que ha ocurrido?


Desconectado jordip

  • **
  • Mensajes: 4
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1265 en: 07-10-2018, 00:33 (Domingo) »
Me respondo (en parte) a mi mismo.

Tras instalar mcproxy tengo IPTV.

Pero sigo sin tener VOD.

Alguien ha dado con ello?

Desconectado jordip

  • **
  • Mensajes: 4
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1266 en: 07-10-2018, 01:04 (Domingo) »
En mi caso ya he localizado el problema.

El MT7621 soporta NAT Offloading y lo he activado al instalar la 18.06.1 ...

Se me ha ocurrido ahora probar a quitarlo y voila! ya tengo de nuevo VOD.

No se muy bien donde esta la incompatibilidad pero haberla la hay ...

Desconectado elpedrui

  • **
  • Mensajes: 3
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1267 en: 07-10-2018, 09:53 (Domingo) »
Buenas, a mi el VoDy el Live me funcionan correctamente lo que no va es lo que Movistar llama "control del directo" (pausar, retroceder, ver desde el inicio un canal live).

Como comenté tengo la ver 18.06.1, instalado el paquete kmod-ipt-nathelper-rtsp y añadida la línea ya comentada en el archivo /etc/sysctl.d/local.conf: "net.netfilter.nf_conntrack_helper = 1"

Creía que funcionando el VoD funcionaría también el paser/retroceder en los canales en directo (también RTSP), pero debe hacer falta algo más ¿Alguna idea?

Gracias de nuevo

Desconectado jordip

  • **
  • Mensajes: 4
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1268 en: 07-10-2018, 10:40 (Domingo) »
Creo que si funciona el VOD también funciona el control directo (básicamente es un VoD, no recibes la señal multicast, sino que ves un video emitido solo para ti), y si me funciona.

Todo lo tengo configurado tal y como lo tenía con el LEDE, solo que no parece que haga falta ninguno de los módulos de bridge ...

Ahora me he dado cuenta que tengo problemas con la VPN, pero eso es otro tema.
« Última modificación: 07-10-2018, 10:40 (Domingo) por jordip »

Desconectado krasny

  • **
  • Mensajes: 1
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1269 en: 09-11-2018, 10:03 (Viernes) »
Hola a todos!

Ayer terminé la configuración el Imagenio en mi router Turris Omnia. Este router utiliza Foris OS que en realidad es un openwrt modificado. Hay un par de cosas que hay que cambiar por si alguien se ve en la misma situación que yo:

- Haz backup de todos los archivos que se modifican antes de correr el script
- Cambiar el valor de switch_wan_eth1 a 1 en lugar de 0 en el script de instalación.
- Si tienes vpn configurada en el router debes de modificar el archivo /etc/config/network con las interfaces de la vpn que el script de Noltari elimina. También retocar un poco las interfaces para dejarlas como originalmente
- el archivo /etc/mcproxy.conf debes copiarlo a /var/etc/mcproxy_mcproxy.conf (por alguna razón el daemon lo lee desde allí).
- la línea net.netfilter.nf_conntrack_helper = 1 debes de meterla en el archivo /etc/sysctl.conf

En otro orden de cosas he recibido un correo de nemesys (equipo de control de abusos de telefónica) indicándome que estaba retrasmitiendo la señal violando los términos de licencia del servicio y que podrían suspenderlo. El problema esta en que en el instalador cuando te pregunta "Allow access to udpxy from WAN? (y/n)" debes responder que no para evitar que haga una regla en el firewall que permite acceso al udpxy desde fuera. También puedes limitar las ips para hacerlo y en este caso no deberían pillarte.

Espero que le sea de ayuda a alguien

Desconectado fvila

  • **
  • Mensajes: 1
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1270 en: 04-12-2018, 20:34 (Martes) »
He migrado a openwrt 18.06.1 y no consigo hacer funcionar el VOD (pausa, retroceder, grabaciones, etc). Tengo basicamente la configuracion que tenia en LEDE 17 y nada. Añadir la linea en sysctl para habilitar los helpers del conntrack NO lo hace funcionar.

El modulo del kernel con el helper de rtsp para conntrack esta instalado y cargado correctamente. He observado con 'contrack -L' y con 'conntrack -E' que el inicio de la peticion cuando se hace pausa en el deco se produce correctamente y el helper asignado es el rtsp o sea que hasta aqui todo bien. Tambien he visto que el helper esta identificado con 'iptables -t raw -L' aunque sospechosamente se encuentra en la zona 'lan' y no en la 'iptv'.

Es como si el helper se asignara correctamente, pero despues no estuviese haciendo su trabajo en el retorno del stream de video (hacer el DNAT hacia el deco). Tampoco puedo ver ninguna regla asociada con 'iptables -t nat -L' (aunque no se si esta tiene que haberla o el helper lo hace todo sin dar de alta una nueva regla)

Me estoy desesperando. ¿ Realmente os ha funcionado con 18.06.1 la pausa, retroceder, etc ? ¿ Habeis hecho algo diferente como meter alguna regla en iptables o a traves del LuCI?

Gracias
« Última modificación: 04-12-2018, 20:35 (Martes) por fvila »

Desconectado elpedrui

  • **
  • Mensajes: 3
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1271 en: 14-12-2018, 12:51 (Viernes) »
He migrado a openwrt 18.06.1 y no consigo hacer funcionar el VOD (pausa, retroceder, grabaciones, etc). Tengo basicamente la configuracion que tenia en LEDE 17 y nada. Añadir la linea en sysctl para habilitar los helpers del conntrack NO lo hace funcionar.

El modulo del kernel con el helper de rtsp para conntrack esta instalado y cargado correctamente. He observado con 'contrack -L' y con 'conntrack -E' que el inicio de la peticion cuando se hace pausa en el deco se produce correctamente y el helper asignado es el rtsp o sea que hasta aqui todo bien. Tambien he visto que el helper esta identificado con 'iptables -t raw -L' aunque sospechosamente se encuentra en la zona 'lan' y no en la 'iptv'.

Es como si el helper se asignara correctamente, pero despues no estuviese haciendo su trabajo en el retorno del stream de video (hacer el DNAT hacia el deco). Tampoco puedo ver ninguna regla asociada con 'iptables -t nat -L' (aunque no se si esta tiene que haberla o el helper lo hace todo sin dar de alta una nueva regla)

Me estoy desesperando. ¿ Realmente os ha funcionado con 18.06.1 la pausa, retroceder, etc ? ¿ Habeis hecho algo diferente como meter alguna regla en iptables o a traves del LuCI?

Gracias

No tengo la solución, un par de post mas arriba pregunté lo mismo hace unos meses y no tuve respuesta. Para que funcionase quité el Router con OpenWrt 18.06.1 y lo dejé solo como punto de acceso.

Si alguien puede darnos alguna pista/solución... grazie mille :)