Autor Tema: [Tutorial] HG556a modo repetidor / con y sin relayd  (Leído 172551 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Elnef

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #80 en: 05-09-2012, 13:29 (Miércoles) »
Hoy he probado la compilación r33275 (gracias noltari).
Ya no es necesario restringir a modo 'g' el interface wifi, para repetir una señal con cifrado WEP, como había comentado anteriormente  ;)

Con el atheros ¿Verdad?



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #81 en: 05-09-2012, 14:28 (Miércoles) »

Con el atheros ¿Verdad?

Sí, mis dos hg556a, tienen el wifi atheros  ;)
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Elnef

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #82 en: 05-09-2012, 14:33 (Miércoles) »
Pregunta de novato.

¿Cómo puedo sacar el dmesg.txt para ver si mi hg556 es atheros o ralink?

Es que pongo en el navegador:

http://192.168.1.200/dmesg.txt

Y no me sale nada (192.168.1.200 es la ip de mi router)

cogollos

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #83 en: 05-09-2012, 14:40 (Miércoles) »
Si no me equivoco primero deberias haber lanzado por la linea de comandos lo siguiente

dmesg > /www/dmesg.txt

Esto crea un fichero en el directorio del servidor web (www) accesible cuando pones http://ip/dmesg.txt

Saludos

Elnef

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #84 en: 05-09-2012, 15:57 (Miércoles) »
Muchas gracias. Ya he podido sacarlo y por lo visto creo que estoy de suerte y es un atheros. Porque aparece la siguiente línea:

[   15.792000] ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xc0320000, irq=39

ciberio

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #85 en: 09-09-2012, 23:20 (Domingo) »
Llevo unos dias intentando poner este router en modo repetidor y no hay manera. Tengo el que lleva chip atheros y la version de openwrt 33275. Consigo activar una segunda radio pero no obtengo asignación de IP en esa segunda radio. Asi que me decidi a reutlizar un wifi usb que tenia por casa. Pero al instalar el modulo Kmod-rtl8187 que es el que necesito me encuentro el siguiente mensaje:
BusyBox v1.19.4 (2012-08-26 15:27:59 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (Bleeding Edge, r33275)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:~# opkg install kmod-rtl8187
Installing kmod-rtl8187 (3.3.8+2012-07-16-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/kmod-rtl8187_3.3.8+2012-07-16-1_brcm63xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-rtl8187:
 *    kernel (= 3.3.8-1-d84cefb39b2dcbdf806cc779398b6f69) *
 * opkg_install_cmd: Cannot install package kmod-rtl8187.


¿alguna idea?


Chumpy

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #86 en: 10-09-2012, 02:06 (Lunes) »
El kernel de los hg556a está parcheado y los paquetes oficiales que comprueban la versión de kernel no pueden instalarse (algunos parece que funcionan forzandolos). ¿No te funciona la versión del firmware de Noltari que publicó en este hilo?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #87 en: 10-09-2012, 08:02 (Lunes) »
Pues sí de verdad el chipset de tu router es atheros, el modo repetidor debería funcionar sin ningún problema.
Si empiezas desde el principio, y posteas los ficheros de configuración, intentaré echarte una mano ...  ^-^
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

ciberio

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #88 en: 10-09-2012, 08:44 (Lunes) »
Ok. Estoy en el curro. Esta tarde pruebo y os cuento.

Elnef

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #89 en: 10-09-2012, 11:49 (Lunes) »
Hoy ha llegado a mis manos otro hg556a con Atheros. Y he podido configurar el modo repetidos sin relay a la primera.

Me queda pendiente el ver porqué no me funcionó con el otro HG556a que tengo.
 

ciberio

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #90 en: 10-09-2012, 16:42 (Lunes) »
Pues nada SOLUCIONADO.
He pasado a la r33311 y con calma he empezado desde el principio y eureka.
Aqui os dejo de todas formas la configuración y otras cosillas por si a alguien puede ayudar

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config interface 'lan'
   option ifname 'eth0'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.2.1'
   option gateway '192.168.1.1'

config interface 'wwan'
   option proto 'dhcp'

config interface 'starbridge'
   option type 'bridge'
   option proto 'static'
   option ipaddr '192.168.2.10'
   option netmask '255.255.255.0'

root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
   option type 'mac80211'
   option macaddr 'aqui va tu Mac'
   option hwmode '11ng'
   option htmode 'HT20'
   list ht_capab 'SHORT-GI-40'
   list ht_capab 'TX-STBC'
   list ht_capab 'RX-STBC1'
   list ht_capab 'DSSS_CCK-40'
   option channel '2'
   option txpower '27'
   option country 'US'

config wifi-iface
   option network 'wwan'
   option bssid 'mac router anfitrion'
   option ssid 'JAZZTEL XXXX'
   option encryption 'wep-open'
   option device 'radio0'
   option mode 'sta'
   option key1 'tu clave'
   option key '1'

config wifi-iface
   option device 'radio0'
   option mode 'ap'
   option ssid 'OpenWrt'
   option encryption 'none'
   option network 'lan'

root@OpenWrt:/etc/config# cat dhcp

config dnsmasq
   option domainneeded '1'
   option boguspriv '1'
   option filterwin2k '0'
   option localise_queries '1'
   option rebind_protection '1'
   option rebind_localhost '1'
   option local '/lan/'
   option domain 'lan'
   option expandhosts '1'
   option nonegcache '0'
   option authoritative '1'
   option readethers '1'
   option leasefile '/tmp/dhcp.leases'
   option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
   option interface 'lan'
   option start '100'
   option limit '150'
   option leasetime '12h'

config dhcp 'wan'
   option interface 'wan'
   option ignore '1'

config dhcp
   option start '100'
   option leasetime '12h'
   option limit '150'
   option interface 'starbridge'


Y si instalais el paquete pciutils

root@OpenWrt:/etc/config# lspci
00:01.0 Network controller: Atheros Communications Inc. AR922X Wireless Network Adapter (rev 01)

y sabeis seguro que tipo de chip wifi tiene montado vuestro Huawei.

Nota: La segunda radio (Openwrt) la tengo abierta, ahora voy a probar a encryptarla, espero que tambien funcione.





ciberio

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #91 en: 10-09-2012, 19:55 (Lunes) »
¡Hostias! pues no va..
Empiezo de nuevo. Era mucho mas facil de lo que yo pensaba...la de horas que he perdido.Torpe soy XD.

Aqui la nueva configuracion(olvidaos del anterior post) con solo dos interfaces y dos radios una como cliente y otra como AP. La AP con otra encriptación diferente y otro pasword pero en el mismo canal.

root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
   option type 'mac80211'
   option macaddr 'tu  Mac'   ----- aqui aparece tu Mac en Hexadecimal
   option hwmode '11ng'
   option htmode 'HT20'
   list ht_capab 'SHORT-GI-40'
   list ht_capab 'TX-STBC'
   list ht_capab 'RX-STBC1'
   list ht_capab 'DSSS_CCK-40'
   option channel '2'
   option txpower '27'
   option country 'US'

config wifi-iface
   option network 'wwan'
   option bssid ' tu Bssid'    --------- aqui tu direccion Bssid en hexadecimal
   option ssid ' tu ssid'         -------- el nombre del router anfitrion (wifi a la que te conectas)
   option encryption 'wep-open'
   option device 'radio0'
   option mode 'sta'
   option key1 'XXXXX'  -------------- Tu clave de acceso
   option key '1'

config wifi-iface
   option device 'radio0'
   option mode 'ap'
   option ssid 'OpenWrt'   ------------ La nueva wifi repetidor
   option network 'lan'
   option encryption 'psk' ------------ encriptacion diferente del wifi cliente
   option key 'xxxxxxx'



root@OpenWrt:/etc/config# cat network

config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config interface 'lan'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.2.1'   ---------------------- diferente sub-net router anfitrion
   option gateway '192.168.1.1' ---------------------  Ip de enlace router anfitrion
   option _orig_ifname 'eth0'
   option _orig_bridge 'true'
   option ifname 'eth0'

config interface 'wwan'
   option proto 'dhcp'


Eso es todo, espero haber ayudado en algo a alguien.

Aprovecho para felicitar a Noltari y Jar229 el trabajo realizado sin él cual no habriamos llegado hasta aqui y disfrutar de Openwrt en ese cacharrito que estaba ya camino de la basura.
Gracias a todos los que han contribuido en este proyecto.


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #92 en: 11-09-2012, 08:21 (Martes) »
Si es lo que yo digo ... las cosas hay que hacerlas con calma  >:(
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

ciberio

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #93 en: 12-09-2012, 09:16 (Miércoles) »
Ahora que le he cogido el gusanillo a esto. ¿puede alguien explicar como compilar openwrt para este router?. Tengo instalado el toolchain en mi LinuxMint11, pero las opciones que aprarecen con el Make menuconfig son casi ilimitadas.

La idea es instalar mumudvb y poder reproducir la tdt en cualquier ordenador de casa. jeje creo que a este router se le puede sacar mucho entretenimiento.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #94 en: 12-09-2012, 11:10 (Miércoles) »
Ahora que le he cogido el gusanillo a esto. ¿puede alguien explicar como compilar openwrt para este router?. Tengo instalado el toolchain en mi LinuxMint11, pero las opciones que aprarecen con el Make menuconfig son casi ilimitadas.

Tanto cuesta buscar, antes de preguntar  ???
La verdad, al final se cansa uno, de tener que hacer las cosas por los demás ... :'(
Mírate el hilo principal (últimas páginas) del hg556a, allí está explicado.
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

ciberio

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #95 en: 12-09-2012, 22:38 (Miércoles) »
perdona jar229 tienes razon. Ya lo he encontrado.
Gracias

curtis

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #96 en: 27-09-2012, 00:04 (Jueves) »
Hola a todos!

En mi primer mensaje lo primero agradecer a toda esta gente que colabora en el foro. Es espectacular la ayuda que recibe aquí la gente y lo que se aprende leyendoos.

No obstante, después de leer mucho, tengo problemas con mi hg556a para ponerlo en modo repetidor. Os cuento qué quiero y qué es lo que me ocurre:

Material:
-HG556a
-Adaptador wifi ALFA

Objetivo: Conectarme a la red de mi hermano que vive a 30 metros mía. Utilizar el HG556a para conectarme a su red repetir su señal por toda mi casa. (1º duda: sería conveniente conectarme a su red mediante el adaptador wifi ALFA (a su vez conectado al HG556)? Por lo que he leído, al tener por defecto solo 1 radio el router, el ancho de banda se reduce a la mitad. Quizás poniéndole el adaptador ALFA, al tener 2 radios (una para recibir y otra para enviar) este problema se resuelva)

Pasos dados:

1.- Instalo openwrt versión: openwrt-HW556-squashfs-cfe_r33311_ralink_usb
2.- Configuración jar226 Modo 2: https://foro.seguridadwireless.net/openwrt/huawei-hg556a-modo-repetidor-(-openwrt)/msg244074/#msg244074

3.- Consigo internet, tanto por cable como por wifi.

4.- Intento instalar paquete rtl8187 para el adaptador ALFA. Se descarga correctamente pero al instalarlo da error en las dependencias (como el mensaje anterior de ciberio). Se mantiene incluso con el -force-depends (Duda 3: ¿Es normal? ¿Alguna idea?)

Se agradece de antemano la atención.
« Última modificación: 27-09-2012, 02:25 (Jueves) por curtis »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #97 en: 27-09-2012, 08:22 (Jueves) »
Meter 'a  machete' los drivers de un usb wifi no suele funcionar.

Así que si quieres usarlo, sólo te queda la opción de compilar: https://foro.seguridadwireless.net/openwrt/compilar-openwrt-a-nuestro-gusto/
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

curtis

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #98 en: 27-09-2012, 12:02 (Jueves) »
Meter 'a  machete' los drivers de un usb wifi no suele funcionar.

Así que si quieres usarlo, sólo te queda la opción de compilar: https://foro.seguridadwireless.net/openwrt/compilar-openwrt-a-nuestro-gusto/

Gracias jar! ¿Obtendría una mejora sustancial en la velocidad trabajar con 2 radios? Eso no me ha quedado claro.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #99 en: 27-09-2012, 12:52 (Jueves) »

Gracias jar! ¿Obtendría una mejora sustancial en la velocidad trabajar con 2 radios? Eso no me ha quedado claro.

Pues depende ...
Para navegar, mirar correo, algo de p2p, etc. ... supongo que no valdría la pena ...  ^-^
Además, que las alfa creo que no eran muy estables en navegación. Si a eso le añadimos que te estaría limitando a una conexión en modo 'g' en lugar de 'n' ... :P
Prueba qué tal te va con una sola radio wifi, y decides tú mismo  ;)
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

//FINAL Y MÁS DOS RESPUESTAS