Autor Tema: [Tutorial] HG556a modo repetidor / con y sin relayd  (Leído 174348 veces)

0 Usuarios y 1 Visitante están viendo este tema.

eq7mavala

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #120 en: 05-11-2012, 23:32 (Lunes) »
root@Despacho:~# vi /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '2'
        option macaddr '64:16:f0:58:4e:77'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option country 'US'
        option txpower '20'

config wifi-iface
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option key 'vazquezlatorre'
        option encryption 'psk2'
        option ssid 'Repetidor_central'
        option bssid '88:25:2C:B2:7E:B8'

- /etc/config/wireless 1/31 3%

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '2'
        option macaddr '64:16:f0:58:4e:77'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option country 'US'
        option txpower '20'

config wifi-iface
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option key 'vazquezlatorre'
        option encryption 'psk2'
        option ssid 'Repetidor_central'
        option bssid '88:25:2C:B2:7E:B8'


root@Despacho:~# vi /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'
        option gateway '192.168.1.1'

config interface 'wwan'
        option _orig_ifname 'wlan0-1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.1.200'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '208.67.220.220'

config interface 'stabridge'
        option proto 'relay'
        option network 'lan wwan'
        option ipaddr '192.168.1.200'

root@Despacho:~# vi /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

root@Despacho:~# vi /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan wwan '

config zone
        option name 'wan'
        option network 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'ACCEPT'
        option forward 'ACCEPT'

config forwarding
        option src 'lan'
        option dest 'wan'
//Esto lo acabo de añadir y yo diría que funciona
        option src 'wan'
        option dest 'lan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #121 en: 05-11-2012, 23:54 (Lunes) »
Modifica la parte wan del fichero network y déjalo así:

Código: [Seleccionar]
config interface 'wwan'
        option proto 'dhcp'

Que conste, que yo no veo el modo 'repetidor' por ningún lado, lo estás configurando como cliente  ;)
Valoraciones positivas en compra/venta:
167 en Htcmania
224 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #122 en: 06-11-2012, 00:12 (Martes) »
Que debo cambiar aparte del dhcp de wwan?

eq7mavala

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #123 en: 06-11-2012, 00:39 (Martes) »
En realidad me interesa que esten todos en la misma subred, por lo que me interesa que funcionen con el paquetito relayd...

Gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #124 en: 06-11-2012, 07:51 (Martes) »
En principio, no debes cambiar nada más.
Supongo que has instalado y activado relayd no ?

Pues así debería funcionar.
Valoraciones positivas en compra/venta:
167 en Htcmania
224 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #125 en: 11-11-2012, 19:54 (Domingo) »
Buenas noches, ha estado unos días funcionando perfecto y hoy, justo se ha vuelto loco y ya solo funciona como cliente, en el momento que activo una red AP pierdo la conexión cliente, tengo chipset atheros... Alguna sugerencia???

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #126 en: 11-11-2012, 21:34 (Domingo) »
Algún cambio habrás hecho.
Yo empezaría de nuevo.
Y no olvides hacer copia de las configuraciones (desde LuCi: Sistema, Copias de seguridad).
Valoraciones positivas en compra/venta:
167 en Htcmania
224 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #127 en: 11-11-2012, 22:00 (Domingo) »
Ahora funciona, pero solo si conecto el pc al hg por ethernet, por wifi hago ping a todos los dispositivos de la red menos la puerta de enlace...

eq7mavala

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #128 en: 14-11-2012, 23:08 (Miércoles) »
Esto es la ostia!

Mi hermano conectado al mismo punto de acceso (HG con relayd) navega y yo con el movil al mismo punto no, desconecto y vuelvo a conectar y suele funcionar...

Sugerencia???

jessu4a

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #129 en: 09-12-2012, 11:55 (Domingo) »
Muy buenas, acabo de conseguir un hg556a para probar de ponerle una usb 3070 pero el enlace parece no funcionar, si alguien fuese tan amable de resubirlo.

https://dl.dropbox.com/u/4708147/openwrt/hw556/openwrt-HW556-squashfs-cfe_r33311_ralink_usb.bin

Probando con los otros firmwares no me deja instalar los drivers desde el gestor de paquetes.


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #130 en: 09-12-2012, 12:18 (Domingo) »
Ese enlace lo has sacado de este hilo?

Enviado desde mi u8500 usando Tapatalk 2
Valoraciones positivas en compra/venta:
167 en Htcmania
224 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

jessu4a

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #131 en: 09-12-2012, 12:35 (Domingo) »
El link esta en el inicio del hilo, por lo visto ya no existe el fichero.


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #132 en: 09-12-2012, 13:04 (Domingo) »
Pues te tocará compilarte un firmware de acuerdo a tus necesidades.

Como curiosidad, porqué quieres usar una tarjeta USB ?
Valoraciones positivas en compra/venta:
167 en Htcmania
224 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

demux

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #133 en: 14-12-2012, 21:05 (Viernes) »
Muy buenas, acabo de conseguir un hg556a para probar de ponerle una usb 3070 pero el enlace parece no funcionar, si alguien fuese tan amable de resubirlo.

https://dl.dropbox.com/u/4708147/openwrt/hw556/openwrt-HW556-squashfs-cfe_r33311_ralink_usb.bin

Probando con los otros firmwares no me deja instalar los drivers desde el gestor de paquetes.


Me sumo a la peticion, si alguien lo tiene a ver si seria tan amable de resubirlo para los que andamos un poco pez en eso de compilar el firmware.

Noltari

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #134 en: 14-12-2012, 21:27 (Viernes) »
Enlace restaurado: https://dl.dropbox.com/u/4708147/openwrt/hw556/openwrt-HW556-squashfs-cfe_r33311_ralink_usb.bin

De todas formas, estaba esperando para la integración del router en Openwrt para compilar uno nuevo con los parches más actualizados.

Saludos!

demux

  • Visitante
Re: huawei hg556a modo repetidor / con y sin relayd ( openWRT)
« Respuesta #135 en: 14-12-2012, 22:06 (Viernes) »
Enlace restaurado: https://dl.dropbox.com/u/4708147/openwrt/hw556/openwrt-HW556-squashfs-cfe_r33311_ralink_usb.bin

De todas formas, estaba esperando para la integración del router en Openwrt para compilar uno nuevo con los parches más actualizados.

Saludos!
Muchas gracias Noltari.

nakuable

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #136 en: 20-01-2013, 05:14 (Domingo) »
Por fin conseguí hacerme con otro HG556a para ponerlo como repetidor wifi, o bien conectándome al HG556a que tengo ya operativo, o bien al router principal. Pero mi problema al intentar instalar el relayd es el siguiente:



Si alguien me puede ayudar se lo agradeceré eternamente.
Muchas gracias y saludos.
« Última modificación: 20-01-2013, 05:16 (Domingo) por nakuable »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #137 en: 20-01-2013, 11:02 (Domingo) »
Ese error te lo da porque no puede actualizar la lista de paquetes. Vamos que no has configurado bien el fichero 'network'.

Enviado desde mi Infected V3.0 usando Tapatalk 2
Valoraciones positivas en compra/venta:
167 en Htcmania
224 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

nakuable

  • Visitante
Re: Re: Re: Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #138 en: 20-01-2013, 16:09 (Domingo) »
Ese error te lo da porque no puede actualizar la lista de paquetes. Vamos que no has configurado bien el fichero 'network'.

Enviado desde mi Infected V3.0 usando Tapatalk 2

Y como lo configuro??
Gracias.

Enviado desde mi Samsung Galaxy S II usando Tapatalk

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Re: Re: Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #139 en: 20-01-2013, 18:53 (Domingo) »

Y como lo configuro??
Gracias.

Enviado desde mi Samsung Galaxy S II usando Tapatalk

Leyendo  ;D
Valoraciones positivas en compra/venta:
167 en Htcmania
224 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka