Autor Tema: [Tutorial] HG556a modo repetidor / con y sin relayd  (Leído 172938 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #180 en: 24-05-2013, 09:36 (Viernes) »
El correcto funcionamiento de relayd, depende del router 'principal' al que lo conectemos por wifi.
Yo tengo un huawei hg532c con el que 'funcionaba', pero la velocidad de navegación era 'penosa' (con unos pings altísimos)  :-[
Sin embargo con un comtrend ar5387un iba de maravilla  >:D

Curioso el hecho de que al asignar la IP (cual le reservabas ?) te dejara de funcionar. A mi me ocurría al contrario  ;D

Bien, me alegro que lo hayas solucionado. Recordad que dos servidores DHCP funcionando en una misma red es una fuente (casi) segura de problemas  ;)

De todas formas y como consejo final, la mejor forma (menos problemática y con mejor rendimiento) de enlazar por wifi dos routers con OpenWrt que queramos que estén en la misma subred, es usando WDS (pero claro, ambos deben tener el mismo chipset wifi).


Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

VTCop

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #181 en: 21-07-2013, 17:42 (Domingo) »
A ver, yo tengo un problema. Quiero configurar mi HG556a rev C con el método 2, es decir, el router principal con una IP y el Huawei con otra subred.

Con la configuración actual todo está funcionando salvo una cosa. El DHCP del Huawei no asigna IPs por la Wireless repetida. Sin embargo sí que asigna en sus puertos LAN cableados, que en teoría es la misma interfaz que la WLAN repetidor. ¿Por qué puede ser?


¿no necesito instalar relayd para este método, verdad?


VTCop

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #182 en: 21-07-2013, 17:57 (Domingo) »
A ver, yo tengo un problema. Quiero configurar mi HG556a rev C con el método 2, es decir, el router principal con una IP y el Huawei con otra subred.

Con la configuración actual todo está funcionando salvo una cosa. El DHCP del Huawei no asigna IPs por la Wireless repetida. Sin embargo sí que asigna en sus puertos LAN cableados, que en teoría es la misma interfaz que la WLAN repetidor. ¿Por qué puede ser?


¿no necesito instalar relayd para este método, verdad?



Vale, me faltaba unir la WIFI y la LAN, es decir, en /etc/config/wireless me faltaba
option network 'lan'

en la parte que define la red repetidor

Carlossg

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #183 en: 23-08-2013, 00:41 (Viernes) »
Buenas, me he atrevido a poner este router en funcionamiento(Me lo encontre en el punto limpio, seguramente alguien que se cambio de compañía, y funciona perfectamente  ^-^ ), bien, lo que quiero hacer es que se conecte a mi red wifi, y me de internet al servidor(Solo obtengo 2ms en modo "Routed Client Mode" que para esto ni PLC ni nada >:( ), bien tras probar el routed client mode, como quiero tener todos los equipos en la misma red(Por que es un servidor), reinicio configuraciones(Realmente vuelvo a flashear) y me pongo con el relayd, me puse con tu post de hace unas cuantas paginas atrás y me es imposible(La primera vez que toco un cacharro con openWrt), pues nada, me pongo con el tutorial este:
http://trac.gateworks.com/wiki/relayd

Lo hago todo(Bueno, no lo sigo al pie de la letra por que eso en informatica es fracaso total), bien, al principio todo seguía como antes y reinicio router y servidor, y al fin me da la IP "buena"  >:( de la red local (192.168.1.1XX) casi lloro de la emocion, que me he tirado la vida para conseguirlo, xD

Bien, cojo, me pongo con el ordenador principal y empiezo a administrar el servidor por SSH, a lo que me percato que va lentiiisimo, cada letra que escribo se escribe un rato tarde  :-\ bien, hago ping al router del ISP y me da entre 1200 ms y 1300 ms  :-[ cojo reinicio router y al primer ping me da entre 2 ms y 3 ms, pero a los pocos segundos vuelve a subir y el led del wifi parpadea como un loco, no para, solo para en caso de que el servidor este desconectado.

Por si no ha quedado claro, este es el esquema de como está montada mi red:



Que le pasa a esto? Decir que no encuentro manera de acceder al router con OpenWrt una vez configurado con relayd para cambiar la modificacion, no se si soy tonto o tonto rematado  ^-^

EDIT:Se me ha olvidado decir que he instalado en el router la versión, "Compilación personalizada del backport a backfire que incluye: LuCi, FPU emulation, transmission, ftp, servidor de impresión, samba, usb-storage, etc.: http://www.mediafire.com/?re01zbzi1l5r8fz
"
« Última modificación: 23-08-2013, 00:43 (Viernes) por Carlossg »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #184 en: 23-08-2013, 14:11 (Viernes) »
Aquí tienes explicado el tema de relayd de forma gráfica: https://foro.seguridadwireless.net/openwrt/instalacion-(facil)-de-openwrt-en-huawei-553/msg279562/#msg279562

Se ha comentado varias veces que relayd no es compatible con todos los routers. Es posible que sea tu caso ...

Si quieres puedes probar con una compilación más reciente, como el backport de danitool a Attitude Adjustment: https://files.myopera.com/danitool/linux/hg556a/hg556a_backport_12.09-luci.zip a ver si mejora la cosa ...  ^-^
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Carlossg

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #185 en: 23-08-2013, 17:15 (Viernes) »
Tengo el mismo resultado con esa versión y ese tutorial  :'(

Me he percatado, de que la Mac del Wifi del Hg556a, cambia de: XX:XX:XX:XX:XX:FA a XX:XX:XX:XX:XX:FC cuando le pongo OpenWrt, bueno, en realidad cuando la he conectado al wifi Principal era XX:XX:XX:XX:XX:FB, y al configurar del todo relayd se ha puesto en XX:XX:XX:XX:XX:FC   :P

EDIT:Decir que mi router es chipset atheros
« Última modificación: 23-08-2013, 17:16 (Viernes) por Carlossg »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #186 en: 23-08-2013, 18:17 (Viernes) »
Desde el router principal le reservas una IP al hg556a ?

Cual es el modelo/marca de tu router ADSL ?
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Carlossg

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #187 en: 23-08-2013, 21:17 (Viernes) »
Un Huawei HG532c

Ya he visto que a ti te pasaba lo mismo, jo :(

EDIT:Edito el nombre del router que desde el movil he faileado con las "teclas" xD
« Última modificación: 23-08-2013, 22:01 (Viernes) por Carlossg »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #188 en: 23-08-2013, 23:38 (Viernes) »
Un Huawei HG532c

Ya he visto que a ti te pasaba lo mismo, jo :(

EDIT:Edito el nombre del router que desde el movil he faileado con las "teclas" xD

Sí, y jamás conseguí solucionarlo  :-\

Así que o te olvidas de relayd ... o cambias el Huawei hg532c por otro  ;D
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Carlossg

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #189 en: 23-08-2013, 23:45 (Viernes) »
Creo que voy a tener que olvidarme de relayd  :-[ vaya chusma de router, cada 2x3 se le va la conexion y de vez en cuando laguea que da gusto el wifi, casi que me dan ganas de reventarlo.

Pena que no tenga OpenWrt

Decir que aqui hay un voluntario por si hay que hacerle algo al router, a ver si me lo cargo pronto  ^-^
« Última modificación: 23-08-2013, 23:57 (Viernes) por Carlossg »

Carlossg

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #190 en: 27-08-2013, 20:07 (Martes) »
Tengo nuevas noticias, acabo de seguir este procedimiento:

-HG556a desconectado de la corriente
-HG552c sin saber nada del HG556a, ni MAC ni nada en dispositivos wifis conectados, solo la ip 192.168.1.139 asignada
-Activo DHCP relay en DHCP option pool(No se si tiene algo que ver, he tocado por tocar  ^-^ )
-Conecto el HG556a a la corriente.

Y tachaaan, me ha estado dando pings de 2 ms durante unos 3-5 min y luego ha empezado a fluctuar entre 1400 ms y 2 ms, algo es algo, seguiré trasteando  >:(

miverto

  • Visitante
No tengo accesso a las carpetas wireless y firewall del router
« Respuesta #191 en: 04-09-2013, 21:45 (Miércoles) »
A ver si alguien me ayuda. Estoy intentando configurar un HG556 en modo repetidor. lo tengo conectado a otro router dándole la dirección 192.168.2.5.. que previamente le he configurado con luci.  Hago ping a google para comprobar que hay internet y todo perfecto y también cargo y activo el paquete relyad sin problemas. Pero no tengo manera a partir de ahí de meterle el código. No tengo acceso a las carpetas wireless y firewall del router (permisssion denied). Segurramente será algo tonto pero no doy con la tecla. Gracias de antemano.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: No tengo accesso a las carpetas wireless y firewall del router
« Respuesta #192 en: 04-09-2013, 22:00 (Miércoles) »
A ver si alguien me ayuda. Estoy intentando configurar un HG556 en modo repetidor. lo tengo conectado a otro router dándole la dirección 192.168.2.5.. que previamente le he configurado con luci.  Hago ping a google para comprobar que hay internet y todo perfecto y también cargo y activo el paquete relyad sin problemas. Pero no tengo manera a partir de ahí de meterle el código. No tengo acceso a las carpetas wireless y firewall del router (permisssion denied). Segurramente será algo tonto pero no doy con la tecla. Gracias de antemano.

Quieres que esté en la misma subred que el router al que se conecta ?

Dónde te da ese error ?
« Última modificación: 04-09-2013, 22:01 (Miércoles) por jar229 »
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

miverto

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #193 en: 04-09-2013, 22:57 (Miércoles) »
Hola Jar229 gracias por tu rápida respuesta.
Perdona, estaba usando mal el comando para editar los ficheros. Ya os cuento como me va.
Gracias.
« Última modificación: 04-09-2013, 23:20 (Miércoles) por miverto »

elnino1

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #194 en: 06-09-2013, 15:43 (Viernes) »
que firm de los ultimos añadidos recomendais para usarlo en modo repetidor?
tengo un version c que sera atheros, el que tengo instalado es de primero de año y quiero actualizarlo a una mas actual


he puesto el r37180 de el otro hilo , y ya lo tengo en modo repetidor funcionando y va  de pu.... m.....
« Última modificación: 07-09-2013, 10:14 (Sábado) por elnino1 »

tool

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #195 en: 15-09-2013, 00:49 (Domingo) »
De vuelta por aquí con un Ralink que tenía por casa parado.

Modo cliente funciona perfectamente por cable, pero no levanta el wifi AP al mismo tiempo.

(otro Atheros que tengo funcionaba OK)

Me olvido del Ralink como Repetidor independiente, o sigo probando cosas?

Chumpy

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #196 en: 15-09-2013, 03:03 (Domingo) »
De vuelta por aquí con un Ralink que tenía por casa parado.

Modo cliente funciona perfectamente por cable, pero no levanta el wifi AP al mismo tiempo.

(otro Atheros que tengo funcionaba OK)

Me olvido del Ralink como Repetidor independiente, o sigo probando cosas?

Con una ralink no vas a conseguir modo repetidor, solo puedes con las atheros.


Vuelve a leerte el primer post del hilo:

AVISO: Este método solo funciona para los dispositivos con chipset atheros, sin embargo existen algunas versiones del hg556a que tienen otros chipsets, para ellos será necesario conectar una interfaz inalámbrica al puerto USB, pues no permiten la creacción de interfaces virtuales.

« Última modificación: 15-09-2013, 03:05 (Domingo) por Chumpy »

tool

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #197 en: 15-09-2013, 12:52 (Domingo) »

Vuelve a leerte el primer post del hilo:

AVISO: Este método solo funciona para los dispositivos con chipset atheros, sin embargo existen algunas versiones del hg556a que tienen otros chipsets, para ellos será necesario conectar una interfaz inalámbrica al puerto USB, pues no permiten la creacción de interfaces virtuales.


Había leído lo de no se podía con Ralink en ese mismo POST, pero pensé que era para el método segundo (independientes).

Haré un cambio del Atheros que uso como AP, por este ralink.

Probaré por curiosidad con una interfaz USB + antena direccional a ver qué tal.

danivargas79

  • Visitante
Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #198 en: 28-10-2013, 21:00 (Lunes) »
Muy buenas gente ante todo gracias por toda la ayuda aportada y super bien explicada para novicios como yo.

Gracias a todos los post que teneis por aqui repartidos he conseguido poner un HG556a con chip atheros en modo repetidor.

Se que cuando hace de repetidor se pierde la mitad de velocidad, pero mi problema es que me llega bastante menos,como una decima parte de la que recibo mediante ethernet, asi que creo algo debo tener mal.

Ademas si le pongo clave(de cualquier tipo) no regula bien las Ips y se las tengo que poner fijas. El problema de las Ips fijas es que en los moviles me llegan whatsapp y sincronizaciones pero no van las paginas ni aplicaciones web. Esto lo he solucionado como un post que lei por aki de dejar la wifi en abierto y filtrar las mac.

Si no os importa os pongo un resumen de como tengo montado esto y a ver si me podeis indicar por donde va el error de la bajada drastica de velocidad.

- Router anfitrion: Solos 4610 RD
- Router AP: HG566a chip atheros
- Openwrt r38342 (no se si esto influye demasiado)
- Interface LAN: IPv4 192.168.2.1, IPv4 netmask:255.255.255.0, DNS server: 8.8.8.8, DHCP activado.
- Wifi Configuracion modo cliente creo que esta todo bien pues llega perfectamente cuando le enchufo el cable. El router principal tiene canal 6, el modo cliente lo deje igual por defecto, pero lo he probado con varios y no cambia.
- Wifi modo acces point, tal cual pone en los post, lo tengo en g+s, no se si influira, la clave del principal es wep.

Casi que esta todo como pone en las guias que teneis.

No he reservado direccion para el AP en el router anfrition ni nada de eso. No me importa que esten en distintas subredes, ni que tenga muchas historias el openwrt, solo necesito que reciba el wifi y lo reparta aunque sea al 50%.

Teneis alguna idea de las configuraciones que podría tocar? Aviso que soy hypernovato,todos los terminos aqui descritos son de estar dos dias empapandome por estos lares, asi que no me pidais cosas como compilar, ni hacer pines,jajaja, no tengo mucha idea.

Otra preguntilla, sabeis si podría usar la configuración WDS con el router Solos 4610 RD y el HG566a o estoy hablando barbaridades?

Muchas gracias por todo.


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Re: [Tutorial] HG556a modo repetidor / con y sin relayd
« Respuesta #199 en: 29-10-2013, 22:04 (Martes) »
Del WDS  olvídate, no te va a funcionar.

En cuanto al tema de la velocidad en el repetidor ... yo miraría de probar compilaciones anteriores.

Enviado desde mi CUBE U30GT usando Tapatalk
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

//FINAL Y MÁS DOS RESPUESTAS