Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 1938974 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

DJROCKER

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1860 en: 13-12-2013, 23:42 (Viernes) »
Buenas, estas compilaciones sirven para el HG553 ?



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1861 en: 14-12-2013, 11:03 (Sábado) »
Buenas, estas compilaciones sirven para el HG553 ?

No  >:D

Para el hg553 tienes otro hilo, dónde también encontrarás muchas compilaciones: https://foro.seguridadwireless.net/openwrt/instalacion-(facil)-de-openwrt-en-huawei-553/

cimbor

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1862 en: 17-12-2013, 04:31 (Martes) »
He compilado una nueva versión que abarque tanto mi modelo con chip ralink como atheros, junto a un nuevo programilla para medir ancho de banda.

r39107 con: kernel 3.10.24, luci, luci-ssl, hd-idle, multiwan, wol, ipv6, soporte 3G, rt-speedtest(nuevo programa para hacer test develocidad), swconfig,  kmod-ath9k + kmod-rt2800-pci + kmod-libertas-usb + kmod-net-prism54 + kmod-p54-usb + kmod-rt2500-usb + kmod-rt2800-usb + kmod-rt2800-pci + kmod-rt73-usb + kmod-rtl8192cu + Ralink MAC Patch + wpad-mini + kmod-usb-ohci + kmod-usb2 + kmod-usb-storage , FPU Emulation, soporte para discos usb en formato vfat, ext2-3-4, soporte para ficheros en formato udf e iso9660, cifs, imapfilter(para organizar periodicamente nuestro correo), msmtp, transmission, servidor samba, pure-ftpd (servidor de ftp), aircrack-ng, wireless-utils, Bully (software alternativo a Reaver), htop, wavemon, cifsmount (montaje de carpetas compartidas en red), block-mount, screen, swap-utils, traceroute6, openvpn, bwping, dsniff (auditoria de redes), ethtool, nbtscan(escaner netbios), netdiscover(otro escaner de red), tcpdump, fdisk, hdparm, sdparm, lmbench, pciutils, usbutils.

Está en: http://ubuntuone.com/016jKzgt2DNYHlFSq6LmcF

tiagorl

  • Visitante
Re:
« Respuesta #1863 en: 17-12-2013, 20:16 (Martes) »
Alguna de estas compilaciones tiene el igmp snooping? Podiais incluirlo o decirme como hacerlo? Lo necesito para un interface relay bridge br-lan. Gracias!!

Enviado desde mi Nexus 4 mediante Tapatalk

CCCP

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1864 en: 19-12-2013, 01:35 (Jueves) »
Buenas:

He compilado una nueva versión que abarque tanto mi modelo con chip ralink como atheros, junto a un nuevo programilla para medir ancho de banda.

r39107 con: kernel 3.10.24, luci, luci-ssl, hd-idle, multiwan, wol, ipv6, soporte 3G, rt-speedtest(nuevo programa para hacer test develocidad), swconfig,  kmod-ath9k + kmod-rt2800-pci + kmod-libertas-usb + kmod-net-prism54 + kmod-p54-usb + kmod-rt2500-usb + kmod-rt2800-usb + kmod-rt2800-pci + kmod-rt73-usb + kmod-rtl8192cu + Ralink MAC Patch + wpad-mini + kmod-usb-ohci + kmod-usb2 + kmod-usb-storage , FPU Emulation, soporte para discos usb en formato vfat, ext2-3-4, soporte para ficheros en formato udf e iso9660, cifs, imapfilter(para organizar periodicamente nuestro correo), msmtp, transmission, servidor samba, pure-ftpd (servidor de ftp), aircrack-ng, wireless-utils, Bully (software alternativo a Reaver), htop, wavemon, cifsmount (montaje de carpetas compartidas en red), block-mount, screen, swap-utils, traceroute6, openvpn, bwping, dsniff (auditoria de redes), ethtool, nbtscan(escaner netbios), netdiscover(otro escaner de red), tcpdump, fdisk, hdparm, sdparm, lmbench, pciutils, usbutils.

Está en: http://ubuntuone.com/016jKzgt2DNYHlFSq6LmcF

Felicidades cimbor, a priori funciona sin problemas. Solo he probado modo cliente. Y ojo q no soy muy experto en openwrt.

Una pregunta. ¿Tiene el paquete relayd para funcionar como repetidor? tal y como expliva jar229 aquí: https://foro.seguridadwireless.net/openwrt/huawei-hg556a-modo-repetidor-%28-openwrt%29/msg244074/#msg244074

He visto que trae otro paquete de nombre 6relayd. ¿Hace las veces del anteriormente mencionado relayd?

un saludo
 

cimbor

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1865 en: 20-12-2013, 00:18 (Viernes) »
Buenas:

He compilado una nueva versión que abarque tanto mi modelo con chip ralink como atheros, junto a un nuevo programilla para medir ancho de banda.

r39107 con: kernel 3.10.24, luci, luci-ssl, hd-idle, multiwan, wol, ipv6, soporte 3G, rt-speedtest(nuevo programa para hacer test develocidad), swconfig,  kmod-ath9k + kmod-rt2800-pci + kmod-libertas-usb + kmod-net-prism54 + kmod-p54-usb + kmod-rt2500-usb + kmod-rt2800-usb + kmod-rt2800-pci + kmod-rt73-usb + kmod-rtl8192cu + Ralink MAC Patch + wpad-mini + kmod-usb-ohci + kmod-usb2 + kmod-usb-storage , FPU Emulation, soporte para discos usb en formato vfat, ext2-3-4, soporte para ficheros en formato udf e iso9660, cifs, imapfilter(para organizar periodicamente nuestro correo), msmtp, transmission, servidor samba, pure-ftpd (servidor de ftp), aircrack-ng, wireless-utils, Bully (software alternativo a Reaver), htop, wavemon, cifsmount (montaje de carpetas compartidas en red), block-mount, screen, swap-utils, traceroute6, openvpn, bwping, dsniff (auditoria de redes), ethtool, nbtscan(escaner netbios), netdiscover(otro escaner de red), tcpdump, fdisk, hdparm, sdparm, lmbench, pciutils, usbutils.

Está en: http://ubuntuone.com/016jKzgt2DNYHlFSq6LmcF

Felicidades cimbor, a priori funciona sin problemas. Solo he probado modo cliente. Y ojo q no soy muy experto en openwrt.

Una pregunta. ¿Tiene el paquete relayd para funcionar como repetidor? tal y como expliva jar229 aquí: https://foro.seguridadwireless.net/openwrt/huawei-hg556a-modo-repetidor-%28-openwrt%29/msg244074/#msg244074

He visto que trae otro paquete de nombre 6relayd. ¿Hace las veces del anteriormente mencionado relayd?

un saludo
 

6relayd es para conexiones con ipv6, esa version no tiene relayd, pero he creado otra, la 39139, que añade relayd,IGMP snooping, y eliminado drivers innecesarios de ethernet. En la configuración de LED del kernel he añadido la activación de LED por la actividad de CPU, pero al configurarlo en luci no se activa el led que le indico; en la descripción de esa opción dice que utiliza un array de LED, no sé si se refiere a que necesita varios o algún dispositivo especial.

La nueva versión está en http://ubuntuone.com/65fJEBu1WLKqP7v9qIEoYG

tiagorl

  • Visitante
Re:
« Respuesta #1866 en: 20-12-2013, 10:48 (Viernes) »
Muchas gracias cimbor!!

Enviado desde mi Nexus 4 mediante Tapatalk

CCCP

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1867 en: 23-12-2013, 18:41 (Lunes) »
Buenas:

He compilado una nueva versión que abarque tanto mi modelo con chip ralink como atheros, junto a un nuevo programilla para medir ancho de banda.

r39107 con: kernel 3.10.24, luci, luci-ssl, hd-idle, multiwan, wol, ipv6, soporte 3G, rt-speedtest(nuevo programa para hacer test develocidad), swconfig,  kmod-ath9k + kmod-rt2800-pci + kmod-libertas-usb + kmod-net-prism54 + kmod-p54-usb + kmod-rt2500-usb + kmod-rt2800-usb + kmod-rt2800-pci + kmod-rt73-usb + kmod-rtl8192cu + Ralink MAC Patch + wpad-mini + kmod-usb-ohci + kmod-usb2 + kmod-usb-storage , FPU Emulation, soporte para discos usb en formato vfat, ext2-3-4, soporte para ficheros en formato udf e iso9660, cifs, imapfilter(para organizar periodicamente nuestro correo), msmtp, transmission, servidor samba, pure-ftpd (servidor de ftp), aircrack-ng, wireless-utils, Bully (software alternativo a Reaver), htop, wavemon, cifsmount (montaje de carpetas compartidas en red), block-mount, screen, swap-utils, traceroute6, openvpn, bwping, dsniff (auditoria de redes), ethtool, nbtscan(escaner netbios), netdiscover(otro escaner de red), tcpdump, fdisk, hdparm, sdparm, lmbench, pciutils, usbutils.

Está en: http://ubuntuone.com/016jKzgt2DNYHlFSq6LmcF

Felicidades cimbor, a priori funciona sin problemas. Solo he probado modo cliente. Y ojo q no soy muy experto en openwrt.

Una pregunta. ¿Tiene el paquete relayd para funcionar como repetidor? tal y como expliva jar229 aquí: https://foro.seguridadwireless.net/openwrt/huawei-hg556a-modo-repetidor-%28-openwrt%29/msg244074/#msg244074

He visto que trae otro paquete de nombre 6relayd. ¿Hace las veces del anteriormente mencionado relayd?

un saludo
 

6relayd es para conexiones con ipv6, esa version no tiene relayd, pero he creado otra, la 39139, que añade relayd,IGMP snooping, y eliminado drivers innecesarios de ethernet. En la configuración de LED del kernel he añadido la activación de LED por la actividad de CPU, pero al configurarlo en luci no se activa el led que le indico; en la descripción de esa opción dice que utiliza un array de LED, no sé si se refiere a que necesita varios o algún dispositivo especial.

La nueva versión está en http://ubuntuone.com/65fJEBu1WLKqP7v9qIEoYG

efectivamente pesa menos y lleva relayd
gracias por la aclaración
he intentado ponerlo en modo repetidor (modo 1 y modo 2) de las configuraciones propuestas por jar229 pero no lo he conseguido.
¿has podido tu?

CCCP

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1868 en: 24-12-2013, 14:57 (Martes) »
Me respondo a mi mismo:

He configurado correctamente el firm de cimbor tanto en modo cliente como en modo repetidor (https://foro.seguridadwireless.net/openwrt/%28tutorial%29-modo-clienterepetidor-openwrt/)

Me conecto al router principal (ADSL + AP con DHCP habilitado) mediante wifi

Mi versión es la que monta atheros

No he tenido que usar relayd dado que los hosts del hg566a estan en otro segmento de red (192.168.2.0/24)

Nota: pierdo 1/4 de ancho de banda al tener una interface virtual en modo repetidor.

Duda:

1- ¿Cómo hago para que el hg566a , en lugar de funcionar no como repetidor wifi, funcione como router neutro? Es decir quiero conseguir esto:
Router principal o Cliente wifi ----rj45----Hg556a ))))))))wifi))))PC
Es decir, entra internet por un puerto rj45 en segmento 192.168.1.0/24 y lo saca por wifi en otro segmento de red 192.168.2.0/24 con DHCP habilitado)?


2- ¿Si repito la neñal con otro adaptador pinchadoe en el hg566a perdería menos ancho de banda?

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1869 en: 24-12-2013, 15:15 (Martes) »
Me respondo a mi mismo:

He configurado correctamente el firm de cimbor tanto en modo cliente como en modo repetidor (https://foro.seguridadwireless.net/openwrt/%28tutorial%29-modo-clienterepetidor-openwrt/)

Me conecto al router principal (ADSL + AP con DHCP habilitado) mediante wifi

Mi versión es la que monta atheros

No he tenido que usar relayd dado que los hosts del hg566a estan en otro segmento de red (192.168.2.0/24)

Nota: pierdo 1/4 de ancho de banda al tener una interface virtual en modo repetidor.

Duda:

1- ¿Cómo hago para que el hg566a , en lugar de funcionar no como repetidor wifi, funcione como router neutro? Es decir quiero conseguir esto:
Router principal o Cliente wifi ----rj45----Hg556a ))))))))wifi))))PC
Es decir, entra internet por un puerto rj45 en segmento 192.168.1.0/24 y lo saca por wifi en otro segmento de red 192.168.2.0/24 con DHCP habilitado)?


2- ¿Si repito la neñal con otro adaptador pinchadoe en el hg566a perdería menos ancho de banda?
1. Para convertirlo en router neutro has de configurar las VLANs del switch
http://wiki.openwrt.org/toh/huawei/hg556a#switch.ports.for.vlans

2. Si pinchas un adaptador para retransmitir la señal por supuesto que dejarás de perder ancho de banda. Ahora bien, el adaptador ha de tener una calidad aceptable, porque si enchufas un adaptador cutre y "barato" igual te quedas como estás.

hanka

  • Visitante
Compilacion con hfsplus
« Respuesta #1870 en: 24-12-2013, 17:58 (Martes) »
   Gracias por el desarrollo en este router, las compilaciones son realmente buenas, pero....a riesgo de ser osado!...alguien podria compilar la proxima vez el soporte a discos externos con hfsplus para usar los discos como copias de seguridad de Mac, la instalacion del paquete hfs y hfsplus da error por luci...
   Se que en ext2-3-4 tambien se podria usar para las backups, pero en hfsplus seria lo mejor....
   Un saludo.

elcruel

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1871 en: 26-12-2013, 12:19 (Jueves) »
Hola a todos soy nuevo por aqui, y vengo peleandome con un hg556 desde hace un tiempo, el tema es que dada mi poca experiencia no se como reconocer q la particion swap q tengo activa esta trabajando o esta pasando de mi , el caso es que cuando transmision baja mas de un archivo  de 1 gb a la vez me reinicia el router y pierdo el progreso de dichos archivos , tengo un disco duro con una particion de 250gb en ext4 y una particion  swap de 512mb

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1872 en: 26-12-2013, 13:08 (Jueves) »
Hola a todos soy nuevo por aqui, y vengo peleandome con un hg556 desde hace un tiempo, el tema es que dada mi poca experiencia no se como reconocer q la particion swap q tengo activa esta trabajando o esta pasando de mi , el caso es que cuando transmision baja mas de un archivo  de 1 gb a la vez me reinicia el router y pierdo el progreso de dichos archivos , tengo un disco duro con una particion de 250gb en ext4 y una particion  swap de 512mb

Las últimas versiones de transmission están dando algunos problemas. Yo me pasaría a rtorrent + rutorrent: https://foro.seguridadwireless.net/openwrt/instalacion-(facil)-de-openwrt-en-huawei-553/

En cuanto al swap, ejecuta el comando free.

elcruel

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1873 en: 26-12-2013, 17:30 (Jueves) »
Hola a todos soy nuevo por aqui, y vengo peleandome con un hg556 desde hace un tiempo, el tema es que dada mi poca experiencia no se como reconocer q la particion swap q tengo activa esta trabajando o esta pasando de mi , el caso es que cuando transmision baja mas de un archivo  de 1 gb a la vez me reinicia el router y pierdo el progreso de dichos archivos , tengo un disco duro con una particion de 250gb en ext4 y una particion  swap de 512mb


bueno  en primer lugar gracias por la rapida respuesta ya veo como trabaja mi swap, y en segundo lugar estoy liado con el tuto de rutorrent y estoy atrancado aqui
"root@OpenWrt:/www1# /etc/init.d/lighttpd restart
Duplicate config variable in conditional 0 global: cgi.assign
2013-12-26 16:55:24: (configfile.c.943) source: cat /etc/lighttpd/conf.d/*.conf line: 69 pos: 15 parser failed somehow near here: (EOL)
2013-12-26 16:55:24: (configfile.c.943) source: /etc/lighttpd/lighttpd.conf line: 90 pos: 13 parser failed somehow near here: (EOL)"
tambien me hago la picha un lio cuando creas el archivo vi.torrent.rc no se si hay que editarlo o dejarlo tal cual lo pones tu. un saludo

eucota

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1874 en: 26-12-2013, 17:36 (Jueves) »
¿¿Alguien ha conseguido hacer streaming dvb-t con este router?? Seria un tuto muuuuy interesante igual que el de pelisalacarta y los otros que se estan colgando ultimamente.

Yo he revisado mumu-dvb pero soy extremadamente novato para meterme en esos menesteres, creo que seria de gran utilidad una versión compilada con el driver de alguno de los dvb-t-usb mas utilizados, de esos que valen 5€ en cualquier pagina china.

Sin otro motivo, un saludo a todos y muchas gracias por los estupendos aportes que realizáis regularmente.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1875 en: 26-12-2013, 18:23 (Jueves) »


bueno  en primer lugar gracias por la rapida respuesta ya veo como trabaja mi swap, y en segundo lugar estoy liado con el tuto de rutorrent y estoy atrancado aqui
"root@OpenWrt:/www1# /etc/init.d/lighttpd restart
Duplicate config variable in conditional 0 global: cgi.assign
2013-12-26 16:55:24: (configfile.c.943) source: cat /etc/lighttpd/conf.d/*.conf line: 69 pos: 15 parser failed somehow near here: (EOL)
2013-12-26 16:55:24: (configfile.c.943) source: /etc/lighttpd/lighttpd.conf line: 90 pos: 13 parser failed somehow near here: (EOL)"
tambien me hago la picha un lio cuando creas el archivo vi.torrent.rc no se si hay que editarlo o dejarlo tal cual lo pones tu. un saludo


Con el comando vi torrent.rc se crea (ya que todavía no existe) el fichero. Luego, has de dejarlo como se indica.

En cuanto a lighttpd, te está diciendo que hay un par de errores en el fichero de configuración.

Si lo prefieres, puede usar WinSCP para conectarte al router y editar los ficheros. Eso sí, recuerda que tienes que configurar el protocolo SCP en la conexión.

elcruel

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1876 en: 26-12-2013, 18:57 (Jueves) »
Bien creo q mi problema está aquí


auth.backend = "htpasswd"
    auth.backend.htpasswd.userfile = "/www1/.htpasswd"
    auth.require = ( "/" =>
            (
            "method" => "basic",
            "realm" => "Introduce Usuario y Password",
            "require" => "user=root"
            )
    )

Suena a tontuna  pero o se sí tengo q editar  "user=root" con mi usuario o "introduce usuario y password" y si es lo segundo  como sería? "Usuario/pass"

Y por cierto el próxy module#### proxy module hay q ediarlo o dejarlo tal cual?

## read proxy.txt for more info
#proxy.server = (
#   ".php" => (
#      "localhost" => (
#         "host" => "192.168.0.101",
#         "port" => 80
#      )
#   )
#)


scgi.server = (
        "/RPC2" =>
                ( "127.0.0.1" =>
                        (               
                                "host" => "127.0.0.1",
                                "port" => 5000,
                                "check-local" => "disable"
                        )
                )
        )





Altair64

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1877 en: 26-12-2013, 19:17 (Jueves) »
Hola a todos soy nuevo por aqui, y vengo peleandome con un hg556 desde hace un tiempo, el tema es que dada mi poca experiencia no se como reconocer q la particion swap q tengo activa esta trabajando o esta pasando de mi , el caso es que cuando transmision baja mas de un archivo  de 1 gb a la vez me reinicia el router y pierdo el progreso de dichos archivos , tengo un disco duro con una particion de 250gb en ext4 y una particion  swap de 512mb

Las últimas versiones de transmission están dando algunos problemas. Yo me pasaría a rtorrent + rutorrent: https://foro.seguridadwireless.net/openwrt/instalacion-(facil)-de-openwrt-en-huawei-553/

En cuanto al swap, ejecuta el comando free.

Buena idea, voy a probarlo... Tengo un router compartiendo isos de linux 24/7 e hice la prueba de compartir algunas de esas ISOs en un programa en el ordenador normal... me extrañaba que compartiese "tan poco", porque tengo otro equipo donde a veces tambien pongo el torrent seedeando alguna iso que tambien tengo en el router, y alos pocos segundos de encenderlo ya esta al maximo de mi subida compartiendo. Con este TRansmission no, solo unas pocas veces.

S2!


bueno  en primer lugar gracias por la rapida respuesta ya veo como trabaja mi swap, y en segundo lugar estoy liado con el tuto de rutorrent y estoy atrancado aqui
"root@OpenWrt:/www1# /etc/init.d/lighttpd restart
Duplicate config variable in conditional 0 global: cgi.assign
2013-12-26 16:55:24: (configfile.c.943) source: cat /etc/lighttpd/conf.d/*.conf line: 69 pos: 15 parser failed somehow near here: (EOL)
2013-12-26 16:55:24: (configfile.c.943) source: /etc/lighttpd/lighttpd.conf line: 90 pos: 13 parser failed somehow near here: (EOL)"
tambien me hago la picha un lio cuando creas el archivo vi.torrent.rc no se si hay que editarlo o dejarlo tal cual lo pones tu. un saludo

Yo tambien ando trolleado por el Lighttpd con ese mismo fallo. Son las dos lineas del final, que marcan unos complementos (no recuerdo lo que exactamente, sé que es necesario para los "mime" de php y todas esas historias).
« Última modificación: 27-12-2013, 01:06 (Viernes) por noentiendero »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1878 en: 26-12-2013, 19:35 (Jueves) »
Bien creo q mi problema está aquí


auth.backend = "htpasswd"
    auth.backend.htpasswd.userfile = "/www1/.htpasswd"
    auth.require = ( "/" =>
            (
            "method" => "basic",
            "realm" => "Introduce Usuario y Password",
            "require" => "user=root"
            )
    )

Suena a tontuna  pero o se sí tengo q editar  "user=root" con mi usuario o "introduce usuario y password" y si es lo segundo  como sería? "Usuario/pass"

Y por cierto el próxy module#### proxy module hay q ediarlo o dejarlo tal cual?

## read proxy.txt for more info
#proxy.server = (
#   ".php" => (
#      "localhost" => (
#         "host" => "192.168.0.101",
#         "port" => 80
#      )
#   )
#)


scgi.server = (
        "/RPC2" =>
                ( "127.0.0.1" =>
                        (               
                                "host" => "127.0.0.1",
                                "port" => 5000,
                                "check-local" => "disable"
                        )
                )
        )






Esto es lo que dice en el turorial:

Citar
Añadimos esto al final del fichero. Es dónde definimos el directorio protegido (para el que creamos el usuario y password previamente con htpasswd)
Si en lugar de root, habéis usado otro usuario, debéis modificarlo aquí: "user=root"

En el paso previo, has protegido el directorio /www1 para que te solicite el password. Si has usado el usuario root, no tienes que tocar nada.  Si has puesto otro usuario, debes cambiar "user=root" por "user=tu_usuario"

Ojo que quitar un paréntesis o añadir una coma, producirá un error al arrancar lighttpd.

Subo mi fichero de configuración lighttpd.conf para que lo mires si tienes dudas: http://pastebin.com/U3PT2W4A

Por cierto, que si vamos a seguir con el tema de rtorrent, habrá que hacerlo en el otro hilo ...  ^-^

DAIkiri2KS

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1879 en: 28-12-2013, 21:07 (Sábado) »
Buenas,

tengo este router con OpenWrt compilación del compañero cimbor (r39107), estoy intentando configurar el router con un pincho usb para poder navegar via 3G y que los clientes se conecten por wifi/cable, el problema es que he probado con varios modems usb (Huawei E1752C, K3765 y WU-260) pero no consigo navegar, esto es lo que sale cuando conecto el módem usb:

[   99.848000] usb 1-2: new high-speed USB device number 4 using ehci-platform
[  101.192000] usb-storage 1-2:1.0: USB Mass Storage device detected
[  102.360000] scsi1 : usb-storage 1-2:1.0
[  104.032000] scsi 1:0:0:0: CD-ROM 3G Modem Mass Storage     2.31 PQ: 0 ANSI: 2
[  104.056000] scsi 1:0:0:0: Attached scsi generic sg0 type 5
 
Una vez conecto el módem creo la interfaz desde luci con los siguientes datos:

Protocolo: UMTS/GPRS/EV-DO
Dispositivo: /dev/ttyS0
Tipo de Servicio: UMTS/GPRS
APN: orangeworld
PIN: No tiene pin
PAP/CHAP: orange
Contraseña: orange

Con esta configuración tendría que conectar correctamente no?

Saludos y gracias