Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 1938969 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1820 en: 01-12-2013, 20:38 (Domingo) »
¿Existe alguna manera facil de distinguir si este router trae wifi atheros o no? De manera externa sin tener que abrirlo.
Me interesa conseguir uno como repetidor sin necesidad de enchufarle antenas wifi, pero comprarlo a ciegas parece una tombola.

En la etiqueta trasera, donde pone el modelo. Si es la versión C, la wifi es atheros  ;)



Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1821 en: 01-12-2013, 21:04 (Domingo) »
¿Existe alguna manera facil de distinguir si este router trae wifi atheros o no? De manera externa sin tener que abrirlo.
Me interesa conseguir uno como repetidor sin necesidad de enchufarle antenas wifi, pero comprarlo a ciegas parece una tombola.

En la etiqueta trasera, donde pone el modelo. Si es la versión C, la wifi es atheros  ;)
La versión A también es atheros, ¿no?
Creo que la única Ralink es la B.

Cuando hice los parches para el router hice 3 definiciones: HW556_A, HW556_B y HW556_C.
Sin embargo, nunca he podido comprobar si mis definiciones se correspondían realmente con las versiones que aparecen en la etiqueta :$.

Saludos!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1822 en: 02-12-2013, 08:19 (Lunes) »
Ahora me has hecho dudar ... :-X

A media mañana llego a casa y lo compruebo.

Enviado desde mi CUBOT GT99 usando Tapatalk

Noltari

  • Visitante
Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1823 en: 02-12-2013, 11:19 (Lunes) »
Ahora me has hecho dudar ... :-X

A media mañana llego a casa y lo compruebo.

Enviado desde mi CUBOT GT99 usando Tapatalk
Y también está esto:


Creo que las versiones A y C son atheros y la ralink es la B, pero no lo sé seguro.
De lo que sí estoy 100% seguro es que la C es atheros, ya que es el único modelo que tengo.

Saludos!

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1824 en: 02-12-2013, 12:49 (Lunes) »
¿A y C atheros?, no, yo diría que la A es ralink. El que yo tengo ahora tiene nº serie 30692 y es atheros.

http://wiki.openwrt.org/_media/media/toh/huawei/hg556a-back.jpg

Según el número de serie el mío es una versión B, pero no veo ninguna diferencia con una placa versión C. En teoría cuando las definiste que tomaste en cuenta, ¿el offset de los cal_data? ¿o el modelo de flash?. En mi caso borré accidentalmente los cal_data así que no puedo saber que offset tenía originalmente.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1825 en: 02-12-2013, 14:28 (Lunes) »
¿A y C atheros?, no, yo diría que la A es ralink. El que yo tengo ahora tiene nº serie 30692 y es atheros.

http://wiki.openwrt.org/_media/media/toh/huawei/hg556a-back.jpg

Según el número de serie el mío es una versión B, pero no veo ninguna diferencia con una placa versión C. En teoría cuando las definiste que tomaste en cuenta, ¿el offset de los cal_data? ¿o el modelo de flash?. En mi caso borré accidentalmente los cal_data así que no puedo saber que offset tenía originalmente.
Sí, tienes razón, se me había ido la olla xD.
Ralink -> A
Atheros -> B/C

Con el identificador del chip de la flash podemos saber si tenía un offset u otro.

Saludos!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1826 en: 02-12-2013, 14:58 (Lunes) »

Sí, tienes razón, se me había ido la olla xD.
Ralink -> A
Atheros -> B/C


Lo confirmo yo también (con un par de routers delante mío)  ;D

albeixon

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1827 en: 02-12-2013, 20:55 (Lunes) »
gente llevo detrás de hacer openwrt al router pero tengo una duda.

si se lo hago sólo me valdría como repetidor wifi no ??? conectándolo a otro router no ?

si es así me pondría a hacerlo...

gracias¡

Altair64

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1828 en: 02-12-2013, 20:57 (Lunes) »
gente llevo detrás de hacer openwrt al router pero tengo una duda.

si se lo hago sólo me valdría como repetidor wifi no ??? conectándolo a otro router no ?

si es así me pondría a hacerlo...

gracias¡

Y como una especie de ordenador desde el que hacer un servidor de archivos, centro de descargas, torrents, etc etc etc

jaimeps4

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1829 en: 04-12-2013, 17:18 (Miércoles) »
Hola buenas soy algo noob en esto veran tengo un router vodafone HG556a http://img441.imageshack.us/img441/9982/mzvg.jpg (es el mio) Mi intencion era conectar un alfa de 1mw al router y hacerlo repetidor (tipoR36). Eh hecho los pasos a seguir en el desarollo (actualizandolo con la version r36114) pero mi router no a acabado de funcionar del todo. Al encenderlo solo se enciende el led de corriente electrica, y en la barra si intento acceder al router por el protocolo 192.168.0.1 (1.1/2.1etc) no me sale nada, en el centro de redes se queda "identificando" todo el rato, tambien e cambiado la configuracion IP y la mascara de subred como dice en el desarrollo. ¿Que e podido hacer mal? ¿hay alguna solucion?  ???

eucota

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1830 en: 04-12-2013, 19:14 (Miércoles) »
Buenas tardes, no deja de sorprenderme lo que avanza este post y las utilidades de Openwrt en el hg556a.

Tengo una cuestión que quizás me podáis resolver los eruditos de los routers.

Existen mas routers qe como el HG556 ver. B/C funcionen como cliente/repetidor ellos solos?? Imagino que existirán otros modelos atheros que hagan lo mismo pero no los conozco, me parece muy útil no necesitar de wifi usb para ese cometido y quizás un router como el hg556 pero con antenas externas sería estupendo.

Agradezco las respuestas. 

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1831 en: 04-12-2013, 19:19 (Miércoles) »
Hola buenas soy algo noob en esto veran tengo un router vodafone HG556a http://img441.imageshack.us/img441/9982/mzvg.jpg (es el mio) Mi intencion era conectar un alfa de 1mw al router y hacerlo repetidor (tipoR36). Eh hecho los pasos a seguir en el desarollo (actualizandolo con la version r36114) pero mi router no a acabado de funcionar del todo. Al encenderlo solo se enciende el led de corriente electrica, y en la barra si intento acceder al router por el protocolo 192.168.0.1 (1.1/2.1etc) no me sale nada, en el centro de redes se queda "identificando" todo el rato, tambien e cambiado la configuracion IP y la mascara de subred como dice en el desarrollo. ¿Que e podido hacer mal? ¿hay alguna solucion?  ???


Vuelve a repetir el proceso descrito en el primer post. Igual se ha quedado a medias la instalación del firmware  ???

La IP a la que debes acceder tras instalar el firmware es: 192.168.1.1

Buenas tardes, no deja de sorprenderme lo que avanza este post y las utilidades de Openwrt en el hg556a.

Tengo una cuestión que quizás me podáis resolver los eruditos de los routers.

Existen mas routers qe como el HG556 ver. B/C funcionen como cliente/repetidor ellos solos?? Imagino que existirán otros modelos atheros que hagan lo mismo pero no los conozco, me parece muy útil no necesitar de wifi usb para ese cometido y quizás un router como el hg556 pero con antenas externas sería estupendo.

Agradezco las respuestas. 

Hay muchos routers con wifi atheros que permiten el modo repetidor.

Así el plan 'bueno, bonito, barato' y fácil de localizar se me ocurre el Tp-link 741nd: https://foro.seguridadwireless.net/openwrt/tp-link-741nd-openwrt-modo-repetidor-por-20/

Yo a este le tengo instalado la última versión de Gargoyle (http://www.gargoyle-router.com/) y va estupendamente  ;D

jaimeps4

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1832 en: 04-12-2013, 22:15 (Miércoles) »
Hola buenas soy algo noob en esto veran tengo un router vodafone HG556a http://img441.imageshack.us/img441/9982/mzvg.jpg (es el mio) Mi intencion era conectar un alfa de 1mw al router y hacerlo repetidor (tipoR36). Eh hecho los pasos a seguir en el desarollo (actualizandolo con la version r36114) pero mi router no a acabado de funcionar del todo. Al encenderlo solo se enciende el led de corriente electrica, y en la barra si intento acceder al router por el protocolo 192.168.0.1 (1.1/2.1etc) no me sale nada, en el centro de redes se queda "identificando" todo el rato, tambien e cambiado la configuracion IP y la mascara de subred como dice en el desarrollo. ¿Que e podido hacer mal? ¿hay alguna solucion?  ???


Vuelve a repetir el proceso descrito en el primer post. Igual se ha quedado a medias la instalación del firmware  ???

La IP a la que debes acceder tras instalar el firmware es: 192.168.1.1


Hola gracias por contestar pero sigue igual, no puedo repetir el proceso ya que lo que ocurre es lo siguiente: Enchufo el router a la red electrica y parpadea la luz de corriente un poco hasta quedarse fija (10segundos aprox) y luego nada, no se enciende ninguna mas  ??? . Todo eso sin apretar el boton reset. Al hacer como el primer paso se iluminan todas pero al soltar hace el paso que eh descrito anteriormente. De una forma o de otra eh intentado acceder al router pero nada.. Eh provado de cambiar la clavija del RJ45 en otra etc pero nada pongo el 192.168.1.1 y nada de nada... quien sabe que demonios le ah pasado al hacer el OpenWrt. Si alguien sabe algo que pueda probar lo agradeceria ya que por lo que veo no voy a perder nada en probar. Salu2

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1833 en: 05-12-2013, 10:16 (Jueves) »
Código: [Seleccionar]
Modo de instalación recomendado:

    Con el router apagado pulsar botón de RESTART y mantenerlo pulsado.
    Encender el router y seguir con el botón apretado durante 20 segundos.
    Soltar el botón.
    Configurar la IP del ordenador como 192.168.1.2 y máscara de subred 255.255.255.0
    Abrir el navegador y acceder a http://192.168.1.1

Estás usando el botón correcto (RESTART) ???

papaloukas

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1834 en: 05-12-2013, 11:02 (Jueves) »
Hola,

alguien lo preguntó hace tiempo en este hilo pero por si acaso lo vuelvo a preguntar: ¿funciona la VoIP en la OpenWRT de este router?

En el mensaje principal se menciona claramente que no funciona el ADSL pero no dice nada de los puertos FXS para la VoIP.

jaimeps4

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1835 en: 05-12-2013, 18:08 (Jueves) »
Código: [Seleccionar]
Modo de instalación recomendado:

    Con el router apagado pulsar botón de RESTART y mantenerlo pulsado.
    Encender el router y seguir con el botón apretado durante 20 segundos.
    Soltar el botón.
    Configurar la IP del ordenador como 192.168.1.2 y máscara de subred 255.255.255.0
    Abrir el navegador y acceder a http://192.168.1.1

Estás usando el botón correcto (RESTART) ???

Hola buenas, hoy por arte de magia se a arreglado solo el problema, volvi al paso 1º y ya me funciona el router, se ve que se quedo a mitad de la instalacion o algo raro porque lo hice exactamente como pone en el tema. Al final el puse el R35318 el mas reciente y ya me funciona todo correcto  ;D . Gracias por la ayuda gente! por cierto me recomendais algun tutorial para lo que quiero hacer, alfa 1mw en este router y del router a dos PC´s. De todas formas antes de hacer nada preguntare que casi me quedo sin router al hacer esto jejejej  ^-^ Saludos!

Altair64

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1836 en: 05-12-2013, 19:44 (Jueves) »
Habia instalado la compilada r37937 pero hoy fui a seguir trasteando con el cacharro y vi que se quedaba ahi parado al encenderlo, con la luz de Power parpadeando y de ahi no pasaba... me metia a la IP que le configuré , mandaba pings al router pero no aparecia ni cargaba nada. Busque y vi que en este hilo un problema igual se solucionó instalando otra compilación... sería la solución??? decidí esa compilación porque vi que tenía bastante cosa instalada (útiles como el transmission, el ftp, etc etc etc) pero no es la última que aparece al principio, hay una superior. Instale esa aunque aun tengo que ver que tal tira el router.

s2¡

EDIT: acabo de ver el problema: la configuración del router no se guarda al reiniciar  ???  probé casi todos los firmwares que aparecen en portada y con ninguno se guarda nada, nada de nada.
« Última modificación: 06-12-2013, 01:08 (Viernes) por noentiendero »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1837 en: 06-12-2013, 10:07 (Viernes) »

EDIT: acabo de ver el problema: la configuración del router no se guarda al reiniciar  ???  probé casi todos los firmwares que aparecen en portada y con ninguno se guarda nada, nada de nada.

Este problema, lo tienes explicado en el hilo de las FAQ: https://foro.seguridadwireless.net/openwrt/%28faq%29-preguntas-mas-comunes-sobre-openwrt/

[...]Gracias por la ayuda gente! por cierto me recomendais algun tutorial para lo que quiero hacer, alfa 1mw en este router y del router a dos PC´s. De todas formas antes de hacer nada preguntare que casi me quedo sin router al hacer esto jejejej  ^-^ Saludos!

Si es la alfa con rtl8187 ... casi todos los comentarios que ha habido en el foro, es que con OpenWrt no se comporta nada bien  >:D

Altair64

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1838 en: 06-12-2013, 10:50 (Viernes) »
Citar
Citar
EDIT: acabo de ver el problema: la configuración del router no se guarda al reiniciar  ???  probé casi todos los firmwares que aparecen en portada y con ninguno se guarda nada, nada de nada.
Este problema, lo tienes explicado en el hilo de las FAQ: https://foro.seguridadwireless.net/openwrt/%28faq%29-preguntas-mas-comunes-sobre-openwrt/




Maldita sea mi existencia! Mira que busqué por google y no se me ocurrio mirar en la FAQ xDDDD que mal quedé >_<'
Luego lo pruebo cuando reinicie a Linux, gracias!


EDIT: efestivamente, se ha solucionado así. Gracias!
« Última modificación: 06-12-2013, 20:15 (Viernes) por noentiendero »

jaimeps4

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1839 en: 06-12-2013, 19:53 (Viernes) »
Si es la alfa con rtl8187 ... casi todos los comentarios que ha habido en el foro, es que con OpenWrt no se comporta nada bien  >:D


No si por lo que e provado se ve que falla bastante, pero que se le va a pedir por un router que te sale "gratis". De todas formas así un router tipo repetidor solo existe el R36 no y el black alpha no?? Estaria interesado en pillarme alguno con la funcion esa de AP por usb. Gracias por contestar!